Дистанционное обучение. Практикум по освоению MS Office. (Beta-версия для экспериментальных групп и ДОТ-курсов)

Лабораторная практика

ОСВОЕНИЕ ПАКЕТА
MICROSOFT OFFICE XP

"Один практический шаг
стоит дюжины теорий."
 Карл Маркс

Постановка задачи

В данном сборнике приведена серия упражнений для самостоятельного освоения популярных приложений семейства MS Office, выполняемых в произвольном порядке в течение семестра с оформлением результатов в создаваемых при этом информационных продуктах. Последние так или иначе (в том числе - по электронной почте) предъявляются в согласованные сроки для проверки и итоговой оценки преподавателю.

Прошедшим ранее полноценное обучение работе с MS Office достаточно ознакомиться с упражнениями и оценить свою способность справиться с поставленными задачами, а также просмотреть контрольные вопросы и попытаться на них ответить.

Для систематизации, проверки и закрепления знаний рекомендуются ответить на контрольные вопросы, относящиеся к соответствующим частям сборника и упражнениям. Надо понимать, что знание возможносей и харпатеристик приложений MS Office - залог профессионального успеха...

Контрльные вопросы

Телефон: (3843)74-88-06
Б.Г.Новокрещин
  • Введение
    Часть I . MICROSOFT OFFICE
  • Занятие 1. Начинаем работу
  • Занятие 2. Приложения Microsoft Office XP
  • Занятие 3 Взаимодействие с операционной системой
  • Занятие 4 Общие черты приложений Office
    Часть II. WORD
  • Занятие 5. Создание и разметка документа
  • Занятие 6. Оформление документа
  • Занятие 7. Таблицы и графики
  • Занятие 8. Дополнительные возможности Word
    Часть III. EXCEL
  • Занятие 9. Электронная таблица
  • Занятие 10. Формулы и функции
  • Занятие 11. Графики и диаграммы
  • Занятие 12. Подготовка листов Excel к печати
    Часть IV. POWERPOINT
  • Занятие 13. Структура презентации
  • Занятие 14. Оформление презентации
  • Занятие 15. Публикация презентации
    Часть V. ACCESS
  • Занятие 16. Базы данных
  • Занятие 17. Подбор требуемых данных
  • Занятие 18. Формы и отчеты
    Часть VI. OUTLOOK
  • Занятие 19. Организатор событий и задач
  • Занятие 20. Контакты
  • Занятие 21. Электронная почта
    Часть VII. FRONTPAGE
  • Занятие 22. Построение web-узла
  • Занятие 23. Редактор web-страниц
  • Занятие 24. Усовершенствование web-страниц


Дистанционное обучение. Практикум использования MS Office. Beta-версия для экспериментальных групп СибГИУ.

Содержательная постановка задачи

"Не продается вдохновенье,
Но можно рукопись продать."
 А.С.Пушкин

Практические занятия необходимы для проверки и закрепления знаний по изучаемому предмету, а также для получения других практически полезных результатов, включая ценные информационные продукты, свидетельствующих о достигнутой автором определеной квалификации. Формальным свидетельством этой квалификации являются публикации информационных продуктов в открытом информационном пространстве Internet с указанием в персональном портфолио достиижений этого факта. Лишь в этом случае практика получает свое логическое завершение и полновесную полезную отдачу...

Учебный процесс - не самоцель, а средство достижения более высоких результатов в обозримой перспективе. Но ничто не мешает получить такие результаты безотлагательно, в процессе обучения, не дожидаясь более подходящего случая. Деловой подход к обучению предполагает бережное и эффективное использование учебного времени и творческих сил, ориентацию на достаточно высокие цели и построение учебного процесса соответственно...

При выполнении цикла упражнений полезно продумать и определить состав и содержание создаваемых информационных продуктов, которыен должны обладать свойствами и характеристиками, заслуживающими внимания и достойными публикации в сетевых структурах планетарного масштавба. В простейшем случае это могут быть наглядные пособия для понимания специфики инструментальных средств с необходимыми их пояснениями. В более сложных случаях такие произведения наполняются особым смыслом и приобретают дополнительную ценность.

Качественные контрольно-демонстрационные примеры использования приложений MS Office можно разместить в специальной тематической группе социальной сети "ВКонтакте" среди подобных информационных продуктов для информационно-методической поддержки начинающих пользователей офисного пакета. Коллекция таких произведений может оказать им неоценимую пользу в реализации неочевидных потенциальных возможностей MS Office.

Ориентация на сверхвысокие практические результаты при выполнении учебных упражнений наполняет их новыми смыслами и порождает повышенные мотивации к постижению секретов мастерства, формируют деловое отношение к обучению и уверенность в своих силах, создает предпосылки для получения неординарных решений и получения других эффектов. Это требует, однако умений планировать подобные операции и определенных творческих способностей для выхода за рамки стереотипов и прописных истин, осознанных устремлений, терпения и воли...


ЧАСТЬ I

Знакомство с Microsoft Office

Microsoft Office XP — это пакет прикладных программ, позволяющих решать разнообразные задачи. Приложения Microsoft Office настолько тесно связаны между собой, что их совокупность можно рассматривать как единую программу. Освоив правила взаимодействия элементов Office друг с другом и с операционной системой Windows, вы получите уникальный инструмент, способный выполнять сложные комбинированные операции.

Занятие №1. Начинаем работу

ТЕМА ЗАНЯТИЯ

На первом занятии вы познакомитесь с азами работы приложений мощного комплекса офисных программ Microsoft Office XP и научитесь создавать и редактировать свои собственные документы. Ниже перечислены несколько несложных операций, описание которых вы найдете в упражнениях этого занятия:

  • запуск приложений Microsoft Office;

  • открытие документа;

  • ввод и форматирование текста;

  • оформление документа;

  • добавление рисунков;

  • сохранение выполненной работы;

  • печать документа.

Вы приступаете к изучению пакета программ, объединенных общим названием Microsoft Office XP. Это последняя версия широко известных офисных приложений компании Microsoft. На протяжении последующих занятий вы научитесь работать с каждым приложением пакета, узнаете об общих чертах этих программ, способах их взаимодействия друг с другом и с операционной системой Windows.

Первое занятие — подготовительное. На нем рассматриваются основные приемы работы с приложениями Office. Вы создадите несколько документов, научитесь сохранять их для последующего использования и печатать результаты работы на принтере.


Запуск приложений

Комплект Microsoft Office XP состоит из нескольких отдельных модулей. Эти программы в значительной степени взаимосвязаны, имеют схожие оформление и инструменты, но все же каждая из них является самостоятельным приложением. Компоненты Microsoft Office XP работают только под управлением операционных систем Windows 95/98 или Windows NT. Если вы до сих пор работаете с устаревшей версией Windows, но хотите воспользоваться всеми преимуществами современного варианта Microsoft Office, вам придется позаботиться об обновлении операционной системы.

Чтобы начать работу с Office XP, нужно включить компьютер и подождать, пока загрузится операционная система, то есть на экране появится рабочий стол со значками и Панелью задач, которая обычно размещается в нижней части экрана и представляет собой серую полоску с кнопкой Пуск (Start) слева. В дальнейшем предполагается, что на компьютере уже установлен комплект Microsoft Office XP в стандартной конфигурации.


Упражнение 1. Открываем программу Office

Давайте познакомимся с компонентами Microsoft Office, научимся открывать их и переключаться между их окнами.

  1. Переместите указатель мыши в левый нижний угол экрана.

  2. Щелкните на кнопке Пуск (Start) Панели задач операционной системы Windows.

  3. Переместите указатель на пункт Программы (Programs) Главного меню. В открывшемся подменю, показанном на рис. 1.1, вы увидите шесть значков приложений комплекта Microsoft Office XP. Кроме того, в самом Главном меню должны присутствовать .пункты Создать документ Office (New Office Document) и Открыть документ Office (Open Office Document).

  4. Переместите указатель на пункт Microsoft Word и щелкните на нем. Откроется окно приложения Microsoft Word.

  5. Снова щелкните на кнопке Пуск (Start) и выберите команду Создать документ Office (New Office Document).

Рис. 1.1. Главное меню со значками приложений Office ХР

  6. На вкладке Общие (General) открывшегося окна диалога дважды щелкните на значке Новая книга (Blank Workbook).

Примечание

Если вы не нашли указанных значков в меню Программы (Programs), поищите их во вложенных папках этого меню или на рабочем столе. Для обнаружения пропавших значков можно воспользоваться инструментом поиска системы Windows, введя в качестве имени файла строку «Microsoft*.*» и выбрав для поиска папку Мой компьютер (My Computer). Если обнаружить значки приложений все же не удалось, но вы точно знаете, что комплект Microsoft Office установлен на компьютере, найдите файлы winword.exe, excel, exe, frontpg.exe, msaccess.exe, outlook.exe и powerpnt.exe, являющиеся исполняемыми файлами приложений Office, и перетащите их из окна поиска или из Проводника на рабочий стол. После этого значки, появившиеся на рабочем столе, можно переименовать и перетащить в Главное меню или любую другую папку.

  7. Теперь открыты окна двух приложений — Microsoft Word и Microsoft Excel. На рис. 1.2 окно Excel показано на фоне окна Word. Если оба окна развернуты до полноэкранного режима, одновременно можно будет видеть только одно из них.

  8. Windows обеспечивает простое переключение между приложениями. Чтобы активизировать окно Word, нажмите клавиши Alt+Tab.

  9. Чтобы вновь увидеть окно Excel, нажмите клавиши Alt+Tab еще раз.

Рис. 1.2. Окно Excel на фоне окна Word

Любой файл Windows отождествляется с некоторым типом, который идентифицируется расширением имени файла. Расширение — это совокупность символов, расположенных в имени файла правее последней точки. Свой тип имеют и документы Microsoft Office. Так, документам Word назначается расширение DOC, шаблонам презентаций PowerPoint — расширение РОТ и т. д.

При установке программы Windows регистрирует связанные с ней типы файлов. В результате операционная система знает, с помощью какого приложения был создан тот или иной файл, и может сопоставить файлам определенного типа некоторые стандартные действия, выполняемые при активизации документа этого типа. Поэтому для запуска приложений Office с одновременным открытием нужного вам документа не обязательно отыскивать значки приложений в Главном меню Windows. Просто выполните одно из следующих действий:

  • дважды щелкните на значке документа, расположенном в окне папки или на рабочем столе;

  • если нужно открыть документ, с которым вы недадно работали, выберите его имя в подменю Документы (Documents) Главного меню.


Упражнение 2. Открываем существующий документ

Чтобы просмотреть или отредактировать документ Word или "внести новую запясь в базу данных Access, необходимо сначала открыть файл документа, содержащий необходимую информацию. Если файла нет на рабочем столе и вы не помните точное название папки, в котором он хранится, проще всего воспользоваться окном диалога открытия документов. Это окно одинаково для всех приложений Office, а его инструменты позволяют быстро отыскать нужный файл.. Давайте изучим способы поиска файла на примере документа Word.

  1. Щелчком на кнопке Документ1 - Microsoft Word (Document1 - Microsoft Word) Панели задач активизируйте окно Word

  2. Щелкните на пункте Файл (File) строки меню Word и выберите в раскрывшемся подменю пункт Открыть (Open). Появится окно диалога, показанное на рис. 1.3.

Рис. 1.3. Окно диалога открытия файла

Примечание

Окна открытия, создания, сохранения и вставки документов в Office ХР значительно переработаны. Теперь у пользователя есть широчайшие возможности поиска файлов, доступ к стандартным папкам и средства управления файлами, размещенные прямо в этих окнах, которые стандартизированы для всех приложений Office ХР.

  3. Щелкните на раскрывающемся списке Тип файлов (Files Of Types) и выберите пункт Документы Word (Word Documents). В результате главное поле окна будет содержать только значки документов Word. Если искомый файл имеет нестандартное расширение, выберите пункт Все файлы (All Files).

  4. Щелкните на раскрывающемся списке Папка (Look In) и укажите жесткий диск локального компьютера или сетевой диск, на котором находится искомый документ.

  5. Для раскрытия папки, вложенной в текущую, найдите ее значок в области списка файлов и дважды щелкните на нем.

  6. Для перехода в родительскую папку щелкните на кнопке Переход на один уровень вверх (Up One Level) панели инструментов.

  7. Чтобы найти документ в стандартной папке Windows, щелкните на одной из пяти кнопок левой панели окна диалога Открытие документа (Open). Они открывают доступ к следующим папкам и файлам:

  • History (Журнал) — ярлыки недавно открывавшихся файлов и папок;

  • Мои документы (My Documents) — папка, в которой по замыслу создателей Windows, должны храниться ваши рабочие документы;

  • Рабочий стол (Desktop) — значки рабочего стола Windows;

  • Избранное (Favorites) — документы и папки, помещенные в личную папку. Многие программы и сама Windows обеспечивают быстрый доступ к личной папке, в которой удобно хранить наиболее часто используемые файлы или их ярлыки;

  • Web-папки (Web Folders) — папки, размещенные в Интернете.

  8. Если вы не можете вспомнить точное имя файла, попробуйте воспользоваться другим режимом просмотра списка файлов. Щелкните на стрелке справа от значка Представления (Views) панели инструментов и выберите подходящий режим. Окно открытия файла предлагает следующие варианты вывода списка документов:

  • Крупные значки (Large Icons) — изображение всех файлов папки в виде крупных значков;

  • Мелкие значки (Small Icons) — изображение всех файлов папки в виде мелких значков;

  • Список (List) — простой список всех файлов папки (см. рис. 1.3);

  • Таблица (Details) — список с указанием размера, типа и времени последнего изменения файла;

  • Свойства (Properties) — отображение свойств выбранного файла, которые выводятся в окне справа от списка, как показано на рис. 1.4;

  • Просмотр (Preview) — предварительный просмотр содержимого выбранного файла в панели, расположенной справа от списка файлов.

  9. Чтобы упорядочить файлы по имени, расширению, размеру или дате в режимах Мелкие значки или Крупные значки, щелкните на них правой кнопкой мыши и выберите в контекстном меню команду Упорядочить значки, а затем укажите в подменю нужный вариант сортировки значков.

Примечание

Для упорядочения файлов по одному из признаков в режиме просмотра Таблица (Details) достаточно щелкнуть на заголовке столбца данного признака.

Если найти нужный файл не удается, щелкните на кнопке Сервис (Tools) панели инструментов и выберите пункт Найти (Find). Откроется окно диалога, в котором можно сконструировать чрезвычайно сложные условия поиска, приводящие к положительному результату даже в самых безнадежных ситуациях.

Рис. 1.4. Свойства документа

  11. Найдя документ, выделите его щелчком мыши или введите его имя в поле Имя файла (File Name).

  12. Щелкните на кнопке Открыть (Open). Содержимое файла появится в окне Word.

  13. Список кнопки Открыть (Open), показанный на рис. 1.5, позволяет выбирать режим открытия файла. Пункт Открыть для чтения (Open Read-Only) запрещает модификацию документа, а режим Открыть как копию (Open As Copy) создает в Word копию открываемого документа. Пункт Открыть и восстановить (Open and Restore) позволяет восстановить файл, который был утерян при внезапном сбое в работе компьютера.

Рис. 1.5. Варианты открытия файла

Примечание

Если нужно продолжить работу с недавно открывавшимся документом, раскройте меню Файл (File). В его нижней части перечислены имена тех файлов, которые обрабатывались последними. Чтобы открыть один из них, щелкните на его имени.

Вы, естественно, будете не только просматривать имеющиеся документы, но и создавать свои собственные. Новый документ автоматически создается в программах Word и Excel при их запуске. Если же потребовался еще один документ или нужно создать новый документ в другом приложении Office XP, щелкните на кнопке Создать (New Blank Document) панели инструментов Стандартная (Standard).


Текст

Текст является основой большинства документов. Приложения Office XP предлагают набор разнообразных инструментов ввода, редактирования и форматирования текста. Основные операции работы с текстом идентичны для всех программ комплекта Office XP.


Упражнение 3. Ввод текста

Чтобы наполнить только что созданный документ текстовым содержанием, выполните следующие шаги.

  1. Введите обращение Дорогой Илья Александрович, и нажмите клавишу Enter.

  2. Затем введите текст Мы рассмотрели ваше предложение, и оно заинтересовало нашу компанию. К сожалению, вы не указали возможные сроки поставки пробных образцов. Сообщите их как можно скорее.

Обратите внимание, что по достижении правого края страницы программа сама переносит строки и пользователю не нужно нажимать клавишу Enter в конце каждой строки.

  3. Дважды щелкните на слове указали, и программа выделит его. Введите слово сообщили. Новое слово заменит выделенное.

  4. Чтобы изменить точку в первой строке текста на восклицательный знак, щелкните правее точки. Текстовый курсор переместится в конец строки.

  5. Нажатием клавиши Backspace удалите точку, затем введите символ !.

Примечание

Клавиша Backspace удаляет символ слева от текстового курсора, а клавиша Delete стирает символ справа от курсора.

  6. Протащите указатель мыши по словам К сожалению, чтобы выделить их, и нажмите клавишу Delete или Backspace. Указанные слова будут удалены.

  7. Нажмите клавишу Shift и, не отпуская ее, нажмите стрелку вправо. Окажется выделенной буква в.

  8. Выберите команду Формат > Регистр (Format > Change Case), в открывшемся окне диалога выберите положение переключателя ВСЕ прописные (UPPERCASE), как показано на рис. 1.6.

  9. Щелкните на кнопке ОК. Буква в будет преобразована к верхнему регистру.

Рис. 1.6. Редактирование текста в Word


Упражнение 4. Форматирование текста

Для ввода простого текста, созданного в предыдущем упражнении, нет смысла пользоваться мощным текстовым процессором Word, вам вполне хватит возможностей программы Блокнот (Notepad). He забывайте, что вы работаете с одним из лучших офисных приложений. Попробуйте немного приукрасить текст.

  1. Для короткого письма шрифт в 10 пунктов кажется слишком мелким. Поэтому выберите команду Правка > Выделить все (Edit > Select All), чтобы выделить весь текст.

  2. Выполните команду Формат > Шрифт (Format > Font).

  3. В списке Размер (Size) открывшегося окна диалога выберите число 14 и щелкните на кнопке ОК.

  4. Щелкните левее первой строки текста. Окажется выделенной вся строка.

  5. Щелчком на кнопке Полужирный (Bold) панели инструментов Форматирование (Formatting) назначьте этой строке полужирное начертание.

Примечание

Если какая-то кнопка панели инструментов не помещается на экране, для доступа к ней щелкните на маленьком треугольнике на правом краю панели и найдите кнопку в раскрывшейся палитре инструментов.

  6. Щелчком на кнопке По центру (Center) той же панели инструментов отцентрируйте первую строку документа.

Рис. 1.7. Форматирование текста

  7. Тройным щелчком в тексте второго абзаца выделите весь этот абзац. Затем щелкните на кнопке По ширине (Justify) панели инструментов Форматирование (Formatting), чтобы растянуть этот абзац на всю ширину страницы, как показано на рис. 1.7.

Примечание

Чтобы узнать название кнопки панели инструментов, переместите на нее указатель мыши и задержите его на несколько секунд. Появится экранная подсказка с названием кнопки.


Добавление объектов

Windows имеет прекрасную возможность вставки объектов, созданных одними программами, в документы других программ. В приложениях Office XP эта технология используется в полной мере. Вы можете строить документы, одновременно содержащие таблицы Word, листы Excel, графики, рисунки и любые другие объекты, создаваемые модулями Office или другими приложениями Windows.

Кроме шести основных программ комплект Microsoft Office содержит несколько дополнительных модулей, которые обеспечивают рисование фигур, создание диаграмм и графиков, построение оргдиаграмм, размещение в документе рисунков, видеоклипов и звуков. Эти дополнительные возможности доступны во всех приложениях Office. Вы будете постепенно знакомиться с ними на протяжении всей книги. Не забывайте, что все они доступны в любом приложении Office. К примеру, методика создания оргдиаграмм описывается при изучении PowerPoint, но с помощью тех же приемов можно добавить оргдиаграмму в документ Word или в лист Excel.


Упражнение 5. Оформление документов

Давайте воспользуемся графическими возможностями Microsoft Office и добавим в верхнюю часть созданного письма красочное название компании, отделенное от текста цветной линией.

  1. Нажатием клавиш Ctrl+Home переместите курсор в начало документа.

  2. Шесть раз нажмите клавишу Enter, чтобы освободить место для будущего названия.

  3. Выберите команду Вставка > Рисунок > Объект WordArt (Insert > Picture > WordArt). Откроется окно диалога модуля WordArt, показанное на рис. 1.8.

  4. Выберите один из 30 стандартных вариантов оформления заголовков (к примеру, четвертый в третьем ряду).

  5. Щелкните на кнопке ОК.

  6. В окне диалога Изменение текста WordArt (Edit WordArt Text) введите текст Геркулес и щелкните на кнопке ОК.

  7. Перетащите появившуюся надпись, разместив ее над текстом письма. Щелкните в окне документа за пределами надписи, чтобы зафиксировать выполненные изменения.

Рис. 1.8. Окно диалога модуля WordArt

  8. Если в нижней части окна Word нет панели инструментов Рисование (Drawing), для ее вывода на экран щелкните на кнопке Рисование (Drawing) панели инструментов Стандартная (Standard).

  9. Щелкните на кнопке Линия (Line) панели инструментов Рисование (Drawing). Значок указателя примет форму перекрестия.

  10. Растяните мышью горизонтальную линию ниже надписи Геркулес.

  11. Щелкните на стрелке справа от кнопки Цвет линии (Line Color) панели инструментов Рисование (Drawing) и выберите в раскрывшейся палитре красный цвет.

  12. Щелкните на кнопке Тип линии (Line Style) и выберите сплошную линию толщиной 3 пункта. Окончательный вариант документа представлен на рис. 1.9.

Рис. 1.9. Документ Word с элементами оформления


Упражнение 6. Вставка документов Office

Приложения Microsoft Office не зря объединены в один пакет. Эти программы не просто имеют сходный интерфейс и записаны на один компакт-диск, они тесно интегрированы друг с другом. Давайте вставим электронную таблицу Excel в имеющийся документ Word.

  1. Нажмите клавиши Ctrl+End. Затем нажмите клавишу Enter, введите текст Мы планируем закупать ваши изделия в следующих количествах; и снова нажмите Enter.

  2. Щелкните на кнопке Добавить таблицу Excel (Insert Microsoft Excel Worksheet) панели инструментов Стандартная (Standard).

  3. В раскрывшейся палитре ячеек щелкните на четвертом квадрате второй строки, как показано на рис. 1.10.

Рис. 1.10. Добавление листа Excel в документ Word

  4. В документе Word появится небольшое окно с таблицей Excel, а меню и стандартные панели инструментов Word заменятся на меню и панели Excel.

  5. Введите число 2001 в первую ячейку листа и нажмите стрелку вправо, чтобы перейти к следующей ячейке.

Примечание

Возможно, инструмент внедрения объектов Excel не установлен на вашем компьютере. В Office XP встроена система автоматической установки недостающих модулей. Если нужный модуль отсутствует, a Office устанавливался с компакт-диска, в процессе внедрения объекта может потребоваться вставить компакт-диск Office XP в устройство чтения. Программа установки, сама добавит необходимые файлы, и Word выполнит внедрение листа Excel.

  6. С помощью клавиш со стрелками перемещайтесь по ячейкам листа Excel и вводите числа, показанные на рис. 1.11.

  7. Щелкните мышью в пределах документа вне листа Excel. Окно Excel превратится в обычную таблицу, и в Word вернутся исходные панели инструментов и меню.

Внедренный объект позволяет не просто ввести данные в таблицу Word с помощью приложения Excel. Внедрение объекта Excel дает возможность пользоваться всеми преимуществами электронных таблиц. Если дважды щелкнуть на таком объекте, появится окно листа Excel, панели инструментов и меню Excel. Вы сможете провести необходимые расчеты, а затем, щелкнув вне окна листа Excel, снова вернуться в документ Word. После этих действий документ будет содержать уже обновленную таблицу Excel.

Рис. 1.11. Лист Excel в документе Word


Упражнение 7. Вставка данных из других приложений

В документы Office можно внедрять не только листы Excel, но и практически любые объекты других приложений. Давайте добавим в левый нижний угол документа Word логотип компании. Для этого выполните следующие шаги.

  1. Нажатием клавиш Ctrl+End переместите курсор в конец документа. Затем нажмите клавишу Enter, чтобы добавить ниже таблицы Excel еще один абзац.

  2. Выберите команду Вставка > Рисунок > Из файла (Insert > Picture > From File). Открывшееся окно диалога Добавление рисунка (Insert Pictures) очень похоже на окно открытия документа, описанное в упражнении 2 этого занятия. Оно работает точно так же и отличается только названием и именем кнопки Вставить (Insert).

  3. Найдите любой графический файл, пользуясь приемами, которые были описаны выше в упражнении 2, и щелкните на кнопке Вставить (Insert).

  4. В Word вставляемый объект привязывается к определенному символу текста. В данном случае рисунок оказался связан с первым символом нового абзаца. Нтобы сместить его к правому краю, щелкните на кнопке По правому краю (Align Right) панели инструментов Форматирование (Formatting). Результат показан на рис. 1.12.

Рис. 1.12. Документ Word с таблицей Excel и рисунком


Сохранение и закрытие документа

Создав документ и наполнив его некоторым содержимым, полезно сразу записать его на жесткий диск. Это предотвратит потерю информации в случае сбоя в работе компьютера или отключения электропитания, которые, как правило, случаются чаще, чем вы того ожидаете. В процессе работы над документом возьмите за правило периодически сохранять его содержимое, чтобы не потерять внесенные изменения.

Примечание

Access и Outlook не требуют ручного сохранения данных, они автоматически обновляют информацию в соответствующих файлах при ее изменении. Тем не менее Access позволяет в любой момент вручную сохранить текущее состояние базы данных, что помогает избежать потери данных из-за сбоя компьютера.


Упражнение 8. Запись на диск нового документа

Новый, ни разу не сохранявшийся документ имеет временное название типа Документ # (Document #), где # — это порядковый номер в ряду документов, созданных в текущем сеансе программы. Для сохранения нового документа выполните следующие шаги.

  1. Выберите команду Файл > Сохранить (File > Save) или щелкните на кнопке Сохранить (Save) панели инструментов Стандартная (Standard). Откроется окно диалога Сохранение документа (Save As), показанное на рис. 1.13. Оно практически идентично описанному выше окну открытия документа и отличается лишь названием и кнопкой Сохранить (Save). Это окно одинаково во всех приложениях .Microsoft Office XP.

Рис. 1.13. Окно диалога сохранения документа

  2. С помощью операций, перечисленных в упражнении 2, откройте папку, в которой следует сохранить файл.

  3. Введите в поле Имя файла (File Name) имя будущего документа.

  4. В раскрывающемся списке Тип файла (Save As Type) выберите тип сохраняемого документа.

Примечание

Обычно тип документа изменять не требуется. Но если вы формируете шаблон, собираетесь сохранить документ в формате HTML или хотите в дальнейшем импортировать файл в другое приложение, воспользуйтесь списком Тип файла (Save As Type) и укажите нужный вариант. Например, для экспорта текста в стандартный формат DOS с корректным преобразованием кодировки русских букв следует выбрать пункт Текст MS-DOS с форматированием (MS-DOS Text With Line Breaks), а для последующего импорта документа в другой текстовый редактор обычно подходит вариант Текст в формате RTF (Rich Text Format).

  5. Щелкните на кнопке Сохранить (Save).


Упражнение 9. Обновление данных

Работая с документом, не забывайте периодически сохранять его, это убережет вас от неприятных потерь информации. Чтобы записать новую версию документа в том же самом файле, достаточно выбрать команду Файл > Сохранить (File > Save), щелкнуть на кнопке Сохранить (Save) панели инструментов Стандартная (Standard) или просто нажать клавиши Ctrl+S.

Примечание

Приложения Office по умолчанию периодически сохраняют все открытые документы в специальных временных файлах. Если произошел сбой компьютера, при следующем запуске приложения Office выполняется автоматическое восстановление данных из этих временных файлов.

Если у вас возникли сомнения в правильности очередной редакции документа, сохраните новую версию в другом файле с помощью следующих шагов.

  1. Выберите команду Файл > Сохранить как (File > Save As). Откроется окно диалога Сохранение документа (Save As), показанное ранее на рис. 1.13.

  2. В поле Имя файла (File Name) введите имя обновленной версии документа, отличное от исходного.

  3. Щелкните на кнопке Сохранить (Save).

Прежняя редакция документа останется на диске под старым именем, а модифицированный вариант запишется в новый файл. При дальнейшем редактировании документа будет изменяться содержимое этого нового файла.

Примечание

Чтобы случайно не испортить исходный файл, открывайте документ в режиме создания копии. Для этого в окне открытия файла щелкните на стрелке кнопки Открыть (Open) и выберите в раскрывшемся меню пункт Открыть как копию (Open As Copy). Появится новый документ, содержимое которого будет идентично данным открывавшегося файла.


Упражнение 10. Закрытие файла и приложения

  1. Чтобы закрыть файл, не закрывая приложения, выберите команду Файл > Закрыть (File > Close) либо щелкните на кнопке с косым крестом в правом верхнем углу окна документа (если окно документа развернуто до размеров окна приложения, это вторая сверху кнопка с косым крестом в правом верхнем углу окна приложения).

Рис. 1.14. Окно диалога, информирующее о наличии несохраненных данных

Программы Office внимательно отслеживают действия пользователя и стараются помочь избежать ошибок. Если вы попытаетесь закрыть модифицированный документ, не сохранив его, появится окно диалога, показанное на рис. 1.14, в котором программа напоминает о наличии несохраненных изменений и просит указать дальнейшее направление развития событий.

  2. В зависимости от ситуации щелкните на одной из трех кнопок:

  • Да (Yes) — сохраняет новый вариант документа и закрывает его;

  • Нет (No) — отменяет изменения, выполненные с момента последнего сохранения файла, и закрывает документ;

  • Отмена (Cancel) — отменяет закрытие документа.

  3. Для завершения работы с приложением выберите команду Файл > Выход (File > Exit) или щелкните на кнопке с косым крестом в правом верхнем углу окна приложения. В результате будут закрыты все открытые документы приложения, а затем и само приложение.

Примечание

Всегда записывайте резервные копии своих документов на отдельный носитель (гибкий диск, съемный жесткий диск или кассету стримера). Опытные пользователи рекомендуют иметь три периодически обновляемые полные резервные копии всех важных файлов на съемных носителях, которые должны храниться в разных помещениях! Копия данных на жестком диске соседнего компьютера локальной сети не спасет вас от потерь, если случится пожар или в сети появится вирус-разрушитель. В конце каждой недели обновляйте поочередно одну из трех копий, а вечером всегда записывайте выборочную копию тех файлов, которые изменялись в течение дня. Не пренебрегайте этим правилом. Когдаже-сткий диск вашего компьютера вдруг начнет скрежетать, как несмазанная телега, вы с облегчением вспомните о наличии свежей копии всех критически важных файлов. Автор не раз сталкивался с ситуациями, когда из-за одной царапины на гибком диске люди полностью теряли файлы, создававшиеся тяжким трудом в течение нескольких недель!


Печать документа

Часто целью работы с программами Office является создание твердой копии документа. Это могут быть напечатанный текст Word, отчет Access, таблица Excel, записки докладчика PowerPoint и другие материалы. Управление принтерами осуществляется операционной системой Windows, поэтому все локальные и сетевые принтеры, установленные на компьютере, доступны для приложений Office, a приемы печати документов из разных программ Office сходны между собой.


Упражнение 11. Печать на стандартный принтер

Вывод информации на принтер, особенно в случае многостраничных документов, связан с большими затратами времени и средств. Чтобы не портить бумагу попусту, многие приложения Office предлагают специальный режим отображения документов, который называется предварительным просмотром. В этом режиме на экране отображается точная копия страниц, которые будут выведены на принтер, что позволяет обнаружить и устранить ошибки размещения текста, не делая пробных отпечатков.

  1. Выбором команды Пуск > Программы > Microsoft Excel (Start > Programs> Microsoft Excel) запустите приложение Excel.

  2. Щелкните на кнопке Открыть (Open) панели инструментов Стандартная (Standard) и откройте файл, который нужно распечатать.

  3. Выберите команду Файл > Предварительный просмотр (File > Print Preview). Окно документа переключится в режим предварительного просмотра, показанный на рис. 1.15.

Рис. 1.15. Предварительный просмотр документа

  4. Щелкните в той точке страницы, которую хочется изучить внимательнее. Excel изменит увеличение и выведет на экран ту область, в которой был выполнен щелчок.

  5. Повторным щелчком в окне документа верните прежнее увеличение. Продолжая щелкать в разных точках, внимательно исследуйте всю страницу.

  6. Нажатием клавиши Page Down перейдите ко второй странице и изучите ее.

Нажимая клавишу Page Down для перехода к последующим страницам и увеличивая критические области, просмотрите весь документ. Для возврата к предыдущим страницам пользуйтесь клавишей Page Up.

  7. Щелчком на кнопке Закрыть (Close) панели инструментов вернитесь к обычному виду документа.

  8. Щелкните на кнопке Печать (Print) панели инструментов Стандартная (Standard). Все страницы активного документа будут распечатаны на принтере, выбираемом в Windows по умолчанию.


Упражнение 12. Настройка параметров печати

Иногда черновой экземпляр печатается на одном принтере, а чистовой — на другом, высококачественном принтере. Часть страниц может содержать цветные элементы, и их придется выводить на цветной принтер, обычно подключенный к одному из компьютеров локальной сети. Чтобы вывести определенные страницы на другой принтер, выполните следующие шаги.

  1. Выберите в программе Excel команду Файл > Печать (File > Print). Откроется окно диалога Печать (Print), показанное на рис. 1.16.

Рис. 1.16. Окно диалога параметров печати

  2. Чтобы напечатать только некоторые страницы, выберите положение пере ключателя Страницы (Pages).

  3. В счетчики с (From) и по (То) введите номера первой и последней страницы печатаемого диапазона.

  4. В поле Число копий (Number Of Copies) укажите необходимое число экземпляров.

  5. В раскрывающемся списке Имя (Name) выберите принтер.

  6. Чтобы настроить принтер, щелкните на кнопке Свойства (Properties) и укажите необходимые величины в окне диалога параметров принтера.

  7. Если в данный момент нужный принтер недоступен либо он находится в другом помещении, установите флажок Печать в файл (Print To File). Это позволит записать команды управления принтером в файл, который затем можно скопировать на гибкий диск и переслать в принтер на том компьютере, к которому подключено устройство нужной модели.


Контрольное упражнение

Вы изучили операции открытия, сохранения и печати документов на примере программ Word и Excel. Попробуйте самостоятельно повторить те же самые процедуры в других приложениях Office. Для самопроверки выполните следующие шаги и ответьте на поставленные вопросы.

Примечание

Ответы на вопросы контрольных упражнений собраны в приложении.

  1. Запустите Frontpage и Word.

  2. Создайте новый web-узел.

    • Как создать новый web-узел в программе Front Page?

  3. Откройте документ Word, созданный на этом занятии, и преобразуйте сплошную линию в пунктирную.

    • Что нужно сделать, чтобы превратить сплошную линию, нарисованную в документе Word, в пунктирную?

  4. Распечатайте на принтере новый вариант оформления страницы.

    • Как в Word распечатать на стандартном принтере текущую страницу?

  5. Сохраните полученный документ Word в виде web-страницы.

    • Как экспортировать документ Word в файл формата HTML ?

  6. Сохраните модифицированный вариант документа.

  7. Закройте открытые приложения.


Подведение итогов

На этом занятии вы познакомились с основными чертами приложений Microsoft Office, научились создавать и печатать простейшие документы, заботиться о сохранности выполненной работы. Вы узнали, как запускаются и закрываются приложения Office XP, познакомились с возможностями окон диалога открытия и сохранения файлов.

Следующее занятие посвящено описанию основных элементов интерфейса приложений Microsoft Office и окон документов. На нем вы также узнаете о назначении каждого приложения комплекта Microsoft Office XP.


Занятие №10

Формулы и функции

ТЕМА ЗАНЯТИЯ

С помощью формул и функций можно выполнять математическую и статистическую обработку данных листа Excel. На этом занятии вы научитесь:

  • вводить формулы;

  • пользоваться стандартными функциями;

  • ссылаться на диапазон ячеек;

  • выполнять сложные вычисления;

  • копировать формулы;

  • исправлять ошибки в формулах.

Вам, наверное, не раз приходилось подсчитывать сумму или среднее значение столбцов или строк таблиц. Excel может выполнять с данными ячеек листа те же вычисления, которые выполняются с помощью калькулятора. Формулы и функции Ехсе1 способны обрабатывать величины как конкретных ячеек таблицы, так и целых блоков (например, строк или столбцов). Формулы Excel могут быть очень сложны, а результат их вычислений, в свою очередь, можно использовать в других расчетах. Неоспоримым преимуществом электронной таблицы является то, что при изменении данных листа результаты вычислений моментально обновляются.

Вычисления в Excel

Все вычисления в Excel выполняются с помощью формул, которые можно вводить в любые ячейки листа. Если содержимое ячейки начинается со знака равенства (=), Excel полагает, что вслед за этим знаком идет формула, и пытается выполнить указанную операцию. Когда это удается, в ячейку с такой формулой выводится результат расчета. Если что-то не так, появляется сообщение об ошибке. Сама формула отображается в ячейке только в том случае, когда ячейка находится в режиме редактирования текста (то есть после двойного щелчка на ней). Если ячейка просто выделена, то ее формула выводится в строке формулы в верхней части окна Excel.

Упражнение 1. Ввод формул

Самым простым способом задания формулы является ее непосредственный ввод в строку формул. У этого варианта есть лишь один недостаток — вы должны помнить правила построения формул Excel, названия встроенных функций и методы ссылок на ячейки листа.

  1. Откройте фaйл Электронная таблица.xls, созданный на предыдущем занятии. В этой рабочей книге есть лист Формулы, измененный в контрольном упражнении предыдущего занятия. Раскройте его. Первые семь строк листа должны выглядеть так, как показано па рис. 10.1, остальные ячейки будут пусты. Если это не соответствует действительности, отредактируйте лист.

  2. Щелкните на ячейке В10 и введите формулу =(СЗ-ВЗ)/ВЗ*100.

Знак равенства указывает программе Excel, что ячейка содержит формулу. СЗ и ВЗ — это ссылки на содержимое соответствующих ячеек. Если предположить, что таблица содержит объем продаж продукции различным клиентам, то (СЗ-ВЗ) — это прирост продаж для фирмы Фантом с января по февраль. Разделив полученную величину на ВЗ (продажи за январь), получаем относительный прирост продаж за месяц. Результат умножается на 100, что дает прирост в процентах. Как видите, в ячейки можно вводить простые, арифметические выражения со знаками +, -, *, / и скобками, определяющими последовательность выполнения операций.

В упражнении 2 предыдущего занятия вы изучили прием автозаполнения ячеек последовательными названиями месяцев и числами. Давайте воспользуемся тем же приемом для добавления однотипных формул.

Рис. 10.1. Ввод формулы

  3. Щелкните на ячейке В10 и перетащите угловой маркер выделения вправо, чтобы оказались охваченными ячейки с В10 по F10.

Примечание

Чтобы результат выводился в процентах, не обязательно умножать его на 100, достаточно сменить формат данных, выделив ячейку и щелкнув на кнопке Процентный формат панели инструментов Форматирование.

На первый взгляд кажется, что в ячейки C10:F10 должна дублироваться формула ячейки В 10, но это не так. Excel поддерживает механизм относительных ссылок на ячейки. Когда формула переносится на одну клетку вправо, точно так же смещаются все ссылки этой формулы (это верно и для смещения формулы в любых других направлениях на любое число клеток). То есть в ячейке С11 появится формула =(D3-C3)/C3*100, в ячейке D10 - формула =(E3-D3)/D3*100 и т. д. Чтобы проверить это, щелкните на каждой ячейке и изучите содержимое строки фор-•мул. В итоге ячейки строки 10 будут содержать относительный прирост продаж компании Фантом по месяцам.

  4. Выделите строки с третьей по седьмую.

  5. Щелчком на кнопке Вырезать (Cut) панели инструментов Стандартная (Standard) вырежьте их содержимое.

  6. Щелкните на ячейке А2 правой кнопкой мыши и выберите в контекстном меню команду Вставить. Данные таблицы переместятся вверх на одну строку. Теперь снова изучите формулы ячеек строки 10.

При смещении ячеек с данными с помощью операций вырезания и вставки ссылки на эти ячейки в имеющихся формулах модифицируются так, что в обновленной таблице в расчетах принимают участие те ячейки, в которые были перемещены исходные данные.

Примечание

Если необходимо, чтобы знак равенства в начале текста ячейки не воспринимался как индикатор формулы, а интерпретировался как символ, поставьте перед ним одинарную кавычку (').

Упражнение 2. функции

Excel поддерживает множество стандартных математических функций, которые можно вставлять в формулы. С тремя из них — СУММ (SUM), СРЗНАЧ (AVERAGE) и СЧЕТ (COUNT) — вы познакомились на предыдущем занятии. Чтобы научиться работать с другими функциями, выполните следующие шаги.

  1. Щелкните на ячейке Н8 и введите текст Максимум. Нажмите клавишу Tab.

  2. Щелкните на кнопке Вставка функции (Paste Function) панели инструментов Стандартная. Откроется окно диалога, показанное на рис. 10.2. Чтобы найти нужную функцию, можно кратко описать желаемую процедуру в текстовом поле Поиск функции (Search for a function) или же выбрать ее категорию в списке категорию: (Select a Category) этого окна диалога, а затем пролистать список Выберите функцию (Select a Function Name). Выделив имя одной из функций, вы увидите ее описание в нижней части окна диалога. Excel делит все функции на следующие категории:

    • Финансовые (Financial) — функции для расчета амортизации имущества, стоимости основных фондов, нормы прибыли, величины выплат на основной капитал и других финансовых показателей;
    • Дата и время (Date & Time) — операции прямого и обратного преобразования даты и времени в текстовые строки. Функции этой группы перечислены в табл. 10.1;

Рис. 10.2. Вставка функции

ТАБЛИЦА 10.1. Функции обработки даты и времени
Функция | Описание
ДАТА(DATE) | Возвращает дату в формате Excel
ДАТАЗНАЧ(DATEVALUE) | Преобразует дату из текстового формата в код Excel
ДЕНЬ(DAY) | День месяца заданной даты
ДНЕЙ360 (DAYS360) | Вычисляет количество дней между двумя датами на основе З60-дневного года
ЧАС (HOUR) | Час времени, заданного аргументом
.МИНУТЫ (MINUTE) | Минута времени, заданного аргументом
МЕСЯЦ (MONTH) | Номер месяца заданной даты
J-ДАТА (NOW) | Текущая дата и время в числовом формате
СЕКУНДЫ (SECOND) | Секунда времени, заданного аргументом
ВРЕМЯ (TIME) | Преобразует время дня в дробное число от 0 до 1
ВРЕМЗНАЧ (TIMEVALUE) | Преобразует время из текстового формата в дату в числовом формате
ДЕНЬ (TODAY) | Текущая дата в числовом формате
ДЕНЬНЕД (WEEKDAY) | Номер дня недели заданной даты
ГОД(YEAR) | Год заданной даты

    • Математические (Math & Trig) — математические и тригонометрические функции, некоторые из них приведены в табл. 10.2;

ТАБЛИЦА 10.2. Математические и тригонометрические функции
Функция | Описание
COS, SIN, TAN, | Тригонометрические функции
ACOS, ASIN, ATAN, ATAN2 | Обратные тригонометрические функции
COSH, SINH, TANH | Гиперболические функции
ACOSH, ASINH, ATANH | Обратные гиперболические функции
LN, LOG, LOG10 | Натуральный логарифм, логарифмы по основанию 2 и 10
EXP | Экспонента
НЕЧЕТ (EVEN), OKPyiTI(ROUND), ОКРУГЛВВЕРХ (ROUNDUP), ОКРУГЛВНИЗ (ROUNDDOWN), 4ETH(ODD) | Функции округления
ABS | Модуль (абсолютное значение)'числа
ГРАДУСЫ (DEGREES), | Преобразование радиан в градусы
РАДИАНЫ (RADIANS) | Преобразование градусов в радианы

ЦЕЛОЕ (INT) | Целая часть числа
ОСТАТ (MOD) | Остаток от деления
ПИ(Р1) | Число пи
СТЕПЕНЬ (POWER) | Возведение в степень
ПРОИЗВЕЛ (PRODUCT) | Произведение ряда чисел
СЛЧИС (RAND) | Возвращает случайное число
РИМСКОЕ (ROMAN) | Преобразование арабского числа в римское
КОРЕНЬ (SQRT) | Квадратный корень
СУММ (SUM) | Сумма ряда чисел
СУММ КВ (SUMSQ) | Сумма квадратов ряда чисел
ОТБР (TRUNC) | Отбрасывает дробную часть

ТАБЛИЦА 10.3. Статистические функции
Функция | Описание
СРОТКЛ(AVEDEV) | Среднее абсолютное значение отклонения от среднего
СРЗНАЧ (AVERAGE), СРЗНАЧА(AVERAGEA) | Среднее арифметическое аргументов
СЧЕТ (COUNT), СЧЕТЗ (COUNTA), СЧИТАТЬ ПУСТОТЫ (COUNT-BLANK), СЧЕТЕСЛИ (COUNTIF) | Количество чисел в списке аргументов
КБЛДРОТКЛ (DEVSQ.) | Сумма квадратов отклонении от среднего но выборке
CFFEOM (GEOMEAN) | Среднее геометрическое набора положительных чисел
МАКС (МАХ), МАКСА (МАХА) | Максимальное значение списка аргументов
МИН (M1N), МИНА (MINA) | Минимальное значение списка аргументов
ДИСП (STDEV), ДИСПА (STDEVA), | Функции расчета дисперсии
ДИСПР (STDEVP), ДИСПРА (STDEVPA) СТАНДОТ-КЛОН (VAR), СТАНДОТКЛОНА (VARA), СТАНДОТКЛОНП (VARP), СТАНДОТКЛОНПА (VARPA) | Стандартное отклонение по выборке

    • Статистические (Statistical) — функции для расчета среднего значения, дисперсии, статистических распределений и других вероятностных характеристик. Некоторые статистические функции перечислены в табл. 10.3;
    • Ссылки и массивы (Lookup & Reference) — операции преобразования ссылки на ячейку в число, расчета ссылок на основе числовых аргументов, вычисления числа строк и столбцов диапазона и других параметров, связанных с адресацией ячеек листа Excel;
    • Работа с базой данных (Database) — функции формирования выборки из базы данных и расчета статистических параметров величин, расположенных в базе данных;
    • Текстовые (Text) — функции для работы с текстовыми строками. Часть этих функций перечислена в табл.-10.4.

ТАБЛИЦА 10.4. Текстовые функции
Функция | Описание
СИМВОЛ (CHAR) | Возвращает символ с заданным кодом
ПЕЧСЙМВ (CLEAN) | Удаляет из строки все непечатаемые символы
КОДСИМВ (CODE) | Код первого символа строки
СЦЕПИТЬ(CONCATENATE) | Объединяет две текстовые строки
СОВПАД (EXACT) | Проверяет идентичность двух строк
ЛЕВСИМВ (LEFT) | Возвращает несколько левых символов строки
ДЛСТР (LEN) | Количество символов в строке
СТРОЧН (LOWER) | Делает все буквы текста строчными
ПРОПНАЧ(PROPER) | Делает первую букву прописной, а остальные — строчными
ПОВТОР(REPT) | Повторяет текст заданное число раз
ПРАВСИМВ (RIGHT) | Возвращает несколько Правых символов и роки
Т, ТЕКСТ(TEXT), ФИКСИРОВАННЫЙ (FIXED) | Преобразует число в текст
СЖПРОБЕЛЫ (TRIM) | Удаляет лишние (двойные) пробелы
ПРОПИСН (UPPER) | Делает все буквы прописными
ЗНАЧЕН (VALUE) | Преобразует текстовый аргумент в число

    • Логические (Logical) — шесть функций для работы с данными логического типа, то есть величинами или условиями, принимающими значение Истина или Ложь. Эти функции перечислены в табл. 10.5;
    • Проверка свойств и значений (Information) — функции проверки типа данных аргумента, режима форматирования ячейки, типа сгенерированной ошибки и других специальных условий.

ТАБЛИЦА 10.5. Логические функции
Функция | Описание
И (AND) | Логическое умножение
ЛОЖЬ (FALSE) | Возвращает ложное значение
ЕСЛИ (IF) | Возвращает одно значение, если условие истинно, и другое, если условие ложно
НЕ (NOT) | Логическое отрицание
ИЛИ (OR) | Логическое сложение
ИСТИНА (TRUE) | Возвращает истинное значение

В списке Категория (Function Category) есть также пункты Рекомендуемый перечень (Recommended), Полный алфавитный перечень (All) и 10 недавно использовавшихся (Most Recently Used), которые выводят соответственно список всех функций и 10 функций, применявшихся последними.

  3. Выберите в списке Категория окна диалога вставки функций (см. рис. 10.2) пункт Статистические.

  4. Выберите в списке Функция (Function Name) пункт МАКС.

  5. Щелкните на кнопке ОК. Откроется окно ввода диапазона ячеек, показанное на рис. 10.3.

Рис. 10.3. Окно ввода аргументов

Некоторые функции, например SIN, имеют только один аргумент, поскольку нельзя вычислить синус сразу двух чисел. Однако многие функции, подобные МАКС, способны обрабатывать практически неограниченные массивы данных. Такие функции могут воспринимать до 30 аргументов, каждый из которых является числом или ссылкой на одну или несколько ячеек.

Примечание

В качестве аргументов могут выступать также арифметические выражения и другие функции, возвращающие значения нужного типа.

С помощью функции МАКС вы сейчас найдете максимальный уровень продаж за один месяц для компаний Фантом, РИФ и Викинг.

Рис. 10.4. Выбор ячеек для первого аргумента

  6. Щелкните на кнопке в правой части поля Число 1 (Number 1). Окно диалога свернется в строку, открывая доступ к ячейкам листа.

  7. Выделите все числовые ячейки строки Фантом. Обозначение соответствующего диапазона ячеек появится в строке свернутого окна диалога ввода аргументов (рис. 10.4).

  8. Щелкните на кнопке строки аргумента. На экране снова развернется окно ввода аргументов.

  9. Щелкните на кнопке в правой части поля Число 2 (Number 2).

  10. Выделите ячейки B4:G4 и снова щелкните на кнопке строки ввода аргумента. Поскольку вы ввели уже два аргумента, Excel автоматически добавит поле ввода третьего.

  11. Введите в поле Ч и ел о 3 (Number 3), как показано на рис. 10.5, текст B6:G6. Это диапазон нужных ячеек строки Викинг. В окне диалога правее полей с аргументами демонстрируются их реальные значения. Ниже списка чисел отображается результат вычислений.

Рис. 10.5. Три диапазона ячеек в качестве аргументов функции МАХ

  12. Щелкните на кнопке ОК. В ячейке 18 появится максимальное число из диапазона, записанного в строках 2,4 и 6. Сама формула появится в строке формул в верхней части окна Excel. Щелкните в этой строке. Три аргумента функции МАКС, задающие три диапазона ячеек, будут выделены разными цветами, а соответствующие группы ячеек листа Excel окажутся обведенными рамками соответствующих цветов, как показано на рис. 10.6.

Рис. 10.6. Группы ячеек, выступающие в качестве аргументов формулы

Примечание

Если вы хорошо знакомы с синтаксисом функций и формул Excel, то можете просто вводить формулы в ячейки, как это делалось на предыдущем занятии, не пользуясь окнами диалога выбора функции и ввода аргументов.

Упражнение 3. Диапазон ячеек

Для ссылки на данные ячеек листа в Excel используются имена клеток, состоящие из буквы столбца (или двух букв, если столбцов больше 26) и номера строки. Так как многие функции могут воспринимать в качестве аргументов целые массивы данных, нужно выучить правила ссылок на такие массивы.

  1. Щелкните на ячейке Н9 и введите текст Сумма. Затем нажмите клавишу Tab.

  2. Введите символы =СУММ () (=SUM ()). Эта формула вычисляет сумму всех величин, указанных в скобках в качестве аргумента.

  3. Щелкните в строке формул и поместите курсор между двумя скобками.

  4. Введите в скобки текст В: В.

  5. Щелкните на кнопке Ввод слева от строки формул. В ячейке 19 появится сумма всех ячеек столбца В, так как символы В:В обозначают все ячейки столбца В.

  6. Снова щелкните в строке формул. В таблице окажется выделенной та группа ячеек, которые описываются аргументом В: В, как показано на рис. 10.7.

  7. Повторите шаги с 3-го по 6-й, поочередно вводя в скобки формул значения из первого столбца табл. 10.6. Изучите, какие диапазоны ячеек соответствуют указанным условным обозначениям. Немного потренировавшись, вы сможете указывать в качестве аргумента 4>ункции любые группы ячеек листа. , Если в разных формулах часто приходится ссылаться на одну и ту же группу ячеек, особенно если в группу входят разрозненные ячейки из разных областей листа, ей удобно присвоить специальное имя.

  8. Протаскиванием мыши выделите ячейки B3:G3.

  9. Нажмите клавишу Ctrl и протащите указатель мыши по ячейкам B5:G5.

Рис. 10.7. Столбец В в качестве аргумента функции

ТАБЛИЦА 10.6 .Способы ссылки на группы ячеек
Обозначение | Группа ячеек
F3 | Ячейка на пересечении столбца F и строки-3
Е10:Е20 | Ячейки с 10-й по 20-ю в столбце Е
В15:Е15 | Ячейки с В по Е в строке 15
5:5 | Все ячейки строки 5
5:10 | Все ячейки строк с 5-й по 10-ю
В:В | Все ячейки столбца В
B:J | Все ячейки столбцов c B no J
А10:Е20 | Прямоугольная область пересечения строк с 10-й по 20-ю и столбцов с А по Е

  10. Введите в поле Имя (Name Box) слово Строки, как показано на рис. 10.8.

  11. Нажмите клавишу Enter.

  12. Щелкните на ячейке 19, введите формулу =СУММ(Строки) (=SUМ(Строки)) и нажмите клавишу Enter. В ячейке 19 появится сумма двенадцати ячеек строк Зи5.

  13. Щелкните на стрелке раскрывающегося списка Имя (Name Box).

Рис. 10.8. Именованная группа ячеек

  14. Выберите пункт Строки. Окажутся выделенными ячейки диапазона Строки. Таблица может содержать несколько именованных диапазонов ячеек. Такие именованные диапазоны значительно упрощают формулы, делая их более наглядными.

Формулы

Формулы Excel чрезвычайно многогранны и заслуживают того, чтобы написать о них отдельную книгу. Чтобы лучше изучить формулы, пользуйтесь справочной системой Excel, дающей исчерпывающую информацию обо всех функциях и правилах построения формул.

Упражнение 4. Копирование формул

Иногда требуется провести одинаковые расчеты с разными группами ячеек. В такой ситуации можно сэкономить время и скопировать формулы, так как Excel поддерживает относительную адресацию ячеек. В строке 10 нашего примера уже есть формулы, рассчитывающие относительный прирост продаж по месяцам для клиента Фантом. Давайте скопируем их, чтобы получить таблицу прироста продаж для всех клиентов.

  1. Щелкните на любой непустой ячейке в строке 10. Вы увидите, что выбранная формула ссылается на ячейки строки 2.

  2. Выделите диапазон B10:F10.

  3. Нажатием клавиш Ctrl+C скопируйте ячейки.

  4. Щелкните на ячейке В11, а затем на кнопке Вставить панели инструментов Стандартная. Появится еще одна строка ячеек с формулами. Щелкните на любой из них и взгляните в строку формул. Вы увидите, что формулы новых ячеек ссылаются на данные строки 3, как показано на рис. 10.9.

  5. Щелкните на ячейке В 12 и нажмите клавиши Ctrl+V, чтобы вставить еще одну строку. Формулы этой строки уже будут ссылаться на данные строки 4. Таким образом, номера ячеек данных изменяются ровно на столько клеток, на сколько смещается вставляемая формула.

Рис. 10.9. Копирование формул

Примечание

Обратите внимание, что вырезание ячеек с формулами с последующей их вставкой в другое место листа никак не изменяет ссылки на данные.

  6. Вставьте тот же самый фрагмент в ячейки В13 и В14.

  7. Скопируйте заголовки строк из ячеек А2:А6 в ячейки А10:А14.

Примечание

Обычно Excel формирует относительные ссылки на ячейки. Но иногда нужно сослаться в формуле на клетку с константой, которая не должна меняться при копировании формулы в другую ячейку или при перемещении исходных данных. В этом случае пользуйтесь абсолютными ссылками, которые отличаются от относительных наличием символа $ перед буквой столбца, номером строки или перед обеими этими характеристиками, например $Е$15. В такой ссылке не изменяется та часть, перед которой стоит знак $. Например, копируя формулу =СУММ($В$2:$0$6) (=SUM($B$2:$G$6)) в другую ячейку, вы получите тот же самый результат, что и в исходной клетке формулы.

Операция суммирования строк или столбцов — одна из наиболее распространенных. Чтобы создать формулы сумм строк или столбцов, не нужно даже копировать ячейки, Excel предлагает еще более быстрый способ.

  8. Выделите группу ячеек 12:16.

  9. Щелкните на кнопке Автосумма (AutoSum) панели инструментов Стандартная.

  10. Осталось только ввести в ячейку II заголовок Итого, и столбец общей суммы продаж для всех пяти клиентов готов (рис. 10.10).

Примечание

Обратите внимание на значок вставки, появляющийся в правом нижнем углу вставленного фрагмента. Благодаря ему легко выбрать вариант вставки — хотите ли вы вставить число из копируемой ячейки или абсолютную либо относительную ссылки, нужно ли сохранять формат исходной ячейки и т. д.

Упражнение 5. Поиск ошибок

По мере изучения формул и функций Excel вы, конечно же, будете делать ошибки. Это может быть неверно заданный диапазон ячеек, неправильное имя функции или просто пропущенная скобка. Excel зафиксирует ошибку и в случае неверного типа аргумента, если, к примеру, в ячейке вместо ожидаемой числовой величины оказалась текстовая.

Рис. 10.10. Автосумма

  1. ЩелкнитенаячейкеШивведитеформулу СРЗНАЧ B11:F11 (AVERAGE B11:F11).

  2. Нажмите клавишу Enter. В ячейке появится сообщение #ИМЯ (#NAME), которое \ указывает на ошибку в имени функции. Слева от него находится маленький значок помощника, содержащий раскрывающийся список, в котором приводятся возможные способы устранения ошибки. . В табл. 10.7 приведен список сообщений об ошибках, которые можно встретить в ячейках при работе с формулами.

  3. Чтобы исправить формулу, двойным щелчком на ячейке 111 перейдите в режим редактирования формулы.

Примечание

Инструмент автокоррекции формул сам исправляет наиболее очевидные ошибки. Например, если в рассматриваемой формуле вы забудете ввести только закрывающую скобку, программа сама добавит ее.

ТАБЛИЦА 10.7. Сообщения об ошибках в формулах
Сообщение | Описание ошибки
##### | Ширина ячейки недостаточна для отображения результата вычисления или отрицательный результат вычислении в ячейке, отформатированной как данные типа даты или времени
#ЗНАЧ (#VALUE!) | Неверный тип аргумента или операнда. Например, указание в качестве аргумента ячейки с текстом, когда требуется число
#ДЕЛ/0(#01У/0!) | Деление на 0
#ИМЯ (#NAME!) | Excel не может распознать текст, введенный в формулу, например неверное имя функции
#Н/Д (#N/A) | Данные ячейки одного из аргументов формулы в данный момент недоступны
*#ССЫЛКА (#REF!) | Неверная ссылка на ячейку
#ЧИСЛО(#МиМ!) | Невозможно вычислить результат формулы, либо он слишком велик или мал для корректного отображения в ячейке
#ПУСТО (#NULL!) | Результат поиска пересечения двух непересекающихся областей, то есть неверная ссылка

  4. Измените содержимое ячейки так, чтобы получилась формула СРЗНАЧ (В 11:F11) (AVERAGE(B11:F11)).

Упражнение 6. Применение функций

До сих пор вы пользовались только функциями СУММ, СРЗНАЧ, СЧЕТ и МАКС. Давайте рассмотрим на примере некоторые функции из разряда текстовых и логических, а также функции работы с датой и временем. Результат всех вычислений, которые будут выполнены в этом упражнении.

  1. В листе Формулы выделите и скопируйте ячейки Bl:Gl.

  2. Разверните лист ЛистЗ (Sheet3).

  3. Щелкните правой кнопкой мыши на ячейке А1 и выберите в контекстном меню команду Вставить.

  4. Введите в ячейку A3 формулу =ЛЕВСИМВ(А1 ;3) (=LEFT(A1; 3)). Эта формула возвращает три левых символа ячейки А1.

  5. Перетащите угловой маркер выделения вправо, чтобы рамка охватила ячейки A3:F3. Теперь в третью строку выводятся сокращенные варианты названий месяцев из ячеек первой строки.

  6. Щелкните наячейкеНЗ и введите формулу =СЦЕПИТЬ(ВЗ ;D3) (CONCATENATE (ВЗ ; D3)). В ячейке НЗ появится объединение строк Фев и Апр.

  7. В ячейку А8 введите формулу =ТДАТА () (=NOW ()) и нажмите клавишу Enter. В ней тут же появятся текущие дата и время.

  8. Введите
     в ячейки с В8 по В13 формулы = ГОД (А8) (=YEAR(A8)), =МЕСЯЦ(А8) (=MONTH
     (А8)),=ДЕНЬ(А8)(=DAY(А8)),=ЧАС(А8)(=HOUR(A8)),=МИНУТЫ(А8) (=MINUTE(A8))
     и =СЕКУНДЫ(А8) (=SECOND (A8)). В этих ячейках появятся по отдельности все
     шесть компонентов текущих даты и времени.

  9. Дважды щелкните на ячейке А8, чтобы перевести ее в режим редактирования.

  10. Щелкните на кнопке Ввод, расположенной слева от строки формул. Эта операция приведет к обновлению значения в ячейке А8, что повлияет и на числа ячеек В8:В13.

Теперь давайте выполним логическую операцию.

  11. ВведитевячейкуА4формулу=ЕСЛИ(АЗ="Фев"; "Да"; "Нет") (=IF(АЗ="Фев"; " Да "; " Н е т ")). Эта операция сравнивает значение ячейки A3 с текстовой строкой Фев. В случае равенства выводится текст второго аргумента — Да. В случае неравенства выводится текст третьего аргумента — Нет. Так как в ячейке A3 присутствует текст Янв, то результатом этой операции будет значение Нет.

  12. Растяните маркер ячейки А4 вправо, чтобы рамка охватила диапазон A4:F4. Теперь формулы строки 4 проверяют ячейки строки 3 на совпадение их содержимого со строкой Фев. Как видите, слово Да появилось только в столбце В.

Знаки, которые используются в Excel для сравнения величин, перечислены в табл. 10.8. Обратите внимание, что текстовые строки, выступающие в качестве аргументов функций, должны заключаться в двойные кавычки.

Примечание

Текстовые строки равны, если попарно совпадают все их символы, в противном случае строки не равны. Одна текстовая строка больше другой, если в ней код первого символа, несовпадающего в обеих строках, больше кода того же символа во второй строке.

ТАБЛИЦА 10.8. Знаки сравнения
Знак | Значение
= | Равно
> | Больше
< | Меньше
>= | Больше или равно
<= | Меньше или равно
<> | Не равно

Контрольное упражнение

  1. В файле электронная таблица .xls раскройте лист Календарь, созданный в контрольном упражнении предыдущего занятия

  2. Щелкните в ячейке G3, введите формулу, вычисляющую среднее значение чисел строки 3 календаря, и нажмите клавишу Enter.

  3. В ячейку НЗ выведите целую часть этого среднего значения.

    • С помощью какой функции выделяется целая часть числа ?

  4. Продублируйте две полученные формулы во всех строках календаря.

    • Как продублировать формулы двух ячеек в нескольких строках?

  5. В ячейке Gil сосчитайте сумму средних значений, а в ячейке Н11 с помощью функции ПРОИЗВЕД произведение целых частей средних значений.

  6. В ячейке F11 с помощью функции СУМ М подсчитайте сумму всех ячеек третьей и четвертой строк листа Excel.

    • Как задать в качестве аргумента функции две строки листа ?

  7. Скопируйте содержимое ячейки F11.

  8. Щелкните на ячейке F13 и вставьте в нее формулу из буфера обмена.

    • Сумму каких ячеек подсчитывает вставленная формула?

Подведение итогов

С помощью упражнений этого занятия вы научились вводить формулы, пользоваться функциями, копировать формулы, находить и исправлять ошибки. Вы узнали о механизме относительной адресации ячеек и изучили некоторые функции, работающие с текстовыми строками и величинами типа даты и времени.

Чтобы наглядно представить результаты вычислений, их нужно оформить в виде диаграммы или графика. Именно этому способу отображения данных Excel и посвящено следующее занятие.


Занятие №10

Формулы и функции

ТЕМА ЗАНЯТИЯ

С помощью формул и функций можно выполнять математическую и статистическую обработку данных листа Excel. На этом занятии вы научитесь:

  • вводить формулы;

  • пользоваться стандартными функциями;

  • ссылаться на диапазон ячеек;

  • выполнять сложные вычисления;

  • копировать формулы;

  • исправлять ошибки в формулах.

Вам, наверное, не раз приходилось подсчитывать сумму или среднее значение столбцов или строк таблиц. Excel может выполнять с данными ячеек листа те же вычисления, которые выполняются с помощью калькулятора. Формулы и функции Ехсе1 способны обрабатывать величины как конкретных ячеек таблицы, так и целых блоков (например, строк или столбцов). Формулы Excel могут быть очень сложны, а результат их вычислений, в свою очередь, можно использовать в других расчетах. Неоспоримым преимуществом электронной таблицы является то, что при изменении данных листа результаты вычислений моментально обновляются.


Вычисления в Excel

Все вычисления в Excel выполняются с помощью формул, которые можно вводить в любые ячейки листа. Если содержимое ячейки начинается со знака равенства (=), Excel полагает, что вслед за этим знаком идет формула, и пытается выполнить указанную операцию. Когда это удается, в ячейку с такой формулой выводится результат расчета. Если что-то не так, появляется сообщение об ошибке. Сама формула отображается в ячейке только в том случае, когда ячейка находится в режиме редактирования текста (то есть после двойного щелчка на ней). Если ячейка просто выделена, то ее формула выводится в строке формулы в верхней части окна Excel.


Упражнение 1. Ввод формул

Самым простым способом задания формулы является ее непосредственный ввод в строку формул. У этого варианта есть лишь один недостаток — вы должны помнить правила построения формул Excel, названия встроенных функций и методы ссылок на ячейки листа.

  1. Откройте фaйл Электронная таблица.xls, созданный на предыдущем занятии. В этой рабочей книге есть лист Формулы, измененный в контрольном упражнении предыдущего занятия. Раскройте его. Первые семь строк листа должны выглядеть так, как показано па рис. 10.1, остальные ячейки будут пусты. Если это не соответствует действительности, отредактируйте лист.

  2. Щелкните на ячейке В10 и введите формулу =(СЗ-ВЗ)/ВЗ*100.

Знак равенства указывает программе Excel, что ячейка содержит формулу. СЗ и ВЗ — это ссылки на содержимое соответствующих ячеек. Если предположить, что таблица содержит объем продаж продукции различным клиентам, то (СЗ-ВЗ) — это прирост продаж для фирмы Фантом с января по февраль. Разделив полученную величину на ВЗ (продажи за январь), получаем относительный прирост продаж за месяц. Результат умножается на 100, что дает прирост в процентах. Как видите, в ячейки можно вводить простые, арифметические выражения со знаками +, -, *, / и скобками, определяющими последовательность выполнения операций.

В упражнении 2 предыдущего занятия вы изучили прием автозаполнения ячеек последовательными названиями месяцев и числами. Давайте воспользуемся тем же приемом для добавления однотипных формул.

Рис. 10.1. Ввод формулы

  3. Щелкните на ячейке В10 и перетащите угловой маркер выделения вправо, чтобы оказались охваченными ячейки с В10 по F10.

Примечание

Чтобы результат выводился в процентах, не обязательно умножать его на 100, достаточно сменить формат данных, выделив ячейку и щелкнув на кнопке Процентный формат панели инструментов Форматирование.

На первый взгляд кажется, что в ячейки C10:F10 должна дублироваться формула ячейки В 10, но это не так. Excel поддерживает механизм относительных ссылок на ячейки. Когда формула переносится на одну клетку вправо, точно так же смещаются все ссылки этой формулы (это верно и для смещения формулы в любых других направлениях на любое число клеток). То есть в ячейке С11 появится формула =(D3-C3)/C3*100, в ячейке D10 - формула =(E3-D3)/D3*100 и т. д. Чтобы проверить это, щелкните на каждой ячейке и изучите содержимое строки фор-•мул. В итоге ячейки строки 10 будут содержать относительный прирост продаж компании Фантом по месяцам.

  4. Выделите строки с третьей по седьмую.

  5. Щелчком на кнопке Вырезать (Cut) панели инструментов Стандартная (Standard) вырежьте их содержимое.

  6. Щелкните на ячейке А2 правой кнопкой мыши и выберите в контекстном меню команду Вставить. Данные таблицы переместятся вверх на одну строку. Теперь снова изучите формулы ячеек строки 10.

При смещении ячеек с данными с помощью операций вырезания и вставки ссылки на эти ячейки в имеющихся формулах модифицируются так, что в обновленной таблице в расчетах принимают участие те ячейки, в которые были перемещены исходные данные.

Примечание

Если необходимо, чтобы знак равенства в начале текста ячейки не воспринимался как индикатор формулы, а интерпретировался как символ, поставьте перед ним одинарную кавычку (').


Упражнение 2. функции

Excel поддерживает множество стандартных математических функций, которые можно вставлять в формулы. С тремя из них — СУММ (SUM), СРЗНАЧ (AVERAGE) и СЧЕТ (COUNT) — вы познакомились на предыдущем занятии. Чтобы научиться работать с другими функциями, выполните следующие шаги.

  1. Щелкните на ячейке Н8 и введите текст Максимум. Нажмите клавишу Tab.

  2. Щелкните на кнопке Вставка функции (Paste Function) панели инструментов Стандартная. Откроется окно диалога, показанное на рис. 10.2. Чтобы найти нужную функцию, можно кратко описать желаемую процедуру в текстовом поле Поиск функции (Search for a function) или же выбрать ее категорию в списке категорию: (Select a Category) этого окна диалога, а затем пролистать список Выберите функцию (Select a Function Name). Выделив имя одной из функций, вы увидите ее описание в нижней части окна диалога. Excel делит все функции на следующие категории:

    • Финансовые (Financial) — функции для расчета амортизации имущества, стоимости основных фондов, нормы прибыли, величины выплат на основной капитал и других финансовых показателей;
    • Дата и время (Date & Time) — операции прямого и обратного преобразования даты и времени в текстовые строки. Функции этой группы перечислены в табл. 10.1;

Рис. 10.2. Вставка функции

ТАБЛИЦА 10.1. Функции обработки даты и времени
Функция | Описание
ДАТА(DATE) | Возвращает дату в формате Excel
ДАТАЗНАЧ(DATEVALUE) | Преобразует дату из текстового формата в код Excel
ДЕНЬ(DAY) | День месяца заданной даты
ДНЕЙ360 (DAYS360) | Вычисляет количество дней между двумя датами на основе З60-дневного года
ЧАС (HOUR) | Час времени, заданного аргументом
.МИНУТЫ (MINUTE) | Минута времени, заданного аргументом
МЕСЯЦ (MONTH) | Номер месяца заданной даты
J-ДАТА (NOW) | Текущая дата и время в числовом формате
СЕКУНДЫ (SECOND) | Секунда времени, заданного аргументом
ВРЕМЯ (TIME) | Преобразует время дня в дробное число от 0 до 1
ВРЕМЗНАЧ (TIMEVALUE) | Преобразует время из текстового формата в дату в числовом формате
ДЕНЬ (TODAY) | Текущая дата в числовом формате
ДЕНЬНЕД (WEEKDAY) | Номер дня недели заданной даты
ГОД(YEAR) | Год заданной даты

    • Математические (Math & Trig) — математические и тригонометрические функции, некоторые из них приведены в табл. 10.2;

ТАБЛИЦА 10.2. Математические и тригонометрические функции
Функция | Описание
COS, SIN, TAN, | Тригонометрические функции
ACOS, ASIN, ATAN, ATAN2 | Обратные тригонометрические функции
COSH, SINH, TANH | Гиперболические функции
ACOSH, ASINH, ATANH | Обратные гиперболические функции
LN, LOG, LOG10 | Натуральный логарифм, логарифмы по основанию 2 и 10
EXP | Экспонента
НЕЧЕТ (EVEN), OKPyiTI(ROUND), ОКРУГЛВВЕРХ (ROUNDUP), ОКРУГЛВНИЗ (ROUNDDOWN), 4ETH(ODD) | Функции округления
ABS | Модуль (абсолютное значение)'числа
ГРАДУСЫ (DEGREES), | Преобразование радиан в градусы
РАДИАНЫ (RADIANS) | Преобразование градусов в радианы

ЦЕЛОЕ (INT) | Целая часть числа
ОСТАТ (MOD) | Остаток от деления
ПИ(Р1) | Число пи
СТЕПЕНЬ (POWER) | Возведение в степень
ПРОИЗВЕЛ (PRODUCT) | Произведение ряда чисел
СЛЧИС (RAND) | Возвращает случайное число
РИМСКОЕ (ROMAN) | Преобразование арабского числа в римское
КОРЕНЬ (SQRT) | Квадратный корень
СУММ (SUM) | Сумма ряда чисел
СУММ КВ (SUMSQ) | Сумма квадратов ряда чисел
ОТБР (TRUNC) | Отбрасывает дробную часть

ТАБЛИЦА 10.3. Статистические функции
Функция | Описание
СРОТКЛ(AVEDEV) | Среднее абсолютное значение отклонения от среднего
СРЗНАЧ (AVERAGE), СРЗНАЧА(AVERAGEA) | Среднее арифметическое аргументов
СЧЕТ (COUNT), СЧЕТЗ (COUNTA), СЧИТАТЬ ПУСТОТЫ (COUNT-BLANK), СЧЕТЕСЛИ (COUNTIF) | Количество чисел в списке аргументов
КБЛДРОТКЛ (DEVSQ.) | Сумма квадратов отклонении от среднего но выборке
CFFEOM (GEOMEAN) | Среднее геометрическое набора положительных чисел
МАКС (МАХ), МАКСА (МАХА) | Максимальное значение списка аргументов
МИН (M1N), МИНА (MINA) | Минимальное значение списка аргументов
ДИСП (STDEV), ДИСПА (STDEVA), | Функции расчета дисперсии
ДИСПР (STDEVP), ДИСПРА (STDEVPA) СТАНДОТ-КЛОН (VAR), СТАНДОТКЛОНА (VARA), СТАНДОТКЛОНП (VARP), СТАНДОТКЛОНПА (VARPA) | Стандартное отклонение по выборке

    • Статистические (Statistical) — функции для расчета среднего значения, дисперсии, статистических распределений и других вероятностных характеристик. Некоторые статистические функции перечислены в табл. 10.3;
    • Ссылки и массивы (Lookup & Reference) — операции преобразования ссылки на ячейку в число, расчета ссылок на основе числовых аргументов, вычисления числа строк и столбцов диапазона и других параметров, связанных с адресацией ячеек листа Excel;
    • Работа с базой данных (Database) — функции формирования выборки из базы данных и расчета статистических параметров величин, расположенных в базе данных;
    • Текстовые (Text) — функции для работы с текстовыми строками. Часть этих функций перечислена в табл.-10.4.

ТАБЛИЦА 10.4. Текстовые функции
Функция | Описание
СИМВОЛ (CHAR) | Возвращает символ с заданным кодом
ПЕЧСЙМВ (CLEAN) | Удаляет из строки все непечатаемые символы
КОДСИМВ (CODE) | Код первого символа строки
СЦЕПИТЬ(CONCATENATE) | Объединяет две текстовые строки
СОВПАД (EXACT) | Проверяет идентичность двух строк
ЛЕВСИМВ (LEFT) | Возвращает несколько левых символов строки
ДЛСТР (LEN) | Количество символов в строке
СТРОЧН (LOWER) | Делает все буквы текста строчными
ПРОПНАЧ(PROPER) | Делает первую букву прописной, а остальные — строчными
ПОВТОР(REPT) | Повторяет текст заданное число раз
ПРАВСИМВ (RIGHT) | Возвращает несколько Правых символов и роки
Т, ТЕКСТ(TEXT), ФИКСИРОВАННЫЙ (FIXED) | Преобразует число в текст
СЖПРОБЕЛЫ (TRIM) | Удаляет лишние (двойные) пробелы
ПРОПИСН (UPPER) | Делает все буквы прописными
ЗНАЧЕН (VALUE) | Преобразует текстовый аргумент в число

    • Логические (Logical) — шесть функций для работы с данными логического типа, то есть величинами или условиями, принимающими значение Истина или Ложь. Эти функции перечислены в табл. 10.5;
    • Проверка свойств и значений (Information) — функции проверки типа данных аргумента, режима форматирования ячейки, типа сгенерированной ошибки и других специальных условий.

ТАБЛИЦА 10.5. Логические функции
Функция | Описание
И (AND) | Логическое умножение
ЛОЖЬ (FALSE) | Возвращает ложное значение
ЕСЛИ (IF) | Возвращает одно значение, если условие истинно, и другое, если условие ложно
НЕ (NOT) | Логическое отрицание
ИЛИ (OR) | Логическое сложение
ИСТИНА (TRUE) | Возвращает истинное значение

В списке Категория (Function Category) есть также пункты Рекомендуемый перечень (Recommended), Полный алфавитный перечень (All) и 10 недавно использовавшихся (Most Recently Used), которые выводят соответственно список всех функций и 10 функций, применявшихся последними.

  3. Выберите в списке Категория окна диалога вставки функций (см. рис. 10.2) пункт Статистические.

  4. Выберите в списке Функция (Function Name) пункт МАКС.

  5. Щелкните на кнопке ОК. Откроется окно ввода диапазона ячеек, показанное на рис. 10.3.

Рис. 10.3. Окно ввода аргументов

Некоторые функции, например SIN, имеют только один аргумент, поскольку нельзя вычислить синус сразу двух чисел. Однако многие функции, подобные МАКС, способны обрабатывать практически неограниченные массивы данных. Такие функции могут воспринимать до 30 аргументов, каждый из которых является числом или ссылкой на одну или несколько ячеек.

Примечание

В качестве аргументов могут выступать также арифметические выражения и другие функции, возвращающие значения нужного типа.

С помощью функции МАКС вы сейчас найдете максимальный уровень продаж за один месяц для компаний Фантом, РИФ и Викинг.

Рис. 10.4. Выбор ячеек для первого аргумента

  6. Щелкните на кнопке в правой части поля Число 1 (Number 1). Окно диалога свернется в строку, открывая доступ к ячейкам листа.

  7. Выделите все числовые ячейки строки Фантом. Обозначение соответствующего диапазона ячеек появится в строке свернутого окна диалога ввода аргументов (рис. 10.4).

  8. Щелкните на кнопке строки аргумента. На экране снова развернется окно ввода аргументов.

  9. Щелкните на кнопке в правой части поля Число 2 (Number 2).

  10. Выделите ячейки B4:G4 и снова щелкните на кнопке строки ввода аргумента. Поскольку вы ввели уже два аргумента, Excel автоматически добавит поле ввода третьего.

  11. Введите в поле Ч и ел о 3 (Number 3), как показано на рис. 10.5, текст B6:G6. Это диапазон нужных ячеек строки Викинг. В окне диалога правее полей с аргументами демонстрируются их реальные значения. Ниже списка чисел отображается результат вычислений.

Рис. 10.5. Три диапазона ячеек в качестве аргументов функции МАХ

  12. Щелкните на кнопке ОК. В ячейке 18 появится максимальное число из диапазона, записанного в строках 2,4 и 6. Сама формула появится в строке формул в верхней части окна Excel. Щелкните в этой строке. Три аргумента функции МАКС, задающие три диапазона ячеек, будут выделены разными цветами, а соответствующие группы ячеек листа Excel окажутся обведенными рамками соответствующих цветов, как показано на рис. 10.6.

Рис. 10.6. Группы ячеек, выступающие в качестве аргументов формулы

Примечание

Если вы хорошо знакомы с синтаксисом функций и формул Excel, то можете просто вводить формулы в ячейки, как это делалось на предыдущем занятии, не пользуясь окнами диалога выбора функции и ввода аргументов.


Упражнение 3. Диапазон ячеек

Для ссылки на данные ячеек листа в Excel используются имена клеток, состоящие из буквы столбца (или двух букв, если столбцов больше 26) и номера строки. Так как многие функции могут воспринимать в качестве аргументов целые массивы данных, нужно выучить правила ссылок на такие массивы.

  1. Щелкните на ячейке Н9 и введите текст Сумма. Затем нажмите клавишу Tab.

  2. Введите символы =СУММ () (=SUM ()). Эта формула вычисляет сумму всех величин, указанных в скобках в качестве аргумента.

  3. Щелкните в строке формул и поместите курсор между двумя скобками.

  4. Введите в скобки текст В: В.

  5. Щелкните на кнопке Ввод слева от строки формул. В ячейке 19 появится сумма всех ячеек столбца В, так как символы В:В обозначают все ячейки столбца В.

  6. Снова щелкните в строке формул. В таблице окажется выделенной та группа ячеек, которые описываются аргументом В: В, как показано на рис. 10.7.

  7. Повторите шаги с 3-го по 6-й, поочередно вводя в скобки формул значения из первого столбца табл. 10.6. Изучите, какие диапазоны ячеек соответствуют указанным условным обозначениям. Немного потренировавшись, вы сможете указывать в качестве аргумента 4>ункции любые группы ячеек листа. , Если в разных формулах часто приходится ссылаться на одну и ту же группу ячеек, особенно если в группу входят разрозненные ячейки из разных областей листа, ей удобно присвоить специальное имя.

  8. Протаскиванием мыши выделите ячейки B3:G3.

  9. Нажмите клавишу Ctrl и протащите указатель мыши по ячейкам B5:G5.

Рис. 10.7. Столбец В в качестве аргумента функции

ТАБЛИЦА 10.6 .Способы ссылки на группы ячеек
Обозначение | Группа ячеек
F3 | Ячейка на пересечении столбца F и строки-3
Е10:Е20 | Ячейки с 10-й по 20-ю в столбце Е
В15:Е15 | Ячейки с В по Е в строке 15
5:5 | Все ячейки строки 5
5:10 | Все ячейки строк с 5-й по 10-ю
В:В | Все ячейки столбца В
B:J | Все ячейки столбцов c B no J
А10:Е20 | Прямоугольная область пересечения строк с 10-й по 20-ю и столбцов с А по Е

  10. Введите в поле Имя (Name Box) слово Строки, как показано на рис. 10.8.

  11. Нажмите клавишу Enter.

  12. Щелкните на ячейке 19, введите формулу =СУММ(Строки) (=SUМ(Строки)) и нажмите клавишу Enter. В ячейке 19 появится сумма двенадцати ячеек строк Зи5.

  13. Щелкните на стрелке раскрывающегося списка Имя (Name Box).

Рис. 10.8. Именованная группа ячеек

  14. Выберите пункт Строки. Окажутся выделенными ячейки диапазона Строки. Таблица может содержать несколько именованных диапазонов ячеек. Такие именованные диапазоны значительно упрощают формулы, делая их более наглядными.


Формулы

Формулы Excel чрезвычайно многогранны и заслуживают того, чтобы написать о них отдельную книгу. Чтобы лучше изучить формулы, пользуйтесь справочной системой Excel, дающей исчерпывающую информацию обо всех функциях и правилах построения формул.


Упражнение 4. Копирование формул

Иногда требуется провести одинаковые расчеты с разными группами ячеек. В такой ситуации можно сэкономить время и скопировать формулы, так как Excel поддерживает относительную адресацию ячеек. В строке 10 нашего примера уже есть формулы, рассчитывающие относительный прирост продаж по месяцам для клиента Фантом. Давайте скопируем их, чтобы получить таблицу прироста продаж для всех клиентов.

  1. Щелкните на любой непустой ячейке в строке 10. Вы увидите, что выбранная формула ссылается на ячейки строки 2.

  2. Выделите диапазон B10:F10.

  3. Нажатием клавиш Ctrl+C скопируйте ячейки.

  4. Щелкните на ячейке В11, а затем на кнопке Вставить панели инструментов Стандартная. Появится еще одна строка ячеек с формулами. Щелкните на любой из них и взгляните в строку формул. Вы увидите, что формулы новых ячеек ссылаются на данные строки 3, как показано на рис. 10.9.

  5. Щелкните на ячейке В 12 и нажмите клавиши Ctrl+V, чтобы вставить еще одну строку. Формулы этой строки уже будут ссылаться на данные строки 4. Таким образом, номера ячеек данных изменяются ровно на столько клеток, на сколько смещается вставляемая формула.

Рис. 10.9. Копирование формул

Примечание

Обратите внимание, что вырезание ячеек с формулами с последующей их вставкой в другое место листа никак не изменяет ссылки на данные.

  6. Вставьте тот же самый фрагмент в ячейки В13 и В14.

  7. Скопируйте заголовки строк из ячеек А2:А6 в ячейки А10:А14.

Примечание

Обычно Excel формирует относительные ссылки на ячейки. Но иногда нужно сослаться в формуле на клетку с константой, которая не должна меняться при копировании формулы в другую ячейку или при перемещении исходных данных. В этом случае пользуйтесь абсолютными ссылками, которые отличаются от относительных наличием символа $ перед буквой столбца, номером строки или перед обеими этими характеристиками, например $Е$15. В такой ссылке не изменяется та часть, перед которой стоит знак $. Например, копируя формулу =СУММ($В$2:$0$6) (=SUM($B$2:$G$6)) в другую ячейку, вы получите тот же самый результат, что и в исходной клетке формулы.

Операция суммирования строк или столбцов — одна из наиболее распространенных. Чтобы создать формулы сумм строк или столбцов, не нужно даже копировать ячейки, Excel предлагает еще более быстрый способ.

  8. Выделите группу ячеек 12:16.

  9. Щелкните на кнопке Автосумма (AutoSum) панели инструментов Стандартная.

  10. Осталось только ввести в ячейку II заголовок Итого, и столбец общей суммы продаж для всех пяти клиентов готов (рис. 10.10).

Примечание

Обратите внимание на значок вставки, появляющийся в правом нижнем углу вставленного фрагмента. Благодаря ему легко выбрать вариант вставки — хотите ли вы вставить число из копируемой ячейки или абсолютную либо относительную ссылки, нужно ли сохранять формат исходной ячейки и т. д.


Упражнение 5. Поиск ошибок

По мере изучения формул и функций Excel вы, конечно же, будете делать ошибки. Это может быть неверно заданный диапазон ячеек, неправильное имя функции или просто пропущенная скобка. Excel зафиксирует ошибку и в случае неверного типа аргумента, если, к примеру, в ячейке вместо ожидаемой числовой величины оказалась текстовая.

Рис. 10.10. Автосумма

  1. ЩелкнитенаячейкеШивведитеформулу СРЗНАЧ B11:F11 (AVERAGE B11:F11).

  2. Нажмите клавишу Enter. В ячейке появится сообщение #ИМЯ (#NAME), которое \ указывает на ошибку в имени функции. Слева от него находится маленький значок помощника, содержащий раскрывающийся список, в котором приводятся возможные способы устранения ошибки. . В табл. 10.7 приведен список сообщений об ошибках, которые можно встретить в ячейках при работе с формулами.

  3. Чтобы исправить формулу, двойным щелчком на ячейке 111 перейдите в режим редактирования формулы.

Примечание

Инструмент автокоррекции формул сам исправляет наиболее очевидные ошибки. Например, если в рассматриваемой формуле вы забудете ввести только закрывающую скобку, программа сама добавит ее.

ТАБЛИЦА 10.7. Сообщения об ошибках в формулах
Сообщение | Описание ошибки
##### | Ширина ячейки недостаточна для отображения результата вычисления или отрицательный результат вычислении в ячейке, отформатированной как данные типа даты или времени
#ЗНАЧ (#VALUE!) | Неверный тип аргумента или операнда. Например, указание в качестве аргумента ячейки с текстом, когда требуется число
#ДЕЛ/0(#01У/0!) | Деление на 0
#ИМЯ (#NAME!) | Excel не может распознать текст, введенный в формулу, например неверное имя функции
#Н/Д (#N/A) | Данные ячейки одного из аргументов формулы в данный момент недоступны
*#ССЫЛКА (#REF!) | Неверная ссылка на ячейку
#ЧИСЛО(#МиМ!) | Невозможно вычислить результат формулы, либо он слишком велик или мал для корректного отображения в ячейке
#ПУСТО (#NULL!) | Результат поиска пересечения двух непересекающихся областей, то есть неверная ссылка

  4. Измените содержимое ячейки так, чтобы получилась формула СРЗНАЧ (В 11:F11) (AVERAGE(B11:F11)).


Упражнение 6. Применение функций

До сих пор вы пользовались только функциями СУММ, СРЗНАЧ, СЧЕТ и МАКС. Давайте рассмотрим на примере некоторые функции из разряда текстовых и логических, а также функции работы с датой и временем. Результат всех вычислений, которые будут выполнены в этом упражнении.

  1. В листе Формулы выделите и скопируйте ячейки Bl:Gl.

  2. Разверните лист ЛистЗ (Sheet3).

  3. Щелкните правой кнопкой мыши на ячейке А1 и выберите в контекстном меню команду Вставить.

  4. Введите в ячейку A3 формулу =ЛЕВСИМВ(А1 ;3) (=LEFT(A1; 3)). Эта формула возвращает три левых символа ячейки А1.

  5. Перетащите угловой маркер выделения вправо, чтобы рамка охватила ячейки A3:F3. Теперь в третью строку выводятся сокращенные варианты названий месяцев из ячеек первой строки.

  6. Щелкните наячейкеНЗ и введите формулу =СЦЕПИТЬ(ВЗ ;D3) (CONCATENATE (ВЗ ; D3)). В ячейке НЗ появится объединение строк Фев и Апр.

  7. В ячейку А8 введите формулу =ТДАТА () (=NOW ()) и нажмите клавишу Enter. В ней тут же появятся текущие дата и время.

  8. Введите
     в ячейки с В8 по В13 формулы = ГОД (А8) (=YEAR(A8)), =МЕСЯЦ(А8) (=MONTH
     (А8)),=ДЕНЬ(А8)(=DAY(А8)),=ЧАС(А8)(=HOUR(A8)),=МИНУТЫ(А8) (=MINUTE(A8))
     и =СЕКУНДЫ(А8) (=SECOND (A8)). В этих ячейках появятся по отдельности все
     шесть компонентов текущих даты и времени.

  9. Дважды щелкните на ячейке А8, чтобы перевести ее в режим редактирования.

  10. Щелкните на кнопке Ввод, расположенной слева от строки формул. Эта операция приведет к обновлению значения в ячейке А8, что повлияет и на числа ячеек В8:В13.

Теперь давайте выполним логическую операцию.

  11. ВведитевячейкуА4формулу=ЕСЛИ(АЗ="Фев"; "Да"; "Нет") (=IF(АЗ="Фев"; " Да "; " Н е т ")). Эта операция сравнивает значение ячейки A3 с текстовой строкой Фев. В случае равенства выводится текст второго аргумента — Да. В случае неравенства выводится текст третьего аргумента — Нет. Так как в ячейке A3 присутствует текст Янв, то результатом этой операции будет значение Нет.

  12. Растяните маркер ячейки А4 вправо, чтобы рамка охватила диапазон A4:F4. Теперь формулы строки 4 проверяют ячейки строки 3 на совпадение их содержимого со строкой Фев. Как видите, слово Да появилось только в столбце В.

Знаки, которые используются в Excel для сравнения величин, перечислены в табл. 10.8. Обратите внимание, что текстовые строки, выступающие в качестве аргументов функций, должны заключаться в двойные кавычки.

Примечание

Текстовые строки равны, если попарно совпадают все их символы, в противном случае строки не равны. Одна текстовая строка больше другой, если в ней код первого символа, несовпадающего в обеих строках, больше кода того же символа во второй строке.

ТАБЛИЦА 10.8. Знаки сравнения
Знак | Значение
= | Равно
> | Больше
< | Меньше
>= | Больше или равно
<= | Меньше или равно
<> | Не равно


Контрольное упражнение

  1. В файле электронная таблица .xls раскройте лист Календарь, созданный в контрольном упражнении предыдущего занятия

  2. Щелкните в ячейке G3, введите формулу, вычисляющую среднее значение чисел строки 3 календаря, и нажмите клавишу Enter.

  3. В ячейку НЗ выведите целую часть этого среднего значения.

    • С помощью какой функции выделяется целая часть числа ?

  4. Продублируйте две полученные формулы во всех строках календаря.

    • Как продублировать формулы двух ячеек в нескольких строках?

  5. В ячейке Gil сосчитайте сумму средних значений, а в ячейке Н11 с помощью функции ПРОИЗВЕД произведение целых частей средних значений.

  6. В ячейке F11 с помощью функции СУМ М подсчитайте сумму всех ячеек третьей и четвертой строк листа Excel.

    • Как задать в качестве аргумента функции две строки листа ?

  7. Скопируйте содержимое ячейки F11.

  8. Щелкните на ячейке F13 и вставьте в нее формулу из буфера обмена.

    • Сумму каких ячеек подсчитывает вставленная формула?


Подведение итогов

С помощью упражнений этого занятия вы научились вводить формулы, пользоваться функциями, копировать формулы, находить и исправлять ошибки. Вы узнали о механизме относительной адресации ячеек и изучили некоторые функции, работающие с текстовыми строками и величинами типа даты и времени.

Чтобы наглядно представить результаты вычислений, их нужно оформить в виде диаграммы или графика. Именно этому способу отображения данных Excel и посвящено следующее занятие.


Занятие №11

Графики и диаграммы

ТЕМА ЗАНЯТИЯ

На этом занятии изучаются приемы построения диаграмм, иллюстрирующих данные листа Excel. Вы познакомитесь с некоторыми компонентами и операциями, которые перечислены ниже:

  • мастер диаграмм Excel;

  • выбор типа диаграммы;

  • подписи маркеров данных;

  • форматирование текста;

  • совмещение данных разных листов;

  • объемная диаграмма;

  • ряды данных.

Модуль диаграмм приложения Excel автоматически генерирует диаграммы, отображающие данные листа в графической форме. Вам остается только выбрать нужный диапазон ячеек и указать тип диаграммы, а затем оформить полученный графический объект по своему вкусу.

Диаграммы Excel во многом похожи на аналогичные объекты, создаваемые модулем Microsoft Graph XP, о котором рассказывалось на занятии 7. Graph поддерживает те же типы диаграмм, что и Excel. В обоих этих модулях используются одинаковые приемы форматирования. Однако модуль диаграмм Excel не имеет отдельной таблицы данных, так как исходная информация считывается прямо с листа Excel. Панели инструментов диаграмм в Excel и Graph немного отличаются. Кроме того, в диаграмму Excel можно одновременно вставлять данные с разных листов.

Добавление диаграммы

Давайте продолжим работать с файлом Электронная таблица.хls. Откройте его в Excel и разверните лист Клиенты. В упражнениях этого занятия будет добавлена и отформатирована диаграмма, представляющая данные этого листа в графической форме.

Упражнение 1. Мастер диаграмм Excel

Для создания диаграммы проще всего воспользоваться соответствующим мастером. Вы уже познакомились с ним на занятии 2. В этом упражнении подробно описываются все окна диалога мастера создания диаграмм.

Рис. 11.1. Выбор типа диаграммы

Рис. 11.2. Задание источника данных

  1. Чтобы указать мастеру диаграмм источник данных, выделите прямоугольную область ячеек A1:G7.

Примечание

Исходные числовые данные для диаграммы следует выделять вместе со строкой и столбцом заголовков таблицы, чтобы соответствующие названия автоматически появлялись в легенде и на оси категорий диаграммы.

  2. Выберите команду Вставка > Диаграмма (Insert > Chart). Откроется первое окно диалога мастера диаграмм, показанное на рис. 11.1, в котором нужно указать тип диаграммы, задающий ее оформление, и конфигурацию элементов, отображающих данные.

  3. В списке Тип (Chart Type) выберите пункт Линейчатая (Bar) или другую подходящую категорию.

  4. В разделе Вид (Chart Sub-type) щелкните на левом верхнем квадрате, задающем подтип Линейчатая диаграмма (Clustered Bar).

  5. Чтобы не выходя из окна мастера оценить будущий вид диаграммы, нажмите мышью кнопку Просмотр результата (Press And Hold To View Sample). В окне диалога вместо списка подтипов появится внешний вид будущей диаграммы. Отпустите кнопку мыши, и окно диалога вернется в прежнее состояние.

  6. Щелкяите на кнопке Далее (Next).

Второе окно диалога мастера, показанное на рис. 11.2, позволяет выбрать или скорректировать источник данных. Поскольку при запуске мастера в листе уже был выделен некоторый диапазон данных, он автоматически выбирается в качестве источника данных. Обратите внимание, что будущая диаграмма, общий вид которой отображается в окне диалога, содержит лишний ряд данных, появившийся из-за наличия в выделенной области пустой строки 2.

  7. Чтобы скорректировать источник данных, щелкните на кнопке, расположенной в правой части поля Диапазон (Data Range). Окно мастера свернется в одну строку, открыв доступ к листу Excel.

  8. Выделите ячейки Al:Gl.

  9. Нажмите клавишу Ctrl и, не отпуская ее, протащите мышь из ячейки A3 в ячейку G7. Эта операция добавит к выделению вторую группу ячеек, как показано на рис. 11.3.

Рис. 11.3. Скорректированный источник данных

  10. Щелкните на кнопке мастера диаграмм, чтобы вновь развернуть его окно диалога. Теперь в поле Диапазон появится формула =Клиенты!$А$1:$6$1; Клиенты! $А$3 :$G$7, которая с помощью абсолютных ссылок задает две области данных из листа Клиенты. Немного потренировавшись, можно научиться вручную вводить формулы источников данных любых конфигураций.

  11. 11. Переключатель Ряды в (Series In) позволяет группировать ряды данных по строкам или столбцам таблицы. Чтобы по вертикальной оси диаграммы выводились названия месяцев года, выберите положение строках (Rows) этого переключателя.

  12. Для перехода к окну диалога параметров диаграммы, показанному на рис. 11.4, щелкните на кнопке Далее.

Рис. 11.4. Настройка параметров диаграммы

Вкладка Ряд (Series) второго окна мастера диаграмм открывает доступ к инструментам, позволяющим гибко перестраивать источник данных, добавляя и удаляя ряды данных и задавая ячейки с заголовками строк и столбцов таблицы.

  13. Введите в поле Название диаграммы (Chart Title) текст Активность клиентов.

  14. В поля Ось Х (категорий) (Category (X) Axis) и Ось Y (значений) (Value (Y) Axis) введите названия осей (см. рис. 11.4).

  15. При необходимости с помощью других вкладок этого окна диалога настройте оси, линии сетки, легенду, подписи данных и режим отображения таблицы данных. Затем щелкните на кнопке Далее, чтобы перейти к четвертому окну мастера (рис. 11.5), определяющему местоположение будущей диаграммы.

  16. Чтобы поместить диаграмму на отдельный лист, выберите положение переключателя в отдельном (As New Sheet).

Рис. 11.5. Выбор расположения диаграммы

Рис. 11.6. Готовая диаграмма на отдельном листе

  17. В текстовое поле имени нового листа введите название Диаграмма.

  18. Щелкните на кнопке Готово (Finish). Результат показан на рис. 11.6.

Примечание

При размещении диаграммы на отдельном листе программа задает ей размер, равный площади окна документа Excel. Если при изменении , размеров окна масштаб диаграммы не меняется, выберите команду Сервис > Параметры и установите флажок Масштабировать диаграмму по размеру окна (Chart Sizes With Window Frame). В противном случае размеры диаграммы будут сохраняться неизменными (если считать в пикселах экрана компьютера).

Упражнение 2. Выбор типа диаграммы

Для лучшего отражения той или иной природы данных следует подобрать соответствующий тип диаграммы. Его, так же как и любые другие параметры, заданные при работе с мастером диаграмм, всегда можно сменить позже в процессе форматирования документа.

  1. Чтобы выбрать другой тип диаграммы, выполните команду Диаграмма > Тип диаграммы (Chart > Chart Type). Откроется окно диалога, похожее на первое окно мастера диаграмм.

  2. Если вы не нашли подходящего типа в списке вкладки Стандартные (Standard Types), щелкните на вкладке Нестандартные (Custom Types). Откроется дополнительный список типов диаграмм, показанный на рис. 11.7.

Примечание

Если вы красиво отформатировали диаграмму и хотите записать ее в качестве именованного типа, чтобы пользоваться им в дальнейшем в качестве шаблона для создания других подобных диаграмм, выберите команду Диаграмма > Тип диаграммы и раскройте вкладку Нестандартные, затем выберите положение Дополнительные (User-defined) переключателя Вывести (Select from) и щелкните на кнопке Добавить. Введите в открывшемся окне диалога имя и описание типа, затем щелкните на кнопке ОК. Теперь новый тип, формат которого подобен оформлению текущей диаграммы, будет появляться на вкладке Нестандартные окна диалога Тип диаграммы (Chart Type).

Рис. 11.7. Дополнительные типы диаграмм

  3. В списке Тип выберите пункт Вырезанные сектора (Pie Explosion).

  4. Щелкните на кнопке ОК.

Рис. 11.8. Настройка источника данных

  5. Диаграмма выбранного типа может отображать только один ряд (строку) данных, поэтому давайте сменим источник данных и воспользуемся выбранным типом для представления итоговых данных листа Клиенты. Выберите команду Диаграмма > Исходные данные (Chart > Source Data).

  6. Замените содержимое поля Диапазон на =Клиенты!$А$9:$С$9, что заставит Excel воспользоваться данными ячеек A9:G9 листа Клиенты. (Знак «$» задает абсолютную адресацию ячеек.)

Рис. 11.9. Выбор ячеек с подписями категорий

  7. Чтобы указать программе ячейки с названиями столбцов, раскройте вкладку Ряд, показанную на рис. 11.8.

Рис. 11.10. Диаграмма с вырезанными секторами

  8. Щелкните на кнопке поля Подписи оси Х (Category Labels). Это поле определяет группу ячеек, в которой находятся подписи делений оси Х (категорий).

  9. Щелкните на корешке листа Клиенты.

  10. Выделите группу ячеек Bl:Gl (рис. 11.9), содержащих заголовки столбцов.

  11. В окне диалога щелкните на кнопке, расположенной в правой части поля ввода.

  12. Щелкните па кнопке ОК.

  13. Затем щелкните па корешке листа Диаграмма. Теперь диаграмма будет вы глядеть примерно так, как показано на рис. 11.10. Заметьте, что с помощью довольно несложных действий можно полностью изменить практически все элементы диаграммы.

Форматирование диаграммы

Если лист Excel в основном служит только рабочим полем, а его оформление не играет особой роли, то диаграммы предназначены для облегчения восприятия числовых данных, поэтому на их внешний вид следует обращать особое внимание. Правильное форматирование диаграммы выделяет существенные данные и приглушает менее важные. С помощью искусно построенной диаграммы можно даже завуалировать нежелательную для вас информацию и, акцентировав внимание на достижениях, скрыть результаты мелких просчетов. В упражнениях этого раздела выполняется преобразование диаграммы, созданной в упражнении 1. На ее примере вы научитесь некоторым операциям, которые затем будете применять в повседневной работе. Диаграммы Excel и Microsoft Graph устроены похожим образом, поэтому здесь не рассматриваются приемы форматирования, описанные ранее на занятии 7 па примере диаграммы Microsoft Graph.

Упражнение 3. Подписи рядов данных

Любая диаграмма состоит из элементов, к которым относятся такие объекты, как область построения диаграммы, оси, координатная сетка, маркеры данных, заголовки. Щелчком мыши можно выделить любой элемент, а щелчком правой кнопки — раскрыть его контекстное меню. Кроме набора стандартных элементов, которые практически всегда присутствуют на диаграмме, Excel позволяет добавлять разные дополнительные компоненты, усиливающие наглядность диаграммы и повышающие ее информативность. К таким вспомогательным элементам относятся подписи рядов данных.

  1. Щелкните правой кнопкой мыши на любом секторе диаграммы и выберите в контекстном меню команду Формат рядов данных (Format Data Series).

  2. Раскройте вкладку Подписи данных (Data Labels), показанную на рис. 11.11. В разделе Включить в подписи (Label contains) можно установить один или несколько флажков, чтобы определить, что именно будет содержаться в подписи:

    • имена рядов (Series Name);
    • имена категорий (Category Name) — название соответствующей отметки оси X;
    • значения (Show Value) — числа источника данных;
    • доли (Show Percentage) —процентная доля данного элемента данных в общем объеме;
    • размеры пузырьков (Show Bubble Sizes) — численное значение диаметра пузырька (доступно только для диаграмм типа Пузырьковые (Bubble)).

Рис. 11.11. Настройка подписей данных

Так как секторные диаграммы не имеют осей, на них автоматически добавляются подписи данных, показывающие соответствие сектора тому или иному столбцу (строке) данных. В рассматриваемом примере подписями данных являются названия категорий Январь, Февраль и т..д.

  3. Чтобы добавить к названиям категорий процентную долю сектора каждого .месяца в общем объеме продаж, установите флажки на пунктах имена категорий и доли.

  4. Сбросьте флажок Линии выноски (Show Leader Lines). Этот флажок выводит линии, связывающие подписи с соответствующими маркерами данных, но в данной ситуации и без них понятно, какому сектору соответствует та или иная надпись, а линии лишь загромождают диаграмму.

  5. Щелкните на кнопке ОК. Теперь рядом с названиями месяцев появятся числа, характеризующие долю, занимаемую соответствующим сектором в целом круге и выраженную в процентах.

Упражнение 4. Форматирование текста

В верхней части диаграммы присутствует заголовок Итого, но он слишком мелкий и сливается с фоном, так как окрашен в темный цвет. Сам текст заголовка непонятен и скорее запутывает, чем разъясняет смысл диаграммы. Давайте исправим эти недочеты.

  1. Щелкните на слове Итого правой кнопкой мыши и выберите в контекстном меню команду Формат заголовка диаграммы (Format Chart Title).

  2. Раскройте вкладку Шрифт. В списке Размер (Size) выберите число 20, а в раскрывающемся списке Цвет (Color) — белый цвет. Щелкните на кнопке ОК.

Надпись Итого сменит цвет и останется выделенной (то есть будет окружена габаритным прямоугольником с маркерами).

  3. Чтобы перейти в режим редактирования надписи, щелкните на ней. Габаритный прямоугольник исчезнет, а вместо него появится текстовый курсор.

  4. Сотрите старую надпись и введите текст Продажи по месяцам.

  5. Чтобы завершить редактирование текстового элемента, щелкните мышью за его пределами.

Примечание

С помощью операций, описанных в шагах 1-5, можно изменить любую надпись, присутствующую на диаграмме.

  6. Шрифт подписей рядов данных, видимо, тоже не удовлетворит вас. Дважды щелкните на надписи Январь 17%.

  7. На вкладке Шрифт открывшегося окна диалога установите белый цвет и подходящий размер шрифта.

  8. Раскройте вкладку Число (Numbers). С ее помощью можно настроить формат численных значений подписей рядов данных. Здесь доступны те же самые варианты, которые обсуждались на предыдущем занятии при форматировании чисел ячеек листа.

  9. Чтобы вывести долю каждого сектора в виде дроби, выберите в списке Числовые форматы (Category) пункт Дробный (Fraction). В появившемся списке Тип (Type) щелкните на пункте Сотыми долями (As Hundredths). Затем щелкните на кнопке ОК.

Обратите внимание, что при форматировании одной подписи синхронно меняются и другие подписи того же ряда данных. Однако подписи данных можно модифицировать и по отдельности. Давайте выделим курсивом подпись сектора Июнь (поскольку это итоговая величина для полугодия). Чтобы выполнить задуманное, нужно сначала выделить элемент в группе подписей.

  10. Щелкните на тексте Июнь 15/100, чтобы вокруг него появился габаритный прямоугольник с надписями. (При этом предполагается, что группа подписей данных диаграммы уже была выделена. Если это не так, щелчком выделите все подписи, затем немного подождите и повторным щелчком выделите указанный текст.)

  11. Выберите команду Формат > Выделенные подписи данных (Format > Selected Data Labels). На вкладке Шрифт открывшегося окна диалога выберите в списке Начертание (Font Style) пункт Полужирный курсив (Bold Italic). В списке Размер щелкните на числе 22, а в раскрывающейся палитре Цвет выберите желтый квадрат.

Примечание

Если подпись обведена габаритным прямоугольником, то двойной щелчок на ней не приведет к раскрытию окна параметров, а переключит текст в режим редактирования с одновременным выделением того слова, на котором был выполнен щелчок.

  12. Щелкните на кнопке ОК. Выполненное форматирование повлияет только на выбранную подпись.

  13. Переместите указатель на рамку габаритного прямоугольника, нажмите кнопку мыши и перетащите рамку вправо и чуть вверх. Подобным перетаскиванием можно перемещать любые надписи диаграммы.

  14. Чтобы снять выделение подписи, щелкните за пределами габаритного прямоугольника. Теперь диаграмма будет выглядеть примерно так, как показано на рис. 11.12.

Рис. 11.12. Форматирование подписей

Упражнение 5. Добавление данных другого листа

Диаграмма Excel может отображать данные сразу нескольких листов. (Именно по этой причине в начале ссылок на источник данных необходимо ставить название листа.) Такая возможность значительно расширяет область применения диаграмм. Например, на одном листе Excel может располагаться таблица расходов со строкой итога, а на другом — аналогичная таблица доходов. Итоговые строки двух таких листов легко выводятся на одну диаграмму. Чтобы добавить в диаграмму предыдущего упражнения данные другого листа, выполните следующие шаги (продолжая работать с листом Диаграмма).

  1. Выберите команду Диаграмма > Добавить данные (Chart > Add Data). Откроется окно диалога Новые данные (Add Data).

  2. Разверните лист Формулы. Обратите внимание, что корешок листа Диаграмма остался светлым, что символизирует смысловую связь выполняемой операции с диаграммой.

  3. Щелкните на ячейке ВЗ .

  4. Нажмите клавишу Shift и, не отпуская ее, щелкните на ячейке G3, чтобы выделить строку ячеек, заголовки столбцов которых соответствуют подписям секторов диаграммы.

  5. Щелкните на кнопке ОК окна диалога Новые данные.

  6. В появившемся окне диалога Специальная вставка (Paste Special) щелкните на кнопке 0К подтвердив выбранные по умолчанию значения параметров. Excel автоматически вернет вас на лист Диаграмма. На первый взгляд кажется, что ничего не изменилось, но это не так. Новые данные не видны, потому что диаграммы секторного типа способны отображать только один ряд данных. Чтобы увидеть добавленные значения, требуется изменить тип диаграммы.

  7. Щелкните правой кнопкой мыши в свободной области диаграммы и выберите в контекстном меню команду Тип диаграммы (Chart Type).

  8. В списке Тип вкладки Стандартные выберите пункт Цилиндрическая (Cylinder).

  9. В разделе Вид щелкните на нижнем левом квадрате (при этом должна появиться подпись Объемный вариант гистограммы со столбцами в виде цилиндров (3-D Column With A Cylindrical Shape)). Затем щелкните на кнопке ОК.

В результате такого преобразования секторы круговой диаграммы превратятся в высокие столбцы. Сзади каждого такого столбца появятся столбцы пониже. Они демонстрируют данные листа Формулы. Заметьте, что диаграмма приобрела третье измерение — глубину. Теперь давайте приведем все элементы обновленной диаграммы к надлежащему виду.

  10. Щелкните правой кнопкой мыши в пустой области диаграммы и выберите в контекстном меню команду Формат области диаграммы (Format Chart Area).

Примечание

Обратите внимание, что при перемещении указателя мыши по окну диаграммы возникает всплывающая подсказка, показывающая, на каком элементе диаграммы в данный момент находится указатель. Это помогает пользователю активизировать нужный элемент диаграммы.

  11. На вкладке В ид открывшегося окна диалога выберите положение Прозрачная (None) переключателя Заливка (Area). Затем щелкните на кнопке ОК. Это приведет к исчезновению темного фона диаграммы, и вы увидите черные линии и подписи осей, появившихся в результате смены типа диаграммы. Заметьте, что объемная диаграмма обладает не двумя, а тремя осями.

  12. Щелчком на крупной надписи Июнь выделите все подписи данных и нажмите клавишу Delete, чтобы удалить их. В новом варианте диаграммы они нам не понадобятся. Аналогичным образом удалите подписи второго ряда данных и заголовок диаграммы.

  13. Дважды щелкните на одной из подписей меток вертикальной оси. С помощью вкладки Шрифт окна диалога Формат оси (Format Axis) настройте размер чисел, чтобы они хорошо смотрелись на экране. Проделайте ту же операцию с подписями горизонтальной оси и оси глубины. В результате диаграмма должна стать примерно такой, как показано на рис. 11.14.

Упражнение 6. Объемная диаграмма

Тип диаграммы, выбранный в предыдущем упражнении, относится к группе объемных типов, которые имеют третье измерение и отображаются в определенной проекции. Такие диаграммы имеют дополнительный набор параметров, задающих тип и наклон проекции, а также угол перспективы.

  1. Выберите команду Диаграмма > Объемный вид (Chart > 3-D View). Откроется окно диалога, показанное на рис. 11.13.

  2. Щелкните три раза на кнопке со стрелкой вверх, чтобы в поле Возвышение (Elevation) появилось число 40. Этот параметр определяет угол взгляда на диаграмму в вертикальной плоскости, перпендикулярной экрану компьютера.

Рис. 11.13. Параметры объемного вида

Примечание

Объемный вид доступен для тех типов диаграмм, в которых ряды данных выводятся объемными маркерами типа цилиндров или пирамид. Наличие третьей оси координат при этом не обязательно.

  3. Щелкните два раза на кнопке поворота по часовой стрелке или введите в поле Поворот (Rotation) число 30 и нажмите клавишу Tab. Этот параметр задает угол поворота диаграммы вокруг вертикальной оси.

По мере изменения величин в окне диалога в области просмотра будет вращаться схематический образец диаграммы, показывающий ее ориентацию.

  4. Щелкните на кнопке Применить (Apply). Диаграмма повернется в соответствии с выполненными изменениями и станет такой, как показано на рис. 11.14, но окно диалога не закроется. Чтобы изучить новое положеии'е диаграммы, сдвиньте окно диалога в сторону, перетащив его за заголовок. Если новый вариант оформления вам не подходит, скорректируйте углы поворота и вновь щелкните на кнопке Применить.

Рис. 11.14. Диаграмма под новым углом зрения

  5. Добившись нужной ориентации, щелкните на кнопке ОК. Объемные диаграммы можно отображать в двух режимах — в изометрии и перспективе.

Рис. 11.15. Диаграмма в режиме перспективы

  6. Чтобы перейти в режим перспективы, сбросьте флажок Изометрия (Right Angle Axes). В окне диалога Формат трехмерной проекции (3-D View) появятся еще одно поле и две кнопки.

  7. Введите в поле Перспектива (Perspective) число 60 и щелкните на кнопке ОК. Перспектива существенно исказит параллельность линий диаграммы (рис. 11.15).

Упражнение 7. Ряды данных

Ряды данных — это столбцы, линейки, точки, пузырьки или другие маркеры, отображающие численные значения ячеек таблицы. Каждой строке или столбцу источника данных соответствует отдельный ряд данных, маркеры которого имеют одинаковый цвет. В зависимости от типа диаграммы вы можете менять цвет, форму и другие параметры рядов данных. Давайте модифицируем форму маркеров, относящихся к данным листа Формулы, и немного раздвинем ряды данных.

  1. Дважды щелкните на/маркере дальнего ряда данных.

  2. На вкладке фигура (Shape) открывшегося окна диалога (рис. 11.16) выберите третий вариант формы.

  3. Разверните вкладку Параметры (Options). .

  4. Увеличьте до 300 число в счетчике Глубина диаграммы (Chart Depth), чтобы раздвинуть ряды данных.

  5. Введите в счетчик Глубина зазора (Gap Depth) число 500, чтобы скорректировать форму цилиндров, сечение которых после предыдущего шага стало овальным.

В данном варианте расположения маркеров данных передние, более высокие столбцы заслоняют задние, более низкие. Это мешает восприятию информации. Следует переставить местами ряды данных.

  6. Раскройте вкладку Порядок рядов (Series Order).

  7. В одноименном списке щелкните на пункте Итого, а затем на кнопке Вниз (Move Down), чтобы переместить выделенный ряд данных ниже ряда S2.

Рис. 11.16. Выбор формы маркеров данных

Рис. 11.17. Изменение названий рядов данных

  8. Щелкните на кнопке ОК.

Остается исправить подписи третьей оси координат. Эта ось появилась в результате выбора типа диаграммы. Подпись Итого соответствует названию строки данных листа Клиенты. Подпись второго ряда данных была сгенерирована автоматически, так как выделенные ячейки данных листа Формулы не содержали названия строки. Для модификации элементов осей требуется изменить источник данных.

Рис. 11.18. Результат форматирования диаграммы

  9. Выберите команду Диаграмма > Исходные данные.

  10. В открывшемся окне диалога раскройте вкладку Ряд, показанную на рис. 11.17.

  11. В списке Ряд (Series) щелкните на пункте Итого.

  12. Протащите мыть в поле Имя (Name), чтобы выделить его содержимое.

  13. Замените формулу Клиенты!$А$9 этого поля текстом Продажи по месяцам.

  14. Щелкните на пункте Ряд2 (SeriesZ) списка Ряд.

  15. Введите в поле Имя текст Диалог, соответствующий названию строки данных листа Формулы, и щелкните на кнопке ОК. Окончательный вид диаграммы показан на рис. 11.18.

Контрольное упражнение

Чтобы попрактиковаться в работе с диаграммами, постройте еще одну, воспользовавшись данными файла Электронная таблица.xls.

  1. Раскройте вкладку Клиенты.

  2. Выполните команду Вставка > Диаграмма.

  3. Выберите диаграмму типа Лепестковая (Radar).

  4. В качестве источника данных укажите диапазон ячеек B3:G7.

    • Как задать заголовки рядов данных?

  5. На вкладке Заголовки (Titles) третьего окна мастера введите название диа граммы.

  6. С помощью вкладки Легенда (Legend) расположите легенду слева от диа граммы.

  7. Поместите диаграмму на лист Клиенты в качестве нового объекта.

  8. Масштабируйте диаграмму, максимально увеличив ее размеры в пределах объекта.

    • Как изменить размеры диаграммы?

  9. Смените цвет фона диаграммы на светло-зеленый.

  10. Выберите команду Диаграмма > Исходные данные.

  11. На вкладке Ряд щелкните в поле Подписи оси Х (Category (X) Axis Labels) и вы берите на листе Клиенты диапазон ячеек B1:G1.

  12. Отформатируйте шрифт текста легенды и подписи осей так, чтобы они хо рошо читались.

  13. Запишите полученную диаграмму в качестве одной из диаграмм пользова тельского типа.

    • Как внести диаграмму в список пользовательских типов?

  14. Закройте файл без сохранения выполненных изменений.

Подведение итогов

Теперь вы умеете не только вводить данные в таблицы Excel и выполнять необходимые расчеты, но и отображать результаты вычислений в виде диаграмм. На занятии были рассмотрены: мастер диаграмм, способы задания источника данных, приемы форматирования текста и рядов данных. Вы познакомились с методикой смены типа диаграммы и приемами настройки объемных диаграмм.

Чтобы завершить изучение Excel, перейдите к следующему занятию, на котором рассматриваются способы печати листов с данными и диаграммами.


Занятие №11

Графики и диаграммы

ТЕМА ЗАНЯТИЯ

На этом занятии изучаются приемы построения диаграмм, иллюстрирующих данные листа Excel. Вы познакомитесь с некоторыми компонентами и операциями, которые перечислены ниже:

  • мастер диаграмм Excel;

  • выбор типа диаграммы;

  • подписи маркеров данных;

  • форматирование текста;

  • совмещение данных разных листов;

  • объемная диаграмма;

  • ряды данных.

Модуль диаграмм приложения Excel автоматически генерирует диаграммы, отображающие данные листа в графической форме. Вам остается только выбрать нужный диапазон ячеек и указать тип диаграммы, а затем оформить полученный графический объект по своему вкусу.

Диаграммы Excel во многом похожи на аналогичные объекты, создаваемые модулем Microsoft Graph XP, о котором рассказывалось на занятии 7. Graph поддерживает те же типы диаграмм, что и Excel. В обоих этих модулях используются одинаковые приемы форматирования. Однако модуль диаграмм Excel не имеет отдельной таблицы данных, так как исходная информация считывается прямо с листа Excel. Панели инструментов диаграмм в Excel и Graph немного отличаются. Кроме того, в диаграмму Excel можно одновременно вставлять данные с разных листов.


Добавление диаграммы

Давайте продолжим работать с файлом Электронная таблица.хls. Откройте его в Excel и разверните лист Клиенты. В упражнениях этого занятия будет добавлена и отформатирована диаграмма, представляющая данные этого листа в графической форме.


Упражнение 1. Мастер диаграмм Excel

Для создания диаграммы проще всего воспользоваться соответствующим мастером. Вы уже познакомились с ним на занятии 2. В этом упражнении подробно описываются все окна диалога мастера создания диаграмм.

Рис. 11.1. Выбор типа диаграммы

Рис. 11.2. Задание источника данных

  1. Чтобы указать мастеру диаграмм источник данных, выделите прямоугольную область ячеек A1:G7.

Примечание

Исходные числовые данные для диаграммы следует выделять вместе со строкой и столбцом заголовков таблицы, чтобы соответствующие названия автоматически появлялись в легенде и на оси категорий диаграммы.

  2. Выберите команду Вставка > Диаграмма (Insert > Chart). Откроется первое окно диалога мастера диаграмм, показанное на рис. 11.1, в котором нужно указать тип диаграммы, задающий ее оформление, и конфигурацию элементов, отображающих данные.

  3. В списке Тип (Chart Type) выберите пункт Линейчатая (Bar) или другую подходящую категорию.

  4. В разделе Вид (Chart Sub-type) щелкните на левом верхнем квадрате, задающем подтип Линейчатая диаграмма (Clustered Bar).

  5. Чтобы не выходя из окна мастера оценить будущий вид диаграммы, нажмите мышью кнопку Просмотр результата (Press And Hold To View Sample). В окне диалога вместо списка подтипов появится внешний вид будущей диаграммы. Отпустите кнопку мыши, и окно диалога вернется в прежнее состояние.

  6. Щелкяите на кнопке Далее (Next).

Второе окно диалога мастера, показанное на рис. 11.2, позволяет выбрать или скорректировать источник данных. Поскольку при запуске мастера в листе уже был выделен некоторый диапазон данных, он автоматически выбирается в качестве источника данных. Обратите внимание, что будущая диаграмма, общий вид которой отображается в окне диалога, содержит лишний ряд данных, появившийся из-за наличия в выделенной области пустой строки 2.

  7. Чтобы скорректировать источник данных, щелкните на кнопке, расположенной в правой части поля Диапазон (Data Range). Окно мастера свернется в одну строку, открыв доступ к листу Excel.

  8. Выделите ячейки Al:Gl.

  9. Нажмите клавишу Ctrl и, не отпуская ее, протащите мышь из ячейки A3 в ячейку G7. Эта операция добавит к выделению вторую группу ячеек, как показано на рис. 11.3.

Рис. 11.3. Скорректированный источник данных

  10. Щелкните на кнопке мастера диаграмм, чтобы вновь развернуть его окно диалога. Теперь в поле Диапазон появится формула =Клиенты!$А$1:$6$1; Клиенты! $А$3 :$G$7, которая с помощью абсолютных ссылок задает две области данных из листа Клиенты. Немного потренировавшись, можно научиться вручную вводить формулы источников данных любых конфигураций.

  11. 11. Переключатель Ряды в (Series In) позволяет группировать ряды данных по строкам или столбцам таблицы. Чтобы по вертикальной оси диаграммы выводились названия месяцев года, выберите положение строках (Rows) этого переключателя.

  12. Для перехода к окну диалога параметров диаграммы, показанному на рис. 11.4, щелкните на кнопке Далее.

Рис. 11.4. Настройка параметров диаграммы

Вкладка Ряд (Series) второго окна мастера диаграмм открывает доступ к инструментам, позволяющим гибко перестраивать источник данных, добавляя и удаляя ряды данных и задавая ячейки с заголовками строк и столбцов таблицы.

  13. Введите в поле Название диаграммы (Chart Title) текст Активность клиентов.

  14. В поля Ось Х (категорий) (Category (X) Axis) и Ось Y (значений) (Value (Y) Axis) введите названия осей (см. рис. 11.4).

  15. При необходимости с помощью других вкладок этого окна диалога настройте оси, линии сетки, легенду, подписи данных и режим отображения таблицы данных. Затем щелкните на кнопке Далее, чтобы перейти к четвертому окну мастера (рис. 11.5), определяющему местоположение будущей диаграммы.

  16. Чтобы поместить диаграмму на отдельный лист, выберите положение переключателя в отдельном (As New Sheet).

Рис. 11.5. Выбор расположения диаграммы

Рис. 11.6. Готовая диаграмма на отдельном листе

  17. В текстовое поле имени нового листа введите название Диаграмма.

  18. Щелкните на кнопке Готово (Finish). Результат показан на рис. 11.6.

Примечание

При размещении диаграммы на отдельном листе программа задает ей размер, равный площади окна документа Excel. Если при изменении , размеров окна масштаб диаграммы не меняется, выберите команду Сервис > Параметры и установите флажок Масштабировать диаграмму по размеру окна (Chart Sizes With Window Frame). В противном случае размеры диаграммы будут сохраняться неизменными (если считать в пикселах экрана компьютера).


Упражнение 2. Выбор типа диаграммы

Для лучшего отражения той или иной природы данных следует подобрать соответствующий тип диаграммы. Его, так же как и любые другие параметры, заданные при работе с мастером диаграмм, всегда можно сменить позже в процессе форматирования документа.

  1. Чтобы выбрать другой тип диаграммы, выполните команду Диаграмма > Тип диаграммы (Chart > Chart Type). Откроется окно диалога, похожее на первое окно мастера диаграмм.

  2. Если вы не нашли подходящего типа в списке вкладки Стандартные (Standard Types), щелкните на вкладке Нестандартные (Custom Types). Откроется дополнительный список типов диаграмм, показанный на рис. 11.7.

Примечание

Если вы красиво отформатировали диаграмму и хотите записать ее в качестве именованного типа, чтобы пользоваться им в дальнейшем в качестве шаблона для создания других подобных диаграмм, выберите команду Диаграмма > Тип диаграммы и раскройте вкладку Нестандартные, затем выберите положение Дополнительные (User-defined) переключателя Вывести (Select from) и щелкните на кнопке Добавить. Введите в открывшемся окне диалога имя и описание типа, затем щелкните на кнопке ОК. Теперь новый тип, формат которого подобен оформлению текущей диаграммы, будет появляться на вкладке Нестандартные окна диалога Тип диаграммы (Chart Type).

Рис. 11.7. Дополнительные типы диаграмм

  3. В списке Тип выберите пункт Вырезанные сектора (Pie Explosion).

  4. Щелкните на кнопке ОК.

Рис. 11.8. Настройка источника данных

  5. Диаграмма выбранного типа может отображать только один ряд (строку) данных, поэтому давайте сменим источник данных и воспользуемся выбранным типом для представления итоговых данных листа Клиенты. Выберите команду Диаграмма > Исходные данные (Chart > Source Data).

  6. Замените содержимое поля Диапазон на =Клиенты!$А$9:$С$9, что заставит Excel воспользоваться данными ячеек A9:G9 листа Клиенты. (Знак «$» задает абсолютную адресацию ячеек.)

Рис. 11.9. Выбор ячеек с подписями категорий

  7. Чтобы указать программе ячейки с названиями столбцов, раскройте вкладку Ряд, показанную на рис. 11.8.

Рис. 11.10. Диаграмма с вырезанными секторами

  8. Щелкните на кнопке поля Подписи оси Х (Category Labels). Это поле определяет группу ячеек, в которой находятся подписи делений оси Х (категорий).

  9. Щелкните на корешке листа Клиенты.

  10. Выделите группу ячеек Bl:Gl (рис. 11.9), содержащих заголовки столбцов.

  11. В окне диалога щелкните на кнопке, расположенной в правой части поля ввода.

  12. Щелкните па кнопке ОК.

  13. Затем щелкните па корешке листа Диаграмма. Теперь диаграмма будет вы глядеть примерно так, как показано на рис. 11.10. Заметьте, что с помощью довольно несложных действий можно полностью изменить практически все элементы диаграммы.


Форматирование диаграммы

Если лист Excel в основном служит только рабочим полем, а его оформление не играет особой роли, то диаграммы предназначены для облегчения восприятия числовых данных, поэтому на их внешний вид следует обращать особое внимание. Правильное форматирование диаграммы выделяет существенные данные и приглушает менее важные. С помощью искусно построенной диаграммы можно даже завуалировать нежелательную для вас информацию и, акцентировав внимание на достижениях, скрыть результаты мелких просчетов. В упражнениях этого раздела выполняется преобразование диаграммы, созданной в упражнении 1. На ее примере вы научитесь некоторым операциям, которые затем будете применять в повседневной работе. Диаграммы Excel и Microsoft Graph устроены похожим образом, поэтому здесь не рассматриваются приемы форматирования, описанные ранее на занятии 7 па примере диаграммы Microsoft Graph.


Упражнение 3. Подписи рядов данных

Любая диаграмма состоит из элементов, к которым относятся такие объекты, как область построения диаграммы, оси, координатная сетка, маркеры данных, заголовки. Щелчком мыши можно выделить любой элемент, а щелчком правой кнопки — раскрыть его контекстное меню. Кроме набора стандартных элементов, которые практически всегда присутствуют на диаграмме, Excel позволяет добавлять разные дополнительные компоненты, усиливающие наглядность диаграммы и повышающие ее информативность. К таким вспомогательным элементам относятся подписи рядов данных.

  1. Щелкните правой кнопкой мыши на любом секторе диаграммы и выберите в контекстном меню команду Формат рядов данных (Format Data Series).

  2. Раскройте вкладку Подписи данных (Data Labels), показанную на рис. 11.11. В разделе Включить в подписи (Label contains) можно установить один или несколько флажков, чтобы определить, что именно будет содержаться в подписи:

    • имена рядов (Series Name);
    • имена категорий (Category Name) — название соответствующей отметки оси X;
    • значения (Show Value) — числа источника данных;
    • доли (Show Percentage) —процентная доля данного элемента данных в общем объеме;
    • размеры пузырьков (Show Bubble Sizes) — численное значение диаметра пузырька (доступно только для диаграмм типа Пузырьковые (Bubble)).

Рис. 11.11. Настройка подписей данных

Так как секторные диаграммы не имеют осей, на них автоматически добавляются подписи данных, показывающие соответствие сектора тому или иному столбцу (строке) данных. В рассматриваемом примере подписями данных являются названия категорий Январь, Февраль и т..д.

  3. Чтобы добавить к названиям категорий процентную долю сектора каждого .месяца в общем объеме продаж, установите флажки на пунктах имена категорий и доли.

  4. Сбросьте флажок Линии выноски (Show Leader Lines). Этот флажок выводит линии, связывающие подписи с соответствующими маркерами данных, но в данной ситуации и без них понятно, какому сектору соответствует та или иная надпись, а линии лишь загромождают диаграмму.

  5. Щелкните на кнопке ОК. Теперь рядом с названиями месяцев появятся числа, характеризующие долю, занимаемую соответствующим сектором в целом круге и выраженную в процентах.


Упражнение 4. Форматирование текста

В верхней части диаграммы присутствует заголовок Итого, но он слишком мелкий и сливается с фоном, так как окрашен в темный цвет. Сам текст заголовка непонятен и скорее запутывает, чем разъясняет смысл диаграммы. Давайте исправим эти недочеты.

  1. Щелкните на слове Итого правой кнопкой мыши и выберите в контекстном меню команду Формат заголовка диаграммы (Format Chart Title).

  2. Раскройте вкладку Шрифт. В списке Размер (Size) выберите число 20, а в раскрывающемся списке Цвет (Color) — белый цвет. Щелкните на кнопке ОК.

Надпись Итого сменит цвет и останется выделенной (то есть будет окружена габаритным прямоугольником с маркерами).

  3. Чтобы перейти в режим редактирования надписи, щелкните на ней. Габаритный прямоугольник исчезнет, а вместо него появится текстовый курсор.

  4. Сотрите старую надпись и введите текст Продажи по месяцам.

  5. Чтобы завершить редактирование текстового элемента, щелкните мышью за его пределами.

Примечание

С помощью операций, описанных в шагах 1-5, можно изменить любую надпись, присутствующую на диаграмме.

  6. Шрифт подписей рядов данных, видимо, тоже не удовлетворит вас. Дважды щелкните на надписи Январь 17%.

  7. На вкладке Шрифт открывшегося окна диалога установите белый цвет и подходящий размер шрифта.

  8. Раскройте вкладку Число (Numbers). С ее помощью можно настроить формат численных значений подписей рядов данных. Здесь доступны те же самые варианты, которые обсуждались на предыдущем занятии при форматировании чисел ячеек листа.

  9. Чтобы вывести долю каждого сектора в виде дроби, выберите в списке Числовые форматы (Category) пункт Дробный (Fraction). В появившемся списке Тип (Type) щелкните на пункте Сотыми долями (As Hundredths). Затем щелкните на кнопке ОК.

Обратите внимание, что при форматировании одной подписи синхронно меняются и другие подписи того же ряда данных. Однако подписи данных можно модифицировать и по отдельности. Давайте выделим курсивом подпись сектора Июнь (поскольку это итоговая величина для полугодия). Чтобы выполнить задуманное, нужно сначала выделить элемент в группе подписей.

  10. Щелкните на тексте Июнь 15/100, чтобы вокруг него появился габаритный прямоугольник с надписями. (При этом предполагается, что группа подписей данных диаграммы уже была выделена. Если это не так, щелчком выделите все подписи, затем немного подождите и повторным щелчком выделите указанный текст.)

  11. Выберите команду Формат > Выделенные подписи данных (Format > Selected Data Labels). На вкладке Шрифт открывшегося окна диалога выберите в списке Начертание (Font Style) пункт Полужирный курсив (Bold Italic). В списке Размер щелкните на числе 22, а в раскрывающейся палитре Цвет выберите желтый квадрат.

Примечание

Если подпись обведена габаритным прямоугольником, то двойной щелчок на ней не приведет к раскрытию окна параметров, а переключит текст в режим редактирования с одновременным выделением того слова, на котором был выполнен щелчок.

  12. Щелкните на кнопке ОК. Выполненное форматирование повлияет только на выбранную подпись.

  13. Переместите указатель на рамку габаритного прямоугольника, нажмите кнопку мыши и перетащите рамку вправо и чуть вверх. Подобным перетаскиванием можно перемещать любые надписи диаграммы.

  14. Чтобы снять выделение подписи, щелкните за пределами габаритного прямоугольника. Теперь диаграмма будет выглядеть примерно так, как показано на рис. 11.12.

Рис. 11.12. Форматирование подписей


Упражнение 5. Добавление данных другого листа

Диаграмма Excel может отображать данные сразу нескольких листов. (Именно по этой причине в начале ссылок на источник данных необходимо ставить название листа.) Такая возможность значительно расширяет область применения диаграмм. Например, на одном листе Excel может располагаться таблица расходов со строкой итога, а на другом — аналогичная таблица доходов. Итоговые строки двух таких листов легко выводятся на одну диаграмму. Чтобы добавить в диаграмму предыдущего упражнения данные другого листа, выполните следующие шаги (продолжая работать с листом Диаграмма).

  1. Выберите команду Диаграмма > Добавить данные (Chart > Add Data). Откроется окно диалога Новые данные (Add Data).

  2. Разверните лист Формулы. Обратите внимание, что корешок листа Диаграмма остался светлым, что символизирует смысловую связь выполняемой операции с диаграммой.

  3. Щелкните на ячейке ВЗ .

  4. Нажмите клавишу Shift и, не отпуская ее, щелкните на ячейке G3, чтобы выделить строку ячеек, заголовки столбцов которых соответствуют подписям секторов диаграммы.

  5. Щелкните на кнопке ОК окна диалога Новые данные.

  6. В появившемся окне диалога Специальная вставка (Paste Special) щелкните на кнопке 0К подтвердив выбранные по умолчанию значения параметров. Excel автоматически вернет вас на лист Диаграмма. На первый взгляд кажется, что ничего не изменилось, но это не так. Новые данные не видны, потому что диаграммы секторного типа способны отображать только один ряд данных. Чтобы увидеть добавленные значения, требуется изменить тип диаграммы.

  7. Щелкните правой кнопкой мыши в свободной области диаграммы и выберите в контекстном меню команду Тип диаграммы (Chart Type).

  8. В списке Тип вкладки Стандартные выберите пункт Цилиндрическая (Cylinder).

  9. В разделе Вид щелкните на нижнем левом квадрате (при этом должна появиться подпись Объемный вариант гистограммы со столбцами в виде цилиндров (3-D Column With A Cylindrical Shape)). Затем щелкните на кнопке ОК.

В результате такого преобразования секторы круговой диаграммы превратятся в высокие столбцы. Сзади каждого такого столбца появятся столбцы пониже. Они демонстрируют данные листа Формулы. Заметьте, что диаграмма приобрела третье измерение — глубину. Теперь давайте приведем все элементы обновленной диаграммы к надлежащему виду.

  10. Щелкните правой кнопкой мыши в пустой области диаграммы и выберите в контекстном меню команду Формат области диаграммы (Format Chart Area).

Примечание

Обратите внимание, что при перемещении указателя мыши по окну диаграммы возникает всплывающая подсказка, показывающая, на каком элементе диаграммы в данный момент находится указатель. Это помогает пользователю активизировать нужный элемент диаграммы.

  11. На вкладке В ид открывшегося окна диалога выберите положение Прозрачная (None) переключателя Заливка (Area). Затем щелкните на кнопке ОК. Это приведет к исчезновению темного фона диаграммы, и вы увидите черные линии и подписи осей, появившихся в результате смены типа диаграммы. Заметьте, что объемная диаграмма обладает не двумя, а тремя осями.

  12. Щелчком на крупной надписи Июнь выделите все подписи данных и нажмите клавишу Delete, чтобы удалить их. В новом варианте диаграммы они нам не понадобятся. Аналогичным образом удалите подписи второго ряда данных и заголовок диаграммы.

  13. Дважды щелкните на одной из подписей меток вертикальной оси. С помощью вкладки Шрифт окна диалога Формат оси (Format Axis) настройте размер чисел, чтобы они хорошо смотрелись на экране. Проделайте ту же операцию с подписями горизонтальной оси и оси глубины. В результате диаграмма должна стать примерно такой, как показано на рис. 11.14.


Упражнение 6. Объемная диаграмма

Тип диаграммы, выбранный в предыдущем упражнении, относится к группе объемных типов, которые имеют третье измерение и отображаются в определенной проекции. Такие диаграммы имеют дополнительный набор параметров, задающих тип и наклон проекции, а также угол перспективы.

  1. Выберите команду Диаграмма > Объемный вид (Chart > 3-D View). Откроется окно диалога, показанное на рис. 11.13.

  2. Щелкните три раза на кнопке со стрелкой вверх, чтобы в поле Возвышение (Elevation) появилось число 40. Этот параметр определяет угол взгляда на диаграмму в вертикальной плоскости, перпендикулярной экрану компьютера.

Рис. 11.13. Параметры объемного вида

Примечание

Объемный вид доступен для тех типов диаграмм, в которых ряды данных выводятся объемными маркерами типа цилиндров или пирамид. Наличие третьей оси координат при этом не обязательно.

  3. Щелкните два раза на кнопке поворота по часовой стрелке или введите в поле Поворот (Rotation) число 30 и нажмите клавишу Tab. Этот параметр задает угол поворота диаграммы вокруг вертикальной оси.

По мере изменения величин в окне диалога в области просмотра будет вращаться схематический образец диаграммы, показывающий ее ориентацию.

  4. Щелкните на кнопке Применить (Apply). Диаграмма повернется в соответствии с выполненными изменениями и станет такой, как показано на рис. 11.14, но окно диалога не закроется. Чтобы изучить новое положеии'е диаграммы, сдвиньте окно диалога в сторону, перетащив его за заголовок. Если новый вариант оформления вам не подходит, скорректируйте углы поворота и вновь щелкните на кнопке Применить.

Рис. 11.14. Диаграмма под новым углом зрения

  5. Добившись нужной ориентации, щелкните на кнопке ОК. Объемные диаграммы можно отображать в двух режимах — в изометрии и перспективе.

Рис. 11.15. Диаграмма в режиме перспективы

  6. Чтобы перейти в режим перспективы, сбросьте флажок Изометрия (Right Angle Axes). В окне диалога Формат трехмерной проекции (3-D View) появятся еще одно поле и две кнопки.

  7. Введите в поле Перспектива (Perspective) число 60 и щелкните на кнопке ОК. Перспектива существенно исказит параллельность линий диаграммы (рис. 11.15).


Упражнение 7. Ряды данных

Ряды данных — это столбцы, линейки, точки, пузырьки или другие маркеры, отображающие численные значения ячеек таблицы. Каждой строке или столбцу источника данных соответствует отдельный ряд данных, маркеры которого имеют одинаковый цвет. В зависимости от типа диаграммы вы можете менять цвет, форму и другие параметры рядов данных. Давайте модифицируем форму маркеров, относящихся к данным листа Формулы, и немного раздвинем ряды данных.

  1. Дважды щелкните на/маркере дальнего ряда данных.

  2. На вкладке фигура (Shape) открывшегося окна диалога (рис. 11.16) выберите третий вариант формы.

  3. Разверните вкладку Параметры (Options). .

  4. Увеличьте до 300 число в счетчике Глубина диаграммы (Chart Depth), чтобы раздвинуть ряды данных.

  5. Введите в счетчик Глубина зазора (Gap Depth) число 500, чтобы скорректировать форму цилиндров, сечение которых после предыдущего шага стало овальным.

В данном варианте расположения маркеров данных передние, более высокие столбцы заслоняют задние, более низкие. Это мешает восприятию информации. Следует переставить местами ряды данных.

  6. Раскройте вкладку Порядок рядов (Series Order).

  7. В одноименном списке щелкните на пункте Итого, а затем на кнопке Вниз (Move Down), чтобы переместить выделенный ряд данных ниже ряда S2.

Рис. 11.16. Выбор формы маркеров данных

Рис. 11.17. Изменение названий рядов данных

  8. Щелкните на кнопке ОК.

Остается исправить подписи третьей оси координат. Эта ось появилась в результате выбора типа диаграммы. Подпись Итого соответствует названию строки данных листа Клиенты. Подпись второго ряда данных была сгенерирована автоматически, так как выделенные ячейки данных листа Формулы не содержали названия строки. Для модификации элементов осей требуется изменить источник данных.

Рис. 11.18. Результат форматирования диаграммы

  9. Выберите команду Диаграмма > Исходные данные.

  10. В открывшемся окне диалога раскройте вкладку Ряд, показанную на рис. 11.17.

  11. В списке Ряд (Series) щелкните на пункте Итого.

  12. Протащите мыть в поле Имя (Name), чтобы выделить его содержимое.

  13. Замените формулу Клиенты!$А$9 этого поля текстом Продажи по месяцам.

  14. Щелкните на пункте Ряд2 (SeriesZ) списка Ряд.

  15. Введите в поле Имя текст Диалог, соответствующий названию строки данных листа Формулы, и щелкните на кнопке ОК. Окончательный вид диаграммы показан на рис. 11.18.


Контрольное упражнение

Чтобы попрактиковаться в работе с диаграммами, постройте еще одну, воспользовавшись данными файла Электронная таблица.xls.

  1. Раскройте вкладку Клиенты.

  2. Выполните команду Вставка > Диаграмма.

  3. Выберите диаграмму типа Лепестковая (Radar).

  4. В качестве источника данных укажите диапазон ячеек B3:G7.

    • Как задать заголовки рядов данных?

  5. На вкладке Заголовки (Titles) третьего окна мастера введите название диа граммы.

  6. С помощью вкладки Легенда (Legend) расположите легенду слева от диа граммы.

  7. Поместите диаграмму на лист Клиенты в качестве нового объекта.

  8. Масштабируйте диаграмму, максимально увеличив ее размеры в пределах объекта.

    • Как изменить размеры диаграммы?

  9. Смените цвет фона диаграммы на светло-зеленый.

  10. Выберите команду Диаграмма > Исходные данные.

  11. На вкладке Ряд щелкните в поле Подписи оси Х (Category (X) Axis Labels) и вы берите на листе Клиенты диапазон ячеек B1:G1.

  12. Отформатируйте шрифт текста легенды и подписи осей так, чтобы они хо рошо читались.

  13. Запишите полученную диаграмму в качестве одной из диаграмм пользова тельского типа.

    • Как внести диаграмму в список пользовательских типов?

  14. Закройте файл без сохранения выполненных изменений.


Подведение итогов

Теперь вы умеете не только вводить данные в таблицы Excel и выполнять необходимые расчеты, но и отображать результаты вычислений в виде диаграмм. На занятии были рассмотрены: мастер диаграмм, способы задания источника данных, приемы форматирования текста и рядов данных. Вы познакомились с методикой смены типа диаграммы и приемами настройки объемных диаграмм.

Чтобы завершить изучение Excel, перейдите к следующему занятию, на котором рассматриваются способы печати листов с данными и диаграммами.


Занятие №12

Подготовка листов Excel к печати

ТЕМА ЗАНЯТИЯ

Вы уже умеете размещать в ячейках Excel числовые данные, выполнять расчеты и оформлять результаты в виде диаграмм. Осталось научиться распечатывать полученные документы. На занятии рассматриваются следующие операции, помогающие подготовить листы Excel к печати:

  • ориентация страницы;

  • настройка полей;

  • добавление колонтитулов;

  • сортировка данных;

  • фильтрация;

  • отображение заголовков строк и столбцов на всех страницах;

  • скрытие ячеек и листов;

  • разбиение на страницы.

Чтобы быстро распечатать лист Excel, достаточно щелкнуть на кнопке Печать (Print) панели инструментов Стандартная. Однако результат этой операции, скорее всего, не удовлетворит вас. Он хорош для вывода черновиков, но совершенно не подходит для печати чистовых документов, которые должны быть хорошо оформлены и не терпят присутствия излишней информации. Поэтому перед окончательной печатью листов Excel нужно настроить масштаб и поля страниц, отсортировать данные таблиц, выделить диапазон печатаемых ячеек, указать способ расположения таблиц и диаграмм и выполнить некоторые другие операции.

Компоновка страниц

В целом настройка параметров печати в Excel похожа на аналогичную операцию в Word. Но листы Excel имеют свою специфику. Удобно, чтобы табличные данные листа помещались на одной странице, поэтому требуется настройка масштаба печати. Широкие листы принято выводить в альбомной ориентации, а длинные таблицы — в портретной. Если в Word параметры страницы, как правило, назначаются сразу всему документу, то в Excel они настраиваются отдельно для каждого листа.

Упражнение 1. Ориентация и масштаб страницы

Давайте продолжим работу с файлом Электронная таблица.х1s и распечатаем некоторые из ее листов. В этом упражнении выполняется первый этап подготовки к печати — настройка ориентации страницы и масштаба выводимого листа.

  1. Откройте файл Электронная таблица.xls.

  2. Разверните лист Формулы, щелкнув на его корешке.

В таблице этого листа есть столбцы только для первых шести месяцев. Давайте расширим таблицу так, чтобы в ней разместились данные для всех 12 месяцев года. Это позволит научиться печатать широкие таблицы, не помещающиеся на лист целиком.

  3. Выделите ячейки B1:G14 и нажатием клавиш Ctrl+C скопируйте их в буфер обмена.

  4. Выберите команду Вставка > Скопированные ячейки (Insert > Copied Cells), чтобы дублировать ячейки, выделенные на шаге 3.

  5. В открывшемся окне диалога выберите положение переключателя Диапазон со сдвигом вправо (Shift Cells Right), а затем щелкните на кнопке ОК. Ячейки, выделенные на шаге 3, будут дублированы с добавлением новых столбцов.

  6. Теперь следует скорректировать заголовки столбцов. Для этого щелкните на ячейке В1 и протащите маркер нижнего левого угла рамки вправо, чтобы рамка охватила диапазон В1:М1. Excel автоматически сгенерирует последовательность названий месяцев.

  7. В столбце G остались пустые ячейки. Чтобы заполнить их соответствующими формулами расчета прироста продаж, выделите группу F10:Fl4, скопируйте ее, щелкните на ячейке G10 правой кнопкой мыши и выберите команду Вставить. Тенерь лист будет выглядеть так, как показано на рис. 12.1.

Рис. 12.1. Обновленный лист Формулы

  8. Выберите команду Файл > Параметры страницы (File > Print Setup).

  9. Разверните в открывшемся окне диалога вкладку Страница (Page), показанную на рис. 12.2.

Рис. 12.2. Настройка ориентации страницы и масштаба

Рис. 12.3. Таблица в масштабе 100 %

  10. Выберите положение переключателя альбомная (Landscape).

  11. Чтобы увидеть предполагаемое размещение чисел на странице, щелкните на кнопке Просмотр (Print Preview). Если выбран стандартный размер бумаги 4юрмата А4, то окажется, что на страницу не влезают все столбцы (рис. 12.3).

  12. Нажмите клавишу Page Down и вы увидите, что ячейки крайнего правого столбца перенесены на вторую страницу. Это неудобно. Следует изменить масштаб, чтобы все столбцы таблицы по ширине вписывались в одну страницу.

Примечание

В полученной таблице данные столбцов H-L повторяют числа столбцов B-G. Если хотите, измените величины в некоторых ячейках. В упражнениях этого занятия конкретные числовые значения ячеек несущественны.

  13. Щелкните на кнопке Страница (Setup) панели инструментов, чтобы вернуться в окно диалога Параметры страницы (Page Setup).

Раздел Масштаб (Scaling) этого окна диалога позволяет уменьшать или увеличивать печатаемые объекты. С помощью счетчика установить (Adjust To) можно выбрать любой масштаб, рассчитываемый в процентах от исходного размера страницы. (Не забудьте при этом выбрать соответствующее положение переключателя.) Можно поступить и по-другому. Excel умеет сам подгонять размер таблицы под площадь страницы.

Примечание

Счетчики, расположенные в строке Разместить..., позволяют указать инструменту автоматического масштабирования, какое число страниц должна занимать таблица по ширине и высоте.

  14. Выберите положение переключателя Разместить... (Fit To) и оставьте в обоих счетчиках, соответствующих этому положению, числа 1.

  15. Щелкните на кнопке ОК. Теперь вся таблица помещается на одну страницу. Если вы снова щелкнете на кнопке Страница, то увидите в счетчике установить величину 96%. Это тот масштаб, который был выбран программой Excel для печати листа Формулы. При необходимости можете скорректировать его.

Упражнение 2. Настройка полей

Поля формируют пустую рамку вокруг информативной области страницы. Уменьшая их, можно немного увеличить размер печатаемой таблицы.

  1. Снова щелкните на кнопке Страница.

  2. В окне диалога Параметры страницы раскройте вкладку Поля (Margins), показанную на рис. 12.4.

Рис. 12.4. Настройка полей

  3. Уменьшите значение счетчика левое (Left) до 1 см.

  4. Точно так же, до 1 см, уменьшите значение счетчика правое (Right).

  5. Таблица листа Формулы невелика по высоте. Давайте напечатаем ее посередине страницы. Для этого установите флажок вертикально (Vertically).

  6. Щелкните на кнопке ОК.

Ширина области печати увеличилась. Если снова посмотреть на вкладку Страница окна диалога Параметры страницы, то можно заметить, что режим автоматической настройки размеров сразу же увеличил масштаб, подогнав таблицу под новый размер области печати.

  7. Щелчком на кнопке Закрыть (Close) выйдите из режима предварительного просмотра.

Упражнение 3. Добавление колонтитулов

Колонтитулы позволяют добавлять в нижнюю и верхнюю часть страниц заголовки и описания, дублирующиеся на всех страницах. Если таблица длинная, в колонтитуле удобно разместить ее название, номера страниц, название файла документа и листа, на котором размещена таблица.

  1. Выберите команду Вид > Колонтитулы (View > Header And Footer). Откроется вкладка Колонтитулы (Header/Footer) окна диалога Параметры страницы, показанная на рис. 12.5. В раскрывающихся списках Верхний колонтитул (Header) и Нижний колонтитул (Footer) можно выбрать один из стандартных вариантов оформления колонтитулов.

Рис. 12.5. Настройка колонтитулов

  2. Раскройте список Верхний колонтитул и выберите пункт Формулы; Страница 1 (Формулы; Page 1). Этот вариант добавляет в верхнюю часть каждой страницы название листа с исходными данными и порядковый номер страницы. В верхней части вкладки Колонтитулы появится пример оформления верхнего колонтитула.

Примечание

Если нужно, чтобы нумерация страниц начиналась не с единицы, введите номер для первой страницы в поле Номер первой страницы (First Page Number) вкладки Страница того же окна диалога.

Если стандартные схемы компоновки колонтитулов вас не устраивают, воспользуйтесь кнопками, расположенными в средней части окна диалога.

  3. Чтобы настроить нижний колонтитул, щелкните на кнопке Создать нижний колонтитул (Custom Footer). Открывшееся окно диалога (рис. 12.6) имеет три списка и несколько кнопок. С помощью этих кнопок можно размещать различные объекты в списках, задающих содержимое левого края колонтитула, его центральной части и правого края.

  4. Щелкните в списке Слева (Left Section).

Рис. 12.6. форматирование колонтитула

  5. Щелкните в центральной части окна на четвертой справа кнопке. В списке появится ссылка &[Файл] (&[File]), генерирующая названия файла документа.

  6. Введите перед ней текст Имя файла:.

  7. Щелкните в списке Справа (Right Section) и введите текст Время создания :.

  8. Щелкните на кнопке с календарем, поместив в колонтитул ссылку на дату &[Дата] (&[Date]).

  9. Нажмите клавишу Пробел и щелкните на кнопке с циферблатом часов, кото рая добавляет ссылку на время печати документа &[Время] (&[Time]).

  10. Закройте окно диалога щелчком на кнопке ОК.

Примечание

Высота нижнего и верхнего колонтитулов настраивается на вкладке Поля окна диалога Параметры страницы.

Теперь в нижний колонтитул будет выводиться имя файла таблицы, а также дата и время печати файла с соответствующими подписями. Если вы хотите увидеть страницу с добавленными колонтитулами, выберите команду Файл > Предварительный просмотр (File > Print Preview).

Сортировка и фильтрация

Сортировка позволяет упорядочить строки таблицы в порядке возрастания или убывания данных одного или нескольких столбцов таблицы. Фильтрация дает возможность временно убрать из таблицы ненужные строки, не стирая их.

Упражнение 4. Сортировка данных

Сортировать данные приходится не только при печати документа. Размещение строк таблицы в порядке возрастания одного из параметров помогает искать нужные записи. Печать чистового варианта документа — подходящий момент для того, чтобы упорядочить данные, если они вводились в спешке и оказались расположенными не должным образом. Давайте рассортируем клиентов в верхней таблице листа в порядке увеличения продаж в апреле месяце.

  1. Щелкните на любой ячейке столбца Апрель верхней таблицы.

  2. Щелкните на кнопке Сортировка по возрастанию (Sort Ascending) панели инструментов Стандартная. Расстановка строк поменяется так, что числа в столбце Апрель будут увеличиваться сверху вниз (рис. 12.7).

Рис. 12.7. Таблица упорядочена по возрастанию продаж в апреле

Сравните заголовки строк верхней таблицы с заголовками нижней и вы увидите, что переставлены строки целиком, а не только ячейки столбца Апрель. (Раньше порядок заголовков в двух таблицах совпадал.) Для сортировки таблицы по убыванию следует щелкнуть на кнопке Сортировка по убыванию (Sort Descending).

Объемы продаж клиентам РИФ и Викинг в апреле совпадают (они равны 11000). Если таких совпадающих значений много, приходится дополнительно упорядочивать таблицу по второму признаку. Например, алфавитный список покупателей следует упорядочить сначала по столбцу с фамилиями, а затем по столбцу с именами, чтобы информация о людях с одинаковыми фамилиями располагалась по ал4)авиту имен. Чтобы дополнительно упорядочить таблицу по возрастанию, продаж в мае (при условии равенства продаж в апреле), выполните следующие действия.

  3. Выберите команду Данные > Сортировка (Data > Sort). Откроется окно диалога, показанное на рис. 12.8. В разделе Сортировать по (Sort By) уже введено условие сортировки по возрастанию значений столбца Апрель, которое было назначено на шаге 2.

Рис. 12.8. Настройка условия сортировки

  4. В раскрывающемся списке Затем по (Then By) выберите столбец Май.

  5. Оставьте выбранным положение переключателя по возрастанию (Ascending).

  6. Щелкните на кнопке ОК. Теперь строки клиентов Викинг и РИФ поменяются местами, поскольку числа 4000 и 12000 располагаются по возрастанию.

Примечание

Обратите внимание, что при сортировке номера строк не меняются, то есть перемещаются сами данные. Поэтому выполненную операцию сортировки нельзя отключить. Для возврата прежнего расположения строк можно лишь воспользоваться стандартной командой отмены операции. После сохранения файла вернуть прежний порядок строк невозможно.

Упражнение 5. Фильтрация

При печати больших таблиц бывает удобно урезать их путем фильтрации интересующих вас строк. Предположим, что вам понадобилась информация только по трем клиентам, которые в мае имели максимальные объемы сделок. Чтобы выбрать соответствующие строки с помощью автофильтра, выполните следующие шаги.

  1. Щелкните в любой ячейке верхней таблицы листа Формулы.

  2. Выберите команду Данные > Фильтр > Автофильтр (Data > Filter > AutoFilter). В ячейках первой строки таблицы появятся кнопки раскрывающихся списков, обеспечивающих фильтрацию по любому из столбцов (рис. 12.9).

  3. Щелкните на кнопке со стрелкой в ячейке F1 столбца Май.

  4. Выберите в раскрывшемся списке пункт Первые 10... (Top 10...). Откроется окно диалога настройки условия фильтрации, показанное на рис. 12.10.

Фильтры типа Первые 10... позволяют выделить несколько строк с максимальными или минимальными значениями в одном из столбцов таблицы. Левый список окна диалога автофильтра позволяет указать, нужно ли фильтровать максимальные или минимальные значения параметра. Правый список задает единицы измерения (строки таблицы или процент от общего числа строк) для счетчика, расположенного посередине, который задает количество или процентную долю оставляемые строк таблицы.

Рис. 12.9 . Список автофильтра

  5. Введите в счетчик окна диалога автофильтра число 3.

  6. Щелкните на кнопке ОК.

В верхней таблице листа останутся только три строки, имеющие максимальные числа в столбце Май. Обратите внимание, что исчезнувшие строки 2 и 5 не пропали. Они просто скрыты с экрана, о чем говорит отсутствие номеров этих строк. Excel позволяет фильтровать данные сразу по нескольким столбцам. Давайте выделим тех клиентов, которые входили в тройку ведущих по объему сделок как в мае, так и в июне.

  7. Щелкните на стрелке раскрывающегося списка ячейки G1 и выберите пункт Первые 10....

  8. Введите в счетчик открывшегося окна диалога число 3 и щелкните на кнопке ОК. Теперь в таблице останутся только два клиента — Диалог и РИФ.

Рис. 12.10. Окно диалога автофильтра

Примечание

Для отмены фильтрации только по одному из столбцов раскройте список в его первой ячейке и выберите пункт Все (АН). Пункт Условие... (Custom...) этого же списка позволяет настраивать более сложные условия фильтрации. Другие пункты списка оставляют в таблице только те строки, в которых ячейка данного столбца содержит величину, выбранную в этом списке автофильтра.

Стрелки тех списков автофильтра, в которых назначена фильтрация, выделяются синим цветом, чтобы пользователь не забыл о назначенных условиях отображения строк.

  9. Чтобы отменить фильтрацию, выберите команду Данные > Фильтр > Отобразить все (Data > Filter > Show All). На лист вернутся все пять исходных строк таблицы.

  10. Чтобы отключить автофильтр, повторно выберите команду Данные > Фильтрация > Автофильтр (Data > Filter > AutoFilter).

Выбор печатаемых объектов

Кроме фильтров есть и другие способы уменьшить печатаемую область. Непосредственно перед печатью листа можно настроить режим печати заголовков столбцов, скрыть ненужные строки и столбцы, задать диапазон печатаемых ячеек и указать способ разбиения листа Excel на страницы.

Упражнение 6. Разбиение на страницы

При печати больших листов программа сама разбивает их на страницы. Однако такое автоматическое деление может вам не подойти. Лист Формулы фактически содержит две отдельные таблицы, которые при печати располагаются на одной странице. Давайте вставим линию разделения страниц, чтобы эти таблицы печатались на двух отдельных листах бумаги.

  1. Выберите команду Вид > Разметка страницы (View > Page Break Preview). Excel переключится в другой режим просмотра, в котором синие линии показывают границы страниц.

  2. Чтобы иметь возможность ручной настройки страниц, следует отключить режим автоматического масштабирования таблицы. Для этого выберите команду Файл > Параметры страницы и на вкладке Страница открывшегося окна диалога выберите положение переключателя Установить. Затем щелкните на кнопке ОК.

  3. Щелкните на ячейке D7.

  4. Выберите команду Вставка > Разрыв страницы (Insert > Page Break). На листе появятся две новые линии деления на страницы. Одна слева от выделенной ячейки, а вторая — сверху. Теперь лист будет печататься на четырех страницах.

Рис. 12.11. Режим разметки страницы

  5. Чтобы просмотреть полученный вариант деления на страницы, щелкните на кнопке Предварительный просмотр (Print Preview) панели инструментов Стандартная. Затем для перехода по страницам пользуйтесь клавишами Page Up и Page Down.

  6. Щелчком на кнопке Закрыть вернитесь в режим разметки страницы.

В наши планы не входило деление на четыре страницы. Вертикальная синяя линия лишняя, ее нужно убрать.

  7. Поместите указатель на границу столбцов С и D, чтобы его значок превратился в двунаправленную стрелку."

  8. Нажмите кнопку мыши и перетащите линию раздела страниц влево за пределы листа. Подобным перетаскиванием границ можно не только убирать линии раздела, но и перемещать их по листу Excel, изменяя конфигурацию страниц.

Теперь лист разделен на две страницы по горизонтали, как показано на рис. 12.11. Чтобы оценить полученный вариант разбиения листа, снова воспользуйтесь режимом предварительного просмотра.

Примечание

Чтобы убрать все установленные разрывы страниц, щелкните в Пределах листа правой кнопкой мыши и выберите в контекстном меню команду Сброс разрывов страниц (Reset All Page Breaks).

  9. С помощью команды Вид > Обычный (View > Normal) вернитесь в обычный режим.

Обратите внимание, что теперь в листе появились пунктирные линии между парами строк 6—7 и 14—15. Эти линии соответствуют настроенным границам страниц.

Упражнение7. Скрытие строк и столбцов

Скрывать определенные ячейки можно не только с помощью фильтрации. Программа позволяет вручную указывать те столбцы и строки, которые временно нужно сделать невидимыми. Столбцы N и 0 листа Формулы содержат не слишком важную информацию, их не нужно печатать. Скрыв их, вы сможете немного увеличить масштаб печати. Необходимый результат достигается с помощью следующих операций.

  1. Протащите указатель мыши по кнопкам столбцов N и 0, чтобы выделить эти столбцы.

  2. Выберите команду Формат > Столбец > Скрыть (Format > Column > Hide).

Выделенные столбцы временно исчезнут. Подобным способом можно скрыть и ненужные строки.

Примечание

Чтобы вернуть скрытые столбцы или строки, выполните соответственно команды Формат > Столбец > Отобразить (Format > Column > Unhide) или Формат ^ Строка > Отобразить (Format » Row > Unhide).

  3. Щелчком на кнопке Предварительный просмотр (Preview) панели инструментов выведите на экран предполагаемый вид первой страницы.

  4. Щелкните на кнопке Страница. Затем па вкладке Страница открывшегося окна диалога подберите значение счетчика Установить так, чтобы по ширине столбцы листа занимали все пространство страницы. По всей видимости подходящим будет значение 115%.

Упражнение 8. Заголовки строк и столбцов

При печати листа на нескольких страницах заголовки столбцов или строк видны не на каждой из них. В нашем примере на второй странице нет названий месяцев. В такой ситуации полезно дублировать заголовки. Для этого выполните следующие шаги.

  1. Выберите команду Файл > Параметры страницы.

  2. Разверните вкладку Лист (Sheet).

  3. Щелкните на кнопке в правой части поля сквозные строки (Rows To Repeat At Top), чтобы свернуть окно диалога и открыть доступ к ячейкам листа.

  4. Щелчком на кнопке первой строки листа выделите ее.

  5. Повторно щелкните на кнопке окна диалога, чтобы развернуть его до прежних размеров (рис. 12.12).

Рис. 12.12. Настройка автоповтора заголовков

Поле сквозные столбцы (Columns To Repeat At Left) вкладки Лист того же окна диалога дает возможность указать столбцы заголовков, которые должны повторяться в левой части каждой страницы. Флажки раздела Печать (Print) этой вкладки добавляют линии раздела ячеек, нумерацию ячеек, включают режимы черно-белой и черновой печати. В разделе Последовательность вывода страниц (Page Order) можно указать способ сортировки страниц при печати многостраничных таблиц.

  6. Щелкните на кнопке ОК. Теперь названия месяцев будут выводиться на обеих страницах.

Упражнение 9. Задание диапазона ячеек

Чтобы распечатать только часть таблицы, не обязательно фильтровать ее или скрывать строки и столбцы. Можно просто указать диапазон тех ячеек, которые должны быть напечатаны. Обратите внимание, что на втором листе между заголовками столбцов и числами таблицы имеется большой пропуск. Давайте устраним его, исключив из диапазона печати пустые строки 7—9.

  1. Выделите строки с 1 по 6.

  2. Нажмите клавишу Ctrl и протащите указатель по кнопкам строк 10—14, чтобы добавить их к имеющемуся выделению, как показано на рис. 12.13.

  3. Выберите команду Файл > Область печати > Задать (File > Print Area >Set Print Area). Теперь будут печататься только выделенные строки. Проверьте это в режиме предварительного просмотра.

Рис. 12.13. Задание диапазона печати

Примечание

Если после выполнения шага 3 вы раскроете вкладку Лист окна диалога Параметры страницы, то увидите в поле Выводить на печать диапазон (Print Area) ссылку 1:6;10:14, которая соответствует строкам, выделенным на шагах 1 и 2. То есть диапазон печати можно задавать и с помощью этого поля окна диалога Параметры страницы. Для сброса установленного диапазона печати достаточно выбрать команду Файл > Область печати > Убрать (File > Print Area > Clear Print Area).

Выполненные операции завершают настройку параметров печати листа Формулы. Но кроме таблицы нужно распечатать диаграмму, представляющую данные в графической форме. В следующем упражнении вы настроите параметры листа Диаграмма и распечатаете ее вместе с таблицей исходных данных.

Упражнение 10. Настройка диаграмм

Листы, целиком занятые диаграммами, имеют те же параметры печати, что и стандартные. Однако вкладка Лист окна диалога Параметры страницы для этих листов заменена вкладкой Диаграмма (Chart).

  1. Щелкните на корешке листа Диаграмма.

  2. Выберите команду Файл > Параметры страницы.

  3. Раскройте вкладку Диаграмма, показанную на рис. 12.14.

Рис. 12.14. Параметры печати диаграммы

  4. Чтобы диаграмма занимала весь лист целиком, выберите положение переключателя уместить на странице (Scale To Fit Page).

Примечание

Если диаграмма будет распечатываться на черно-белом принтере, установите флажок черно-белая (Print in black and white).

  5. Щелкните на кнопке ОК.

Осталось только вывести листы на принтер. Для этого выполните следующие действия.

  6. Нажмите клавишу Ctrl и, не отпуская ее, щелкните на корешке листа Формулы. Активным останется лист Диаграмма, но корешок Формулы станет белым, что указывает на выделенный статус листа. Теперь с помощью одной операции печати можно распечатать сразу два листа.

  7. Выберите команду Файл > Печать (File > Print) или щелкните в режиме предварительного просмотра на кнопке Печать (Print) панели инструментов. Откроется окно диалога, показанное на рис. 12.15. Оно предлагает дополнительные способы задания диапазона печати.

Примечание

Чтобы выделить несколько смежных листов, щелкните на корешке первого из них, нажмите клавишу Shift и, не отпуская ее, щелкните на корешке последнего листа выделяемой группы.

Рис. 12.15. Печать листов

  8. Убедитесь, что в разделе Печатать (Print Range) выбрано положение переключателя все (All).

  9. Если вы хотите напечатать только некоторые страницы, выберите положение переключателя страницы (Page(s)) и введите необходимые номера в счетчики с (From) и по (То).

  10. Выберите положение выделенные листы (Active Sheets) переключателя Вывести на печать (Print What).

Положение всю книгу (Entire Workbook) этого переключателя обеспечивает печать всех листов, а выделенный диапазон (Selection) — только выделенных ячеек.

  11. В счетчик Число копий (Number Of Copies) введите требуемое число копий.

  12. В раскрывающемся списке Имя (Name) выберите нужный принтер.

  13. Щелкните на кнопке ОК.

Примечание

Чтобы быстро распечатать одну копию выделенных листов на стандартном принтере, достаточно щелкнуть на кнопке Печать (Print) панели инструментов Стандартная.

Контрольное упражнение

Если, изучая упражнения этого занятия, вы были достаточно внимательны, то без труда сможете выполнить проверочное задание.

  1. Откройте файл Электронная таблица,xls.

  2. Разверните лист Расходы.

  3. Задайте книжную ориентацию страницы.

  4. Установите поля сверху и снизу по 5 см, а справа и слева по 3 см.

  5. Отведите 2 см под верхний колонтитул и 3 см под нижний.

    • Как установить высоту верхнего колонтитула 2 см, а нижнего — 3 см?

  6. В верхний колонтитул добавьте название файла, название листа и номер страницы.

  7. Настройте параметры листа так, чтобы нумерация страниц начиналась с 20.

    • Где устанавливается номер первой страницы?

  8. В нижний колонтитул вставьте дату и время печати документа.

  9. Рассортируйте строки по убыванию чисел в столбце А.

  10. Скройте столбцы Б и F, являющиеся дубликатами столбцов В и С.

    • Как распечатать лист без столбцов Е и F, не скрывая их?

  11. Задайте такое разбиение на страницы, чтобы на первой из них печатались данные с января по апрель, а на второй — оставшиеся столбцы.

  12. Задайте режим повторения заголовков строк на всех страницах.

  13. Скройте строку 1, так как теперь введенный в ней заголовок делится между двумя страницами.

  14. Добавьте в верхний колонтитул текст заголовка таблицы, скрытого на предыдущем шаге.

  15. Проверьте правильность форматирования страниц в режиме предварительного просмотра.

  16. Настройте параметры печати листа Календарь по своему усмотрению.

  17. Выделите листы Расходы и Календарь.

  18. Распечатайте оба листа в двух экземплярах.

Подведение итогов

В упражнениях этого занятия были рассмотрены вопросы выбора диапазона печатаемых ячеек, настройки параметров страницы и формирования схемы разбиения листа Excel на страницы. Вы научились фильтровать и сортировать строки, скрывать ячейки, дублировать заголовки таблиц. Наконец, вы теперь умеете под- ' гонять размеры выводимой области под формат страницы, печатать одновремен- ' но несколько листов в нескольких экземплярах.

Самым полным справочником по всем возможностям, предоставляемым программой Excel 2000, является книга Б. Карпова «Microsoft Excel 2002: справочник» («Питер», 2001).

Это занятие завершает серию упражнений, посвященных описанию второго приложения комплекта Microsoft Office XP. Три следующих занятия описывают программу PowerPoint, предназначенную для организации презентаций.


Занятие №12

Подготовка листов Excel к печати

ТЕМА ЗАНЯТИЯ

Вы уже умеете размещать в ячейках Excel числовые данные, выполнять расчеты и оформлять результаты в виде диаграмм. Осталось научиться распечатывать полученные документы. На занятии рассматриваются следующие операции, помогающие подготовить листы Excel к печати:

  • ориентация страницы;

  • настройка полей;

  • добавление колонтитулов;

  • сортировка данных;

  • фильтрация;

  • отображение заголовков строк и столбцов на всех страницах;

  • скрытие ячеек и листов;

  • разбиение на страницы.

Чтобы быстро распечатать лист Excel, достаточно щелкнуть на кнопке Печать (Print) панели инструментов Стандартная. Однако результат этой операции, скорее всего, не удовлетворит вас. Он хорош для вывода черновиков, но совершенно не подходит для печати чистовых документов, которые должны быть хорошо оформлены и не терпят присутствия излишней информации. Поэтому перед окончательной печатью листов Excel нужно настроить масштаб и поля страниц, отсортировать данные таблиц, выделить диапазон печатаемых ячеек, указать способ расположения таблиц и диаграмм и выполнить некоторые другие операции.


Компоновка страниц

В целом настройка параметров печати в Excel похожа на аналогичную операцию в Word. Но листы Excel имеют свою специфику. Удобно, чтобы табличные данные листа помещались на одной странице, поэтому требуется настройка масштаба печати. Широкие листы принято выводить в альбомной ориентации, а длинные таблицы — в портретной. Если в Word параметры страницы, как правило, назначаются сразу всему документу, то в Excel они настраиваются отдельно для каждого листа.


Упражнение 1. Ориентация и масштаб страницы

Давайте продолжим работу с файлом Электронная таблица.х1s и распечатаем некоторые из ее листов. В этом упражнении выполняется первый этап подготовки к печати — настройка ориентации страницы и масштаба выводимого листа.

  1. Откройте файл Электронная таблица.xls.

  2. Разверните лист Формулы, щелкнув на его корешке.

В таблице этого листа есть столбцы только для первых шести месяцев. Давайте расширим таблицу так, чтобы в ней разместились данные для всех 12 месяцев года. Это позволит научиться печатать широкие таблицы, не помещающиеся на лист целиком.

  3. Выделите ячейки B1:G14 и нажатием клавиш Ctrl+C скопируйте их в буфер обмена.

  4. Выберите команду Вставка > Скопированные ячейки (Insert > Copied Cells), чтобы дублировать ячейки, выделенные на шаге 3.

  5. В открывшемся окне диалога выберите положение переключателя Диапазон со сдвигом вправо (Shift Cells Right), а затем щелкните на кнопке ОК. Ячейки, выделенные на шаге 3, будут дублированы с добавлением новых столбцов.

  6. Теперь следует скорректировать заголовки столбцов. Для этого щелкните на ячейке В1 и протащите маркер нижнего левого угла рамки вправо, чтобы рамка охватила диапазон В1:М1. Excel автоматически сгенерирует последовательность названий месяцев.

  7. В столбце G остались пустые ячейки. Чтобы заполнить их соответствующими формулами расчета прироста продаж, выделите группу F10:Fl4, скопируйте ее, щелкните на ячейке G10 правой кнопкой мыши и выберите команду Вставить. Тенерь лист будет выглядеть так, как показано на рис. 12.1.

Рис. 12.1. Обновленный лист Формулы

  8. Выберите команду Файл > Параметры страницы (File > Print Setup).

  9. Разверните в открывшемся окне диалога вкладку Страница (Page), показанную на рис. 12.2.

Рис. 12.2. Настройка ориентации страницы и масштаба

Рис. 12.3. Таблица в масштабе 100 %

  10. Выберите положение переключателя альбомная (Landscape).

  11. Чтобы увидеть предполагаемое размещение чисел на странице, щелкните на кнопке Просмотр (Print Preview). Если выбран стандартный размер бумаги 4юрмата А4, то окажется, что на страницу не влезают все столбцы (рис. 12.3).

  12. Нажмите клавишу Page Down и вы увидите, что ячейки крайнего правого столбца перенесены на вторую страницу. Это неудобно. Следует изменить масштаб, чтобы все столбцы таблицы по ширине вписывались в одну страницу.

Примечание

В полученной таблице данные столбцов H-L повторяют числа столбцов B-G. Если хотите, измените величины в некоторых ячейках. В упражнениях этого занятия конкретные числовые значения ячеек несущественны.

  13. Щелкните на кнопке Страница (Setup) панели инструментов, чтобы вернуться в окно диалога Параметры страницы (Page Setup).

Раздел Масштаб (Scaling) этого окна диалога позволяет уменьшать или увеличивать печатаемые объекты. С помощью счетчика установить (Adjust To) можно выбрать любой масштаб, рассчитываемый в процентах от исходного размера страницы. (Не забудьте при этом выбрать соответствующее положение переключателя.) Можно поступить и по-другому. Excel умеет сам подгонять размер таблицы под площадь страницы.

Примечание

Счетчики, расположенные в строке Разместить..., позволяют указать инструменту автоматического масштабирования, какое число страниц должна занимать таблица по ширине и высоте.

  14. Выберите положение переключателя Разместить... (Fit To) и оставьте в обоих счетчиках, соответствующих этому положению, числа 1.

  15. Щелкните на кнопке ОК. Теперь вся таблица помещается на одну страницу. Если вы снова щелкнете на кнопке Страница, то увидите в счетчике установить величину 96%. Это тот масштаб, который был выбран программой Excel для печати листа Формулы. При необходимости можете скорректировать его.


Упражнение 2. Настройка полей

Поля формируют пустую рамку вокруг информативной области страницы. Уменьшая их, можно немного увеличить размер печатаемой таблицы.

  1. Снова щелкните на кнопке Страница.

  2. В окне диалога Параметры страницы раскройте вкладку Поля (Margins), показанную на рис. 12.4.

Рис. 12.4. Настройка полей

  3. Уменьшите значение счетчика левое (Left) до 1 см.

  4. Точно так же, до 1 см, уменьшите значение счетчика правое (Right).

  5. Таблица листа Формулы невелика по высоте. Давайте напечатаем ее посередине страницы. Для этого установите флажок вертикально (Vertically).

  6. Щелкните на кнопке ОК.

Ширина области печати увеличилась. Если снова посмотреть на вкладку Страница окна диалога Параметры страницы, то можно заметить, что режим автоматической настройки размеров сразу же увеличил масштаб, подогнав таблицу под новый размер области печати.

  7. Щелчком на кнопке Закрыть (Close) выйдите из режима предварительного просмотра.


Упражнение 3. Добавление колонтитулов

Колонтитулы позволяют добавлять в нижнюю и верхнюю часть страниц заголовки и описания, дублирующиеся на всех страницах. Если таблица длинная, в колонтитуле удобно разместить ее название, номера страниц, название файла документа и листа, на котором размещена таблица.

  1. Выберите команду Вид > Колонтитулы (View > Header And Footer). Откроется вкладка Колонтитулы (Header/Footer) окна диалога Параметры страницы, показанная на рис. 12.5. В раскрывающихся списках Верхний колонтитул (Header) и Нижний колонтитул (Footer) можно выбрать один из стандартных вариантов оформления колонтитулов.

Рис. 12.5. Настройка колонтитулов

  2. Раскройте список Верхний колонтитул и выберите пункт Формулы; Страница 1 (Формулы; Page 1). Этот вариант добавляет в верхнюю часть каждой страницы название листа с исходными данными и порядковый номер страницы. В верхней части вкладки Колонтитулы появится пример оформления верхнего колонтитула.

Примечание

Если нужно, чтобы нумерация страниц начиналась не с единицы, введите номер для первой страницы в поле Номер первой страницы (First Page Number) вкладки Страница того же окна диалога.

Если стандартные схемы компоновки колонтитулов вас не устраивают, воспользуйтесь кнопками, расположенными в средней части окна диалога.

  3. Чтобы настроить нижний колонтитул, щелкните на кнопке Создать нижний колонтитул (Custom Footer). Открывшееся окно диалога (рис. 12.6) имеет три списка и несколько кнопок. С помощью этих кнопок можно размещать различные объекты в списках, задающих содержимое левого края колонтитула, его центральной части и правого края.

  4. Щелкните в списке Слева (Left Section).

Рис. 12.6. форматирование колонтитула

  5. Щелкните в центральной части окна на четвертой справа кнопке. В списке появится ссылка &[Файл] (&[File]), генерирующая названия файла документа.

  6. Введите перед ней текст Имя файла:.

  7. Щелкните в списке Справа (Right Section) и введите текст Время создания :.

  8. Щелкните на кнопке с календарем, поместив в колонтитул ссылку на дату &[Дата] (&[Date]).

  9. Нажмите клавишу Пробел и щелкните на кнопке с циферблатом часов, кото рая добавляет ссылку на время печати документа &[Время] (&[Time]).

  10. Закройте окно диалога щелчком на кнопке ОК.

Примечание

Высота нижнего и верхнего колонтитулов настраивается на вкладке Поля окна диалога Параметры страницы.

Теперь в нижний колонтитул будет выводиться имя файла таблицы, а также дата и время печати файла с соответствующими подписями. Если вы хотите увидеть страницу с добавленными колонтитулами, выберите команду Файл > Предварительный просмотр (File > Print Preview).


Сортировка и фильтрация

Сортировка позволяет упорядочить строки таблицы в порядке возрастания или убывания данных одного или нескольких столбцов таблицы. Фильтрация дает возможность временно убрать из таблицы ненужные строки, не стирая их.


Упражнение 4. Сортировка данных

Сортировать данные приходится не только при печати документа. Размещение строк таблицы в порядке возрастания одного из параметров помогает искать нужные записи. Печать чистового варианта документа — подходящий момент для того, чтобы упорядочить данные, если они вводились в спешке и оказались расположенными не должным образом. Давайте рассортируем клиентов в верхней таблице листа в порядке увеличения продаж в апреле месяце.

  1. Щелкните на любой ячейке столбца Апрель верхней таблицы.

  2. Щелкните на кнопке Сортировка по возрастанию (Sort Ascending) панели инструментов Стандартная. Расстановка строк поменяется так, что числа в столбце Апрель будут увеличиваться сверху вниз (рис. 12.7).

Рис. 12.7. Таблица упорядочена по возрастанию продаж в апреле

Сравните заголовки строк верхней таблицы с заголовками нижней и вы увидите, что переставлены строки целиком, а не только ячейки столбца Апрель. (Раньше порядок заголовков в двух таблицах совпадал.) Для сортировки таблицы по убыванию следует щелкнуть на кнопке Сортировка по убыванию (Sort Descending).

Объемы продаж клиентам РИФ и Викинг в апреле совпадают (они равны 11000). Если таких совпадающих значений много, приходится дополнительно упорядочивать таблицу по второму признаку. Например, алфавитный список покупателей следует упорядочить сначала по столбцу с фамилиями, а затем по столбцу с именами, чтобы информация о людях с одинаковыми фамилиями располагалась по ал4)авиту имен. Чтобы дополнительно упорядочить таблицу по возрастанию, продаж в мае (при условии равенства продаж в апреле), выполните следующие действия.

  3. Выберите команду Данные > Сортировка (Data > Sort). Откроется окно диалога, показанное на рис. 12.8. В разделе Сортировать по (Sort By) уже введено условие сортировки по возрастанию значений столбца Апрель, которое было назначено на шаге 2.

Рис. 12.8. Настройка условия сортировки

  4. В раскрывающемся списке Затем по (Then By) выберите столбец Май.

  5. Оставьте выбранным положение переключателя по возрастанию (Ascending).

  6. Щелкните на кнопке ОК. Теперь строки клиентов Викинг и РИФ поменяются местами, поскольку числа 4000 и 12000 располагаются по возрастанию.

Примечание

Обратите внимание, что при сортировке номера строк не меняются, то есть перемещаются сами данные. Поэтому выполненную операцию сортировки нельзя отключить. Для возврата прежнего расположения строк можно лишь воспользоваться стандартной командой отмены операции. После сохранения файла вернуть прежний порядок строк невозможно.


Упражнение 5. Фильтрация

При печати больших таблиц бывает удобно урезать их путем фильтрации интересующих вас строк. Предположим, что вам понадобилась информация только по трем клиентам, которые в мае имели максимальные объемы сделок. Чтобы выбрать соответствующие строки с помощью автофильтра, выполните следующие шаги.

  1. Щелкните в любой ячейке верхней таблицы листа Формулы.

  2. Выберите команду Данные > Фильтр > Автофильтр (Data > Filter > AutoFilter). В ячейках первой строки таблицы появятся кнопки раскрывающихся списков, обеспечивающих фильтрацию по любому из столбцов (рис. 12.9).

  3. Щелкните на кнопке со стрелкой в ячейке F1 столбца Май.

  4. Выберите в раскрывшемся списке пункт Первые 10... (Top 10...). Откроется окно диалога настройки условия фильтрации, показанное на рис. 12.10.

Фильтры типа Первые 10... позволяют выделить несколько строк с максимальными или минимальными значениями в одном из столбцов таблицы. Левый список окна диалога автофильтра позволяет указать, нужно ли фильтровать максимальные или минимальные значения параметра. Правый список задает единицы измерения (строки таблицы или процент от общего числа строк) для счетчика, расположенного посередине, который задает количество или процентную долю оставляемые строк таблицы.

Рис. 12.9 . Список автофильтра

  5. Введите в счетчик окна диалога автофильтра число 3.

  6. Щелкните на кнопке ОК.

В верхней таблице листа останутся только три строки, имеющие максимальные числа в столбце Май. Обратите внимание, что исчезнувшие строки 2 и 5 не пропали. Они просто скрыты с экрана, о чем говорит отсутствие номеров этих строк. Excel позволяет фильтровать данные сразу по нескольким столбцам. Давайте выделим тех клиентов, которые входили в тройку ведущих по объему сделок как в мае, так и в июне.

  7. Щелкните на стрелке раскрывающегося списка ячейки G1 и выберите пункт Первые 10....

  8. Введите в счетчик открывшегося окна диалога число 3 и щелкните на кнопке ОК. Теперь в таблице останутся только два клиента — Диалог и РИФ.

Рис. 12.10. Окно диалога автофильтра

Примечание

Для отмены фильтрации только по одному из столбцов раскройте список в его первой ячейке и выберите пункт Все (АН). Пункт Условие... (Custom...) этого же списка позволяет настраивать более сложные условия фильтрации. Другие пункты списка оставляют в таблице только те строки, в которых ячейка данного столбца содержит величину, выбранную в этом списке автофильтра.

Стрелки тех списков автофильтра, в которых назначена фильтрация, выделяются синим цветом, чтобы пользователь не забыл о назначенных условиях отображения строк.

  9. Чтобы отменить фильтрацию, выберите команду Данные > Фильтр > Отобразить все (Data > Filter > Show All). На лист вернутся все пять исходных строк таблицы.

  10. Чтобы отключить автофильтр, повторно выберите команду Данные > Фильтрация > Автофильтр (Data > Filter > AutoFilter).


Выбор печатаемых объектов

Кроме фильтров есть и другие способы уменьшить печатаемую область. Непосредственно перед печатью листа можно настроить режим печати заголовков столбцов, скрыть ненужные строки и столбцы, задать диапазон печатаемых ячеек и указать способ разбиения листа Excel на страницы.


Упражнение 6. Разбиение на страницы

При печати больших листов программа сама разбивает их на страницы. Однако такое автоматическое деление может вам не подойти. Лист Формулы фактически содержит две отдельные таблицы, которые при печати располагаются на одной странице. Давайте вставим линию разделения страниц, чтобы эти таблицы печатались на двух отдельных листах бумаги.

  1. Выберите команду Вид > Разметка страницы (View > Page Break Preview). Excel переключится в другой режим просмотра, в котором синие линии показывают границы страниц.

  2. Чтобы иметь возможность ручной настройки страниц, следует отключить режим автоматического масштабирования таблицы. Для этого выберите команду Файл > Параметры страницы и на вкладке Страница открывшегося окна диалога выберите положение переключателя Установить. Затем щелкните на кнопке ОК.

  3. Щелкните на ячейке D7.

  4. Выберите команду Вставка > Разрыв страницы (Insert > Page Break). На листе появятся две новые линии деления на страницы. Одна слева от выделенной ячейки, а вторая — сверху. Теперь лист будет печататься на четырех страницах.

Рис. 12.11. Режим разметки страницы

  5. Чтобы просмотреть полученный вариант деления на страницы, щелкните на кнопке Предварительный просмотр (Print Preview) панели инструментов Стандартная. Затем для перехода по страницам пользуйтесь клавишами Page Up и Page Down.

  6. Щелчком на кнопке Закрыть вернитесь в режим разметки страницы.

В наши планы не входило деление на четыре страницы. Вертикальная синяя линия лишняя, ее нужно убрать.

  7. Поместите указатель на границу столбцов С и D, чтобы его значок превратился в двунаправленную стрелку."

  8. Нажмите кнопку мыши и перетащите линию раздела страниц влево за пределы листа. Подобным перетаскиванием границ можно не только убирать линии раздела, но и перемещать их по листу Excel, изменяя конфигурацию страниц.

Теперь лист разделен на две страницы по горизонтали, как показано на рис. 12.11. Чтобы оценить полученный вариант разбиения листа, снова воспользуйтесь режимом предварительного просмотра.

Примечание

Чтобы убрать все установленные разрывы страниц, щелкните в Пределах листа правой кнопкой мыши и выберите в контекстном меню команду Сброс разрывов страниц (Reset All Page Breaks).

  9. С помощью команды Вид > Обычный (View > Normal) вернитесь в обычный режим.

Обратите внимание, что теперь в листе появились пунктирные линии между парами строк 6—7 и 14—15. Эти линии соответствуют настроенным границам страниц.


Упражнение7. Скрытие строк и столбцов

Скрывать определенные ячейки можно не только с помощью фильтрации. Программа позволяет вручную указывать те столбцы и строки, которые временно нужно сделать невидимыми. Столбцы N и 0 листа Формулы содержат не слишком важную информацию, их не нужно печатать. Скрыв их, вы сможете немного увеличить масштаб печати. Необходимый результат достигается с помощью следующих операций.

  1. Протащите указатель мыши по кнопкам столбцов N и 0, чтобы выделить эти столбцы.

  2. Выберите команду Формат > Столбец > Скрыть (Format > Column > Hide).

Выделенные столбцы временно исчезнут. Подобным способом можно скрыть и ненужные строки.

Примечание

Чтобы вернуть скрытые столбцы или строки, выполните соответственно команды Формат > Столбец > Отобразить (Format > Column > Unhide) или Формат ^ Строка > Отобразить (Format » Row > Unhide).

  3. Щелчком на кнопке Предварительный просмотр (Preview) панели инструментов выведите на экран предполагаемый вид первой страницы.

  4. Щелкните на кнопке Страница. Затем па вкладке Страница открывшегося окна диалога подберите значение счетчика Установить так, чтобы по ширине столбцы листа занимали все пространство страницы. По всей видимости подходящим будет значение 115%.


Упражнение 8. Заголовки строк и столбцов

При печати листа на нескольких страницах заголовки столбцов или строк видны не на каждой из них. В нашем примере на второй странице нет названий месяцев. В такой ситуации полезно дублировать заголовки. Для этого выполните следующие шаги.

  1. Выберите команду Файл > Параметры страницы.

  2. Разверните вкладку Лист (Sheet).

  3. Щелкните на кнопке в правой части поля сквозные строки (Rows To Repeat At Top), чтобы свернуть окно диалога и открыть доступ к ячейкам листа.

  4. Щелчком на кнопке первой строки листа выделите ее.

  5. Повторно щелкните на кнопке окна диалога, чтобы развернуть его до прежних размеров (рис. 12.12).

Рис. 12.12. Настройка автоповтора заголовков

Поле сквозные столбцы (Columns To Repeat At Left) вкладки Лист того же окна диалога дает возможность указать столбцы заголовков, которые должны повторяться в левой части каждой страницы. Флажки раздела Печать (Print) этой вкладки добавляют линии раздела ячеек, нумерацию ячеек, включают режимы черно-белой и черновой печати. В разделе Последовательность вывода страниц (Page Order) можно указать способ сортировки страниц при печати многостраничных таблиц.

  6. Щелкните на кнопке ОК. Теперь названия месяцев будут выводиться на обеих страницах.


Упражнение 9. Задание диапазона ячеек

Чтобы распечатать только часть таблицы, не обязательно фильтровать ее или скрывать строки и столбцы. Можно просто указать диапазон тех ячеек, которые должны быть напечатаны. Обратите внимание, что на втором листе между заголовками столбцов и числами таблицы имеется большой пропуск. Давайте устраним его, исключив из диапазона печати пустые строки 7—9.

  1. Выделите строки с 1 по 6.

  2. Нажмите клавишу Ctrl и протащите указатель по кнопкам строк 10—14, чтобы добавить их к имеющемуся выделению, как показано на рис. 12.13.

  3. Выберите команду Файл > Область печати > Задать (File > Print Area >Set Print Area). Теперь будут печататься только выделенные строки. Проверьте это в режиме предварительного просмотра.

Рис. 12.13. Задание диапазона печати

Примечание

Если после выполнения шага 3 вы раскроете вкладку Лист окна диалога Параметры страницы, то увидите в поле Выводить на печать диапазон (Print Area) ссылку 1:6;10:14, которая соответствует строкам, выделенным на шагах 1 и 2. То есть диапазон печати можно задавать и с помощью этого поля окна диалога Параметры страницы. Для сброса установленного диапазона печати достаточно выбрать команду Файл > Область печати > Убрать (File > Print Area > Clear Print Area).

Выполненные операции завершают настройку параметров печати листа Формулы. Но кроме таблицы нужно распечатать диаграмму, представляющую данные в графической форме. В следующем упражнении вы настроите параметры листа Диаграмма и распечатаете ее вместе с таблицей исходных данных.


Упражнение 10. Настройка диаграмм

Листы, целиком занятые диаграммами, имеют те же параметры печати, что и стандартные. Однако вкладка Лист окна диалога Параметры страницы для этих листов заменена вкладкой Диаграмма (Chart).

  1. Щелкните на корешке листа Диаграмма.

  2. Выберите команду Файл > Параметры страницы.

  3. Раскройте вкладку Диаграмма, показанную на рис. 12.14.

Рис. 12.14. Параметры печати диаграммы

  4. Чтобы диаграмма занимала весь лист целиком, выберите положение переключателя уместить на странице (Scale To Fit Page).

Примечание

Если диаграмма будет распечатываться на черно-белом принтере, установите флажок черно-белая (Print in black and white).

  5. Щелкните на кнопке ОК.

Осталось только вывести листы на принтер. Для этого выполните следующие действия.

  6. Нажмите клавишу Ctrl и, не отпуская ее, щелкните на корешке листа Формулы. Активным останется лист Диаграмма, но корешок Формулы станет белым, что указывает на выделенный статус листа. Теперь с помощью одной операции печати можно распечатать сразу два листа.

  7. Выберите команду Файл > Печать (File > Print) или щелкните в режиме предварительного просмотра на кнопке Печать (Print) панели инструментов. Откроется окно диалога, показанное на рис. 12.15. Оно предлагает дополнительные способы задания диапазона печати.

Примечание

Чтобы выделить несколько смежных листов, щелкните на корешке первого из них, нажмите клавишу Shift и, не отпуская ее, щелкните на корешке последнего листа выделяемой группы.

Рис. 12.15. Печать листов

  8. Убедитесь, что в разделе Печатать (Print Range) выбрано положение переключателя все (All).

  9. Если вы хотите напечатать только некоторые страницы, выберите положение переключателя страницы (Page(s)) и введите необходимые номера в счетчики с (From) и по (То).

  10. Выберите положение выделенные листы (Active Sheets) переключателя Вывести на печать (Print What).

Положение всю книгу (Entire Workbook) этого переключателя обеспечивает печать всех листов, а выделенный диапазон (Selection) — только выделенных ячеек.

  11. В счетчик Число копий (Number Of Copies) введите требуемое число копий.

  12. В раскрывающемся списке Имя (Name) выберите нужный принтер.

  13. Щелкните на кнопке ОК.

Примечание

Чтобы быстро распечатать одну копию выделенных листов на стандартном принтере, достаточно щелкнуть на кнопке Печать (Print) панели инструментов Стандартная.


Контрольное упражнение

Если, изучая упражнения этого занятия, вы были достаточно внимательны, то без труда сможете выполнить проверочное задание.

  1. Откройте файл Электронная таблица,xls.

  2. Разверните лист Расходы.

  3. Задайте книжную ориентацию страницы.

  4. Установите поля сверху и снизу по 5 см, а справа и слева по 3 см.

  5. Отведите 2 см под верхний колонтитул и 3 см под нижний.

    • Как установить высоту верхнего колонтитула 2 см, а нижнего — 3 см?

  6. В верхний колонтитул добавьте название файла, название листа и номер страницы.

  7. Настройте параметры листа так, чтобы нумерация страниц начиналась с 20.

    • Где устанавливается номер первой страницы?

  8. В нижний колонтитул вставьте дату и время печати документа.

  9. Рассортируйте строки по убыванию чисел в столбце А.

  10. Скройте столбцы Б и F, являющиеся дубликатами столбцов В и С.

    • Как распечатать лист без столбцов Е и F, не скрывая их?

  11. Задайте такое разбиение на страницы, чтобы на первой из них печатались данные с января по апрель, а на второй — оставшиеся столбцы.

  12. Задайте режим повторения заголовков строк на всех страницах.

  13. Скройте строку 1, так как теперь введенный в ней заголовок делится между двумя страницами.

  14. Добавьте в верхний колонтитул текст заголовка таблицы, скрытого на предыдущем шаге.

  15. Проверьте правильность форматирования страниц в режиме предварительного просмотра.

  16. Настройте параметры печати листа Календарь по своему усмотрению.

  17. Выделите листы Расходы и Календарь.

  18. Распечатайте оба листа в двух экземплярах.


Подведение итогов

В упражнениях этого занятия были рассмотрены вопросы выбора диапазона печатаемых ячеек, настройки параметров страницы и формирования схемы разбиения листа Excel на страницы. Вы научились фильтровать и сортировать строки, скрывать ячейки, дублировать заголовки таблиц. Наконец, вы теперь умеете под- ' гонять размеры выводимой области под формат страницы, печатать одновремен- ' но несколько листов в нескольких экземплярах.

Самым полным справочником по всем возможностям, предоставляемым программой Excel 2000, является книга Б. Карпова «Microsoft Excel 2002: справочник» («Питер», 2001).

Это занятие завершает серию упражнений, посвященных описанию второго приложения комплекта Microsoft Office XP. Три следующих занятия описывают программу PowerPoint, предназначенную для организации презентаций.


Занятие №13

ЧАСТЬ IV

PowerPoint

PowerPoint XP — приложение для подготовки презентаций, слайды которых выносятся на суд общественности в виде распечатанных графических материалов или посредством демонстрации электронного слайд-фильма. Создав или импортировав содержание доклада, вы сможете быстро украсить его рисунками, дополнить диаграммами и анимационными эффектами. Элементы навигации дают возможность генерировать интерактивные презентации, управляемые самим зрителем.

Структура презентации

ТЕМА ЗАНЯТИЯ

Приложение PowerPoint — лидер среди систем организации презентации. С его помощью текстовая и числовая информация легко превращается в красочно оформленные слайды и диаграммы. На этом занятии вы научитесь создавать свою презентацию, разрабатывать ее общую компоновку и наполнять слайды содержанием. Вы узнаете о принципах построения презентации и о режимах программы, ускоряющих разработку документа. В упражнениях занятия рассматриваются следующие темы:

  • мастер создания презентации;

  • добавление слайдов;

  • режим слайдов;

  • структура презентации;

  • сортировщик слайдов;

  • шаблон дизайна.

Построение презентации

Программа PowerPoint для многих крупных организаций стала стандартным средством создания презентации, поскольку она направляет действия пользователя момента своего запуска и вплоть до завершения процесса разработки презента. Этот раздел посвящен описанию основных понятий и инструментов PowerPoint. Вы научитесь быстро строить красочные презентации и модифицировать их.

Упражнение 1. Создание презентации

В основе любой презентации лежит набор слайдов, на которых размещаются текст, графики, рисунки. Электронные слайды подобны обычным фотографическим, но издаются гораздо проще. Программа PowerPoint сама запрашивает всю необходимую текстовую и числовую информацию, а также предоставляет множество готовых вариантов дизайна и шаблонов содержания. Сейчас мы воспользуемся одним из таких шаблонов.

Рис. 13.1. Окно диалога PowerPoint

Сразу после запуска PowerPoint появляется окно презентации с первым титульным слайдом; справа в области задач приложения видно окно Создание презентации (New Presentation), показанное на рис. 13.1. Оно позволяет выбрать способ создания документа. Первый раздел Открыть презентацию (Open a Presentation) дает возможность открыть уже существующую презентацию. В разделе Создание (New) перечислены возможные варианты создания новой презентации:

  • Новая презентация (Blank Presentation) без какого-либо форматирования;

  • презентация Из шаблона оформления (From Design Template);

  • презентация Из мастера автосодержания (From AutoContent Wizard) с заранее заданной структурой содержания.

В этом же окне можно выбрать шаблон оформления в разделе Создание с помощью шаблона (New From Template).

Если у вас уже есть тезисы презентации и нужно лишь разместить готовый текст на слайдах и оформить его надлежащим образом, выполните следующие шаги:

  1. Щелкните на пункте Общие шаблоны (General Templates).

  2. Откроется окно диалога Шаблоны (Templates), показанное на рис. 13.2. На вкладке Шаблоны оформления (Design Templates) вы увидите список доступных шаблонов оформления слайдов. Другие вкладки этого окна открывают доступ к иным способам создания презентаций, о которых мы поговорим позже. Щелкните по очереди на значках каждого из шаблонов, чтобы в расположенном справа поле просмотра увидеть примеры оформления презентации.

Рис. 13.2. Окно диалога Шаблоны (Templates)

  3. Дважды, щелкните на значке шаблона Галстук (Dads Tie). Шаблон будет применен к слайду в окне презентации.

Чтобы добавить в окно создания презентации свой собственный шаблон, сохраните его в папке Windows\Application Data\Microson\Templates. Шаблон появится на вкладке Общие (General). Чтобы поместить его на новую вкладку, которая, например, будет содержать все шаблоны вашей фирмы, создайте в указанной папке вложенную папку и переместите туда свой шаблон. Роль шаблона может играть любая презентация, при сохранении которой был выбран тип файла Шаблон презентации (Design Template).

Рис. 13.3. Титульный слайд в обычном режиме просмотра

В поле презентации окажется титульный слайд в режиме структуры с примененным к нему выбранным шаблоном, а в области задач появится окно Разметка слайда (Slide Layout) с набором стандартных авторазметок. Поместив указатель мыши на одном из образцов, вы увидите всплывающую подсказку, характеризующую образец, и треугольник справа от него, скрывающий раскрывающийся список с набором возможных команд.

  4. Щелкните в поле с надписью Заголовок слайда (Click to add title) и введите заголовок презентации. В нашем примере это будет текст План развития.

  5. Чтобы добавить к основному названию небольшое пояснение, щелкните на поле Подзаголовок слайда (Click to add subtitle) и введите подзаголовок Отдел информационных технологий. На рис. 13.3 показан сформированный титульный слайд в окне презентации PowerPoint.

  6. Щелкните на кнопке Сохранить (Save) панели инструментов Стандартная (Standard). Откроется окно сохранения презентации.

  7. В левой части окна щелкните на значке папки Мои документы (My Documents). В поле Имя файла (File Name) введите имя План и щелкните на кнопке Сохранить. Любой файл PowerPoint содержит всю презентацию целиком, поэтому вам не нужно беспокоиться о том, что при демонстрации некоторые слайды могут пропасть.

Упражнение 2. Обычный режим просмотра

PowerPoint позволяет создавать презентации с очень большим количеством слайдов. Чтобы управлять этим огромным объемом ин4юрмации, программа предлагает несколько режимов просмотра:

  • Обычный (Normal View) — режим, появившийся в впервые PowerPoint 2000, — вариант просмотра, объединяющий режимы слайдов, структуры и заметок;

  • Сортировщик слайдов (Slide Sorter View) — режим, демонстрирующий миниатюры всех слайдов, равномерно расположенные в окне просмотра;

  • Слайды (Slide View) — режим, в котором удобно конструировать и корректировать отдельные слайды;

  • Структура (Outline View) — режим, отображающий текстовое содержание презентации и предназначенный для ввода и редактирования текста;

  • Страницы заметок (Notes Page View) — режим, предназначенный для создания заметок, которые помогают докладчику ориентироваться в материале во время ведения презентации.

Рис. 13.4. Кнопки выбора режима просмотра

  1. Переключение из одного режима в другой для первых двух режимов, а также запуск просмотра слайдов осуществляется простым щелчком па одной из трех кнопок, расположенных в левом нижнем углу окна презентации (рис. 13.4).Две кнопки вверху окна обычного режима позволяют переключаться между режимами слайдов и структуры. Переключиться на режим страниц заметок можно из меню Вид > Страницы заметок (View > Notes Page).

  2. Попробуйте по очереди щелкнуть на указанных кнопках, наблюдая за презентацией в одном из режимов просмотра.

  3. 3 Щелкните на средней кнопке вверху окна презентации, чтобы вернуться в обычный режим.

В обычном режиме (см. рис. 13.3), который автоматически включается при создании пустой презентации или презентации на основе шаблона дизайна, окно документа поделено на три области: область слайда, поле структуры и область заметок. Первая из них всегда содержит общий вид текущего слайда. Расположенная слева область структуры презентации является уменьшенной копией режима структуры. В правой нижней части окна презентации находится область заметок. Сюда можно ввести пояснительный текст, который не появляется на самом слайде, но который можно вывести на экран в режиме заметок или, готовя заметки докладчика, распечатать рядом с соответствующим слайдом.

  4. Соотношение размеров областей обычного режима просмотра можно изменить. Для этого поместите указатель мыши на границу между областями, чтобы значок указателя сменился на двунаправленную стрелку, нажмите кнопку мыши и перетащите линию границы. Подобрав нужный размер, отпустите кнопку мыши.

В обычном режиме, как и в большинстве других режимов просмотра, в окне PowerPoint присутствуют три панели инструментов. Вверху расположена панель Стандартная. Ее инструменты выполняют операции открытия и сохранения презентаций, копирования и вставки содержимого, добавления слайдов и объектов. Под ней находится панель инструментов Форматирование (Formatting). Она позволяет изменять шрифт и начертание выделенного текста, форматировать абзацы и списки, настраивать эффекты анимации. О панели инструментов Рисование (Drawing), расположенной в нижней части окна, мы поговорим на следующем занятии.

Упражнение 3. Добавление нового слайда

Сформировав титульный слайд, можно перейти к добавлению других слайдов.

  1. Найдите на панели инструментов Форматирование кнопку Создать слайд (New Slide). Если вы забыли, как выглядит значок этой кнопки, переместите указатель мыши на панель инструментов и задержите его на несколько секунд. Появится экранная подсказка, разъясняющая смысл той кнопки, на которой расположен указатель мыши. Перемещайте указатель по кнопкам и читайте экранные подсказки.

  2. Если кнопки Создать слайд не оказалось в панели инструментов Форматирование, щелкните на маленькой треугольной стрелке, расположенной на правом краю панели. Откроется дополнительная палитра с кнопками (рис. 13.5). Здесь, можно отыскать пропавший инструмент Создать слайд.

  3. Щелкните на кнопке Новый слайд (New Slide). В окне презентации появится незаполненный второй слайд.

Рис. 13.5. Дополнительная палитра кнопок стандартной панели инструментов

  4. В области задач в окне Разметка слайда, показанном на рис. 13.6, PowerPoint предлагает 27 типов стандартных авторазметок, которые способны удовлетворить практически любые потребности разработчиков презентаций.

Авторазметка — это шаблон слайда с заранее размещенными стандартными объектами, такими как заголовок, маркированный список, диаграмма или рисунок.

Рис. 13.6. Окно Разметка слайда с набором авторазметок

После создания слайда на базе авторазметки вам остается лишь щелкать на место заполнителях этих объектов и вводить необходимую информацию.

  5. Просмотрите имеющиеся авторазметки. Для этого воспользуйтесь полосой прокрутки, расположенной в правой части окна.

Примечание

На значках авторазметок заголовки показаны серой полосой, маркированные списки — прямоугольником с тремя пунктами. Диаграммы представлены маленькой гистограммой, рисунки — портретом человечка. Здесьже можно найти миниатюры организационных диаграмм и видеоклипов.

  6. Выберите для второго слайда авторазметку Маркированный список (Bulleted List), щелкнув на ней.

В области структуры презентации появится значок второго слайда, а справа будет виден сам новый слайд с двумя местозаполнителями.

Местозаполнитель представляет собой рамку, заменяющую будущий объект. Внутри рамки содержится текст, предлагающий щелкнуть в области рамки для ввода данных. К примеру, авторазметка Маркированный список содержит два место-заполнителя один для заголовка и второй для маркированного списка (рис. 13.7).

Рис. 13.7. Слайд с маркированным списком

  7. Чтобы добавить заголовок нового слайда, щелкните на местозаполнителе Заголовок слайда (Click to add title). Текст местозаподнителя исчезнет, и вы сможете сразу ввести заголовок. Напечатайте слова Направления развития.

  8. Щелкните на местозаполнителе маркированного списка Текст слайда (Click to add text) и введите первый пункт списка Спутниковая связь. Нажмите клавишу Enter.

  9. В списке появится маркер второго пункта. Не огорчайтесь, если форма маркера вас не устраивает. Позже его можно будет изменить или даже совсем убрать. Введите текст Цифровая телефония. Снова нажмите клавишу Enter и введите слово Интернет.

Упражнение 4. Заметки докладчика

Второй слайд презентации практически готов. Осталось добавить заметки, которые помогут докладчику не растеряться в момент представления планов отделана суд начальства. Каждый слайд презентации имеет особый вид внешнего представления, называемый заметками докладчика. На странице заметок всегда присутствуют два объекта: сам слайд в верхней части страницы и заметки в ее нижней части. Эти заметки не видны на экране в режиме просмотра презентации, они не выводятся на печать вместе со слайдом. Однако, проводя электронную презентацию в локальной сети, докладчик может читать заметки на экране своего компьютера. Кроме того, страницы заметок можно распечатать и пользоваться ими во время доклада.

Чтобы добавить текст заметок, выполните следующие шаги.

  1. В правой нижней области окна презентации найдите местозаполнитель Заметки к слайду (Click to add notes) и щелкните на нем. Введите текст Сделать акцент на применении цифровых технологий связи.

  2. Чтобы увидеть страницу заметок целиком, выберите команду Вид > Страницы заметок. Включится режим страниц заметок (рис. 13.8).

Рис. 13.8. Слайд в режиме просмотра страниц заметок

  3. Выбрав команду Вид > Обычный (View > Normal), вернитесь в обычный режим просмотра.

Обратите внимание, что новый слайд появляется не только в области слайдов. Он представлен и в области структуры презентации. Здесь можно отыскать значок слайда под номером 2, заголовок слайда и все три пункта маркированного списка (рис. 13.9).

Рис. 13.9. Второй слайд презентации в обычном режиме просмотра

  4. Щелчком на кнопке Сохранить панели инструментов Стандартная сохраните текущий вариант презентации.

  5. Щелкните на кнопке с косым крестом в правом верхнем углу окна презентации, чтобы закрыть документ.

Упражнение 5. Режим слайдов

В режиме слайдов отдельный слайд занимает все окно презентации. Это как бы увеличенный вариант области слайда обычного режима просмотра. В режиме слайдов удобно редактировать отдельные объекты, добавлять рисунки и текстовые комментарии. Давайте продолжим построение презентации, созданной в предыдущих упражнениях.

  1. Щелкните на кнопке Открыть (Open) панели инструментов Стандартная.

  2. В окне диалога открытия файла щелкните на папке Мои документы, найдите значок документа План.ррt и дважды щелкните на нем.

Рис. 13.10. Второй слайд в режиме просмотра слайдов

  3. Щелчком на кнопке панели смены режимов включите режим слайдов.

На экране появится первый слайд презентации. Новые слайды в PowerPoint всегда вставляются после текущего. Мы хотим добавить третий слайд, поэтому нужно сделать текущим второй слайд презентации.

  4. Щелкните на кнопке Следующий слайд (Next Slide) полосы прокрутки слайдов. На экране появится второй слайд (рис. 13.10).

  5. Щелкните на кнопке Создать слайд панели инструментов Форматирование.

  6. В окне Разметка слайда щелкните на авторазметке Маркированный список.

  7. Введите заголовок слайда Выставки и конференции. Щелкните на место заполнителе маркированного списка и введите пункты:

Вам пришло в голову, что хорошо бы разделить названия выставок и конференций и разместить их в отдельных списках. Но дополнительный слайд кажется вам лишним, а на текущем слайде все место занято имеющимся списком. Что делать?

PowerPoint позволяет оперативно изменять разметку любого слайда. Если вы решили удобавить на слайд еще один список или дополнительный рисунок, бывает достаточно просто сменить авторазметку, хотя иногда приходится добавлять недостающие объекты вручную.

Рис 13.11. Изменение разметки второго слайда

  8. В окне Разметка слайда щелкните на авторазметке Текст в две колонки (2 Column Text).

  9. Введите в появившийся справа дополнительный маркированный список следующие пункты:

  • История телефонной связи;

  • Опыт зарубежных филиалов;

  • Исследования отечественного рынка.

  10. Выберите в меню Вставка (Insert) команду Надпись (Text Box).

  11. Ниже маркированных списков растяните мытью рамку текстового поля. Введите текст Сроки проведения: с мая по ноябрь.

Рис. 13.12. Третий слайд презентации

  12. Чтобы отцентрировать текст, щелкните в панели инструментов Форматирование на кнопке По центру (Center). Окончательный вид третьего слайда показан на рис. 13.12.

Для перехода от слайда к слайду в режиме слайдов пользуйтесь вертикальной полосой прокрутки. Если выбранный масштаб не позволяет увидеть весь слайд целиком, кнопки и ползунок полосы прокрутки обеспечивают возможность перемещений как по слайду, так и между слайдами вперед и назад в пределах всей последовательности слайдов данной презентации. При перетаскивании мышью ползунка полосы прокрутки рядом с ним появляется номер и заголовок текущего; слайда. Для быстрого перехода к предыдущему и-последующему слайдам пользуйтесь кнопками Следующий слайд и Предыдущий слайд (Previous Slide) или клавишами Page Down и Page Up.

Примечание

Этими же приемами перехода по слайдам можно пользоваться и во всех остальных режимах просмотра, однако режим структуры и обычный режим предлагают другие, более удобные способы переключения слайдов.

Режим структуры

Режим структуры похож на обычный, но область структуры презентации увеличена, а области слайда и заметок уменьшены. Этот режим в основном предназначен для работы над текстом. Он позволяет сконцентрироваться на словесном изложении идей, подобрать оптимальную последовательность подачи материала. Дизайн и другие элементы оформления, как правило, прорабатываются в других режимах просмотра, хотя область слайда позволяет работать с конкретными объектами и в режиме структуры.

Упражнение 6. Содержание презентации

На рис. 13.13 представлены разделы и подразделы презентации в режиме структуры. В расположенной слева области структуры есть пронумерованные значки слайдов с заголовками, а также подзаголовки и пункты списков. Подобная область структуры имеется и в обычном режиме просмотра, который поддерживает все приемы работы со структурой презентации. Однако при обычном просмотре презентации размер этой области, как правило, невелик.

Для разработки содержания презентации предназначена специальная панель инструментов Структура (Outlining), показанная на рис. 13.14. Она помогает перемещать слайды презентации, изменять уровень структурных элементов, сворачивать и разворачивать вложенные списки пунктов.

Рис. 13.13. Режим структуры

Примечание

В области структуры отображается не всякий текст, имеющийся на слайде, а толь ко тот, который был введен в специальные зоны разметки слайдов— текстовые местозаполнители. Обратите внимание, что в структуре третьего слайда отсутствует надпись, добавленная вами в нижнюю часть слайда.

Рис. 13.14. Панель инструментов структуры

Примечание

Если панель Структура отсутствует на экране, щелкните правой кнопкой мыши на любой панели инструментов и выберите в контекстном меню пункт Структура (Outlining). Повторный выбор того же пункта скроет указанную панель инструментов.

Давайте воспользуемся режимом структуры и дополним презентацию еще несколькими слайдами, а заодно научимся перемещать слайды и пункты списков в пределах одной презентации. .

  1. Чтобы переключиться в режим структуры, щелкните на соответствующей кнопке панели режимов.

  2. Щелкните на кнопке Свернуть все (Collapse All) панели инструментов Структура, чтобы в структуре презентации остались видны только заголовки слайдов.

  3. Переместите текстовый курсор в конец заголовка третьего слайда и нажмите клавишу Enter. В презентацию будет добавлен четвертый слайд.

  4. Введите текст Структура подразделения и нажмите клавишу Enter. Появится пятый слайд.

  5. Повторяя указанные действия, введите заголовки пятого и шестого слайдов, чтобы структура презентации стала такой, как показано на рис. 13.15.

Рис. 13.15. Список слайдов презентации

Шестой слайд будет содержать двухуровневый маркированный список. Давайте введем его пункты.

  6. Нажмите клавишу Enter. Появится седьмой слайд. Щелкните на кнопке Понизить уровень (Demote) панели инструментов Структура. Строка седьмого слайда превратится в пункт списка. Введите текст Телевидение.

  7. Нажмите клавишу Enter. Снова щелкните на кнопке Понизить уровень. Появится пункт списка второго уровня вложения. Введите текст 30-секундный ролик. Нажмите клавишу Enter и введите текст 60-секундный ролик.

  8. Еще раз нажмите клавишу Enter и щелкните на кнопке Повысить уровень (Promote). Пункт списка второго уровня превратится в пункт списка первого уровня. Введите слово Радио.

  9. Нажмите клавишу Enter и щелкните на кнопке Понизить уровень.

Рис. 13.16. Двухуровневый маркированный список

  10. Введите еще несколько пунктов списка, как показано на рис. 13.16.

При необходимости разметку слайда можно изменить прямо в режиме структуры. Кроме того, хотелось бы переставить местами слайды презентации и поменять пункты списка шестого слайда. Чтобы скорректировать структуру презентации, выполните следующие действия.

  11. Выделите пятый слайд. Он сделан по разметке Заголовок и текст. Щелкните на авторазметке Заголовок и текст в две колонки в окне Разметка слайда в области задач приложения. В пятом слайде появятся два местозаполнителя для ввода текста.

Примечание

Для повышения и понижения уровня элемента структуры можно пользоваться соответствующими кнопками панели Форматирование, клавишей Tab и комбинацией клавиш Shift+Tab.

  12. Поместите указатель мыши на значок шестого слайда.

  13. Нажмите левую кнопку мыши и тащите указатель вверх. Когда горизонтальная линия, показывающая будущее положение шестого слайда, окажется между значками четвертого и пятого слайдов, отпустите кнопку мыши (рис. 13.17). Пятый и шестой слайды поменяются местами.

Рис. 13.17. Перемещение слайда с помощью мыши

  14. Щелкните на маркере пункта Телевидение. Окажутся выделенными как этот пункт, так и все вложенные подпункты.

  15. Тремя щелчками на кнопке Вниз (Move Down) панели инструментов Структура переместите выделенные пункты в конец слайда.

  16. Щелчком поместите текстовый курсор в заголовок слайда 3 и щелкните на кнопке Развернуть (Expand) панели инструментов Структура. На экране появится содержимое третьего слайда. Изучите различия между структурой списков разных слайдов.

Чтобы свернуть содержимое слайда, с которым вы не работаете в данный момент, поместите курсор в тело этого слайда и щелкните па кнопке Свернуть (Collapse).

  17. Щелкните на кнопке Развернуть все (Expand All) панели инструментов Структура, чтобы вывести на экран текст всех слайдов.

Примечание

Если панель инструментов Структура отсутствует на экране, для разво-рачивания и сворачивания структуры слайдов пользуйтесь кнопкой Развернуть панели инструментов Стандартная, которая работает как флажок.

  18. Щелкните на кнопке Отобразить форматирование (Show Formatting) панели инструментов Структура или Стандартная. Вы увидите реальный шрифт и маркеры всех пунктов структуры слайдов, как показано на рис. 13.18. В этом режиме удобно изменять начертание текста прямо в структуре презентации и сравнивать шрифты различных слайдов.

Рис. 13.18. Структура слайдов в режиме показа форматирования

  19. Чтобы вернуться к редактированию структуры и не отвлекаться на форматирование текста, повторно щелкните на кнопке Отобразить форматирование. Элементы форматирования текста исчезнут.

Упражнение 7. Итоговый слайд

PowerPoint предоставляет возможность простого и оперативного создания итогового слайда на основе последовательности выбранных слайдов. В итоговом слайде формируется маркированный список заголовков каждого слайда серии. Итоговый слайд можно поместить как до, так и после обобщаемой им совокупности. Он может играть роль аннотации доклада.

Чтобы создать итоговый слайд, выполните следующие действия.

  1. Нажатием клавиш Alt+Shift+A сверните содержимое всех слайдов.

  2. Щелкните на значке слайда 2, нажмите клавишу Shift и, не отпуская ее, щелкните на значке слайда 6.

  3. Щелкните на кнопке Итоговый слайд (Summary Slide) пацелн инструментов Структура. Итоговый слайд появится перед выделенным набором, то есть он станет вторым слайдом презентации.

  4. Выделите слова Итоговый слайд (Summary Slide), протащив по ним указатель мыши, и введите в качестве заголовка итогового слайда текст Содержание доклада.

На рис. 13.19 показан итоговый слайд в обычном режиме просмотра.

Рис. 13.19. Итоговый слайд

Упражнение 8. Мастер автосодержания

Конечно, PowerPoint не знает, что именно вы хотите сказать, но разработчикам программы хорошо известно, каким образом умелые докладчики строят свои презентации. Мастер автосодержания предлагает достаточное количество хорошо отработанных макетов презентаций, среди которых можно найти варианты, раскрывающие следующие темы:

  • доклады по общим вопросам;

  • доклады по служебным вопросам;

  • описания проектов;

  • отчеты о продажах и маркетинге;

  • сообщения в стиле Карнеги.

Чтобы создать базовую структуру презентации, выполните следующие шаги.

  1. Выберите команду Файл > Создать (File > New). В области задач приложения в окне Создание презентации щелкните на пункте из мастера автосодержания.

  2. В первом, вступительном окне мастера автосодержания щелкните на кнопке Далее (Next).

  3. В окне Вид презентации (Presentation Type) щелкните на кнопке нужной категории или на кнопке Все (All), чтобы увидеть все предлагаемые шаблоны (рис. 13.20).

Рис. 13.20. Выбор типа презентации

  4. Подыщите в списке шаблонов презентацию подходящего типа. Для примера давайте выберем пункт План продаж (Marketing Plan).

  5. Затем щелкните на кнопке Далее.

  6. В следующем окне мастера выберите стиль презентации. Здесь предлагается пять вариантов:

  • Презентация на экране (On-screen presentation);

  • Презентация в Интернете (Web-presentation);

  • Черно-белые прозрачки (Black and white overheads);

  • Цветные прозрачки (Color overheads);

  • Слайды 35 мм (35mm slides).

Выберите положение переключателя Презентация на экране и щелкните на кнопке Далее.

  7. В появившемся окне параметров презентации в поле Заголовок презентации (Presentation Title) введите заголовок.

  8. В поле Нижний колонтитул (Footer) введите текст Предложения на следующий год, который будет появляться в нижнем колонтитуле каждого слайда.

  9. Оставьте установленными флажки Дата последнего обновления (Data Last Update) и Номер слайда (Slide Number), которые инициируют добавление даты создания презентации и номера слайда на все слайды последовательности (рис. 13.21).

  10. Щелкните на кнопке Далее.

Рис. 13.21. Дополнительные параметры презентации

  11. В последнем окне мастера автосодержания щелкните на кнопке Готово (Finish). В результате появится новая презентация, структура которой показана на рис. 13.22. Обратите внимание, что слайды созданной презентации снабжены не только заголовками, но и предполагаемым текстовым содержанием.

Рис. 13.22. Структура презентации, созданная Мастером автосодержания

  12. Сохраните полученную презентацию в файле План продаж.ppt. Она пригодится в следующих упражнениях.

На основе базовой структуры, сформированной мастером автосодержания, легко построить свой собственный доклад. Для этого нужно лишь подправить заголовки и наполнить пункты презентации конкретными фактами. При желании можно сменить оформление и добавить необходимые диаграммы и рисунки. Как это делается, вы узнаете из следующих упражнений.

Упражнение 9. Импорт структуры

Есть возможность заранее создать структуру презентации в Microsoft Word, а затем импортировать ее в PowerPoint. Разработка содержания в Word позволяет пользоваться всеми преимуществами этого мощного текстового процессора. Например, можно запустить тезаурус для замены обычных слов яркими, выразительными синонимами. Для импорта содержания, сформированного в программе Word, выполните следующие действия.

  1. Откройте текстовый файл в программе Word.

  2. Выберите команду Файл > Отправить > Microsoft PowerPoint (File > Send To > Microsoft PowerPoint). Программа Word, если потребуется, сама запустит PowerPoint, создаст новую презентацию и экспортирует текст в структуру презентации PowerPoint.

Структуру презентации можно импортировать практически из любого текстового процессора. Если программа может генерировать RTF-файлы, воспользуйтесь этим форматом. При импорте содержания PowerPoint воспользуется имеющейся информацией о стилях. Если приложение не поддерживает формат RTF, сохраните текст в простом ASCII-файле. В этом случае PowerPoint будет формировать структуру, опираясь на символы табуляции. Абзац без табуляции станет заголовком слайда. Абзац с одной табуляцией — элементом маркированного списка и т. д.

Для импорта файла формата RTF или ASCII выполните следующие шаги.

  3. Щелкните на кнопке Открыть панели инструментов Стандартная.

  4. В списке Тип файлов (Files Of Type) окна диалога открытия файла выберите вариант Все структуры (All Outlines).

  5. Перемещаясь по дереву папок, выделите исходный текстовый файл и щелкните на кнопке Открыть. PowerPoint откроет файл и выведет его на экран в виде содержания презентации.

Сортировщик слайдов

Режим сортировщика дает возможность работать с презентацией в целом. В нем окно документа содержит совокупность миниатюр всех слайдов. С помощью сортировщика удобно проверять презентацию на наличие ошибок и однородность дизайна, изменять шаблон, цветовую схему и фон группы слайдов, дублировать, копщювать и переставлять слайды, перемешать слайды между презентациями, настраивать и просматривать эффекты переходов и анимационные эффекты, предназначенные для электронных слайд-фильмов.

Упражнение 10. Перестановка и копирование слайдов

Перемещать слайды последовательности можно с помощью мыши, команд меню или кнопок панели инструментов. Чтобы изменить расположение слайдов презентации План.ррt методом «перетащить и оставить», выполните следующие действия.

  1. Щелчком на кнопке панели режимов включите сортировщик слайдов (рис. 13.23). При переключении в режим сортировщика панель инструментов Форматирование заменяется на панель Сортировщик слайдов (Slide Sorter).

Рис. 13.23. Режим сортировщика слайдов

  2. Поместите указатель мыши на второй слайд, который мы будем перемещать.

  3. Нажмите кнопку мыши и перетащите вертикальную линию позиции вставки в новое положение между четвертым и пятым слайдами.

  4. Отпустите кнопку мыши. Слайд передвинется на новое место.

Чтобы переместить или скопировать группу слайдов, сначала их нужно выделить. Для этого воспользуйтесь следующими приемами.

Примечание

Чтобы вместо перемещения слайда или группы слайдов выполнить их копирование, в процессе перетаскивания удерживайте нажатой клавишу Ctrl. Слайды появятся в новой позиции, а их копия сохранится на прежнем месте.

  5. Для выделения нескольких смежных слайдов (например, 5, 6 и 7) поместите указатель рядом с первым слайдом последовательности (слайд 5).

  6. Нажмите кнопку мыши и протащите указатель через этот слайд до последнего слайда последовательности (слайд 7), как показано на рис. 13.24.

Рис. 13.24. Перемещение группы слайдов

Вместо этого можно щелкнуть на пятом слайде, нажать клавишу Shift и, не отпуская ее, щелкнуть на седьмом слайде.

  7. Чтобы добавить в выделенную группу несмежный слайд 3, нажмите клавишу Ctrl и щелкните на третьем слайде.

  8. Щелчком на кнопке Копировать (Copy) панели инструментов Стандартная скопируйте группу слайдов.

  9. Чтобы поместить точку вставки между первым и вторым слайдами, щелкните на первом слайде.

  10. Щелчком на кнопке Вставить (Paste) панели инструментов Стандартная вставьте скопированные слайды между первым и вторым слайдами презентации.

Упражнение 11. Добавление и удаление слайдов

Кроме перестановки слайдов в процессе разработки презентации может понадобиться добавить новые или убрать некоторые слайды. Это удобно делать в режиме сортировщика, так как здесь можно наблюдать влияние выполненных изменений на общий вид презентации.

  1. Щелчками на нижней кнопке полосы прокрутки переместитесь в конец презентации.

  2. Выделите слайд 7, а затем щелчком на кнопке Вырезать (Cut) панели инструментов Стандартная удалите его.

  3. Щелкните на слайде 3, нажмите клавишу Shift и щелкните на слайде 5. Нажатием клавиши Delete удалите выделенные слайды 3,4 и 5. Оставшиеся слайды будут перенумерованы.

  4. Щелкните на слайде 5, а затем на кнопке Новый слайд панели инструментов Стандартная.

  5. В окне разметки слайда щелкните на авторазметке Текст и графика (Text & Clip Art). Между пятым и шестым слайдами появится новый, пустой слайд, который можно наполнить содержанием в обычном режиме, режиме слайдов или структуры.

Примечание

Чтобы выйти из режима сортировщика и вернуться к обычному просмотру конкретного слайда, просто дважды щелкните на этом слайде.

Упражнение 12. Перемещение слайдов между презентациями

Слайды можно перемещать и копировать не только в пределах одной презентации, но и между различными презентациями. Для этого необходимо расположить презентации рядом друг с другом в режиме сортировщика слайдов. Выполните следующие действия.

  1. Откройте презентацию План.ррt.

  2. Откройте презентацию План продаж.ppt.

Рис. 13.25. Окна двух презентаций в режиме сортировщика

  3. Выберите команду Упорядочить все (Arrange All) меню Окно (Window), чтобы окна обеих презентаций разместились рядом друг с другом.

  4. Переключите обе презентации в режим сортировщика (рис. 13.25). Для этого щелкните на соответствующих кнопках панелей режимов.

Теперь можно перемещать и копировать слайды между презентациями точно так же, как это делалось в пределах одной презентации. При этом шаблон слайда автоматически меняется в соответствии с шаблоном презентации, в которую он перемещается.

Упражнение 13. Шаблон дизайна и цветовая схема

Самый простой и наиболее всеобъемлющий способ изменения внешнего вида презентации — это применение другого шаблона. Смена шаблона влечет модификацию цветовой схемы, от которой зависят цвета элементов презентации, влияет на дизайн фона и принимаемые по умолчанию параметры форматирования текста. Поставляемые в комплекте PowerPoint шаблоны дизайна разработаны профессиональными художниками и гарантируют элегантность и привлекательность презентации.

Для изменения шаблона существующей презентации выполните следующие действия.

  1. Откройте презентацию План продаж.ppt.

  2. Выберите команду Формат > Оформление слайда (Format > Slide Design).

  3. В области задач приложения появится окно Дизайн слайда (Slide Design) с тремя параметрами. Щелкните на пункте Шаблоны оформления (Design Templates). В окне Применить шаблон оформления (Apply a design template) будут отображаться различные шаблоны; щелкайте поочередно на них, чтобы увидеть предлагаемое оформление в окне презентации.

  4. Остановитесь на понравившемся вам варианте.

Рис. 13.26. Выбор шаблона дизайна

Одним из компонентов каждого шаблона является цветовая схема, которая определяет упорядоченную последовательность из восьми цветов, предназначенных для изображения различных элементов оформления презентации. Простой смены некоторых цветов или всей цветовой схемы бывает достаточно, чтобы презентация полностью преобразилась. Чтобы скорректировать цветовую схему презентации, проще всего выбрать одну из стандартных схем PowerPoint.

  5. Переключитесь в режим сортировщика.

  6. Любым из вышеописанных способов выделите четвертый и пятый слайды или любые другие слайды, которым нужно назначить новую цветовую схему.

  7. Щелкните на пункте 11ветовые схемы (Color Schemes) в окне Дизайн слайда. В окне Применить цветовую схему (Apply a color scheme) будут отображаться стандартные цветовые схемы PowerPoint, как показано на рис. 13.27.

Рис. 13.27. Смена цветовой схемы слайдов

  8. Поставьте указатель мыши на одну из них. Справа появляется маленький треугольник, щелчок на котором выводит на экран раскрывающееся меню. Щелкните на пункте Применить к выделенным слайдам (Apply to Selected Slides), и в окне презентации наблюдайте воздействие ее на оформление выделенных слайдов.

  9. Поочередно просмотрите различные схемы и выберите подходящую. Если новая схема оказалась хороша и вы решили перекрасить все слайды презентации, в раскрывающемся списке соответствующей схемы щелкните на пункте Применить ко всем слайдам (Apply to All Slides).

Контрольное упражнение

Пришло время проверить, насколько хорошо вы освоили навыки создания презентаций и работы в разных режимах PowerPoint. Попробуйте выполнить следующие операции и ответить па поставленные вопросы.

  1. Создайте пустую презентацию без какого-либо оформления и содержания.

  2. Добавьте несколько слайдов в режиме структуры.

  3. Переключитесь в режим слайдов.

  4. Удалите второй слайд.

    • Как удалить слайд в режиме слайдов?

  5. Переключитесь в окно презентации План.ррt

  6. На слайде Выставки и конференции презентации План.ррt есть два маркированных списка. Превратите второй из них в отдельный слайд с соответствующим заголовком.

    • Как превратить маркированный список в отдельный слайд?

  7. Переместите группу слайдов с четвертого но шестой между первым и вторым слайдами.

  8. Переключитесь в режим сортировщика и создайте итоговый слайд для группы слайдов со второго по шестой.

    • Как создать итоговый слайд в режиме сортировщика?

  9. Закройте все окна презентаций.

Подведение итогов

На этом занятии вы познакомились с приложением PowerPoint, режимами просмотра презентаций и основными панелями инструментов. Вы узнали принципы работы этой программы и научились быстро строить презентационные последовательности на базе стандартного шаблона дизайна и с помощью мастера автосодержания. Теперь вы умеете корректировать содержание презентации, разметку и цветовое оформление слайдов. Наконец, вы можете быстро преобразовать план, написанный в Word, в структуру новой презентации.

На следующем занятии рассматриваются вопросы оформления презентации. Вы научитесь форматировать текст слайдов, строить таблицы и графики, добавлять рисунки и организационные диаграммы.


Занятие №13

ЧАСТЬ IV

PowerPoint

PowerPoint XP — приложение для подготовки презентаций, слайды которых выносятся на суд общественности в виде распечатанных графических материалов или посредством демонстрации электронного слайд-фильма. Создав или импортировав содержание доклада, вы сможете быстро украсить его рисунками, дополнить диаграммами и анимационными эффектами. Элементы навигации дают возможность генерировать интерактивные презентации, управляемые самим зрителем.

Структура презентации

ТЕМА ЗАНЯТИЯ

Приложение PowerPoint — лидер среди систем организации презентации. С его помощью текстовая и числовая информация легко превращается в красочно оформленные слайды и диаграммы. На этом занятии вы научитесь создавать свою презентацию, разрабатывать ее общую компоновку и наполнять слайды содержанием. Вы узнаете о принципах построения презентации и о режимах программы, ускоряющих разработку документа. В упражнениях занятия рассматриваются следующие темы:

  • мастер создания презентации;

  • добавление слайдов;

  • режим слайдов;

  • структура презентации;

  • сортировщик слайдов;

  • шаблон дизайна.


Построение презентации

Программа PowerPoint для многих крупных организаций стала стандартным средством создания презентации, поскольку она направляет действия пользователя момента своего запуска и вплоть до завершения процесса разработки презента. Этот раздел посвящен описанию основных понятий и инструментов PowerPoint. Вы научитесь быстро строить красочные презентации и модифицировать их.


Упражнение 1. Создание презентации

В основе любой презентации лежит набор слайдов, на которых размещаются текст, графики, рисунки. Электронные слайды подобны обычным фотографическим, но издаются гораздо проще. Программа PowerPoint сама запрашивает всю необходимую текстовую и числовую информацию, а также предоставляет множество готовых вариантов дизайна и шаблонов содержания. Сейчас мы воспользуемся одним из таких шаблонов.

Рис. 13.1. Окно диалога PowerPoint

Сразу после запуска PowerPoint появляется окно презентации с первым титульным слайдом; справа в области задач приложения видно окно Создание презентации (New Presentation), показанное на рис. 13.1. Оно позволяет выбрать способ создания документа. Первый раздел Открыть презентацию (Open a Presentation) дает возможность открыть уже существующую презентацию. В разделе Создание (New) перечислены возможные варианты создания новой презентации:

  • Новая презентация (Blank Presentation) без какого-либо форматирования;

  • презентация Из шаблона оформления (From Design Template);

  • презентация Из мастера автосодержания (From AutoContent Wizard) с заранее заданной структурой содержания.

В этом же окне можно выбрать шаблон оформления в разделе Создание с помощью шаблона (New From Template).

Если у вас уже есть тезисы презентации и нужно лишь разместить готовый текст на слайдах и оформить его надлежащим образом, выполните следующие шаги:

  1. Щелкните на пункте Общие шаблоны (General Templates).

  2. Откроется окно диалога Шаблоны (Templates), показанное на рис. 13.2. На вкладке Шаблоны оформления (Design Templates) вы увидите список доступных шаблонов оформления слайдов. Другие вкладки этого окна открывают доступ к иным способам создания презентаций, о которых мы поговорим позже. Щелкните по очереди на значках каждого из шаблонов, чтобы в расположенном справа поле просмотра увидеть примеры оформления презентации.

Рис. 13.2. Окно диалога Шаблоны (Templates)

  3. Дважды, щелкните на значке шаблона Галстук (Dads Tie). Шаблон будет применен к слайду в окне презентации.

Чтобы добавить в окно создания презентации свой собственный шаблон, сохраните его в папке Windows\Application Data\Microson\Templates. Шаблон появится на вкладке Общие (General). Чтобы поместить его на новую вкладку, которая, например, будет содержать все шаблоны вашей фирмы, создайте в указанной папке вложенную папку и переместите туда свой шаблон. Роль шаблона может играть любая презентация, при сохранении которой был выбран тип файла Шаблон презентации (Design Template).

Рис. 13.3. Титульный слайд в обычном режиме просмотра

В поле презентации окажется титульный слайд в режиме структуры с примененным к нему выбранным шаблоном, а в области задач появится окно Разметка слайда (Slide Layout) с набором стандартных авторазметок. Поместив указатель мыши на одном из образцов, вы увидите всплывающую подсказку, характеризующую образец, и треугольник справа от него, скрывающий раскрывающийся список с набором возможных команд.

  4. Щелкните в поле с надписью Заголовок слайда (Click to add title) и введите заголовок презентации. В нашем примере это будет текст План развития.

  5. Чтобы добавить к основному названию небольшое пояснение, щелкните на поле Подзаголовок слайда (Click to add subtitle) и введите подзаголовок Отдел информационных технологий. На рис. 13.3 показан сформированный титульный слайд в окне презентации PowerPoint.

  6. Щелкните на кнопке Сохранить (Save) панели инструментов Стандартная (Standard). Откроется окно сохранения презентации.

  7. В левой части окна щелкните на значке папки Мои документы (My Documents). В поле Имя файла (File Name) введите имя План и щелкните на кнопке Сохранить. Любой файл PowerPoint содержит всю презентацию целиком, поэтому вам не нужно беспокоиться о том, что при демонстрации некоторые слайды могут пропасть.


Упражнение 2. Обычный режим просмотра

PowerPoint позволяет создавать презентации с очень большим количеством слайдов. Чтобы управлять этим огромным объемом ин4юрмации, программа предлагает несколько режимов просмотра:

  • Обычный (Normal View) — режим, появившийся в впервые PowerPoint 2000, — вариант просмотра, объединяющий режимы слайдов, структуры и заметок;

  • Сортировщик слайдов (Slide Sorter View) — режим, демонстрирующий миниатюры всех слайдов, равномерно расположенные в окне просмотра;

  • Слайды (Slide View) — режим, в котором удобно конструировать и корректировать отдельные слайды;

  • Структура (Outline View) — режим, отображающий текстовое содержание презентации и предназначенный для ввода и редактирования текста;

  • Страницы заметок (Notes Page View) — режим, предназначенный для создания заметок, которые помогают докладчику ориентироваться в материале во время ведения презентации.

Рис. 13.4. Кнопки выбора режима просмотра

  1. Переключение из одного режима в другой для первых двух режимов, а также запуск просмотра слайдов осуществляется простым щелчком па одной из трех кнопок, расположенных в левом нижнем углу окна презентации (рис. 13.4).Две кнопки вверху окна обычного режима позволяют переключаться между режимами слайдов и структуры. Переключиться на режим страниц заметок можно из меню Вид > Страницы заметок (View > Notes Page).

  2. Попробуйте по очереди щелкнуть на указанных кнопках, наблюдая за презентацией в одном из режимов просмотра.

  3. 3 Щелкните на средней кнопке вверху окна презентации, чтобы вернуться в обычный режим.

В обычном режиме (см. рис. 13.3), который автоматически включается при создании пустой презентации или презентации на основе шаблона дизайна, окно документа поделено на три области: область слайда, поле структуры и область заметок. Первая из них всегда содержит общий вид текущего слайда. Расположенная слева область структуры презентации является уменьшенной копией режима структуры. В правой нижней части окна презентации находится область заметок. Сюда можно ввести пояснительный текст, который не появляется на самом слайде, но который можно вывести на экран в режиме заметок или, готовя заметки докладчика, распечатать рядом с соответствующим слайдом.

  4. Соотношение размеров областей обычного режима просмотра можно изменить. Для этого поместите указатель мыши на границу между областями, чтобы значок указателя сменился на двунаправленную стрелку, нажмите кнопку мыши и перетащите линию границы. Подобрав нужный размер, отпустите кнопку мыши.

В обычном режиме, как и в большинстве других режимов просмотра, в окне PowerPoint присутствуют три панели инструментов. Вверху расположена панель Стандартная. Ее инструменты выполняют операции открытия и сохранения презентаций, копирования и вставки содержимого, добавления слайдов и объектов. Под ней находится панель инструментов Форматирование (Formatting). Она позволяет изменять шрифт и начертание выделенного текста, форматировать абзацы и списки, настраивать эффекты анимации. О панели инструментов Рисование (Drawing), расположенной в нижней части окна, мы поговорим на следующем занятии.


Упражнение 3. Добавление нового слайда

Сформировав титульный слайд, можно перейти к добавлению других слайдов.

  1. Найдите на панели инструментов Форматирование кнопку Создать слайд (New Slide). Если вы забыли, как выглядит значок этой кнопки, переместите указатель мыши на панель инструментов и задержите его на несколько секунд. Появится экранная подсказка, разъясняющая смысл той кнопки, на которой расположен указатель мыши. Перемещайте указатель по кнопкам и читайте экранные подсказки.

  2. Если кнопки Создать слайд не оказалось в панели инструментов Форматирование, щелкните на маленькой треугольной стрелке, расположенной на правом краю панели. Откроется дополнительная палитра с кнопками (рис. 13.5). Здесь, можно отыскать пропавший инструмент Создать слайд.

  3. Щелкните на кнопке Новый слайд (New Slide). В окне презентации появится незаполненный второй слайд.

Рис. 13.5. Дополнительная палитра кнопок стандартной панели инструментов

  4. В области задач в окне Разметка слайда, показанном на рис. 13.6, PowerPoint предлагает 27 типов стандартных авторазметок, которые способны удовлетворить практически любые потребности разработчиков презентаций.

Авторазметка — это шаблон слайда с заранее размещенными стандартными объектами, такими как заголовок, маркированный список, диаграмма или рисунок.

Рис. 13.6. Окно Разметка слайда с набором авторазметок

После создания слайда на базе авторазметки вам остается лишь щелкать на место заполнителях этих объектов и вводить необходимую информацию.

  5. Просмотрите имеющиеся авторазметки. Для этого воспользуйтесь полосой прокрутки, расположенной в правой части окна.

Примечание

На значках авторазметок заголовки показаны серой полосой, маркированные списки — прямоугольником с тремя пунктами. Диаграммы представлены маленькой гистограммой, рисунки — портретом человечка. Здесьже можно найти миниатюры организационных диаграмм и видеоклипов.

  6. Выберите для второго слайда авторазметку Маркированный список (Bulleted List), щелкнув на ней.

В области структуры презентации появится значок второго слайда, а справа будет виден сам новый слайд с двумя местозаполнителями.

Местозаполнитель представляет собой рамку, заменяющую будущий объект. Внутри рамки содержится текст, предлагающий щелкнуть в области рамки для ввода данных. К примеру, авторазметка Маркированный список содержит два место-заполнителя один для заголовка и второй для маркированного списка (рис. 13.7).

Рис. 13.7. Слайд с маркированным списком

  7. Чтобы добавить заголовок нового слайда, щелкните на местозаполнителе Заголовок слайда (Click to add title). Текст местозаподнителя исчезнет, и вы сможете сразу ввести заголовок. Напечатайте слова Направления развития.

  8. Щелкните на местозаполнителе маркированного списка Текст слайда (Click to add text) и введите первый пункт списка Спутниковая связь. Нажмите клавишу Enter.

  9. В списке появится маркер второго пункта. Не огорчайтесь, если форма маркера вас не устраивает. Позже его можно будет изменить или даже совсем убрать. Введите текст Цифровая телефония. Снова нажмите клавишу Enter и введите слово Интернет.


Упражнение 4. Заметки докладчика

Второй слайд презентации практически готов. Осталось добавить заметки, которые помогут докладчику не растеряться в момент представления планов отделана суд начальства. Каждый слайд презентации имеет особый вид внешнего представления, называемый заметками докладчика. На странице заметок всегда присутствуют два объекта: сам слайд в верхней части страницы и заметки в ее нижней части. Эти заметки не видны на экране в режиме просмотра презентации, они не выводятся на печать вместе со слайдом. Однако, проводя электронную презентацию в локальной сети, докладчик может читать заметки на экране своего компьютера. Кроме того, страницы заметок можно распечатать и пользоваться ими во время доклада.

Чтобы добавить текст заметок, выполните следующие шаги.

  1. В правой нижней области окна презентации найдите местозаполнитель Заметки к слайду (Click to add notes) и щелкните на нем. Введите текст Сделать акцент на применении цифровых технологий связи.

  2. Чтобы увидеть страницу заметок целиком, выберите команду Вид > Страницы заметок. Включится режим страниц заметок (рис. 13.8).

Рис. 13.8. Слайд в режиме просмотра страниц заметок

  3. Выбрав команду Вид > Обычный (View > Normal), вернитесь в обычный режим просмотра.

Обратите внимание, что новый слайд появляется не только в области слайдов. Он представлен и в области структуры презентации. Здесь можно отыскать значок слайда под номером 2, заголовок слайда и все три пункта маркированного списка (рис. 13.9).

Рис. 13.9. Второй слайд презентации в обычном режиме просмотра

  4. Щелчком на кнопке Сохранить панели инструментов Стандартная сохраните текущий вариант презентации.

  5. Щелкните на кнопке с косым крестом в правом верхнем углу окна презентации, чтобы закрыть документ.


Упражнение 5. Режим слайдов

В режиме слайдов отдельный слайд занимает все окно презентации. Это как бы увеличенный вариант области слайда обычного режима просмотра. В режиме слайдов удобно редактировать отдельные объекты, добавлять рисунки и текстовые комментарии. Давайте продолжим построение презентации, созданной в предыдущих упражнениях.

  1. Щелкните на кнопке Открыть (Open) панели инструментов Стандартная.

  2. В окне диалога открытия файла щелкните на папке Мои документы, найдите значок документа План.ррt и дважды щелкните на нем.

Рис. 13.10. Второй слайд в режиме просмотра слайдов

  3. Щелчком на кнопке панели смены режимов включите режим слайдов.

На экране появится первый слайд презентации. Новые слайды в PowerPoint всегда вставляются после текущего. Мы хотим добавить третий слайд, поэтому нужно сделать текущим второй слайд презентации.

  4. Щелкните на кнопке Следующий слайд (Next Slide) полосы прокрутки слайдов. На экране появится второй слайд (рис. 13.10).

  5. Щелкните на кнопке Создать слайд панели инструментов Форматирование.

  6. В окне Разметка слайда щелкните на авторазметке Маркированный список.

  7. Введите заголовок слайда Выставки и конференции. Щелкните на место заполнителе маркированного списка и введите пункты:

Вам пришло в голову, что хорошо бы разделить названия выставок и конференций и разместить их в отдельных списках. Но дополнительный слайд кажется вам лишним, а на текущем слайде все место занято имеющимся списком. Что делать?

PowerPoint позволяет оперативно изменять разметку любого слайда. Если вы решили удобавить на слайд еще один список или дополнительный рисунок, бывает достаточно просто сменить авторазметку, хотя иногда приходится добавлять недостающие объекты вручную.

Рис 13.11. Изменение разметки второго слайда

  8. В окне Разметка слайда щелкните на авторазметке Текст в две колонки (2 Column Text).

  9. Введите в появившийся справа дополнительный маркированный список следующие пункты:

  • История телефонной связи;

  • Опыт зарубежных филиалов;

  • Исследования отечественного рынка.

  10. Выберите в меню Вставка (Insert) команду Надпись (Text Box).

  11. Ниже маркированных списков растяните мытью рамку текстового поля. Введите текст Сроки проведения: с мая по ноябрь.

Рис. 13.12. Третий слайд презентации

  12. Чтобы отцентрировать текст, щелкните в панели инструментов Форматирование на кнопке По центру (Center). Окончательный вид третьего слайда показан на рис. 13.12.

Для перехода от слайда к слайду в режиме слайдов пользуйтесь вертикальной полосой прокрутки. Если выбранный масштаб не позволяет увидеть весь слайд целиком, кнопки и ползунок полосы прокрутки обеспечивают возможность перемещений как по слайду, так и между слайдами вперед и назад в пределах всей последовательности слайдов данной презентации. При перетаскивании мышью ползунка полосы прокрутки рядом с ним появляется номер и заголовок текущего; слайда. Для быстрого перехода к предыдущему и-последующему слайдам пользуйтесь кнопками Следующий слайд и Предыдущий слайд (Previous Slide) или клавишами Page Down и Page Up.

Примечание

Этими же приемами перехода по слайдам можно пользоваться и во всех остальных режимах просмотра, однако режим структуры и обычный режим предлагают другие, более удобные способы переключения слайдов.


Режим структуры

Режим структуры похож на обычный, но область структуры презентации увеличена, а области слайда и заметок уменьшены. Этот режим в основном предназначен для работы над текстом. Он позволяет сконцентрироваться на словесном изложении идей, подобрать оптимальную последовательность подачи материала. Дизайн и другие элементы оформления, как правило, прорабатываются в других режимах просмотра, хотя область слайда позволяет работать с конкретными объектами и в режиме структуры.


Упражнение 6. Содержание презентации

На рис. 13.13 представлены разделы и подразделы презентации в режиме структуры. В расположенной слева области структуры есть пронумерованные значки слайдов с заголовками, а также подзаголовки и пункты списков. Подобная область структуры имеется и в обычном режиме просмотра, который поддерживает все приемы работы со структурой презентации. Однако при обычном просмотре презентации размер этой области, как правило, невелик.

Для разработки содержания презентации предназначена специальная панель инструментов Структура (Outlining), показанная на рис. 13.14. Она помогает перемещать слайды презентации, изменять уровень структурных элементов, сворачивать и разворачивать вложенные списки пунктов.

Рис. 13.13. Режим структуры

Примечание

В области структуры отображается не всякий текст, имеющийся на слайде, а толь ко тот, который был введен в специальные зоны разметки слайдов— текстовые местозаполнители. Обратите внимание, что в структуре третьего слайда отсутствует надпись, добавленная вами в нижнюю часть слайда.

Рис. 13.14. Панель инструментов структуры

Примечание

Если панель Структура отсутствует на экране, щелкните правой кнопкой мыши на любой панели инструментов и выберите в контекстном меню пункт Структура (Outlining). Повторный выбор того же пункта скроет указанную панель инструментов.

Давайте воспользуемся режимом структуры и дополним презентацию еще несколькими слайдами, а заодно научимся перемещать слайды и пункты списков в пределах одной презентации. .

  1. Чтобы переключиться в режим структуры, щелкните на соответствующей кнопке панели режимов.

  2. Щелкните на кнопке Свернуть все (Collapse All) панели инструментов Структура, чтобы в структуре презентации остались видны только заголовки слайдов.

  3. Переместите текстовый курсор в конец заголовка третьего слайда и нажмите клавишу Enter. В презентацию будет добавлен четвертый слайд.

  4. Введите текст Структура подразделения и нажмите клавишу Enter. Появится пятый слайд.

  5. Повторяя указанные действия, введите заголовки пятого и шестого слайдов, чтобы структура презентации стала такой, как показано на рис. 13.15.

Рис. 13.15. Список слайдов презентации

Шестой слайд будет содержать двухуровневый маркированный список. Давайте введем его пункты.

  6. Нажмите клавишу Enter. Появится седьмой слайд. Щелкните на кнопке Понизить уровень (Demote) панели инструментов Структура. Строка седьмого слайда превратится в пункт списка. Введите текст Телевидение.

  7. Нажмите клавишу Enter. Снова щелкните на кнопке Понизить уровень. Появится пункт списка второго уровня вложения. Введите текст 30-секундный ролик. Нажмите клавишу Enter и введите текст 60-секундный ролик.

  8. Еще раз нажмите клавишу Enter и щелкните на кнопке Повысить уровень (Promote). Пункт списка второго уровня превратится в пункт списка первого уровня. Введите слово Радио.

  9. Нажмите клавишу Enter и щелкните на кнопке Понизить уровень.

Рис. 13.16. Двухуровневый маркированный список

  10. Введите еще несколько пунктов списка, как показано на рис. 13.16.

При необходимости разметку слайда можно изменить прямо в режиме структуры. Кроме того, хотелось бы переставить местами слайды презентации и поменять пункты списка шестого слайда. Чтобы скорректировать структуру презентации, выполните следующие действия.

  11. Выделите пятый слайд. Он сделан по разметке Заголовок и текст. Щелкните на авторазметке Заголовок и текст в две колонки в окне Разметка слайда в области задач приложения. В пятом слайде появятся два местозаполнителя для ввода текста.

Примечание

Для повышения и понижения уровня элемента структуры можно пользоваться соответствующими кнопками панели Форматирование, клавишей Tab и комбинацией клавиш Shift+Tab.

  12. Поместите указатель мыши на значок шестого слайда.

  13. Нажмите левую кнопку мыши и тащите указатель вверх. Когда горизонтальная линия, показывающая будущее положение шестого слайда, окажется между значками четвертого и пятого слайдов, отпустите кнопку мыши (рис. 13.17). Пятый и шестой слайды поменяются местами.

Рис. 13.17. Перемещение слайда с помощью мыши

  14. Щелкните на маркере пункта Телевидение. Окажутся выделенными как этот пункт, так и все вложенные подпункты.

  15. Тремя щелчками на кнопке Вниз (Move Down) панели инструментов Структура переместите выделенные пункты в конец слайда.

  16. Щелчком поместите текстовый курсор в заголовок слайда 3 и щелкните на кнопке Развернуть (Expand) панели инструментов Структура. На экране появится содержимое третьего слайда. Изучите различия между структурой списков разных слайдов.

Чтобы свернуть содержимое слайда, с которым вы не работаете в данный момент, поместите курсор в тело этого слайда и щелкните па кнопке Свернуть (Collapse).

  17. Щелкните на кнопке Развернуть все (Expand All) панели инструментов Структура, чтобы вывести на экран текст всех слайдов.

Примечание

Если панель инструментов Структура отсутствует на экране, для разво-рачивания и сворачивания структуры слайдов пользуйтесь кнопкой Развернуть панели инструментов Стандартная, которая работает как флажок.

  18. Щелкните на кнопке Отобразить форматирование (Show Formatting) панели инструментов Структура или Стандартная. Вы увидите реальный шрифт и маркеры всех пунктов структуры слайдов, как показано на рис. 13.18. В этом режиме удобно изменять начертание текста прямо в структуре презентации и сравнивать шрифты различных слайдов.

Рис. 13.18. Структура слайдов в режиме показа форматирования

  19. Чтобы вернуться к редактированию структуры и не отвлекаться на форматирование текста, повторно щелкните на кнопке Отобразить форматирование. Элементы форматирования текста исчезнут.


Упражнение 7. Итоговый слайд

PowerPoint предоставляет возможность простого и оперативного создания итогового слайда на основе последовательности выбранных слайдов. В итоговом слайде формируется маркированный список заголовков каждого слайда серии. Итоговый слайд можно поместить как до, так и после обобщаемой им совокупности. Он может играть роль аннотации доклада.

Чтобы создать итоговый слайд, выполните следующие действия.

  1. Нажатием клавиш Alt+Shift+A сверните содержимое всех слайдов.

  2. Щелкните на значке слайда 2, нажмите клавишу Shift и, не отпуская ее, щелкните на значке слайда 6.

  3. Щелкните на кнопке Итоговый слайд (Summary Slide) пацелн инструментов Структура. Итоговый слайд появится перед выделенным набором, то есть он станет вторым слайдом презентации.

  4. Выделите слова Итоговый слайд (Summary Slide), протащив по ним указатель мыши, и введите в качестве заголовка итогового слайда текст Содержание доклада.

На рис. 13.19 показан итоговый слайд в обычном режиме просмотра.

Рис. 13.19. Итоговый слайд


Упражнение 8. Мастер автосодержания

Конечно, PowerPoint не знает, что именно вы хотите сказать, но разработчикам программы хорошо известно, каким образом умелые докладчики строят свои презентации. Мастер автосодержания предлагает достаточное количество хорошо отработанных макетов презентаций, среди которых можно найти варианты, раскрывающие следующие темы:

  • доклады по общим вопросам;

  • доклады по служебным вопросам;

  • описания проектов;

  • отчеты о продажах и маркетинге;

  • сообщения в стиле Карнеги.

Чтобы создать базовую структуру презентации, выполните следующие шаги.

  1. Выберите команду Файл > Создать (File > New). В области задач приложения в окне Создание презентации щелкните на пункте из мастера автосодержания.

  2. В первом, вступительном окне мастера автосодержания щелкните на кнопке Далее (Next).

  3. В окне Вид презентации (Presentation Type) щелкните на кнопке нужной категории или на кнопке Все (All), чтобы увидеть все предлагаемые шаблоны (рис. 13.20).

Рис. 13.20. Выбор типа презентации

  4. Подыщите в списке шаблонов презентацию подходящего типа. Для примера давайте выберем пункт План продаж (Marketing Plan).

  5. Затем щелкните на кнопке Далее.

  6. В следующем окне мастера выберите стиль презентации. Здесь предлагается пять вариантов:

  • Презентация на экране (On-screen presentation);

  • Презентация в Интернете (Web-presentation);

  • Черно-белые прозрачки (Black and white overheads);

  • Цветные прозрачки (Color overheads);

  • Слайды 35 мм (35mm slides).

Выберите положение переключателя Презентация на экране и щелкните на кнопке Далее.

  7. В появившемся окне параметров презентации в поле Заголовок презентации (Presentation Title) введите заголовок.

  8. В поле Нижний колонтитул (Footer) введите текст Предложения на следующий год, который будет появляться в нижнем колонтитуле каждого слайда.

  9. Оставьте установленными флажки Дата последнего обновления (Data Last Update) и Номер слайда (Slide Number), которые инициируют добавление даты создания презентации и номера слайда на все слайды последовательности (рис. 13.21).

  10. Щелкните на кнопке Далее.

Рис. 13.21. Дополнительные параметры презентации

  11. В последнем окне мастера автосодержания щелкните на кнопке Готово (Finish). В результате появится новая презентация, структура которой показана на рис. 13.22. Обратите внимание, что слайды созданной презентации снабжены не только заголовками, но и предполагаемым текстовым содержанием.

Рис. 13.22. Структура презентации, созданная Мастером автосодержания

  12. Сохраните полученную презентацию в файле План продаж.ppt. Она пригодится в следующих упражнениях.

На основе базовой структуры, сформированной мастером автосодержания, легко построить свой собственный доклад. Для этого нужно лишь подправить заголовки и наполнить пункты презентации конкретными фактами. При желании можно сменить оформление и добавить необходимые диаграммы и рисунки. Как это делается, вы узнаете из следующих упражнений.


Упражнение 9. Импорт структуры

Есть возможность заранее создать структуру презентации в Microsoft Word, а затем импортировать ее в PowerPoint. Разработка содержания в Word позволяет пользоваться всеми преимуществами этого мощного текстового процессора. Например, можно запустить тезаурус для замены обычных слов яркими, выразительными синонимами. Для импорта содержания, сформированного в программе Word, выполните следующие действия.

  1. Откройте текстовый файл в программе Word.

  2. Выберите команду Файл > Отправить > Microsoft PowerPoint (File > Send To > Microsoft PowerPoint). Программа Word, если потребуется, сама запустит PowerPoint, создаст новую презентацию и экспортирует текст в структуру презентации PowerPoint.

Структуру презентации можно импортировать практически из любого текстового процессора. Если программа может генерировать RTF-файлы, воспользуйтесь этим форматом. При импорте содержания PowerPoint воспользуется имеющейся информацией о стилях. Если приложение не поддерживает формат RTF, сохраните текст в простом ASCII-файле. В этом случае PowerPoint будет формировать структуру, опираясь на символы табуляции. Абзац без табуляции станет заголовком слайда. Абзац с одной табуляцией — элементом маркированного списка и т. д.

Для импорта файла формата RTF или ASCII выполните следующие шаги.

  3. Щелкните на кнопке Открыть панели инструментов Стандартная.

  4. В списке Тип файлов (Files Of Type) окна диалога открытия файла выберите вариант Все структуры (All Outlines).

  5. Перемещаясь по дереву папок, выделите исходный текстовый файл и щелкните на кнопке Открыть. PowerPoint откроет файл и выведет его на экран в виде содержания презентации.


Сортировщик слайдов

Режим сортировщика дает возможность работать с презентацией в целом. В нем окно документа содержит совокупность миниатюр всех слайдов. С помощью сортировщика удобно проверять презентацию на наличие ошибок и однородность дизайна, изменять шаблон, цветовую схему и фон группы слайдов, дублировать, копщювать и переставлять слайды, перемешать слайды между презентациями, настраивать и просматривать эффекты переходов и анимационные эффекты, предназначенные для электронных слайд-фильмов.


Упражнение 10. Перестановка и копирование слайдов

Перемещать слайды последовательности можно с помощью мыши, команд меню или кнопок панели инструментов. Чтобы изменить расположение слайдов презентации План.ррt методом «перетащить и оставить», выполните следующие действия.

  1. Щелчком на кнопке панели режимов включите сортировщик слайдов (рис. 13.23). При переключении в режим сортировщика панель инструментов Форматирование заменяется на панель Сортировщик слайдов (Slide Sorter).

Рис. 13.23. Режим сортировщика слайдов

  2. Поместите указатель мыши на второй слайд, который мы будем перемещать.

  3. Нажмите кнопку мыши и перетащите вертикальную линию позиции вставки в новое положение между четвертым и пятым слайдами.

  4. Отпустите кнопку мыши. Слайд передвинется на новое место.

Чтобы переместить или скопировать группу слайдов, сначала их нужно выделить. Для этого воспользуйтесь следующими приемами.

Примечание

Чтобы вместо перемещения слайда или группы слайдов выполнить их копирование, в процессе перетаскивания удерживайте нажатой клавишу Ctrl. Слайды появятся в новой позиции, а их копия сохранится на прежнем месте.

  5. Для выделения нескольких смежных слайдов (например, 5, 6 и 7) поместите указатель рядом с первым слайдом последовательности (слайд 5).

  6. Нажмите кнопку мыши и протащите указатель через этот слайд до последнего слайда последовательности (слайд 7), как показано на рис. 13.24.

Рис. 13.24. Перемещение группы слайдов

Вместо этого можно щелкнуть на пятом слайде, нажать клавишу Shift и, не отпуская ее, щелкнуть на седьмом слайде.

  7. Чтобы добавить в выделенную группу несмежный слайд 3, нажмите клавишу Ctrl и щелкните на третьем слайде.

  8. Щелчком на кнопке Копировать (Copy) панели инструментов Стандартная скопируйте группу слайдов.

  9. Чтобы поместить точку вставки между первым и вторым слайдами, щелкните на первом слайде.

  10. Щелчком на кнопке Вставить (Paste) панели инструментов Стандартная вставьте скопированные слайды между первым и вторым слайдами презентации.


Упражнение 11. Добавление и удаление слайдов

Кроме перестановки слайдов в процессе разработки презентации может понадобиться добавить новые или убрать некоторые слайды. Это удобно делать в режиме сортировщика, так как здесь можно наблюдать влияние выполненных изменений на общий вид презентации.

  1. Щелчками на нижней кнопке полосы прокрутки переместитесь в конец презентации.

  2. Выделите слайд 7, а затем щелчком на кнопке Вырезать (Cut) панели инструментов Стандартная удалите его.

  3. Щелкните на слайде 3, нажмите клавишу Shift и щелкните на слайде 5. Нажатием клавиши Delete удалите выделенные слайды 3,4 и 5. Оставшиеся слайды будут перенумерованы.

  4. Щелкните на слайде 5, а затем на кнопке Новый слайд панели инструментов Стандартная.

  5. В окне разметки слайда щелкните на авторазметке Текст и графика (Text & Clip Art). Между пятым и шестым слайдами появится новый, пустой слайд, который можно наполнить содержанием в обычном режиме, режиме слайдов или структуры.

Примечание

Чтобы выйти из режима сортировщика и вернуться к обычному просмотру конкретного слайда, просто дважды щелкните на этом слайде.


Упражнение 12. Перемещение слайдов между презентациями

Слайды можно перемещать и копировать не только в пределах одной презентации, но и между различными презентациями. Для этого необходимо расположить презентации рядом друг с другом в режиме сортировщика слайдов. Выполните следующие действия.

  1. Откройте презентацию План.ррt.

  2. Откройте презентацию План продаж.ppt.

Рис. 13.25. Окна двух презентаций в режиме сортировщика

  3. Выберите команду Упорядочить все (Arrange All) меню Окно (Window), чтобы окна обеих презентаций разместились рядом друг с другом.

  4. Переключите обе презентации в режим сортировщика (рис. 13.25). Для этого щелкните на соответствующих кнопках панелей режимов.

Теперь можно перемещать и копировать слайды между презентациями точно так же, как это делалось в пределах одной презентации. При этом шаблон слайда автоматически меняется в соответствии с шаблоном презентации, в которую он перемещается.


Упражнение 13. Шаблон дизайна и цветовая схема

Самый простой и наиболее всеобъемлющий способ изменения внешнего вида презентации — это применение другого шаблона. Смена шаблона влечет модификацию цветовой схемы, от которой зависят цвета элементов презентации, влияет на дизайн фона и принимаемые по умолчанию параметры форматирования текста. Поставляемые в комплекте PowerPoint шаблоны дизайна разработаны профессиональными художниками и гарантируют элегантность и привлекательность презентации.

Для изменения шаблона существующей презентации выполните следующие действия.

  1. Откройте презентацию План продаж.ppt.

  2. Выберите команду Формат > Оформление слайда (Format > Slide Design).

  3. В области задач приложения появится окно Дизайн слайда (Slide Design) с тремя параметрами. Щелкните на пункте Шаблоны оформления (Design Templates). В окне Применить шаблон оформления (Apply a design template) будут отображаться различные шаблоны; щелкайте поочередно на них, чтобы увидеть предлагаемое оформление в окне презентации.

  4. Остановитесь на понравившемся вам варианте.

Рис. 13.26. Выбор шаблона дизайна

Одним из компонентов каждого шаблона является цветовая схема, которая определяет упорядоченную последовательность из восьми цветов, предназначенных для изображения различных элементов оформления презентации. Простой смены некоторых цветов или всей цветовой схемы бывает достаточно, чтобы презентация полностью преобразилась. Чтобы скорректировать цветовую схему презентации, проще всего выбрать одну из стандартных схем PowerPoint.

  5. Переключитесь в режим сортировщика.

  6. Любым из вышеописанных способов выделите четвертый и пятый слайды или любые другие слайды, которым нужно назначить новую цветовую схему.

  7. Щелкните на пункте 11ветовые схемы (Color Schemes) в окне Дизайн слайда. В окне Применить цветовую схему (Apply a color scheme) будут отображаться стандартные цветовые схемы PowerPoint, как показано на рис. 13.27.

Рис. 13.27. Смена цветовой схемы слайдов

  8. Поставьте указатель мыши на одну из них. Справа появляется маленький треугольник, щелчок на котором выводит на экран раскрывающееся меню. Щелкните на пункте Применить к выделенным слайдам (Apply to Selected Slides), и в окне презентации наблюдайте воздействие ее на оформление выделенных слайдов.

  9. Поочередно просмотрите различные схемы и выберите подходящую. Если новая схема оказалась хороша и вы решили перекрасить все слайды презентации, в раскрывающемся списке соответствующей схемы щелкните на пункте Применить ко всем слайдам (Apply to All Slides).


Контрольное упражнение

Пришло время проверить, насколько хорошо вы освоили навыки создания презентаций и работы в разных режимах PowerPoint. Попробуйте выполнить следующие операции и ответить па поставленные вопросы.

  1. Создайте пустую презентацию без какого-либо оформления и содержания.

  2. Добавьте несколько слайдов в режиме структуры.

  3. Переключитесь в режим слайдов.

  4. Удалите второй слайд.

    • Как удалить слайд в режиме слайдов?

  5. Переключитесь в окно презентации План.ррt

  6. На слайде Выставки и конференции презентации План.ррt есть два маркированных списка. Превратите второй из них в отдельный слайд с соответствующим заголовком.

    • Как превратить маркированный список в отдельный слайд?

  7. Переместите группу слайдов с четвертого но шестой между первым и вторым слайдами.

  8. Переключитесь в режим сортировщика и создайте итоговый слайд для группы слайдов со второго по шестой.

    • Как создать итоговый слайд в режиме сортировщика?

  9. Закройте все окна презентаций.


Подведение итогов

На этом занятии вы познакомились с приложением PowerPoint, режимами просмотра презентаций и основными панелями инструментов. Вы узнали принципы работы этой программы и научились быстро строить презентационные последовательности на базе стандартного шаблона дизайна и с помощью мастера автосодержания. Теперь вы умеете корректировать содержание презентации, разметку и цветовое оформление слайдов. Наконец, вы можете быстро преобразовать план, написанный в Word, в структуру новой презентации.

На следующем занятии рассматриваются вопросы оформления презентации. Вы научитесь форматировать текст слайдов, строить таблицы и графики, добавлять рисунки и организационные диаграммы.


Занятие №14

Оформление презентации

ТЕМА ЗАНЯТИЯ

На этом занятии вы познакомитесь с некоторыми приемами о4зормления слайдов презентации. Будут рассмотрены следующие темы:

  • маркированные списки;

  • текстовые объекты;

  • графические объекты;

  • образец слайда;

  • организационная диаграмма.

При отсутствии достаточного количества времени для оформления презентации можно воспользоваться стандартным шаблоном дизайна и задать цветовую схему с помощью приемов, рассмотренных в упражнении 13 предыдущего занятия. Но чтобы получить действительно привлекательную презентацию, следует дополнительно выделить важные пункты, добавить необходимые рисунки, а возможно, и изменить образец слайда, определяющий общее расположение объектов на всех слайдах последовательности.

Форматирование слайда

Абзацы и шрифт слайдов PowerPoint форматируются точно так же, как текст Word. Одно из неоспоримых преимуществ программного пакета Office ХР — это сходство операций во всех приложениях. Вы можете выделить любой фрагмент текста, настроить отступы, интервалы и режимы выравнивания абзацев, воспользовавшись приемами, описанными на занятии 6. Эти параметры удобнее всего регулировать с помощью горизонтальной и вертикальной линеек, которые подобны линейкам Word. Посредством табуляторов можно создавать небольшие таблицы. Выделив фразу, с помощью команды Формат > Шрифт (Format > Font) можно изменять размер и начертание ее шрифта.

Упражнение 1. Шрифт, маркеры и отступы абзацев

Основными текстовыми элементами презентаций являются списки. В отличие от Word списки PowerPoint изначально предполагаются многоуровневыми, что вносит некоторую специфику в приемы их форматирования. Чтобы приукрасить списки презентации, созданной на предыдущем занятии, выполните следующие шаги.

  1. Откройте презентацию План.ррt

  2. Из обычного режима, щелкнув на соответствующей кнопке, перейдите в Режим слайдов, чтобы развернуть слайд на все окно PowerPoint.

  3. Несколькими нажатиями клавиши Page Down перейдите к последнему, восьмому слайду, показанному на. рис. 14.1. На этом слайде расположен двухуровневый список.

  4. Чтобы вывести на экран линейки (если таковые отсутствуют), выберите команду Вид > Линейка (View > Ruler).

  5. Щелкните в пределах списка. Вокруг списка появится рамка габаритного контейнера с шестью маркерами, а на линейках появятся границы габаритного контейнера и ползунки отступов пунктов списка первого и второго уровней. Списки PowerPoint поддерживают шесть уровней вложения пунктов, которые соответствуют шести уровням в режиме структуры. По умолчанию пункты разного уровня отличаются маркерами и величиной отступа от левого края. Давайте скорректируем эти параметры на примере списка восьмого слайда.

Рис. 14.1. Слайд с двухуровневым списком

  6. Перетащите ползунок левого отступа второго уровня вправо на 4 см. Этот ползунок смещает как маркеры, так и пункты списка.

  7. Перетащите влево на 1 см ползунок отступа маркеров. Маркеры второго уровня сместятся влево, а текст пунктов останется на месте.

  8. Щелкните слева от пункта 30-секундный ролик, чтобы выделить его.

  9. Нажмите клавишу Shift и щелкните слева от следующего пункта. Теперь окажутся выделенными два пункта второго, уровня.

  10. Щелкните в области выделенного текста правой кнопкой мыши и выберите в контекстном меню команду Список (Bullets And Numbering) (рис. 14.2).

  11. В открывшемся окне диалога щелкните на вкладке Маркированный список (Bulleted).

  12. С помощью этого окна можно выбрать один из предлагаемых вариантов маркеров, щелкнув на нем, или же самим разработать вариант маркера. Щелкните на кнопке Настройка (Customize). В списке Шрифт (Font) окна диалога Символ (Symbol) выберите пункт Wingdings (рис. 14.3).

  13. Щелкая на клетках с символами, можно просматривать значки в увеличенном виде. Выберите подходящий маркер.

  14. Щелкните на кнопке ОК.

Рис. 14.2. Форматирование списка

В качестве маркера можно использовать любой символ любого шрифта и даже рисунок. Чтобы назначить рисунок, щелкните в окне вкладки Маркированный список на кнопке Рисунок (Picture) и выберите один из предлагаемых графических маркеров либо импортируйте в библиотеку маркеров файл с рисунком.

Рис. 14.3. Выбор маркера

  15. Щелкните на пункте Местные радиостанции.

  16. Нажмите клавишу Shift и щелкните правее пункта Специальные предложения, чтобы выделить три последних пункта слайда.

  17. Щелчком ла кнопке Увеличить размер шрифта (Increase Font Size) панели инструментов Форматирование сделайте крупнее шрифт выделенного фрагмента.

  18. Чтобы три последних пункта выводились курсивом, щелкните на кнопке Курсив (Italic) той же панели инструментов,

Рис. 14.4. форматирование списка

  19. Щелкните на кнопке Нумерация (Numbering). Теперь роль маркеров последнего списка слайда будут играть последовательные числа, как показано на рис. 14.4.

Упражнение 2. Текстовые объекты

В PowerPoint любой текст, так же как рисунок, диаграмма или таблица, представляет собой отдельный объект или автофигуру, которую можно перемещать, масштабировать, поворачивать и раскрашивать. Давайте поучимся форматировать такие объекты.

  1. С помощью ползунка вертикальной полосы прокрутки перейдите на слайд 3, который называется Содержание доклада.

  2. Щелкните в списке этого слайда правой кнопкой мыши и выберите в контекстном меню команду Формат прототипа (Format Placeholder). Текстовый объект списка будет выделен, и на экране появится окно диалога Формат автофигры (Format AutoShape). Вкладка Надпись (Text Box) этого окна, показанная на рис. 14.5, задает способ размещения текста внутри местозаполнителя. Эта вкладка доступна только для автофигур с текстом.

Рис. 14.5. Настройка размещения надписи

  3. Выберите в раскрывающемся списке Размещение текста (Text Anchor Point) пункт Сверху по центру (Top Centered), чтобы центрировать текст внутри габаритного контейнера по горизонтали.

  4. Установите флажок подгонять размер автофигуры под текст (Resize AutoShape To Fit Text). Этот режим автоматически сжимает габаритный контейнер по вертикали до размеров текста. При вводе в этом режиме дополнительных символов контейнер будет сам увеличиваться по высоте, чтобы вместить весь текст.

Рис. 14.6. Настройка фона и рамки

Примечание

Вкладка Wеb окна параметров автофигуры предназначена для презентаций, размещаемых на web-узле. Раскройте эту вкладку и введите описание текстового объекта или автофигуры. При невозможности загрузки самого объекта или при отключенном режиме загрузки изображений браузер выведет на экран это описание, которое поможет пользователю сориентироваться в презентации.

  5. Раскройте вкладку Цвета и линии (Colors And Lines), которая позволяет задавать фон и рамку объектов (рис. 14.6).

  6. В палитре цвет (Color) раздела Заливка (Fill) выберите желтый цвет.

  7. В аналогичной палитре раздела Линии (Line) укажите темно-синий цвет.

  8. В раскрывающемся списке шаблон (Dashed) выберите пунктирную линию.

  9. С помощью счетчика толщина (Weight) задайте толщину 6 пунктов.

  10. Щелкните на кнопке ОК. Обновленный слайд показан на рис. 14.7.

Рис. 14.7. Обновленный список

Упражнение 3. Перемещение и масштабирование объектов

В PowerPoint текстовые объекты, как и рисунки, можно перемещать и масштабировать.

  1. Сохраняя выделенным объект списка, на панели инструментов Рисование (Drawing) в меню кнопки Действие (Draw) выберите команду Повернуть/отразить > Свободное вращение (Rotate or Flip > Free Rotate). Рамка автофигуры заменится четырьмя зелеными кружками, расположенными по углам.

  2. Поместите указатель на один из таких кружков, нажмите левую кнопку и, перетаскивая мышь, поверните текст примерно на 45° (рис. 14.8).

  3. Щелчком на кнопке Выбор объектов (Select Object) панели инструментов Рисование отключите режим вращения. Теперь автофигура вылезает за пределы слайда и ее нужно уменьшить.

  4. Захватите мышью серединный маркер правой стороны текста и перетащите его немного вниз.

Примечание

Текстовые объекты имеют два режима выделения. Если щелкнуть на тексте повернутого списка, автофигура перейдет в режим редактирования текста. При этом она автоматически примет горизонтальное положение. Когда вы закончите редактировать текст, щелкните за пределами автофигуры, и она вернется в прежнее положение. Чтобы получить доступ к маркерам рамки текста, сохранив при этом его расположение на слайде, щелкните в тексте, а затем щелкните на рамке объекта. Полоса рамки изменит штриховку, а объект перейдет в режим редактирования автофигуры.

  5. Перетащите серединный маркер левой стороны рамки вверх.

Автофигура маркированного списка уменьшилась по ширине и теперь целиком помещается на слайде, но она закрывает часть заголовка. В PowerPoint все автофигуры накладываются друг на друга в определенном порядке, который можно менять. В данном случае заголовок слайда оказался под списком. Поскольку заголовок не имеет фона, его можно наложить на список. Чтобы изменить порядок размещения объектов, выполните следующие действия.

  6. Щелчком на заголовке Содержание доклада выделите его.

  7. Выберите в меню кнопки Действие панели инструментов Рисование команду Порядок > На передний план (Order > Bring To Front) (см. рис. 14.8).

  8. Щелкните за пределами заголовка.

Рис. 14.8. Изменение порядка наложения объектов

Конечно, полученный слайд вряд ли подойдет для реальной презентации, однако в определенных ситуациях рассмотренные приемы оформления помогут вам разместить текст слайда надлежащим образом.

Упражнение 4. Редактирование образца слайда

В состав шаблона дизайна презентации кроме цветовой схемы входят образцы слайдов, титульного слайда, страниц заметок и раздаточного материала, которые определяют стандартное оформление этих элементов. Изменяя образец, можно .модифицировать сразу все слайды презентации. Образец слайдов содержит в себе следующие компоненты:

  • цвет фона, который может иметь плавные переходы тона;

  • принимаемые по умолчанию параметры форматирования шрифтов, заголовков и маркированных списков;

  • дополнительные объекты, размещаемые на заднем плане слайдов;

  • три специальных поля, отображающие дату, номер слайда и текст нижнего колонтитула.

Давайте изменим фон слайдов и включим отображение перечисленных выше служебных полей.

Рис. 14.9. Настройка фона образца слайда

  1. Выберите команду Вид > Образец >Образец слайдов (View > Master > Slide Master).

Появится образец слайдов с пятью местозаполнителями и панель инструментов Образец (Master) с несколькими кнопками, позволяющими вводить новый образец, удалять, сохранять и переименовывать его. С помощью приемов, описанных в упражнениях 1 и 2 этого занятия, вы можете редактировать образец слайда, изменять размеры местозаполнителей, заливку, рамку и шрифт, а также маркеры списков. Выполненное форматирование подействует на все слайды презентации, кроме титульного.

Примечание

Для модификации оформления титульного слайда следует отформатировать образец заголовка. Образец заголовка расположен вторым в ряду слайдов-образцов. Чтобы перейти к нему от образца слайда, нажмите клавишу Page Down.

  2. Выполните команду Формат > Фон (Format > Background). С помощью открывшегося окна диалога (рис. 14.9) можно настраивать фон не только образца, но и любого конкретного слайда.

  3. В раскрывающемся списке окна диалога Фон (Background) выберите пункт Способы заливки (Fill Effects), открывающий доступ к узорным и градиентным заливкам фона.

  4. На вкладке Градиентная (Gradient) окна диалога Способы заливки (Fill Effects), показанного на рис. 14.10, выберите положение переключателя два цвета (Two Colors).

Рис. 14.10. Выбор градиентной заливки

Примечание

Вкладки Текстура (Texture), Узор (Pattern) и Рисунок (Picture) позволяют установить в качестве фона слайда соответственно текстурную заливку, геометрический узор или рисунок любого графического формата. Если вам не понравилась градиентная заливка, подберите фон на свой вкус.

  5. Выберите положение из угла (From Corner) переключателя Тип штриховки (Sha ding Styles).

  6. В разделе Варианты (Variants) выберите правый верхний квадрат.

  7. Затем щелкните на кнопке ОК.

  8. В окне диалога Фон (Background) щелкните на кнопке Применить ко всем (Apply То All), чтобы назначить выбранный фон как образцу слайда, так и образцу титульного слайда.

  9. Для активизации трех дополнительных объектов, расположенных в нижней части образца, выберите команду Вид > Колонтитулы (View > Header And Footer).

  10. Выберите положение переключателя Автообновление (Update Automatically), чтобы выводилась дата последнего обновления презентации (если сброшен флажок Дату и время (Date And Time), установите его).

  11. В списке Язык (Language) выберите пункт Русский (Russian).

  12. Установите флажок Номер слайда, чтобы добавить в правый, нижний угол порядковый номер слайда.

  13. В поле Нижний колонтитул введите текст Средства связи, который будет теперь появляться на каждом слайде (при этом должен быть установлен флажок Нижний колонтитул (Footer)).

Рис. 14.11. Новый фон и подписи на нижнем краю слайда

  14. Щелкните на кнопке Применить ко всем (Apply To All).

  15. С помощью кнопки Закрыть (Close) панели инструментов Образец вернитесь к просмотру слайдов.

Обновленный третий слайд показан на рис. 14.11. Остальные слайды будут выглядеть так же.

Упражнение 5. Графические объекты

Графические объекты PowerPoint ничем не отличаются от рисунков и автофигур Word, о которых рассказывалось на занятии 5. Их можно вставлять как на сами слайды, так и в образцы. Для форматирования графических объектов используются кнопки и команды панели инструментов Рисование. Чтобы с помощью образца добавить на каждый слайд логотип компании и гиперссылки на следующий и предыдущий слайды,, выполните перечисленные ниже операции.

  1. С помощью команды Вид > Образец > Образец слайдов снова откройте образец слайда.

  2. Щелкните на местозаполпителе Образец заголовка (Click To Edit Master Title Style).

  3. Перетащите влево серединный маркер правой границы появившейся рамки, чтобы уменьшить область заголовка и освободить место под логотип.

Рис. 14.12. Добавление логотипа и гиперссылок

  4. Щелкните на кнопке Добавить картинку (Insert Clip Art) панели инструментов Рисование. В окне Вставка картинки (Insert ClipArt) области задач в разделе Поиск клипа в текстовое ноле Искать текст (Search for) введите ключевое слово Животные (Animals) и щелкните на кнопке Найти (Search). В разделе Результаты (Results) появятся образцы картинок.

  5. Поместите указатель на рисунок тигра и перетащите его мышью в правый верхний угол слайда, как показано на рис. 14.12.

  6. Выделите область объекта и сдвиньте вверх ее нижний край.

  7. В панели инструментов Рисование раскройте подменю Автофигуры > Фигурные стрелки (AutoShapes > Block Arrows) и щелкните на кнопке со стрелкой вправо.

  8. В правом нижнем углу слайда растяните мышью диагональ габаритного контейнера стрелки.

  9. Чтобы стрелка стала видимой, щелкните на кнопке цвет заливки (Fill Color).

  10. Щелкните на стрелке правой кнопкой мыши и выберите команду Гиперссылка (Hyperlink).

  11. В левой части открывшегося окна диалога щелкните на кнопке Местом в этом документе (Place In This Document). Затем в списке слайдов назначения выберите пункт Следующий слайд и щелкните на кнопке ОК.

Рис. 14.13. Слайде гиперссылками и рисунком

  12. Нажатием клавиш Ctrl+С скопируйте стрелку ссылки. Затем нажмите клавишу Page Down, а вслед за ней клавиатурную комбинацию Ctrl+V, чтобы вставить скопированный объект в образец заголовка. Нажатием клавиши Page Up вернитесь к образцу слайда.

  13. Повторив шаги 7-11, добавьте между областью объекта и областью даты стрелку влево и назначьте ей гиперссылку Предыдущий слайд (Previous Slide).

14. Щелчком на кнопке Закрыть панели инструментов Образец вернитесь к слайдам презентации.

Давайте проверим, как работают настроенные гиперссылки. Для этого нажмите клавишу F5. PowerPoint откроет первый слайд в режиме полноэкранного просмотра слайд-фильма. Щелкните на стрелке ссылки на следующий слайд, откроется второй слайд (рис. 14.13). Точно так же можно перейти и к третьему слайду. Обратите внимание, что на каждом слайде есть ссылки на предыдущий и следующий слайды, а также логотип компании. Чтобы выйти из режима демонстрации презентации, нажмите клавишу Esc.

Организационная диаграмма

На слайдах PowerPoint можно размещать таблицы, диаграммы и другие объекты, разъясняющие содержание презентации. Иногда хорошо построенный график намного красноречивее нескольких десятков слов. В PowerPoint также доступны таблицы, которые полностью аналогичны таблицам Word (с ними вы встречались на занятии 7). Диаграммы и графики были рассмотрены при изучении Word и Excel. В следующих упражнениях вы познакомитесь с еще одним типом объектов Microsoft Office — организационной диаграммой. Такая оргдиаграмма представляет собой блок-схему из связанных прямоугольников и может обрисовывать, например, структуру организации или генеалогическое древо семьи.

Примечание

Чтобы разместить на слайде PowerPoint таблицу или диаграмму, воспользуйтесь соответствующими авторазметками или командами Диаграмма (Chart) и Таблица (Table) меню Вставка.

Упражнение 6. Добавление оргдиаграммы

Для добавления оргдиаграммы на слайд PowerPoint проще всего воспользоваться специальной авторазметкой.

  1. С помощью клавиш Page Up и Page Down перейдите к седьмому слайду, имеющему заголовок Структура подразделения.

  2. Выберите команду Формат > Разметка слайда (Format > Slide Layout). В области задач приложения в открывшемся окне Разметка слайда в разделе Применить разметку слайда (Apply Slide Layout) щелкните на авторазметке Организационная диаграмма (Organization Chart). На слайде появится местозаполпитель с подписью Вставка организационной диаграммы (Double Click To Add Org Chart).

Примечание

В предыдущих версиях Office для работы с организационными диаграммами требовался запуск специальной утилиты Microsoft Organization Chart. В Office XP функция построения организационных диаграмм встроена в PowerPoint.

  3. Дважды щелкните на этом местозаполнителе. Откроется окно диалога Библиотека диаграмм (Diagram Gallery) с предлагаемыми типами диаграмм.

  4. Выделите подходящий вариант, представляющий блок начальника и трех подчиненных, и щелкните на кнопке ОК. Диаграмма будет перенесена на слайд.

  5. Щелкните на клетке верхнего уровня и введите текст: Суворов, нажмите клавишу Enter и введите: Директор.

  6. Щелкните на блоке первого подчиненного и введите его фамилию и должность.

Примечание

Для добавления оргдиаграммы в документы Word или Excel выполните команду Вставка > Объект (Insert > Object), выберите в открывшемся окне диалога пункт MS Organization Chart и щелкните на кнопке ОК.

  7. Аналогичным образом введите текст для второго и третьего подчиненных, например, как показано на рис. 14.14.

Рис. 14.14. Организационная диаграмма

  8. Чтобы изменить уже введенный текст, щелкните на блоке и введите нужный текст. Исправив ошибки, щелкните за пределами блока.

  9. Чтобы закончить редактирование организационной диаграммы, щелкните на слайде за ее пределами.

Упражнение 7. Добавление и перемещение блоков

Любой объект презентации можно изменять. Чтобы добавить в оргдиаграмму, созданную на предыдущем упражнении, дополнительные блоки, выполните следующие шаги:

  1. В седьмом слайде презентации щелкните на оргдиаграмме, чтобы сделать ее доступной редактированию. В оргдиаграмме различаются несколько типов блоков. Они представлены командами меню Добавить фигуру (Insert Shape) панели инструментов Организационная диаграмма, которые выполняют следующие действия:

  • Подчиненный (Subordinate) — добавляет блок на уровень ниже выбранного;

  • Сотрудник (Co-worker) — добавляет блок слева или справа от выбранного (в зависимости от выбранной кнопки) на том же уровне подчиненности;

  • Помощник (Assistant) — присоединяет блок к линии сбоку, ниже выбранного блока.

Рис. 14.15. Добавление и перемещение блоков

Давайте добавим помощника директора и двух подчиненных в производственный отдел.

  2. Выделите блок директора, щелкнув на нем.

  3. Выберите в меню Добавить фигуру команду Помощник.

  4. Щелкните на блоке начальника производственного отдела.

  5. Выберите в меню Добавить фигуру команду Подчиненный. Повторите шаг 5, чтобы добавить в производственный отдел второго подчиненного.

  6. Щелкайте на вновь добавленных блоках и вводите необходимую информацию о работниках компании.

Примечание

Чтобы удалить ненужный блок, следует выделить его щелчком, а затем нажать клавишу Delete.

Блоки оргдиаграммы можно не только добавлять и удалять, но и перемещать, изменяя схему подчиненности. Пусть, например, отдел сбыта переподчинили производственному отделу. Давайте соответствующим образом изменим схему.

  7. Поместите указатель на блок начальника отдела сбыта, нажмите кнопку мыши и перетащите блок поверх блока начальника производственного отдела. Отпустите кнопку мыши. Измененная оргдиаграмма показана на рис. 14.15.

Упражнение 8. Форматирование блоков

Оргдиаграмму, как и другие документы, можно форматировать, изменяя фон и рамки блоков, толщину соединительных линий и другие параметры с помощью кнопок панели инструментов Рисование.

  1. Щелчком мыши выделите блок с фамилией Николаев.

  2. Нажмите клавишу Shift и щелкните на блоках Курочкин и Неспешный, чтобы они тоже были выделены.

  3. Щелкните на стрелке рядом с кнопкой Цвет линии (Line Color) и выберите в открывшейся палитре черный цвет.

  4. К сожалению, стандартная рамка слишком тонка, поэтому давайте сделаем ее немного потолще. Для этого щелкните на кнопке Тип линии (Line Style) и выберите в палитре линий двойную жирную линию.

  5. Выберите в меню Выделить (Select) панели инструментов Организационная диаграмма команду Все соединительные линии (All Connecting Lines).

  6. Щелкните на кнопке Тип линии панели инструментов Рисование, В раскрывшейся палитре выберите шестой снизу пункт. Теперь линии видны намного лучше (рис. 14.16). С помощью панели инструментов Рисование можно добавлять в оргдиаграмму дополнительные линии и прямоугольники, не вписывающиеся в иерархическую структуру блоков.

  7. На панели инструментов Рисование щелкните на варианте линии с уступом в подменю Автофигуры > Соединительные линии (AutoShapes > Connecting Lines).

  8. Нажмите кнопку мыши на прямоугольнике главного инженера.

  9. Переместите указатель на прямоугольник с фамилией Николаев и отпустите кнопку мыши. Появится вспомогательная линия, символизирующая членство Николаева в комиссии главного инженера.

  10. В оргдиаграмму можно добавлять и дополнительные надписи. Щелкните на кнопке Текст (Enter Text).

  11. Щелкните в левом верхнем углу диаграммы и введите текст (Проект).

  12. Выберите кнопку Выделение (Select) и методом перетаскивания скорректируйте положение новой Надписи.

Рис. 14.16. Форматирование блоков и вспомогательных элементов

  13. Если полученная оргдиаграмма оказалась слишком маленькой, увеличьте ее, перетащив угловые маркеры рамки объекта, чтобы слайд стал примерно таким, как показано на рис. 14.17.

Рис. 14.17. Слайд с оргдиаграммой

Контрольное упражнение

Попробуйте самостоятельно повторить некоторые приемы форматирования презентаций, рассмотренные на этом занятии.

  1. Создайте новую пустую презентацию.

  2. Добавьте титульный слайд и введите в него заголовок и подзаголовок.

  3. Добавьте два слайда, один с двумя списками, а второй с оргдиаграммой. Заполните местозаполнители каким-либо текстом.

  4. Сделайте первый список первого слайда нумерованным.

  5. Второму списку того же слайда задайте маркеры из библиотеки ClipArt.

  6. Откройте образец слайда и добавьте на каждый слайд рисунок с гиперссыл-кой на первый слайд презентации.

    • Какая гиперссылка обеспечивает переход па первый слайд?

  7. В поле даты образца слайда выведите дату и время последнего обновления презентации.

    • Как настраивается формат даты?

  8. Залейте фон образца каким-нибудь узором.

  9. Добавьте на третий слайд презентации оргдиаграмму из четырех стандартных блоков (один начальник и три подчиненных).

  10. Расположите блоки подчиненных друг под другом.

    • Как изменить способ размещения блоков?

  11. Закройте презентацию, не сохраняя ее.

Подведение итогов

На этом занятии вы изучили приемы форматирования текста и объектов слайдов презентации. Последние три упражнения были посвящены модулю Organization Chart и добавлению в слайды организационных диаграмм.

На следующем занятии рассматриваются способы настройки и демонстрации электронного слайд-фильма, а также публикация презентаций в виде бумажных оттисков и 4ютографических слайдов.


Занятие №14

Оформление презентации

ТЕМА ЗАНЯТИЯ

На этом занятии вы познакомитесь с некоторыми приемами о4зормления слайдов презентации. Будут рассмотрены следующие темы:

  • маркированные списки;

  • текстовые объекты;

  • графические объекты;

  • образец слайда;

  • организационная диаграмма.

При отсутствии достаточного количества времени для оформления презентации можно воспользоваться стандартным шаблоном дизайна и задать цветовую схему с помощью приемов, рассмотренных в упражнении 13 предыдущего занятия. Но чтобы получить действительно привлекательную презентацию, следует дополнительно выделить важные пункты, добавить необходимые рисунки, а возможно, и изменить образец слайда, определяющий общее расположение объектов на всех слайдах последовательности.


Форматирование слайда

Абзацы и шрифт слайдов PowerPoint форматируются точно так же, как текст Word. Одно из неоспоримых преимуществ программного пакета Office ХР — это сходство операций во всех приложениях. Вы можете выделить любой фрагмент текста, настроить отступы, интервалы и режимы выравнивания абзацев, воспользовавшись приемами, описанными на занятии 6. Эти параметры удобнее всего регулировать с помощью горизонтальной и вертикальной линеек, которые подобны линейкам Word. Посредством табуляторов можно создавать небольшие таблицы. Выделив фразу, с помощью команды Формат > Шрифт (Format > Font) можно изменять размер и начертание ее шрифта.


Упражнение 1. Шрифт, маркеры и отступы абзацев

Основными текстовыми элементами презентаций являются списки. В отличие от Word списки PowerPoint изначально предполагаются многоуровневыми, что вносит некоторую специфику в приемы их форматирования. Чтобы приукрасить списки презентации, созданной на предыдущем занятии, выполните следующие шаги.

  1. Откройте презентацию План.ррt

  2. Из обычного режима, щелкнув на соответствующей кнопке, перейдите в Режим слайдов, чтобы развернуть слайд на все окно PowerPoint.

  3. Несколькими нажатиями клавиши Page Down перейдите к последнему, восьмому слайду, показанному на. рис. 14.1. На этом слайде расположен двухуровневый список.

  4. Чтобы вывести на экран линейки (если таковые отсутствуют), выберите команду Вид > Линейка (View > Ruler).

  5. Щелкните в пределах списка. Вокруг списка появится рамка габаритного контейнера с шестью маркерами, а на линейках появятся границы габаритного контейнера и ползунки отступов пунктов списка первого и второго уровней. Списки PowerPoint поддерживают шесть уровней вложения пунктов, которые соответствуют шести уровням в режиме структуры. По умолчанию пункты разного уровня отличаются маркерами и величиной отступа от левого края. Давайте скорректируем эти параметры на примере списка восьмого слайда.

Рис. 14.1. Слайд с двухуровневым списком

  6. Перетащите ползунок левого отступа второго уровня вправо на 4 см. Этот ползунок смещает как маркеры, так и пункты списка.

  7. Перетащите влево на 1 см ползунок отступа маркеров. Маркеры второго уровня сместятся влево, а текст пунктов останется на месте.

  8. Щелкните слева от пункта 30-секундный ролик, чтобы выделить его.

  9. Нажмите клавишу Shift и щелкните слева от следующего пункта. Теперь окажутся выделенными два пункта второго, уровня.

  10. Щелкните в области выделенного текста правой кнопкой мыши и выберите в контекстном меню команду Список (Bullets And Numbering) (рис. 14.2).

  11. В открывшемся окне диалога щелкните на вкладке Маркированный список (Bulleted).

  12. С помощью этого окна можно выбрать один из предлагаемых вариантов маркеров, щелкнув на нем, или же самим разработать вариант маркера. Щелкните на кнопке Настройка (Customize). В списке Шрифт (Font) окна диалога Символ (Symbol) выберите пункт Wingdings (рис. 14.3).

  13. Щелкая на клетках с символами, можно просматривать значки в увеличенном виде. Выберите подходящий маркер.

  14. Щелкните на кнопке ОК.

Рис. 14.2. Форматирование списка

В качестве маркера можно использовать любой символ любого шрифта и даже рисунок. Чтобы назначить рисунок, щелкните в окне вкладки Маркированный список на кнопке Рисунок (Picture) и выберите один из предлагаемых графических маркеров либо импортируйте в библиотеку маркеров файл с рисунком.

Рис. 14.3. Выбор маркера

  15. Щелкните на пункте Местные радиостанции.

  16. Нажмите клавишу Shift и щелкните правее пункта Специальные предложения, чтобы выделить три последних пункта слайда.

  17. Щелчком ла кнопке Увеличить размер шрифта (Increase Font Size) панели инструментов Форматирование сделайте крупнее шрифт выделенного фрагмента.

  18. Чтобы три последних пункта выводились курсивом, щелкните на кнопке Курсив (Italic) той же панели инструментов,

Рис. 14.4. форматирование списка

  19. Щелкните на кнопке Нумерация (Numbering). Теперь роль маркеров последнего списка слайда будут играть последовательные числа, как показано на рис. 14.4.


Упражнение 2. Текстовые объекты

В PowerPoint любой текст, так же как рисунок, диаграмма или таблица, представляет собой отдельный объект или автофигуру, которую можно перемещать, масштабировать, поворачивать и раскрашивать. Давайте поучимся форматировать такие объекты.

  1. С помощью ползунка вертикальной полосы прокрутки перейдите на слайд 3, который называется Содержание доклада.

  2. Щелкните в списке этого слайда правой кнопкой мыши и выберите в контекстном меню команду Формат прототипа (Format Placeholder). Текстовый объект списка будет выделен, и на экране появится окно диалога Формат автофигры (Format AutoShape). Вкладка Надпись (Text Box) этого окна, показанная на рис. 14.5, задает способ размещения текста внутри местозаполнителя. Эта вкладка доступна только для автофигур с текстом.

Рис. 14.5. Настройка размещения надписи

  3. Выберите в раскрывающемся списке Размещение текста (Text Anchor Point) пункт Сверху по центру (Top Centered), чтобы центрировать текст внутри габаритного контейнера по горизонтали.

  4. Установите флажок подгонять размер автофигуры под текст (Resize AutoShape To Fit Text). Этот режим автоматически сжимает габаритный контейнер по вертикали до размеров текста. При вводе в этом режиме дополнительных символов контейнер будет сам увеличиваться по высоте, чтобы вместить весь текст.

Рис. 14.6. Настройка фона и рамки

Примечание

Вкладка Wеb окна параметров автофигуры предназначена для презентаций, размещаемых на web-узле. Раскройте эту вкладку и введите описание текстового объекта или автофигуры. При невозможности загрузки самого объекта или при отключенном режиме загрузки изображений браузер выведет на экран это описание, которое поможет пользователю сориентироваться в презентации.

  5. Раскройте вкладку Цвета и линии (Colors And Lines), которая позволяет задавать фон и рамку объектов (рис. 14.6).

  6. В палитре цвет (Color) раздела Заливка (Fill) выберите желтый цвет.

  7. В аналогичной палитре раздела Линии (Line) укажите темно-синий цвет.

  8. В раскрывающемся списке шаблон (Dashed) выберите пунктирную линию.

  9. С помощью счетчика толщина (Weight) задайте толщину 6 пунктов.

  10. Щелкните на кнопке ОК. Обновленный слайд показан на рис. 14.7.

Рис. 14.7. Обновленный список


Упражнение 3. Перемещение и масштабирование объектов

В PowerPoint текстовые объекты, как и рисунки, можно перемещать и масштабировать.

  1. Сохраняя выделенным объект списка, на панели инструментов Рисование (Drawing) в меню кнопки Действие (Draw) выберите команду Повернуть/отразить > Свободное вращение (Rotate or Flip > Free Rotate). Рамка автофигуры заменится четырьмя зелеными кружками, расположенными по углам.

  2. Поместите указатель на один из таких кружков, нажмите левую кнопку и, перетаскивая мышь, поверните текст примерно на 45° (рис. 14.8).

  3. Щелчком на кнопке Выбор объектов (Select Object) панели инструментов Рисование отключите режим вращения. Теперь автофигура вылезает за пределы слайда и ее нужно уменьшить.

  4. Захватите мышью серединный маркер правой стороны текста и перетащите его немного вниз.

Примечание

Текстовые объекты имеют два режима выделения. Если щелкнуть на тексте повернутого списка, автофигура перейдет в режим редактирования текста. При этом она автоматически примет горизонтальное положение. Когда вы закончите редактировать текст, щелкните за пределами автофигуры, и она вернется в прежнее положение. Чтобы получить доступ к маркерам рамки текста, сохранив при этом его расположение на слайде, щелкните в тексте, а затем щелкните на рамке объекта. Полоса рамки изменит штриховку, а объект перейдет в режим редактирования автофигуры.

  5. Перетащите серединный маркер левой стороны рамки вверх.

Автофигура маркированного списка уменьшилась по ширине и теперь целиком помещается на слайде, но она закрывает часть заголовка. В PowerPoint все автофигуры накладываются друг на друга в определенном порядке, который можно менять. В данном случае заголовок слайда оказался под списком. Поскольку заголовок не имеет фона, его можно наложить на список. Чтобы изменить порядок размещения объектов, выполните следующие действия.

  6. Щелчком на заголовке Содержание доклада выделите его.

  7. Выберите в меню кнопки Действие панели инструментов Рисование команду Порядок > На передний план (Order > Bring To Front) (см. рис. 14.8).

  8. Щелкните за пределами заголовка.

Рис. 14.8. Изменение порядка наложения объектов

Конечно, полученный слайд вряд ли подойдет для реальной презентации, однако в определенных ситуациях рассмотренные приемы оформления помогут вам разместить текст слайда надлежащим образом.


Упражнение 4. Редактирование образца слайда

В состав шаблона дизайна презентации кроме цветовой схемы входят образцы слайдов, титульного слайда, страниц заметок и раздаточного материала, которые определяют стандартное оформление этих элементов. Изменяя образец, можно .модифицировать сразу все слайды презентации. Образец слайдов содержит в себе следующие компоненты:

  • цвет фона, который может иметь плавные переходы тона;

  • принимаемые по умолчанию параметры форматирования шрифтов, заголовков и маркированных списков;

  • дополнительные объекты, размещаемые на заднем плане слайдов;

  • три специальных поля, отображающие дату, номер слайда и текст нижнего колонтитула.

Давайте изменим фон слайдов и включим отображение перечисленных выше служебных полей.

Рис. 14.9. Настройка фона образца слайда

  1. Выберите команду Вид > Образец >Образец слайдов (View > Master > Slide Master).

Появится образец слайдов с пятью местозаполнителями и панель инструментов Образец (Master) с несколькими кнопками, позволяющими вводить новый образец, удалять, сохранять и переименовывать его. С помощью приемов, описанных в упражнениях 1 и 2 этого занятия, вы можете редактировать образец слайда, изменять размеры местозаполнителей, заливку, рамку и шрифт, а также маркеры списков. Выполненное форматирование подействует на все слайды презентации, кроме титульного.

Примечание

Для модификации оформления титульного слайда следует отформатировать образец заголовка. Образец заголовка расположен вторым в ряду слайдов-образцов. Чтобы перейти к нему от образца слайда, нажмите клавишу Page Down.

  2. Выполните команду Формат > Фон (Format > Background). С помощью открывшегося окна диалога (рис. 14.9) можно настраивать фон не только образца, но и любого конкретного слайда.

  3. В раскрывающемся списке окна диалога Фон (Background) выберите пункт Способы заливки (Fill Effects), открывающий доступ к узорным и градиентным заливкам фона.

  4. На вкладке Градиентная (Gradient) окна диалога Способы заливки (Fill Effects), показанного на рис. 14.10, выберите положение переключателя два цвета (Two Colors).

Рис. 14.10. Выбор градиентной заливки

Примечание

Вкладки Текстура (Texture), Узор (Pattern) и Рисунок (Picture) позволяют установить в качестве фона слайда соответственно текстурную заливку, геометрический узор или рисунок любого графического формата. Если вам не понравилась градиентная заливка, подберите фон на свой вкус.

  5. Выберите положение из угла (From Corner) переключателя Тип штриховки (Sha ding Styles).

  6. В разделе Варианты (Variants) выберите правый верхний квадрат.

  7. Затем щелкните на кнопке ОК.

  8. В окне диалога Фон (Background) щелкните на кнопке Применить ко всем (Apply То All), чтобы назначить выбранный фон как образцу слайда, так и образцу титульного слайда.

  9. Для активизации трех дополнительных объектов, расположенных в нижней части образца, выберите команду Вид > Колонтитулы (View > Header And Footer).

  10. Выберите положение переключателя Автообновление (Update Automatically), чтобы выводилась дата последнего обновления презентации (если сброшен флажок Дату и время (Date And Time), установите его).

  11. В списке Язык (Language) выберите пункт Русский (Russian).

  12. Установите флажок Номер слайда, чтобы добавить в правый, нижний угол порядковый номер слайда.

  13. В поле Нижний колонтитул введите текст Средства связи, который будет теперь появляться на каждом слайде (при этом должен быть установлен флажок Нижний колонтитул (Footer)).

Рис. 14.11. Новый фон и подписи на нижнем краю слайда

  14. Щелкните на кнопке Применить ко всем (Apply To All).

  15. С помощью кнопки Закрыть (Close) панели инструментов Образец вернитесь к просмотру слайдов.

Обновленный третий слайд показан на рис. 14.11. Остальные слайды будут выглядеть так же.


Упражнение 5. Графические объекты

Графические объекты PowerPoint ничем не отличаются от рисунков и автофигур Word, о которых рассказывалось на занятии 5. Их можно вставлять как на сами слайды, так и в образцы. Для форматирования графических объектов используются кнопки и команды панели инструментов Рисование. Чтобы с помощью образца добавить на каждый слайд логотип компании и гиперссылки на следующий и предыдущий слайды,, выполните перечисленные ниже операции.

  1. С помощью команды Вид > Образец > Образец слайдов снова откройте образец слайда.

  2. Щелкните на местозаполпителе Образец заголовка (Click To Edit Master Title Style).

  3. Перетащите влево серединный маркер правой границы появившейся рамки, чтобы уменьшить область заголовка и освободить место под логотип.

Рис. 14.12. Добавление логотипа и гиперссылок

  4. Щелкните на кнопке Добавить картинку (Insert Clip Art) панели инструментов Рисование. В окне Вставка картинки (Insert ClipArt) области задач в разделе Поиск клипа в текстовое ноле Искать текст (Search for) введите ключевое слово Животные (Animals) и щелкните на кнопке Найти (Search). В разделе Результаты (Results) появятся образцы картинок.

  5. Поместите указатель на рисунок тигра и перетащите его мышью в правый верхний угол слайда, как показано на рис. 14.12.

  6. Выделите область объекта и сдвиньте вверх ее нижний край.

  7. В панели инструментов Рисование раскройте подменю Автофигуры > Фигурные стрелки (AutoShapes > Block Arrows) и щелкните на кнопке со стрелкой вправо.

  8. В правом нижнем углу слайда растяните мышью диагональ габаритного контейнера стрелки.

  9. Чтобы стрелка стала видимой, щелкните на кнопке цвет заливки (Fill Color).

  10. Щелкните на стрелке правой кнопкой мыши и выберите команду Гиперссылка (Hyperlink).

  11. В левой части открывшегося окна диалога щелкните на кнопке Местом в этом документе (Place In This Document). Затем в списке слайдов назначения выберите пункт Следующий слайд и щелкните на кнопке ОК.

Рис. 14.13. Слайде гиперссылками и рисунком

  12. Нажатием клавиш Ctrl+С скопируйте стрелку ссылки. Затем нажмите клавишу Page Down, а вслед за ней клавиатурную комбинацию Ctrl+V, чтобы вставить скопированный объект в образец заголовка. Нажатием клавиши Page Up вернитесь к образцу слайда.

  13. Повторив шаги 7-11, добавьте между областью объекта и областью даты стрелку влево и назначьте ей гиперссылку Предыдущий слайд (Previous Slide).

14. Щелчком на кнопке Закрыть панели инструментов Образец вернитесь к слайдам презентации.

Давайте проверим, как работают настроенные гиперссылки. Для этого нажмите клавишу F5. PowerPoint откроет первый слайд в режиме полноэкранного просмотра слайд-фильма. Щелкните на стрелке ссылки на следующий слайд, откроется второй слайд (рис. 14.13). Точно так же можно перейти и к третьему слайду. Обратите внимание, что на каждом слайде есть ссылки на предыдущий и следующий слайды, а также логотип компании. Чтобы выйти из режима демонстрации презентации, нажмите клавишу Esc.


Организационная диаграмма

На слайдах PowerPoint можно размещать таблицы, диаграммы и другие объекты, разъясняющие содержание презентации. Иногда хорошо построенный график намного красноречивее нескольких десятков слов. В PowerPoint также доступны таблицы, которые полностью аналогичны таблицам Word (с ними вы встречались на занятии 7). Диаграммы и графики были рассмотрены при изучении Word и Excel. В следующих упражнениях вы познакомитесь с еще одним типом объектов Microsoft Office — организационной диаграммой. Такая оргдиаграмма представляет собой блок-схему из связанных прямоугольников и может обрисовывать, например, структуру организации или генеалогическое древо семьи.

Примечание

Чтобы разместить на слайде PowerPoint таблицу или диаграмму, воспользуйтесь соответствующими авторазметками или командами Диаграмма (Chart) и Таблица (Table) меню Вставка.


Упражнение 6. Добавление оргдиаграммы

Для добавления оргдиаграммы на слайд PowerPoint проще всего воспользоваться специальной авторазметкой.

  1. С помощью клавиш Page Up и Page Down перейдите к седьмому слайду, имеющему заголовок Структура подразделения.

  2. Выберите команду Формат > Разметка слайда (Format > Slide Layout). В области задач приложения в открывшемся окне Разметка слайда в разделе Применить разметку слайда (Apply Slide Layout) щелкните на авторазметке Организационная диаграмма (Organization Chart). На слайде появится местозаполпитель с подписью Вставка организационной диаграммы (Double Click To Add Org Chart).

Примечание

В предыдущих версиях Office для работы с организационными диаграммами требовался запуск специальной утилиты Microsoft Organization Chart. В Office XP функция построения организационных диаграмм встроена в PowerPoint.

  3. Дважды щелкните на этом местозаполнителе. Откроется окно диалога Библиотека диаграмм (Diagram Gallery) с предлагаемыми типами диаграмм.

  4. Выделите подходящий вариант, представляющий блок начальника и трех подчиненных, и щелкните на кнопке ОК. Диаграмма будет перенесена на слайд.

  5. Щелкните на клетке верхнего уровня и введите текст: Суворов, нажмите клавишу Enter и введите: Директор.

  6. Щелкните на блоке первого подчиненного и введите его фамилию и должность.

Примечание

Для добавления оргдиаграммы в документы Word или Excel выполните команду Вставка > Объект (Insert > Object), выберите в открывшемся окне диалога пункт MS Organization Chart и щелкните на кнопке ОК.

  7. Аналогичным образом введите текст для второго и третьего подчиненных, например, как показано на рис. 14.14.

Рис. 14.14. Организационная диаграмма

  8. Чтобы изменить уже введенный текст, щелкните на блоке и введите нужный текст. Исправив ошибки, щелкните за пределами блока.

  9. Чтобы закончить редактирование организационной диаграммы, щелкните на слайде за ее пределами.


Упражнение 7. Добавление и перемещение блоков

Любой объект презентации можно изменять. Чтобы добавить в оргдиаграмму, созданную на предыдущем упражнении, дополнительные блоки, выполните следующие шаги:

  1. В седьмом слайде презентации щелкните на оргдиаграмме, чтобы сделать ее доступной редактированию. В оргдиаграмме различаются несколько типов блоков. Они представлены командами меню Добавить фигуру (Insert Shape) панели инструментов Организационная диаграмма, которые выполняют следующие действия:

  • Подчиненный (Subordinate) — добавляет блок на уровень ниже выбранного;

  • Сотрудник (Co-worker) — добавляет блок слева или справа от выбранного (в зависимости от выбранной кнопки) на том же уровне подчиненности;

  • Помощник (Assistant) — присоединяет блок к линии сбоку, ниже выбранного блока.

Рис. 14.15. Добавление и перемещение блоков

Давайте добавим помощника директора и двух подчиненных в производственный отдел.

  2. Выделите блок директора, щелкнув на нем.

  3. Выберите в меню Добавить фигуру команду Помощник.

  4. Щелкните на блоке начальника производственного отдела.

  5. Выберите в меню Добавить фигуру команду Подчиненный. Повторите шаг 5, чтобы добавить в производственный отдел второго подчиненного.

  6. Щелкайте на вновь добавленных блоках и вводите необходимую информацию о работниках компании.

Примечание

Чтобы удалить ненужный блок, следует выделить его щелчком, а затем нажать клавишу Delete.

Блоки оргдиаграммы можно не только добавлять и удалять, но и перемещать, изменяя схему подчиненности. Пусть, например, отдел сбыта переподчинили производственному отделу. Давайте соответствующим образом изменим схему.

  7. Поместите указатель на блок начальника отдела сбыта, нажмите кнопку мыши и перетащите блок поверх блока начальника производственного отдела. Отпустите кнопку мыши. Измененная оргдиаграмма показана на рис. 14.15.


Упражнение 8. Форматирование блоков

Оргдиаграмму, как и другие документы, можно форматировать, изменяя фон и рамки блоков, толщину соединительных линий и другие параметры с помощью кнопок панели инструментов Рисование.

  1. Щелчком мыши выделите блок с фамилией Николаев.

  2. Нажмите клавишу Shift и щелкните на блоках Курочкин и Неспешный, чтобы они тоже были выделены.

  3. Щелкните на стрелке рядом с кнопкой Цвет линии (Line Color) и выберите в открывшейся палитре черный цвет.

  4. К сожалению, стандартная рамка слишком тонка, поэтому давайте сделаем ее немного потолще. Для этого щелкните на кнопке Тип линии (Line Style) и выберите в палитре линий двойную жирную линию.

  5. Выберите в меню Выделить (Select) панели инструментов Организационная диаграмма команду Все соединительные линии (All Connecting Lines).

  6. Щелкните на кнопке Тип линии панели инструментов Рисование, В раскрывшейся палитре выберите шестой снизу пункт. Теперь линии видны намного лучше (рис. 14.16). С помощью панели инструментов Рисование можно добавлять в оргдиаграмму дополнительные линии и прямоугольники, не вписывающиеся в иерархическую структуру блоков.

  7. На панели инструментов Рисование щелкните на варианте линии с уступом в подменю Автофигуры > Соединительные линии (AutoShapes > Connecting Lines).

  8. Нажмите кнопку мыши на прямоугольнике главного инженера.

  9. Переместите указатель на прямоугольник с фамилией Николаев и отпустите кнопку мыши. Появится вспомогательная линия, символизирующая членство Николаева в комиссии главного инженера.

  10. В оргдиаграмму можно добавлять и дополнительные надписи. Щелкните на кнопке Текст (Enter Text).

  11. Щелкните в левом верхнем углу диаграммы и введите текст (Проект).

  12. Выберите кнопку Выделение (Select) и методом перетаскивания скорректируйте положение новой Надписи.

Рис. 14.16. Форматирование блоков и вспомогательных элементов

  13. Если полученная оргдиаграмма оказалась слишком маленькой, увеличьте ее, перетащив угловые маркеры рамки объекта, чтобы слайд стал примерно таким, как показано на рис. 14.17.

Рис. 14.17. Слайд с оргдиаграммой


Контрольное упражнение

Попробуйте самостоятельно повторить некоторые приемы форматирования презентаций, рассмотренные на этом занятии.

  1. Создайте новую пустую презентацию.

  2. Добавьте титульный слайд и введите в него заголовок и подзаголовок.

  3. Добавьте два слайда, один с двумя списками, а второй с оргдиаграммой. Заполните местозаполнители каким-либо текстом.

  4. Сделайте первый список первого слайда нумерованным.

  5. Второму списку того же слайда задайте маркеры из библиотеки ClipArt.

  6. Откройте образец слайда и добавьте на каждый слайд рисунок с гиперссыл-кой на первый слайд презентации.

    • Какая гиперссылка обеспечивает переход па первый слайд?

  7. В поле даты образца слайда выведите дату и время последнего обновления презентации.

    • Как настраивается формат даты?

  8. Залейте фон образца каким-нибудь узором.

  9. Добавьте на третий слайд презентации оргдиаграмму из четырех стандартных блоков (один начальник и три подчиненных).

  10. Расположите блоки подчиненных друг под другом.

    • Как изменить способ размещения блоков?

  11. Закройте презентацию, не сохраняя ее.


Подведение итогов

На этом занятии вы изучили приемы форматирования текста и объектов слайдов презентации. Последние три упражнения были посвящены модулю Organization Chart и добавлению в слайды организационных диаграмм.

На следующем занятии рассматриваются способы настройки и демонстрации электронного слайд-фильма, а также публикация презентаций в виде бумажных оттисков и 4ютографических слайдов.


Занятие №15

Публикация презентации

ТЕМА ЗАНЯТИЯ

Упражнения этого занятия научат вас печатать слайды презентации на бумаге и прозрачных пленках, сохранять их в формате HTML и представлять в виде электронного слайд-шоу. Ниже перечислены операции, с которыми вы здесь познакомитесь:

  • настройка параметров страниц;

  • экспорт слайдов в другие приложения;

  • преобразование в формат HTML;

  • настройка переходов;

  • анимация объектов;

  • запись звукового сопровождения;

  • демонстрация слайд-фильма.

Завершив процесс создания презентационной последовательности, следует подумать о том, в каком виде слайды должны быть представлены на суд общественности. PowerPoint позволяет печатать со слайдов прозрачные пленки (прозрачки) или страницы доклада, содержащие до шести слайдов с комментариями на одном листе. Можно вывести презентацию на 35-миллиметровые слайды или преобразовать в формат HTML и разместить на web-узле. Наконец, можно показать их в виде интерактивного слайд-фильма, в котором слайды сопровождаются привлекательными переходами, записанным звуком и другими эффектами.

Публикация презентации

Преимуществом печатного варианта представления презентации является его независимость от компьютеров. Прозрачные пленки со слайдами презентации можно показать в любом конференц-зале на большом экране, а страницы с комментариями просто раздать коллегам для ознакомления. С другой стороны, в печатной копии исчезают добавленные электронные эффекты.

Упражнение 1. Параметры страницы

Перед выводом слайдов на печать следует проверить установленные параметры страницы. Стандартные величины, выбираемые в PowerPoint no умолчанию, обычно подходят для электронного слайд-фильма и печати прозрачных пленок. Менять их имеет смысл при выводе презентации на 35-миллиметровые слайды или на бумагу специального формата.

  1. Чтобы проверить параметры страницы, выберите команду Файл > Параметры страницы (File > Page Setup). Откроется окно диалога, показанное на рис. 15.1.

Рис. 15.1. Параметры страницы

  2. В раскрывающемся списке Размер слайдов (Slide Sized For) выберите один из стандартных размеров. Например, для печати прозрачных пленок следует указать пункт Прозрачка (Overhead).

  3. Если создаваемая презентация является продолжением предыдущего доклада, измените нумерацию слайдов, задав номер первого из них с помощью счетчика Нумеровать слайды с (Number Slides From).

Примечание

При выборе пункта Произвольный (Custom) с помощью счетчиков Ширина (Width) и Высота (Height) можно задавать произвольные размеры страницы. По умолчанию вариант Произвольный устанавливает размеры поля вывода для текущего принтера.

PowerPoint позволяет выбирать разную ориентацию страницы для вывода слайдов и для печати заметок, раздаточных материалов и структуры.

  4. В разделе Ориентация (Orientation) проверьте ориентацию страницы. Обычно для слайдов устанавливается положение переключателя Альбомная (Landscape), а для остальных документов — Книжная (Portrait).

Примечание

Если предполагается печатать презентацию на прозрачных пленках, можете выбрать для слайдов книжную ориентацию, но это лучше сделать перед разработкой содержания слайдов, так как в противном случае придется корректировать компоновку объектов презентации.

  5. Щелкните на кнопке ОК.

Упражнение 2. Печать слайдов, заметок и структуры

Чтобы распечатать презентацию на бумагу или прозрачные пленки, выполните следующие действия.

  1. Выберите команду Файл > Печать (File > Print). Откроется окно диалога, показанное на рис. 15.2.

Рис. 15.2. Настройка параметров печати

  2. В раскрывающемся списке Печатать (Print What) выберите тип печатаемого документа. Здесь доступны следующие варианты:

    • Слайды (Slides) — печать слайдов по одному на каждой странице;
    • Выдачи (Handouts) — вывод материалов для раздачи слушателям. В этом варианте на одной странице печатается несколько слайдов. Для указания количества и расположения слайдов на страницах пользуйтесь параметрами раздела Выдачи. Для конфигурирования выдач можно также воспользоваться образцом выдач, который открывается командой Вид > Образец > Образец выдач (View > Master > Handout Master);
    • Заметки (Notes Pages) — печать страниц заметок, на каждой из которых размещаюется один слайд и текст заметок к слайду, в обычном режиме просмотра располагающиеся под текущим слайдом. Формат страниц заметок можно настроить с помощью соответствующего образца, доступного в подменю Вид > Образец (View > Master);
    • Структуру (Outline View) — вывод на принтер только структуры презентации, идентичной той, которая отображается в режиме просмотра структуры.

  3. В разделе Диапазон печати (Print Range) выберите положение переключателя все (All), чтобы напечатать все слайды, или текущий слайд (Current Slide), чтобы вывести один текущий слайд, либо выберите положение переключателя слайды (Slides) и введите в одноименное поле номера тех слайдов, которые нужно напечатать. В раскрывающемся списке Цвет или оттенки серого (Color/ Greyscale) выберите один из вариантов:

    • (Цветная печать (Color);
    • Оттенки серого (Grayscale) — улучшает вид цветных областей при печати на черно-белом принтере;
    • Черно-белый без серого (Pure Black and White) —все объекты и тона вы водятся черным цветом на белом фоне без промежуточных градаций серого.

В окне диалога параметров печати есть дополнительные флажки, которые включают специальные режимы:

    • Масштабировать по листу (Scale To Fit Paper) — масштабирует слайды так, чтобы они максимально использовали полезную площадь листа;
    • Обрамление слайдов (Frame Slides) — добавляет рамку по краям всех слайдов;
    • Включить страницы с примечаниями (Include Comment Pages) — печатает страницы комментариев для всех слайдов, содержащих комментарии.

  4. С помощью счетчика число копий (Numbers Of Copies) задайте количество печатаемых копий.

  5. В раскрывающемся списке Имя (Name) выберите принтер. Если вы хотите распечатать слайды на прозрачных пленках, необходимо настроить параметры принтера. Для этого выполните следующие шаги.

  6. Щелкните на кнопке Свойства (Properties). Откроется окно диалога параметров принтера. Его вид может быть разным, в зависимости от типа принтера. Например, окно параметров принтера HP DeskJet 500 показано на рис. 15.3.

Рис. 15.3. Параметры принтера

  7. Выберите в этом окне необходимый размер и ориентацию листов прозрачной пленки, а также способ ее подачи.

  8. Щелкните на кнопке ОК.

  9. Чтобы распечатать указанную последовательность слайдов, выдач или заметок, щелкните на кнопке ОК окна диалога Печать (Print).

Упражнение 3. Преобразование в другие форматы

Встроенные инструменты PowerPoint дают возможность рассылать слайды презентации по электронной почте, помещать их в общие папки Outlook, вставлять презентации в документы Word или преобразовывать в web-страницы, которые можно опубликовать в интрасети или через Интернет.

Команды подменю Файл > Отправить (File > Send To) позволяют переслать слайды PowerPoint в следующие места назначения:

    • Сообщение (на рецензию) (Mail Recipient (for Review)) — вставляет слайд в электронное письмо Outlook;
    • Вложение в сообщение (Mail Recipient (As Attachment)) - присоединяет файл презентации к электронному письму Outlook;
    • По маршруту— отправка нескольким адресатам в определенной порядке;
    • Участнику собрания по сети (Online Meeting Participant) —позволяет демонстрировать презентацию через сеть в реальном времени с помощью системы NetMeeting;
    • Папка Exchange (Exchange Folder) — помещает презентацию в общую папку обмена документами между пользователями;
    • в Microsoft Word (Microsoft Word) — помещает презентацию в документ Word.

Чтобы добавить презентацию в файл Microsoft Word, выполните следуюхщие действия.

  1. Откройте презентацию План-ppt.

  2. Выберите команду Файл > Отправить > Microsoft Word (File > Send To > Microsoft Word). Появится окно диалога, показанное на рис. 15.4.

Рис. 15.4. Выбор разметки страницы

  3. В разделе Разметка страницы в Microsoft Word (Page Layout In Microsoft Word) выберите вариант размещения слайдов и заметок на страницах документа Word.

  4. Переключатель Добавить слайды в документ Microsoft Word (Add Slides To Microsoft Word Document) предлагает два режима вставки презентации:

    • Вставить (Paste) —добавляет в документ Word копию презентации, которая хранится в документе;
    • Связать (Paste Link) — связывает документ Word с презентацией. При этом вы видите содержание презентации в окне Word, но исходная информация остается в файле данных PowerPoint. При таком подходе обновление презентации влечет за собой одновременное обновление документа Word, однако для переноса такого документа, например, на другой компьютер, необходимо копировать не только документ Word, -но и саму презентацию, связанную с этим документом.

  5. Щелкните на кнопке ОК. В результате автоматически запустится приложение Word, откроется новый документ, в который будет вставлена презентация. Теперь, пользуясь широкими возможностями текстового процессора, вы сможете снабдить слайды необходимыми пояснениями и распечатать их на принтере. Промежуточным вариантом между распечаткой прозрачных пленок и электронным слайд-шоу является презентация, сохраненная в формате HTML. Полученные таким образом web-страницы можно опубликовать на web-узле, предоставив к ним доступ через интрасеть или Интерпет. Презентацией в виде web-страниц нельзя управлять, пользователь сам перемещается по слайдам. Но вы можете разместить на слайдах гиперссылки, подобные тем, которые были добавлены в файл План.рр1 на предыдущем занятии. Гиперссылки помогают пользователю ориентироваться в презентации. Давайте сохраним презентацию План.ррt в формате HTML.

  6. Выберите команду Файл > Сохранить как web-страницу (File > Save As Web Page). В открывшемся окне диалога выберите папку для web-страниц и в качестве имени введите название главного HTML-файла, с помощью которого будет инициирован просмотр презентации.

  7. Щелкните на кнопке Опубликовать (Publish). Откроется окно диалога, показанное на рис. 15.5.

Рис. 15.5. Параметры публикации

Примечание

Как и в PowerPoint 2000, в данной версии процедура записи презентации в формат HTML значительно упрощена по сравнению с PowerPoint 97, в котором для этих целей использовался специальный мастер. Если вместо кнопки Опубликовать щелкнуть на кнопке Сохранить, то PowerPoint сразу запишет презентацию в формате HTML, не открывая окна настройки дополнительных параметров.

  8. Выберите положение Все перечисленные обозреватели (All Browsers Listed Above) переключателя Поддержка обозревателя (Browser Support), чтобы презентация одинаково хорошо смотрелась как в Internet Explorer, так и в Netscape Navigator..

  9. При необходимости в разделе Объект для публикации (Publish What) выберите положение переключателя Слайды (Slide Number) и введите в счетчики номера первого и последнего слайдов публикуемой последовательности.

  10. Щелкните на кнопке Веб-параметры (Web Options). В открывшемся окне диалога есть шесть вкладок, на которых расположены следующие параметры:

    • Общие (General) — режимы отображения инструментов навигации и анимационных переходов, цвет фона браузера;
    • Обозреватели (Browsers) — выбор типа браузера для просмотра web-страниц и некоторых его дополнительных параметров;
    • Файлы (Files) — правила расположения и генерации имен файлов web-страниц;
    • Картинки (Pictures) — формат графических объектов и предполагаемое разрешение экрана компьютера;
    • Кодировка (Encoding) — язык кодирования текста;
    • Шрифты (Fonts) — выбор языка, шрифта и его размера.

Рис. 15.6. Презентация в окне браузера

  11. Два раза щелкните на кнопках Опубликовать, а затем на кнопке ОК. PowerPoint создаст в указанной папке индексный файл с указанным именем и расширением НТМ и добавит в эту папку вложенную папку, в которой разместятся остальные файлы web-страниц презентации.

  12. Откройте Проводник (Windows Explorer), найдите в нем новый индексный файл (он будет называться План.htm, если вы не изменили имя, выбираемое по умолчанию) и дважды щелкните на нем.

Первый слайд презентации откроется в окне стандартного браузера Windows, как показано на рис. 15.6. Если вы не изменяли параметры Web, то в правую часть окна браузера будет выведена структура презентации, а снизу появятся кнопки навигации, позволяющие перемещаться по слайдам. В презентации План.ppt слайды можно также переключать щелчками па стрелках с гиперссылками, добавленными на предыдущем занятии.

Разработка слайд-фильма

В последнее время все большую популярность получают слайд-фильмы — скомпонованные последовательности слайдов со специальными эффектами, которые демонстрируются на большом экране с помощью компьютерного проектора или в интрасети. Если вы собираетесь воспроизводить презентацию в виде слайд-фильма, можете воспользоваться дополнительными оформительскими возможностями PowerPoint.

Упражнение 4. Организация переходов

В обычном режиме слайды презентационной последовательности просто сменяют друг друга. Настроив переходы между слайдами, можно приукрасить этот процесс, заставив слайды плавно перетекать друг в друга.

  1. Откройте файл План.ppt.

  2. Выберите команду Показ слайдов > Смена слайдов (Slide Show > Slide Transition).

  3. В списке Применить к выделенному слайду (Apply to selected slide) открывшегося в области задач окна Смена слайдов (Slide Transition) (рис. 15.7) выберите один из доступных эффектов перехода, например пункт Наплыв вправо-вниз (Cover Right-Down).

  4. В списке Скорость (Speed) раздела Изменить переход (Modify Transition) выберите положение переключателя средне (Medium), чтобы задать среднюю скорость наплыва слайда. При этом настроенный переход будет показан в поле слайда. Если вы не успели рассмотреть переход, щелкните на надписи Просмотр (Play), эффект перехода будет повторен.

  5. Переберите все пункты списка Применить к выделенному слайду и отыщите тот вариант перехода, который лучше отвечает вашему вкусу.

  6. В разделе Смена слайда (Advance Slide) установите флажок автоматически после (Automatically After).

  7. Введите в одноименное поле число 6. Теперь каждый слайд презентации будет демонстрироваться ровно 6 секунд, после чего автоматически появится следующий слайд.

Рис. 15.7. Настройка перехода

  8. Чтобы озвучить процесс перехода между слайдами, выберите в списке Звук (Sound) один из предлагаемых звуков.

Примечание

Установленный флажок по щелчку (On Mouse Click) разрешает смену слайда щелчком мыши до истечения установленного срока демонстрации.

  9. Щелкните на пункте Применить ко всем (Apply To All), при этом настроенный переход будет назначен всем слайдам презентационной последовательности.

Примечание

Если разным слайдам необходимо назначить различные переходы или неодинаковое время демонстрации, то, игнорируя пункт Применить ко всем, переходите последовательно от слайда к слайду и настраивайте переход для каждого. Продолжайте этот процесс, пока не переберете все слайды.

  10. Выберите команду Показ слайдов > Начать показ (Slide Show > View Show) и понаблюдайте за автоматической сменой слайдов и анимационными эффектами, прослушайте звуки, сопровождающие переходы.

Примечание

Настроить переход от кадра к кадру можно просто щелкнув правой кнопкой на слайде в обычном режиме и выбрав в контекстном меню команду Смена кадра (Slide Transition). При этом отображается область задач с окном Смена кадра (Slide Transition).

Упражнение 5. Анимация объектов

В дополнение к переходам между слайдами PowerPoint позволяет настроить анимацию объектов слайдов. Давайте изучим возможности анимации на примере пунктов маркированного списка.

  1. Перейдите ко второму слайду презентации, который называется Содержание доклада.

  2. Выберите команду Показ слайдов > Настройка анимации (Slide Show > Custom Animation).

В области задач откроется окно Настройка анимации (Custom Animation). В центре окна перечислены все объекты слайда — это заголовок Заголовок 2 (Title 2) и элементы маркированного списка (рис. 15.8). Ниже находятся две стрелки, направленные вниз и вверх, позволяющие менять очередность анимации выделенного элемента.

Рис. 15.8. Настройка анимации

  3. Щелкните на пункте Заголовок 2 списка элементов. Раскрывающийся список Изменить (Change) предлагает варианты способов применения эффектов анимации с набором готовых схем анимации. Выберите для заголовка вариант Вход >Жалюзи (Entrance > Blinds).

  4. Щелкните на треугольнике рядом с выделенным элементом. В раскрывающемся списке, щелкнув на команде Параметры эффекта (Effect Options), вызовите на экран окно диалога Жалюзи (Blinds) с тремя вкладками, позволяющими уточнить параметры установки выбранной анимации, а также задать интервалы времени, определяющие скорость автоматического появления объекта и анимацию текста. Кроме того, параметры выбранной анимации (в данном случае, направление и скорость) можно уточнить в разделе Изменить (Modify).

  5. Аналогичным образом назначьте анимацию элементам маркированного списка.

  6. Нажатием клавиши F5 запустите показ презентации.

Примечание

С помощью команды Просмотр (Play) внизу окна Настройка анимации можно наблюдать эффект анимации текущего слайда на всех этапах настройки.

Упражнение 6. Скрытие слайда

Некоторые слайды презентации могут играть вспомогательную роль и демонстрироваться слушателям только при необходимости детального разъяснения конкретного вопроса. Такие слайды можно скрыть, и они не будут появляться в презентационной последовательности, однако докладчик в любой момент сможет вызвать их на экран с помощью специальных команд. Слайды 5 и 6 презентации План.рр! пока не содержат никакой информации, давайте скроем их.

Примечание

С помощью кнопок панели инструментов сортировщика слайдов Смена слайдов (Slide Transition Effects) и Настройка анимации (Present Animation) можно быстро в области задач сменить режим перехода и анимацию объектов выделенных слайдов.

  1. С помощью команды Вид > Сортировщик слайдов (View > Slide Sorter) переклю читесь в режим сортировщика.

  2. Щелчком выделите слайд 6.

  3. Чтобы скрыть выделенный слайд, щелкните на кнопке Скрыть слайд (Hide Slide) панели инструментов Сортировщик слайдов.

  4. Повторите шаги 2 и 3 для слайда 5. Обратите внимание, что теперь номера слайдов 5 и 6 перечеркнуты, что указывает на их скрытый статус (рис. 15.9).

Примечание

Чтобы вернуть слайд в презентационную последовательность, выделите его и повторно щелкните на кнопке Скрыть слайд.

В режиме сортировщика под слайдами выводится не только порядковый номер, но и значок перехода.

  5. Щелкните на значке перехода под вторым слайдом, и вы увидите в окне сортировщика анимацию перехода от первого ко второму слайду и затем всю анимационную последовательность слайда.

Рис. 15.9. Скрытие слайдов в режиме сортировщика

Правее значка перехода указано время демонстрации слайда, после которого выполняется автоматический переход к следующему слайду. Как видите, режим сортировщика дает возможность быстро просмотреть все назначенные эффекты и хронометраж презентации.

Демонстрация слайд-фильма

Режимы слайдов и сортировщика позволяют настраивать и просматривать все анимационные эффекты. Однако чтобы увидеть их на полном экране, протестировать гиперссылки слайдов, настроить время демонстрации и записать сопроводительную речь диктора, следует воспользоваться режимом полноэкранного просмотра, который применяется и при окончательной демонстрации презентационной последовательности.

Упражнение7. Хронометраж

Если время доклада лимитировано, а ваша речь хорошо подготовлена, не имеет смысла тратить время на ручную смену слайдов. Эту задачу можно возложить на

PowerPoint. В упражнении 4 вы уже назначили каждому слайду интервал демонстрации, равный 6 секундам. Но вручную выставлять время показа неудобно. Проще воспользоваться инструментом настройки времени.

  1. Щелкните на кнопке Настройка времени (Rehearse Timing). PowerPoint запустит полноэкранную демонстрацию и откроет окно диалога Репетиция (Rehearsal), которое показано на рис. 15.10.

Рис. 15.10. Настройка времени

  2. Проговорите ту часть доклада, которая должна завершиться на фоне титульного слайда, и щелкните на кнопке Далее. Произойдет смена слайда.

  3. Объясните содержание нового слайда и снова щелкните на кнопке Далее.

  4. Продолжайте репетицию доклада в том же духе, пока не закончится презен-тационная последовательность.

Примечание

Во время показа второго слайда вам придется щелкать на кнопке Далее несколько раз, инициируя каждый шаг настроенной анимации объектов.

В процессе записи временных интервалов в поле Время слайда (Slide Time) выводится время показа текущего слайда, а в правую часть окна диалога Репетиция (Rehearse Timing) — общее время от начала презентации. Если вы сбились и хотите повторить репетицию речи для текущего слайда, щелкните на кнопке Повторить (Repeat). PowerPoint сбросит поле Время слайда на ноль и начнет новый отсчет времени показа текущего слайда. Кнопка Пауза (Pause) позволяет временно приостановить хронометраж. Повторный щелчок на этой кнопке даст возможность продолжить репетицию доклада.

Щелчок на кнопке Далее во время показа последнего слайда приведет к остановке хронометража и появлению окна диалога с запросом о необходимости обновления временных интервалов.

  5. Чтобы подтвердить выбранную длительность показа слайдов, щелкните на кнопке Да (Yes). Новые интервалы демонстрации появятся под слайдами в режиме сортировщика.

Упражнение 8. Запись речи диктора

Чтобы записать в презентацию звуковую дорожку, сопровождающую демонстрацию слайдов, необходимо иметь в компьютере звуковую карту и подключенный к ней микрофон. Такую презентацию со звуковой дорожкой можно использовать в качестве рекламного ролика. Чтобы записать звуковое сопровождение, выполните следующие шаги.

  1. Выберите команду Показ слайдов > Звукозапись.

  2. В открывшемся окне диалога (рис. 15.11) щелкните на кнопке Громкость микрофона (Set Microphone Level).

Рис. 15.11. Настройка звукозаписи

  3. Скажите в микрофон какую-нибудь фразу и проверьте, чтобы на экране появилась полоска, показывающая уровень сигнала. При необходимости настройте уровень записи с помощью ползунка. Затем щелкните на кнопке ОК. В окне диалога Запись речевого сопровождения (Record Narration) отображается выбранный режим записи. Здесь указывается интенсивность использования диска, свободное пространство диска и соответствующее ему максимально возможное время записи. Щелкнув на кнопке Изменить качество (Change Quality), вы можете открыть окно диалога, позволяющее изменить параметры качества записи. Но не забывайте, что при повышении качества запись занимает больше места на диске.

  4. Если предполагается записывать длинный доклад, установите флажок Связать речевое сопровождение с (Link Narrations In), щелкните на кнопке Обзор (Browse) и укажите каталог для записи сообщения. В таком варианте сообщение записывается в отдельный файл. В результате, выезжая в командировку, вы сможете показывать презентацию без текстового сопровождения, ' файл которого оказался слишком велик, чтобы сохранить его на гибких дисках. Если указанный флажок сброшен, звук записывается непосредственно в файл презентации.

  5. Щелкните на кнопке ОК.

  6. Чтобы начать запись с первого слайда, щелкните на кнопке Первый слайд (First Slide).

  7. Проговорите текст доклада. Для примера можете просто повторить текст слайдов. В нужных местах сменяйте слайды презентации щелчком мыши в любой точке экрана.

  8. По завершении презентации появится окно диалога, запрашивающее о необходимости обновления ранее настроенного хронометража. Если сообщения были короткими и при их записи вы сменяли слайды быстрее, чем это необходимо, щелкните на кнопке Нет (No). Чтобы заменить прежний хронометраж, щелкните на кнопке Да.

Примечание

После записи доклада на каждом слайде презентации появится дополнительный объект— записанный звук. Он будет представлен значком громкоговорителя. С помощью команды Показ слайдов > Настройка анимации можно настроить режим воспроизведения этого мультимедийного объекта. Чтобы удалить звук со слайда, просто выделите его значок и нажмите клавишу Delete.

Не всегда удается с первого раза без ошибок записать всю звуковую дорожку. Чтобы изменить сообщение для одного слайда, выполните следующие действия.

  9. Перейдите к нужному слайду в обычном режиме или выделите этот слайд в режиме сортировщика.

  10. Выберите команду Показ слайдов > Звукозапись, настройте параметры звукозаписи и щелкните на кнопке ОК.

  11. Щелкните на кнопке Текущий слайд (Current Slide). Во время демонстрации слайда проговорите в микрофон нужный текст.

  12. Щелкните правой кнопкой мыши и выберите в контекстном меню команду Завершить демонстрацию (End Show).

Примечание

При повторной записи звукового фрагмента не завершайте демонстрацию нажатием клавиши Esc. Это приведет к отмене записи звука.

  13. Щелкните на одной из кнопок открывшегося окна диалога в соответствии с инструкциями шага 8.

Упражнение 9. Запуск слайд-фильма

Вы уже, наверное, догадались, что запустить демонстрацию слайд-фильма можно выбором команды Показ слайдов > Начать показ (Slide Show > View Show) или простым нажатием клавиши F5. Однако, готовясь показать презентацию перед большой аудиторией, следует настроить параметры демонстрации и научиться манипулировать слайдами.

  1. Выберите команду Показ слайдов > Настройка презентации (Slide Show > Set Up Show).

Переключатель и флажки раздела Показ слайдов (Show Type) открывшегося окна диалога (рис. 15.12) позволяют задать следующие режимы:

  • управляемый докладчиком (Presented By A Speaker) — полноэкранный режим демонстрации;

  • управляемый пользователем (Browsed By An Individual) — демонстрация в окне;

  • с полосой прокрутки (Show Scrollbar) — добавление полосы прокрутки в окопном режиме просмотра;

  • автоматический (Browsed At A Kiosk) — автоматически повторяющаяся бесконечное число раз демонстрация всей последовательности;

  • непрерывный цикл до нажатия клавиши "Esc" (Loop Continuously Until "Esc") — переход к первому слайду после показа последнего;

  • без речевого сопровождения (Show Without Narration) — отключение всех записанных звуковых сообщений;

  • без анимации (Show Without Animation) — отключение анимации объектов слайдов.

Рис. 15.12. Параметры слайд-шоу

  2. Чтобы демонстрировались только некоторые слайды, введите номера первого и последнего слайдов последовательности в счетчики от (From) и до (То) и выберите соответствующее положение переключателя.

  3. Для отмены автоматической смены слайдов выберите положение переключателя вручную (Manually). Теперь презентация полностью находится под вашим контролем.

  4. Завершив настройку, щелкните на кнопке ОК.

  5. Нажатием клавиши F5 запустите показ презентации.

Управление слайд-фильмом производится с помощью кнопки контекстного меню и самого"меню, которые показаны на рис. 15.13.

  6. Для вызова меню щелкните на кнопке меню или щелкните правой кнопкой мыши в произвольной точке экрана.

Примечание

Чтобы во время демонстрации кнопка меню не появлялась на экране, выберите команду Сервис > Параметры (Tools > Options) и на вкладке Вид (View) сбросьте флажок Показывать кнопку контекстного меню (Show Popup Menu Button). При этом проверьте, чтобы был установлен флажок Контекстное меню при щелчке правой кнопкой (Popup Menu On Right Mouse Click).

Команды Далее и Назад контекстного меню позволяют переходить на один слайд вперед и назад. Чтобы перейти к конкретному слайду (в том числе скрытому), раскройте подменю Переход > Выбор слайда по имени (Go > By Title) и выберите слайд в появившемся списке.

  7. Щелкая левой кнопкой мыши, пролистайте все слайды презентации, прослушав записанную звуковую дорожку. Если понадобится сделать перерыв, не стоит оставлять на экране текущий слайд (особенно при показе презентации с помощью проектора в большом зале). Команда Экран > Черный экран (Screen > Black Screen) отключает показ, заменяя слайд черным нолем. Чтобы возобновить презентацию, просто щелкните мышью. Презентацией можно управлять и с помощью клавиатуры, пользуясь комбинациями, перечисленными в табл. 15.1.

Таблица. 15.1. Клавиши управления показом презентации
Клавиша или клавиатурная комбинация | Операция
Пробел, вправо, вверх, Page Down или N | Переход к следующему слайду
Backspace, влево, вверх, Page Up или Р | Возврат к предыдущему слайду
Номер слайда+Enter | Переход к слайду с указанным номером
В или Точка | Черный экран/возврат слайда
W или Запятая | Белый экран/возврат слайда
Ctrl+P | Режим карандаша, позволяющий, протаскивая мышь по слайду, рисовать на нем прямо в режиме демон страции
Ctrl+H | Скрыть указатель мыши
Ctrl+A | Возврат к обычному указателю мыши
S или Серый плюс | Остановка/возобновление автоматической демонстраниции
Н | Показать скрытый слайд, расположенный вслед за текущим
Esc | Закончить демонстрацию

Контрольное упражнение

Чтобы закрепить знания и попрактиковаться в построении слайд-шоу с переходами и анимациями, выполните следующее задание.

  1. Откройте презентацию План продаж.ppt, созданную на занятии 13 с помощью мастера автосодержания.

  2. Распечатайте второй слайд презентации.
  3. Отправьте презентацию по электронной почте своему коллеге.
    • Как присоединить презентацию к электронному сообщению?

  4. Переключитесь в режим сортировщика.

  5. С помощью кнопок панели инструментов сортировщика назначьте первым трем слайдам переходы Жалюзи горизонтальные (Blinds Horizontal), а остальным слайдам переходы Жалюзи вертикальные (Blinds Vertical).

  6. Текстовым объектам пятого и шестого слайдов задайте, соответственно, анимацию Прямоугольник внутрь (Box In) и Прямоугольник наружу (Box Out).

  7. Скройте 10-й и 12-й слайды.
  8. Запишите речь диктора для нескольких слайдов с качеством Радиотрансляция.
    • Как изменить качество записи?

  9. Настройте параметры просмотра слайд-фильма, чтобы он демонстрировался в окне браузера без линейки прокрутки, без анимации, а после последнего слайда выполнялся переход на первый слайд.

    • Какиережимы следует выбрать в окне параметров слайд-фильма? 10. Запустите просмотр презентации.

Подведение итогов

Это занятие завершает серию упражнений, в которых изучалась программа PowerPoint. Теперь вы умеете не только создавать слайды, но и строить из них последовательность плавно перетекающих друг в друга кадров с анимацией и звуковым сопровождением. Вы можете отправить презентацию по почте, переслать ее в документ Word, преобразовать в набор web-страниц или продемонстрировать на экране компьютера в виде интерактивного слайд-фильма.

Три следующих занятия книги посвящены приложению Microsoft Access, которое позволяет помещать информацию в базу данных, извлекать ее в соответствии с определенными условиями отбора, печатать отчеты и выполнять многие другие операции с большими информационными массивами.


Занятие №15

Публикация презентации

ТЕМА ЗАНЯТИЯ

Упражнения этого занятия научат вас печатать слайды презентации на бумаге и прозрачных пленках, сохранять их в формате HTML и представлять в виде электронного слайд-шоу. Ниже перечислены операции, с которыми вы здесь познакомитесь:

  • настройка параметров страниц;

  • экспорт слайдов в другие приложения;

  • преобразование в формат HTML;

  • настройка переходов;

  • анимация объектов;

  • запись звукового сопровождения;

  • демонстрация слайд-фильма.

Завершив процесс создания презентационной последовательности, следует подумать о том, в каком виде слайды должны быть представлены на суд общественности. PowerPoint позволяет печатать со слайдов прозрачные пленки (прозрачки) или страницы доклада, содержащие до шести слайдов с комментариями на одном листе. Можно вывести презентацию на 35-миллиметровые слайды или преобразовать в формат HTML и разместить на web-узле. Наконец, можно показать их в виде интерактивного слайд-фильма, в котором слайды сопровождаются привлекательными переходами, записанным звуком и другими эффектами.


Публикация презентации

Преимуществом печатного варианта представления презентации является его независимость от компьютеров. Прозрачные пленки со слайдами презентации можно показать в любом конференц-зале на большом экране, а страницы с комментариями просто раздать коллегам для ознакомления. С другой стороны, в печатной копии исчезают добавленные электронные эффекты.


Упражнение 1. Параметры страницы

Перед выводом слайдов на печать следует проверить установленные параметры страницы. Стандартные величины, выбираемые в PowerPoint no умолчанию, обычно подходят для электронного слайд-фильма и печати прозрачных пленок. Менять их имеет смысл при выводе презентации на 35-миллиметровые слайды или на бумагу специального формата.

  1. Чтобы проверить параметры страницы, выберите команду Файл > Параметры страницы (File > Page Setup). Откроется окно диалога, показанное на рис. 15.1.

Рис. 15.1. Параметры страницы

  2. В раскрывающемся списке Размер слайдов (Slide Sized For) выберите один из стандартных размеров. Например, для печати прозрачных пленок следует указать пункт Прозрачка (Overhead).

  3. Если создаваемая презентация является продолжением предыдущего доклада, измените нумерацию слайдов, задав номер первого из них с помощью счетчика Нумеровать слайды с (Number Slides From).

Примечание

При выборе пункта Произвольный (Custom) с помощью счетчиков Ширина (Width) и Высота (Height) можно задавать произвольные размеры страницы. По умолчанию вариант Произвольный устанавливает размеры поля вывода для текущего принтера.

PowerPoint позволяет выбирать разную ориентацию страницы для вывода слайдов и для печати заметок, раздаточных материалов и структуры.

  4. В разделе Ориентация (Orientation) проверьте ориентацию страницы. Обычно для слайдов устанавливается положение переключателя Альбомная (Landscape), а для остальных документов — Книжная (Portrait).

Примечание

Если предполагается печатать презентацию на прозрачных пленках, можете выбрать для слайдов книжную ориентацию, но это лучше сделать перед разработкой содержания слайдов, так как в противном случае придется корректировать компоновку объектов презентации.

  5. Щелкните на кнопке ОК.


Упражнение 2. Печать слайдов, заметок и структуры

Чтобы распечатать презентацию на бумагу или прозрачные пленки, выполните следующие действия.

  1. Выберите команду Файл > Печать (File > Print). Откроется окно диалога, показанное на рис. 15.2.

Рис. 15.2. Настройка параметров печати

  2. В раскрывающемся списке Печатать (Print What) выберите тип печатаемого документа. Здесь доступны следующие варианты:

    • Слайды (Slides) — печать слайдов по одному на каждой странице;
    • Выдачи (Handouts) — вывод материалов для раздачи слушателям. В этом варианте на одной странице печатается несколько слайдов. Для указания количества и расположения слайдов на страницах пользуйтесь параметрами раздела Выдачи. Для конфигурирования выдач можно также воспользоваться образцом выдач, который открывается командой Вид > Образец > Образец выдач (View > Master > Handout Master);
    • Заметки (Notes Pages) — печать страниц заметок, на каждой из которых размещаюется один слайд и текст заметок к слайду, в обычном режиме просмотра располагающиеся под текущим слайдом. Формат страниц заметок можно настроить с помощью соответствующего образца, доступного в подменю Вид > Образец (View > Master);
    • Структуру (Outline View) — вывод на принтер только структуры презентации, идентичной той, которая отображается в режиме просмотра структуры.

  3. В разделе Диапазон печати (Print Range) выберите положение переключателя все (All), чтобы напечатать все слайды, или текущий слайд (Current Slide), чтобы вывести один текущий слайд, либо выберите положение переключателя слайды (Slides) и введите в одноименное поле номера тех слайдов, которые нужно напечатать. В раскрывающемся списке Цвет или оттенки серого (Color/ Greyscale) выберите один из вариантов:

    • (Цветная печать (Color);
    • Оттенки серого (Grayscale) — улучшает вид цветных областей при печати на черно-белом принтере;
    • Черно-белый без серого (Pure Black and White) —все объекты и тона вы водятся черным цветом на белом фоне без промежуточных градаций серого.

В окне диалога параметров печати есть дополнительные флажки, которые включают специальные режимы:

    • Масштабировать по листу (Scale To Fit Paper) — масштабирует слайды так, чтобы они максимально использовали полезную площадь листа;
    • Обрамление слайдов (Frame Slides) — добавляет рамку по краям всех слайдов;
    • Включить страницы с примечаниями (Include Comment Pages) — печатает страницы комментариев для всех слайдов, содержащих комментарии.

  4. С помощью счетчика число копий (Numbers Of Copies) задайте количество печатаемых копий.

  5. В раскрывающемся списке Имя (Name) выберите принтер. Если вы хотите распечатать слайды на прозрачных пленках, необходимо настроить параметры принтера. Для этого выполните следующие шаги.

  6. Щелкните на кнопке Свойства (Properties). Откроется окно диалога параметров принтера. Его вид может быть разным, в зависимости от типа принтера. Например, окно параметров принтера HP DeskJet 500 показано на рис. 15.3.

Рис. 15.3. Параметры принтера

  7. Выберите в этом окне необходимый размер и ориентацию листов прозрачной пленки, а также способ ее подачи.

  8. Щелкните на кнопке ОК.

  9. Чтобы распечатать указанную последовательность слайдов, выдач или заметок, щелкните на кнопке ОК окна диалога Печать (Print).


Упражнение 3. Преобразование в другие форматы

Встроенные инструменты PowerPoint дают возможность рассылать слайды презентации по электронной почте, помещать их в общие папки Outlook, вставлять презентации в документы Word или преобразовывать в web-страницы, которые можно опубликовать в интрасети или через Интернет.

Команды подменю Файл > Отправить (File > Send To) позволяют переслать слайды PowerPoint в следующие места назначения:

    • Сообщение (на рецензию) (Mail Recipient (for Review)) — вставляет слайд в электронное письмо Outlook;
    • Вложение в сообщение (Mail Recipient (As Attachment)) - присоединяет файл презентации к электронному письму Outlook;
    • По маршруту— отправка нескольким адресатам в определенной порядке;
    • Участнику собрания по сети (Online Meeting Participant) —позволяет демонстрировать презентацию через сеть в реальном времени с помощью системы NetMeeting;
    • Папка Exchange (Exchange Folder) — помещает презентацию в общую папку обмена документами между пользователями;
    • в Microsoft Word (Microsoft Word) — помещает презентацию в документ Word.

Чтобы добавить презентацию в файл Microsoft Word, выполните следуюхщие действия.

  1. Откройте презентацию План-ppt.

  2. Выберите команду Файл > Отправить > Microsoft Word (File > Send To > Microsoft Word). Появится окно диалога, показанное на рис. 15.4.

Рис. 15.4. Выбор разметки страницы

  3. В разделе Разметка страницы в Microsoft Word (Page Layout In Microsoft Word) выберите вариант размещения слайдов и заметок на страницах документа Word.

  4. Переключатель Добавить слайды в документ Microsoft Word (Add Slides To Microsoft Word Document) предлагает два режима вставки презентации:

    • Вставить (Paste) —добавляет в документ Word копию презентации, которая хранится в документе;
    • Связать (Paste Link) — связывает документ Word с презентацией. При этом вы видите содержание презентации в окне Word, но исходная информация остается в файле данных PowerPoint. При таком подходе обновление презентации влечет за собой одновременное обновление документа Word, однако для переноса такого документа, например, на другой компьютер, необходимо копировать не только документ Word, -но и саму презентацию, связанную с этим документом.

  5. Щелкните на кнопке ОК. В результате автоматически запустится приложение Word, откроется новый документ, в который будет вставлена презентация. Теперь, пользуясь широкими возможностями текстового процессора, вы сможете снабдить слайды необходимыми пояснениями и распечатать их на принтере. Промежуточным вариантом между распечаткой прозрачных пленок и электронным слайд-шоу является презентация, сохраненная в формате HTML. Полученные таким образом web-страницы можно опубликовать на web-узле, предоставив к ним доступ через интрасеть или Интерпет. Презентацией в виде web-страниц нельзя управлять, пользователь сам перемещается по слайдам. Но вы можете разместить на слайдах гиперссылки, подобные тем, которые были добавлены в файл План.рр1 на предыдущем занятии. Гиперссылки помогают пользователю ориентироваться в презентации. Давайте сохраним презентацию План.ррt в формате HTML.

  6. Выберите команду Файл > Сохранить как web-страницу (File > Save As Web Page). В открывшемся окне диалога выберите папку для web-страниц и в качестве имени введите название главного HTML-файла, с помощью которого будет инициирован просмотр презентации.

  7. Щелкните на кнопке Опубликовать (Publish). Откроется окно диалога, показанное на рис. 15.5.

Рис. 15.5. Параметры публикации

Примечание

Как и в PowerPoint 2000, в данной версии процедура записи презентации в формат HTML значительно упрощена по сравнению с PowerPoint 97, в котором для этих целей использовался специальный мастер. Если вместо кнопки Опубликовать щелкнуть на кнопке Сохранить, то PowerPoint сразу запишет презентацию в формате HTML, не открывая окна настройки дополнительных параметров.

  8. Выберите положение Все перечисленные обозреватели (All Browsers Listed Above) переключателя Поддержка обозревателя (Browser Support), чтобы презентация одинаково хорошо смотрелась как в Internet Explorer, так и в Netscape Navigator..

  9. При необходимости в разделе Объект для публикации (Publish What) выберите положение переключателя Слайды (Slide Number) и введите в счетчики номера первого и последнего слайдов публикуемой последовательности.

  10. Щелкните на кнопке Веб-параметры (Web Options). В открывшемся окне диалога есть шесть вкладок, на которых расположены следующие параметры:

    • Общие (General) — режимы отображения инструментов навигации и анимационных переходов, цвет фона браузера;
    • Обозреватели (Browsers) — выбор типа браузера для просмотра web-страниц и некоторых его дополнительных параметров;
    • Файлы (Files) — правила расположения и генерации имен файлов web-страниц;
    • Картинки (Pictures) — формат графических объектов и предполагаемое разрешение экрана компьютера;
    • Кодировка (Encoding) — язык кодирования текста;
    • Шрифты (Fonts) — выбор языка, шрифта и его размера.

Рис. 15.6. Презентация в окне браузера

  11. Два раза щелкните на кнопках Опубликовать, а затем на кнопке ОК. PowerPoint создаст в указанной папке индексный файл с указанным именем и расширением НТМ и добавит в эту папку вложенную папку, в которой разместятся остальные файлы web-страниц презентации.

  12. Откройте Проводник (Windows Explorer), найдите в нем новый индексный файл (он будет называться План.htm, если вы не изменили имя, выбираемое по умолчанию) и дважды щелкните на нем.

Первый слайд презентации откроется в окне стандартного браузера Windows, как показано на рис. 15.6. Если вы не изменяли параметры Web, то в правую часть окна браузера будет выведена структура презентации, а снизу появятся кнопки навигации, позволяющие перемещаться по слайдам. В презентации План.ppt слайды можно также переключать щелчками па стрелках с гиперссылками, добавленными на предыдущем занятии.


Разработка слайд-фильма

В последнее время все большую популярность получают слайд-фильмы — скомпонованные последовательности слайдов со специальными эффектами, которые демонстрируются на большом экране с помощью компьютерного проектора или в интрасети. Если вы собираетесь воспроизводить презентацию в виде слайд-фильма, можете воспользоваться дополнительными оформительскими возможностями PowerPoint.


Упражнение 4. Организация переходов

В обычном режиме слайды презентационной последовательности просто сменяют друг друга. Настроив переходы между слайдами, можно приукрасить этот процесс, заставив слайды плавно перетекать друг в друга.

  1. Откройте файл План.ppt.

  2. Выберите команду Показ слайдов > Смена слайдов (Slide Show > Slide Transition).

  3. В списке Применить к выделенному слайду (Apply to selected slide) открывшегося в области задач окна Смена слайдов (Slide Transition) (рис. 15.7) выберите один из доступных эффектов перехода, например пункт Наплыв вправо-вниз (Cover Right-Down).

  4. В списке Скорость (Speed) раздела Изменить переход (Modify Transition) выберите положение переключателя средне (Medium), чтобы задать среднюю скорость наплыва слайда. При этом настроенный переход будет показан в поле слайда. Если вы не успели рассмотреть переход, щелкните на надписи Просмотр (Play), эффект перехода будет повторен.

  5. Переберите все пункты списка Применить к выделенному слайду и отыщите тот вариант перехода, который лучше отвечает вашему вкусу.

  6. В разделе Смена слайда (Advance Slide) установите флажок автоматически после (Automatically After).

  7. Введите в одноименное поле число 6. Теперь каждый слайд презентации будет демонстрироваться ровно 6 секунд, после чего автоматически появится следующий слайд.

Рис. 15.7. Настройка перехода

  8. Чтобы озвучить процесс перехода между слайдами, выберите в списке Звук (Sound) один из предлагаемых звуков.

Примечание

Установленный флажок по щелчку (On Mouse Click) разрешает смену слайда щелчком мыши до истечения установленного срока демонстрации.

  9. Щелкните на пункте Применить ко всем (Apply To All), при этом настроенный переход будет назначен всем слайдам презентационной последовательности.

Примечание

Если разным слайдам необходимо назначить различные переходы или неодинаковое время демонстрации, то, игнорируя пункт Применить ко всем, переходите последовательно от слайда к слайду и настраивайте переход для каждого. Продолжайте этот процесс, пока не переберете все слайды.

  10. Выберите команду Показ слайдов > Начать показ (Slide Show > View Show) и понаблюдайте за автоматической сменой слайдов и анимационными эффектами, прослушайте звуки, сопровождающие переходы.

Примечание

Настроить переход от кадра к кадру можно просто щелкнув правой кнопкой на слайде в обычном режиме и выбрав в контекстном меню команду Смена кадра (Slide Transition). При этом отображается область задач с окном Смена кадра (Slide Transition).


Упражнение 5. Анимация объектов

В дополнение к переходам между слайдами PowerPoint позволяет настроить анимацию объектов слайдов. Давайте изучим возможности анимации на примере пунктов маркированного списка.

  1. Перейдите ко второму слайду презентации, который называется Содержание доклада.

  2. Выберите команду Показ слайдов > Настройка анимации (Slide Show > Custom Animation).

В области задач откроется окно Настройка анимации (Custom Animation). В центре окна перечислены все объекты слайда — это заголовок Заголовок 2 (Title 2) и элементы маркированного списка (рис. 15.8). Ниже находятся две стрелки, направленные вниз и вверх, позволяющие менять очередность анимации выделенного элемента.

Рис. 15.8. Настройка анимации

  3. Щелкните на пункте Заголовок 2 списка элементов. Раскрывающийся список Изменить (Change) предлагает варианты способов применения эффектов анимации с набором готовых схем анимации. Выберите для заголовка вариант Вход >Жалюзи (Entrance > Blinds).

  4. Щелкните на треугольнике рядом с выделенным элементом. В раскрывающемся списке, щелкнув на команде Параметры эффекта (Effect Options), вызовите на экран окно диалога Жалюзи (Blinds) с тремя вкладками, позволяющими уточнить параметры установки выбранной анимации, а также задать интервалы времени, определяющие скорость автоматического появления объекта и анимацию текста. Кроме того, параметры выбранной анимации (в данном случае, направление и скорость) можно уточнить в разделе Изменить (Modify).

  5. Аналогичным образом назначьте анимацию элементам маркированного списка.

  6. Нажатием клавиши F5 запустите показ презентации.

Примечание

С помощью команды Просмотр (Play) внизу окна Настройка анимации можно наблюдать эффект анимации текущего слайда на всех этапах настройки.


Упражнение 6. Скрытие слайда

Некоторые слайды презентации могут играть вспомогательную роль и демонстрироваться слушателям только при необходимости детального разъяснения конкретного вопроса. Такие слайды можно скрыть, и они не будут появляться в презентационной последовательности, однако докладчик в любой момент сможет вызвать их на экран с помощью специальных команд. Слайды 5 и 6 презентации План.рр! пока не содержат никакой информации, давайте скроем их.

Примечание

С помощью кнопок панели инструментов сортировщика слайдов Смена слайдов (Slide Transition Effects) и Настройка анимации (Present Animation) можно быстро в области задач сменить режим перехода и анимацию объектов выделенных слайдов.

  1. С помощью команды Вид > Сортировщик слайдов (View > Slide Sorter) переклю читесь в режим сортировщика.

  2. Щелчком выделите слайд 6.

  3. Чтобы скрыть выделенный слайд, щелкните на кнопке Скрыть слайд (Hide Slide) панели инструментов Сортировщик слайдов.

  4. Повторите шаги 2 и 3 для слайда 5. Обратите внимание, что теперь номера слайдов 5 и 6 перечеркнуты, что указывает на их скрытый статус (рис. 15.9).

Примечание

Чтобы вернуть слайд в презентационную последовательность, выделите его и повторно щелкните на кнопке Скрыть слайд.

В режиме сортировщика под слайдами выводится не только порядковый номер, но и значок перехода.

  5. Щелкните на значке перехода под вторым слайдом, и вы увидите в окне сортировщика анимацию перехода от первого ко второму слайду и затем всю анимационную последовательность слайда.

Рис. 15.9. Скрытие слайдов в режиме сортировщика

Правее значка перехода указано время демонстрации слайда, после которого выполняется автоматический переход к следующему слайду. Как видите, режим сортировщика дает возможность быстро просмотреть все назначенные эффекты и хронометраж презентации.


Демонстрация слайд-фильма

Режимы слайдов и сортировщика позволяют настраивать и просматривать все анимационные эффекты. Однако чтобы увидеть их на полном экране, протестировать гиперссылки слайдов, настроить время демонстрации и записать сопроводительную речь диктора, следует воспользоваться режимом полноэкранного просмотра, который применяется и при окончательной демонстрации презентационной последовательности.


Упражнение7. Хронометраж

Если время доклада лимитировано, а ваша речь хорошо подготовлена, не имеет смысла тратить время на ручную смену слайдов. Эту задачу можно возложить на

PowerPoint. В упражнении 4 вы уже назначили каждому слайду интервал демонстрации, равный 6 секундам. Но вручную выставлять время показа неудобно. Проще воспользоваться инструментом настройки времени.

  1. Щелкните на кнопке Настройка времени (Rehearse Timing). PowerPoint запустит полноэкранную демонстрацию и откроет окно диалога Репетиция (Rehearsal), которое показано на рис. 15.10.

Рис. 15.10. Настройка времени

  2. Проговорите ту часть доклада, которая должна завершиться на фоне титульного слайда, и щелкните на кнопке Далее. Произойдет смена слайда.

  3. Объясните содержание нового слайда и снова щелкните на кнопке Далее.

  4. Продолжайте репетицию доклада в том же духе, пока не закончится презен-тационная последовательность.

Примечание

Во время показа второго слайда вам придется щелкать на кнопке Далее несколько раз, инициируя каждый шаг настроенной анимации объектов.

В процессе записи временных интервалов в поле Время слайда (Slide Time) выводится время показа текущего слайда, а в правую часть окна диалога Репетиция (Rehearse Timing) — общее время от начала презентации. Если вы сбились и хотите повторить репетицию речи для текущего слайда, щелкните на кнопке Повторить (Repeat). PowerPoint сбросит поле Время слайда на ноль и начнет новый отсчет времени показа текущего слайда. Кнопка Пауза (Pause) позволяет временно приостановить хронометраж. Повторный щелчок на этой кнопке даст возможность продолжить репетицию доклада.

Щелчок на кнопке Далее во время показа последнего слайда приведет к остановке хронометража и появлению окна диалога с запросом о необходимости обновления временных интервалов.

  5. Чтобы подтвердить выбранную длительность показа слайдов, щелкните на кнопке Да (Yes). Новые интервалы демонстрации появятся под слайдами в режиме сортировщика.


Упражнение 8. Запись речи диктора

Чтобы записать в презентацию звуковую дорожку, сопровождающую демонстрацию слайдов, необходимо иметь в компьютере звуковую карту и подключенный к ней микрофон. Такую презентацию со звуковой дорожкой можно использовать в качестве рекламного ролика. Чтобы записать звуковое сопровождение, выполните следующие шаги.

  1. Выберите команду Показ слайдов > Звукозапись.

  2. В открывшемся окне диалога (рис. 15.11) щелкните на кнопке Громкость микрофона (Set Microphone Level).

Рис. 15.11. Настройка звукозаписи

  3. Скажите в микрофон какую-нибудь фразу и проверьте, чтобы на экране появилась полоска, показывающая уровень сигнала. При необходимости настройте уровень записи с помощью ползунка. Затем щелкните на кнопке ОК. В окне диалога Запись речевого сопровождения (Record Narration) отображается выбранный режим записи. Здесь указывается интенсивность использования диска, свободное пространство диска и соответствующее ему максимально возможное время записи. Щелкнув на кнопке Изменить качество (Change Quality), вы можете открыть окно диалога, позволяющее изменить параметры качества записи. Но не забывайте, что при повышении качества запись занимает больше места на диске.

  4. Если предполагается записывать длинный доклад, установите флажок Связать речевое сопровождение с (Link Narrations In), щелкните на кнопке Обзор (Browse) и укажите каталог для записи сообщения. В таком варианте сообщение записывается в отдельный файл. В результате, выезжая в командировку, вы сможете показывать презентацию без текстового сопровождения, ' файл которого оказался слишком велик, чтобы сохранить его на гибких дисках. Если указанный флажок сброшен, звук записывается непосредственно в файл презентации.

  5. Щелкните на кнопке ОК.

  6. Чтобы начать запись с первого слайда, щелкните на кнопке Первый слайд (First Slide).

  7. Проговорите текст доклада. Для примера можете просто повторить текст слайдов. В нужных местах сменяйте слайды презентации щелчком мыши в любой точке экрана.

  8. По завершении презентации появится окно диалога, запрашивающее о необходимости обновления ранее настроенного хронометража. Если сообщения были короткими и при их записи вы сменяли слайды быстрее, чем это необходимо, щелкните на кнопке Нет (No). Чтобы заменить прежний хронометраж, щелкните на кнопке Да.

Примечание

После записи доклада на каждом слайде презентации появится дополнительный объект— записанный звук. Он будет представлен значком громкоговорителя. С помощью команды Показ слайдов > Настройка анимации можно настроить режим воспроизведения этого мультимедийного объекта. Чтобы удалить звук со слайда, просто выделите его значок и нажмите клавишу Delete.

Не всегда удается с первого раза без ошибок записать всю звуковую дорожку. Чтобы изменить сообщение для одного слайда, выполните следующие действия.

  9. Перейдите к нужному слайду в обычном режиме или выделите этот слайд в режиме сортировщика.

  10. Выберите команду Показ слайдов > Звукозапись, настройте параметры звукозаписи и щелкните на кнопке ОК.

  11. Щелкните на кнопке Текущий слайд (Current Slide). Во время демонстрации слайда проговорите в микрофон нужный текст.

  12. Щелкните правой кнопкой мыши и выберите в контекстном меню команду Завершить демонстрацию (End Show).

Примечание

При повторной записи звукового фрагмента не завершайте демонстрацию нажатием клавиши Esc. Это приведет к отмене записи звука.

  13. Щелкните на одной из кнопок открывшегося окна диалога в соответствии с инструкциями шага 8.


Упражнение 9. Запуск слайд-фильма

Вы уже, наверное, догадались, что запустить демонстрацию слайд-фильма можно выбором команды Показ слайдов > Начать показ (Slide Show > View Show) или простым нажатием клавиши F5. Однако, готовясь показать презентацию перед большой аудиторией, следует настроить параметры демонстрации и научиться манипулировать слайдами.

  1. Выберите команду Показ слайдов > Настройка презентации (Slide Show > Set Up Show).

Переключатель и флажки раздела Показ слайдов (Show Type) открывшегося окна диалога (рис. 15.12) позволяют задать следующие режимы:

  • управляемый докладчиком (Presented By A Speaker) — полноэкранный режим демонстрации;

  • управляемый пользователем (Browsed By An Individual) — демонстрация в окне;

  • с полосой прокрутки (Show Scrollbar) — добавление полосы прокрутки в окопном режиме просмотра;

  • автоматический (Browsed At A Kiosk) — автоматически повторяющаяся бесконечное число раз демонстрация всей последовательности;

  • непрерывный цикл до нажатия клавиши "Esc" (Loop Continuously Until "Esc") — переход к первому слайду после показа последнего;

  • без речевого сопровождения (Show Without Narration) — отключение всех записанных звуковых сообщений;

  • без анимации (Show Without Animation) — отключение анимации объектов слайдов.

Рис. 15.12. Параметры слайд-шоу

  2. Чтобы демонстрировались только некоторые слайды, введите номера первого и последнего слайдов последовательности в счетчики от (From) и до (То) и выберите соответствующее положение переключателя.

  3. Для отмены автоматической смены слайдов выберите положение переключателя вручную (Manually). Теперь презентация полностью находится под вашим контролем.

  4. Завершив настройку, щелкните на кнопке ОК.

  5. Нажатием клавиши F5 запустите показ презентации.

Управление слайд-фильмом производится с помощью кнопки контекстного меню и самого"меню, которые показаны на рис. 15.13.

  6. Для вызова меню щелкните на кнопке меню или щелкните правой кнопкой мыши в произвольной точке экрана.

Примечание

Чтобы во время демонстрации кнопка меню не появлялась на экране, выберите команду Сервис > Параметры (Tools > Options) и на вкладке Вид (View) сбросьте флажок Показывать кнопку контекстного меню (Show Popup Menu Button). При этом проверьте, чтобы был установлен флажок Контекстное меню при щелчке правой кнопкой (Popup Menu On Right Mouse Click).

Команды Далее и Назад контекстного меню позволяют переходить на один слайд вперед и назад. Чтобы перейти к конкретному слайду (в том числе скрытому), раскройте подменю Переход > Выбор слайда по имени (Go > By Title) и выберите слайд в появившемся списке.

  7. Щелкая левой кнопкой мыши, пролистайте все слайды презентации, прослушав записанную звуковую дорожку. Если понадобится сделать перерыв, не стоит оставлять на экране текущий слайд (особенно при показе презентации с помощью проектора в большом зале). Команда Экран > Черный экран (Screen > Black Screen) отключает показ, заменяя слайд черным нолем. Чтобы возобновить презентацию, просто щелкните мышью. Презентацией можно управлять и с помощью клавиатуры, пользуясь комбинациями, перечисленными в табл. 15.1.

Таблица. 15.1. Клавиши управления показом презентации
Клавиша или клавиатурная комбинация | Операция
Пробел, вправо, вверх, Page Down или N | Переход к следующему слайду
Backspace, влево, вверх, Page Up или Р | Возврат к предыдущему слайду
Номер слайда+Enter | Переход к слайду с указанным номером
В или Точка | Черный экран/возврат слайда
W или Запятая | Белый экран/возврат слайда
Ctrl+P | Режим карандаша, позволяющий, протаскивая мышь по слайду, рисовать на нем прямо в режиме демон страции
Ctrl+H | Скрыть указатель мыши
Ctrl+A | Возврат к обычному указателю мыши
S или Серый плюс | Остановка/возобновление автоматической демонстраниции
Н | Показать скрытый слайд, расположенный вслед за текущим
Esc | Закончить демонстрацию


Контрольное упражнение

Чтобы закрепить знания и попрактиковаться в построении слайд-шоу с переходами и анимациями, выполните следующее задание.

  1. Откройте презентацию План продаж.ppt, созданную на занятии 13 с помощью мастера автосодержания.

  2. Распечатайте второй слайд презентации.
  3. Отправьте презентацию по электронной почте своему коллеге.
    • Как присоединить презентацию к электронному сообщению?

  4. Переключитесь в режим сортировщика.

  5. С помощью кнопок панели инструментов сортировщика назначьте первым трем слайдам переходы Жалюзи горизонтальные (Blinds Horizontal), а остальным слайдам переходы Жалюзи вертикальные (Blinds Vertical).

  6. Текстовым объектам пятого и шестого слайдов задайте, соответственно, анимацию Прямоугольник внутрь (Box In) и Прямоугольник наружу (Box Out).

  7. Скройте 10-й и 12-й слайды.
  8. Запишите речь диктора для нескольких слайдов с качеством Радиотрансляция.
    • Как изменить качество записи?

  9. Настройте параметры просмотра слайд-фильма, чтобы он демонстрировался в окне браузера без линейки прокрутки, без анимации, а после последнего слайда выполнялся переход на первый слайд.

    • Какиережимы следует выбрать в окне параметров слайд-фильма? 10. Запустите просмотр презентации.


Подведение итогов

Это занятие завершает серию упражнений, в которых изучалась программа PowerPoint. Теперь вы умеете не только создавать слайды, но и строить из них последовательность плавно перетекающих друг в друга кадров с анимацией и звуковым сопровождением. Вы можете отправить презентацию по почте, переслать ее в документ Word, преобразовать в набор web-страниц или продемонстрировать на экране компьютера в виде интерактивного слайд-фильма.

Три следующих занятия книги посвящены приложению Microsoft Access, которое позволяет помещать информацию в базу данных, извлекать ее в соответствии с определенными условиями отбора, печатать отчеты и выполнять многие другие операции с большими информационными массивами.


Занятие №16

ЧАСТЬ V

Access

Microsoft Access XP — профессиональная программа управления базами данных. С ее помощью можно накапливать и систематизировать разнообразную информацию, искать и сортировать объекты согласно выбранным критериям, конструировать удобные формы для ввода данных и генерировать на основании имеющихся записей прекрасно оформленные отчеты. Access обеспечивает одновременный доступ к данным десяткам пользователей.

Базы данных

ТЕМА ЗАНЯТИЯ

На этом занятии вы познакомитесь со структурой баз данных, научитесь конструировать и изменять таблицы данных — основные хранилища информации в Access. В упражнениях занятия рассматриваются следующие темы:

  • мастер таблиц;

  • конструктор таблиц;

  • типы данных;

  • список подстановки;

  • связь таблиц;

  • значение по умолчанию;

  • ограничение на значение поля;

  • индекс.

Базы данных — это совокупность структур, предназначенных для хранения больших объемов информации и программных модулей, осуществляющих управление данными, их выборку, сортировку и другие подобные действия. Информация базы данных хранится в одной или нескольких таблицах. Любая таблица с данными состоит из набора однотипных записей, расположенных друг за другом. Они представляют собой строки таблицы, которые можно добавлять, удалять или изменять. Каждая запись является набором именованных полей, или ячеек, которые могут хранить самую разнообразную информацию, начиная от даты рождения и заканчивая подробным описанием кулинарного рецепта. Однотипные поля разных записей образуют столбец таблицы.

Записи одной таблицы могут содержать ссылки на данные другой таблицы, например, в таблице со списком товаров могут храниться ссылки на справочник производителей товаров с их адресами и другими реквизитами. При этом записи, касающиеся разных товаров, могут указывать на одного и того же производителя. Такое взаимодействие таблиц называется связью.

Другие модули базы данных предназначены для обработки информации, хранящейся в таблицах. С помощью запросов производится выборка данных, отвечающих определенным условиям. Формы предназначены для форматированного ввода и восприятия информации. Отчеты обеспечивают вывод (как правило, на принтер) красочно оформленного списка записей с заголовками, пунктами и подпунктами.

Создание базы данных

Создав одну таблицу (например, так, как вы это делали па занятии 2), вы уже получаете полноценную базу данных. Однако в реальной жизни структуры баз данных, а соответственно и способы их создания, намного сложнее. На этом занятии будут рассмотрены лишь некоторые из них.

Упражнение 1. Мастер таблиц

С помощью мастера таблиц можно создавать некоторые часто встречающиеся структуры данных. Прежде чем заново строить структуру таблицы, подумайте, нельзя ли воспользоваться одним из стандартных шаблонов мастера таблиц. Это позволит сэкономить время. Например, чтобы создать таблицу данных, предназначенную для хранения списка людей, с которыми вы контактируете, выполните следующие действия.

  1. Запустите Microsoft Access, выполнив соответствующую команду меню Пуск > Программы (Start > Programs).

  2. В появившемся в области задач приложения окне Создание файл? (New File) в разделе Создание (New) щелкните на пункте Новая база данных (Blank Access Database) (рис. 16.1).

Откроется окно диалога Файл новой базы данных (File New Database).

Рис. 16.1. Окно Microsoft Access

  3. Выберите для размещения новой базы данных папку Мои документы (My Documents). В поле Имя файла (File Name) введите имя Контакты. Затем щелкните па кнопке Создать (Create).

Примечание

После своего создания файл базы данных обновляется автоматически при закрытии и выполнении некоторых критических операций (например, изменении структуры таблицы). Нет необходимости вручную сохранять файл, хотя при долгой работе это следует делать во избежание потерь данных из-за сбоя компьютера.

Откроется окно базы данных, показанное на рис. 16.2. Оно является основным окном базы и позволяет открывать, добавлять и удалять любые объекты базы данных. В левой области окна находятся кнопки групп объектов. В его правой части расположен список объектов выбранного типа, имеющихся в текущей базе данных, а также значки команд, позволяющих создавать новые объекты данного типа. Пока что в этой базе данных нет ни одного объекта.

  4. Щелкните на кнопке Таблицы (Tables).

  5. Чтобы запустить мастер создания таблиц, дважды щелкните на значке Создание таблицы с помощью мастера (Create Table By Using Wizard).

Рис. 16.2. Окно базы данных

В первом окне мастера, показанном на рис. 16.3, нужно указать подходящую структуру и выбрать в ней необходимый набор полей.

  6. Выберите положение переключателя Деловые (Business).

  7. В списке Образцы таблиц (Sample Tables) выберите пункт Контакты (Contacts).

  8. Щелкните на пункте Имя (FirstName) списка Образцы полей (Sample Fields).

  9. Щелкните на кнопке со стрелкой вправо, чтобы добавить выбранное поле в структуру создаваемой таблицы.

  10. Повторяя шаги 8 и 9, добавьте в список Поля новой таблицы (Fields In My New Table) поля Фамилия (LastName), Адрес (Address), НазваниеКомпании (Company Name) и РабочийТелефон (WorkPhone).

  11. Щелкните на кнопке Далее (Next).

  12. В поле второго окна мастера введите слово Контакты, которое будет играть роль имени таблицы. Затем щелкните на кнопке Далее.

Рис. 16.3. Мастер создания таблиц

  13. В третьем окне мастера щелкните на кнопке Готово (Finish). Мастер сгенерирует таблицу и откроет ее в режиме ввода данных.

Обратите внимание: поскольку во втором окне осталось выбранным положение переключателя Microsoft Access автоматически определяет ключ (Yes, Set A Primary Key For Me), Access добавляет в таблицу дополнительное ключевое поле Код_ Контакты (КонтактыЮ), которое играет роль уникального идентификатора записей.

Упражнение 2. Таблицы

Таблица данных похожа на лист электронной таблицы, но ее размеры ограничены. Число ее строк на единицу больше количества записей (последняя пустая строка предназначена для ввода новой записи), а число столбцов равно количеству полей в записи. Заголовки столбцов таблицы соответствуют именам полей, сформированных с помощью мастера создания таблиц.

  1. Щелкните на поле Имя и введите какое-нибудь имя. Access автоматически добавит в таблицу, созданную на предыдущем упражнении, первую запись, а строка новой записи сместится вниз.

  2. Введите фамилию в поле Фамилия.

  3. Заполните все остальные поля первой записи.

  4. Щелкните на поле Имя последней строки и введите имя еще одного человека, его фамилию, адрес, название компании и телефон. Добавьте подобным образом несколько записей, чтобы таблица стала такой, как показано на рис. 16.4. Если вы ошиблись при вводе, просто щелкните на ячейке с неверными данными и отредактируйте их. Стандартные заголовки столбцов часто оказываются неудобными, поэтому Access позволяет заменять их.

Рис. 16.4. Таблица данных

  5. Щелкните на заголовке Фамилия правой кнопкой мыши и выберите команду Переименовать (Rename).

  6. Введите слово Название, которое заменит подсвеченный заголовок Фамилия.

  7. Повторив шаги 5 и 6, верните столбцу название Фамилия.

  8. Щелчком на кнопке Первая запись (First Record) переместите указатель теку щей записи в начало таблицы.

  9. Два раза щелкните на кнопке Следующая запись (Next Record), чтобы перейти к четвертой записи.

  10. Щелкните на кнопке Удалить запись (Delete Record) панели инструментов.

  11. В появившемся окне запроса, информирующем о невозможности отмены операции удаления записи, щелчком на кнопке Да (Yes) подтвердите необходимость удаления. Обратите внимание, что ключевое поле Код_Контакты автоматически заполняется некоторыми числами. Эти числа не обязательно образуют непрерывную последовательность. Единственным условием является их уникальность. Содержимое ключевого поля различно для всех записей таблицы, что позволяет однозначно идентифицировать запись. Такие поля используются для формирования связей таблиц, о которых вы узнаете на этом занятии позже.

Конструктор таблиц

Конструктор таблиц предназначен для задания и изменения структуры таблицы. С помощью конструктора можно формировать сколь угодно сложные таблицы с полями любого типа.

Упражнение 3. Структура таблицы

В упражнении 1 была создана таблица для хранения данных о людях, с которыми вы контактируете. Теперь давайте с помощью конструктора добавим в базу данных еще одну таблицу, предназначенную для записи всех случаев контакта с людьми из первой таблицы.

  1. Щелчком на кнопке Окно базы данных (Database Window) переключитесь на список таблиц базы данных.

  2. Дважды щелкните на значке Создание таблицы в режиме конструктора (Create Table In Design View). Окно конструктора, показанное на рис. 16.5, состоит из двух частей. В верхней отображается список полей таблицы, а в нижней — свойства выделенного поля.

  3. Введите слово Дата, которое будет играть роль названия нового поля.

  4. Щелкните на ячейке Тип данных (Data Type) первой строки списка полей. Здесь необходимо выбрать тип поля, который определяет структуру и размер данных.

Рис. 16.5. Конструктор таблиц

  5. Щелкните на появившейся стрелке раскрывающегося списка ячейки Тип данных и выберите пункт Дата/время (Date/Time).

  6. Нажмите клавишу Tab и введите расшифровку назначения поля: Дата контакта. Такие описания вводить не обязательно, но их наличие помогает разобраться в структуре таблицы.

  7. Щелкните на второй ячейке столбца Имя поля (Field Name) и введите имя Описание.

  8. Задайте для второго поля тип Текстовый (Text).

  9. Укажите назначение поля в соответствии с рис. 16.5.

Кроме даты и описания контакта таблица данных должна содержать информацию о том, с кем вы контактировали. Но список людей хранится в таблице Контакты, поэтому в новой таблице не нужно заново вводить имя и фамилию. Достаточно лишь добавить ссылку на одну из записей таблицы Контакты. Эта ссылка будет иметь числовой тип и содержать число, равное значению поля Код_Контакты соответствующей записи таблицы Контакты.

  10. Добавьте еще одно поле с именем Код_Контакты и типом Числовой (Number),

Теперь нужно добавить индексированное поле и назначить его ключом, однозначно' идентифицирующим записи таблицы. Индексированные поля, или индексы, отличаются от обычных тем, что для них Access создает специальные списки, позволяющие выполнять быструю сортировку и поиск по содержимому индексированного поля. Таблица может содержать несколько индексов. Ключ — это специальный индекс, идентифицирующий записи. Значения такого поля должны быть уникальными. Его наличие не обязательно, но оно так часто используется, что при отсутствии ключа Access напоминает об этом и предлагает автоматически добавить ключевое поле.

  11. Добавьте поле Ключ и назначьте ему тип Счетчик (AutoNumber). Такой тип данных избавляет пользователя от необходимости ввода значений ключевого поля и инициирует автоматическую генерацию уникальных значений.

  12. Сохраняя активной строку Ключ, щелкните на кнопке Ключевое поле (Primary Key). На кнопке этой строки появится значок ключа, показывающий особый статус поля.

  13. Щелкните на кнопке закрытия окна конструктора.

  14. Access спросит о необходимости сохранения структуры таблицы. В ответ щелкните на кнопке Да.

  15. В открывшемся окне диалога (рис. 16.6) введите имя Список.

Рис. 16.6. Ввод имени таблицы

  16. Щелкните на кнопке ОК.

Упражнение 4. Список подстановки

Пришло время наполнить таблицу Список конкретной ин4юрмацией. Для этого выполните следующие шаги.

  1. В окне базы данных откройте список таблиц и дважды щелкните на значке Список. Выбранная таблица откроется в режиме просмотра данных.

  2. Добавьте несколько записей в соответствии с рис. 16.7.

Рис. 16.7. Список состоявшихся контактов

Примечание

Чтобы расширить столбец Описание, содержащий длинные текстовые строки, поместите указатель мыши на его правую границу и, когда значок сменится на двунаправленную стрелку, перетащите границу вправо.

Не забывайте, что числа в столбце Код_Контакты должны соответствовать номерам записей таблицы Контакты, описывающих людей, с которыми вы контактировали. Согласитесь, что искать соответствующие номера очень неудобно. Access позволяет автоматизировать эту операцию с помощью списка подстановки, который настраивается следующим образом.

  3. Щелкните на кнопке Вид (View) панели инструментов. Откроется окно конструктора таблицы.

  4. В списке типа данных для поля Код_Контакты выберите пункт Мастер подстановок (Lookup Wizard).

  5. В первом окне мастера оставьте выбранным положение переключателя Объект «столбец подстановки» будет использовать значения из таблицы или запроса (I Want The Lookup Column To Look Up The Values In The Table Or Query) и щелкните на кнопке Далее. Три положения переключателя второго окна мастера выводят на экран список таблиц, запросов или объединяют эти два списка. Здесь нужно выбрать таблицу или запрос на роль источника подстановки. В нашем случае база данных кроме таблицы Список содержит только один объект — таблицу Контакты, которая и окажется выбранной в окне мастера.

  6. Щелкните на кнопке Далее. Третье окно мастера, показанное на рис. 16.8, предлагает выбрать из таблицы Контакты поля, участвующие в подстановке. Этот список обязан содержать то поле, значения которого должны помещаться в поле Код_Контакты, то есть одноименное поле таблицы Контакты.

  7. Щелкните на пункте Код_Контакты.

Рис. 16.8. Мастер подстановок

Рис. 16.9. Параметры подстановки

  8. Щелкните на кнопке со стрелкой вправо. В список источника подстановки следует также добавить те поля, содержимое которых должно отображаться вместо численного значения, помещаемого из поля Код_Контакты таблицы Контакты в поле Код_Контакты таблицы Список. Я думаю, что будет удобно выбирать людей по их именам и фамилиям.

  9. Добавьте в список Выбранные поля (Selected Fields) пункты Фамилия и Имя.

  10. Затем щелкните на кнопке Далее.

  11. В следующем окне мастер продемонстрирует два столбца таблицы-источника, скрыв столбец Код_Контакты, содержащий идентификатор записи. Щелкните на кнопке Далее.

  12. В поле последнего столбца введите название Контакт, которое заменит имя столбца Код_Контакты, и щелкните на кнопке Готово.

  13. В появившемся окне диалога щелчком на кнопке Да подтвердите необходимость сохранения построенной структуры.

Примечание

Параметры списка подстановки появятся на вкладке Подстановка (Lookup), показанной на рис. 16.9. Если вы знакомы с языком структурированных запросов SQL, то сможете разобраться в запросе Источник строк (Row Source), который формирует таблицу подстановки.

  14. Щелкните на кнопке Вид, чтобы снова переключиться в режим ввода данных.

Теперь в третьем столбце таблицы вместо чисел видны фамилии, соответствующие этим числам, хотя само значение поля Код_Контакты не изменилось. Access автоматически ищет соответствующую запись таблицы Контакты по числу, содержащемуся в поле Код_Контакты, и выводит в ячейку текст поля Фамилия — второго поля таблицы Контакты из выбранных в окне мастера подстановки. Давайте попробуем добавить в таблицу Список еще одну запись.

Рис. 16.10. Список подстановки

  15. Щелкните на нижней ячейке столбца Дата и введите дату 10.10.97.

  16. Нажмите клавишу Tab и напечатайте текст Письмо с предложениями о сотрудничестве.

  17. Снова нажмите клавишу Tab и щелкните на появившейся кнопке раскрывающегося списка, как показано на рис. 16.10. Теперь вы можете выбирать людей из списка подстановки, сформированного на базе полей Фамилия и Имя таблицы Контакты.

  18. Щелкните на втором пункте списка.

Access автоматически отыщет в таблице Контакты значение поля Код_Контакты для записи, содержащей информацию о Петре Петрове, и введет найденное число в поле Код_Контакты таблицы Список. Это значение останется скрытым. Вместо него в ячейке таблицы Список появится соответствующая фамилия, взятая из таблицы Контакты.

Упражнение 5. Связь таблиц

В предыдущем упражнении с помощью мастера подстановок была сформирована связь между двумя таблицами. Такая связь позволяет установить правила взаимодействия между таблицами. Список подстановок можно было организовать и без связи. Но представьте, что вы удалите из таблицы Контакты запись, на которую ссылаются некоторые записи таблицы Список. В такой ситуации останутся описания контактов, фамилии людей в которых потеряны. Наличие правильно организованной связи позволяет избежать подобных неприятностей.

  1. Выберите команду Сервис > Схема данных (Tools > Relationships). Откроется окно, схематически изображающее связи базы данных. На рис. 16.11 видно, что линия связи соединяет поля Код_Контакты таблицы Контакты и Контакт таблицы Список.

Примечание

Данная связь соединяет ключевое и обычное поля. Это связь типа «один ко многим», когда одной записи таблицы Контакты может соответствовать несколько записей таблицы Список, но не наоборот.

Рис. 16.11. Схема данных

Для тренировки давайте удалим связь, а затем создадим ее заново.

  2. Щелчком выделите линию связи.

  3. Нажмите клавишу Delete. В ответ на появившийся запрос щелкните на кнопке Да. Связь исчезнет.

  4. Поместите указатель мыши на пункт Код_Контакты таблицы Контакты.

  5. Нажмите кнопку мыши и перетащите указатель на поле Контакт таблицы Список.

  6. В открывшемся окне диалога щелкните на кнопке Создать. Связь появится вновь.

Чтобы настроить параметры связи, выполните следующие шаги.

  7. Дважды щелкните на линии связи. Откроется окно диалога, показанное на рис. 16.12.

Рис. 16.12. Параметры связи

Примечание

Если таблицы, между которыми нужно организовать связь, отсутствуют, щелкните в окне Схема данных (Relationships) правой кнопкой мыши и выберите команду Добавить таблицу (Show Table). В открывшемся окне диалога выделяйте таблицы, которые нужно разместить в окне Схема данных и щелкайте на кнопке Добавить (Add). Получив все необходимые таблицы, закройте окно диалога кнопкой Закрыть (Close).

  8. Установите флажок Обеспечение целостности данных (Enforce Referential Integrity). Этот режим не позволит Access оставлять в таблице Список записи, для которых нельзя подобрать запись таблицы Контакты с подходящим значением поля Код_Контакты.

  9. Установите флажок Каскадное удаление связанных записей (Cascade Delete Related Records). Теперь при удалении записи таблицы Контакты (то есть удалении информации о конкретном человеке) будут удалены все соответствующие записи таблицы Список (то есть все описания контактов с этим человеком). Если указанный флажок сброшен, удаление тех записей таблицы Контакты, на которые ссылается хотя бы одна запись таблицы Список, запрещено.

Примечание

Установка флажка Каскадное обновление связанных полей приведет к тому, что при обновлении поля Код_Контакты таблицы Контакты будут автоматически обновляться одноименные поля в соответствующих записях таблицы Список.

  10. Щелкните на кнопке ОК.

  11. Закройте окно Схема данных.

  12. В окне базы данных дважды щелкните на значке таблицы Контакты. В открывшемся окне таблицы видны небольшие знаки «плюс», расположенные в левой части записей. Их присутствие говорит о наличии связи ключевого поля таблицы с другой таблицей.

  13. Щелкните на знаке «плюс» записи для Петра Петрова. Откроется вложенная таблица, содержащая те записи таблицы Список, значение поля Код_Кон-такты которых равно величине одноименного поля записи для Петра Петрова (рис. 16.13).

Рис. 16.13. Выборка данных из связанной таблицы

Примечание

При раскрытии фрагмента связанной таблицы знак «плюс» превращается в знак «минус». Чтобы скрыть дополнительную таблицу, щелкните на нем еще раз.

  14. Щелкните еще на каком-нибудь знаке «плюс», и вы увидите описание всех контактов с еще одним человеком. Таким образом, с помощью созданной связи вы можете быстро просматривать в окне таблицы Список описания всех контактов с определенным человеком или группой лиц.

Упражнение 6. Параметры поля

Для того, чтобы обеспечить возможность хранения в базе данных разнообразной информации, Access предлагает большой набор типов данных, перечисленных в табл. 16.1.

ТАБЛИЦА 16.1 . Типы данных
Название типа | Назначение
Текстовый (Text) | Текст длиной до 255 символов
Поле MEMO (Memo) | Текст длиной до 65 000 символов
Числовой (Number) | Числа различных форматов
Дата/время (Date/Time) | Дата и/или время
Денежный (Currency) | Денежные значения различных форматов
Счетчик (AutoNumber) | Счетчик, который автоматически увеличивается на единицу с добавлением каждой новой записи
Логический (Yes/No) | Величины, способные принимать только два значения: да/нет или 1/0
Поле объекта OLE (OLE Object) | Поля, позволяющие вставлять рисунки, звуки и данные других типов
Гиперссылка (Hyperlink) | Ссылки, дающие возможность открывать объект Access (таблицу, форму, запрос и т. п.), файл другого приложения или web-страницу

Чтобы сделать работу со списком контактов более продуктивной, следует изменить типы данных некоторых полей.

  1. В окне базы данных выделите таблицу Список и щелкните на кнопке Конструктор (Design), расположенной в верхней части окна. Выбранная таблица откроется в режиме конструктора.

  2. Описание контакта может быть достаточно длинным, а максимальная длина текстовых полей ограничена 256 символами. Поэтому измените тип поля Описание на Поле MEMO.

  3. Щелкните на поле Дата.

Рис. 16.14. Выбор формата

  4. Для удобства прочтения даты контакта измените 4юрмат ее отображения, выбрав в раскрывающемся списке Формат поля (Format) пункт Длинный формат даты (Long Date), как показано на рис. 16.14.

Кроме типа данных и формата отображения вкладка Общие (General) окна конструктора позволяет настроить некоторые дополнительные параметры поля, влияющие на способ ввода данных. Параметр Значение по умолчанию (Default Value) задает содержимое поля, которое записывается в новую запись в том случае, если пользователь не ввел в это поле никаких данных. Если вы регулярно обновляете список контактов, то дата контакта чаще всего будет совпадать с текущей датой. Чтобы упростить ввод информации, можно задать текущую дату в качестве значения по умолчанию для поля Дата.

  5. Введите в поле Значение по умолчанию (Default Value) функцию Date(), которая возвращает текущую дату. В некоторых случаях требуется не только задать тип данных поля, но и ограничить его возможные значения некоторым интервалом или более сложным правилом отбора. Такое правило вводится в поле Условие на значение (Validation Rule). Предположим, вы точно знаете, что все контакты, которые будут заноситься в список, состоятся после 1 января 1999 г. Чтобы избежать ошибок, можно заставить Access сообщать вам о вводе неверной даты. Для этого выполните следующие шаги.

  6. В поле Условие на значение щелкните на кнопке построителя выражений. Откроется окно диалога. Для задания условий или значений определенных параметров Access предлагает большой набор математических операций и функций. Построитель выражений помогает ориентироваться во всем многообразии функций Access. Верхнее прокручивающееся поле построителя содержит конструируемое выражение. Его можно изменять как путем непосредственного редактирования текста, так и с помощью других кнопок и списков построителя.

  7. Необходимо, чтобы дата записи была позднее, то есть больше, даты 1 января 1999 г. Поэтому щелкните на кнопке >, чтобы добавить нужное условие.

Теперь нужно указать дату, с которой выполняется сравнение. Дяя этого следует воспользоваться специальной функцией, преобразующей строковую константу в дату в формате Access.

  8. Дважды щелкните на папке Функции (Functions) в левом списке построителя выражений.

  9. Щелкните на папке Встроенные функции (Built-in Function), чтобы вывести список стандартных функций Access.

  10. В среднем списке выберите категорию Дата/время.

  11. Двойным щелчком на имени функции DateValue добавьте ее в поле выражения. Вместо местозаполнителя аргумента «stringexpr» нужно ввести конкретную дату в строковом формате.

  12. В поле выражения щелчком выделите текст «stringexpr», а затем напечатайте "1.1.99".

  13. Щелкните на кнопке ОК.

Рис. 16.15. Параметры поля Дата

  14. В поле Сообщение об ошибке (Validation Text) введите текст Неверная дата, который будет появляться при вводе даты, более ранней, чем 1 января 1999 г. Окончательный набор параметров поля Дата показан на рис. 16.15.

  15. Щелкните на кнопке закрытия окна конструктора. В окне запроса на обновление структуры таблицы щелкните на кнопке Да. По причине добавления условий на значения поля Дата Access запросит о необходимости проверки содержимого этого поля в уже имеющихся записях таблицы. Щелкните на кнопке Нет (No), чтобы не выполнять проверку.

Давайте изучим влияние настроенных параметров на поведение базы данных.

  16. Выделите таблицу Список в окне базы данных и щелкните на кнопке Открыть (Open). Теперь все даты отображаются в длинном формате, а в ячейке Дата в строке новой записи автоматически появляется текущая дата.

  17. Щелкните в ячейке Дата второй строки, измените ее содержимое на 19.11.95 и нажмите клавишу Tab, чтобы перейти к следующему полю. Так как модифицированная дата предшествует 1 января 1999 г., что противоречит настроенному условию, Access не позволит убрать курсор из текущей ячейки и откроет окно сообщения с текстом, введенным вами в поле Сообщение об ошибке конструктора таблицы на шаге 14. Такое сообщение будет появляться до тех пор, пока вы не скорректируете дату.

  18. Щелкните на кнопке ОК.

  19. Исправьте дату на 19.11.00.

  20. Закройте таблицу Список.

Упражнение 7. Индекс

Для ускорения поиска данных о конкретном человеке в таблице Контакты удобно рассортировать записи по алфавиту. Чтобы назначить сортировку по полю Фамилия, выполните следующие шаги.

  1. В окне базы данных щелкните на значке таблицы Контакты.

  2. Щелчком на кнопке Открыть откройте таблицу в режиме редактирования.

  3. В окне таблицы щелкните на заголовке Фамилия, чтобы выделить столбец.

Рис. 16.16. Сортировка фамилий по алфавиту

  4. Щелчком на кнопке Сортировка по возрастанию (Sort Ascending) упорядочите записи столбца фамилии таблицы по алфавиту (рис. 16.16).

  5. Вставьте в таблицу еще несколько человек с фамилией Петров. Например, Василий Петров, Николай Петров и Игорь Петров. Добавляйте записи в указанном порядке.

  6. Чтобы обновить сортировку, закройте окно таблицы Контакты и вновь откройте таблицу. Записи окажутся расположенными так, как показано на рис. 16.17.

Рис. 16.17. Несколько человек с одинаковыми фамилиями

Фамилии упорядочены по алфавиту, но имена людей расставлены в беспорядке. Если бы в таблице было несколько сотен людей с фамилией Петров, то поиск нужного человека существенно бы осложнился. Чтобы выполнить сортировку сразу по нескольким полям, следует воспользоваться сложным индексом. Его настройка выполняется посредством следующих действий.

  7. Щелчком на кнопке Вид переключитесь в режим конструктора.

  8. Чтобы открыть окно индексов таблицы Контакты, показанное на рис. 16.18, щелкните на кнопке Индексы (Indexes) панели инструментов. В окне индексов есть список со столбцами названия индекса, имени поля, по которому выполняется индексация, и режима сортировки (по возрастанию или по убыванию). Мастер таблиц при создании таблицы Контакты индексировал ее потрем полям: Название Компании, Фамилия, Код_Контакты, добавив индексы с именами соответственно: Название Компании, Фамилия и PrimaryKey. Последний из трех индексов является ключом таблицы, однозначно идентифицирующим ее записи. Все имеющиеся индексы простые, то есть назначают сортировку только по одному полю. Чтобы записи с одинаковыми фамилиями располагались по алфавиту имен, следует модифицировать индекс Фамилия, добавив в него условие сортировки по полю Имя. Для этого выполните следующие шаги.

Рис. 16.18. Индексы

  9. Щелкните правой кнопкой мыши на той строке, которая расположена ниже строки индекса Фамилия.

  10. Выберите в контекстном меню команду Добавить строки (Insert Rows), чтобы вставить одну пустую строку.

  11. В новой строке щелкните на кнопке раскрывающегося списка ячейки Имя поля.

  12. Выберите пункт Имя. В столбце Порядок сортировки (Sort Order) автоматически появится вариант По возрастанию (Ascending).

Рис. 16.19. Сортировка по двум полям

В окне настройки индексов имена полей, по которым происходит упорядочивание в данном индексе, располагаются в строке с именем индекса и ниже ее в строках с пустой ячейкой Индекс (Index Name) в порядке убывания влияния поля. То есть первой выполняется сортировка по тому полю, которое в данном индексе расположено выше. В одном индексе можно использовать до 10 полей. Таким образом, теперь индекс Фамилия упорядочивает записи по алфавиту сначала по фамилиям, а потом по именам.

  13. Закройте окно индексов.

  14. Щелкните на кнопке Вид, чтобы переключиться в режим редактирования таблицы.

  15. Ответьте Да на запрос о необходимости сохранения таблицы. Теперь имена оказались выстроенными по алфавиту, как показано на рис. 16.19. Поскольку перед этим уже была настроена сортировка по полю Фамилия (то есть по индексу Фамилия, главным полем которого является Фамилия), вам даже не пришлось перенастраивать сортировку. Модификация индекса автоматически привела к упорядочению имен.

Контрольное упражнение

Пришло время самостоятельно попрактиковаться в работе с конструктором таблиц.

Access автоматически обновляет файл базы данных. Чтобы сохранить его исходный вариант, в Проводнике создайте копии файлов Контакты.mdb и Список.mdb — соответственно файлы Контакты_копия.mbd и Список_копия.таЬ. Закончив контрольное упражнение, переименуйте файлы Контакты_копия.mbd и Список_копия.mbd обратно в Контакты.mdb и Список.mdb.

  1. Откройте таблицу Контакты в режиме конструктора.

  2. Измените тип данных поля Адрес на Поле MEMO.

  3. Ограничьте длину текстового поля Имя величиной 30 символов.

    • Какой параметр определяет длину поля?
  4. Поле Фамилия является ключевым. Запретите Access добавлять в таблицу Контакты записи с пустым полем Фамилия.
    • Как запретить добавление пустого поля?

  5. Закройте конструктор и сохраните структуру таблицы.

  6. Создайте новую таблицу с именем Метод.

  7. В конструкторе добавьте в нее поле Метод ID с типом данных Счетчик и поле Вариант с типом Текстовый. Первое из них сделайте ключом таблицы.

  8. Переключитесь в режим редактирования и введите в таблицу три записи, в поле Метод которых введите слова Телефон, Письмо, Факс. Эта таблица будет хранить возможные способы контакта.

  9. С помощью конструктора добавьте в таблицу Список поле Метод ID с числовым типом.
  10. С помощью мастера подстановки назначьте этому полю подстановку, состоящую из полей МетодЮ и Вариант таблицы Метод.
    • Как сделать, чтобы в список подстановки кроме названия метода выводился его кодовый номер?

  11. В имеющихся записях таблицы Список введите значение в новое поле, выбрав его в списке подстановки.

  12. Закройте базу данных.

    • Какие операции закрывают базу данных?

Подведение итогов

На этом занятии вы научились создавать таблицы, вводить в них данные, изменять структуру таблиц с помощью конструктора, добавлять связь таблиц с помощью мастера подстановок, настраивать сложные индексы.

Следующее занятие посвящено описанию запросов, предназначенных для отбора данных и их просмотра на экране, а также фильтров, с помощью которых содержимое таблиц урезается на основе введенных условий отбора.


Занятие №16

ЧАСТЬ V

Access

Microsoft Access XP — профессиональная программа управления базами данных. С ее помощью можно накапливать и систематизировать разнообразную информацию, искать и сортировать объекты согласно выбранным критериям, конструировать удобные формы для ввода данных и генерировать на основании имеющихся записей прекрасно оформленные отчеты. Access обеспечивает одновременный доступ к данным десяткам пользователей.

Базы данных

ТЕМА ЗАНЯТИЯ

На этом занятии вы познакомитесь со структурой баз данных, научитесь конструировать и изменять таблицы данных — основные хранилища информации в Access. В упражнениях занятия рассматриваются следующие темы:

  • мастер таблиц;

  • конструктор таблиц;

  • типы данных;

  • список подстановки;

  • связь таблиц;

  • значение по умолчанию;

  • ограничение на значение поля;

  • индекс.

Базы данных — это совокупность структур, предназначенных для хранения больших объемов информации и программных модулей, осуществляющих управление данными, их выборку, сортировку и другие подобные действия. Информация базы данных хранится в одной или нескольких таблицах. Любая таблица с данными состоит из набора однотипных записей, расположенных друг за другом. Они представляют собой строки таблицы, которые можно добавлять, удалять или изменять. Каждая запись является набором именованных полей, или ячеек, которые могут хранить самую разнообразную информацию, начиная от даты рождения и заканчивая подробным описанием кулинарного рецепта. Однотипные поля разных записей образуют столбец таблицы.

Записи одной таблицы могут содержать ссылки на данные другой таблицы, например, в таблице со списком товаров могут храниться ссылки на справочник производителей товаров с их адресами и другими реквизитами. При этом записи, касающиеся разных товаров, могут указывать на одного и того же производителя. Такое взаимодействие таблиц называется связью.

Другие модули базы данных предназначены для обработки информации, хранящейся в таблицах. С помощью запросов производится выборка данных, отвечающих определенным условиям. Формы предназначены для форматированного ввода и восприятия информации. Отчеты обеспечивают вывод (как правило, на принтер) красочно оформленного списка записей с заголовками, пунктами и подпунктами.


Создание базы данных

Создав одну таблицу (например, так, как вы это делали па занятии 2), вы уже получаете полноценную базу данных. Однако в реальной жизни структуры баз данных, а соответственно и способы их создания, намного сложнее. На этом занятии будут рассмотрены лишь некоторые из них.


Упражнение 1. Мастер таблиц

С помощью мастера таблиц можно создавать некоторые часто встречающиеся структуры данных. Прежде чем заново строить структуру таблицы, подумайте, нельзя ли воспользоваться одним из стандартных шаблонов мастера таблиц. Это позволит сэкономить время. Например, чтобы создать таблицу данных, предназначенную для хранения списка людей, с которыми вы контактируете, выполните следующие действия.

  1. Запустите Microsoft Access, выполнив соответствующую команду меню Пуск > Программы (Start > Programs).

  2. В появившемся в области задач приложения окне Создание файл? (New File) в разделе Создание (New) щелкните на пункте Новая база данных (Blank Access Database) (рис. 16.1).

Откроется окно диалога Файл новой базы данных (File New Database).

Рис. 16.1. Окно Microsoft Access

  3. Выберите для размещения новой базы данных папку Мои документы (My Documents). В поле Имя файла (File Name) введите имя Контакты. Затем щелкните па кнопке Создать (Create).

Примечание

После своего создания файл базы данных обновляется автоматически при закрытии и выполнении некоторых критических операций (например, изменении структуры таблицы). Нет необходимости вручную сохранять файл, хотя при долгой работе это следует делать во избежание потерь данных из-за сбоя компьютера.

Откроется окно базы данных, показанное на рис. 16.2. Оно является основным окном базы и позволяет открывать, добавлять и удалять любые объекты базы данных. В левой области окна находятся кнопки групп объектов. В его правой части расположен список объектов выбранного типа, имеющихся в текущей базе данных, а также значки команд, позволяющих создавать новые объекты данного типа. Пока что в этой базе данных нет ни одного объекта.

  4. Щелкните на кнопке Таблицы (Tables).

  5. Чтобы запустить мастер создания таблиц, дважды щелкните на значке Создание таблицы с помощью мастера (Create Table By Using Wizard).

Рис. 16.2. Окно базы данных

В первом окне мастера, показанном на рис. 16.3, нужно указать подходящую структуру и выбрать в ней необходимый набор полей.

  6. Выберите положение переключателя Деловые (Business).

  7. В списке Образцы таблиц (Sample Tables) выберите пункт Контакты (Contacts).

  8. Щелкните на пункте Имя (FirstName) списка Образцы полей (Sample Fields).

  9. Щелкните на кнопке со стрелкой вправо, чтобы добавить выбранное поле в структуру создаваемой таблицы.

  10. Повторяя шаги 8 и 9, добавьте в список Поля новой таблицы (Fields In My New Table) поля Фамилия (LastName), Адрес (Address), НазваниеКомпании (Company Name) и РабочийТелефон (WorkPhone).

  11. Щелкните на кнопке Далее (Next).

  12. В поле второго окна мастера введите слово Контакты, которое будет играть роль имени таблицы. Затем щелкните на кнопке Далее.

Рис. 16.3. Мастер создания таблиц

  13. В третьем окне мастера щелкните на кнопке Готово (Finish). Мастер сгенерирует таблицу и откроет ее в режиме ввода данных.

Обратите внимание: поскольку во втором окне осталось выбранным положение переключателя Microsoft Access автоматически определяет ключ (Yes, Set A Primary Key For Me), Access добавляет в таблицу дополнительное ключевое поле Код_ Контакты (КонтактыЮ), которое играет роль уникального идентификатора записей.


Упражнение 2. Таблицы

Таблица данных похожа на лист электронной таблицы, но ее размеры ограничены. Число ее строк на единицу больше количества записей (последняя пустая строка предназначена для ввода новой записи), а число столбцов равно количеству полей в записи. Заголовки столбцов таблицы соответствуют именам полей, сформированных с помощью мастера создания таблиц.

  1. Щелкните на поле Имя и введите какое-нибудь имя. Access автоматически добавит в таблицу, созданную на предыдущем упражнении, первую запись, а строка новой записи сместится вниз.

  2. Введите фамилию в поле Фамилия.

  3. Заполните все остальные поля первой записи.

  4. Щелкните на поле Имя последней строки и введите имя еще одного человека, его фамилию, адрес, название компании и телефон. Добавьте подобным образом несколько записей, чтобы таблица стала такой, как показано на рис. 16.4. Если вы ошиблись при вводе, просто щелкните на ячейке с неверными данными и отредактируйте их. Стандартные заголовки столбцов часто оказываются неудобными, поэтому Access позволяет заменять их.

Рис. 16.4. Таблица данных

  5. Щелкните на заголовке Фамилия правой кнопкой мыши и выберите команду Переименовать (Rename).

  6. Введите слово Название, которое заменит подсвеченный заголовок Фамилия.

  7. Повторив шаги 5 и 6, верните столбцу название Фамилия.

  8. Щелчком на кнопке Первая запись (First Record) переместите указатель теку щей записи в начало таблицы.

  9. Два раза щелкните на кнопке Следующая запись (Next Record), чтобы перейти к четвертой записи.

  10. Щелкните на кнопке Удалить запись (Delete Record) панели инструментов.

  11. В появившемся окне запроса, информирующем о невозможности отмены операции удаления записи, щелчком на кнопке Да (Yes) подтвердите необходимость удаления. Обратите внимание, что ключевое поле Код_Контакты автоматически заполняется некоторыми числами. Эти числа не обязательно образуют непрерывную последовательность. Единственным условием является их уникальность. Содержимое ключевого поля различно для всех записей таблицы, что позволяет однозначно идентифицировать запись. Такие поля используются для формирования связей таблиц, о которых вы узнаете на этом занятии позже.


Конструктор таблиц

Конструктор таблиц предназначен для задания и изменения структуры таблицы. С помощью конструктора можно формировать сколь угодно сложные таблицы с полями любого типа.


Упражнение 3. Структура таблицы

В упражнении 1 была создана таблица для хранения данных о людях, с которыми вы контактируете. Теперь давайте с помощью конструктора добавим в базу данных еще одну таблицу, предназначенную для записи всех случаев контакта с людьми из первой таблицы.

  1. Щелчком на кнопке Окно базы данных (Database Window) переключитесь на список таблиц базы данных.

  2. Дважды щелкните на значке Создание таблицы в режиме конструктора (Create Table In Design View). Окно конструктора, показанное на рис. 16.5, состоит из двух частей. В верхней отображается список полей таблицы, а в нижней — свойства выделенного поля.

  3. Введите слово Дата, которое будет играть роль названия нового поля.

  4. Щелкните на ячейке Тип данных (Data Type) первой строки списка полей. Здесь необходимо выбрать тип поля, который определяет структуру и размер данных.

Рис. 16.5. Конструктор таблиц

  5. Щелкните на появившейся стрелке раскрывающегося списка ячейки Тип данных и выберите пункт Дата/время (Date/Time).

  6. Нажмите клавишу Tab и введите расшифровку назначения поля: Дата контакта. Такие описания вводить не обязательно, но их наличие помогает разобраться в структуре таблицы.

  7. Щелкните на второй ячейке столбца Имя поля (Field Name) и введите имя Описание.

  8. Задайте для второго поля тип Текстовый (Text).

  9. Укажите назначение поля в соответствии с рис. 16.5.

Кроме даты и описания контакта таблица данных должна содержать информацию о том, с кем вы контактировали. Но список людей хранится в таблице Контакты, поэтому в новой таблице не нужно заново вводить имя и фамилию. Достаточно лишь добавить ссылку на одну из записей таблицы Контакты. Эта ссылка будет иметь числовой тип и содержать число, равное значению поля Код_Контакты соответствующей записи таблицы Контакты.

  10. Добавьте еще одно поле с именем Код_Контакты и типом Числовой (Number),

Теперь нужно добавить индексированное поле и назначить его ключом, однозначно' идентифицирующим записи таблицы. Индексированные поля, или индексы, отличаются от обычных тем, что для них Access создает специальные списки, позволяющие выполнять быструю сортировку и поиск по содержимому индексированного поля. Таблица может содержать несколько индексов. Ключ — это специальный индекс, идентифицирующий записи. Значения такого поля должны быть уникальными. Его наличие не обязательно, но оно так часто используется, что при отсутствии ключа Access напоминает об этом и предлагает автоматически добавить ключевое поле.

  11. Добавьте поле Ключ и назначьте ему тип Счетчик (AutoNumber). Такой тип данных избавляет пользователя от необходимости ввода значений ключевого поля и инициирует автоматическую генерацию уникальных значений.

  12. Сохраняя активной строку Ключ, щелкните на кнопке Ключевое поле (Primary Key). На кнопке этой строки появится значок ключа, показывающий особый статус поля.

  13. Щелкните на кнопке закрытия окна конструктора.

  14. Access спросит о необходимости сохранения структуры таблицы. В ответ щелкните на кнопке Да.

  15. В открывшемся окне диалога (рис. 16.6) введите имя Список.

Рис. 16.6. Ввод имени таблицы

  16. Щелкните на кнопке ОК.


Упражнение 4. Список подстановки

Пришло время наполнить таблицу Список конкретной ин4юрмацией. Для этого выполните следующие шаги.

  1. В окне базы данных откройте список таблиц и дважды щелкните на значке Список. Выбранная таблица откроется в режиме просмотра данных.

  2. Добавьте несколько записей в соответствии с рис. 16.7.

Рис. 16.7. Список состоявшихся контактов

Примечание

Чтобы расширить столбец Описание, содержащий длинные текстовые строки, поместите указатель мыши на его правую границу и, когда значок сменится на двунаправленную стрелку, перетащите границу вправо.

Не забывайте, что числа в столбце Код_Контакты должны соответствовать номерам записей таблицы Контакты, описывающих людей, с которыми вы контактировали. Согласитесь, что искать соответствующие номера очень неудобно. Access позволяет автоматизировать эту операцию с помощью списка подстановки, который настраивается следующим образом.

  3. Щелкните на кнопке Вид (View) панели инструментов. Откроется окно конструктора таблицы.

  4. В списке типа данных для поля Код_Контакты выберите пункт Мастер подстановок (Lookup Wizard).

  5. В первом окне мастера оставьте выбранным положение переключателя Объект «столбец подстановки» будет использовать значения из таблицы или запроса (I Want The Lookup Column To Look Up The Values In The Table Or Query) и щелкните на кнопке Далее. Три положения переключателя второго окна мастера выводят на экран список таблиц, запросов или объединяют эти два списка. Здесь нужно выбрать таблицу или запрос на роль источника подстановки. В нашем случае база данных кроме таблицы Список содержит только один объект — таблицу Контакты, которая и окажется выбранной в окне мастера.

  6. Щелкните на кнопке Далее. Третье окно мастера, показанное на рис. 16.8, предлагает выбрать из таблицы Контакты поля, участвующие в подстановке. Этот список обязан содержать то поле, значения которого должны помещаться в поле Код_Контакты, то есть одноименное поле таблицы Контакты.

  7. Щелкните на пункте Код_Контакты.

Рис. 16.8. Мастер подстановок

Рис. 16.9. Параметры подстановки

  8. Щелкните на кнопке со стрелкой вправо. В список источника подстановки следует также добавить те поля, содержимое которых должно отображаться вместо численного значения, помещаемого из поля Код_Контакты таблицы Контакты в поле Код_Контакты таблицы Список. Я думаю, что будет удобно выбирать людей по их именам и фамилиям.

  9. Добавьте в список Выбранные поля (Selected Fields) пункты Фамилия и Имя.

  10. Затем щелкните на кнопке Далее.

  11. В следующем окне мастер продемонстрирует два столбца таблицы-источника, скрыв столбец Код_Контакты, содержащий идентификатор записи. Щелкните на кнопке Далее.

  12. В поле последнего столбца введите название Контакт, которое заменит имя столбца Код_Контакты, и щелкните на кнопке Готово.

  13. В появившемся окне диалога щелчком на кнопке Да подтвердите необходимость сохранения построенной структуры.

Примечание

Параметры списка подстановки появятся на вкладке Подстановка (Lookup), показанной на рис. 16.9. Если вы знакомы с языком структурированных запросов SQL, то сможете разобраться в запросе Источник строк (Row Source), который формирует таблицу подстановки.

  14. Щелкните на кнопке Вид, чтобы снова переключиться в режим ввода данных.

Теперь в третьем столбце таблицы вместо чисел видны фамилии, соответствующие этим числам, хотя само значение поля Код_Контакты не изменилось. Access автоматически ищет соответствующую запись таблицы Контакты по числу, содержащемуся в поле Код_Контакты, и выводит в ячейку текст поля Фамилия — второго поля таблицы Контакты из выбранных в окне мастера подстановки. Давайте попробуем добавить в таблицу Список еще одну запись.

Рис. 16.10. Список подстановки

  15. Щелкните на нижней ячейке столбца Дата и введите дату 10.10.97.

  16. Нажмите клавишу Tab и напечатайте текст Письмо с предложениями о сотрудничестве.

  17. Снова нажмите клавишу Tab и щелкните на появившейся кнопке раскрывающегося списка, как показано на рис. 16.10. Теперь вы можете выбирать людей из списка подстановки, сформированного на базе полей Фамилия и Имя таблицы Контакты.

  18. Щелкните на втором пункте списка.

Access автоматически отыщет в таблице Контакты значение поля Код_Контакты для записи, содержащей информацию о Петре Петрове, и введет найденное число в поле Код_Контакты таблицы Список. Это значение останется скрытым. Вместо него в ячейке таблицы Список появится соответствующая фамилия, взятая из таблицы Контакты.


Упражнение 5. Связь таблиц

В предыдущем упражнении с помощью мастера подстановок была сформирована связь между двумя таблицами. Такая связь позволяет установить правила взаимодействия между таблицами. Список подстановок можно было организовать и без связи. Но представьте, что вы удалите из таблицы Контакты запись, на которую ссылаются некоторые записи таблицы Список. В такой ситуации останутся описания контактов, фамилии людей в которых потеряны. Наличие правильно организованной связи позволяет избежать подобных неприятностей.

  1. Выберите команду Сервис > Схема данных (Tools > Relationships). Откроется окно, схематически изображающее связи базы данных. На рис. 16.11 видно, что линия связи соединяет поля Код_Контакты таблицы Контакты и Контакт таблицы Список.

Примечание

Данная связь соединяет ключевое и обычное поля. Это связь типа «один ко многим», когда одной записи таблицы Контакты может соответствовать несколько записей таблицы Список, но не наоборот.

Рис. 16.11. Схема данных

Для тренировки давайте удалим связь, а затем создадим ее заново.

  2. Щелчком выделите линию связи.

  3. Нажмите клавишу Delete. В ответ на появившийся запрос щелкните на кнопке Да. Связь исчезнет.

  4. Поместите указатель мыши на пункт Код_Контакты таблицы Контакты.

  5. Нажмите кнопку мыши и перетащите указатель на поле Контакт таблицы Список.

  6. В открывшемся окне диалога щелкните на кнопке Создать. Связь появится вновь.

Чтобы настроить параметры связи, выполните следующие шаги.

  7. Дважды щелкните на линии связи. Откроется окно диалога, показанное на рис. 16.12.

Рис. 16.12. Параметры связи

Примечание

Если таблицы, между которыми нужно организовать связь, отсутствуют, щелкните в окне Схема данных (Relationships) правой кнопкой мыши и выберите команду Добавить таблицу (Show Table). В открывшемся окне диалога выделяйте таблицы, которые нужно разместить в окне Схема данных и щелкайте на кнопке Добавить (Add). Получив все необходимые таблицы, закройте окно диалога кнопкой Закрыть (Close).

  8. Установите флажок Обеспечение целостности данных (Enforce Referential Integrity). Этот режим не позволит Access оставлять в таблице Список записи, для которых нельзя подобрать запись таблицы Контакты с подходящим значением поля Код_Контакты.

  9. Установите флажок Каскадное удаление связанных записей (Cascade Delete Related Records). Теперь при удалении записи таблицы Контакты (то есть удалении информации о конкретном человеке) будут удалены все соответствующие записи таблицы Список (то есть все описания контактов с этим человеком). Если указанный флажок сброшен, удаление тех записей таблицы Контакты, на которые ссылается хотя бы одна запись таблицы Список, запрещено.

Примечание

Установка флажка Каскадное обновление связанных полей приведет к тому, что при обновлении поля Код_Контакты таблицы Контакты будут автоматически обновляться одноименные поля в соответствующих записях таблицы Список.

  10. Щелкните на кнопке ОК.

  11. Закройте окно Схема данных.

  12. В окне базы данных дважды щелкните на значке таблицы Контакты. В открывшемся окне таблицы видны небольшие знаки «плюс», расположенные в левой части записей. Их присутствие говорит о наличии связи ключевого поля таблицы с другой таблицей.

  13. Щелкните на знаке «плюс» записи для Петра Петрова. Откроется вложенная таблица, содержащая те записи таблицы Список, значение поля Код_Кон-такты которых равно величине одноименного поля записи для Петра Петрова (рис. 16.13).

Рис. 16.13. Выборка данных из связанной таблицы

Примечание

При раскрытии фрагмента связанной таблицы знак «плюс» превращается в знак «минус». Чтобы скрыть дополнительную таблицу, щелкните на нем еще раз.

  14. Щелкните еще на каком-нибудь знаке «плюс», и вы увидите описание всех контактов с еще одним человеком. Таким образом, с помощью созданной связи вы можете быстро просматривать в окне таблицы Список описания всех контактов с определенным человеком или группой лиц.


Упражнение 6. Параметры поля

Для того, чтобы обеспечить возможность хранения в базе данных разнообразной информации, Access предлагает большой набор типов данных, перечисленных в табл. 16.1.

ТАБЛИЦА 16.1 . Типы данных
Название типа | Назначение
Текстовый (Text) | Текст длиной до 255 символов
Поле MEMO (Memo) | Текст длиной до 65 000 символов
Числовой (Number) | Числа различных форматов
Дата/время (Date/Time) | Дата и/или время
Денежный (Currency) | Денежные значения различных форматов
Счетчик (AutoNumber) | Счетчик, который автоматически увеличивается на единицу с добавлением каждой новой записи
Логический (Yes/No) | Величины, способные принимать только два значения: да/нет или 1/0
Поле объекта OLE (OLE Object) | Поля, позволяющие вставлять рисунки, звуки и данные других типов
Гиперссылка (Hyperlink) | Ссылки, дающие возможность открывать объект Access (таблицу, форму, запрос и т. п.), файл другого приложения или web-страницу

Чтобы сделать работу со списком контактов более продуктивной, следует изменить типы данных некоторых полей.

  1. В окне базы данных выделите таблицу Список и щелкните на кнопке Конструктор (Design), расположенной в верхней части окна. Выбранная таблица откроется в режиме конструктора.

  2. Описание контакта может быть достаточно длинным, а максимальная длина текстовых полей ограничена 256 символами. Поэтому измените тип поля Описание на Поле MEMO.

  3. Щелкните на поле Дата.

Рис. 16.14. Выбор формата

  4. Для удобства прочтения даты контакта измените 4юрмат ее отображения, выбрав в раскрывающемся списке Формат поля (Format) пункт Длинный формат даты (Long Date), как показано на рис. 16.14.

Кроме типа данных и формата отображения вкладка Общие (General) окна конструктора позволяет настроить некоторые дополнительные параметры поля, влияющие на способ ввода данных. Параметр Значение по умолчанию (Default Value) задает содержимое поля, которое записывается в новую запись в том случае, если пользователь не ввел в это поле никаких данных. Если вы регулярно обновляете список контактов, то дата контакта чаще всего будет совпадать с текущей датой. Чтобы упростить ввод информации, можно задать текущую дату в качестве значения по умолчанию для поля Дата.

  5. Введите в поле Значение по умолчанию (Default Value) функцию Date(), которая возвращает текущую дату. В некоторых случаях требуется не только задать тип данных поля, но и ограничить его возможные значения некоторым интервалом или более сложным правилом отбора. Такое правило вводится в поле Условие на значение (Validation Rule). Предположим, вы точно знаете, что все контакты, которые будут заноситься в список, состоятся после 1 января 1999 г. Чтобы избежать ошибок, можно заставить Access сообщать вам о вводе неверной даты. Для этого выполните следующие шаги.

  6. В поле Условие на значение щелкните на кнопке построителя выражений. Откроется окно диалога. Для задания условий или значений определенных параметров Access предлагает большой набор математических операций и функций. Построитель выражений помогает ориентироваться во всем многообразии функций Access. Верхнее прокручивающееся поле построителя содержит конструируемое выражение. Его можно изменять как путем непосредственного редактирования текста, так и с помощью других кнопок и списков построителя.

  7. Необходимо, чтобы дата записи была позднее, то есть больше, даты 1 января 1999 г. Поэтому щелкните на кнопке >, чтобы добавить нужное условие.

Теперь нужно указать дату, с которой выполняется сравнение. Дяя этого следует воспользоваться специальной функцией, преобразующей строковую константу в дату в формате Access.

  8. Дважды щелкните на папке Функции (Functions) в левом списке построителя выражений.

  9. Щелкните на папке Встроенные функции (Built-in Function), чтобы вывести список стандартных функций Access.

  10. В среднем списке выберите категорию Дата/время.

  11. Двойным щелчком на имени функции DateValue добавьте ее в поле выражения. Вместо местозаполнителя аргумента «stringexpr» нужно ввести конкретную дату в строковом формате.

  12. В поле выражения щелчком выделите текст «stringexpr», а затем напечатайте "1.1.99".

  13. Щелкните на кнопке ОК.

Рис. 16.15. Параметры поля Дата

  14. В поле Сообщение об ошибке (Validation Text) введите текст Неверная дата, который будет появляться при вводе даты, более ранней, чем 1 января 1999 г. Окончательный набор параметров поля Дата показан на рис. 16.15.

  15. Щелкните на кнопке закрытия окна конструктора. В окне запроса на обновление структуры таблицы щелкните на кнопке Да. По причине добавления условий на значения поля Дата Access запросит о необходимости проверки содержимого этого поля в уже имеющихся записях таблицы. Щелкните на кнопке Нет (No), чтобы не выполнять проверку.

Давайте изучим влияние настроенных параметров на поведение базы данных.

  16. Выделите таблицу Список в окне базы данных и щелкните на кнопке Открыть (Open). Теперь все даты отображаются в длинном формате, а в ячейке Дата в строке новой записи автоматически появляется текущая дата.

  17. Щелкните в ячейке Дата второй строки, измените ее содержимое на 19.11.95 и нажмите клавишу Tab, чтобы перейти к следующему полю. Так как модифицированная дата предшествует 1 января 1999 г., что противоречит настроенному условию, Access не позволит убрать курсор из текущей ячейки и откроет окно сообщения с текстом, введенным вами в поле Сообщение об ошибке конструктора таблицы на шаге 14. Такое сообщение будет появляться до тех пор, пока вы не скорректируете дату.

  18. Щелкните на кнопке ОК.

  19. Исправьте дату на 19.11.00.

  20. Закройте таблицу Список.


Упражнение 7. Индекс

Для ускорения поиска данных о конкретном человеке в таблице Контакты удобно рассортировать записи по алфавиту. Чтобы назначить сортировку по полю Фамилия, выполните следующие шаги.

  1. В окне базы данных щелкните на значке таблицы Контакты.

  2. Щелчком на кнопке Открыть откройте таблицу в режиме редактирования.

  3. В окне таблицы щелкните на заголовке Фамилия, чтобы выделить столбец.

Рис. 16.16. Сортировка фамилий по алфавиту

  4. Щелчком на кнопке Сортировка по возрастанию (Sort Ascending) упорядочите записи столбца фамилии таблицы по алфавиту (рис. 16.16).

  5. Вставьте в таблицу еще несколько человек с фамилией Петров. Например, Василий Петров, Николай Петров и Игорь Петров. Добавляйте записи в указанном порядке.

  6. Чтобы обновить сортировку, закройте окно таблицы Контакты и вновь откройте таблицу. Записи окажутся расположенными так, как показано на рис. 16.17.

Рис. 16.17. Несколько человек с одинаковыми фамилиями

Фамилии упорядочены по алфавиту, но имена людей расставлены в беспорядке. Если бы в таблице было несколько сотен людей с фамилией Петров, то поиск нужного человека существенно бы осложнился. Чтобы выполнить сортировку сразу по нескольким полям, следует воспользоваться сложным индексом. Его настройка выполняется посредством следующих действий.

  7. Щелчком на кнопке Вид переключитесь в режим конструктора.

  8. Чтобы открыть окно индексов таблицы Контакты, показанное на рис. 16.18, щелкните на кнопке Индексы (Indexes) панели инструментов. В окне индексов есть список со столбцами названия индекса, имени поля, по которому выполняется индексация, и режима сортировки (по возрастанию или по убыванию). Мастер таблиц при создании таблицы Контакты индексировал ее потрем полям: Название Компании, Фамилия, Код_Контакты, добавив индексы с именами соответственно: Название Компании, Фамилия и PrimaryKey. Последний из трех индексов является ключом таблицы, однозначно идентифицирующим ее записи. Все имеющиеся индексы простые, то есть назначают сортировку только по одному полю. Чтобы записи с одинаковыми фамилиями располагались по алфавиту имен, следует модифицировать индекс Фамилия, добавив в него условие сортировки по полю Имя. Для этого выполните следующие шаги.

Рис. 16.18. Индексы

  9. Щелкните правой кнопкой мыши на той строке, которая расположена ниже строки индекса Фамилия.

  10. Выберите в контекстном меню команду Добавить строки (Insert Rows), чтобы вставить одну пустую строку.

  11. В новой строке щелкните на кнопке раскрывающегося списка ячейки Имя поля.

  12. Выберите пункт Имя. В столбце Порядок сортировки (Sort Order) автоматически появится вариант По возрастанию (Ascending).

Рис. 16.19. Сортировка по двум полям

В окне настройки индексов имена полей, по которым происходит упорядочивание в данном индексе, располагаются в строке с именем индекса и ниже ее в строках с пустой ячейкой Индекс (Index Name) в порядке убывания влияния поля. То есть первой выполняется сортировка по тому полю, которое в данном индексе расположено выше. В одном индексе можно использовать до 10 полей. Таким образом, теперь индекс Фамилия упорядочивает записи по алфавиту сначала по фамилиям, а потом по именам.

  13. Закройте окно индексов.

  14. Щелкните на кнопке Вид, чтобы переключиться в режим редактирования таблицы.

  15. Ответьте Да на запрос о необходимости сохранения таблицы. Теперь имена оказались выстроенными по алфавиту, как показано на рис. 16.19. Поскольку перед этим уже была настроена сортировка по полю Фамилия (то есть по индексу Фамилия, главным полем которого является Фамилия), вам даже не пришлось перенастраивать сортировку. Модификация индекса автоматически привела к упорядочению имен.


Контрольное упражнение

Пришло время самостоятельно попрактиковаться в работе с конструктором таблиц.

Access автоматически обновляет файл базы данных. Чтобы сохранить его исходный вариант, в Проводнике создайте копии файлов Контакты.mdb и Список.mdb — соответственно файлы Контакты_копия.mbd и Список_копия.таЬ. Закончив контрольное упражнение, переименуйте файлы Контакты_копия.mbd и Список_копия.mbd обратно в Контакты.mdb и Список.mdb.

  1. Откройте таблицу Контакты в режиме конструктора.

  2. Измените тип данных поля Адрес на Поле MEMO.

  3. Ограничьте длину текстового поля Имя величиной 30 символов.

    • Какой параметр определяет длину поля?
  4. Поле Фамилия является ключевым. Запретите Access добавлять в таблицу Контакты записи с пустым полем Фамилия.
    • Как запретить добавление пустого поля?

  5. Закройте конструктор и сохраните структуру таблицы.

  6. Создайте новую таблицу с именем Метод.

  7. В конструкторе добавьте в нее поле Метод ID с типом данных Счетчик и поле Вариант с типом Текстовый. Первое из них сделайте ключом таблицы.

  8. Переключитесь в режим редактирования и введите в таблицу три записи, в поле Метод которых введите слова Телефон, Письмо, Факс. Эта таблица будет хранить возможные способы контакта.

  9. С помощью конструктора добавьте в таблицу Список поле Метод ID с числовым типом.
  10. С помощью мастера подстановки назначьте этому полю подстановку, состоящую из полей МетодЮ и Вариант таблицы Метод.
    • Как сделать, чтобы в список подстановки кроме названия метода выводился его кодовый номер?

  11. В имеющихся записях таблицы Список введите значение в новое поле, выбрав его в списке подстановки.

  12. Закройте базу данных.

    • Какие операции закрывают базу данных?


Подведение итогов

На этом занятии вы научились создавать таблицы, вводить в них данные, изменять структуру таблиц с помощью конструктора, добавлять связь таблиц с помощью мастера подстановок, настраивать сложные индексы.

Следующее занятие посвящено описанию запросов, предназначенных для отбора данных и их просмотра на экране, а также фильтров, с помощью которых содержимое таблиц урезается на основе введенных условий отбора.


Занятие №17

Подбор требуемых данных

ТЕМА ЗАНЯТИЯ

На этом занятии рассказывается о способах фильтрации данных, выборки информации из базы данных на основе определенных критериев и о выполнении вычислений. В упражнениях занятия рассматриваются следующие темы:

  • мастер запросов;

  • конструктор запросов;

  • условие отбора;

  • итоговый запрос;

  • запрос действия;

  • фильтры.

Таблицы данных предназначены для хранения информации. Вам, конечно, захочется не только заносить в них данные, но и обрабатывать записанную ранее информацию. Access предлагает множество способов извлечения данных из таблиц. Вы можете запросить данные, руководствуясь определенным правилом отбора, отфильтровать нужные записи или рассчитать результирующие значения с помощью формул.

Запросы

Запросы являются инструментом поиска и структурирования данных. Запрос, адресованный одной или нескольким таблицам, инициирует выборку определенной части данных и их передачу в таблицу, формируемую самим запросом. В результате вы получаете подмножество информационного множества исходных таблиц, сформированное по определенному закону. Если обрабатываемый объем информации велик, выделение необходимых данных в такое подмножество позволяет существенно сократить время их обработки. В системах типа клиент-сервер, где основные базы данных хранятся на файловом сервере, система запросов позволяет уменьшить объем информации, передаваемой через локальную сеть.

Упражнение 1. Мастер запросов

Чтобы упростить задачу пользователя, в состав Access включен мастер запросов, позволяющий автоматизировать процесс построения запроса. Давайте с помощью этого мастера выполним выборку информации из таблиц базы данных Контакты.

  1. В окне базы данных щелкните на кнопке Запросы (Queries).

  2. Дважды щелкните на значке Создание запроса с помощью мастера (Create Query By Using Wizard).

  3. В раскрывающемся списке Таблицы и запросы (Tables/Queries) первого окна мастера выберите таблицу Список (рис. 17.1).

  4. В списке Доступные поля (Available Fields) щелкните на строке Дата.

  5. Щелкните на кнопке >, чтобы переместить выделенное поле в список Выбранные поля.

  6. Повторяя шаги 3-5, добавьте в список Выбранные поля поле, Описание таблицы Список, а также ноле Фамилия таблицы Контакты.

  7. Щелкните на кнопке Далее.

  8. Введите имя запроса Перечень контактов и щелкните на кнопке Готово.

Access построит запрос и выполнит его. Запрос — это набор условий, согласно которым производится выборка информации из таблиц. Запуск запроса формирует новую таблицу данных, единственным отличием которой от обычных таблиц является то, что с помощью повторных запусков запроса ее данные можно обновлять в соответствии с изменением информации источников данных запроса.

Рис. 17.1. Мастер запросов

Примечание

Чтобы база данных выглядела интереснее, в таблицу Список было добавлено несколько новых записей.

В рассматриваемом случае условие отбора инициирует получение из таблицы Список полей Дата и Описание всех имеющихся записей, а также поля Фамилия таблицы Контакты. Таблицы Список и Контакты связаны между собой через поле Код_Контакты, при этом Контакты является главной таблицей, а Список — подчиненной (то есть каждой записи таблицы Список соответствует только одна запись таблицы Контакты). Поэтому в поле Фамилия результата запроса выводится фамилия из той записи таблицы Контакты, значение поля Код_Контакты которой совпадает со значением одноименного поля таблицы Список.

Рис. 17.2. Результат выполнения запроса

Результат выполнения запроса показан на рис. 17.2.

Упражнение 2. Конструктор запросов

Мастер запросов умеет конструировать только простые условия отбора. Чтобы наложить дополнительные ограничения, следует пользоваться конструктором запросов, обеспечивающим полное управление параметрами запроса и построение сложных условий отбора данных.

  1. Чтобы переключиться в режим конструктора, выберите команду Вид > Конструктор (View > Design View). Окно конструктора показано на рис. 17.3. В его верхней части отображаются списки полей таблиц, к которым обращается запрос, и связи между таблицами. Нижняя область содержит бланк выбора полей таблиц, условий отбора и режимов сортировки. Чтобы добавить в запрос еще одно поле, выполните следующие шаги.

  2. Переместите указатель на пункт Имя таблицы Контакты.

Рис. 17.3. Конструктор запроса

  3. Нажмите кнопку мыши и перетащите поле Имя в верхнюю ячейку четвертой строки бланка запроса. Его имя появится в этой ячейке, а имя соответствующей таблицы — во второй ячейке того же столбца. Третья строка бланка запроса позволяет сортировать результат запроса по тому или иному полю.

  4. В раскрывающемся списке третьей ячейки третьего столбца бланка выберите пункт По возрастанию.

Примечание

Чтобы добавить в запрос сразу все поля таблицы, перетаскивайте пункт *. Если нужная таблица отсутствует в верхней части окна запроса, щелкните на кнопке Отобразить таблицу (Show Table) панели инструментов, выделите нужную таблицу или запрос в открывшемся окне диалога, щелкните на кнопке Добавить, а затем на кнопке Закрыть.

  5. Назначьте тот же режим сортировки для поля Имя. Теперь записи результата запроса будут упорядочены по алфавиту фамилий и имен. Имеющийся вариант связи добавляет в результат запроса только те записи связанных таблиц, в которых значения полей Код_Контакты равны. Так как для некоторых людей из таблицы Контакты нет записей в таблице Список, то информация о таких людях не включается в результат запроса. Чтобы запрос возвращал данные даже о тех людях (включенных в таблицу Контакты), с которыми не было никаких контактов, нашедших отражение в таблице Список, следует изменить параметры объединения.

  6. Дважды щелкните на линии связи.

  7. В открывшемся окне диалога Параметры объединения (Join Properties) выберите положение переключателя Объединение всех записей из "Контакты" и только тех записей из "Список", в которых связанные поля совпадают (Include All Records From "Контакты" And Only Those Records From "Список" Where The Joined Fields Are Equal).

  8. Щелкните на кнопке ОК. На одном конце линии связи появится стрелка, указывающая на смену режима объединения.

Примечание

Изменение режима объединения в окне запроса никак не влияет на параметры исходной связи, определяющие правила взаимодействия между таблицами данных, а задает только порядок отбора записей базы данных, включаемых в результат запроса.

  9. Щелчком на кнопке Вид панели инструментов запустите запрос повторно. Результат выполнения запроса с учетом сортировки и нового режима объединения будет таким, как показано на рис. 17.5.

  10. Закройте окно запроса.

  11. В ответ на вопрос о необходимости сохранения новой структуры запроса ответьте Да.

Упражнение 3. Условие отбора

Добавление в запрос условия отбора позволяет выбирать из таблицы не все записи, а лишь те, которые удовлетворяют определенным критериям. Например, вас могут заинтересовать контакты, приходящиеся на декабрь 1999 года. Давайте модифицируем запрос добавлением соответствующего условия отбора.

  1. Выделите в окне базы данных (рис. 17.4) значок запроса Перечень контактов.

Рис. 17.4. Окно базы данных

  2. Щелкните на кнопке Конструктор.

  3. В бланке запроса щелкните на ячейке Условие отбора (Criteria) первого столбца правой кнопкой мыши и выберите в контекстном меню команду Построить (Build). Откроется окно построителя выражений.

  4. В левом списке построителя щелкните на папке Операторы (Operators).

  5. В среднем списке выберите категорию Сравнения (Comparison).

  6. В правом списке дважды щелкните на пункте Between, чтобы добавить этот оператор в ноле формулы.

  7. Щелчком выделите в поле формулы первый местозаполнитель «Выражение» («Ехрг»).

  8. В левом списке построителя выражений двойным щелчком откройте папку Функции.

  9. 9. Щелкните на папке Встроенные функции, содержащей стандартные функции Access.

  10. В среднем списке построителя выражений щелкните на пункте Дата/время (Data/Time).

  11. В правом списке дважды щелкните на функции DateValue, чтобы заменить ею местозаполнитель «Выражение».

  12. Нажмите два раза клавишу —>, выделив местозаполнитель «stringexpr».

  13. Введите текст "1.12.99".

  14. Повторяя шаги 7-13, замените второй местозаполнитель «Выражение» на выражение DateValue ("31.12.99").

У вас должна получиться формула Between DateValue ("1.12.99") And DateValue ("31.12.99"). Она проверяет условие нахождения даты в интервале от 1 до 31 декабря 1999 г., то есть отбирает те записи, значение поля Дата которых относится к декабрю 1999 г.

Примечание

Если вы уже освоили правила построения выражений Access, то можете не пользоваться построителем, а непосредственно вводить выражения в бланк запроса.

  15. Щелкните па кнопке ОК. Построенная формула появится в ячейке Условие отбора первого столбца бланка запроса. При выборе записей, относящихся к одному месяцу, точная дата контакта может оказаться несущественной. Совсем выбросить это поле из бланка запроса нельзя, так как оно необходимо для реализации условия отбора. Однако любое поле можно скрыть, то есть не включать в результат запроса.

  16. Сбросьте флажок Вывод на экран (Show) первого столбца запроса (рис. 17.5).

Рис. 17.5. Скрытие поля

  17. Щелчком на кнопке Запуск (Run) панели инструментов выполните запрос.

Упражнение 4. Итоговый запрос

Запросы позволяют не только выбирать записи из таблиц, но и вычислять различные статистические параметры. Например, можно подсчитать суммарное количество контактов и вывести даты первого и последнего контакта с каждым из людей, включенных в таблицу Контакты. Чтобы построить такой запрос в режиме конструктора, выполните следующие действия.

  1. В окне базы данных щелкните на кнопке Запросы.

  2. Дважды щелкните на значке Создание запроса в режиме конструктора (Create Query In Design View).

  3. В открывшемся окне диалога (рис. 17.6) выделите строку Контакты.

  4. 4. Щелчком на кнопке Добавить добавьте выбранную таблицу в верхнюю область конструктора запроса.

  5. 5. Выделите пункт Список и снова щелкните на кнопке Добавить.

  6. 6. Щелчком на кнопке Закрыть закройте окно диалога Добавление таблицы (Show Table). Списки полей двух таблиц, соединенные линией связи, появятся в окне конструктора.

  7. 7. Щелкните на кнопке Групповые операции (Totals) панели инструментов. В бланке запроса появится дополнительная строка Групповая операция: (Total), позволяющая выполнять статистические операции со значениями конкретных полей.

Рис. 17.6 . Добавление таблицы

  8. Перетащите поле Фамилия в ячейку Поле (Field) первого столбца конструктора.

  9. В ту же ячейку второго столбца перетащите поле Имя таблицы Контакты.

  10. В третий, четвертый и пятый столбцы бланка запроса перетащите поле Дата таблицы Список (рис. 17.7).

Рис. 17.7. Запрос с групповыми операциями

  11. В раскрывающемся списке ячейки Групповая операция (Total) третьего столб ца бланка запроса выберите пункт Min.

  12. В той же ячейке четвертого столбца выберите пункт Мах.

  13. В пятом столбце задайте групповую операцию Count. Групповые операции построенного запроса обработают все записи таблицы Список, соответствующие конкретному человеку из таблицы Контакты, и вместо самих данных таблицы Список выведут в соответствующее поле результата запроса только значение величины, вычисляемой по определенной формуле. Доступные групповые операции перечислены в табл. 17.1.

ТАБЛИЦА 17.1 . Групповые операции

Название | Функция
Условие(Where) | Режим задания условия отбора для поля, но которому не выполняется группировка. Access автоматически делает такое поле скрытым
Выражение (Expression) | Вычисляемое поле, значение которого рассчитывается по сложной формуле
Group By | Поле, определяющее группу записей, по которой вычисляются статистические параметры. К одной группе относятся все записи, для которых значения поля с режимом Group By (Группировка) одинаковы
Last | Последнее значение в группе
First | Первое значение в группе
Var | Вариация значений поля
StDev | Стандартное отклонение величин ноля от среднего
Count | Количество записей, соответствующее ноле которых не содержит величины Null
Мах | Максимальное значение
Min | Минимальное значение
Avg | Среднее значение поля
Sum | Сумма значений поля по всем записям

Примечание

Поскольку в пятом поле запроса вычисляется количество записей, в ячейку Поле этого столбца можно поместить любое поле таблицы Список.

  14. Щелкните на кнопке Вид, чтобы выполнить запрос. Появится таблица с пятью столбцами. Два первых столбца содержат фамилии и имена людей. По ним выполняется группировка, то есть расчет значений остальных полей запроса выполняется для записей таблицы Список, сопоставляемых с одним человеком. Как уже говорилось выше, соответствие контакта таблицы Список и человека из таблицы Контакты определяется полями Код_Контакты, с помощью которых осуществляется связь этих двух таблиц. Третий и четвертый столбцы запроса выводят соответственно дату первого (функция Min) и последнего (функция Мах) контакта с данным человеком. Пятый столбец содержит количество записей в таблице Список (функция Count), соответствующих. данному человеку, то есть число контактов с ним. Единственный недостаток построенного запроса — это непонятные имена столбцов. Давайте скорректируем их.

  15. Щелчком на кнопке Вид вернитесь в конструктор запроса.

  16. В ячейке Поле третьего столбца замените имя Дата на текст Дата первого контакта: Дата. Правая часть этого выражения, расположенная правее двоеточия, по-прежнему задает имя поля, а левая определяет название столбца результата запроса. Таким образом, любому столбцу запроса можно назначить произвольное имя.

  17. В ячейке Поле четвертого столбца введите Дата последнего контакта: Дата.

  18. В первой строке пятого столбца бланка'запроса введите Число контактов: Дата.

Примечание

К сожалению, подобный прием не подходит для смены названия поля, значение которого не вычисляется, а передается из таблицы. То есть таким способом не удастся переименовать поле Имя.

  19. Снова щелкните на кнопке Вид.

  20. Закройте запрос.

  21. Для сохранения изменений структуры щелкните на кнопке Да.

  22. В окне диалога Сохранение (Save As) введите имя Итоговый запрос и щелкните на кнопке ОК.

Упражнение 5. Запрос действия

До сих пор вы сталкивались с запросами, выполняющими выборку данных и некоторые вычисления. Однако запросы могут применяться также для добавления, удаления и обновления группы записей таблицы. Такие запросы являются мощным инструментом преобразования данных, они называются запросами действия. Предположим, что по каким-то причинам вам понадобилось скорректировать даты контактов, заменив во всех записях таблицы Список, относящихся к 1999 году, месяц ноябрь на декабрь. Подобную операцию трудно проделать вручную,- если в таблице содержится несколько тысяч записей. Запрос действия позволяет быстро решить поставленную задачу.

  1. В окне базы данных щелкните на кнопке Таблицы.

  2. Выделите таблицу Список, данные которой нужно обновить.

  3. В палитре кнопки Новый объект (New Object) выберите пункт Запрос (Query). Откроется окно диалога Новый запрос (New Query), показанное на рис. 17.8. Подобное окно открывается и при щелчке на кнопке Создать (New) окна базы данных. Оно позволяет выбрать наиболее удобный способ создания объекта.

Рис. 17.8. Создание запроса

  4. Дважды щелкните на строке Конструктор (Design View). Таблица Список, выделенная в окне базы данных на шаге 2, автоматически появится в окне конструктора запросов.

  5. Перетащите в бланк запроса поле Дата, значение которого нужно обновлять.

Примечание

Название поля, заключенное в квадратные скобки, является ссылкой на значение поля. Чтобы сослаться на поле другой таблицы, нужно в начале указать имя таблицы, а затем имя поля (оба имени в квадратных скобках) и разделить их восклицательным знаком. Например [Контакты]! [Фамилия].

  6. В палитре кнопки Тип запроса (Query Type) выберите пункт Обновление (Update Query). Описание всех возможных вариантов запросов, предлагаемых программой Access, приведено в табл. 17.2. Структура бланка запроса видоизменяется в соответствии с типом запроса. В бланке выбранного варианта запроса на обновление появляется поле Обновление (Update To), в которое нужно ввести новое значение поля. Чтобы изменить месяц даты с ноября на декабрь, достаточно прибавить к дате 30 дней.

  7. Введите в ячейку Обновление (Update To) формулу [Дата] +30.

ТАБЛИЦА 17.2. Варианты запросов

Тип | Описание
Выборка (Select) ; | Выборка данных в таблицу результата запроса на основе указанных условий отбора
Перекрестный (Crosstab) | Результат запроса выводит статистические значения (сумму, количество или среднее) для одного из полей таблицы в зависимости от двух параметров других полей таблицы, задающих заголовки строк и столбцов результата перекрестного запроса
Создание таблицы (Make-Table) | Создание новой таблицы в текущей или в другой базе данных на базе информации из имеющихся таблиц
Обновление (Update) | Обновление данных таблицы
Добавление (Append) | Добавление набора записей в таблицу
Удаление (Delete) | Удаление записей таблицы в соответствии с указанным критерием

  8. Чтобы обновлялись только даты, относящиеся к ноябрю 2000 года, введите в ячейку Условие отбора формулу Between DateValue ("1.11.99") And DateValue ("30.11.99"), которая подробно обсуждалась в третьем упражнении этого занятия (рис. 17.12).

  9. Закройте запрос, сохранив его под именем Обновление.

  10. Щелкните на кнопке Таблицы окна базы данных и двойным щелчком на значке Список откройте эту таблицу. В ней есть четыре записи, относящиеся к ноябрю 2000 года.

Примечание

Запросы действия могут выполнять широкомасштабные изменения данных, которые отменить уже невозможно. Будьте внимательны. Перед запуском таких запросов полезно сделать резервную копию базы данных, чтобы иметь возможность возвратиться к исходному состоянию таблиц. Значки запросов действия снабжены восклицательным знаком, предупреждающим об их особой роли.

  11. В окне базы данных щелкните на кнопке Запросы.

  12. Дважды щелкните на значке Обновление.

Ответьте Да на вопрос о необходимости запуска запроса действия. Access проинформирует вас об обнаружении четырех записей, удовлетворяющих условию отбора, и попросит подтвердить необходимость их изменения.

Рис. 17.9. Запрос на обновление

  13. Щелкните на кнопке Да и изучите изменения, произошедшие с данными таблицы Список.

Фильтры

Фильтры, как и запросы, предназначены для отбора определенных записей базы данных. Но фильтр сохраняется вместе с таблицей и не может использоваться с другими объектами, если он не был записан в виде запроса.

Упражнение 6. Установка фильтра

Установка фильтра — простейший способ отбора части записей в таблице, запросе или форме. В этом упражнении с помощью фильтра будет выделено несколько записей таблицы Контакты.

  1. В окне базы данных щелкните на кнопке Таблицы, а затем дважды на значке Контакты.

  2. В столбце Фамилия щелкните на ячейке с фамилией Петров.

  3. Щелкните на кнопке Фильтр по выделенному (Filter By Selection). В результате видимыми останутся только те записи, в поле Фамилия которых присутствует значение Петров (рис. 17.10).

  4. Чтобы отменить влияние фильтра, щелкните на кнопке Удалить фильтр (Remove Filter).

Примечание

Access запоминает последний применявшийся фильтр. Его можно снова назначить простым щелчком на кнопке Применение фильтра (Apply Filter). Это та же самая кнопка, с помощью которой отменяется действие фильтра, но теперь она будет иметь другое название.

Фильтр может быть и более сложным. Например, чтобы оставить все записи с фамилией Петров и непустым полем телефона, выполните следующие шаги.

Рис. 17.10. Фильтрация записей

  5. Выберите команду Записи > Фильтр > Расширенный фильтр (Records > Filter > Advanced Filter/Sort). Откроется окно, похожее на конструктор запроса. Критерий равенства поля Фамилия значению Петров уже будет присутствовать в бланке фильтра.

  6. Перетащите поле Рабочий Телефон во второй столбец бланка.

Рис. 17.11. Окно расширенного фильтра

  7. В ячейку Условие отбора введите формулу <>Null (рис. 17.11).

Значение любого пустого поля равно величине NuIL Условие < >NuII проверяет поле на неравенство величине Null, то есть отбирает все непустые поля.

  8. Выберите команду Фильтр > Применить фильтр (Filter > Apply Filter/Sort). Настроенный" фильтр будет применен к таблице Контакты. В результате в ней останутся только две записи.

  9. С помощью команды Записи > Удалить фильтр (Records > Remove Filter/Sort) отмените фильтрацию.

Упражнение 7. Преобразование в запрос

К сожалению, назначение нового фильтра автоматически стирает все предыдущие, которые уже невозможно применить повторно. Если фильтр достаточно сложный, его многократная настройка может отнимать много времени, и вам, вероятно, захочется как-то спасти результат титанического труда. Access предлагает простой способ сохранения фильтров. Так как окно фильтра подобно конструктору запроса, было бы логично записать фильтр в виде запроса с теми же условиями отбора. Чтобы превратить фильтр в запрос, выполните следующие шаги.

  1. Командой Записи > Фильтр > Расширенный фильтр (Records > Filter > Advanced Filter/Sort) активизируйте окно сложного фильтра, созданного в предыдущем упражнении.

  2. Выполните команду Файл > Сохранить как запрос (File > Save As Query).

  3. В открывшемся окне диалога введите имя Фил ьтр и щелкните на кнопке ОК.

  4. Закройте окно фильтра.

  5. В окне базы данных появился новый запрос с названием Фильтр. Дважды щелкните на значке этого запроса.

Откроется окно результата выполнения запроса, записи которого будут повторять записи фильтрованной таблицы Контакты. Этим запросом можно пользоваться когда угодно, выводя на экран записи, отобранные по соответствующим критериям. Более того, любой запрос можно превратить в фильтр. Это делается следующим образом.

  6. Щелчком активизируйте окно таблицы Контакты (если таблица закрыта, откройте ее).

  7. Чтобы назначить новый фильтр (и стереть предыдущий), щелкните на ячейке с фамилией Петров правой кнопкой мыши и выберите в контекстном меню команду Исключить выделенное (Filter Excluding Selection). В таблице останутся только те записи, в поле Фамилия которых нет слова Петров.

  8. Щелчком на кнопке Удалить фильтр отмените фильтрацию данных. Теперь давайте вернем прежний сложный фильтр.

  9. Выберите команду Записи > Фильтр > Расширенный фильтр.

  10. Выберите команду Файл > Загрузить из запроса (File > Load From Query).

  11. В открывшемся окне диалога выделите запрос Фильтр и щелкните на кнопке ОК.

Старые условия фильтрации появятся в бланке окна фильтра. Теперь для применения сохраненного фильтра достаточно щелкнуть на кнопке Применение фильтра панели инструментов.

Контрольное упражнение

С помощью контрольного упражнения закрепите знания о запросах и фильтрах, выполнив самостоятельно приведенные ниже операции и ответив на предложенные вопросы.

  1. Запустите мастер запросов.

  2. Добавьте в запрос поля Фамилия и Адрес таблицы Контакты, а затем поля Дата и Описание таблицы Список.
  3. Настройте итоговый запрос, подсчитывающий количество записей.
    • Как с помощью мастера, создать итоговый запрос?

  4. Переключитесь в режим конструктора.

  5. Скройте третье и четвертое поля запроса.

  6. Закройте запрос, сохранив его под именем Количество записей.

  7. Откройте таблицу Список.

  8. Включите фильтр, оставляющий только записи, относящиеся к фамилии Леонидов.

  9. Откройте окно сложного фильтра.
  10. Измените условие фильтрации так, чтобы оставались также записи, касающиеся Петрова.
    • Какое условие отбора необходимо добавить ?

  11. Назначьте обновленный фильтр.

  12. Сохраните настроенный фильтр в виде запроса.

  13. Откройте запрос Обновление в конструкторе запросов.
  14. Просмотрите его в режиме SQL.
    • Как включить режим просмотра SQL?

  15. Закройте базу данных.

Подведение итогов

На занятии были изучены запросы, запросы действия и фильтры. Эти объекты позволяют сортировать данные, выбирать их на основе введенных условий, а также обновлять и создавать таблицы.

Следующее занятие посвящено описанию форм, предназначенных для форматированного ввода данных и их просмотра на экране, и отчетов, с помощью которых содержимое таблиц выводится на принтер.


Занятие №17

Подбор требуемых данных

ТЕМА ЗАНЯТИЯ

На этом занятии рассказывается о способах фильтрации данных, выборки информации из базы данных на основе определенных критериев и о выполнении вычислений. В упражнениях занятия рассматриваются следующие темы:

  • мастер запросов;

  • конструктор запросов;

  • условие отбора;

  • итоговый запрос;

  • запрос действия;

  • фильтры.

Таблицы данных предназначены для хранения информации. Вам, конечно, захочется не только заносить в них данные, но и обрабатывать записанную ранее информацию. Access предлагает множество способов извлечения данных из таблиц. Вы можете запросить данные, руководствуясь определенным правилом отбора, отфильтровать нужные записи или рассчитать результирующие значения с помощью формул.


Запросы

Запросы являются инструментом поиска и структурирования данных. Запрос, адресованный одной или нескольким таблицам, инициирует выборку определенной части данных и их передачу в таблицу, формируемую самим запросом. В результате вы получаете подмножество информационного множества исходных таблиц, сформированное по определенному закону. Если обрабатываемый объем информации велик, выделение необходимых данных в такое подмножество позволяет существенно сократить время их обработки. В системах типа клиент-сервер, где основные базы данных хранятся на файловом сервере, система запросов позволяет уменьшить объем информации, передаваемой через локальную сеть.


Упражнение 1. Мастер запросов

Чтобы упростить задачу пользователя, в состав Access включен мастер запросов, позволяющий автоматизировать процесс построения запроса. Давайте с помощью этого мастера выполним выборку информации из таблиц базы данных Контакты.

  1. В окне базы данных щелкните на кнопке Запросы (Queries).

  2. Дважды щелкните на значке Создание запроса с помощью мастера (Create Query By Using Wizard).

  3. В раскрывающемся списке Таблицы и запросы (Tables/Queries) первого окна мастера выберите таблицу Список (рис. 17.1).

  4. В списке Доступные поля (Available Fields) щелкните на строке Дата.

  5. Щелкните на кнопке >, чтобы переместить выделенное поле в список Выбранные поля.

  6. Повторяя шаги 3-5, добавьте в список Выбранные поля поле, Описание таблицы Список, а также ноле Фамилия таблицы Контакты.

  7. Щелкните на кнопке Далее.

  8. Введите имя запроса Перечень контактов и щелкните на кнопке Готово.

Access построит запрос и выполнит его. Запрос — это набор условий, согласно которым производится выборка информации из таблиц. Запуск запроса формирует новую таблицу данных, единственным отличием которой от обычных таблиц является то, что с помощью повторных запусков запроса ее данные можно обновлять в соответствии с изменением информации источников данных запроса.

Рис. 17.1. Мастер запросов

Примечание

Чтобы база данных выглядела интереснее, в таблицу Список было добавлено несколько новых записей.

В рассматриваемом случае условие отбора инициирует получение из таблицы Список полей Дата и Описание всех имеющихся записей, а также поля Фамилия таблицы Контакты. Таблицы Список и Контакты связаны между собой через поле Код_Контакты, при этом Контакты является главной таблицей, а Список — подчиненной (то есть каждой записи таблицы Список соответствует только одна запись таблицы Контакты). Поэтому в поле Фамилия результата запроса выводится фамилия из той записи таблицы Контакты, значение поля Код_Контакты которой совпадает со значением одноименного поля таблицы Список.

Рис. 17.2. Результат выполнения запроса

Результат выполнения запроса показан на рис. 17.2.


Упражнение 2. Конструктор запросов

Мастер запросов умеет конструировать только простые условия отбора. Чтобы наложить дополнительные ограничения, следует пользоваться конструктором запросов, обеспечивающим полное управление параметрами запроса и построение сложных условий отбора данных.

  1. Чтобы переключиться в режим конструктора, выберите команду Вид > Конструктор (View > Design View). Окно конструктора показано на рис. 17.3. В его верхней части отображаются списки полей таблиц, к которым обращается запрос, и связи между таблицами. Нижняя область содержит бланк выбора полей таблиц, условий отбора и режимов сортировки. Чтобы добавить в запрос еще одно поле, выполните следующие шаги.

  2. Переместите указатель на пункт Имя таблицы Контакты.

Рис. 17.3. Конструктор запроса

  3. Нажмите кнопку мыши и перетащите поле Имя в верхнюю ячейку четвертой строки бланка запроса. Его имя появится в этой ячейке, а имя соответствующей таблицы — во второй ячейке того же столбца. Третья строка бланка запроса позволяет сортировать результат запроса по тому или иному полю.

  4. В раскрывающемся списке третьей ячейки третьего столбца бланка выберите пункт По возрастанию.

Примечание

Чтобы добавить в запрос сразу все поля таблицы, перетаскивайте пункт *. Если нужная таблица отсутствует в верхней части окна запроса, щелкните на кнопке Отобразить таблицу (Show Table) панели инструментов, выделите нужную таблицу или запрос в открывшемся окне диалога, щелкните на кнопке Добавить, а затем на кнопке Закрыть.

  5. Назначьте тот же режим сортировки для поля Имя. Теперь записи результата запроса будут упорядочены по алфавиту фамилий и имен. Имеющийся вариант связи добавляет в результат запроса только те записи связанных таблиц, в которых значения полей Код_Контакты равны. Так как для некоторых людей из таблицы Контакты нет записей в таблице Список, то информация о таких людях не включается в результат запроса. Чтобы запрос возвращал данные даже о тех людях (включенных в таблицу Контакты), с которыми не было никаких контактов, нашедших отражение в таблице Список, следует изменить параметры объединения.

  6. Дважды щелкните на линии связи.

  7. В открывшемся окне диалога Параметры объединения (Join Properties) выберите положение переключателя Объединение всех записей из "Контакты" и только тех записей из "Список", в которых связанные поля совпадают (Include All Records From "Контакты" And Only Those Records From "Список" Where The Joined Fields Are Equal).

  8. Щелкните на кнопке ОК. На одном конце линии связи появится стрелка, указывающая на смену режима объединения.

Примечание

Изменение режима объединения в окне запроса никак не влияет на параметры исходной связи, определяющие правила взаимодействия между таблицами данных, а задает только порядок отбора записей базы данных, включаемых в результат запроса.

  9. Щелчком на кнопке Вид панели инструментов запустите запрос повторно. Результат выполнения запроса с учетом сортировки и нового режима объединения будет таким, как показано на рис. 17.5.

  10. Закройте окно запроса.

  11. В ответ на вопрос о необходимости сохранения новой структуры запроса ответьте Да.


Упражнение 3. Условие отбора

Добавление в запрос условия отбора позволяет выбирать из таблицы не все записи, а лишь те, которые удовлетворяют определенным критериям. Например, вас могут заинтересовать контакты, приходящиеся на декабрь 1999 года. Давайте модифицируем запрос добавлением соответствующего условия отбора.

  1. Выделите в окне базы данных (рис. 17.4) значок запроса Перечень контактов.

Рис. 17.4. Окно базы данных

  2. Щелкните на кнопке Конструктор.

  3. В бланке запроса щелкните на ячейке Условие отбора (Criteria) первого столбца правой кнопкой мыши и выберите в контекстном меню команду Построить (Build). Откроется окно построителя выражений.

  4. В левом списке построителя щелкните на папке Операторы (Operators).

  5. В среднем списке выберите категорию Сравнения (Comparison).

  6. В правом списке дважды щелкните на пункте Between, чтобы добавить этот оператор в ноле формулы.

  7. Щелчком выделите в поле формулы первый местозаполнитель «Выражение» («Ехрг»).

  8. В левом списке построителя выражений двойным щелчком откройте папку Функции.

  9. 9. Щелкните на папке Встроенные функции, содержащей стандартные функции Access.

  10. В среднем списке построителя выражений щелкните на пункте Дата/время (Data/Time).

  11. В правом списке дважды щелкните на функции DateValue, чтобы заменить ею местозаполнитель «Выражение».

  12. Нажмите два раза клавишу —>, выделив местозаполнитель «stringexpr».

  13. Введите текст "1.12.99".

  14. Повторяя шаги 7-13, замените второй местозаполнитель «Выражение» на выражение DateValue ("31.12.99").

У вас должна получиться формула Between DateValue ("1.12.99") And DateValue ("31.12.99"). Она проверяет условие нахождения даты в интервале от 1 до 31 декабря 1999 г., то есть отбирает те записи, значение поля Дата которых относится к декабрю 1999 г.

Примечание

Если вы уже освоили правила построения выражений Access, то можете не пользоваться построителем, а непосредственно вводить выражения в бланк запроса.

  15. Щелкните па кнопке ОК. Построенная формула появится в ячейке Условие отбора первого столбца бланка запроса. При выборе записей, относящихся к одному месяцу, точная дата контакта может оказаться несущественной. Совсем выбросить это поле из бланка запроса нельзя, так как оно необходимо для реализации условия отбора. Однако любое поле можно скрыть, то есть не включать в результат запроса.

  16. Сбросьте флажок Вывод на экран (Show) первого столбца запроса (рис. 17.5).

Рис. 17.5. Скрытие поля

  17. Щелчком на кнопке Запуск (Run) панели инструментов выполните запрос.


Упражнение 4. Итоговый запрос

Запросы позволяют не только выбирать записи из таблиц, но и вычислять различные статистические параметры. Например, можно подсчитать суммарное количество контактов и вывести даты первого и последнего контакта с каждым из людей, включенных в таблицу Контакты. Чтобы построить такой запрос в режиме конструктора, выполните следующие действия.

  1. В окне базы данных щелкните на кнопке Запросы.

  2. Дважды щелкните на значке Создание запроса в режиме конструктора (Create Query In Design View).

  3. В открывшемся окне диалога (рис. 17.6) выделите строку Контакты.

  4. 4. Щелчком на кнопке Добавить добавьте выбранную таблицу в верхнюю область конструктора запроса.

  5. 5. Выделите пункт Список и снова щелкните на кнопке Добавить.

  6. 6. Щелчком на кнопке Закрыть закройте окно диалога Добавление таблицы (Show Table). Списки полей двух таблиц, соединенные линией связи, появятся в окне конструктора.

  7. 7. Щелкните на кнопке Групповые операции (Totals) панели инструментов. В бланке запроса появится дополнительная строка Групповая операция: (Total), позволяющая выполнять статистические операции со значениями конкретных полей.

Рис. 17.6 . Добавление таблицы

  8. Перетащите поле Фамилия в ячейку Поле (Field) первого столбца конструктора.

  9. В ту же ячейку второго столбца перетащите поле Имя таблицы Контакты.

  10. В третий, четвертый и пятый столбцы бланка запроса перетащите поле Дата таблицы Список (рис. 17.7).

Рис. 17.7. Запрос с групповыми операциями

  11. В раскрывающемся списке ячейки Групповая операция (Total) третьего столб ца бланка запроса выберите пункт Min.

  12. В той же ячейке четвертого столбца выберите пункт Мах.

  13. В пятом столбце задайте групповую операцию Count. Групповые операции построенного запроса обработают все записи таблицы Список, соответствующие конкретному человеку из таблицы Контакты, и вместо самих данных таблицы Список выведут в соответствующее поле результата запроса только значение величины, вычисляемой по определенной формуле. Доступные групповые операции перечислены в табл. 17.1.

ТАБЛИЦА 17.1 . Групповые операции

Название | Функция
Условие(Where) | Режим задания условия отбора для поля, но которому не выполняется группировка. Access автоматически делает такое поле скрытым
Выражение (Expression) | Вычисляемое поле, значение которого рассчитывается по сложной формуле
Group By | Поле, определяющее группу записей, по которой вычисляются статистические параметры. К одной группе относятся все записи, для которых значения поля с режимом Group By (Группировка) одинаковы
Last | Последнее значение в группе
First | Первое значение в группе
Var | Вариация значений поля
StDev | Стандартное отклонение величин ноля от среднего
Count | Количество записей, соответствующее ноле которых не содержит величины Null
Мах | Максимальное значение
Min | Минимальное значение
Avg | Среднее значение поля
Sum | Сумма значений поля по всем записям

Примечание

Поскольку в пятом поле запроса вычисляется количество записей, в ячейку Поле этого столбца можно поместить любое поле таблицы Список.

  14. Щелкните на кнопке Вид, чтобы выполнить запрос. Появится таблица с пятью столбцами. Два первых столбца содержат фамилии и имена людей. По ним выполняется группировка, то есть расчет значений остальных полей запроса выполняется для записей таблицы Список, сопоставляемых с одним человеком. Как уже говорилось выше, соответствие контакта таблицы Список и человека из таблицы Контакты определяется полями Код_Контакты, с помощью которых осуществляется связь этих двух таблиц. Третий и четвертый столбцы запроса выводят соответственно дату первого (функция Min) и последнего (функция Мах) контакта с данным человеком. Пятый столбец содержит количество записей в таблице Список (функция Count), соответствующих. данному человеку, то есть число контактов с ним. Единственный недостаток построенного запроса — это непонятные имена столбцов. Давайте скорректируем их.

  15. Щелчком на кнопке Вид вернитесь в конструктор запроса.

  16. В ячейке Поле третьего столбца замените имя Дата на текст Дата первого контакта: Дата. Правая часть этого выражения, расположенная правее двоеточия, по-прежнему задает имя поля, а левая определяет название столбца результата запроса. Таким образом, любому столбцу запроса можно назначить произвольное имя.

  17. В ячейке Поле четвертого столбца введите Дата последнего контакта: Дата.

  18. В первой строке пятого столбца бланка'запроса введите Число контактов: Дата.

Примечание

К сожалению, подобный прием не подходит для смены названия поля, значение которого не вычисляется, а передается из таблицы. То есть таким способом не удастся переименовать поле Имя.

  19. Снова щелкните на кнопке Вид.

  20. Закройте запрос.

  21. Для сохранения изменений структуры щелкните на кнопке Да.

  22. В окне диалога Сохранение (Save As) введите имя Итоговый запрос и щелкните на кнопке ОК.


Упражнение 5. Запрос действия

До сих пор вы сталкивались с запросами, выполняющими выборку данных и некоторые вычисления. Однако запросы могут применяться также для добавления, удаления и обновления группы записей таблицы. Такие запросы являются мощным инструментом преобразования данных, они называются запросами действия. Предположим, что по каким-то причинам вам понадобилось скорректировать даты контактов, заменив во всех записях таблицы Список, относящихся к 1999 году, месяц ноябрь на декабрь. Подобную операцию трудно проделать вручную,- если в таблице содержится несколько тысяч записей. Запрос действия позволяет быстро решить поставленную задачу.

  1. В окне базы данных щелкните на кнопке Таблицы.

  2. Выделите таблицу Список, данные которой нужно обновить.

  3. В палитре кнопки Новый объект (New Object) выберите пункт Запрос (Query). Откроется окно диалога Новый запрос (New Query), показанное на рис. 17.8. Подобное окно открывается и при щелчке на кнопке Создать (New) окна базы данных. Оно позволяет выбрать наиболее удобный способ создания объекта.

Рис. 17.8. Создание запроса

  4. Дважды щелкните на строке Конструктор (Design View). Таблица Список, выделенная в окне базы данных на шаге 2, автоматически появится в окне конструктора запросов.

  5. Перетащите в бланк запроса поле Дата, значение которого нужно обновлять.

Примечание

Название поля, заключенное в квадратные скобки, является ссылкой на значение поля. Чтобы сослаться на поле другой таблицы, нужно в начале указать имя таблицы, а затем имя поля (оба имени в квадратных скобках) и разделить их восклицательным знаком. Например [Контакты]! [Фамилия].

  6. В палитре кнопки Тип запроса (Query Type) выберите пункт Обновление (Update Query). Описание всех возможных вариантов запросов, предлагаемых программой Access, приведено в табл. 17.2. Структура бланка запроса видоизменяется в соответствии с типом запроса. В бланке выбранного варианта запроса на обновление появляется поле Обновление (Update To), в которое нужно ввести новое значение поля. Чтобы изменить месяц даты с ноября на декабрь, достаточно прибавить к дате 30 дней.

  7. Введите в ячейку Обновление (Update To) формулу [Дата] +30.

ТАБЛИЦА 17.2. Варианты запросов

Тип | Описание
Выборка (Select) ; | Выборка данных в таблицу результата запроса на основе указанных условий отбора
Перекрестный (Crosstab) | Результат запроса выводит статистические значения (сумму, количество или среднее) для одного из полей таблицы в зависимости от двух параметров других полей таблицы, задающих заголовки строк и столбцов результата перекрестного запроса
Создание таблицы (Make-Table) | Создание новой таблицы в текущей или в другой базе данных на базе информации из имеющихся таблиц
Обновление (Update) | Обновление данных таблицы
Добавление (Append) | Добавление набора записей в таблицу
Удаление (Delete) | Удаление записей таблицы в соответствии с указанным критерием

  8. Чтобы обновлялись только даты, относящиеся к ноябрю 2000 года, введите в ячейку Условие отбора формулу Between DateValue ("1.11.99") And DateValue ("30.11.99"), которая подробно обсуждалась в третьем упражнении этого занятия (рис. 17.12).

  9. Закройте запрос, сохранив его под именем Обновление.

  10. Щелкните на кнопке Таблицы окна базы данных и двойным щелчком на значке Список откройте эту таблицу. В ней есть четыре записи, относящиеся к ноябрю 2000 года.

Примечание

Запросы действия могут выполнять широкомасштабные изменения данных, которые отменить уже невозможно. Будьте внимательны. Перед запуском таких запросов полезно сделать резервную копию базы данных, чтобы иметь возможность возвратиться к исходному состоянию таблиц. Значки запросов действия снабжены восклицательным знаком, предупреждающим об их особой роли.

  11. В окне базы данных щелкните на кнопке Запросы.

  12. Дважды щелкните на значке Обновление.

Ответьте Да на вопрос о необходимости запуска запроса действия. Access проинформирует вас об обнаружении четырех записей, удовлетворяющих условию отбора, и попросит подтвердить необходимость их изменения.

Рис. 17.9. Запрос на обновление

  13. Щелкните на кнопке Да и изучите изменения, произошедшие с данными таблицы Список.


Фильтры

Фильтры, как и запросы, предназначены для отбора определенных записей базы данных. Но фильтр сохраняется вместе с таблицей и не может использоваться с другими объектами, если он не был записан в виде запроса.


Упражнение 6. Установка фильтра

Установка фильтра — простейший способ отбора части записей в таблице, запросе или форме. В этом упражнении с помощью фильтра будет выделено несколько записей таблицы Контакты.

  1. В окне базы данных щелкните на кнопке Таблицы, а затем дважды на значке Контакты.

  2. В столбце Фамилия щелкните на ячейке с фамилией Петров.

  3. Щелкните на кнопке Фильтр по выделенному (Filter By Selection). В результате видимыми останутся только те записи, в поле Фамилия которых присутствует значение Петров (рис. 17.10).

  4. Чтобы отменить влияние фильтра, щелкните на кнопке Удалить фильтр (Remove Filter).

Примечание

Access запоминает последний применявшийся фильтр. Его можно снова назначить простым щелчком на кнопке Применение фильтра (Apply Filter). Это та же самая кнопка, с помощью которой отменяется действие фильтра, но теперь она будет иметь другое название.

Фильтр может быть и более сложным. Например, чтобы оставить все записи с фамилией Петров и непустым полем телефона, выполните следующие шаги.

Рис. 17.10. Фильтрация записей

  5. Выберите команду Записи > Фильтр > Расширенный фильтр (Records > Filter > Advanced Filter/Sort). Откроется окно, похожее на конструктор запроса. Критерий равенства поля Фамилия значению Петров уже будет присутствовать в бланке фильтра.

  6. Перетащите поле Рабочий Телефон во второй столбец бланка.

Рис. 17.11. Окно расширенного фильтра

  7. В ячейку Условие отбора введите формулу <>Null (рис. 17.11).

Значение любого пустого поля равно величине NuIL Условие < >NuII проверяет поле на неравенство величине Null, то есть отбирает все непустые поля.

  8. Выберите команду Фильтр > Применить фильтр (Filter > Apply Filter/Sort). Настроенный" фильтр будет применен к таблице Контакты. В результате в ней останутся только две записи.

  9. С помощью команды Записи > Удалить фильтр (Records > Remove Filter/Sort) отмените фильтрацию.


Упражнение 7. Преобразование в запрос

К сожалению, назначение нового фильтра автоматически стирает все предыдущие, которые уже невозможно применить повторно. Если фильтр достаточно сложный, его многократная настройка может отнимать много времени, и вам, вероятно, захочется как-то спасти результат титанического труда. Access предлагает простой способ сохранения фильтров. Так как окно фильтра подобно конструктору запроса, было бы логично записать фильтр в виде запроса с теми же условиями отбора. Чтобы превратить фильтр в запрос, выполните следующие шаги.

  1. Командой Записи > Фильтр > Расширенный фильтр (Records > Filter > Advanced Filter/Sort) активизируйте окно сложного фильтра, созданного в предыдущем упражнении.

  2. Выполните команду Файл > Сохранить как запрос (File > Save As Query).

  3. В открывшемся окне диалога введите имя Фил ьтр и щелкните на кнопке ОК.

  4. Закройте окно фильтра.

  5. В окне базы данных появился новый запрос с названием Фильтр. Дважды щелкните на значке этого запроса.

Откроется окно результата выполнения запроса, записи которого будут повторять записи фильтрованной таблицы Контакты. Этим запросом можно пользоваться когда угодно, выводя на экран записи, отобранные по соответствующим критериям. Более того, любой запрос можно превратить в фильтр. Это делается следующим образом.

  6. Щелчком активизируйте окно таблицы Контакты (если таблица закрыта, откройте ее).

  7. Чтобы назначить новый фильтр (и стереть предыдущий), щелкните на ячейке с фамилией Петров правой кнопкой мыши и выберите в контекстном меню команду Исключить выделенное (Filter Excluding Selection). В таблице останутся только те записи, в поле Фамилия которых нет слова Петров.

  8. Щелчком на кнопке Удалить фильтр отмените фильтрацию данных. Теперь давайте вернем прежний сложный фильтр.

  9. Выберите команду Записи > Фильтр > Расширенный фильтр.

  10. Выберите команду Файл > Загрузить из запроса (File > Load From Query).

  11. В открывшемся окне диалога выделите запрос Фильтр и щелкните на кнопке ОК.

Старые условия фильтрации появятся в бланке окна фильтра. Теперь для применения сохраненного фильтра достаточно щелкнуть на кнопке Применение фильтра панели инструментов.


Контрольное упражнение

С помощью контрольного упражнения закрепите знания о запросах и фильтрах, выполнив самостоятельно приведенные ниже операции и ответив на предложенные вопросы.

  1. Запустите мастер запросов.

  2. Добавьте в запрос поля Фамилия и Адрес таблицы Контакты, а затем поля Дата и Описание таблицы Список.
  3. Настройте итоговый запрос, подсчитывающий количество записей.
    • Как с помощью мастера, создать итоговый запрос?

  4. Переключитесь в режим конструктора.

  5. Скройте третье и четвертое поля запроса.

  6. Закройте запрос, сохранив его под именем Количество записей.

  7. Откройте таблицу Список.

  8. Включите фильтр, оставляющий только записи, относящиеся к фамилии Леонидов.

  9. Откройте окно сложного фильтра.
  10. Измените условие фильтрации так, чтобы оставались также записи, касающиеся Петрова.
    • Какое условие отбора необходимо добавить ?

  11. Назначьте обновленный фильтр.

  12. Сохраните настроенный фильтр в виде запроса.

  13. Откройте запрос Обновление в конструкторе запросов.
  14. Просмотрите его в режиме SQL.
    • Как включить режим просмотра SQL?

  15. Закройте базу данных.


Подведение итогов

На занятии были изучены запросы, запросы действия и фильтры. Эти объекты позволяют сортировать данные, выбирать их на основе введенных условий, а также обновлять и создавать таблицы.

Следующее занятие посвящено описанию форм, предназначенных для форматированного ввода данных и их просмотра на экране, и отчетов, с помощью которых содержимое таблиц выводится на принтер.


Занятие №18

Формы и отчеты

ТЕМА ЗАНЯТИЯ

Информация баз данных хранится в таблицах, но с ними не очень удобно работать. Для ввода, редактирования и печати информации предназначаются формы и отчеты. Вы познакомитесь с ними на этом занятии, в упражнениях которого рассматриваются следующие темы:

  • мастер форм;

  • конструктор форм;

  • элементы управления;

  • заголовок и примечание формы;

  • мастер отчетов;

  • конструктор отчетов;

  • группировка и сортировка;

  • печать данных.

Форма

В то время как таблицы и запросы позволяют отобразить на экране длинные списки записей, формы дают возможность сосредоточиться на конкретной записи. Они облегчают ввод, редактирование и восприятие информации, могут содержать вспомогательные подписи и элементы оформления.

Упражнение 1. Мастер форм

Мастер форм позволяет сберечь время и быстро сконструировать привлекательную форму для записей любой таблицы.

  1. С помощью команды Файл > Открыть (File > Open) откройте базу данных Контакты, созданную на предыдущем занятии.

  2. В окне базы данных щелкните на кнопке Формы (Forms).

  3. В списке форм дважды щелкните на значке Создание формы с помощью мастера (Create Form By Using Wizard).

  4. В списке Таблицы/запросы первого окна мастера, показанного на рис. 18.1, выберите пункт Таблица: Контакты.

Рис. 18.1. Мастер форм

  5. Щелкните на кнопке », чтобы добавить в список Выбранные поля все поля таблицы.

  6. Выделите пункт Код_Контакты и щелчком на кнопке < уберите это поле обратно в левый список. Содержимое поля Код_Контакты генерируется автоматически, а его значение несущественно для пользователя, поэтому не следует включать это поле в форму.

  7. Щелкните на кнопке Далее.

  8. В следующем окне диалога выберите для формы стиль Выровненный (Justified) и щелкните на кнопке Далее.

  9. В списке третьего окна выберите вариант оформления Камень (Stone) или любой другой понравившийся вам стиль и снова щелкните на кнопке Далее.

  10. В последнем окне мастера щелкните на кнопке Готово, не изменяя никаких параметров. Мастер сгенерирует форму и откроет ее в режиме просмотра данных.

Окно формы содержит названия и области отображения для всех полей таблицы, выбранных в первом окне мастера. В нижней части формы расположены кнопки перемещения по записям, аналогичные кнопкам окна таблицы.

  11. Щелкните несколько раз на кнопке Следующая запись, чтобы добраться до информации о Василии Петрове. В этой записи отсутствуют адрес, название фирмы и телефон.

  12. Щелкните на поле ниже подписи Адрес и введите адрес Василия Петрова.

  13. Аналогичным способом добавьте название компании и телефон (рис. 18.2).

Рис. 18.2. Форма для таблицы Контакты

  14. Щелкните на кнопке Новая запись (New Record) и добавьте информацию еще об одном человеке. Как видите, форма позволяет просматривать и редактировать любую запись, а также добавлять записи.

Упражнение 2. Конструктор форм

Недостатком форм, создаваемых мастером, является то, что они однообразны и не содержат пояснительных надписей. Чтобы приукрасить форму и расположить поля более удобным образом, следует воспользоваться конструктором форм, который позволяет передвигать и масштабировать элементы формы, связывать их с источником данных и настраивать любые другие параметры формы. Давайте создадим с помощью конструктора форму для таблицы Список.

  1. В окне базы данных дважды щелкните на значке Создать форму в режиме конструктора (Create Form In Design View). В окне конструктора присутствуют пустая форма с разметочной сеткой, вертикальная и горизонтальная линейки, помогающие позиционировать объекты (рис. 18.3). Неотъемлемым атрибутом конструктора форм является пацель инструментов Панель элементов (Toolbox), помогающая добавлять элементы формы. Новую форму необходимо связать с источником данных — таблицей Список.

Рис. 18.3. Конструктор форм

  2. Щелкните в пустой области конструктора и выберите в контекстном меню команду Свойства (Properties).

  3. На вкладке Данные (Data) окна диалога свойств формы (рис. 18.4) щелкните на стрелке поля Источник записей (Record Source).

Примечание

Любой элемент формы имеет контекстное меню, в котором есть команда Свойства. Выбор такой команды открывает окно свойств, подобное окну свойств формы. Вкладка Макет (Format) содержит параметры форматирования объекта. Вкладка Данные — описание источника данных, различные ограничения и условия, накладываемые на данные поля. Вкладка События (Event) позволяет писать функции отклика на различные события (например, перемещение мыши на объект). Параметры, не вошедшие в первые три группы, размещаются на вкладке Другие (Other). Вкладка Все (АН) обеспечивает одновременный доступ ко всем параметрам.

  4. Выберите в раскрывшемся списке пункт Список.

  5. Закройте окно свойств. В конструкторе форм появится небольшое окно со списком полей источника записей (таблицы Список). Это окно помогает добавлять элементы управления формы. Его можно скрывать или выводить на экран с помощью кнопки Список полей (Field List). Сейчас нужно добавить в форму три области ввода для трех полей таблицы.

  6. Поместите указатель на пункт Дата окна Список, нажмите кнопку мыши и перетащите этот пункт в область формы. Access создаст элемент управления типа поле, а также подпись.

Рис. 18.4. Окно свойств формы

  7. Проделайте аналогичную операцию для пунктов Описание и Код_Контакты, расположив поля примерно так, как показано на рис. 18.5. Любой объект формы можно выделить щелчком мыши, при этом вокруг него появляется габаритная рамка с боковыми и угловыми маркерами масштабирования объекта. В левом верхнем углу объекта появляется большой квадрат, за который можно перетаскивать объект в пределах формы.

  8. Щелчком выделите подпись Описание. Затем еще раз щелкните на ней, чтобы перейти в режим редактирования. Замените имеющийся текст на Описание контакта.

  9. Захватите правый боковой маркер поля Описание мышью и растяните рамку поля до правого края формы.

Рис. 18.5. Добавление полей

Рис. 18.6. Готовая форма

  10. При необходимости, ухватившись за маркер перемещения мышью, подвигайте поле Описание.

  11. Повторите процедуры шагов 8-10 для всех трех полей. Разместите их и настройте подписи в соответствии с рис. 18.6.

  12. Чтобы привести оформление новой формы в соответствие с форматом формы, созданной в предыдущем упражнении, щелкните на кнопке Автоформат (AutoFormat) панели инструментов.

  13. Выберите в списке открывшегося окна диалога пункт Камень и щелкните на кнопке ОК. Access приведет фон формы, оформление, цвет и шрифт полей в соответствие с выбранным шаблоном.

  14. Щелчком на кнопке Вид перейдите в режим редактирования данных.

В форму будет выведено содержимое первой записи таблицы Список. Обратите внимание, что поле с подписью Фамилия имеет такой же список подстановки, который был настроен для поля Код_Контакты таблицы Список на предыдущем занятии. Структура списка подстановки была перенесена в форму в процессе перетаскивания поля на шаге 7.

  15. Закройте окно формы.

  16. В появившемся окне диалога введите в качестве имени новой формы слово С п и с о к и щелкните на кнопке О К.

Теперь форма Список появится на вкладке Формы (Forms) окна базы данных.

Примечание

Чтобы одновременно переместить поле вместе с его подписью, тащите объект за тело подписи (но не за маркер перемещения).

Упражнение 3. Элементы управления

При открытии конструктора форм на экране появляется панель элементов (см. рис. 18.3). Если ее нет, щелкните на кнопке Панель элементов панели инструментов. С помощью кнопок панели элементов в форму можно добавлять различные объекты, типы которых перечислены в табл. 18.1. Элементы управления форм и отчетов сходны между собой, поэтому такая же панель элементов имеется и в конструкторе отчетов, о котором мы поговорим на этом занятии позже, а все операции, рассматриваемые в этом и в следующем упражнении, одинаково применимы как к формам, так и к отчетам.

Примечание

В предыдущем упражнении в форму было добавлено шесть элементов управления: два поля ввода (Дата и Описание), одно поле со списком Код_Контакты и три надписи, по одной рядом с каждым полем.

ТАБЛИЦА 18.1. Элементы управления форм и отчетов
Значок | Название | Назначение
 | Надпись (Label) | Надписи создаются автоматически вместе с элементами типа текстовое поле, поле со списком и т. п. Они разъясняют смысл поля ввода. Дополнительные надписи могут использоваться для заголовков и пояснений
 | Поле (Text Box) | Используется для ввода и отображения информации полей таблиц и запросов, а также для вывода результатов вычислений
 | Группа переключателей (Option Group) | Группа переключателей ссылается на некоторое поле таблицы. Каждый переключатель группы соответствует определенному целочисленному значению этого поля
 | Выключатель (Toggle Button) | Позволяет вводить информацию типа да/нет. Величине «да» или «истина» соответствует утопленное положение выключателя
 | Переключатель (Option Button) | Элемент группы переключателей, в которой может быть отмечен только один из них (его кружок выглядит зачерненным)
 | Флажок (Check Box) | Предназначен для представления полей типа да/нет. Отмеченный квадратик соответствует величине «да», а пустой — «нет»
 | Поле со списком (Combo Box) | Разрешает как непосредственный ввод значения в поле, так и его выбор в раскрывающемся списке предопределенных значений
 | Список (List Box) | Позволяет выбирать данные из набора пунктов и не разрешает непосредственный ввод значений
 | Кнопка (Command Button) | Щелчок на такой кнопке выполняет команду, с помощью которой можно перейти в другую форму, переместиться по записям и выполнить многие другие операции

Рисунок | Рисунок любого графического формата с рамкой
Свободная рамка объекта (Unbound Object Frame) | Объект OLE, не связанный ни с каким источником данных
Присоединенная рамка объекта (Bound Object Frame) | Объект OLE, связанный с полем данных таблицы или запроса
Разрыв страницы (Page Break) | Линия, по которой формируется перевод страницы при выводе формы или отчета на принтер
Набор вкладок (Tab Control) | Позволяет разместить на одном и том же пространстве экрана несколько наборов элементов управления. Удобен в тех случаях, когда элементы легко разделяются на логические группы
Подчиненная форма/отчет (Subform/Subreport) | Вставляет в форму (или отчет) область с другой формой (или отчетом), связанной с главной
Линия (Line) | Добавляет прямую линию
Я Прямоугольник (Rectangle) | Рисует прозрачный или непрозрачный прямоугольник с цветной границей любой толщины
Другие элементы (More Controls) | Открывает меню с элементами управления, не вошедшими в панель элементов

Чтобы с помощью панели элементов добавить в форму декоративные объекты, выполните следующие шаги.

  1. Поместите указатель мыши на угол области формы.

  2. Перетащите этот угол вправо вниз, чтобы немного увеличить форму.

  3. С помощью команды Правка > Выделить все (Edit > Select All) выделите все элементы формы.

  4. Нажмите клавишу Ctrl и, не отпуская ее, нажатиями клавиш со стрелками передвиньте элементы формы так, чтобы они были отцентрированы относительно новых границ формы.

  5. Щелкните на кнопке Прямоугольник (Rectangle) панели элементов.

  6. Растяните мышью диагональ прямоугольника, чтобы он окружил все элементы формы (рис. 18.7).

  7. В палитре кнопки 11вет линии/границы (Line/Border Color) панели инструментов Форматирование (Formatting) выберите синий цвет.

Рис. 18.7. Добавление элементов формы

  8. В палитре кнопки Толщина линии/границы (Line/Border Width) выберите толщину 4 пиксела.

  9. Щелкните на кнопке Рисунок (Image) панели элементов.

  10. В левом нижнем углу формы растяните рамку рисунка.

Рис. 18.8. Параметры рисунка

  11. В открывшемся окне выбора файла найдите папку, в которую был установлен Office XP (обычно она называется Microsoft Office), раскройте вложенную в нее папку Office10\Broadcast, выберите файл NS_logo.gif и щелкните на кнопке ОК. (Вместо этого файла можете вставить любой другой не слишком большой рисунок.)

По умолчанию рисунки вставляются в форму в режиме урезания рисунка рамкой элемента. Чтобы изменить режим размещения, выполните следующие действия.

  12. Щелкните на рисунке правой кнопкой мыши и выберите в контекстном меню команду Свойства.

  13. В списке Установка размеров (Size Mode) вкладки Макет открывшегося окна параметров выберите пункт Вписать в рамку (Stretch), как показано на рис. 18.8. Теперь рисунок будет растягиваться и сжиматься вместе с рамкой элемента, подстраиваясь под ее размеры.

  14. Закройте окно параметров.

Упражнение 4. Заголовок и примечание

До сих пор вы имели дело с формами, в которых одновременно отображалась только одна запись. Однако параметры формы можно настроить так, чтобы в ее окне демонстрировался длинный список одинаковых форм, содержащих данные разных записей таблицы. Чтобы включить этот режим, выполните следующие действия.

  1. В конструкторе формы Список щелкните на свободном пространстве правой кнопкой мыши.

  2. Выберите в контекстном меню команду Свойства, чтобы открыть окно свойств формы, показанное на рис. 18.9.

Рис. 18.9. Параметры форматирования формы

  3. В списке Режим по умолчанию (Default View) вкладки Макет выберите пункт Ленточная форма (Continuous Forms).

  4. Закройте окно параметров.

В подобных ленточных формах для размещения заголовков и пояснительных надписей удобно пользоваться дополнительными разделами — заголовком и примечанием формы, которые остаются на месте при прокручивании ленточной формы. Чтобы добавить эти разделы, сделайте следующее.

  5. Выберите команду Вид > Заголовок/примечание формы (View > Form Header/Footer), в окне конструктора формы появятся дополнительные области, показанные на рис. 18.10.

  6. Щелкните на кнопке Надпись (Label) панели элементов.

  7. Растяните мышью прямоугольник в разделе Заголовок формы (Form Header).

  8. Введите текст Список контактов.

  9. Нажмите клавишу Esc, чтобы выйти из режима редактирования текста, но оставить надпись выделенной.

  10. В списке Размер (Font Size) панели инструментов Форматирование выберите число 22.

  11. Щелкните на кнопке По центру (Center).

  12. Поместите указатель на верхний край полосы Область данных (Detail) и, нажав кнопку мыши, перетащите ее вверх, уменьшив область заголовка до необходимых размеров.

Рис. 18.10. Добавление заголовка и примечания

Рис. 18.11. Ленточная форма

  13. Повторив шаги 6-8, введите в примечание формы текст Если при добавлении контакта вы не нашли нужного человека в списке Фамилии, с помощью формы Контакты добавьте информацию об этом человеке в новую запись таблицы Контакты.

  14. Перетащите нижний край формы вверх, уменьшив ее по высоте.

  15. Щелкните на кнопке Вид.

Теперь в окне формы может разместиться сразу две записи, как показано на рис. 18.11. Такую форму можно листать с помощью полосы прокрутки. Заголовок и примечание формы отображаются в верхней и нижней частях окна, не смещаясь при прокручивании записей.

Отчет

В целом отчеты похожи на формы, но они, как правило, предназначаются для вывода информации из базы данных на принтер. Поэтому в отчетах данные форматируют так, чтобы их было удобно размещать на отдельных страницах. Отчеты поддерживают самые разнообразные способы оформления и позволяют группировать данные, разбивая их на логически цельные блоки.

Упражнение 5. Мастер отчетов

Чтобы облегчить работу пользователя, в Access имеется специальный мастер, который при недостатке времени позволяет быстро создавать довольно привлекательные отчеты. Давайте поручим мастеру построение отчета о контактах с разными людьми.

  1. В окне базы данных щелкните на кнопке Отчеты (Reports).

  2. Дважды щелкните на значке Создание отчета с помощью мастера (Create Report By Using Wizard).

В отчет нужно добавить как информацию о людях, так и данные о контактах с ними. Для этого следует сгруппировать вместе все контакты с одним человеком и распечатать их список ниже области с данными об этом человеке. Затем нужно вывести информацию о следующем человеке и список контактов с ним и т. д. Такой порядок печати записей позволит быстро найти полный список контактов с любым из ваших коллег. В первом окне мастера, показанном на рис. 18.12, нужно указать все поля, включаемые в отчет.

Рис. 18.12. Выбор полей для отчета

  3. В раскрывающемся списке Таблицы и запросы первого окна мастера отчета выберите таблицу Контакты.

  4. В списке Доступные поля выделите поле Фамилия.

  5. Щелчком на кнопке > переместите выбранное поле в список Выбранные поля.

  6. Повторяя шаги 4 и 5, добавьте в список Выбранные поля поля Имя, Адрес, Название Компании, Рабочий Телефон.

Примечание

Поле Код_Контакты содержит служебную информацию, обеспечивая связь записей двух таблиц. Не помещайте такие поля в отчет никогда, кроме случаев отладки взаимосвязей таблиц базы данных.

  7. Выберите в списке Таблицы и запросы таблицу Список.

  8. Переместите в список Выбранные поля поля Дата и Описание, добавив их к по лям таблицы Контакты.

9. Щелкните на кнопке Далее.

Во втором окне мастера можно выбрать способ расположения данных — упорядоченные по записям таблицы Контакты, а затем уже по записям таблицы Список, или наоборот. Схема группировки отображается в правой части окна диалога.

Рис. 18.13. Пятое окно мастера отчетов

  10. Оставьте вариант Контакты (By Контакты) и щелкните на кнопке Далее.

  11. В следующем окне не назначайте дополнительной группировки. Просто щелк ните на кнопке Далее.

  12. Четвертое окно мастера отчета позволяет задать порядок сортировки записей. Выберите в списке 1 пункт Дата и щелкните на кнопке Далее.

Следующее окно, показанное на рис. 18.13, позволяет выбрать способ расположения полей и ориентацию страницы.

Рис. 18.14. Фрагмент отчета, сгенерированного мастером

  13. Выберите положение переключателя Структура 1 (Outline 1).

  14. Затем щелкните на кнопке Далее.

  15. В следующем окне мастера выберите вариант оформления Строгий (Corporate) и щелкните на кнопке Далее.

  16. Введите в качестве заголовка текст Список контактов и щелкните на кнопке Готово.

Мастер сформирует отчет и откроет его в отдельном окне в режиме предварительного просмотра (рис. 18.14). В нем видно, что сначала идет фамилия первого человека, информация о нем и список контактов с ним, затем располагаются те же данные, касающиеся второго человека, и т. д. В целом отчет выглядит неплохо и может устроить нетребовательного пользователя.

Упражнение 6. Конструктор отчетов

Если внимательно присмотреться к отчету, показанному на рис. 18.14, можно заметить несколько недостатков. Вот их список:

  • названия таких полей, как Фамилия и Имя, явно лишние, их следует убрать;

  • информация о человеке занимает слишком много места, ее можно представить компактнее;

  • некоторые подписи следует заменить более понятными;

  • поле Дата слишком коротко, оно не вмещает дату в длинном формате. Давайте исправим указанные недочеты в конструкторе отчетов.

  1. Чтобы переключиться в режим конструктора, выберите команду Вид > Конструктор.

Рис. 18.15. Конструктор отчетов

В схеме отчета (рис. 18.15) присутствует несколько разделов. Их назначение указано в табл. 18.2. Поля и подписи можно размещать в любом разделе отчета, регулируя этим их положение на странице.

  2. Щелчком выделите надпись Фамилия.

  3. Нажатием клавиши Delete удалите надпись.

ТАБЛИЦА 18.2 . Разделы отчета
Раздел | Назначение
Заголовок отчета (Report Header) | Печатается в самом начале отчета один раз. Выводится и скрывается командой Вид > Заголовок/примечание отчета (View > Report Header/Footer)
Верхний колонтитул (Page Header) | Печатается в верхнем поле каждой страницы. Выводится и скрывается командой Вид > Колонтитулы (View > Page Header/Footer)
Заголовок группы КолКонтакты (КонтактыЮ Header) | Появляется в начале каждой группы записей, соответствующих очередному значению поля КодКонтакты (то есть того поля, по которому назначена группировка)
Область данных (Detail) | Основные данные отчета
Нижний колонтитул (Page Footer) | Печатается в нижнем поле каждой страницы. Выводится и скрывается командой Вид > Колонтитулы (View > Page Header/Footer)
Примечание отчета (Report Footer) | Печатается в самом конце отчета. Выводится и скрывается командой Вид > Заголовок/приме чание отчета (View > Report Header/Footer)

  4. Повторяя шаги 2 и 3, удалите из раздела Заголовок группы Код_Контакты надписи Имя, Дата и Описание. Назначение соответствующих полей очевидно и не нуждается в пояснении.

  5. Щелкните на горизонтальной линии, расположенной ниже поля Назвакие Компании, правой кнопкой мыши и выберите команду Вырезать (Cut).

  6. Аналогичным приемом удалите три оставшиеся линии раздела Заголовок группы Код_Контакты. Нет смысла выводить подписи полей адреса, названия компании и телефона в заголовке каждой группы. Достаточно будет поместить соответствующие надписи в верхний колонтитул страницы.

  7. Поместите указатель мыши между заголовками разделов Верхний колонтитул и Заголовок группы Код_Контакты, чтобы его значок превратился в двунаправленную стрелку. Нажмите кнопку мыши и перетащите заголовок группы вниз, освобождая место для верхнего колонтитула.

  8. Щелчком выделите надпись Адрес. Нажмите клавиши Ctrl+X, чтобы вырезать ее.

  9. Щелкните на заголовке раздела Верхний колонтитул и нажмите клавиши Ctrl+V, чтобы вставить вырезанную надпись в верхний колонтитул.

  10. Выделяя надписи колонтитула и перетаскивая их мышью за маркер верхнего левого угла либо передвигая нажатием клавиши Ctrl и клавиш со стрелками, разместите их так, как показано на рис. 18.16.

Рис. 18.16. Перемещение надписей между разделами

  11. Щелкните на надписи Адрес. Повторным щелчком на ней включите режим редактирования и замените текст на Почтовый адрес.

  12. Описанным выше приемом измените текст подписей НазваниеКомпании и РабочийТелефон соответственно на Компания и Телефон.

  13. Переставьте поля раздела Заголовок группы Код_Контакты, разместив их в две строки. Фамилия и имя — в первой строке, а остальные три поля — во второй.

  14. Щелкните правой кнопкой мыши на жирной линии, расположенной в разделе Заголовок отчета. Выберите в контекстном меню команду Копировать (Copy).

  15. Щелкните на заголовке раздела Заголовок группы Код_Контакты и нажмите клавиши Ctrl+V, чтобы вставить в этот раздел дубликат линии.

  16. Нажимая клавиши Ctrl+V, переместите линию вниз, под вторую строку полей данных.

  17. Снова нажмите Ctrl+V, добавив вторую линию вдоль верхнего края раздела.

  18. Перетащите заголовок раздела Область данных вверх, убрав излишнее пустое пространство.

  19. Щелчком выделите поле Дата. Увеличьте его горизонтальный размер, перетащив вправо серединный маркер правой границы поля.

Рис. 18.17. Модифицированная структура отчета

  20. Растяните поле Описание вправо до границы отчета. Окончательный вид новой структуры отчета показан на рис. 18.17.

  21. С помощью команды Вид > Предварительный просмотр (View > Print Preview) переключите отчет в режим вывода данных. В новом варианте, показанном на рис. 18.18, информация размещается намного компактнее.

  22. Закройте отчет. При появлении запроса о необходимости сохранения новой структуры отчета щелкните на кнопке Да.

Примечание

В нижней части страницы отчета выводятся текущая дата и номер страницы. Эта информация генерируется элементами управления, размещенными в разделе Нижний колонтитул конструктора отчета.

Рис. 18.18. Просмотр нового варианта отчета

Упражнение 7. Группировка и сортировка

Отчет, который вы сконструировали в двух предыдущих упражнениях, имеет еще один существенный недостаток. Фамилии людей из списка Контакты выводятся не по алфавиту. Мастер отчетов автоматически сгруппировал данные таблицы Список по их принадлежности к тем или иным записям таблицы Контакты, которая определяется связью между полями Код_Контакты этих двух таблиц. По указанной причине фамилии в отчете упорядочены по возрастанию числового параметра Код_Контакты — идентификатора записей таблицы Контакты. Это неудобно, в отчетах с большим числом записей при такой сортировке будет довольно трудно отыскать нужного человека. Есть смысл изменить порядок сортировки, для этого выполните следующие шаги.

  1. Щелкните на кнопке Отчеты окна базы данных.

  2. Выделите значок отчета Список контактов.

  3. Щелчком на кнопке Конструктор панели инструментов окна базы данных от- кройте отчет в режиме конструктора.

  4. Щелкните на кнопке Сортировка и группировка (Sorting And Grouping) панели инструментов, чтобы открыть окно диалога, показанное на рис. 18.19.

Рис. 18.19. Сортировка и группировка

В этом окне назначены два уровня сортировки. Сначала в порядке возрастания по полю Код_Контакты, а затем в пределах списка контактов, относящихся к одному человеку, по возрастанию даты контакта. На кнопке строки Код_Контакты виден значок, указывающий на то, что записи группируются по данному полю, то есть при перебаре записей таблицы Контакты для каждого нового значения поля Код_Контакты генерируется заголовок группы, в котором, как вы должны помнить из предыдущего упражнения, выводятся имя, фамилия и другие характеристики людей.

Казалось бы, можно просто изменить поле сортировки Код_Контакты на Фамилия, и записи в отчете сразу же выстроятся по алфавиту. Но в этом случае для четырех людей с одинаковой фамилией Петров будет выведен только один заголовок группы, ниже которого разместится список контактов со всеми Петровыми. Вспомните, что новый заголовок группы выводится только для каждого нового значения поля, по которому выполняется группировка. Код_Контакты — уникальный идентификатор записей таблицы Контакты, группировка по которому обеспечивает вывод в отчет всех записей этой таблицы. Для сортировки записей по алфавиту фамилий и имен следует добавить в список окна диалога Сортировка и группировка (Sorting And Grouping) соответствующие поля, разместив их выше поля группировки Код_Контакты.

  5. Щелкните в третьей строке на кнопке раскрывающегося списка Поле/выражение (Field/Expression).

  6. Выберите пункт Фамилия.

  7. В раскрывающемся списке Поле/выражение четвертой строки окна Сортировка и группировка выберите пункт Имя.

Примечание

При добавлении нового поля сортировки Access автоматически назначает ему порядок сортировки По возрастанию. Чтобы реализовать обратный порядок записей, выберите в раскрывающемся списке ячейки Порядок сортировки соответствующей строки пункт По убыванию (Descending).

  8. Щелчком на кнопке строки Фамилия выделите ее.

  9. Поместите указатель на кнопку строки Фамилия, нажмите кнопку мыши и перетащите строку на самый верх списка. Отпустите кнопку мыши в тот момент, когда жирная горизонтальная линия, показывающая будущее расположение перемещаемой строки, окажется над первой строкой таблицы.

  10. Повторяя шаги 8 и 9, разместите строку Имя между строками Фамилия и Код_Контакты, как показано на рис. 18.20.

Рис. 18.20. Добавление полей сортировки

  11. Закройте окно Сортировка и группировка.

Примечание

Заголовки тех групп, для которых нет ни одной записи в таблице Список, в отчет не выводятся.

  1. Щелкните на кнопке Вид панели инструментов, чтобы вывести отчет в режиме предварительного просмотра.

Теперь записи сначала сортируются по фамилиям, затем по именам. После этого для каждой новой записи таблицы Контакты появляется заголовок группы (так как величины поля Код_Контакты для всех записей различны). Ниже каждого такого заголовка из таблицы Список выводятся все контакты, соответствующие данному значению величины Код_Контакты, то есть данному человеку (рис. 18.21).

Рис. 18.21. Окончательный вид отчета

  13. Закройте отчет.

Вывод результатов

Несмотря на многообразие объектов баз данных, все они печатаются с помощью одних и тех же приемов. Вид печатной копии отчета или формы определяется расположением элементов управления в окне конструктора. Таблицы и запросы вообще практически не имеют параметров форматирования. Ширина и высота ячеек, а также шрифт их содержимого настраиваются непосредственно в режиме просмотра таблицы или запроса с помощью команд меню Формат (Fornrat). Перед печатью данных полезно вывести отчет в режиме предварительного просмотра, после чего можно распечатывать его на бумагу.

Упражнение 8. Предварительный просмотр

Перед выводом объекта базы данных на принтер нужно настроить параметры страницы и проверить правильность форматирования в режиме предварительного просмотра. Давайте выполним все эти действия на примере таблицы Контакты.

  1. В окне базы данных щелкните на кнопке Таблицы.

  2. Двойным щелчком на значке Контакты откройте эту таблицу в режиме редактирования данных.

  3. Увеличьте ширину столбца Адрес (Address), перетащив вправо его правую границу, чтобы адреса не обрезались по длине.

  4. Выберите команду Формат > Подтаблица > Развернуть все (Format > Subdatasheet > Expand All), чтобы отобразить записи таблицы Список.

  5. Выделите столбец Код_Контакты, щелкнув на его заголовке.

  6. С помощью команды Формат > Скрыть столбцы (Format > Hide Columns) скройте выделенный столбец. Этот служебный столбец не нужно печатать.

  7. Щелкните на заголовке столбца Ключ подчиненной таблицы.

  8. Повторным выполнением команды Формат > Скрыть столбцы уберите и этот столбец.

Примечание

Режим предварительного просмотра является основным вариантом демонстрации отчетов, поэтому он активизируется двойным щелчком на значке отчета в окне базы данных.

  9. Выберите команду Файл > Предварительный просмотр. Вы увидите предпола-гаемое > оформление бумажной копии таблицы.

Упражнение 9. Печать таблиц и запросов

Чтобы распечатать активный объект (таблицу, запрос, форму или отчет) базы данных, выполните следующие шаги.

  1. Выберите команду Файл > Параметры страницы (File > Page Setup). Откроется окно диалога, которое позволяет настроить размер страницы, ее ориентацию и поля (рис. 18.22).

  2. На вкладке Поля (Margins) увеличьте левый отступ до 40 мм. Изменение полей отразится на образце, демонстрируемом в разделе Образец (Sample).

  3. Щелкните на вкладке Страница (Page). При необходимости измените ориентацию на Альбомная (Landscape).

Ориентация и поля страницы определяют, сколько записей сможет поместиться на одном листе.

  4. Щелкните на кнопке ОК.

  5. Выберите команду Файл > Печать (File > Print). Откроется окно диалога Печать (Print).

  6. В раскрывающемся списке Имя (Name) выберите принтер. В разделе Копии (Copies) укажите необходимое число копий и щелкните на кнопке ОК.

Рис. 18.22. Параметры страницы

Упражнение 10. Файловые операции

Чтобы поддерживать базу данных в надлежащем порядке, необходимо периодически выполнять некоторые служебные процедуры. Вероятно, наиболее важной из них является резервное копирование данных, которое выполняется с помощью стандартных средств Windows для работы с файлами. Не менее существенной процедурой является сжатие базы данных. По мере обработки таблиц и добавления объектов 'файл базы данных увеличивается в объеме. При стирании части информации не происходит полного ее удаления из файла. В результате объем, занимаемый базой данных на жестком диске, может оказаться неоправданно большим.

  1. Чтобы сжать базу данных, выполните команду Сервис > Служебные программы > Сжать и восстановить базу данных (Tools > Database Utilities > Compact And Repare Database).

  2. Сравните размер файла базы данных до и после сжатия. Вы увидите, насколько эффективно сжатие экономит дисковое пространство.

Та же самая команда выполняет восстановление базы данных, поврежденной в результате внезапного сбоя электропитания. Иногда в процессе работы вы заметите, что база данных ведет себя как-то странно. В такой ситуации, не дожидаясь предупреждения, выполните команду Сжать и восстановить базу данных. Access по возможности восстановит нарушения, обнаруженные в структуре данных.

Если база данных содержит конфиденциальные сведения, воспользуйтесь возможностями Access по ограничению доступа и шифрованию данных. Чтобы задать пароль на открытие базы данных, выполните следующие шаги.

  3. Закройте базу данных.

  4. Щелкните на кнопке Открыть панели инструментов.

  5. В окне открытия файла выделите значок Контакты.mdb.

  6. Щелкните на стрелке палитры кнопки Открыть и выберите пункт Монопольно (Open Exclusive). Такой режим открытия предотвращает одновременный доступ к базе данных другого пользователя через локальную сеть.

  7. Выберите команду Сервис > Защита > Задать пароль базы данных (Tools > Security > Set Database Password).

  8. В поле Пароль (Password) открывшегося окна диалога введите пароль.

  9. Для проверки повторно введите тот же пароль в поле Подтверждение (Verify).

  10. Щелкните на кнопке ОК. Теперь для следующего открытия базы данных потребуется вводить пароль.

Примечание

Чтобы удалить пароль, выберите команду Сервис > Защита > Удалить пароль базы данных (Tools > Security > Remove Database Password), введите старый пароль и щелкните на кнопке ОК.

Еще одним полезным инструментом Access является возможность пересылки информации из базы данных в другие приложения Office XP. Например, чтобы для выполнения вычислений переслать таблицу Контакты в книгу Excel, выполните следующие операции.

  11. Щелкните на кнопке Таблицы окна базы данных.

  12. Выделите таблицу Контакты.

  13. Выберите команду Сервис > Связи с Office > Анализ в MS Excel (Tools > Office Links > Analyze It With MS Excel).

Примечание

Кроме передачи данных в Excel вы можете с помощью команды Публикация в MS Word (Publish It With MS Word) того же подменю опубликовать их в Word или, выполнив команду Слияние с MS Word (Merge It With MS Word), использовать информацию базы данных в качестве источника данных для слияний, которые обсуждались на занятии 8.

Access автоматически запустит Excel XP, создаст новую книгу с одним листом и перешлет в его ячейки данные из таблицы Контакты.

Контрольное упражнение

Чтобы закрепить приемы работы с формами и отчетами, выполните самостоятельно следующие операции.

  1. Для создания нового отчета запустите мастер отчетов.

  2. Включите в отчет поля даты и описание контакта, а также фамилию и имя.

  3. Выберите вариант просмотра по таблице Список.

  4. Настройте группировку записей по дате.

    • Как с помощью мастера отчетов сгруппировать записи по дате ?

  5. Выберите стиль отчета Блок (Block).

  6. В четвертом окне мастера задайте сортировку по фамилиям и именам в обратном алфавитном порядке.

    • Как назначить обратную алфавитному порядку сортировку по двум полям?

  7. Назовите новый отчет Контакты по датам.

  8. Переключитесь в режим конструктора отчетов.

  9. Уберите рамку всех полей.

    • Как быстро убрать рамку всех элементов управления?

  10. Перенесите первое поле даты (которое начинается с функции =Format) из раздела Область данных в раздел Заголовок группы Дата.

  11. Увеличьте ширину поля Дата, чтобы в него помещалась дата в длинном формате. При необходимости переместите другие поля.

  12. Замените текст заголовков полей на корректные русские подписи.

  13. Распечатайте полученный отчет.

Подведение итогов

Это занятие завершает серию упражнений, посвященных изучению баз данных Access. Теперь вы умеете с помощью мастеров строить формы и отчеты, обеспечивающие форматированный вывод записей таблиц базы данных на экран и на печать. Вы познакомились с конструкторами форм и отчетов, позволяющими изменять любые параметры этих объектов Access, и научились распечатывать информацию из базы данных [ Если вы собираетесь постоянно работать с Access, лучшим помощником в повседневной работе будет книга Б. Карпова «Microsoft Acccess 2002: справочник» («Питер», 2001). ].

Три следующих занятия посвящены приложению Outlook ХР — клиенту электронной почты и всемогущему планировщику вашей работы.


Занятие №18

Формы и отчеты

ТЕМА ЗАНЯТИЯ

Информация баз данных хранится в таблицах, но с ними не очень удобно работать. Для ввода, редактирования и печати информации предназначаются формы и отчеты. Вы познакомитесь с ними на этом занятии, в упражнениях которого рассматриваются следующие темы:

  • мастер форм;

  • конструктор форм;

  • элементы управления;

  • заголовок и примечание формы;

  • мастер отчетов;

  • конструктор отчетов;

  • группировка и сортировка;

  • печать данных.


Форма

В то время как таблицы и запросы позволяют отобразить на экране длинные списки записей, формы дают возможность сосредоточиться на конкретной записи. Они облегчают ввод, редактирование и восприятие информации, могут содержать вспомогательные подписи и элементы оформления.


Упражнение 1. Мастер форм

Мастер форм позволяет сберечь время и быстро сконструировать привлекательную форму для записей любой таблицы.

  1. С помощью команды Файл > Открыть (File > Open) откройте базу данных Контакты, созданную на предыдущем занятии.

  2. В окне базы данных щелкните на кнопке Формы (Forms).

  3. В списке форм дважды щелкните на значке Создание формы с помощью мастера (Create Form By Using Wizard).

  4. В списке Таблицы/запросы первого окна мастера, показанного на рис. 18.1, выберите пункт Таблица: Контакты.

Рис. 18.1. Мастер форм

  5. Щелкните на кнопке », чтобы добавить в список Выбранные поля все поля таблицы.

  6. Выделите пункт Код_Контакты и щелчком на кнопке < уберите это поле обратно в левый список. Содержимое поля Код_Контакты генерируется автоматически, а его значение несущественно для пользователя, поэтому не следует включать это поле в форму.

  7. Щелкните на кнопке Далее.

  8. В следующем окне диалога выберите для формы стиль Выровненный (Justified) и щелкните на кнопке Далее.

  9. В списке третьего окна выберите вариант оформления Камень (Stone) или любой другой понравившийся вам стиль и снова щелкните на кнопке Далее.

  10. В последнем окне мастера щелкните на кнопке Готово, не изменяя никаких параметров. Мастер сгенерирует форму и откроет ее в режиме просмотра данных.

Окно формы содержит названия и области отображения для всех полей таблицы, выбранных в первом окне мастера. В нижней части формы расположены кнопки перемещения по записям, аналогичные кнопкам окна таблицы.

  11. Щелкните несколько раз на кнопке Следующая запись, чтобы добраться до информации о Василии Петрове. В этой записи отсутствуют адрес, название фирмы и телефон.

  12. Щелкните на поле ниже подписи Адрес и введите адрес Василия Петрова.

  13. Аналогичным способом добавьте название компании и телефон (рис. 18.2).

Рис. 18.2. Форма для таблицы Контакты

  14. Щелкните на кнопке Новая запись (New Record) и добавьте информацию еще об одном человеке. Как видите, форма позволяет просматривать и редактировать любую запись, а также добавлять записи.


Упражнение 2. Конструктор форм

Недостатком форм, создаваемых мастером, является то, что они однообразны и не содержат пояснительных надписей. Чтобы приукрасить форму и расположить поля более удобным образом, следует воспользоваться конструктором форм, который позволяет передвигать и масштабировать элементы формы, связывать их с источником данных и настраивать любые другие параметры формы. Давайте создадим с помощью конструктора форму для таблицы Список.

  1. В окне базы данных дважды щелкните на значке Создать форму в режиме конструктора (Create Form In Design View). В окне конструктора присутствуют пустая форма с разметочной сеткой, вертикальная и горизонтальная линейки, помогающие позиционировать объекты (рис. 18.3). Неотъемлемым атрибутом конструктора форм является пацель инструментов Панель элементов (Toolbox), помогающая добавлять элементы формы. Новую форму необходимо связать с источником данных — таблицей Список.

Рис. 18.3. Конструктор форм

  2. Щелкните в пустой области конструктора и выберите в контекстном меню команду Свойства (Properties).

  3. На вкладке Данные (Data) окна диалога свойств формы (рис. 18.4) щелкните на стрелке поля Источник записей (Record Source).

Примечание

Любой элемент формы имеет контекстное меню, в котором есть команда Свойства. Выбор такой команды открывает окно свойств, подобное окну свойств формы. Вкладка Макет (Format) содержит параметры форматирования объекта. Вкладка Данные — описание источника данных, различные ограничения и условия, накладываемые на данные поля. Вкладка События (Event) позволяет писать функции отклика на различные события (например, перемещение мыши на объект). Параметры, не вошедшие в первые три группы, размещаются на вкладке Другие (Other). Вкладка Все (АН) обеспечивает одновременный доступ ко всем параметрам.

  4. Выберите в раскрывшемся списке пункт Список.

  5. Закройте окно свойств. В конструкторе форм появится небольшое окно со списком полей источника записей (таблицы Список). Это окно помогает добавлять элементы управления формы. Его можно скрывать или выводить на экран с помощью кнопки Список полей (Field List). Сейчас нужно добавить в форму три области ввода для трех полей таблицы.

  6. Поместите указатель на пункт Дата окна Список, нажмите кнопку мыши и перетащите этот пункт в область формы. Access создаст элемент управления типа поле, а также подпись.

Рис. 18.4. Окно свойств формы

  7. Проделайте аналогичную операцию для пунктов Описание и Код_Контакты, расположив поля примерно так, как показано на рис. 18.5. Любой объект формы можно выделить щелчком мыши, при этом вокруг него появляется габаритная рамка с боковыми и угловыми маркерами масштабирования объекта. В левом верхнем углу объекта появляется большой квадрат, за который можно перетаскивать объект в пределах формы.

  8. Щелчком выделите подпись Описание. Затем еще раз щелкните на ней, чтобы перейти в режим редактирования. Замените имеющийся текст на Описание контакта.

  9. Захватите правый боковой маркер поля Описание мышью и растяните рамку поля до правого края формы.

Рис. 18.5. Добавление полей

Рис. 18.6. Готовая форма

  10. При необходимости, ухватившись за маркер перемещения мышью, подвигайте поле Описание.

  11. Повторите процедуры шагов 8-10 для всех трех полей. Разместите их и настройте подписи в соответствии с рис. 18.6.

  12. Чтобы привести оформление новой формы в соответствие с форматом формы, созданной в предыдущем упражнении, щелкните на кнопке Автоформат (AutoFormat) панели инструментов.

  13. Выберите в списке открывшегося окна диалога пункт Камень и щелкните на кнопке ОК. Access приведет фон формы, оформление, цвет и шрифт полей в соответствие с выбранным шаблоном.

  14. Щелчком на кнопке Вид перейдите в режим редактирования данных.

В форму будет выведено содержимое первой записи таблицы Список. Обратите внимание, что поле с подписью Фамилия имеет такой же список подстановки, который был настроен для поля Код_Контакты таблицы Список на предыдущем занятии. Структура списка подстановки была перенесена в форму в процессе перетаскивания поля на шаге 7.

  15. Закройте окно формы.

  16. В появившемся окне диалога введите в качестве имени новой формы слово С п и с о к и щелкните на кнопке О К.

Теперь форма Список появится на вкладке Формы (Forms) окна базы данных.

Примечание

Чтобы одновременно переместить поле вместе с его подписью, тащите объект за тело подписи (но не за маркер перемещения).


Упражнение 3. Элементы управления

При открытии конструктора форм на экране появляется панель элементов (см. рис. 18.3). Если ее нет, щелкните на кнопке Панель элементов панели инструментов. С помощью кнопок панели элементов в форму можно добавлять различные объекты, типы которых перечислены в табл. 18.1. Элементы управления форм и отчетов сходны между собой, поэтому такая же панель элементов имеется и в конструкторе отчетов, о котором мы поговорим на этом занятии позже, а все операции, рассматриваемые в этом и в следующем упражнении, одинаково применимы как к формам, так и к отчетам.

Примечание

В предыдущем упражнении в форму было добавлено шесть элементов управления: два поля ввода (Дата и Описание), одно поле со списком Код_Контакты и три надписи, по одной рядом с каждым полем.

ТАБЛИЦА 18.1. Элементы управления форм и отчетов
Значок | Название | Назначение
 | Надпись (Label) | Надписи создаются автоматически вместе с элементами типа текстовое поле, поле со списком и т. п. Они разъясняют смысл поля ввода. Дополнительные надписи могут использоваться для заголовков и пояснений
 | Поле (Text Box) | Используется для ввода и отображения информации полей таблиц и запросов, а также для вывода результатов вычислений
 | Группа переключателей (Option Group) | Группа переключателей ссылается на некоторое поле таблицы. Каждый переключатель группы соответствует определенному целочисленному значению этого поля
 | Выключатель (Toggle Button) | Позволяет вводить информацию типа да/нет. Величине «да» или «истина» соответствует утопленное положение выключателя
 | Переключатель (Option Button) | Элемент группы переключателей, в которой может быть отмечен только один из них (его кружок выглядит зачерненным)
 | Флажок (Check Box) | Предназначен для представления полей типа да/нет. Отмеченный квадратик соответствует величине «да», а пустой — «нет»
 | Поле со списком (Combo Box) | Разрешает как непосредственный ввод значения в поле, так и его выбор в раскрывающемся списке предопределенных значений
 | Список (List Box) | Позволяет выбирать данные из набора пунктов и не разрешает непосредственный ввод значений
 | Кнопка (Command Button) | Щелчок на такой кнопке выполняет команду, с помощью которой можно перейти в другую форму, переместиться по записям и выполнить многие другие операции

Рисунок | Рисунок любого графического формата с рамкой
Свободная рамка объекта (Unbound Object Frame) | Объект OLE, не связанный ни с каким источником данных
Присоединенная рамка объекта (Bound Object Frame) | Объект OLE, связанный с полем данных таблицы или запроса
Разрыв страницы (Page Break) | Линия, по которой формируется перевод страницы при выводе формы или отчета на принтер
Набор вкладок (Tab Control) | Позволяет разместить на одном и том же пространстве экрана несколько наборов элементов управления. Удобен в тех случаях, когда элементы легко разделяются на логические группы
Подчиненная форма/отчет (Subform/Subreport) | Вставляет в форму (или отчет) область с другой формой (или отчетом), связанной с главной
Линия (Line) | Добавляет прямую линию
Я Прямоугольник (Rectangle) | Рисует прозрачный или непрозрачный прямоугольник с цветной границей любой толщины
Другие элементы (More Controls) | Открывает меню с элементами управления, не вошедшими в панель элементов

Чтобы с помощью панели элементов добавить в форму декоративные объекты, выполните следующие шаги.

  1. Поместите указатель мыши на угол области формы.

  2. Перетащите этот угол вправо вниз, чтобы немного увеличить форму.

  3. С помощью команды Правка > Выделить все (Edit > Select All) выделите все элементы формы.

  4. Нажмите клавишу Ctrl и, не отпуская ее, нажатиями клавиш со стрелками передвиньте элементы формы так, чтобы они были отцентрированы относительно новых границ формы.

  5. Щелкните на кнопке Прямоугольник (Rectangle) панели элементов.

  6. Растяните мышью диагональ прямоугольника, чтобы он окружил все элементы формы (рис. 18.7).

  7. В палитре кнопки 11вет линии/границы (Line/Border Color) панели инструментов Форматирование (Formatting) выберите синий цвет.

Рис. 18.7. Добавление элементов формы

  8. В палитре кнопки Толщина линии/границы (Line/Border Width) выберите толщину 4 пиксела.

  9. Щелкните на кнопке Рисунок (Image) панели элементов.

  10. В левом нижнем углу формы растяните рамку рисунка.

Рис. 18.8. Параметры рисунка

  11. В открывшемся окне выбора файла найдите папку, в которую был установлен Office XP (обычно она называется Microsoft Office), раскройте вложенную в нее папку Office10\Broadcast, выберите файл NS_logo.gif и щелкните на кнопке ОК. (Вместо этого файла можете вставить любой другой не слишком большой рисунок.)

По умолчанию рисунки вставляются в форму в режиме урезания рисунка рамкой элемента. Чтобы изменить режим размещения, выполните следующие действия.

  12. Щелкните на рисунке правой кнопкой мыши и выберите в контекстном меню команду Свойства.

  13. В списке Установка размеров (Size Mode) вкладки Макет открывшегося окна параметров выберите пункт Вписать в рамку (Stretch), как показано на рис. 18.8. Теперь рисунок будет растягиваться и сжиматься вместе с рамкой элемента, подстраиваясь под ее размеры.

  14. Закройте окно параметров.


Упражнение 4. Заголовок и примечание

До сих пор вы имели дело с формами, в которых одновременно отображалась только одна запись. Однако параметры формы можно настроить так, чтобы в ее окне демонстрировался длинный список одинаковых форм, содержащих данные разных записей таблицы. Чтобы включить этот режим, выполните следующие действия.

  1. В конструкторе формы Список щелкните на свободном пространстве правой кнопкой мыши.

  2. Выберите в контекстном меню команду Свойства, чтобы открыть окно свойств формы, показанное на рис. 18.9.

Рис. 18.9. Параметры форматирования формы

  3. В списке Режим по умолчанию (Default View) вкладки Макет выберите пункт Ленточная форма (Continuous Forms).

  4. Закройте окно параметров.

В подобных ленточных формах для размещения заголовков и пояснительных надписей удобно пользоваться дополнительными разделами — заголовком и примечанием формы, которые остаются на месте при прокручивании ленточной формы. Чтобы добавить эти разделы, сделайте следующее.

  5. Выберите команду Вид > Заголовок/примечание формы (View > Form Header/Footer), в окне конструктора формы появятся дополнительные области, показанные на рис. 18.10.

  6. Щелкните на кнопке Надпись (Label) панели элементов.

  7. Растяните мышью прямоугольник в разделе Заголовок формы (Form Header).

  8. Введите текст Список контактов.

  9. Нажмите клавишу Esc, чтобы выйти из режима редактирования текста, но оставить надпись выделенной.

  10. В списке Размер (Font Size) панели инструментов Форматирование выберите число 22.

  11. Щелкните на кнопке По центру (Center).

  12. Поместите указатель на верхний край полосы Область данных (Detail) и, нажав кнопку мыши, перетащите ее вверх, уменьшив область заголовка до необходимых размеров.

Рис. 18.10. Добавление заголовка и примечания

Рис. 18.11. Ленточная форма

  13. Повторив шаги 6-8, введите в примечание формы текст Если при добавлении контакта вы не нашли нужного человека в списке Фамилии, с помощью формы Контакты добавьте информацию об этом человеке в новую запись таблицы Контакты.

  14. Перетащите нижний край формы вверх, уменьшив ее по высоте.

  15. Щелкните на кнопке Вид.

Теперь в окне формы может разместиться сразу две записи, как показано на рис. 18.11. Такую форму можно листать с помощью полосы прокрутки. Заголовок и примечание формы отображаются в верхней и нижней частях окна, не смещаясь при прокручивании записей.


Отчет

В целом отчеты похожи на формы, но они, как правило, предназначаются для вывода информации из базы данных на принтер. Поэтому в отчетах данные форматируют так, чтобы их было удобно размещать на отдельных страницах. Отчеты поддерживают самые разнообразные способы оформления и позволяют группировать данные, разбивая их на логически цельные блоки.


Упражнение 5. Мастер отчетов

Чтобы облегчить работу пользователя, в Access имеется специальный мастер, который при недостатке времени позволяет быстро создавать довольно привлекательные отчеты. Давайте поручим мастеру построение отчета о контактах с разными людьми.

  1. В окне базы данных щелкните на кнопке Отчеты (Reports).

  2. Дважды щелкните на значке Создание отчета с помощью мастера (Create Report By Using Wizard).

В отчет нужно добавить как информацию о людях, так и данные о контактах с ними. Для этого следует сгруппировать вместе все контакты с одним человеком и распечатать их список ниже области с данными об этом человеке. Затем нужно вывести информацию о следующем человеке и список контактов с ним и т. д. Такой порядок печати записей позволит быстро найти полный список контактов с любым из ваших коллег. В первом окне мастера, показанном на рис. 18.12, нужно указать все поля, включаемые в отчет.

Рис. 18.12. Выбор полей для отчета

  3. В раскрывающемся списке Таблицы и запросы первого окна мастера отчета выберите таблицу Контакты.

  4. В списке Доступные поля выделите поле Фамилия.

  5. Щелчком на кнопке > переместите выбранное поле в список Выбранные поля.

  6. Повторяя шаги 4 и 5, добавьте в список Выбранные поля поля Имя, Адрес, Название Компании, Рабочий Телефон.

Примечание

Поле Код_Контакты содержит служебную информацию, обеспечивая связь записей двух таблиц. Не помещайте такие поля в отчет никогда, кроме случаев отладки взаимосвязей таблиц базы данных.

  7. Выберите в списке Таблицы и запросы таблицу Список.

  8. Переместите в список Выбранные поля поля Дата и Описание, добавив их к по лям таблицы Контакты.

9. Щелкните на кнопке Далее.

Во втором окне мастера можно выбрать способ расположения данных — упорядоченные по записям таблицы Контакты, а затем уже по записям таблицы Список, или наоборот. Схема группировки отображается в правой части окна диалога.

Рис. 18.13. Пятое окно мастера отчетов

  10. Оставьте вариант Контакты (By Контакты) и щелкните на кнопке Далее.

  11. В следующем окне не назначайте дополнительной группировки. Просто щелк ните на кнопке Далее.

  12. Четвертое окно мастера отчета позволяет задать порядок сортировки записей. Выберите в списке 1 пункт Дата и щелкните на кнопке Далее.

Следующее окно, показанное на рис. 18.13, позволяет выбрать способ расположения полей и ориентацию страницы.

Рис. 18.14. Фрагмент отчета, сгенерированного мастером

  13. Выберите положение переключателя Структура 1 (Outline 1).

  14. Затем щелкните на кнопке Далее.

  15. В следующем окне мастера выберите вариант оформления Строгий (Corporate) и щелкните на кнопке Далее.

  16. Введите в качестве заголовка текст Список контактов и щелкните на кнопке Готово.

Мастер сформирует отчет и откроет его в отдельном окне в режиме предварительного просмотра (рис. 18.14). В нем видно, что сначала идет фамилия первого человека, информация о нем и список контактов с ним, затем располагаются те же данные, касающиеся второго человека, и т. д. В целом отчет выглядит неплохо и может устроить нетребовательного пользователя.


Упражнение 6. Конструктор отчетов

Если внимательно присмотреться к отчету, показанному на рис. 18.14, можно заметить несколько недостатков. Вот их список:

  • названия таких полей, как Фамилия и Имя, явно лишние, их следует убрать;

  • информация о человеке занимает слишком много места, ее можно представить компактнее;

  • некоторые подписи следует заменить более понятными;

  • поле Дата слишком коротко, оно не вмещает дату в длинном формате. Давайте исправим указанные недочеты в конструкторе отчетов.

  1. Чтобы переключиться в режим конструктора, выберите команду Вид > Конструктор.

Рис. 18.15. Конструктор отчетов

В схеме отчета (рис. 18.15) присутствует несколько разделов. Их назначение указано в табл. 18.2. Поля и подписи можно размещать в любом разделе отчета, регулируя этим их положение на странице.

  2. Щелчком выделите надпись Фамилия.

  3. Нажатием клавиши Delete удалите надпись.

ТАБЛИЦА 18.2 . Разделы отчета
Раздел | Назначение
Заголовок отчета (Report Header) | Печатается в самом начале отчета один раз. Выводится и скрывается командой Вид > Заголовок/примечание отчета (View > Report Header/Footer)
Верхний колонтитул (Page Header) | Печатается в верхнем поле каждой страницы. Выводится и скрывается командой Вид > Колонтитулы (View > Page Header/Footer)
Заголовок группы КолКонтакты (КонтактыЮ Header) | Появляется в начале каждой группы записей, соответствующих очередному значению поля КодКонтакты (то есть того поля, по которому назначена группировка)
Область данных (Detail) | Основные данные отчета
Нижний колонтитул (Page Footer) | Печатается в нижнем поле каждой страницы. Выводится и скрывается командой Вид > Колонтитулы (View > Page Header/Footer)
Примечание отчета (Report Footer) | Печатается в самом конце отчета. Выводится и скрывается командой Вид > Заголовок/приме чание отчета (View > Report Header/Footer)

  4. Повторяя шаги 2 и 3, удалите из раздела Заголовок группы Код_Контакты надписи Имя, Дата и Описание. Назначение соответствующих полей очевидно и не нуждается в пояснении.

  5. Щелкните на горизонтальной линии, расположенной ниже поля Назвакие Компании, правой кнопкой мыши и выберите команду Вырезать (Cut).

  6. Аналогичным приемом удалите три оставшиеся линии раздела Заголовок группы Код_Контакты. Нет смысла выводить подписи полей адреса, названия компании и телефона в заголовке каждой группы. Достаточно будет поместить соответствующие надписи в верхний колонтитул страницы.

  7. Поместите указатель мыши между заголовками разделов Верхний колонтитул и Заголовок группы Код_Контакты, чтобы его значок превратился в двунаправленную стрелку. Нажмите кнопку мыши и перетащите заголовок группы вниз, освобождая место для верхнего колонтитула.

  8. Щелчком выделите надпись Адрес. Нажмите клавиши Ctrl+X, чтобы вырезать ее.

  9. Щелкните на заголовке раздела Верхний колонтитул и нажмите клавиши Ctrl+V, чтобы вставить вырезанную надпись в верхний колонтитул.

  10. Выделяя надписи колонтитула и перетаскивая их мышью за маркер верхнего левого угла либо передвигая нажатием клавиши Ctrl и клавиш со стрелками, разместите их так, как показано на рис. 18.16.

Рис. 18.16. Перемещение надписей между разделами

  11. Щелкните на надписи Адрес. Повторным щелчком на ней включите режим редактирования и замените текст на Почтовый адрес.

  12. Описанным выше приемом измените текст подписей НазваниеКомпании и РабочийТелефон соответственно на Компания и Телефон.

  13. Переставьте поля раздела Заголовок группы Код_Контакты, разместив их в две строки. Фамилия и имя — в первой строке, а остальные три поля — во второй.

  14. Щелкните правой кнопкой мыши на жирной линии, расположенной в разделе Заголовок отчета. Выберите в контекстном меню команду Копировать (Copy).

  15. Щелкните на заголовке раздела Заголовок группы Код_Контакты и нажмите клавиши Ctrl+V, чтобы вставить в этот раздел дубликат линии.

  16. Нажимая клавиши Ctrl+V, переместите линию вниз, под вторую строку полей данных.

  17. Снова нажмите Ctrl+V, добавив вторую линию вдоль верхнего края раздела.

  18. Перетащите заголовок раздела Область данных вверх, убрав излишнее пустое пространство.

  19. Щелчком выделите поле Дата. Увеличьте его горизонтальный размер, перетащив вправо серединный маркер правой границы поля.

Рис. 18.17. Модифицированная структура отчета

  20. Растяните поле Описание вправо до границы отчета. Окончательный вид новой структуры отчета показан на рис. 18.17.

  21. С помощью команды Вид > Предварительный просмотр (View > Print Preview) переключите отчет в режим вывода данных. В новом варианте, показанном на рис. 18.18, информация размещается намного компактнее.

  22. Закройте отчет. При появлении запроса о необходимости сохранения новой структуры отчета щелкните на кнопке Да.

Примечание

В нижней части страницы отчета выводятся текущая дата и номер страницы. Эта информация генерируется элементами управления, размещенными в разделе Нижний колонтитул конструктора отчета.

Рис. 18.18. Просмотр нового варианта отчета


Упражнение 7. Группировка и сортировка

Отчет, который вы сконструировали в двух предыдущих упражнениях, имеет еще один существенный недостаток. Фамилии людей из списка Контакты выводятся не по алфавиту. Мастер отчетов автоматически сгруппировал данные таблицы Список по их принадлежности к тем или иным записям таблицы Контакты, которая определяется связью между полями Код_Контакты этих двух таблиц. По указанной причине фамилии в отчете упорядочены по возрастанию числового параметра Код_Контакты — идентификатора записей таблицы Контакты. Это неудобно, в отчетах с большим числом записей при такой сортировке будет довольно трудно отыскать нужного человека. Есть смысл изменить порядок сортировки, для этого выполните следующие шаги.

  1. Щелкните на кнопке Отчеты окна базы данных.

  2. Выделите значок отчета Список контактов.

  3. Щелчком на кнопке Конструктор панели инструментов окна базы данных от- кройте отчет в режиме конструктора.

  4. Щелкните на кнопке Сортировка и группировка (Sorting And Grouping) панели инструментов, чтобы открыть окно диалога, показанное на рис. 18.19.

Рис. 18.19. Сортировка и группировка

В этом окне назначены два уровня сортировки. Сначала в порядке возрастания по полю Код_Контакты, а затем в пределах списка контактов, относящихся к одному человеку, по возрастанию даты контакта. На кнопке строки Код_Контакты виден значок, указывающий на то, что записи группируются по данному полю, то есть при перебаре записей таблицы Контакты для каждого нового значения поля Код_Контакты генерируется заголовок группы, в котором, как вы должны помнить из предыдущего упражнения, выводятся имя, фамилия и другие характеристики людей.

Казалось бы, можно просто изменить поле сортировки Код_Контакты на Фамилия, и записи в отчете сразу же выстроятся по алфавиту. Но в этом случае для четырех людей с одинаковой фамилией Петров будет выведен только один заголовок группы, ниже которого разместится список контактов со всеми Петровыми. Вспомните, что новый заголовок группы выводится только для каждого нового значения поля, по которому выполняется группировка. Код_Контакты — уникальный идентификатор записей таблицы Контакты, группировка по которому обеспечивает вывод в отчет всех записей этой таблицы. Для сортировки записей по алфавиту фамилий и имен следует добавить в список окна диалога Сортировка и группировка (Sorting And Grouping) соответствующие поля, разместив их выше поля группировки Код_Контакты.

  5. Щелкните в третьей строке на кнопке раскрывающегося списка Поле/выражение (Field/Expression).

  6. Выберите пункт Фамилия.

  7. В раскрывающемся списке Поле/выражение четвертой строки окна Сортировка и группировка выберите пункт Имя.

Примечание

При добавлении нового поля сортировки Access автоматически назначает ему порядок сортировки По возрастанию. Чтобы реализовать обратный порядок записей, выберите в раскрывающемся списке ячейки Порядок сортировки соответствующей строки пункт По убыванию (Descending).

  8. Щелчком на кнопке строки Фамилия выделите ее.

  9. Поместите указатель на кнопку строки Фамилия, нажмите кнопку мыши и перетащите строку на самый верх списка. Отпустите кнопку мыши в тот момент, когда жирная горизонтальная линия, показывающая будущее расположение перемещаемой строки, окажется над первой строкой таблицы.

  10. Повторяя шаги 8 и 9, разместите строку Имя между строками Фамилия и Код_Контакты, как показано на рис. 18.20.

Рис. 18.20. Добавление полей сортировки

  11. Закройте окно Сортировка и группировка.

Примечание

Заголовки тех групп, для которых нет ни одной записи в таблице Список, в отчет не выводятся.

  1. Щелкните на кнопке Вид панели инструментов, чтобы вывести отчет в режиме предварительного просмотра.

Теперь записи сначала сортируются по фамилиям, затем по именам. После этого для каждой новой записи таблицы Контакты появляется заголовок группы (так как величины поля Код_Контакты для всех записей различны). Ниже каждого такого заголовка из таблицы Список выводятся все контакты, соответствующие данному значению величины Код_Контакты, то есть данному человеку (рис. 18.21).

Рис. 18.21. Окончательный вид отчета

  13. Закройте отчет.


Вывод результатов

Несмотря на многообразие объектов баз данных, все они печатаются с помощью одних и тех же приемов. Вид печатной копии отчета или формы определяется расположением элементов управления в окне конструктора. Таблицы и запросы вообще практически не имеют параметров форматирования. Ширина и высота ячеек, а также шрифт их содержимого настраиваются непосредственно в режиме просмотра таблицы или запроса с помощью команд меню Формат (Fornrat). Перед печатью данных полезно вывести отчет в режиме предварительного просмотра, после чего можно распечатывать его на бумагу.


Упражнение 8. Предварительный просмотр

Перед выводом объекта базы данных на принтер нужно настроить параметры страницы и проверить правильность форматирования в режиме предварительного просмотра. Давайте выполним все эти действия на примере таблицы Контакты.

  1. В окне базы данных щелкните на кнопке Таблицы.

  2. Двойным щелчком на значке Контакты откройте эту таблицу в режиме редактирования данных.

  3. Увеличьте ширину столбца Адрес (Address), перетащив вправо его правую границу, чтобы адреса не обрезались по длине.

  4. Выберите команду Формат > Подтаблица > Развернуть все (Format > Subdatasheet > Expand All), чтобы отобразить записи таблицы Список.

  5. Выделите столбец Код_Контакты, щелкнув на его заголовке.

  6. С помощью команды Формат > Скрыть столбцы (Format > Hide Columns) скройте выделенный столбец. Этот служебный столбец не нужно печатать.

  7. Щелкните на заголовке столбца Ключ подчиненной таблицы.

  8. Повторным выполнением команды Формат > Скрыть столбцы уберите и этот столбец.

Примечание

Режим предварительного просмотра является основным вариантом демонстрации отчетов, поэтому он активизируется двойным щелчком на значке отчета в окне базы данных.

  9. Выберите команду Файл > Предварительный просмотр. Вы увидите предпола-гаемое > оформление бумажной копии таблицы.


Упражнение 9. Печать таблиц и запросов

Чтобы распечатать активный объект (таблицу, запрос, форму или отчет) базы данных, выполните следующие шаги.

  1. Выберите команду Файл > Параметры страницы (File > Page Setup). Откроется окно диалога, которое позволяет настроить размер страницы, ее ориентацию и поля (рис. 18.22).

  2. На вкладке Поля (Margins) увеличьте левый отступ до 40 мм. Изменение полей отразится на образце, демонстрируемом в разделе Образец (Sample).

  3. Щелкните на вкладке Страница (Page). При необходимости измените ориентацию на Альбомная (Landscape).

Ориентация и поля страницы определяют, сколько записей сможет поместиться на одном листе.

  4. Щелкните на кнопке ОК.

  5. Выберите команду Файл > Печать (File > Print). Откроется окно диалога Печать (Print).

  6. В раскрывающемся списке Имя (Name) выберите принтер. В разделе Копии (Copies) укажите необходимое число копий и щелкните на кнопке ОК.

Рис. 18.22. Параметры страницы


Упражнение 10. Файловые операции

Чтобы поддерживать базу данных в надлежащем порядке, необходимо периодически выполнять некоторые служебные процедуры. Вероятно, наиболее важной из них является резервное копирование данных, которое выполняется с помощью стандартных средств Windows для работы с файлами. Не менее существенной процедурой является сжатие базы данных. По мере обработки таблиц и добавления объектов 'файл базы данных увеличивается в объеме. При стирании части информации не происходит полного ее удаления из файла. В результате объем, занимаемый базой данных на жестком диске, может оказаться неоправданно большим.

  1. Чтобы сжать базу данных, выполните команду Сервис > Служебные программы > Сжать и восстановить базу данных (Tools > Database Utilities > Compact And Repare Database).

  2. Сравните размер файла базы данных до и после сжатия. Вы увидите, насколько эффективно сжатие экономит дисковое пространство.

Та же самая команда выполняет восстановление базы данных, поврежденной в результате внезапного сбоя электропитания. Иногда в процессе работы вы заметите, что база данных ведет себя как-то странно. В такой ситуации, не дожидаясь предупреждения, выполните команду Сжать и восстановить базу данных. Access по возможности восстановит нарушения, обнаруженные в структуре данных.

Если база данных содержит конфиденциальные сведения, воспользуйтесь возможностями Access по ограничению доступа и шифрованию данных. Чтобы задать пароль на открытие базы данных, выполните следующие шаги.

  3. Закройте базу данных.

  4. Щелкните на кнопке Открыть панели инструментов.

  5. В окне открытия файла выделите значок Контакты.mdb.

  6. Щелкните на стрелке палитры кнопки Открыть и выберите пункт Монопольно (Open Exclusive). Такой режим открытия предотвращает одновременный доступ к базе данных другого пользователя через локальную сеть.

  7. Выберите команду Сервис > Защита > Задать пароль базы данных (Tools > Security > Set Database Password).

  8. В поле Пароль (Password) открывшегося окна диалога введите пароль.

  9. Для проверки повторно введите тот же пароль в поле Подтверждение (Verify).

  10. Щелкните на кнопке ОК. Теперь для следующего открытия базы данных потребуется вводить пароль.

Примечание

Чтобы удалить пароль, выберите команду Сервис > Защита > Удалить пароль базы данных (Tools > Security > Remove Database Password), введите старый пароль и щелкните на кнопке ОК.

Еще одним полезным инструментом Access является возможность пересылки информации из базы данных в другие приложения Office XP. Например, чтобы для выполнения вычислений переслать таблицу Контакты в книгу Excel, выполните следующие операции.

  11. Щелкните на кнопке Таблицы окна базы данных.

  12. Выделите таблицу Контакты.

  13. Выберите команду Сервис > Связи с Office > Анализ в MS Excel (Tools > Office Links > Analyze It With MS Excel).

Примечание

Кроме передачи данных в Excel вы можете с помощью команды Публикация в MS Word (Publish It With MS Word) того же подменю опубликовать их в Word или, выполнив команду Слияние с MS Word (Merge It With MS Word), использовать информацию базы данных в качестве источника данных для слияний, которые обсуждались на занятии 8.

Access автоматически запустит Excel XP, создаст новую книгу с одним листом и перешлет в его ячейки данные из таблицы Контакты.


Контрольное упражнение

Чтобы закрепить приемы работы с формами и отчетами, выполните самостоятельно следующие операции.

  1. Для создания нового отчета запустите мастер отчетов.

  2. Включите в отчет поля даты и описание контакта, а также фамилию и имя.

  3. Выберите вариант просмотра по таблице Список.

  4. Настройте группировку записей по дате.

    • Как с помощью мастера отчетов сгруппировать записи по дате ?

  5. Выберите стиль отчета Блок (Block).

  6. В четвертом окне мастера задайте сортировку по фамилиям и именам в обратном алфавитном порядке.

    • Как назначить обратную алфавитному порядку сортировку по двум полям?

  7. Назовите новый отчет Контакты по датам.

  8. Переключитесь в режим конструктора отчетов.

  9. Уберите рамку всех полей.

    • Как быстро убрать рамку всех элементов управления?

  10. Перенесите первое поле даты (которое начинается с функции =Format) из раздела Область данных в раздел Заголовок группы Дата.

  11. Увеличьте ширину поля Дата, чтобы в него помещалась дата в длинном формате. При необходимости переместите другие поля.

  12. Замените текст заголовков полей на корректные русские подписи.

  13. Распечатайте полученный отчет.


Подведение итогов

Это занятие завершает серию упражнений, посвященных изучению баз данных Access. Теперь вы умеете с помощью мастеров строить формы и отчеты, обеспечивающие форматированный вывод записей таблиц базы данных на экран и на печать. Вы познакомились с конструкторами форм и отчетов, позволяющими изменять любые параметры этих объектов Access, и научились распечатывать информацию из базы данных [ Если вы собираетесь постоянно работать с Access, лучшим помощником в повседневной работе будет книга Б. Карпова «Microsoft Acccess 2002: справочник» («Питер», 2001). ].

Три следующих занятия посвящены приложению Outlook ХР — клиенту электронной почты и всемогущему планировщику вашей работы.


Занятие №19

ЧАСТЬ VI

Outlook

Microsoft Outlook XP — отличный организатор вашей деловой жизни. Это приложение может служить электронным аналогом записной книжки, обрабатывать сообщения электронной почты, хранить списки контактов и задач, вести дневник событий.

Организатор событий и задач

ТЕМА ЗАНЯТИЯ

Outlook управляет документами компьютера и сообщениями электронной почты, хранит список контактов с другими людьми и компаниями, напоминает о назначенных встречах и совещаниях. На этом занятии вы познакомитесь с основными инструментами интерфейса Outlook и научитесь выполнять следующие операции:

  • добавлять ярлыки Outlook;

  • просматривать дневник событий;

  • искать документы Outlook;

  • добавлять события в календарь;

  • назначать совещания;

  • обновлять список задач.

Бели ваш стол завален записками, вы периодически не можете найти нужный адрес, забываете о назначенных совещаниях и не можете разобраться в море документов, переполняющих жесткий диск компьютера, попробуйте обратиться за помощью к Outlook. Этот электронный организатор поможет сохранить всю важную информацию и вовремя напомнит о предстоящем событии.

Приложение Outlook объединяет в себе несколько компонентов, облегчающих управление документами компьютера, отправку и получение электронных сообщений, составление расписания событий и списка задач, хранение информации о контактах с другими людьми. Outlook может даже заменить Проводник Windows, обеспечив доступ ко всем ресурсам компьютера.

Навигация в Outlook

Outlook хранит информацию в папках, расположенных в специальных файлах (не следует путать папки Outlook с папками жесткого диска). Пользователю не нужно заботиться о своевременном сохранении данных Outlook. Программа сама вовремя запишет все новые сообщения, события и контакты на жесткий диск. Папки Outlook достаточно разнообразны. Для обработки хранящейся в них информации предлагается множество различных инструментов. По этой причине Outlook имеет достаточно сложный интерфейс с большим количеством кнопок, меню, списков и окон диалога. В следующих упражнениях, по мере изучения папок Outlook, вы познакомитесь с основными инструментами навигации этой программы.

Упражнение 1. Ярлыки Outlook

После запуска Outlook командой Про граммы > Microsoft Outlook (Programs > Microsoft Outlook) Главного меню Windows на экране появляется окно Outlook. В его левой части расположена панель с набором ярлыков, объединенных в группы. В верхней части окна есть обычная строка меню и панель инструментов. Остальная область окна Outlook отводится под содержимое открытой папки, над которым располагается раскрывающийся список личных папок (то есть папок, содержимое которых хранится во внутренних файлах Outlook). Чтобы вывести на экран ту или иную информацию из стандартных папок Outlook, выполните следующие шаги.

  1. Щелкните на кнопке группы Ярлыки Outlook (Outlook Shortcuts).

  2. Щелкните на одном из ярлыков этой группы, например на значке Outlook сегодня (Outlook Today). В основной области окна Outlook появится информация о текущих событиях сегодняшнего дня, как показано на рис. 19.1. Сюда выводится список событий, назначенных в календаре Outlook, задачи, запланированные на текущий день, а также состояние ваших почтовых ящиков. Кроме стандартных ярлыков, Outlook разрешает пользователю добавлять собственные ярлыки и группы. Это позволяет поместить в панель Outlook ярлыки часто используемых папок компьютера и инструментов Outlook, сгруппировав их по темам.

Рис. 19.1. Окно Outlook

  3. Щелкните в панели ярлыков правой кнопкой мыши и выберите в контекст ном меню команду Добавить группу (Add New Group).

  4. В качестве названия группы введите текст Мои ярлыки.

  5. Щелкните на кнопке новой группы.

  6. Щелкните правой кнопкой мыши в области ярлыков новой группы и выберите в контекстном меню команду Ярлык для панели Outlook (Outlook Bar Shortcut). Список Просмотреть (Look In) открывшегося окна диалога (рис. 19.2) позволяет выбрать один из двух наборов папок:

    • Outlook — стандартные папки Outlook, хранящиеся в служебных файлах программы, и папки с сообщениями электронной почты;
    • Файловая система (File System) — папки файловой системы компьютера или папки других компьютеров локальной сети.

  7. Выберите в списке Добавить к панели Outlook пункт Файловая система.

  8. Разворачивая ветви дерева папок компьютера, найдите папку с какими-либо документами (например, папку MyWebs) и выделите ее.

  9. Щелкните на кнопке ОК.

  10. Щелкните на новой папке правой кнопкой мыши и выберите команду Переименовать ярлык (Rename Shortcut). Введите имя Web-страницы.

  11. Повторяя шаги 6-10, добавьте в группу Мои ярлыки стандартную парку Outlook Дневник (Journal), назначив ей название Журнал.

Рис. 19.2 . Добавление ярлыков в панель Outlook

Примечание

Чтобы удалить ненужный ярлык, щелкните на нем правой кнопкой мыши и выберите команду Удалить с панели Outlook (Remove From Outlook Bar). Для удаления группы щелкните правой кнопкой мыши на ее заголовке и выберите команду Удалить группу (Remove Group).

  12. Щелкните на ярлыке Веб-страницы. В окно Outlook будет выведено содержимое соответствующей папки жесткого диска. С помощью инструментов Outlook вы можете выполнять с файлами списка практически те же операции, что и в окне Проводника Windows:

  • запускать программу, дважды щелкнув на исполняемом файле или ярлыке;

  • открывать документ, дважды щелкнув на его значке или перетащив значок в окно приложения;

  • щелчком правой кнопки мыши открывать контекстное меню файла, с помощью которого можно вырезать, копировать, переименовывать, удалять или распечатывать файл и выполнять многие другие операции;

  • копировать файл в другую папку, перетащив его значок из окнa.Outlook в окно Проводника, окно папки, на рабочий стол или на значок папки-приемника в панели ярлыков Outlook;

  • создавать в панели Outlook ярлык файла, перетащив значок в эту панель.

Примечание

Ярлыки основных папок жесткого диска с документами пользователя по умолчанию помещаются в группу Другие папки (Other) панели ярлыков Outlook.

Упражнение 2. Дневник

В дневник Outlook автоматически записываются все операции, выполнявшиеся с документами Office. Чтобы открыть дневник, выполните следующие действия.

  1. В панели ярлыков щелкните на заголовке группы Ярлыки Outlook.

  2. С помощью кнопки прокрутки панели найдите значок Дневник (Journal).

  3. Щелкните на этом значке.

  4. Чтобы развернуть список документов Word, щелкните на знаке «плюс» в строке Microsoft Word. Ниже этой строки появятся имена открывавшихся файлов, расположенные под теми днями шкалы времени, в которые вы работали с этими файлами.

  5. Щелкните на одном из значков правой кнопкой мыши. Появится контекстное меню, позволяющее открыть выбранный файл, распечатать его, отправить документ по электронной почте и выполнить некоторые другие операции. На рис. 19.3 дневник показан в режиме просмотра типа файла. Для каждой из своих папок Outlook предлагает несколько режимов просмотра. Нужный вариант можно выбрать в меню Вид > Текущее представление (View > Current View). Но есть и другой способ переключения режимов. В панели инструментов расположена кнопка организатора, который помогает ориентироваться в Outlook.

Рис. 19.3. Дневник

Вкладки Организатора видоизменяются в зависимости от того, с какой папкой Outlook вы работаете, и позволяют быстро настроить нужный формат отображения информации. Если щелкнуть на кнопке Найти (Find) панели инструментов, на смену организатору придет инструмент упрощенного поиска — еще один эффективный модуль Outlook XP, способный в ряде случаев заменить сложное окно расширенного поиска информации.

  6. Щелкните на кнопке Организовать (Organize). В верхней части области про смотра дневника появится панель организатора.

  7. Щелкните на ссылке По представлению (Using Views).

  8. В списке режимов выберите пункт Список элементов (Entry List). Теперь дневник похож на окно папки Windows или Проводника в режиме просмотра таблицы (рис. 19.4). Каждая запись занимает одну строку таблицы, столбцы которой информируют о времени открытия документа, продолжительности работы с ним и о некоторых других параметрах файла.

Примечание

Чтобы упорядочить список по одному из параметров, например по продолжительности работы с документом, щелкните на заголовке соответствующего столбца списка. Повторный щелчок на том же заголовке рассортирует пункты списка в обратном порядке.

  9. Закройте организатор.

  10. Нажмите клавишу Ctrl и, не отпуская ее, щелкните на нескольких пунктах списка, чтобы выделить их.

  11. Щелчком на кнопке Удалить (Delete) сотрите выбранные пункты. Для быстрого перемещения по папкам Outlook можно воспользоваться списком папок.

Рис. 19.4. Просмотр списка элементов дневника

Рис. 19.5. Удаленные элементы

  12. Щелкните на заголовке Дневник.

  13. В открывшейся панели щелкните на значке канцелярской кнопки в правом верхнем углу. Раскрывающийся список папок превратится в постоянную панель Список папок (Folder List).

  14. Щелкните на пункте Удаленные (Deleted Items). Откроется папка, содержащая стертые элементы различных папок Outlook (рис. 19.5). Она похожа на Корзину Windows. Здесь вы найдете записи, удаленны? из дневника на шаге 11.

Рис. 19.6. Добавление папки Outlook

  15. Щелкните на одном из пунктов папки правой кнопкой мыши и выберите в контекстном меню команду Переместить в папку (Move To Folder). Откроется окно диалога, которое позволяет перемещать элементы между папками Outlook и добавлять новые папки.

  16. Щелкните на кнопке Создать (New).

  17. В поле Имя папки (Name) открывшегося окна диалога (рис. 19.6) введите слова Важные заметки.

  18. В раскрывающемся списке Содержимое папки (Folder Contains) выберите пункт Элементы типа Заметки (Note Items).

Любая папка Outlook, как видно из списка, относится к одному из шести стандартных типов, каждый из которых имеет определенное предназначение и свой формат представления информации:

  • Дневник (Journal) — журнал выполнявшихся операций;

  • Задача (Task) — список запланированных задач;

  • Заметки (Note) — заметки пользователя;

  • Календарь (Calendar) — список запланированных событий;

  • Контакт (Contact) — список людей или компаний с адресами, телефонами и другой информацией;

  • Почта (Mail and Posti) — папка с входящими или исходящими сообщениями электронной почты.

  19. Щелкните на кнопке ОК.

  20. Чтобы поместить значок новой папки в панель ярлыков, щелкните на кнопке Да (Yes).

  21. Щелчком на кнопке О Кв окне Перемещение элементов (Move Items) завершите операцию перемещения записи из папки Удаленные в только что созданную папку.

Упражнение 3. Поиск

Инструмент поиска позволяет пользователю находить во всем многообразии папок Outlook требуемую информацию. Чтобы научиться искать нужные записи, давайте сначала добавим несколько заметок.

  1. В панели списка папок щелкните на пункте Заметки.

Открывшаяся папка предназначена для хранения информации, которая с трудом поддается систематизации, но всегда должна быть под рукой. Папка заметок заменяет многочисленные листочки с записями,, разбросанные по рабочему столу или наклеенные на дисплей компьютера.

  2. В панели инструментов щелкните на кнопке Создать. Появится окно заметки. Введите в него некоторый текст, например показанный на рис. 19.7. Кроме самого текста в заметке хранятся дата и время ее создания или последнего изменения, которые выводятся в нижней части окна.

Рис. 19.7. Заметка

  3. Закройте окно заметки.

  4. Добавьте еще несколько заметок, наполнив их содержанием по собственно му усмотрению.

  5. Чтобы открыть окно поиска, выберите команду Сервис > Расширенный поиск файлов (Tools > Advanced Find).

  6. В раскрывающемся списке Просмотреть (Look For) выберите пункт Любой элемент Outlook (Any Type Of Outlook Item), чтобы искать во всех папках Outlook.

  7. В поле Искать текст (Search For The Word) вкладки Любые элементы (Any Items) введите слово Outlook.

  8. Чтобы поиск осуществлялся не только в заголовках, но и в теле сообщений и заметок, выберите в списке Место поиска (In) пункт поля тем и заметок (Subject And Notes Fields).

Рис. 19.8. Окно расширенного поиска

  9. Щелкните на кнопке Найти (Find Now). Программа обнаружит все записи, в которых встречается слово Outlook, и выведет их список в нижнюю часть окна поиска, как показано на рис. 19.8. Здесь вы найдете заметку, созданную в начале упражнения. Двойной щелчок на любом из пунктов списка найденных элементов откроет окно этого элемента и даст возможность ознакомиться с его содержанием.

Календарь

Календарь представляет собой бесконечный ежедневник, в который записываются определенные события. Вы можете внести в бланк календаря любое событие, и сообщение о нем появится на экране компьютера в указанный момент, напомнив вам о запланированном мероприятии. Другим типом записи календаря является периодическое событие, которое подобно обычному событию, но генерирует сообщение регулярно через определенные промежутки времени согласно заранее настроенному расписанию. Третий тип записи календаря — это уведомление о совещании, которое автоматически рассылается программой Outlook всем участникам совещания в заранее указанный момент времени.

Упражнение 4. Добавление события

Рабочий день делового человека наполнен различными встречами, совещаниями и семинарами. Календарь поможет организовать ваше расписание и вовремя напомнит о предстоящем событии. Чтобы добавить планируемую встречу в бланк календаря, выполните следующие действия.

  1. С помощью команды Вид > Список папок (View > Folder List) закройте панель списка папок, открытую в предыдущих упражнениях.

  2. В группе Ярлыки Outlook щелкните на значке Календарь (Calendar). Календарь появится в виде расписания текущего дня, прокручиваемого календаря месяцев и списка задач, как показано на рис. 19.9.

  3. Щелкните на стрелке кнопки Создать и выберите пункт Встреча (Appointment).

  4. Введите в поле Тема (Subject) открывшегося окна диалога текст Совещание по вопросам рекламы.

  5. В поле Место (Location) напечатайте Офис дочерней компании.

  6. В левом раскрывающемся списке строки Начало (Start Time) выберите в календаре день, на который назначено совещание (например, четверг следующей недели). Для перехода к другому месяцу пользуйтесь кнопками прокрутки (рис. 19.10).

  7. В правом раскрывающемся списке строки Начало выберите время начала совещания.

  8. В таком же списке строки Конец (End Time) укажите предполагаемое время окончания совещания.

Рис. 19.9. Календарь

  9. Установите флажок Оповещение (Reminder). Это заставит Outlook заранее предупредить вас о предстоящем совещании.

Рис. 19.10. Настройка события

  10. В одноименном раскрывающемся списке выберите пункт 1 час (1 hour), чтобы напоминание появилось за час до предстоящего события.

  11. Если вы еще не решили, следует ли появляться на планируемом совещании, выберите в раскрывающемся списке В это время (Show Time As) пункт Под вопросом (Tentative). По умолчанию назначаемое событие получает состояние Занят (Busy). Если вы хотите дать возможность своему секретарю записать на то же самое время еще одно событие, выбирайте вариант Под вопросом. Чтобы указать на свое отсутствие в зоне досягаемости и невозможность ответа на телефонные звонки, назначьте для такого интервала времени событие с состоянием Нет на работе (Out Of Office). Различные состояния отражаются в бланке календаря разным цветом.

  12. В нижнем прокручивающемся поле для заметок введите текст Не забыть материалы по рекламе в журналах.

  13. Щелкните на кнопке Сохранить и закрыть (Save And Close) панели инструментов. В нужный день ровно за час до назначенного времени Outlook напомнит о предстоящем совещании звуковым сигналом и появлением окна сообщения, подобного показанному на рис. 19.11.

Рис. 19.11. Окно напоминания

Щелчок на кнопке Прекратить (Dismiss) закроет окно напоминания. Кнопка Отложить (Snooze) тоже закрывает окно, но инициирует повторное напоминание через интервал времени, указанный в раскрывающемся списке в нижней части окна. Щелчок на кнопке Открыть (Open Item) откроет детальное описание события.

Примечание

Программа Outlook напомнит о предстоящем событии, только если она запущена. Чтобы не пропустить важное заседание, поместите значок Outlook в папку Автозагрузка (StartUp) Главного меню, чтобы программа запускалась автоматически сразу после включения компьютера и загрузки Windows.

Упражнение 5. Периодическое событие

Некоторые события повторяются достаточно часто с определенной периодичностью. Нет надобности вносить в календарь такое событие несколько раз. Outlook сам заполнит ячейки в соответствии с указанным вами правилом. Чтобы настроить периодическое событие, выполните следующие шаги.

  1. Выберите команду Файл > Создать > Встреча (File > New > Appointment).

  2. В поле Тема введите текст Обеденный перерыв.

  3. В качестве времени начала выберите 12 :00, а в качестве времени окончания 13:00.

  4. Включите режим напоминания за 15 минут до события и назначьте состояние Нет на работе.

  5. Щелчком на кнопке Повторение (Recurrence) откройте окно диалога, показанное на рис. 19.12:

Рис. 19.12. Настройка повторения

  6. Чтобы сообщение об обеденном перерыве появлялось пять раз в неделю по рабочим дням, выберите положение переключателя еженедельно (Weekly).

  7. Установите флажки рабочих дней.

  8. В календаре поля начало (Start) раздела Пределы повторения (Range Of Recurrence) щелкните на кнопке Сегодня (Today). Этим вы укажете сегодняшний день в качестве начала отсчета для повторяющихся напоминаний. Положение переключателя нет конечной даты (No End Date) раздела Пределы повторения, выбираемое по умолчанию, инициирует бесконечный процесс повторения напоминаний. Положение завершить после (End After) позволяет указать количество повторений события, после которого пропадает надобность в дальнейшем размещении записей в календаре. Положение дата окончания (End By) дает возможность ввести дату окончания цикла повторения.

  9. Щелкните на кнопке ОК.

  10. Чтобы установить для настраиваемого события повышенную важность, щелкните на кнопке Важность: высокая (Importance: High) панели инструментов.

  11. Щелкните на кнопке Сохранить и закрыть. Обеденный перерыв появится в бланке каждого дня календаря, кроме выходных.

Упражнение 6. Приглашение на совещание

Широкие возможности Outlook позволяют напомнить о предстоящем совещании не только вам, но и другим участникам. Для этого в Outlook интегрированы инструменты отправки электронных сообщений.

  1. В панели инструментов календаря щелкните на стрелке кнопки Создать и выберите в раскрывшемся меню команду Приглашение на собрание (Meeting Request). Откроется окно, показанное на рис. 19.13. Оно подобно окну настройки параметров встречи, но в нем есть дополнительное поле, снабженное кнопкой Кому. В этом поле нужно перечислить электронные адреса всех участников совещания. Скорее всего, вы не помните их наизусть, поэтому проще будет выбрать адреса из справочников Outlook.

Рис. 19.13. Приглашение на совещание

  2. Щелчком на кнопке Кому откройте окно диалога. В его верхней части есть раскрывающийся список, позволяющий указать один из справочников адресов. Это может быть личная адресная книга Windows, адресная книга Outlook или список контактов, с которым вы познакомитесь на следующем занятии.

  3. Выберите подходящую адресную книгу.

  4. Выделите адресата в левом списке окна диалога.

  5. Щелкните на кнопке Обязательный (Required). Если нужного человека в адресных книгах нет, можно добавить информацию о нем в одну из них. Для этого щелкните на кнопке Создать, заполните в открывшемся окне нужные поля, после чего щелкните на кнопке ОК.

  6. Выбирайте фамилии людей и щелкайте на кнопке Обязательный до тех пор, пока не переберете всех участников совещания.

  7. Щелкните на кнопке О К, чтобы вернуться в окно настройки параметров встречи.

  8. В поле Тема введите предложение Семинар по защите окружающей среды.

  9. В раскрывающемся списке Место выберите пункт Офис дочерней компании, попавший в этот список при добавлении события в упражнении 4.

  10. В календаре поля Начало выберите тот же день, в который было назначено совещание в упражнении 4.

  11. Установите флажок Целый день (All Day Event). Режим назначения события на целый день позволяет размещать в календаре упоминания о мероприятиях, длящихся продолжительное время. На фоне такого мероприятия в календаре могут присутствовать и встречи, назначенные на конкретное время и пересекающиеся с длительным мероприятием.

  12. Выберите в календаре поля Конец пятницу той же недели, на которую приходится начало семинара.

  13. В поле комментария введите текст, который должен быть отправлен адресатам вместе с напоминанием о семинаре.

  14. Щелкните на кнопке Отправить (Send). Outlook автоматически сгенерирует необходимые сообщения и отправит их участникам совещания по электронной почте. Если компьютер связывается с провайдером посредством модема, то сообщения будут отправлены при очередном подключении к почтовому серверу.

Примечание

Не задумывайтесь сейчас о том, как Outlook обрабатывает электронную почту. Вы познакомитесь с почтовыми возможностями этого приложения на занятии 21.

Упражнение7. Вид календаря

В предыдущих упражнениях вы добавили в календарь несколько записей. Теперь давайте взглянем на них, воспользовавшись разными режимами просмотра. Исходный режим, который называется День/неделя/месяц (Day/Week/Month), показан на рис. 19.14. Он позволяет не только просматривать назначенные события, но и оперативно добавлять и удалять пункты календаря.

Рис. 19.14. Режим День/неделя/месяц

  1. Чтобы отвести под календарь больше пространства, выполните команду Вид > Панель Outlook (View > Outlook Bar), скрыв этим панель ярлыков.

  2. В области календарей на месяц щелкните на том дне, на который было назначено совещание в упражнении 4 (в моем примере это 11 февраля 1999 года). Вы увидите в бланке календаря три события. Название семинара, который будет длиться два дня, находится в верхней части расписания текущего дня. Два других события расположены в соответствии с назначенным временем. Чтобы добавить в расписание дня еще одну встречу, выполните следующие действия.

  3. Щелкните на графе 11:00.

  4. Введите текст Встреча с представителем компании Фантом.

  5. Нажмите клавишу Enter. Обратите внимание, что слева от описания каждого события расположена полоска определенного цвета. Синим цветом выделены временные интервалы, обозначенные как занятые, синим со штриховкой — как занятые под вопросом, а темно-синим — те промежутки времени, когда вы будете отсутствовать на работе.

  6. На панели инструментов календаря щелкните на кнопке с раскрывающимся списком Текущее представление (Current View) и выберите пункт Активные встречи (Active Appointments).

Теперь на экране появится список активных (запланированных на будущее) событий, разделенных на группы в соответствии с выбранным режимом повторяемости. С помощью кнопок в заголовках групп можно сворачивать (щелчок на значке «минус») и разворачивать (щелчок на значке «плюс») содержимое группы. В левой ячейке каждой строки таблицы находится значок, показывающий тип данного пункта. Встречи и повторяющиеся события отмечены маленьким календарем, а приглашения на совещания — изображением двух людей. Этот вариант просмотра, показанный на рис. 19.15, позволяет оперативно изменять параметры событий. Просто щелкните на любой ячейке и отредактируйте ее содержимое. Изменение информации о событии тут же отразится во всех остальных режимах просмотра календаря.

Рис. 19.15. Просмотр активных встреч

  7. С помощью той же кнопки Текущее представление, выбрав пункт День/неделя/месяц (Day/Week/Month), вернитесь к прежнему режиму просмотра.

  8. Щелкните на кнопке Неделя (Week) панели инструментов. Бланк расписания дня заменится на список из семи дней недели.

  9. Щелкните на кнопке Месяц (Month), и вы увидите большой бланк календаря на месяц со списком запланированных событий.

  10. Щелчком на кнопке День (Day) вернитесь к исходному режиму.

Задачи

Список задач, который виден в правой части календаря на рис. 19.15, принципиально отличается от списка событий тем, что задачи не привязаны к конкретному времени, а лишь напоминают о той работе, которую нужно сделать. Они остаются в списке до тех пор, пока не будут удалены пользователем. Чтобы не забыть о проделанной работе, задачи можно не удалять, а помечать как выполненные, тогда текст этих задач перечеркивается горизонтальной линией.

Упражнение 8. Добавление задачи

Задачи хранятся в отдельной папке Outlook. Но добавить их туда можно практически в любой момент, даже работая с другими папками программы. Попробуйте создать запись о новой задаче.

  1. Щелкните на стрелке кнопки Создать панели инструментов и выберите пункт Задача (Task). Откроется окно ввода параметров задачи, показанное на рис. 19.16.

  2. В поле Тема введите текст Изучить возможности почтового модуля Outlook.

Рис. 19.16 . Добавление задачи

  3. Раскройте список Срок (Due Date) и выберите в календаре вчерашнюю дату. Назначение срока исполнения позволяет контролировать запланированную скорость работы. Если к назначенному сроку задача не была помечена как выполненная, ее текст будет отображаться красным цветом. Именно это случится с только что добавленной задачей, которая должна была быть выполнена до вчерашнего дня.

  4. Щелкните на кнопке Категории (Categories).

  5. Вам, вероятно, не понравятся категории с английскими названиями. Чтобы добавить новую категорию, щелкните на кнопке Главный список категорий (Master Category List), введите слово Обучение, щелкните на кнопке Добавить (Add), а затем на кнопке ОК.

  6. В списке открывшегося окна диалога установите флажки у тех категорий, к которым относится добавляемая задача.

  7. Щелкните на кнопке ОК.

  8. В панели инструментов щелкните на кнопке Сохранить и закрыть.

  9. В списке задач окна календаря щелкните на надписи Щелчок добавит элемент (Click Here To Add A New Task) и введите текст Продумать дополнительные скидки для клиентов.

  10. Нажмите клавишу Enter. В списке появится еще одна задача, добавленная без открытия окна новой задачи.

Примечание

Чтобы открыть бланк новой задачи, просматривая календарь или папку задач, достаточно дважды щелкнуть на строке Щелчок добавит элемент (Click Here To Add A New Task). Для модификации параметров существующей задачи дважды щелкните на ее строке.

Упражнение 9. Просмотр задач

Как и записи календаря, задачи тоже можно просматривать в различных режимах.

  1. Щелкните на заголовке Календарь, чтобы раскрыть список папок Outlook.

  2. Выберите пункт Задачи (Tasks).

  3. Выполните команду Вид > Текущее представление по категориям (View > Current View > By Category).

  4. Щелкайте на значках «плюс» в заголовках всех категорий, чтобы развернуть списки относящихся к ним задач. Одна из задач, добавленных в предыдущем упражнении, оказалась упомянутой трижды, так как она была отнесена сразу к трем категориям. Категория может быть назначена не только задаче, но также и записи любой другой папки Outlook (событию календаря, контакту и т. д.). Деление по категориям позволяет распределить большое число записей по тематическим подгруппам, относящимся к конкретным проектам или сферам деятельности. Чтобы отсортировать пункты категории по одному из признаков, щелкните на заголовке соответствующего столбца. Повторный щелчок на том же заголовке приводит к смене порядка сортировки на обратный.

  5. В раскрывающемся списке ячейки Состояние (Status) этой задачи выберите пункт Завершена (Completed). Название данной задачи будет перечеркнуто в списках всех трех категорий, как показано на рис. 19.17.

Рис. 19.17. Просмотр задач по категориям

  6. Чтобы вернуть панель ярлыков Outlook, выберите команду Вид > Панель Outlook.

  7. Щелкните на ярлыке Outlook Сегодня. Вы увидите добавленные задачи ыи события календаря в списке, приготовленном программой на сегодняшний день.

Контрольное упражнение

Инструменты Outlook достаточно просты, но они предоставляют огромное количество разнообразных возможностей работы. Это контрольное упражнение поможет перейти к самостоятельному изучению тех компонентов и режимов, которые не были упомянуты в упражнениях занятия.

  1. Откройте календарь.

  2. Добавьте в список праздники и дни рождения друзей, назначив их событиями с периодичностью в один год.

  3. Добавьте две новые категории: Праздник и День рождения. Назначьте каждому из введенных событий одну из этих категорий.

  4. Измените режим просмотра календаря так, чтобы в бланке отображалось расписание трех последовательных дней следующей недели.

    • Как включить указанный режим просмотра?

  5. В поле отображения задач в окне календаря выберите режим вывода всех : (в том числе выполненных) задач. *

    • Как изменить режим списка задач в календаре ?

  6. Верните всем задачам статус невыполненных.

  7. Перейдите в календаре к отображению бланка текущего дня.

    • Как быстро перейти к бланку текущего дня?

Подведение итогов

На этом занятии вы познакомились с дневником событий, папкой заметок, календарем и списком задач, научились ориентироваться в инструментах навигации Outlook и переключать режимы просмотра папок этой программы. Теперь вы можете управлять файлами компьютера прямо из окна Outlook, не прибегая к помощи Проводника.

На следующем занятии будет рассмотрен пятый тип папок Outlook — Контакты. Вы научитесь записывать в эти папки информацию о человеке и пользоваться сохраненными контактами при отправке электронных сообщений, планировании встреч и совещаний.


Занятие №19

ЧАСТЬ VI

Outlook

Microsoft Outlook XP — отличный организатор вашей деловой жизни. Это приложение может служить электронным аналогом записной книжки, обрабатывать сообщения электронной почты, хранить списки контактов и задач, вести дневник событий.

Организатор событий и задач

ТЕМА ЗАНЯТИЯ

Outlook управляет документами компьютера и сообщениями электронной почты, хранит список контактов с другими людьми и компаниями, напоминает о назначенных встречах и совещаниях. На этом занятии вы познакомитесь с основными инструментами интерфейса Outlook и научитесь выполнять следующие операции:

  • добавлять ярлыки Outlook;

  • просматривать дневник событий;

  • искать документы Outlook;

  • добавлять события в календарь;

  • назначать совещания;

  • обновлять список задач.

Бели ваш стол завален записками, вы периодически не можете найти нужный адрес, забываете о назначенных совещаниях и не можете разобраться в море документов, переполняющих жесткий диск компьютера, попробуйте обратиться за помощью к Outlook. Этот электронный организатор поможет сохранить всю важную информацию и вовремя напомнит о предстоящем событии.

Приложение Outlook объединяет в себе несколько компонентов, облегчающих управление документами компьютера, отправку и получение электронных сообщений, составление расписания событий и списка задач, хранение информации о контактах с другими людьми. Outlook может даже заменить Проводник Windows, обеспечив доступ ко всем ресурсам компьютера.


Навигация в Outlook

Outlook хранит информацию в папках, расположенных в специальных файлах (не следует путать папки Outlook с папками жесткого диска). Пользователю не нужно заботиться о своевременном сохранении данных Outlook. Программа сама вовремя запишет все новые сообщения, события и контакты на жесткий диск. Папки Outlook достаточно разнообразны. Для обработки хранящейся в них информации предлагается множество различных инструментов. По этой причине Outlook имеет достаточно сложный интерфейс с большим количеством кнопок, меню, списков и окон диалога. В следующих упражнениях, по мере изучения папок Outlook, вы познакомитесь с основными инструментами навигации этой программы.


Упражнение 1. Ярлыки Outlook

После запуска Outlook командой Про граммы > Microsoft Outlook (Programs > Microsoft Outlook) Главного меню Windows на экране появляется окно Outlook. В его левой части расположена панель с набором ярлыков, объединенных в группы. В верхней части окна есть обычная строка меню и панель инструментов. Остальная область окна Outlook отводится под содержимое открытой папки, над которым располагается раскрывающийся список личных папок (то есть папок, содержимое которых хранится во внутренних файлах Outlook). Чтобы вывести на экран ту или иную информацию из стандартных папок Outlook, выполните следующие шаги.

  1. Щелкните на кнопке группы Ярлыки Outlook (Outlook Shortcuts).

  2. Щелкните на одном из ярлыков этой группы, например на значке Outlook сегодня (Outlook Today). В основной области окна Outlook появится информация о текущих событиях сегодняшнего дня, как показано на рис. 19.1. Сюда выводится список событий, назначенных в календаре Outlook, задачи, запланированные на текущий день, а также состояние ваших почтовых ящиков. Кроме стандартных ярлыков, Outlook разрешает пользователю добавлять собственные ярлыки и группы. Это позволяет поместить в панель Outlook ярлыки часто используемых папок компьютера и инструментов Outlook, сгруппировав их по темам.

Рис. 19.1. Окно Outlook

  3. Щелкните в панели ярлыков правой кнопкой мыши и выберите в контекст ном меню команду Добавить группу (Add New Group).

  4. В качестве названия группы введите текст Мои ярлыки.

  5. Щелкните на кнопке новой группы.

  6. Щелкните правой кнопкой мыши в области ярлыков новой группы и выберите в контекстном меню команду Ярлык для панели Outlook (Outlook Bar Shortcut). Список Просмотреть (Look In) открывшегося окна диалога (рис. 19.2) позволяет выбрать один из двух наборов папок:

    • Outlook — стандартные папки Outlook, хранящиеся в служебных файлах программы, и папки с сообщениями электронной почты;
    • Файловая система (File System) — папки файловой системы компьютера или папки других компьютеров локальной сети.

  7. Выберите в списке Добавить к панели Outlook пункт Файловая система.

  8. Разворачивая ветви дерева папок компьютера, найдите папку с какими-либо документами (например, папку MyWebs) и выделите ее.

  9. Щелкните на кнопке ОК.

  10. Щелкните на новой папке правой кнопкой мыши и выберите команду Переименовать ярлык (Rename Shortcut). Введите имя Web-страницы.

  11. Повторяя шаги 6-10, добавьте в группу Мои ярлыки стандартную парку Outlook Дневник (Journal), назначив ей название Журнал.

Рис. 19.2 . Добавление ярлыков в панель Outlook

Примечание

Чтобы удалить ненужный ярлык, щелкните на нем правой кнопкой мыши и выберите команду Удалить с панели Outlook (Remove From Outlook Bar). Для удаления группы щелкните правой кнопкой мыши на ее заголовке и выберите команду Удалить группу (Remove Group).

  12. Щелкните на ярлыке Веб-страницы. В окно Outlook будет выведено содержимое соответствующей папки жесткого диска. С помощью инструментов Outlook вы можете выполнять с файлами списка практически те же операции, что и в окне Проводника Windows:

  • запускать программу, дважды щелкнув на исполняемом файле или ярлыке;

  • открывать документ, дважды щелкнув на его значке или перетащив значок в окно приложения;

  • щелчком правой кнопки мыши открывать контекстное меню файла, с помощью которого можно вырезать, копировать, переименовывать, удалять или распечатывать файл и выполнять многие другие операции;

  • копировать файл в другую папку, перетащив его значок из окнa.Outlook в окно Проводника, окно папки, на рабочий стол или на значок папки-приемника в панели ярлыков Outlook;

  • создавать в панели Outlook ярлык файла, перетащив значок в эту панель.

Примечание

Ярлыки основных папок жесткого диска с документами пользователя по умолчанию помещаются в группу Другие папки (Other) панели ярлыков Outlook.


Упражнение 2. Дневник

В дневник Outlook автоматически записываются все операции, выполнявшиеся с документами Office. Чтобы открыть дневник, выполните следующие действия.

  1. В панели ярлыков щелкните на заголовке группы Ярлыки Outlook.

  2. С помощью кнопки прокрутки панели найдите значок Дневник (Journal).

  3. Щелкните на этом значке.

  4. Чтобы развернуть список документов Word, щелкните на знаке «плюс» в строке Microsoft Word. Ниже этой строки появятся имена открывавшихся файлов, расположенные под теми днями шкалы времени, в которые вы работали с этими файлами.

  5. Щелкните на одном из значков правой кнопкой мыши. Появится контекстное меню, позволяющее открыть выбранный файл, распечатать его, отправить документ по электронной почте и выполнить некоторые другие операции. На рис. 19.3 дневник показан в режиме просмотра типа файла. Для каждой из своих папок Outlook предлагает несколько режимов просмотра. Нужный вариант можно выбрать в меню Вид > Текущее представление (View > Current View). Но есть и другой способ переключения режимов. В панели инструментов расположена кнопка организатора, который помогает ориентироваться в Outlook.

Рис. 19.3. Дневник

Вкладки Организатора видоизменяются в зависимости от того, с какой папкой Outlook вы работаете, и позволяют быстро настроить нужный формат отображения информации. Если щелкнуть на кнопке Найти (Find) панели инструментов, на смену организатору придет инструмент упрощенного поиска — еще один эффективный модуль Outlook XP, способный в ряде случаев заменить сложное окно расширенного поиска информации.

  6. Щелкните на кнопке Организовать (Organize). В верхней части области про смотра дневника появится панель организатора.

  7. Щелкните на ссылке По представлению (Using Views).

  8. В списке режимов выберите пункт Список элементов (Entry List). Теперь дневник похож на окно папки Windows или Проводника в режиме просмотра таблицы (рис. 19.4). Каждая запись занимает одну строку таблицы, столбцы которой информируют о времени открытия документа, продолжительности работы с ним и о некоторых других параметрах файла.

Примечание

Чтобы упорядочить список по одному из параметров, например по продолжительности работы с документом, щелкните на заголовке соответствующего столбца списка. Повторный щелчок на том же заголовке рассортирует пункты списка в обратном порядке.

  9. Закройте организатор.

  10. Нажмите клавишу Ctrl и, не отпуская ее, щелкните на нескольких пунктах списка, чтобы выделить их.

  11. Щелчком на кнопке Удалить (Delete) сотрите выбранные пункты. Для быстрого перемещения по папкам Outlook можно воспользоваться списком папок.

Рис. 19.4. Просмотр списка элементов дневника

Рис. 19.5. Удаленные элементы

  12. Щелкните на заголовке Дневник.

  13. В открывшейся панели щелкните на значке канцелярской кнопки в правом верхнем углу. Раскрывающийся список папок превратится в постоянную панель Список папок (Folder List).

  14. Щелкните на пункте Удаленные (Deleted Items). Откроется папка, содержащая стертые элементы различных папок Outlook (рис. 19.5). Она похожа на Корзину Windows. Здесь вы найдете записи, удаленны? из дневника на шаге 11.

Рис. 19.6. Добавление папки Outlook

  15. Щелкните на одном из пунктов папки правой кнопкой мыши и выберите в контекстном меню команду Переместить в папку (Move To Folder). Откроется окно диалога, которое позволяет перемещать элементы между папками Outlook и добавлять новые папки.

  16. Щелкните на кнопке Создать (New).

  17. В поле Имя папки (Name) открывшегося окна диалога (рис. 19.6) введите слова Важные заметки.

  18. В раскрывающемся списке Содержимое папки (Folder Contains) выберите пункт Элементы типа Заметки (Note Items).

Любая папка Outlook, как видно из списка, относится к одному из шести стандартных типов, каждый из которых имеет определенное предназначение и свой формат представления информации:

  • Дневник (Journal) — журнал выполнявшихся операций;

  • Задача (Task) — список запланированных задач;

  • Заметки (Note) — заметки пользователя;

  • Календарь (Calendar) — список запланированных событий;

  • Контакт (Contact) — список людей или компаний с адресами, телефонами и другой информацией;

  • Почта (Mail and Posti) — папка с входящими или исходящими сообщениями электронной почты.

  19. Щелкните на кнопке ОК.

  20. Чтобы поместить значок новой папки в панель ярлыков, щелкните на кнопке Да (Yes).

  21. Щелчком на кнопке О Кв окне Перемещение элементов (Move Items) завершите операцию перемещения записи из папки Удаленные в только что созданную папку.


Упражнение 3. Поиск

Инструмент поиска позволяет пользователю находить во всем многообразии папок Outlook требуемую информацию. Чтобы научиться искать нужные записи, давайте сначала добавим несколько заметок.

  1. В панели списка папок щелкните на пункте Заметки.

Открывшаяся папка предназначена для хранения информации, которая с трудом поддается систематизации, но всегда должна быть под рукой. Папка заметок заменяет многочисленные листочки с записями,, разбросанные по рабочему столу или наклеенные на дисплей компьютера.

  2. В панели инструментов щелкните на кнопке Создать. Появится окно заметки. Введите в него некоторый текст, например показанный на рис. 19.7. Кроме самого текста в заметке хранятся дата и время ее создания или последнего изменения, которые выводятся в нижней части окна.

Рис. 19.7. Заметка

  3. Закройте окно заметки.

  4. Добавьте еще несколько заметок, наполнив их содержанием по собственно му усмотрению.

  5. Чтобы открыть окно поиска, выберите команду Сервис > Расширенный поиск файлов (Tools > Advanced Find).

  6. В раскрывающемся списке Просмотреть (Look For) выберите пункт Любой элемент Outlook (Any Type Of Outlook Item), чтобы искать во всех папках Outlook.

  7. В поле Искать текст (Search For The Word) вкладки Любые элементы (Any Items) введите слово Outlook.

  8. Чтобы поиск осуществлялся не только в заголовках, но и в теле сообщений и заметок, выберите в списке Место поиска (In) пункт поля тем и заметок (Subject And Notes Fields).

Рис. 19.8. Окно расширенного поиска

  9. Щелкните на кнопке Найти (Find Now). Программа обнаружит все записи, в которых встречается слово Outlook, и выведет их список в нижнюю часть окна поиска, как показано на рис. 19.8. Здесь вы найдете заметку, созданную в начале упражнения. Двойной щелчок на любом из пунктов списка найденных элементов откроет окно этого элемента и даст возможность ознакомиться с его содержанием.


Календарь

Календарь представляет собой бесконечный ежедневник, в который записываются определенные события. Вы можете внести в бланк календаря любое событие, и сообщение о нем появится на экране компьютера в указанный момент, напомнив вам о запланированном мероприятии. Другим типом записи календаря является периодическое событие, которое подобно обычному событию, но генерирует сообщение регулярно через определенные промежутки времени согласно заранее настроенному расписанию. Третий тип записи календаря — это уведомление о совещании, которое автоматически рассылается программой Outlook всем участникам совещания в заранее указанный момент времени.


Упражнение 4. Добавление события

Рабочий день делового человека наполнен различными встречами, совещаниями и семинарами. Календарь поможет организовать ваше расписание и вовремя напомнит о предстоящем событии. Чтобы добавить планируемую встречу в бланк календаря, выполните следующие действия.

  1. С помощью команды Вид > Список папок (View > Folder List) закройте панель списка папок, открытую в предыдущих упражнениях.

  2. В группе Ярлыки Outlook щелкните на значке Календарь (Calendar). Календарь появится в виде расписания текущего дня, прокручиваемого календаря месяцев и списка задач, как показано на рис. 19.9.

  3. Щелкните на стрелке кнопки Создать и выберите пункт Встреча (Appointment).

  4. Введите в поле Тема (Subject) открывшегося окна диалога текст Совещание по вопросам рекламы.

  5. В поле Место (Location) напечатайте Офис дочерней компании.

  6. В левом раскрывающемся списке строки Начало (Start Time) выберите в календаре день, на который назначено совещание (например, четверг следующей недели). Для перехода к другому месяцу пользуйтесь кнопками прокрутки (рис. 19.10).

  7. В правом раскрывающемся списке строки Начало выберите время начала совещания.

  8. В таком же списке строки Конец (End Time) укажите предполагаемое время окончания совещания.

Рис. 19.9. Календарь

  9. Установите флажок Оповещение (Reminder). Это заставит Outlook заранее предупредить вас о предстоящем совещании.

Рис. 19.10. Настройка события

  10. В одноименном раскрывающемся списке выберите пункт 1 час (1 hour), чтобы напоминание появилось за час до предстоящего события.

  11. Если вы еще не решили, следует ли появляться на планируемом совещании, выберите в раскрывающемся списке В это время (Show Time As) пункт Под вопросом (Tentative). По умолчанию назначаемое событие получает состояние Занят (Busy). Если вы хотите дать возможность своему секретарю записать на то же самое время еще одно событие, выбирайте вариант Под вопросом. Чтобы указать на свое отсутствие в зоне досягаемости и невозможность ответа на телефонные звонки, назначьте для такого интервала времени событие с состоянием Нет на работе (Out Of Office). Различные состояния отражаются в бланке календаря разным цветом.

  12. В нижнем прокручивающемся поле для заметок введите текст Не забыть материалы по рекламе в журналах.

  13. Щелкните на кнопке Сохранить и закрыть (Save And Close) панели инструментов. В нужный день ровно за час до назначенного времени Outlook напомнит о предстоящем совещании звуковым сигналом и появлением окна сообщения, подобного показанному на рис. 19.11.

Рис. 19.11. Окно напоминания

Щелчок на кнопке Прекратить (Dismiss) закроет окно напоминания. Кнопка Отложить (Snooze) тоже закрывает окно, но инициирует повторное напоминание через интервал времени, указанный в раскрывающемся списке в нижней части окна. Щелчок на кнопке Открыть (Open Item) откроет детальное описание события.

Примечание

Программа Outlook напомнит о предстоящем событии, только если она запущена. Чтобы не пропустить важное заседание, поместите значок Outlook в папку Автозагрузка (StartUp) Главного меню, чтобы программа запускалась автоматически сразу после включения компьютера и загрузки Windows.


Упражнение 5. Периодическое событие

Некоторые события повторяются достаточно часто с определенной периодичностью. Нет надобности вносить в календарь такое событие несколько раз. Outlook сам заполнит ячейки в соответствии с указанным вами правилом. Чтобы настроить периодическое событие, выполните следующие шаги.

  1. Выберите команду Файл > Создать > Встреча (File > New > Appointment).

  2. В поле Тема введите текст Обеденный перерыв.

  3. В качестве времени начала выберите 12 :00, а в качестве времени окончания 13:00.

  4. Включите режим напоминания за 15 минут до события и назначьте состояние Нет на работе.

  5. Щелчком на кнопке Повторение (Recurrence) откройте окно диалога, показанное на рис. 19.12:

Рис. 19.12. Настройка повторения

  6. Чтобы сообщение об обеденном перерыве появлялось пять раз в неделю по рабочим дням, выберите положение переключателя еженедельно (Weekly).

  7. Установите флажки рабочих дней.

  8. В календаре поля начало (Start) раздела Пределы повторения (Range Of Recurrence) щелкните на кнопке Сегодня (Today). Этим вы укажете сегодняшний день в качестве начала отсчета для повторяющихся напоминаний. Положение переключателя нет конечной даты (No End Date) раздела Пределы повторения, выбираемое по умолчанию, инициирует бесконечный процесс повторения напоминаний. Положение завершить после (End After) позволяет указать количество повторений события, после которого пропадает надобность в дальнейшем размещении записей в календаре. Положение дата окончания (End By) дает возможность ввести дату окончания цикла повторения.

  9. Щелкните на кнопке ОК.

  10. Чтобы установить для настраиваемого события повышенную важность, щелкните на кнопке Важность: высокая (Importance: High) панели инструментов.

  11. Щелкните на кнопке Сохранить и закрыть. Обеденный перерыв появится в бланке каждого дня календаря, кроме выходных.


Упражнение 6. Приглашение на совещание

Широкие возможности Outlook позволяют напомнить о предстоящем совещании не только вам, но и другим участникам. Для этого в Outlook интегрированы инструменты отправки электронных сообщений.

  1. В панели инструментов календаря щелкните на стрелке кнопки Создать и выберите в раскрывшемся меню команду Приглашение на собрание (Meeting Request). Откроется окно, показанное на рис. 19.13. Оно подобно окну настройки параметров встречи, но в нем есть дополнительное поле, снабженное кнопкой Кому. В этом поле нужно перечислить электронные адреса всех участников совещания. Скорее всего, вы не помните их наизусть, поэтому проще будет выбрать адреса из справочников Outlook.

Рис. 19.13. Приглашение на совещание

  2. Щелчком на кнопке Кому откройте окно диалога. В его верхней части есть раскрывающийся список, позволяющий указать один из справочников адресов. Это может быть личная адресная книга Windows, адресная книга Outlook или список контактов, с которым вы познакомитесь на следующем занятии.

  3. Выберите подходящую адресную книгу.

  4. Выделите адресата в левом списке окна диалога.

  5. Щелкните на кнопке Обязательный (Required). Если нужного человека в адресных книгах нет, можно добавить информацию о нем в одну из них. Для этого щелкните на кнопке Создать, заполните в открывшемся окне нужные поля, после чего щелкните на кнопке ОК.

  6. Выбирайте фамилии людей и щелкайте на кнопке Обязательный до тех пор, пока не переберете всех участников совещания.

  7. Щелкните на кнопке О К, чтобы вернуться в окно настройки параметров встречи.

  8. В поле Тема введите предложение Семинар по защите окружающей среды.

  9. В раскрывающемся списке Место выберите пункт Офис дочерней компании, попавший в этот список при добавлении события в упражнении 4.

  10. В календаре поля Начало выберите тот же день, в который было назначено совещание в упражнении 4.

  11. Установите флажок Целый день (All Day Event). Режим назначения события на целый день позволяет размещать в календаре упоминания о мероприятиях, длящихся продолжительное время. На фоне такого мероприятия в календаре могут присутствовать и встречи, назначенные на конкретное время и пересекающиеся с длительным мероприятием.

  12. Выберите в календаре поля Конец пятницу той же недели, на которую приходится начало семинара.

  13. В поле комментария введите текст, который должен быть отправлен адресатам вместе с напоминанием о семинаре.

  14. Щелкните на кнопке Отправить (Send). Outlook автоматически сгенерирует необходимые сообщения и отправит их участникам совещания по электронной почте. Если компьютер связывается с провайдером посредством модема, то сообщения будут отправлены при очередном подключении к почтовому серверу.

Примечание

Не задумывайтесь сейчас о том, как Outlook обрабатывает электронную почту. Вы познакомитесь с почтовыми возможностями этого приложения на занятии 21.


Упражнение7. Вид календаря

В предыдущих упражнениях вы добавили в календарь несколько записей. Теперь давайте взглянем на них, воспользовавшись разными режимами просмотра. Исходный режим, который называется День/неделя/месяц (Day/Week/Month), показан на рис. 19.14. Он позволяет не только просматривать назначенные события, но и оперативно добавлять и удалять пункты календаря.

Рис. 19.14. Режим День/неделя/месяц

  1. Чтобы отвести под календарь больше пространства, выполните команду Вид > Панель Outlook (View > Outlook Bar), скрыв этим панель ярлыков.

  2. В области календарей на месяц щелкните на том дне, на который было назначено совещание в упражнении 4 (в моем примере это 11 февраля 1999 года). Вы увидите в бланке календаря три события. Название семинара, который будет длиться два дня, находится в верхней части расписания текущего дня. Два других события расположены в соответствии с назначенным временем. Чтобы добавить в расписание дня еще одну встречу, выполните следующие действия.

  3. Щелкните на графе 11:00.

  4. Введите текст Встреча с представителем компании Фантом.

  5. Нажмите клавишу Enter. Обратите внимание, что слева от описания каждого события расположена полоска определенного цвета. Синим цветом выделены временные интервалы, обозначенные как занятые, синим со штриховкой — как занятые под вопросом, а темно-синим — те промежутки времени, когда вы будете отсутствовать на работе.

  6. На панели инструментов календаря щелкните на кнопке с раскрывающимся списком Текущее представление (Current View) и выберите пункт Активные встречи (Active Appointments).

Теперь на экране появится список активных (запланированных на будущее) событий, разделенных на группы в соответствии с выбранным режимом повторяемости. С помощью кнопок в заголовках групп можно сворачивать (щелчок на значке «минус») и разворачивать (щелчок на значке «плюс») содержимое группы. В левой ячейке каждой строки таблицы находится значок, показывающий тип данного пункта. Встречи и повторяющиеся события отмечены маленьким календарем, а приглашения на совещания — изображением двух людей. Этот вариант просмотра, показанный на рис. 19.15, позволяет оперативно изменять параметры событий. Просто щелкните на любой ячейке и отредактируйте ее содержимое. Изменение информации о событии тут же отразится во всех остальных режимах просмотра календаря.

Рис. 19.15. Просмотр активных встреч

  7. С помощью той же кнопки Текущее представление, выбрав пункт День/неделя/месяц (Day/Week/Month), вернитесь к прежнему режиму просмотра.

  8. Щелкните на кнопке Неделя (Week) панели инструментов. Бланк расписания дня заменится на список из семи дней недели.

  9. Щелкните на кнопке Месяц (Month), и вы увидите большой бланк календаря на месяц со списком запланированных событий.

  10. Щелчком на кнопке День (Day) вернитесь к исходному режиму.


Задачи

Список задач, который виден в правой части календаря на рис. 19.15, принципиально отличается от списка событий тем, что задачи не привязаны к конкретному времени, а лишь напоминают о той работе, которую нужно сделать. Они остаются в списке до тех пор, пока не будут удалены пользователем. Чтобы не забыть о проделанной работе, задачи можно не удалять, а помечать как выполненные, тогда текст этих задач перечеркивается горизонтальной линией.


Упражнение 8. Добавление задачи

Задачи хранятся в отдельной папке Outlook. Но добавить их туда можно практически в любой момент, даже работая с другими папками программы. Попробуйте создать запись о новой задаче.

  1. Щелкните на стрелке кнопки Создать панели инструментов и выберите пункт Задача (Task). Откроется окно ввода параметров задачи, показанное на рис. 19.16.

  2. В поле Тема введите текст Изучить возможности почтового модуля Outlook.

Рис. 19.16 . Добавление задачи

  3. Раскройте список Срок (Due Date) и выберите в календаре вчерашнюю дату. Назначение срока исполнения позволяет контролировать запланированную скорость работы. Если к назначенному сроку задача не была помечена как выполненная, ее текст будет отображаться красным цветом. Именно это случится с только что добавленной задачей, которая должна была быть выполнена до вчерашнего дня.

  4. Щелкните на кнопке Категории (Categories).

  5. Вам, вероятно, не понравятся категории с английскими названиями. Чтобы добавить новую категорию, щелкните на кнопке Главный список категорий (Master Category List), введите слово Обучение, щелкните на кнопке Добавить (Add), а затем на кнопке ОК.

  6. В списке открывшегося окна диалога установите флажки у тех категорий, к которым относится добавляемая задача.

  7. Щелкните на кнопке ОК.

  8. В панели инструментов щелкните на кнопке Сохранить и закрыть.

  9. В списке задач окна календаря щелкните на надписи Щелчок добавит элемент (Click Here To Add A New Task) и введите текст Продумать дополнительные скидки для клиентов.

  10. Нажмите клавишу Enter. В списке появится еще одна задача, добавленная без открытия окна новой задачи.

Примечание

Чтобы открыть бланк новой задачи, просматривая календарь или папку задач, достаточно дважды щелкнуть на строке Щелчок добавит элемент (Click Here To Add A New Task). Для модификации параметров существующей задачи дважды щелкните на ее строке.


Упражнение 9. Просмотр задач

Как и записи календаря, задачи тоже можно просматривать в различных режимах.

  1. Щелкните на заголовке Календарь, чтобы раскрыть список папок Outlook.

  2. Выберите пункт Задачи (Tasks).

  3. Выполните команду Вид > Текущее представление по категориям (View > Current View > By Category).

  4. Щелкайте на значках «плюс» в заголовках всех категорий, чтобы развернуть списки относящихся к ним задач. Одна из задач, добавленных в предыдущем упражнении, оказалась упомянутой трижды, так как она была отнесена сразу к трем категориям. Категория может быть назначена не только задаче, но также и записи любой другой папки Outlook (событию календаря, контакту и т. д.). Деление по категориям позволяет распределить большое число записей по тематическим подгруппам, относящимся к конкретным проектам или сферам деятельности. Чтобы отсортировать пункты категории по одному из признаков, щелкните на заголовке соответствующего столбца. Повторный щелчок на том же заголовке приводит к смене порядка сортировки на обратный.

  5. В раскрывающемся списке ячейки Состояние (Status) этой задачи выберите пункт Завершена (Completed). Название данной задачи будет перечеркнуто в списках всех трех категорий, как показано на рис. 19.17.

Рис. 19.17. Просмотр задач по категориям

  6. Чтобы вернуть панель ярлыков Outlook, выберите команду Вид > Панель Outlook.

  7. Щелкните на ярлыке Outlook Сегодня. Вы увидите добавленные задачи ыи события календаря в списке, приготовленном программой на сегодняшний день.


Контрольное упражнение

Инструменты Outlook достаточно просты, но они предоставляют огромное количество разнообразных возможностей работы. Это контрольное упражнение поможет перейти к самостоятельному изучению тех компонентов и режимов, которые не были упомянуты в упражнениях занятия.

  1. Откройте календарь.

  2. Добавьте в список праздники и дни рождения друзей, назначив их событиями с периодичностью в один год.

  3. Добавьте две новые категории: Праздник и День рождения. Назначьте каждому из введенных событий одну из этих категорий.

  4. Измените режим просмотра календаря так, чтобы в бланке отображалось расписание трех последовательных дней следующей недели.

    • Как включить указанный режим просмотра?

  5. В поле отображения задач в окне календаря выберите режим вывода всех : (в том числе выполненных) задач. *

    • Как изменить режим списка задач в календаре ?

  6. Верните всем задачам статус невыполненных.

  7. Перейдите в календаре к отображению бланка текущего дня.

    • Как быстро перейти к бланку текущего дня?


Подведение итогов

На этом занятии вы познакомились с дневником событий, папкой заметок, календарем и списком задач, научились ориентироваться в инструментах навигации Outlook и переключать режимы просмотра папок этой программы. Теперь вы можете управлять файлами компьютера прямо из окна Outlook, не прибегая к помощи Проводника.

На следующем занятии будет рассмотрен пятый тип папок Outlook — Контакты. Вы научитесь записывать в эти папки информацию о человеке и пользоваться сохраненными контактами при отправке электронных сообщений, планировании встреч и совещаний.


Занятие №2

Приложения Microsoft Office XP

ТЕМА ЗАНЯТИЯ

В пакет Microsoft Office XP входит шесть основных приложений, каждое из которых может рассматриваться как самостоятельная программа Windows. На этом занятии вы познакомитесь со структурой окон приложений Office, узнаете о назначении и приемах работы с основными типами документов Office, которые перечислены ниже:

  • документ Word;
  • лист Excel;
  • презентация PowerPoint;
  • база данных Access;
  • папки Outlook;
  • web-узел Frontpage.

Пакет Microsoft Office XP, как и предыдущие версии, — это не просто совокупность равноправных программ, выполняющих различные функции, например управление базой данных или расчеты в электронных таблицах. Шесть основных приложений тесно связаны друг с другом. Это наделяет программы некоторыми полезными свойствами.

  • Все продукты имеют сходный интерфейс.
  • Документы, созданные в одной программе, легко переносятся в другие. Для этого достаточно просто перетащить фрагмент данных из окна одной программы в окно другой,
  • Пакет Office содержит множество дополнительных модулей, доступных в любом приложении пакета. Эти модули позволяют вставлять определенные структуры (например, организационные диаграммы) и приукрашивать документы.
  • Вы можете организовать связь файлов. Если в процессе вставки данных одного документа в другой создать связь, то при изменении первого документа содержимое второго будет обновляться автоматически.
  • Программы Office обеспечивают доступ к Интернету, что позволяет обновлять пакет и получать справочную информацию непосредственно с web-узла Microsoft.

Окна приложений Office

Любое приложение Windows открывается в своем окне. Это обеспечивает равноправность всех программ, одновременную работу с несколькими приложениями и возможность перемещения данных между двумя программами.

Упражнение 1. Окно приложения

Окно каждой программы имеет стандартные системные элементы управления и поддерживает операции перемещения и изменения размера.

  1. Щелкните на кнопке Пуск (Start) и выберите команду Программы > Microsoft Excel (Programs > Microsoft Excel). Затем еще раз раскройте Главное меню и выберите пункт Программы > Microsoft Frontpage (Programs > Microsoft Frontpage). Теперь рабочий стол Windows будет выглядеть примерно так, как показано на рис. 2.1. Заголовок окна активного приложения (в данном случае Front-page) всегда окрашен ярким цветом. Заголовки остальных окон серые.
  2. Щелчком на кнопке Развернуть (Maximize) окна Frontpage увеличьте это окно до размеров экрана.
  3. Повторным щелчком на той же кнопке восстановите прежние размеры окна.
  4. Щелкните на значке приложения Frontpage, расположенном в левой части заголовка окна.

Рис. 2.1. Окна двух приложений на рабочем столе Windows

  5. В раскрывшемся системном меню окна выберите команду Свернуть (Minimize). Окно Frontpage исчезнет с экрана, но сама программа останется в памяти компьютера, на что указывает значок Панели задач. Активным станет окно Excel.
  6. Переместите указатель на правый верхний угол рамки окна Excel, чтобы значок мыши превратился в двунаправленную стрелку. Нажмите кнопку мыши и, не отпуская ее, тащите угол в любую сторону. Масштабировав окно до нужных размеров, отпустите кнопку мыши.
  7. Захватив окно Excel за заголовок, перетащите его мышью в другую область экрана.
  8. Щелчком на кнопке Панели задач восстановите окно FrontPage.
  9. Чтобы закрыть FrontPage, щелкните на кнопке с косым крестом в правой части заголовка окна программы.
  10. Двойным щелчком на значке системного меню Excel закройте и это приложение.

Обратите внимание, что окна Office подчиняются общим правилам поведения окон Windows. Если вы уже работали с другими программами этой операционной среды, приложения Office покажутся вам знакомыми уже с первых шагов работы с ними.

Примечание

Системное меню позволяет выполнять все основные операции с окнами приложений. С клавиатуры системное меню раскрывается нажатием клавиш Alt+Пробел. Чтобы появилось системное меню приложения, свернутого в кнопку Панели задач, щелкните на этой кнопке правой кнопкой мыши.

Упражнение 2. Окна документов

Любое приложение Office может работать сразу с несколькими документами. Каждый документ открывается в отдельном окне, которое можно развернуть, свернуть и масштабировать точно так же, как и основное окно приложения.

  1. Чтобы открыть очередной документ в Word, Excel или PowerPoint, выберите команду Файл > Открыть (File > Open).
  2. Дважды щелкните в окне диалога открытия документа на нужном файле. Внутри основного окна приложения появится окно второго документа, как показано на рис. 2.2.

Рис. 2.2. Два документа в окне Excel

Открыв несколько файлов, вы можете перемещать и копировать данные из одного документа в другой. В целях повышения удобства программы Word и Excel позволяют разделять окно документа на несколько частей. Это дает возможность одновременно просматривать различные фрагменты одного и того же файла в одном окне.

  3. Чтобы разделить окно, выполните команду Окно > Разделить (Window > Split). Примером такого поделенного окна служит документ Книга З (см. рис. 2.2). Обратите внимание, что одну и ту же ячейку можно видеть во всех четырех областях указанного окна. Документы Access и Outlook имеют сложную структуру и состоят из набора объектов. В этих программах нельзя одновременно открыть два файла, но каждый объект файла можно рассматривать как отдельный документ, отображаемый в своем окне. Во Frontpage открытая web-страница всегда занимает все пространство окна приложения, хотя одновременно можно открыть несколько таких страниц и переключаться между ними с помощью меню Окно (Window). Открытие нового web-узла ведет к появлению дубликата Главного окна Frontpage.
  4. Чтобы открыть окно объекта в Access, дважды щелкните в окне базы данных на значке одного из объектов. Несколько таких окон показаны на рис. 2.3.
  5. Для открытия нового окна Frontpage выберите команду Окно > Новое (Window > New Window). Такая команда есть и в других приложениях Office. Она позволяет открывать дубликат окна документа, что удобно при сравнении разных фрагментов одного и того же файла, копировании или перемещении данных внутри документа.

Команды меню Окно (Window), показанного на рис. 2.3, позволяют не только создавать и разделять окна, но также переключаться между окнами и упорядочивать открытые окна документов каскадом или мозаикой.

Рис. 2.3. Окна объектов базы данных Access

Примечание

В Office XP существует и другой способ переключения между документами. Каждый документ появляется в виде значка Панели задач. На рис. 2.3 видно, что наряду со значками Word и Frontpage в Панели задач присутствуют три значка объектов базы данных Access. Окно документа активизируется простым щелчком на таком значке Панели задач. Переключаться между документами в Office XP можно и с помощью комбинации клавиш Alt+Tab. Если в рассматриваемом примере нажать Alt+Tab, а затем отпустить Tab, не отпуская клавишу Alt, на экране появится окно переключения между приложениями. Последовательными нажатиями клавиши Tab можно выбрать не только другое приложение, но и другой объект Access. Переместив квадратную рамку на соответствующий значок, отпустите клавишу Alt, и система сразу перенесет вас в окно выбранного объекта.

В заголовке окна документа есть все те же элементы управления, которые свойственны окну приложения. Они позволяют разворачивать, сворачивать, масштабировать, перемещать и закрывать окна документов.

Word

Microsoft Word — мощный текстовый процессор. С его помощью можно нс только отформатировать и красиво оформить многостраничный текст, но даже полностью сверстать небольшую книгу.

Упражнение 3. Окно Word

Давайте изучим структуру программы Word и ее документов.

  1. Запустите Word и выберите команду Файл > Создать (File > New). В правой части экрана появляется окно Область задач (Task Pane), в котором предлагаются различные варианты создания нового документа:
  • Создание (New) — создание нового документа;
  • Создание из имеющегося документа (New from existing document);
  • Создание с помощью шаблона (New from template)

Примечание

Область задач (Task Pane) — новая особенность Office XP. Это окно, располагающееся в правой части окна приложения. Во всех приложениях оно имеет подобный вид. С его помощью можно производить стандартные операции открытия существующего файла, создания новых файлов, работать с буфером обмена, осуществлять поиск. Помимо этого, в окне области задач имеются возможности совершения операций, характерных для каждого конкретного приложения. Во время работы с приложением это окно всегда можно вызвать на экран, выбрав команду Область задач (Task Pane) меню Вид (View).

  2. В последнем из перечисленных разделов щелкните на пункте Общие шаблоны (General Templates) и в появившемся окне диалога Шаблоны (Templates) раскройте вкладку Другие документы (Other Documents). Дважды щелкните на значке Современное резюме (Professional Resume).

Появится документ, созданный на базе выбранного шаблона. Такие шаблоны позволяют автоматически наполнять новые документы заранее подготовленным стандартным содержанием и оформлением. Например, вы можете создать шаблон с логотипом фирмы и пользоваться им при подготовке официальных писем вашей фирмы.

  3. Документ открылся в режиме разметки страницы, который демонстрирует расположение текста на страницах. Чтобы перейти в обычный режим просмотра, выберите команду Вид > Обычный (View > Normal). Результат показан на рис. 2.4.

Рис. 2.4. Окно Word

Как видно из рисунка, окно Word обладает всеми стандартными элементами текстового процессора. В заголовок выводится название документа. Строка меню обеспечивает доступ к командам. Панели инструментов содержат кнопки самых популярных операций. Строка состояния сообщает о количестве страниц и разделов в документе, обозначает текущее положение текстового курсора и содержит индикаторы некоторых режимов программы. Вертикальная полоса прокрутки обеспечивает быстрое перемещение по тексту документа вверх и вниз. Здесь есть линейка, облегчающая выравнивание объектов, и кнопки смены режимов просмотра документа.

Упражнение 4. Структура документа

Поскольку программа Word предназначена для обработки текста, то документ Word в основном состоит из символов, слов и абзацев. В обычном режиме просмотра текст не разбивается на страницы, однако его ширина ограничена шириной страницы, заданной для документа. Строки внутри абзаца переносятся автоматически, а нажатие клавиши Enter формирует переход к следующему абзацу. Кроме обычных букв, цифр и знаков в тексте Word присутствуют специальные управляющие непечатаемые символы (рис. 2.5).

Рис. 2.5. Непечатаемые символы Word

  1. Для вывода на экран непечатаемых символов щелкните на кнопке Непечатаемые знаки (Show/Hide) панели инструментов Стандартная (Standard).
  2. Чтобы получше рассмотреть документ, щелкните в той же панели инструментов на стрелке раскрывающегося списка Масштаб (Zoom) и выберите пункт

По ширине страницы (Page Width). Теперь текст выглядит так, как показано на рис. 2.5. Режим демонстрации непечатаемых символов облегчает разметку документа и позволяет разобраться в его структуре. Знаки конца ячейки говорят о том, что текст, показанный на рис. 2.5, построен в виде таблицы, хотя рамка этой таблицы невидима.

Примечание

Если нужной кнопки нет на панели инструментов, щелкните на маленьком треугольнике на правом краю панели и найдите кнопку в раскрывшейся палитре.

  3. Чтобы скрыть непечатаемые символы, повторно щелкните на кнопке Непечатаемые знаки (Show/Hide). В документе Word всегда присутствует текстовый курсор, который отображается в виде вертикальной мерцающей черты. Ввод текста выполняется в точке расположения курсора. Перемещается курсор с помощью клавиш со стрелками или щелчком мыши. Word поддерживает два режима ввода символов. Если в строке состояния индикатор ЗАМ (OVR) яркий, вводимые символы замещают знаки, расположенные справа от курсора. Если индикатор тусклый, то символы добавляются в текст в точке курсора. Режимы замещения/вставки переключаются клавишей Insert.
  4. Благодаря усовершенствованной поддержке формата HTML вы можете быстро превратить любой документ в web-страницу и опубликовать его на web-узле компании. Чтобы преобразовать документ Word в web-страницу, выберите команду Файл > Сохранить как web-страницу (File > Save As Web Page), в окне диалога сохранения файла введите имя HTML-файла и щелкните на кнопке Сохранить (Save).
  5. Выберите команду Файл > Предварительный просмотр web-страницы (File > Web Page Preview). Word откроет полученную web-страницу в окне стандартного браузера.

Excel

Электронные таблицы служат для расчетов с табличными данными, построения на их основе диаграмм и вывода полученной информации на печать в виде аккуратно оформленных листов с таблицами, заголовками и пояснительными надписями.

Упражнение 5. Лист Excel

Чтобы понять принципы построения документов Excel, которые называются книгами, давайте создадим простую электронную таблицу.

  1. Запустите Excel. В окне этого приложения появится чистый лист с ячейками; В книге Excel может быть сколько угодно листов, которые расположены на отдельных вкладках. При создании нового документа появляются три чистых листа, корешки которых видны в нижней части окна документа. Строки ячеек пронумерованы цифрами, а столбцы ячеек названы буквами английского алфавита. Любая ячейка имеет индивидуальный идентификатор, образующийся слиянием буквы столбца и цифры строки. Верхняя левая ячейка А1 окружена рамкой. Эта рамка указывает на активную ячейку, в которую можно вводить данные. В верхней части окна Excel под панелью инструментов расположена строка формул для ввода данных или формул, на основе которых выполняются расчеты. Слева от строки формул демонстрируется номер активной ячейки.
  2. Введите текст Тренировочная таблица и два раза нажмите клавишу Enter.
  3. Сместитесь на одну ячейку вправо. Для перемещения по ячейкам листа Excel пользуйтесь клавишами со стрелками, клавишами Enter или Tab либо просто щелкайте на той клетке, содержимое которой нужно изменить.
  4. Введите текст 1 квартал.
  5. Сместитесь на одну ячейку вправо и введите текст 2 квартал.
  6. Продолжайте ввод данных, пока таблица не станет такой, как показано на рис. 2.6.

Рис. 2.6. Лист Excel

Упражнение 6. Графическое представление информации

Теперь на основе введенных данных можно построить диаграмму. В пакете Office есть стандартная программа построения графиков и диаграмм — Microsoft Chart. Однако Excel имеет для этих целей собственный модуль, возможности которого несколько шире.

  1. Выберите команду Вставка > Диаграмма (Insert > Chart). Откроется окно диалога Мастер диаграмм (Chart Wizard).
  2. Щелкните на кнопке Далее (Next). Откроется второе окно мастера, в котором вас попросят указать ячейки с теми данными, на основе которых следует строить диаграммы.
  3. Щелкните в листе Excel на ячейке A3.
  4. Нажмите клавишу Shift и, не отпуская ее, щелкните на ячейке Е7.
  5. В окне диалога мастера выберите положение переключателя строках (Rows). В области просмотра появится диаграмма, показанная на рис. 2.7.
  6. В окне мастера диаграмм щелкните два раза на кнопке Далее (Next), а затем на кнопке Готово (Finish). На лист рядом с таблицей будет вставлена диаграмма, отражающая введенные данные в графической форме.
  7. Захватите сформированную диаграмму мышью и перетащите ее под таблицу данных, разместив так, как показано на рис. 2.8.
  8. Щелкните на кнопке Печать (Print) панели инструментов Стандартная (Standard), чтобы распечатать полученный лист.

Рис. 2.7. Выбор ячеек для построения диаграммы

Рис. 2.8. Лист Excel с диаграммой

PowerPoint

Теперь вы познакомитесь с презентацией PowerPoint — современным способом представления самой разной информации. Презентация состоит из серии слайдов с определенным содержанием. Эти слайды можно распечатать на бумаге и пленке или показать их на большом экране в виде электронного слайд-шоу. С помощью PowerPoint можно быстро подготовить красочно оформленные материалы для доклада.

Упражнение 7. Презентация PowerPoint

  1. Выберите в Главном меню команду Программы > Microsoft PowerPoint (Programs > Microsoft PowerPoint).
  2. В правой части экрана в открывшейся области задач PowerPoint в разделе Создание (New) щелкните на значке Из мастера автосодержания (From AutoContent Wizard).
  3. В окне мастера автосодержания щелкните на кнопке Далее (Next). В списке второго окна мастера щелкните на строке Общий доклад (Generic). Затем щелкните на кнопке Далее (Next).
  4. Еще два раза щелкните на кнопке Далее (Next) и, наконец, щелкните на кнопке Готово (Finish). На экране появится презентация, показанная на рис. 2.9. В левой части окна отображается текстовое содержание презентации. Жирным шрифтом выделены заголовки слайдов. Справа вверху демонстрируется текущий слайд.
  5. Чтобы последовательно просмотреть все слайды презентации, щелкните в расположенной справа области слайда, затем нажимайте для смены слайдов клавиши Page Down и Page Up или щелкайте на кнопках полосы прокрутки. Презентации, создаваемые с помощью мастера автосодержания, уже наполнены определенным текстом и имеют привлекательный дизайн.

Примечание

Текст можно заменять и на самих слайдах. Если на слайде присутствует область, обведенная пунктирной рамкой, щелкните в ней. Она обозначает ту часть слайда, где должен размещаться текст. Служебная надпись, которая не отображается в содержании презентации, исчезнет, и вы сможете сразу ввести требуемую информацию. Такие пунктирные рамки называются местозаполнителями, они видны на первом слайде презентации.

  6. Для замены стандартного текста своей информацией щелкайте на строках области содержания презентации, удаляйте текст, сгенерированный мастером, и вводите свой.

Рис. 2.9. Презентация PowerPoint

Упражнение 8. Электронное слайд-шоу

Если в вашем распоряжении есть большой дисплей или компьютерный проектор, электронную презентацию можно демонстрировать в большом конференц-зале. Такой способ проведения доклада дает много неоспоримых преимуществ. Вы можете приукрасить слайды разнообразными переходами, когда абзацы, строки или элементы диаграмм выводятся на экран поочередно как раз в тот момент, когда докладчик ссылается на них. Электронное слайд-шоу позволяет показать видеоролик и воспроизвести текст докладчика. В слайд-фильм можно внедрить документ другого приложения, например чертежи проекта, которые открываются в ходе презентации и демонстрируют вспомогательную информацию.

Чтобы добавить в слайд-фильм специальные эффекты, выполните следующие шаги.

  1. Щелкните на кнопке Режим сортировщика слайдов (Slide Sorter View), расположенной в левом нижнем углу окна презентации. Режим сортировщика на рис. 2.10 позволяет показать сразу все слайды. Этот режим удобен для перестановки слайдов и настройки переходов. Мастер автосодержания уже назначил переходы всем слайдам, кроме первого, о чем говорят значки перехода, расположенные под слайдами.

Рис. 2.10. Режим сортировщика слайдов

  2. Щелкните на кнопке Смена слайдов (Slide Change) панели инструментов сортировщика слайдов. В области задач приложения в правой части экрана появится окно Смена слайдов (Slide Change).
  3. Выберите в раскрывающемся списке Применить к выделенным слайдам (Apply to selected slide) пункт Появление снизу (Fly From Bottom) и щелкните на пятом слайде. Щелчком на кнопке Просмотр (Preview) можно запустить выбранный -эффект, а в разделе Изменить переход (Modify Transition) установить скорость перехода.
  4. Аналогичным способом назначьте шестому слайду анимацию Появление слева (Fly From Left), а седьмому — анимацию Прямоугольник наружу (Box Out).
  5. Щелкните на четвертом слайде.
  6. Выберите в списке пункт Наплыв вправо (Cover Right).
  7. Для второго и третьего слайдов выберите, соответственно, эффекты Жалюзи вертикальные (Blinds Vertical) и Растворение (Dissolve).
  8. Чтобы просмотреть слайд-шоу, выполните команду Показ слайдов > Начать Показ (Slide Show > View Show). Для перехода к последующим слайдам нажимайте клавишу Enter. Для завершения демонстрации нажмите клавишу Esc. Присмотритесь к переходам между слайдами 1,2,3 и 4. Обратите внимание, что текст слайдов 5,6 и 7 появляется не сразу. Очередной пункт списка всплывает при каждом последующем нажатии клавиши Enter.

Access

Базы данных в чем-то похожи па электронные таблицы. И те и другие оперируют с табличными данными. Но если электронные таблицы, как правило, используются для проведения расчетов, то основным предназначением баз данных является хранение больших массивов информации, их сортировка и поиск запрашиваемых данных. Программа Access — это интерактивная оболочка базы данных, позволяющая не только работать с информацией, но и оперативно изменять структуру таблиц, форм и отчетов.

Упражнение 9. База данных Access

Чтобы создать базу данных, выполните следующие шаги.

  1. Запустите Access и в открывшемся окне Microsoft Access выберите положение переключателя Новая база данных (Blank Access Database), а затем щелкните на кнопке ОК.
  2. В окне диалога Файл новой базы данных (File New Database) укажите папку и имя файла создаваемой базы данных и щелкните на кнопке Создать (Create). Откроется окно базы данных, показанное на рис. 2.11. В его левой части есть кнопки, раскрывающие списки групп однотипных объектов базы данных, таких как таблицы, формы или отчеты.
  3. Дважды щелкните на пункте Создание таблицы путем ввода данных (Create Table By Entering Data).
  4. Введите в ячейки открывшейся таблицы какие-нибудь данные. Для перемещения но клеткам пользуйтесь клавишами со стрелками. Пример небольшой таблицы показан па рис. 2.12.

Рис. 2.11. Окно новой базы данных

Примечание

База данных состоит из однотипных записей. Такая запись содержит одно или несколько полей. Таблица является хранилищем записей. В таблице Access каждой записи соответствует одна строка, а каждому полю свой столбец.

  5. Щелчком на кнопке с косым крестом закройте окно таблицы.
  6. При появлении запроса о необходимости сохранения модифицированной структуры таблицы щелкните на кнопке Да (Yes).
  7. В текстовое поле открывшегося окна диалога Сохранение (Save As) введите имя таблицы, например Таблица данных, и щелкните на кнопке ОК.
  8. 8. В окне, запрашивающем о необходимости добавления ключевого поля, щелкните на кнопке Нет (No). В окне базы данных появится значок вновь созданной таблицы.

Рис. 2.12. Создание таблицы путем ввода данных

Упражнение 10. Формы

Формы предназначены для ввода, изменения и просмотра записей базы данных. Формы позволяют отображать содержимое таблицы в отформатированном виде.

Чтобы создать форму для таблицы, построенной в предыдущем упражнении, выполните следующие действия.

  1. В левом поле окна базы данных щелкните на кнопке Формы (Forms).
  2. В правом поле того же окна дважды щелкните на строке Создание формы с помощью мастера (Create Form By Using Wizard).
  3. В первом окне мастера щелкните на кнопке », чтобы поместить в форму все поля таблицы данных. Затем щелкните на кнопке Далее (Next).
  4. Во втором окне мастера выберите положение переключателя Выровненный (Justified), а затем щелкните на кнопке Далее (Next).
  5. Еще раз щелкните на кнопке Далее (Next) и затем на кнопке Готово (Finish). Появится окно формы (рис. 2.13) с четырьмя полями, соответствующими столбцам таблицы данных. Одновременно значок новой формы появится в окне базы данных. С помощью формы можно просматривать и изменять информацию. Для перемещения по записям пользуйтесь кнопками в нижней части окна формы.

Рис. 2.13. Форма

  6. Чтобы с помощью формы добавить в таблицу данных новую запись, щелк ните в нижнем ряду на самой правой кнопке.
  7. Заполните четыре пустых поля в соответствии с рис. 2.14.
  8. Закройте окно формы.

Рис. 2.14. Добавление записи в таблицу

Упражнение 11. Отчеты

Отчеты предназначены для печати информации, хранящейся в базе данных. Чтобы распечатать таблицу, созданную в упражнении 9, выполните следующие шаги:

  1. В левом поле окна базы данных щелкните на кнопке Отчеты (Reports).
  2. В списке того же окна дважды щелкните на значке Создание отчета с помощью мастера (Create Report By Using Wizard).
  3. Чтобы поместить в отчет все поля, щелкните в первом окне мастера отчетов на кнопке », а затем на кнопке Далее (Next).
  4. Щелкните на кнопке Далее (Next) еще четыре раза, затем щелкните на кнопке Готово (Finish). Откроется окно предварительного просмотра отчета, показанное па рис. 2.15. Здесь можно проверить правильность оформления отчета.

Рис. 2.15. Отчет

  5. Чтобы распечатать отчет, щелкните на кнопке Печать (Print) панели инструментов.
  6. Закройте окно Access. Новые объекты и модифицированные данные автоматически заносятся в файл базы данных, поэтому нет нужды вручную сохранять какую-либо информацию. Закрываясь, программа Access сама позаботится о записи данных на жесткий диск.

Outlook

Outlook выполняет множество полезных функции. Эта программа позволяет отправлять и получать электронную почту, планировать ваше расписание, составлять списки задач и контактов и даже управлять документами. Outlook не только грамотно структурирует работу с документами. Эта программа может взять на себя планирование всех ваших дел.

Упражнение 12. Папки Outlook

Запустив Outlook, вы увидите окно, показанное на рис. 2.16. В левой части находится список папок и ярлыков Outlook, которые объединены в группы. Справа выводится содержимое активной папки. Каждая папка хранит информацию определенного типа, например входящие письма электронной почты или дневник событий.

Рис. 2.16. Окно Outlook XP

Примечание

Не путайте папки Outlook с папками жесткого диска. Это совершенно разные объекты. Если папка диска представляет собой каталог с файлами, то папка Outlook хранится внутри специальных файлов и доступна только из программы Outlook.

Давайте поближе познакомимся с папками Outlook.

  1. Чтобы найти нужную папку, щелкните в левой части окна Outlook на кноп ке группы Ярлыки Outlook (Outlook Shortcuts).
  2. С помощью кнопок со стрелками прокрутите панель к значку папки Кален дарь (Calendar).
  3. Щелкните на этом значке.
  4. Выберите команду Вид > День (View > Day). В окне Outlook появится ежеднев ник, календарь па два месяца и список задач, как показано на рис. 2.17.
  5. Щелкните в календаре на завтрашнем дне.
  6. В ежедневнике щелкните в графе 10:00 и введите текст Встреча с заказчиком. Теперь Outlook вовремя напомнит вам о запланированной встрече.
  7. В левой панели Outlook щелкните на значке Контакты (Contacts). Откроется папка контактов с информацией о поставщиках, клиентах и других людях и фирмах. Эта папка играет роль записной книжки.

Рис. 2.17. Календарь

  8. Щелкните на кнопке Создать (New) панели инструментов. Откроется окно нового контакта.
  9. Введите фамилию, должность, телефоны и другие данные о человеке, контакт с которым нужно сохранить.
  10. Щелкните на кнопке Сохранить и закрыть (Save and Close) панели инструментов. Добавленная информация появится в папке контактов.

Упражнение 13. Электронная почта

Одна из важных возможностей Outlook — управление почтовой системой. На занятии 21 будет подробно рассказано о возможностях почтового клиента Outlook и способах настройки службы электронной почты. Сейчас давайте научимся читать и отправлять письма.

  1. Щелкните в левой панели Outlook на значке Входящие (Inbox). Откроется ' папка входящих писем, которая автоматически появляется на экране при запуске Outlook. В ее верхней части расположен список всех пришедших писем, а в нижней — содержимое выбранного письма.
  2. В верхней части окна папки Входящие (Inbox) дважды щелкните на строке одного из писем. Откроется окно сообщения, показанное на рис. 2.18.
  3. Для просмотра всех имеющихся сообщений щелкайте на кнопках Назад (Previous Item) и Далее (Next Item).
  4. Чтобы немедленно ответить на письмо, щелкните на кнопке Ответить (Reply).
  5. В окне нового сообщения введите текст письма и выберите команду Файл > Отправить (File > Send). Письмо будет отправлено адресату в первом же сеансе связи с почтовым сервером.

Рис. 2.18. Входящее сообщение в отдельном окне

FrontPage

Frontpage — это редактор HTML-документов, с помощью которого можно не только наполнить содержанием отдельную web-страницу, но также построить целый web-узел, все компоненты которого будут иметь однотипное оформление, и опубликовать его в Интернете.

Примечание

Программа Frontpage — это новый, шестой компонент Microsoft Office. В Office 97 для редактирования web-страниц приходилось пользоваться программой Word либо экспортировать документы других приложений Office в формат HTML. Теперь в вашем распоряжении есть Frontpage ХР — прекрасный редактор web-документов.

Упражнение 14. Построение web-узла

Для того чтобы создать собственный web-узел, выполните следующие действия.

  1. Запустите Frontpage и выполните команду Файл > Создать > Страница или web-узел? (File > New > Page or Web).
  2. В области задач в разделе Создание с помощью шаблона (New from Templates) щелкните на значке Шаблоны web-узлов (Web Site Templates) и в появившемся одноименном окне диалога дважды щелкните на значке Личный web-узел (Personal Web). Мастер построения web-узла сформирует необходимые HTML-файлы, построит пять web-страниц и добавит на них рисунки.

Щелчком на кнопке Создать (New) панели инструментов Стандартная (Standard) добавьте еще одну обычную страницу к созданному мастером web-узлу и введите текст в соответствии с рис. 2.19.

Рис. 2.19. Новая web-страница

Расположенная слева панель режимов Frontpage позволяет выбирать различные варианты просмотра web-узла — открыть окно редактирования страницы, вывести общую структуру узла, просмотреть имеющиеся гиперссылки, сформировать отчеты о содержимом web-узла и увидеть другую информацию. Вкладки web-страницы дают возможность отображать содержимое в стандартном виде, в текстовом режиме HTML-документа и в режиме предварительного просмотра страницы.

  3. Щелкните на кнопке Сохранить (Save) панели инструментов Стандартная (Standard), в поле Имя файла (File Name) открывшегося окна диалога введите имя pagel и щелкните на кнопке Сохранить (Save). ;
  4. Щелчком на значке Переходы (Navigation) переключитесь в режим навигатора. В левой части окна навигатора выводится список файлов и папок web-узла, 1а в правой демонстрируется структура подчиненности web-страниц узла (рис. 2.21).
  5. Переместите указатель на значок файла pagel.htm.
  6. Нажмите левую кнопку мыши и перетащите значок в правое поле навигатора, чтобы пунктирная линия связала прямоугольник новой страницы с прямоугольником Home Page (Домашняя страница).
  7. В списке файлов дважды щелкните на значке index.htm. Домашняя страница узла откроется в режиме редактора страниц.
  8. В левом поле домашней страницы находится панель ссылок, щелкните на ней правой кнопкой мыши и выберите в контекстном меню пункт Свойства панели ссылок (Link Bar Properties).
  9. В открывшемся окне диалога укажите, какие ссылки необходимо поместить в панель ссылок.
  10. Щелкните на кнопке ОК.
    • Для домашней страницы (файл Index, htm) следует выбрать положение переключателя Дочерний уровень (Child level) и сбросить флажки Домашняя страница (Home Page) и Родительская страница (Parent Page).
    • Для остальных страниц следует выбрать положение переключателя Тот же уровень (Same Level) и установить флажок (Home Page).
  11. Повторяйте указанные действия для всех имеющихся панелей навигации страницы.
  12. Щелчком на кнопке Переходы (Navigation) вернитесь в режим навигатора и в списке компонентов узла дважды щелкните на другом файле с расширением HTM. Настройте панели навигации второй web-страницы. Указанным способом переберите все страницы узла и настройте их панели навигации. Немного попрактиковавшись, вы научитесь модифицировать панели по своему вкусу. Завершая редактирование очередной страницы, для сохранения изменений щелкайте на кнопке Сохранить (Save) панели инструментов.
  13. Выполните команду Файл > Просмотр в обозревателе (File > Preview In Browser). В открывшемся окне диалога выберите тип браузера и размер окна просмотра. Затем щелкните на кнопке Просмотр (Preview).
    • Текущая страница web-узла появится в окне браузера. В верхней части страницы находится стандартный баннер и кнопки ссылок на страницы web-узла. Слева расположена панель со ссылками, щелчки на которых перенесут вас к тем пяти страницам, которые были автоматически построены мастером web-узла.

  14. Щелкая на гиперссылках, изучите структуру узла, а затем закройте окно браузера.
  15. Чтобы опубликовать созданный узел в Интернете, выберите команду Файл > Опубликовать узел (File > Publish Web).
  16. В открывшемся окне диалога введите адрес, по которому должен располагаться web-узел, и щелкните на кнопке Опубликовать (Publish). Теперь ваш новый узел станет доступен всему сообществу Интернета.

Контрольное упражнение

Пришло время проверить, насколько хорошо вы освоили базовые операции приложений Office.

  1. Запустите Excel и Access.
  2. Откройте базу данных, созданную на этом занятии.
    • Как в Access открыть имеющуюся базу данных?
  3. Удалите третью запись базы данных.
    • Какими двумя способами можно удалить запись базы данных?
  4. Переключитесь в окно Excel.
  5. Откройте электронную таблицу, построенную на этом занятии.
  6. Удалите содержимое ячеек D6, D7, Еб и Е7.
    • Как в Excel удалить содержимое группы ячеек?
  7. Скопируйте заголовок таблицы Excel в текстовое поле новой записи базы данных Access.
    • Как скопировать данные из ячейки электронной таблицы в поле базы данных?
  8. Закройте Excel и Access.

Подведение итогов

На этом занятии вы познакомились с шестью основными приложениями Office ХР, научились создавать текстовые документы и электронные таблицы, строить презентации и заполнять базы данных, просматривать и отправлять электронные сообщения, конструировать web-узлы.

На следующем занятии будут рассмотрены вопросы взаимодействия приложений Office с операционной системой Windows.


Занятие №2

Приложения Microsoft Office XP

ТЕМА ЗАНЯТИЯ

В пакет Microsoft Office XP входит шесть основных приложений, каждое из которых может рассматриваться как самостоятельная программа Windows. На этом занятии вы познакомитесь со структурой окон приложений Office, узнаете о назначении и приемах работы с основными типами документов Office, которые перечислены ниже:

  • документ Word;
  • лист Excel;
  • презентация PowerPoint;
  • база данных Access;
  • папки Outlook;
  • web-узел Frontpage.

Пакет Microsoft Office XP, как и предыдущие версии, — это не просто совокупность равноправных программ, выполняющих различные функции, например управление базой данных или расчеты в электронных таблицах. Шесть основных приложений тесно связаны друг с другом. Это наделяет программы некоторыми полезными свойствами.

  • Все продукты имеют сходный интерфейс.
  • Документы, созданные в одной программе, легко переносятся в другие. Для этого достаточно просто перетащить фрагмент данных из окна одной программы в окно другой,
  • Пакет Office содержит множество дополнительных модулей, доступных в любом приложении пакета. Эти модули позволяют вставлять определенные структуры (например, организационные диаграммы) и приукрашивать документы.
  • Вы можете организовать связь файлов. Если в процессе вставки данных одного документа в другой создать связь, то при изменении первого документа содержимое второго будет обновляться автоматически.
  • Программы Office обеспечивают доступ к Интернету, что позволяет обновлять пакет и получать справочную информацию непосредственно с web-узла Microsoft.


Окна приложений Office

Любое приложение Windows открывается в своем окне. Это обеспечивает равноправность всех программ, одновременную работу с несколькими приложениями и возможность перемещения данных между двумя программами.


Упражнение 1. Окно приложения

Окно каждой программы имеет стандартные системные элементы управления и поддерживает операции перемещения и изменения размера.

  1. Щелкните на кнопке Пуск (Start) и выберите команду Программы > Microsoft Excel (Programs > Microsoft Excel). Затем еще раз раскройте Главное меню и выберите пункт Программы > Microsoft Frontpage (Programs > Microsoft Frontpage). Теперь рабочий стол Windows будет выглядеть примерно так, как показано на рис. 2.1. Заголовок окна активного приложения (в данном случае Front-page) всегда окрашен ярким цветом. Заголовки остальных окон серые.
  2. Щелчком на кнопке Развернуть (Maximize) окна Frontpage увеличьте это окно до размеров экрана.
  3. Повторным щелчком на той же кнопке восстановите прежние размеры окна.
  4. Щелкните на значке приложения Frontpage, расположенном в левой части заголовка окна.

Рис. 2.1. Окна двух приложений на рабочем столе Windows

  5. В раскрывшемся системном меню окна выберите команду Свернуть (Minimize). Окно Frontpage исчезнет с экрана, но сама программа останется в памяти компьютера, на что указывает значок Панели задач. Активным станет окно Excel.
  6. Переместите указатель на правый верхний угол рамки окна Excel, чтобы значок мыши превратился в двунаправленную стрелку. Нажмите кнопку мыши и, не отпуская ее, тащите угол в любую сторону. Масштабировав окно до нужных размеров, отпустите кнопку мыши.
  7. Захватив окно Excel за заголовок, перетащите его мышью в другую область экрана.
  8. Щелчком на кнопке Панели задач восстановите окно FrontPage.
  9. Чтобы закрыть FrontPage, щелкните на кнопке с косым крестом в правой части заголовка окна программы.
  10. Двойным щелчком на значке системного меню Excel закройте и это приложение.

Обратите внимание, что окна Office подчиняются общим правилам поведения окон Windows. Если вы уже работали с другими программами этой операционной среды, приложения Office покажутся вам знакомыми уже с первых шагов работы с ними.

Примечание

Системное меню позволяет выполнять все основные операции с окнами приложений. С клавиатуры системное меню раскрывается нажатием клавиш Alt+Пробел. Чтобы появилось системное меню приложения, свернутого в кнопку Панели задач, щелкните на этой кнопке правой кнопкой мыши.


Упражнение 2. Окна документов

Любое приложение Office может работать сразу с несколькими документами. Каждый документ открывается в отдельном окне, которое можно развернуть, свернуть и масштабировать точно так же, как и основное окно приложения.

  1. Чтобы открыть очередной документ в Word, Excel или PowerPoint, выберите команду Файл > Открыть (File > Open).
  2. Дважды щелкните в окне диалога открытия документа на нужном файле. Внутри основного окна приложения появится окно второго документа, как показано на рис. 2.2.

Рис. 2.2. Два документа в окне Excel

Открыв несколько файлов, вы можете перемещать и копировать данные из одного документа в другой. В целях повышения удобства программы Word и Excel позволяют разделять окно документа на несколько частей. Это дает возможность одновременно просматривать различные фрагменты одного и того же файла в одном окне.

  3. Чтобы разделить окно, выполните команду Окно > Разделить (Window > Split). Примером такого поделенного окна служит документ Книга З (см. рис. 2.2). Обратите внимание, что одну и ту же ячейку можно видеть во всех четырех областях указанного окна. Документы Access и Outlook имеют сложную структуру и состоят из набора объектов. В этих программах нельзя одновременно открыть два файла, но каждый объект файла можно рассматривать как отдельный документ, отображаемый в своем окне. Во Frontpage открытая web-страница всегда занимает все пространство окна приложения, хотя одновременно можно открыть несколько таких страниц и переключаться между ними с помощью меню Окно (Window). Открытие нового web-узла ведет к появлению дубликата Главного окна Frontpage.
  4. Чтобы открыть окно объекта в Access, дважды щелкните в окне базы данных на значке одного из объектов. Несколько таких окон показаны на рис. 2.3.
  5. Для открытия нового окна Frontpage выберите команду Окно > Новое (Window > New Window). Такая команда есть и в других приложениях Office. Она позволяет открывать дубликат окна документа, что удобно при сравнении разных фрагментов одного и того же файла, копировании или перемещении данных внутри документа.

Команды меню Окно (Window), показанного на рис. 2.3, позволяют не только создавать и разделять окна, но также переключаться между окнами и упорядочивать открытые окна документов каскадом или мозаикой.

Рис. 2.3. Окна объектов базы данных Access

Примечание

В Office XP существует и другой способ переключения между документами. Каждый документ появляется в виде значка Панели задач. На рис. 2.3 видно, что наряду со значками Word и Frontpage в Панели задач присутствуют три значка объектов базы данных Access. Окно документа активизируется простым щелчком на таком значке Панели задач. Переключаться между документами в Office XP можно и с помощью комбинации клавиш Alt+Tab. Если в рассматриваемом примере нажать Alt+Tab, а затем отпустить Tab, не отпуская клавишу Alt, на экране появится окно переключения между приложениями. Последовательными нажатиями клавиши Tab можно выбрать не только другое приложение, но и другой объект Access. Переместив квадратную рамку на соответствующий значок, отпустите клавишу Alt, и система сразу перенесет вас в окно выбранного объекта.

В заголовке окна документа есть все те же элементы управления, которые свойственны окну приложения. Они позволяют разворачивать, сворачивать, масштабировать, перемещать и закрывать окна документов.


Word

Microsoft Word — мощный текстовый процессор. С его помощью можно нс только отформатировать и красиво оформить многостраничный текст, но даже полностью сверстать небольшую книгу.


Упражнение 3. Окно Word

Давайте изучим структуру программы Word и ее документов.

  1. Запустите Word и выберите команду Файл > Создать (File > New). В правой части экрана появляется окно Область задач (Task Pane), в котором предлагаются различные варианты создания нового документа:
  • Создание (New) — создание нового документа;
  • Создание из имеющегося документа (New from existing document);
  • Создание с помощью шаблона (New from template)

Примечание

Область задач (Task Pane) — новая особенность Office XP. Это окно, располагающееся в правой части окна приложения. Во всех приложениях оно имеет подобный вид. С его помощью можно производить стандартные операции открытия существующего файла, создания новых файлов, работать с буфером обмена, осуществлять поиск. Помимо этого, в окне области задач имеются возможности совершения операций, характерных для каждого конкретного приложения. Во время работы с приложением это окно всегда можно вызвать на экран, выбрав команду Область задач (Task Pane) меню Вид (View).

  2. В последнем из перечисленных разделов щелкните на пункте Общие шаблоны (General Templates) и в появившемся окне диалога Шаблоны (Templates) раскройте вкладку Другие документы (Other Documents). Дважды щелкните на значке Современное резюме (Professional Resume).

Появится документ, созданный на базе выбранного шаблона. Такие шаблоны позволяют автоматически наполнять новые документы заранее подготовленным стандартным содержанием и оформлением. Например, вы можете создать шаблон с логотипом фирмы и пользоваться им при подготовке официальных писем вашей фирмы.

  3. Документ открылся в режиме разметки страницы, который демонстрирует расположение текста на страницах. Чтобы перейти в обычный режим просмотра, выберите команду Вид > Обычный (View > Normal). Результат показан на рис. 2.4.

Рис. 2.4. Окно Word

Как видно из рисунка, окно Word обладает всеми стандартными элементами текстового процессора. В заголовок выводится название документа. Строка меню обеспечивает доступ к командам. Панели инструментов содержат кнопки самых популярных операций. Строка состояния сообщает о количестве страниц и разделов в документе, обозначает текущее положение текстового курсора и содержит индикаторы некоторых режимов программы. Вертикальная полоса прокрутки обеспечивает быстрое перемещение по тексту документа вверх и вниз. Здесь есть линейка, облегчающая выравнивание объектов, и кнопки смены режимов просмотра документа.


Упражнение 4. Структура документа

Поскольку программа Word предназначена для обработки текста, то документ Word в основном состоит из символов, слов и абзацев. В обычном режиме просмотра текст не разбивается на страницы, однако его ширина ограничена шириной страницы, заданной для документа. Строки внутри абзаца переносятся автоматически, а нажатие клавиши Enter формирует переход к следующему абзацу. Кроме обычных букв, цифр и знаков в тексте Word присутствуют специальные управляющие непечатаемые символы (рис. 2.5).

Рис. 2.5. Непечатаемые символы Word

  1. Для вывода на экран непечатаемых символов щелкните на кнопке Непечатаемые знаки (Show/Hide) панели инструментов Стандартная (Standard).
  2. Чтобы получше рассмотреть документ, щелкните в той же панели инструментов на стрелке раскрывающегося списка Масштаб (Zoom) и выберите пункт

По ширине страницы (Page Width). Теперь текст выглядит так, как показано на рис. 2.5. Режим демонстрации непечатаемых символов облегчает разметку документа и позволяет разобраться в его структуре. Знаки конца ячейки говорят о том, что текст, показанный на рис. 2.5, построен в виде таблицы, хотя рамка этой таблицы невидима.

Примечание

Если нужной кнопки нет на панели инструментов, щелкните на маленьком треугольнике на правом краю панели и найдите кнопку в раскрывшейся палитре.

  3. Чтобы скрыть непечатаемые символы, повторно щелкните на кнопке Непечатаемые знаки (Show/Hide). В документе Word всегда присутствует текстовый курсор, который отображается в виде вертикальной мерцающей черты. Ввод текста выполняется в точке расположения курсора. Перемещается курсор с помощью клавиш со стрелками или щелчком мыши. Word поддерживает два режима ввода символов. Если в строке состояния индикатор ЗАМ (OVR) яркий, вводимые символы замещают знаки, расположенные справа от курсора. Если индикатор тусклый, то символы добавляются в текст в точке курсора. Режимы замещения/вставки переключаются клавишей Insert.
  4. Благодаря усовершенствованной поддержке формата HTML вы можете быстро превратить любой документ в web-страницу и опубликовать его на web-узле компании. Чтобы преобразовать документ Word в web-страницу, выберите команду Файл > Сохранить как web-страницу (File > Save As Web Page), в окне диалога сохранения файла введите имя HTML-файла и щелкните на кнопке Сохранить (Save).
  5. Выберите команду Файл > Предварительный просмотр web-страницы (File > Web Page Preview). Word откроет полученную web-страницу в окне стандартного браузера.


Excel

Электронные таблицы служат для расчетов с табличными данными, построения на их основе диаграмм и вывода полученной информации на печать в виде аккуратно оформленных листов с таблицами, заголовками и пояснительными надписями.


Упражнение 5. Лист Excel

Чтобы понять принципы построения документов Excel, которые называются книгами, давайте создадим простую электронную таблицу.

  1. Запустите Excel. В окне этого приложения появится чистый лист с ячейками; В книге Excel может быть сколько угодно листов, которые расположены на отдельных вкладках. При создании нового документа появляются три чистых листа, корешки которых видны в нижней части окна документа. Строки ячеек пронумерованы цифрами, а столбцы ячеек названы буквами английского алфавита. Любая ячейка имеет индивидуальный идентификатор, образующийся слиянием буквы столбца и цифры строки. Верхняя левая ячейка А1 окружена рамкой. Эта рамка указывает на активную ячейку, в которую можно вводить данные. В верхней части окна Excel под панелью инструментов расположена строка формул для ввода данных или формул, на основе которых выполняются расчеты. Слева от строки формул демонстрируется номер активной ячейки.
  2. Введите текст Тренировочная таблица и два раза нажмите клавишу Enter.
  3. Сместитесь на одну ячейку вправо. Для перемещения по ячейкам листа Excel пользуйтесь клавишами со стрелками, клавишами Enter или Tab либо просто щелкайте на той клетке, содержимое которой нужно изменить.
  4. Введите текст 1 квартал.
  5. Сместитесь на одну ячейку вправо и введите текст 2 квартал.
  6. Продолжайте ввод данных, пока таблица не станет такой, как показано на рис. 2.6.

Рис. 2.6. Лист Excel


Упражнение 6. Графическое представление информации

Теперь на основе введенных данных можно построить диаграмму. В пакете Office есть стандартная программа построения графиков и диаграмм — Microsoft Chart. Однако Excel имеет для этих целей собственный модуль, возможности которого несколько шире.

  1. Выберите команду Вставка > Диаграмма (Insert > Chart). Откроется окно диалога Мастер диаграмм (Chart Wizard).
  2. Щелкните на кнопке Далее (Next). Откроется второе окно мастера, в котором вас попросят указать ячейки с теми данными, на основе которых следует строить диаграммы.
  3. Щелкните в листе Excel на ячейке A3.
  4. Нажмите клавишу Shift и, не отпуская ее, щелкните на ячейке Е7.
  5. В окне диалога мастера выберите положение переключателя строках (Rows). В области просмотра появится диаграмма, показанная на рис. 2.7.
  6. В окне мастера диаграмм щелкните два раза на кнопке Далее (Next), а затем на кнопке Готово (Finish). На лист рядом с таблицей будет вставлена диаграмма, отражающая введенные данные в графической форме.
  7. Захватите сформированную диаграмму мышью и перетащите ее под таблицу данных, разместив так, как показано на рис. 2.8.
  8. Щелкните на кнопке Печать (Print) панели инструментов Стандартная (Standard), чтобы распечатать полученный лист.

Рис. 2.7. Выбор ячеек для построения диаграммы

Рис. 2.8. Лист Excel с диаграммой


PowerPoint

Теперь вы познакомитесь с презентацией PowerPoint — современным способом представления самой разной информации. Презентация состоит из серии слайдов с определенным содержанием. Эти слайды можно распечатать на бумаге и пленке или показать их на большом экране в виде электронного слайд-шоу. С помощью PowerPoint можно быстро подготовить красочно оформленные материалы для доклада.


Упражнение 7. Презентация PowerPoint

  1. Выберите в Главном меню команду Программы > Microsoft PowerPoint (Programs > Microsoft PowerPoint).
  2. В правой части экрана в открывшейся области задач PowerPoint в разделе Создание (New) щелкните на значке Из мастера автосодержания (From AutoContent Wizard).
  3. В окне мастера автосодержания щелкните на кнопке Далее (Next). В списке второго окна мастера щелкните на строке Общий доклад (Generic). Затем щелкните на кнопке Далее (Next).
  4. Еще два раза щелкните на кнопке Далее (Next) и, наконец, щелкните на кнопке Готово (Finish). На экране появится презентация, показанная на рис. 2.9. В левой части окна отображается текстовое содержание презентации. Жирным шрифтом выделены заголовки слайдов. Справа вверху демонстрируется текущий слайд.
  5. Чтобы последовательно просмотреть все слайды презентации, щелкните в расположенной справа области слайда, затем нажимайте для смены слайдов клавиши Page Down и Page Up или щелкайте на кнопках полосы прокрутки. Презентации, создаваемые с помощью мастера автосодержания, уже наполнены определенным текстом и имеют привлекательный дизайн.

Примечание

Текст можно заменять и на самих слайдах. Если на слайде присутствует область, обведенная пунктирной рамкой, щелкните в ней. Она обозначает ту часть слайда, где должен размещаться текст. Служебная надпись, которая не отображается в содержании презентации, исчезнет, и вы сможете сразу ввести требуемую информацию. Такие пунктирные рамки называются местозаполнителями, они видны на первом слайде презентации.

  6. Для замены стандартного текста своей информацией щелкайте на строках области содержания презентации, удаляйте текст, сгенерированный мастером, и вводите свой.

Рис. 2.9. Презентация PowerPoint


Упражнение 8. Электронное слайд-шоу

Если в вашем распоряжении есть большой дисплей или компьютерный проектор, электронную презентацию можно демонстрировать в большом конференц-зале. Такой способ проведения доклада дает много неоспоримых преимуществ. Вы можете приукрасить слайды разнообразными переходами, когда абзацы, строки или элементы диаграмм выводятся на экран поочередно как раз в тот момент, когда докладчик ссылается на них. Электронное слайд-шоу позволяет показать видеоролик и воспроизвести текст докладчика. В слайд-фильм можно внедрить документ другого приложения, например чертежи проекта, которые открываются в ходе презентации и демонстрируют вспомогательную информацию.

Чтобы добавить в слайд-фильм специальные эффекты, выполните следующие шаги.

  1. Щелкните на кнопке Режим сортировщика слайдов (Slide Sorter View), расположенной в левом нижнем углу окна презентации. Режим сортировщика на рис. 2.10 позволяет показать сразу все слайды. Этот режим удобен для перестановки слайдов и настройки переходов. Мастер автосодержания уже назначил переходы всем слайдам, кроме первого, о чем говорят значки перехода, расположенные под слайдами.

Рис. 2.10. Режим сортировщика слайдов

  2. Щелкните на кнопке Смена слайдов (Slide Change) панели инструментов сортировщика слайдов. В области задач приложения в правой части экрана появится окно Смена слайдов (Slide Change).
  3. Выберите в раскрывающемся списке Применить к выделенным слайдам (Apply to selected slide) пункт Появление снизу (Fly From Bottom) и щелкните на пятом слайде. Щелчком на кнопке Просмотр (Preview) можно запустить выбранный -эффект, а в разделе Изменить переход (Modify Transition) установить скорость перехода.
  4. Аналогичным способом назначьте шестому слайду анимацию Появление слева (Fly From Left), а седьмому — анимацию Прямоугольник наружу (Box Out).
  5. Щелкните на четвертом слайде.
  6. Выберите в списке пункт Наплыв вправо (Cover Right).
  7. Для второго и третьего слайдов выберите, соответственно, эффекты Жалюзи вертикальные (Blinds Vertical) и Растворение (Dissolve).
  8. Чтобы просмотреть слайд-шоу, выполните команду Показ слайдов > Начать Показ (Slide Show > View Show). Для перехода к последующим слайдам нажимайте клавишу Enter. Для завершения демонстрации нажмите клавишу Esc. Присмотритесь к переходам между слайдами 1,2,3 и 4. Обратите внимание, что текст слайдов 5,6 и 7 появляется не сразу. Очередной пункт списка всплывает при каждом последующем нажатии клавиши Enter.


Access

Базы данных в чем-то похожи па электронные таблицы. И те и другие оперируют с табличными данными. Но если электронные таблицы, как правило, используются для проведения расчетов, то основным предназначением баз данных является хранение больших массивов информации, их сортировка и поиск запрашиваемых данных. Программа Access — это интерактивная оболочка базы данных, позволяющая не только работать с информацией, но и оперативно изменять структуру таблиц, форм и отчетов.


Упражнение 9. База данных Access

Чтобы создать базу данных, выполните следующие шаги.

  1. Запустите Access и в открывшемся окне Microsoft Access выберите положение переключателя Новая база данных (Blank Access Database), а затем щелкните на кнопке ОК.
  2. В окне диалога Файл новой базы данных (File New Database) укажите папку и имя файла создаваемой базы данных и щелкните на кнопке Создать (Create). Откроется окно базы данных, показанное на рис. 2.11. В его левой части есть кнопки, раскрывающие списки групп однотипных объектов базы данных, таких как таблицы, формы или отчеты.
  3. Дважды щелкните на пункте Создание таблицы путем ввода данных (Create Table By Entering Data).
  4. Введите в ячейки открывшейся таблицы какие-нибудь данные. Для перемещения но клеткам пользуйтесь клавишами со стрелками. Пример небольшой таблицы показан па рис. 2.12.

Рис. 2.11. Окно новой базы данных

Примечание

База данных состоит из однотипных записей. Такая запись содержит одно или несколько полей. Таблица является хранилищем записей. В таблице Access каждой записи соответствует одна строка, а каждому полю свой столбец.

  5. Щелчком на кнопке с косым крестом закройте окно таблицы.
  6. При появлении запроса о необходимости сохранения модифицированной структуры таблицы щелкните на кнопке Да (Yes).
  7. В текстовое поле открывшегося окна диалога Сохранение (Save As) введите имя таблицы, например Таблица данных, и щелкните на кнопке ОК.
  8. 8. В окне, запрашивающем о необходимости добавления ключевого поля, щелкните на кнопке Нет (No). В окне базы данных появится значок вновь созданной таблицы.

Рис. 2.12. Создание таблицы путем ввода данных


Упражнение 10. Формы

Формы предназначены для ввода, изменения и просмотра записей базы данных. Формы позволяют отображать содержимое таблицы в отформатированном виде.

Чтобы создать форму для таблицы, построенной в предыдущем упражнении, выполните следующие действия.

  1. В левом поле окна базы данных щелкните на кнопке Формы (Forms).
  2. В правом поле того же окна дважды щелкните на строке Создание формы с помощью мастера (Create Form By Using Wizard).
  3. В первом окне мастера щелкните на кнопке », чтобы поместить в форму все поля таблицы данных. Затем щелкните на кнопке Далее (Next).
  4. Во втором окне мастера выберите положение переключателя Выровненный (Justified), а затем щелкните на кнопке Далее (Next).
  5. Еще раз щелкните на кнопке Далее (Next) и затем на кнопке Готово (Finish). Появится окно формы (рис. 2.13) с четырьмя полями, соответствующими столбцам таблицы данных. Одновременно значок новой формы появится в окне базы данных. С помощью формы можно просматривать и изменять информацию. Для перемещения по записям пользуйтесь кнопками в нижней части окна формы.

Рис. 2.13. Форма

  6. Чтобы с помощью формы добавить в таблицу данных новую запись, щелк ните в нижнем ряду на самой правой кнопке.
  7. Заполните четыре пустых поля в соответствии с рис. 2.14.
  8. Закройте окно формы.

Рис. 2.14. Добавление записи в таблицу


Упражнение 11. Отчеты

Отчеты предназначены для печати информации, хранящейся в базе данных. Чтобы распечатать таблицу, созданную в упражнении 9, выполните следующие шаги:

  1. В левом поле окна базы данных щелкните на кнопке Отчеты (Reports).
  2. В списке того же окна дважды щелкните на значке Создание отчета с помощью мастера (Create Report By Using Wizard).
  3. Чтобы поместить в отчет все поля, щелкните в первом окне мастера отчетов на кнопке », а затем на кнопке Далее (Next).
  4. Щелкните на кнопке Далее (Next) еще четыре раза, затем щелкните на кнопке Готово (Finish). Откроется окно предварительного просмотра отчета, показанное па рис. 2.15. Здесь можно проверить правильность оформления отчета.

Рис. 2.15. Отчет

  5. Чтобы распечатать отчет, щелкните на кнопке Печать (Print) панели инструментов.
  6. Закройте окно Access. Новые объекты и модифицированные данные автоматически заносятся в файл базы данных, поэтому нет нужды вручную сохранять какую-либо информацию. Закрываясь, программа Access сама позаботится о записи данных на жесткий диск.


Outlook

Outlook выполняет множество полезных функции. Эта программа позволяет отправлять и получать электронную почту, планировать ваше расписание, составлять списки задач и контактов и даже управлять документами. Outlook не только грамотно структурирует работу с документами. Эта программа может взять на себя планирование всех ваших дел.


Упражнение 12. Папки Outlook

Запустив Outlook, вы увидите окно, показанное на рис. 2.16. В левой части находится список папок и ярлыков Outlook, которые объединены в группы. Справа выводится содержимое активной папки. Каждая папка хранит информацию определенного типа, например входящие письма электронной почты или дневник событий.

Рис. 2.16. Окно Outlook XP

Примечание

Не путайте папки Outlook с папками жесткого диска. Это совершенно разные объекты. Если папка диска представляет собой каталог с файлами, то папка Outlook хранится внутри специальных файлов и доступна только из программы Outlook.

Давайте поближе познакомимся с папками Outlook.

  1. Чтобы найти нужную папку, щелкните в левой части окна Outlook на кноп ке группы Ярлыки Outlook (Outlook Shortcuts).
  2. С помощью кнопок со стрелками прокрутите панель к значку папки Кален дарь (Calendar).
  3. Щелкните на этом значке.
  4. Выберите команду Вид > День (View > Day). В окне Outlook появится ежеднев ник, календарь па два месяца и список задач, как показано на рис. 2.17.
  5. Щелкните в календаре на завтрашнем дне.
  6. В ежедневнике щелкните в графе 10:00 и введите текст Встреча с заказчиком. Теперь Outlook вовремя напомнит вам о запланированной встрече.
  7. В левой панели Outlook щелкните на значке Контакты (Contacts). Откроется папка контактов с информацией о поставщиках, клиентах и других людях и фирмах. Эта папка играет роль записной книжки.

Рис. 2.17. Календарь

  8. Щелкните на кнопке Создать (New) панели инструментов. Откроется окно нового контакта.
  9. Введите фамилию, должность, телефоны и другие данные о человеке, контакт с которым нужно сохранить.
  10. Щелкните на кнопке Сохранить и закрыть (Save and Close) панели инструментов. Добавленная информация появится в папке контактов.


Упражнение 13. Электронная почта

Одна из важных возможностей Outlook — управление почтовой системой. На занятии 21 будет подробно рассказано о возможностях почтового клиента Outlook и способах настройки службы электронной почты. Сейчас давайте научимся читать и отправлять письма.

  1. Щелкните в левой панели Outlook на значке Входящие (Inbox). Откроется ' папка входящих писем, которая автоматически появляется на экране при запуске Outlook. В ее верхней части расположен список всех пришедших писем, а в нижней — содержимое выбранного письма.
  2. В верхней части окна папки Входящие (Inbox) дважды щелкните на строке одного из писем. Откроется окно сообщения, показанное на рис. 2.18.
  3. Для просмотра всех имеющихся сообщений щелкайте на кнопках Назад (Previous Item) и Далее (Next Item).
  4. Чтобы немедленно ответить на письмо, щелкните на кнопке Ответить (Reply).
  5. В окне нового сообщения введите текст письма и выберите команду Файл > Отправить (File > Send). Письмо будет отправлено адресату в первом же сеансе связи с почтовым сервером.

Рис. 2.18. Входящее сообщение в отдельном окне


FrontPage

Frontpage — это редактор HTML-документов, с помощью которого можно не только наполнить содержанием отдельную web-страницу, но также построить целый web-узел, все компоненты которого будут иметь однотипное оформление, и опубликовать его в Интернете.

Примечание

Программа Frontpage — это новый, шестой компонент Microsoft Office. В Office 97 для редактирования web-страниц приходилось пользоваться программой Word либо экспортировать документы других приложений Office в формат HTML. Теперь в вашем распоряжении есть Frontpage ХР — прекрасный редактор web-документов.


Упражнение 14. Построение web-узла

Для того чтобы создать собственный web-узел, выполните следующие действия.

  1. Запустите Frontpage и выполните команду Файл > Создать > Страница или web-узел? (File > New > Page or Web).
  2. В области задач в разделе Создание с помощью шаблона (New from Templates) щелкните на значке Шаблоны web-узлов (Web Site Templates) и в появившемся одноименном окне диалога дважды щелкните на значке Личный web-узел (Personal Web). Мастер построения web-узла сформирует необходимые HTML-файлы, построит пять web-страниц и добавит на них рисунки.

Щелчком на кнопке Создать (New) панели инструментов Стандартная (Standard) добавьте еще одну обычную страницу к созданному мастером web-узлу и введите текст в соответствии с рис. 2.19.

Рис. 2.19. Новая web-страница

Расположенная слева панель режимов Frontpage позволяет выбирать различные варианты просмотра web-узла — открыть окно редактирования страницы, вывести общую структуру узла, просмотреть имеющиеся гиперссылки, сформировать отчеты о содержимом web-узла и увидеть другую информацию. Вкладки web-страницы дают возможность отображать содержимое в стандартном виде, в текстовом режиме HTML-документа и в режиме предварительного просмотра страницы.

  3. Щелкните на кнопке Сохранить (Save) панели инструментов Стандартная (Standard), в поле Имя файла (File Name) открывшегося окна диалога введите имя pagel и щелкните на кнопке Сохранить (Save). ;
  4. Щелчком на значке Переходы (Navigation) переключитесь в режим навигатора. В левой части окна навигатора выводится список файлов и папок web-узла, 1а в правой демонстрируется структура подчиненности web-страниц узла (рис. 2.21).
  5. Переместите указатель на значок файла pagel.htm.
  6. Нажмите левую кнопку мыши и перетащите значок в правое поле навигатора, чтобы пунктирная линия связала прямоугольник новой страницы с прямоугольником Home Page (Домашняя страница).
  7. В списке файлов дважды щелкните на значке index.htm. Домашняя страница узла откроется в режиме редактора страниц.
  8. В левом поле домашней страницы находится панель ссылок, щелкните на ней правой кнопкой мыши и выберите в контекстном меню пункт Свойства панели ссылок (Link Bar Properties).
  9. В открывшемся окне диалога укажите, какие ссылки необходимо поместить в панель ссылок.
  10. Щелкните на кнопке ОК.
    • Для домашней страницы (файл Index, htm) следует выбрать положение переключателя Дочерний уровень (Child level) и сбросить флажки Домашняя страница (Home Page) и Родительская страница (Parent Page).
    • Для остальных страниц следует выбрать положение переключателя Тот же уровень (Same Level) и установить флажок (Home Page).
  11. Повторяйте указанные действия для всех имеющихся панелей навигации страницы.
  12. Щелчком на кнопке Переходы (Navigation) вернитесь в режим навигатора и в списке компонентов узла дважды щелкните на другом файле с расширением HTM. Настройте панели навигации второй web-страницы. Указанным способом переберите все страницы узла и настройте их панели навигации. Немного попрактиковавшись, вы научитесь модифицировать панели по своему вкусу. Завершая редактирование очередной страницы, для сохранения изменений щелкайте на кнопке Сохранить (Save) панели инструментов.
  13. Выполните команду Файл > Просмотр в обозревателе (File > Preview In Browser). В открывшемся окне диалога выберите тип браузера и размер окна просмотра. Затем щелкните на кнопке Просмотр (Preview).
    • Текущая страница web-узла появится в окне браузера. В верхней части страницы находится стандартный баннер и кнопки ссылок на страницы web-узла. Слева расположена панель со ссылками, щелчки на которых перенесут вас к тем пяти страницам, которые были автоматически построены мастером web-узла.

  14. Щелкая на гиперссылках, изучите структуру узла, а затем закройте окно браузера.
  15. Чтобы опубликовать созданный узел в Интернете, выберите команду Файл > Опубликовать узел (File > Publish Web).
  16. В открывшемся окне диалога введите адрес, по которому должен располагаться web-узел, и щелкните на кнопке Опубликовать (Publish). Теперь ваш новый узел станет доступен всему сообществу Интернета.


Контрольное упражнение

Пришло время проверить, насколько хорошо вы освоили базовые операции приложений Office.

  1. Запустите Excel и Access.
  2. Откройте базу данных, созданную на этом занятии.
    • Как в Access открыть имеющуюся базу данных?
  3. Удалите третью запись базы данных.
    • Какими двумя способами можно удалить запись базы данных?
  4. Переключитесь в окно Excel.
  5. Откройте электронную таблицу, построенную на этом занятии.
  6. Удалите содержимое ячеек D6, D7, Еб и Е7.
    • Как в Excel удалить содержимое группы ячеек?
  7. Скопируйте заголовок таблицы Excel в текстовое поле новой записи базы данных Access.
    • Как скопировать данные из ячейки электронной таблицы в поле базы данных?
  8. Закройте Excel и Access.


Подведение итогов

На этом занятии вы познакомились с шестью основными приложениями Office ХР, научились создавать текстовые документы и электронные таблицы, строить презентации и заполнять базы данных, просматривать и отправлять электронные сообщения, конструировать web-узлы.

На следующем занятии будут рассмотрены вопросы взаимодействия приложений Office с операционной системой Windows.


Занятие №20

Контакты

ТЕМА ЗАНЯТИЯ

Outlook предлагает множество инструментов управления большим списком контактов — записей, содержащих информацию о ваших знакомых и коллегах. Опираясь на библиотеку контактов, можно быстро отправлять адресатам электронные сообщения, планировать совещания, выполнять необходимые телефонные звонки и многие другие действия, часть из которых рассматривается на этом занятии:

  • создание контакта;

  • редактирование контакта;

  • список рассылки;

  • планирование совещания;

  • дневник;

  • телефонный звонок.

Контакт — это имя, фамилия, адрес, телефон и другая информация о человеке, с которым вы часто связываетесь тем или иным образом. В список участников контакта могут входить коллеги по работе, клиенты, организации, с которыми вам приходится взаимодействовать, необходимые справочные службы. Имея электронную базу данных контактов Outlook, вы получаете возможность быстрого поиска и сортировки информации по любому параметру.

Список контактов

В Outlook информация о людях и организациях хранится в папке Контакты (Contacts). Предполагается, что сейчас эта папка пуста. Поэтому, прежде чем выполнять те или иные операции, нужно добавить несколько контактов и научиться корректировать введенные данные.

Упражнение 1. Добавление контакта

Чтобы добавить новый контакт, выполните следующие шаги.

  1. Запустите Outlook.

  2. Выберите в панели ярлыков Outlook значок Контакты (Contacts).

  3. В панели инструментов щелкните на кнопке Создать. Откроется окно бланка контакта, показанное на рис. 20.1. Оно имеет пять вкладок:

    • Общие (General) — содержит поля для ввода часто используемой информации: имени, адреса, названия компании, телефонов, электронного адреса и заметок;
    • Подробности (Details) — позволяет вводить дополнительные данные о человеке, например отдел компании, профессию, сокращенное имя, дату рождения и т. п;
    • Действия (Activities) — представляет собой журнал операций, выполнявшихся с использованием данного контакта. Сюда записываются факты отправки и получения электронных сообщений и писем, телефонные звонки;
    • Сертификаты (Certificates) — хранит сертификаты безопасности (цифровые идентификаторы), позволяющие расшифровывать электронные сообщения, поступающие от человека, описанного в данном контакте;
    • Все поля (All Fields) — позволяет увидеть все поля контакта. С помощью этой вкладки можно изменить любую информацию, связанную с контактом, например цвет заметок, записываемых со ссылкой на этот контакт. Здесь же можно ввести дополнительные данные, такие как имена детей или список увлечений.

  4. В поле Полное имя (Full Name) введите текст Александр Петров и нажмите клавишу Enter. Курсор переместится в поле Должность (Job Title).

Примечание

Чтобы указать дополнительные параметры имени, такие как отчество, префикс обращения и суффикс, щелкните на кнопке Полное имя (Full Name) и заполните соответствующие поля.

Рис. 20.1. Контакт

  5. Введите текст Главный архитектор и снова нажмите клавишу Enter.

  6. В поле Организация (Company) введите слова Строительная компания. По умолчанию имя и фамилия автоматически дублируются в поле Хранить как (File As) в обратном порядке. Это поле определяет формат идентификатора контакта, который обусловливает местоположение контакта в алфавитном списке. Роль главного слова в алфавитном списке могут играть фамилия, имя или название организации.

  7. Раскройте список Хранить как (File As) и выберите пункт Строительная компания (Петров, Александр), чтобы в дальнейшем искать данную запись по названию организации. На вкладке Общие бланка контакта предусмотрены четыре поля для телефонов. Однако Outlook может одновременно хранить гораздо больше номеров телефонов, отображая на этой вкладке любые четыре из них.

  8. Чтобы указать, какой номер телефона должен демонстрироваться в первом поле, щелкните на соответствующей кнопке со стрелкой.

  9. Выберите в раскрывшемся списке пункт Автомобильный (Car).

  10. Введите номер автомобильного телефона и нажмите клавишу Enter.

  11. В открывшемся окне диалога выберите страну расположения телефона и код города. Затем щелкните на кнопке ОК. Указанные данные позволят Outlook правильно адресовать телефонный звонок при использовании этой программы для автоматического набора номера.

Примечание

Окно выбора страны и кода города открывается только в том случае, если вы ввели номер телефона не полностью. Можно сразу записать номер телефона с кодом страны и города, тогда указанное окно не появится.

  12. Введите номер домашнего телефона, рабочий факс и номер мобильного телефона.

  13. Щелкните на кнопке Адрес (Address).

  14. В открывшемся окне диалога (рис. 20.2) введите рабочий адрес Петрова.

Рис. 20.2. Добавление адреса

  15. Щелкните на кнопке ОК. Адрес появится на вкладке Общие. При необходимости щелкните на кнопке со стрелкой, расположенной ниже кнопки Адрес, выберите другую разновидность адреса и, повторив шаги 11-13, введите домашний адрес.

  16. Напечатайте адрес электронной почты в поле Эл. почта (E-mail). Если электронный адрес уже имеется в адресной книге Windows, можете скопировать его оттуда. Для этого щелкните на кнопке с раскрытой книгой. В списке Источник адресов (Show Names From The) появившегося окна диалога выберите необходимую адресную книгу, щелкните на нужной записи книги, а затем на кнопке ОК. В поле примечаний любого контакта можно ввести дополнительные пояснения или даже добавить файл. Такой файл может содержать резюме человека, его фотографию и любую другую информацию, которую полезно хранить вместе с контактом.

  17. Чтобы присоединить к контакту документ Word, щелкните на кнопке Добавить файл (Insert File).

  18. В открывшемся окне щелкните на кнопке Мои документы (My Documents), выделите один из файлов с расширением DOC (например, созданный на первом занятии) и щелкните на кнопке Вставка (Insert). Значок файла появится в нижней части вкладки Общие. Теперь, чтобы просмотреть содержимое файла, достаточно дважды щелкнуть на его значке в окне контакта.

  19. Щелкните на кнопке Категории.

  20. В списке категорий установите флажок Дела (Business) и щелкните на кнопкеОК.

  21. Чтобы сохранить настроенный контакт и сразу перейти к вводу нового, щелкните на кнопке Сохранить и создать (Save And New).

  22. Повторяя описанные выше шаги, введите еще два контакта.

Примечание

Чтобы создать контакт для человека, работающего в компании, рекви-1 зиты которой уже записаны в одном из контактов, выделите в папке Контакты имеющийся контакт с этой компанией и выполните команду Действия > Создать контакт в той же организации (Actions > New Contact From Same Company). В открывшемся бланке контакта уже будут заполнены поля организации, адреса и рабочих телефонов.

  23. Заполнив поля последнего контакта, щелкните на кнопке Сохранить и закрыть, чтобы вернуться в основное окно папки контактов, .которое теперь будет выглядеть примерно так, как показано на рис. 20.3.

Рис. 20.3. Папка контактов

Упражнение 2. Редактирование контакта

Со временем у людей меняются адреса и телефоны, а иногда вы просто узнаете дополнительную информацию, которую следует добавить в контакт. Во всех таких случаях приходится редактировать контакты. Чтобы изменить контакт, отыщите его в папке. Для перемещения к нужной букве алфавитного списка пользуйтесь кнопками, расположенными в правой части окна Outlook. Если вам не удается быстро найти нужного человека, смените режим просмотра. Для этого выполните следующие действия.

Рис. 20.4. Просмотр контактов по категориям

  1. Выберите команду Вид > Текущее представление > По категориям. Алфавитный список сменится таблицей контактов, рассортированных по категориям (рис. 20.4).

Рис. 20.5. Дополнительные сведения

  2. Щелчком на значке «плюс» разверните ту категорию, в которой должен находиться искомый контакт.

  3. Чтобы упорядочить контакты по алфавиту названий компаний, щелкните на'заголовке столбца Организация (Company).

  4. Найдя контакт, который нужно изменить, дважды щелкните на его строке. Теперь давайте добавим в контакт некоторые дополнительные сведения.

  5. Щелкните на вкладке Подробности.

  6. Введите название отдела и дату дня рождения, как показано на рис. 20.5.

  7. Щелкните на кнопке Отметить к исполнению (Flag For Follow Up). Эта кнопка, как и одноименная команда меню, позволяет пометить контакт флагом, напоминающим о необходимости связаться с данным человеком в ближайшее время.

  8. В раскрывающемся списке Отметка к исполнению (Flag To) окна диалога, показанного на рис. 20.6, выберите пункт Позвонить (Call). При желании введите дату и время в поле Срок: (Due By)

  9. Щелкните на кнопке ОК.

  10. Щелчком на кнопке Сохранить и закрыть сохраните изменения и вернитесь в папку контактов.

Примечание

Те поля контакта, которые отображаются в таблице режима просмотра по категориям, можно изменять непосредственным редактированием текста поля прямо в этой таблице, не открывая окна бланка контакта.

Рис. 20.6. Установка флага

  11. Выберите команду Вид > Текущее представление > Адресные карточки (View > Current View > Address Card), чтобы вернуться к прежнему режиму просмотра., Обратите внимание, что в карточке Василия Сидорова появилось напоминание о необходимости телефонного звонка, которое было установлено с помощью флага.

Упражнение 3. Список рассылки

Кроме одиночных контактов в папке можно размещать списки рассылки, которые являются группами контактов. Предположим, у вас есть четыре заместителя и большинство директив приходится рассылать всем четырем. Чтобы облегчить свою работу, подготовьте список рассылки и включите в него контакты заместителей. После этого при отправке очередной директивы не нужно будет последовательно указывать адреса всех четырех человек, достаточно выбрать соответствующий список рассылки. Для добавления списка выполните следующие шаги.

  1. В раскрывающемся списке кнопки Создать выберите команду Создать список рассылки (Distribution List).

Примечание

В Outlook XP имеется возможность объединять несколько контактов в списке рассылки, который, в свою очередь, может использоваться в операциях как одновременный контакт с несколькими людьми.

Рис. 20.7. Добавление адресов в список рассылки

  2. В поле Имя (Name) введите название Четыре электронных адреса.

  3. Щелкните на кнопке Выберите членов (Select Members).

  4. В списке Источник адресов окна добавления адресов, показанного на рис. 20.7, выберите пункт Контакты.

Примечание

Адреса для списка рассылки можно выбирать не только из папки контактов, но также из адресной книги Windows и из других адресных справочников, зарегистрированных в Outlook.

  5. В левом списке окна выделите строку Александр Петров (Эл. почта).

  6. Щелкните на кнопке Члены.

  7. Повторяя шаги 5 и 6, добавьте в список рассылки электронные адреса двух других людей.

  8. Щёлкните на кнопке ОК.

  9. Чтобы добавить в список рассылки электронный адрес, отсутствующий в спра вочнике, щелкните на кнопке Добавить (Add New).

  10. В открывшемся окне диалога Добавление новой записи (Add New) в поле Краткое имя (Display Name) введите Сергей Николаев. В поле Адрес электронной почты (E-mail address) напечатайте электронный адрес mcolaOphantom. ru. Установите флажок Добавить контакт (Add To Contacts), чтобы новый адрес автоматически был добавлен в папку контактов Outlook. Затем щелкните на кнопке ОК. Теперь окно списка рассылки будет выглядеть так, как показано на рис. 20.8.

Рис. 20.8. Список рассылки

Примечание

Чтобы удалить адрес из списка рассылки, выделите строку с этим ад-¦ ресом и щелкните на кнопке Удалить (Remove).

  11. Щелкните на кнопке Сохранить и закрыть панели инструментов. В папке контакт появится адресная карточка Сергея Николаева и заголовок списка рассылки.

Работа с контактами

Записанный контакт с данными о человеке или организации позволяет существенно экономить время. С помощью инструментов Outlook можно отправить по адресу контакта электронное сообщение, послать приглашения на совещание согласно адресам, указанным в списке контактов, и даже позвонить по телефонному номеру, зафиксированному в контакте. Вам не придется повторно вводить адреса и телефоны. Outlook автоматически считает необходимую информацию из папки контактов.

Упражнение 4. Планирование совещания

Контакты, хранящиеся в Outlook, могут использоваться для рассылки приглашении на совещание. Для планирования совещаний Outlook предлагает специальный инструмент. Попробуйте воспользоваться им.

  1. В панели ярлыков Outlook щелкните на значке Календарь.

  2. Щелкните на кнопке Создать.

  3. Раскройте вкладку Планирование (Scheduling).

  4. Щелкните на кнопке Другие (Invite Others).

  5. В списке Источник адресов открывшегося окна диалога (см. рис. 20.7) выберите пункт Контакты.

  6. В списке доступных имен и ресурсов щелкните на строке Александр Петров (Эл.почта).

  7. Щелкните на кнопке Обязательный, чтобы указать на настоятельную необходимость присутствия этого человека на совещании.

  8. Выделите строку Сергей Николаев (Эл. почта) и щелкните на кнопке Необязательный (Optional).

  9. Затем щелкните на кнопке ОК.

На вкладке Планирование, показанной на рис. 20.9, наряду с вашим именем появятся имена приглашенных. Бланк занятости по времени показывает, что в промежутке от 14:00 до 14:30 вы отсутствуете в офисе, интервал 11:00-11:30 занят, а с 15:00 до 15:30 вы тоже, видимо, не сможете присутствовать на совещании (все указанные встречи и время обеденного перерыва были настроены на предыдущем занятии). Вертикальная белая полоса с зеленым и красным краями предлагает интервал времени, который, по мнению Outlook, подходит для назначения совещания.

Примечание

Если Outlook имеет доступ (например, через локальную сеть) к расписаниям людей, приглашаемых на совещание, в окне планирования совещания появятся отметки занятых интервалов времени для этих людей. В такой ситуации вам было бы достаточно щелкнуть на кнопке Автовыбор (AutoPick), чтобы программа Outlook нашла для совещания время, устраивающее вас и всех приглашенных.

  10. Чтобы назначить начало совещания на 13:00, щелкните мышью в бланке занятости вблизи этого числа.

  11. С помощью раскрывающегося списка Конец собрания (Meeting End Time) выберите время окончания совещания 15:00.

Рис. 20.9. Планирование совещания

  12. Разверните вкладку Встреча (Appointment). В поле Тема введите текст Совещание, который будет добавлен в одноименное поле электронных сообщении. В поле, расположенное в нижней части этой вкладки, введите необходимые пояснения.

  13. Щелкните на кнопке Отправить. Outlook автоматически прочтет адреса приглашенных из папки Контакты, сгенерирует сообщения и при первой возможности отправит их по электронной почте.

  14. Закройте окно встречи без сохранения введенных данных.

Упражнение 5. Отправка письма

Не всегда можно лично встретиться с человеком. Многие документы приходится пересылать по электронной почте. Это упражнение научит вас отправлять текст, набранный в Word, по адресу, записанному в папке контактов. В подобных ситуациях удобнее всего воспользоваться мастером писем.

  1. В панели ярлыков Outlook выберите значок Контакты.

  2. Щелкните на записи Сидоров Василий, чтобы выделить ее.

  3. Выберите команду Действия > Новое письмо (Actions > New Letter To Contact). Запустится Microsoft Word, в котором откроется окно мастера писем.

  4. Установите флажок Строка даты (Date Line), чтобы добавить в письмо дату отправки, отформатированную стандартным образом.

  5. В раскрывающемся списке Шаблон (Choose A Page Design) выберите пункт Современное письмо (Professional Letter). Ниже указанного списка появится образец выбранного шаблона.

  6. Щелкните на кнопке Далее (Next), которая перенесет вас на вкладку Получатель (Recipient Info). Здесь в поле Имя получателя (Recipient's Name) уже указаны имя и фамилия человека, выбранного в списке контактов Outlook, а в поле Адрес доставки (Delivery Address) — его адрес.

Рис. 20.10. Добавление дополнительных адресов

  7. Щелкните на кнопке Далее. Третья вкладка мастера писем, показанная на рис. 20.10, позволяет добавлять некоторые вспомогательные поля и дополнительные адреса назначения.

  8. Щелкните на значке адресной книги.

  9. В списке Источник адресов открывшегося окна диалога (рис. 20.11) выберите пункт Контакты.

  10. Выделите строку Сидоров Василий.

  11. Щелкните на кнопке Копия (Сс).

Рис. 20.11. Выбор адреса

Примечание

Положения Почта (Mailing), Личные (Ноте) и Другие (Other) переключателя, расположенного в правом верхнем углу окна добавления адреса, позволяют выбрать один из трех адресов, записанных в контакте данного человека.

  12. Щелчком на кнопке ОК закройте окно диалога. В списке Копия третьего окна мастера появится дополнительный адресат.

  13. Затем щелкните на кнопке Далее. Введите или выберите из адресной книги свое имя и обратный адрес.

  14. Наконец щелкните на кнопке Готово (Finish).

Теперь в письмо добавлены все необходимые реквизиты. Помощник по Office спросит, не нужно ли вернуться в мастер писем, создать почтовые наклейки или распечатать адрес на конверте. При необходимости выполните одно из указанных действий, выбрав соответствующее положение переключателя в окне Помощника.

После этого вам останется только вставить текст сообщения, распечатать его, заклеить в конверт и отнести на почту.

Упражнение 6. Запись в дневнике

Дневник может хранить не только записи о работе с теми или иными приложениями Office. Вы можете самостоятельно заносить сообщения в дневник, сохраняя хронологию определенных событий. Давайте, используя технологию «перетащить и оставить», занесем в дневник запись о взаимодействии с человеком, указанным в контакте. Предположим, вы только что обсудили важный вопрос со своим коллегой и хотите зафиксировать этот факт.

  1. Откройте папку Контакты.

  2. Поместите указатель на карточку контакта с Александром Петровым, нажмите кнопку мыши и перетащите контакт в панель ярлыков Outlook на значок Дневник (Journal). Откроется окно диалога.

  3. В списке Тип (Entry Type) выберите пункт Телефонный звонок (Phone Call).

  4. В поле заметок рядом со значком карточки контакта введите описание воп роса, который вы обсуждали.

  5. При необходимости измените время и продолжительность события. По умолчанию Outlook установит время равным текущему, а продолжительность равной 0.

  6. Щелкните на кнопке Сохранить и закрыть.

  7. Чтобы просмотреть внесенную запись дневника, выберите в раскрывающемся списке папок пункт Дневник. Записи дневника появятся в текущем представлении По типу (By Type).

  8. Щелкните на значке «плюс» в строке заголовка Тип записи: Телефонный звонок (Entry Type: Call). Вы увидите значок разговора с Петровым, занесенный в дневник.

Рис.20.12. Дневник

  9. Щелкните на значке правой кнопкой мыши. Ниже перечислены команды появившегося контекстного меню (рис. 20.12).

  • Открыть (Open) — открывает документ, представленный значком (в данном случае запись дневника).

  • Печать (Print) — печатает запись дневника на стандартном принтере.

  • Переслать (Forward) — формирует сообщение и отправляет запись дневника по электронной почте.

  • Категории (Categories) — позволяет изменить категорию записи.

  • Пометить как прочтенные (Mark as Read).

  • Пометить как непрочтенные (Mark as Unread).

  • Удалить (Delete) — удаляет запись дневника.

  • Переместить в папку (Remove to Folder) — помещает запись в соответствующую папку.

Упражнение 7. Телефон

Вы помните, что в начале занятия при создании контактов вы заносили в них номера телефонов людей. Если в компьютере установлен модем, подключенный к телефонной линии, наличие этой информации позволяет автоматически набирать номер телефона человека, с которым вы хотите связаться. Конечно, на первый взгляд, проще снять трубку телефона и позвонить в ручном режиме, но представьте, что вы часто звоните в другие города и вам хочется знать, сколько времени длился тот или иной междугородный разговор. Outlook позволяет автоматически хронометрировать телефонные звонки, сохраняя записи о них в дневнике. Чтобы позвонить с использованием возможностей Outlook, выполните следующие шаги.

  1. Вернитесь в папку контактов щелчком на соответствующем ярлыке панели Outlook.

  2. Выделите контакт Петров Александр.

  3. Поставьте указатель мыши на кнопку Телефон (Dial) панели инструментов и щелкните на треугольнике рядом с ней. В раскрывающемся списке указаны все телефоны данного контакта. Выберите нужный вариант. (Кроме того, с помощью этого списка можно осуществить повторный набор номера, быстрый набор или сделать новый звонок.)

Откроется окно диалога нового звонка.

  4. Щелкните на кнопке Свойства соединения (Dialing Properties).

  5. Проверьте, все ли параметры соединения соответствуют реальному состоянию дел. Затем щелкните на кнопке ОК.

  6. Чтобы телефонный звонок фиксировался в дневнике, установите флажок При каждом звонке создавать запись в дневнике (Create New Journal Entry When Starting New Call).

  7. Щелкните на кнопке Параметры соединения (Dialing Options).

Открывшееся окно диалога (рис. 20.13) позволяет добавить настройки для быстрого набора номера и настроить свойства телефонной линии (а при наличии нескольких модемов выбрать тот, через который подключен телефонный аппарат).

Примечание

Чтобы иметь возможность набора телефонного номера с помощью компьютера, к телефонной розетке нужно подключить разъем Line модема, а телефонный аппарат следует включить в разъем Phone того же модема.

  8. Введя необходимые параметры, щелкните на кнопке ОК; чтобы вернуться в окно Новый звонок (New Call).

Рис. 20.13. Параметры соединения

  9. Щелкните на кнопке Позвонить (Start Call). Outlook наберет телефонный номер.

  10. После соединения с абонентом снимите телефонную трубку и щелкните в окне соединения на кнопке Разговор.

  11. Окончив разговор, щелкните на кнопке Конец связи (End Call). Откроется новая запись дневника, в которой будет указан контакт и продолжительность разговора. При необходимости скорректируйте параметры контакта и добавьте комментарии.

  12. Щелкните на кнопке Сохранить и закрыть. Запись параметров телефонного разговора будет добавлена в дневник.

Контрольное упражнение

Чтобы попрактиковаться в работе с контактами и закрепить навыки, полученные на этом занятии, выполните самостоятельно следующие шаги.

  1. Добавьте в список контактов имена, адреса и телефоны своих родных, друзей и знакомых.

  2. Назначьте всем этим контактам категорию Личные данные ( Ре r s о n a l).

  3. Добавьте несколько списков рассылки, сгруппировав людей по их интересам.

  4. Сформируйте приглашение на совещание и отправьте его по электронной поч-те, добавив в качестве адресатов некоторые из новых контактов.

  5. Добавьте задачу, которую нужно выполнить совместно с коллегой, уведомив его об этом.

    • Как добавить задачу, связанную с определенным контактом?

  6. Позвоните своему другу с помощью инструмента автонабора. Зафиксируйте продолжительность разговора в дневнике.

  7. С помощью контекстного меню контакта отправьте электронное письмо всем членам списка рассылки, созданного на шаге 2.

    • Какие действия нужно предпринять для отправки электронного сообщения?

  8. Просмотрите дневник и найдите в нем запись о только что выполненном телефонном разговоре.

    • Какими двумя способами можно открыть дневник?

Подведение итогов

На этом занятии вы познакомились со структурой контактов — записей с информацией о людях и организациях. Вы научились приглашать людей на совещания, звонить с помощью компьютера и выполнять с контактами некоторые другие действия, попутно протоколируя их в дневнике.

На следующем занятии вы изучите те папки Outlook, которые относятся к системе поддержки электронной почты, узнаете, как настраивать почтовые службы и учетные записи, научитесь отправлять, получать и сортировать сообщения.


Занятие №20

Контакты

ТЕМА ЗАНЯТИЯ

Outlook предлагает множество инструментов управления большим списком контактов — записей, содержащих информацию о ваших знакомых и коллегах. Опираясь на библиотеку контактов, можно быстро отправлять адресатам электронные сообщения, планировать совещания, выполнять необходимые телефонные звонки и многие другие действия, часть из которых рассматривается на этом занятии:

  • создание контакта;

  • редактирование контакта;

  • список рассылки;

  • планирование совещания;

  • дневник;

  • телефонный звонок.

Контакт — это имя, фамилия, адрес, телефон и другая информация о человеке, с которым вы часто связываетесь тем или иным образом. В список участников контакта могут входить коллеги по работе, клиенты, организации, с которыми вам приходится взаимодействовать, необходимые справочные службы. Имея электронную базу данных контактов Outlook, вы получаете возможность быстрого поиска и сортировки информации по любому параметру.


Список контактов

В Outlook информация о людях и организациях хранится в папке Контакты (Contacts). Предполагается, что сейчас эта папка пуста. Поэтому, прежде чем выполнять те или иные операции, нужно добавить несколько контактов и научиться корректировать введенные данные.


Упражнение 1. Добавление контакта

Чтобы добавить новый контакт, выполните следующие шаги.

  1. Запустите Outlook.

  2. Выберите в панели ярлыков Outlook значок Контакты (Contacts).

  3. В панели инструментов щелкните на кнопке Создать. Откроется окно бланка контакта, показанное на рис. 20.1. Оно имеет пять вкладок:

    • Общие (General) — содержит поля для ввода часто используемой информации: имени, адреса, названия компании, телефонов, электронного адреса и заметок;
    • Подробности (Details) — позволяет вводить дополнительные данные о человеке, например отдел компании, профессию, сокращенное имя, дату рождения и т. п;
    • Действия (Activities) — представляет собой журнал операций, выполнявшихся с использованием данного контакта. Сюда записываются факты отправки и получения электронных сообщений и писем, телефонные звонки;
    • Сертификаты (Certificates) — хранит сертификаты безопасности (цифровые идентификаторы), позволяющие расшифровывать электронные сообщения, поступающие от человека, описанного в данном контакте;
    • Все поля (All Fields) — позволяет увидеть все поля контакта. С помощью этой вкладки можно изменить любую информацию, связанную с контактом, например цвет заметок, записываемых со ссылкой на этот контакт. Здесь же можно ввести дополнительные данные, такие как имена детей или список увлечений.

  4. В поле Полное имя (Full Name) введите текст Александр Петров и нажмите клавишу Enter. Курсор переместится в поле Должность (Job Title).

Примечание

Чтобы указать дополнительные параметры имени, такие как отчество, префикс обращения и суффикс, щелкните на кнопке Полное имя (Full Name) и заполните соответствующие поля.

Рис. 20.1. Контакт

  5. Введите текст Главный архитектор и снова нажмите клавишу Enter.

  6. В поле Организация (Company) введите слова Строительная компания. По умолчанию имя и фамилия автоматически дублируются в поле Хранить как (File As) в обратном порядке. Это поле определяет формат идентификатора контакта, который обусловливает местоположение контакта в алфавитном списке. Роль главного слова в алфавитном списке могут играть фамилия, имя или название организации.

  7. Раскройте список Хранить как (File As) и выберите пункт Строительная компания (Петров, Александр), чтобы в дальнейшем искать данную запись по названию организации. На вкладке Общие бланка контакта предусмотрены четыре поля для телефонов. Однако Outlook может одновременно хранить гораздо больше номеров телефонов, отображая на этой вкладке любые четыре из них.

  8. Чтобы указать, какой номер телефона должен демонстрироваться в первом поле, щелкните на соответствующей кнопке со стрелкой.

  9. Выберите в раскрывшемся списке пункт Автомобильный (Car).

  10. Введите номер автомобильного телефона и нажмите клавишу Enter.

  11. В открывшемся окне диалога выберите страну расположения телефона и код города. Затем щелкните на кнопке ОК. Указанные данные позволят Outlook правильно адресовать телефонный звонок при использовании этой программы для автоматического набора номера.

Примечание

Окно выбора страны и кода города открывается только в том случае, если вы ввели номер телефона не полностью. Можно сразу записать номер телефона с кодом страны и города, тогда указанное окно не появится.

  12. Введите номер домашнего телефона, рабочий факс и номер мобильного телефона.

  13. Щелкните на кнопке Адрес (Address).

  14. В открывшемся окне диалога (рис. 20.2) введите рабочий адрес Петрова.

Рис. 20.2. Добавление адреса

  15. Щелкните на кнопке ОК. Адрес появится на вкладке Общие. При необходимости щелкните на кнопке со стрелкой, расположенной ниже кнопки Адрес, выберите другую разновидность адреса и, повторив шаги 11-13, введите домашний адрес.

  16. Напечатайте адрес электронной почты в поле Эл. почта (E-mail). Если электронный адрес уже имеется в адресной книге Windows, можете скопировать его оттуда. Для этого щелкните на кнопке с раскрытой книгой. В списке Источник адресов (Show Names From The) появившегося окна диалога выберите необходимую адресную книгу, щелкните на нужной записи книги, а затем на кнопке ОК. В поле примечаний любого контакта можно ввести дополнительные пояснения или даже добавить файл. Такой файл может содержать резюме человека, его фотографию и любую другую информацию, которую полезно хранить вместе с контактом.

  17. Чтобы присоединить к контакту документ Word, щелкните на кнопке Добавить файл (Insert File).

  18. В открывшемся окне щелкните на кнопке Мои документы (My Documents), выделите один из файлов с расширением DOC (например, созданный на первом занятии) и щелкните на кнопке Вставка (Insert). Значок файла появится в нижней части вкладки Общие. Теперь, чтобы просмотреть содержимое файла, достаточно дважды щелкнуть на его значке в окне контакта.

  19. Щелкните на кнопке Категории.

  20. В списке категорий установите флажок Дела (Business) и щелкните на кнопкеОК.

  21. Чтобы сохранить настроенный контакт и сразу перейти к вводу нового, щелкните на кнопке Сохранить и создать (Save And New).

  22. Повторяя описанные выше шаги, введите еще два контакта.

Примечание

Чтобы создать контакт для человека, работающего в компании, рекви-1 зиты которой уже записаны в одном из контактов, выделите в папке Контакты имеющийся контакт с этой компанией и выполните команду Действия > Создать контакт в той же организации (Actions > New Contact From Same Company). В открывшемся бланке контакта уже будут заполнены поля организации, адреса и рабочих телефонов.

  23. Заполнив поля последнего контакта, щелкните на кнопке Сохранить и закрыть, чтобы вернуться в основное окно папки контактов, .которое теперь будет выглядеть примерно так, как показано на рис. 20.3.

Рис. 20.3. Папка контактов


Упражнение 2. Редактирование контакта

Со временем у людей меняются адреса и телефоны, а иногда вы просто узнаете дополнительную информацию, которую следует добавить в контакт. Во всех таких случаях приходится редактировать контакты. Чтобы изменить контакт, отыщите его в папке. Для перемещения к нужной букве алфавитного списка пользуйтесь кнопками, расположенными в правой части окна Outlook. Если вам не удается быстро найти нужного человека, смените режим просмотра. Для этого выполните следующие действия.

Рис. 20.4. Просмотр контактов по категориям

  1. Выберите команду Вид > Текущее представление > По категориям. Алфавитный список сменится таблицей контактов, рассортированных по категориям (рис. 20.4).

Рис. 20.5. Дополнительные сведения

  2. Щелчком на значке «плюс» разверните ту категорию, в которой должен находиться искомый контакт.

  3. Чтобы упорядочить контакты по алфавиту названий компаний, щелкните на'заголовке столбца Организация (Company).

  4. Найдя контакт, который нужно изменить, дважды щелкните на его строке. Теперь давайте добавим в контакт некоторые дополнительные сведения.

  5. Щелкните на вкладке Подробности.

  6. Введите название отдела и дату дня рождения, как показано на рис. 20.5.

  7. Щелкните на кнопке Отметить к исполнению (Flag For Follow Up). Эта кнопка, как и одноименная команда меню, позволяет пометить контакт флагом, напоминающим о необходимости связаться с данным человеком в ближайшее время.

  8. В раскрывающемся списке Отметка к исполнению (Flag To) окна диалога, показанного на рис. 20.6, выберите пункт Позвонить (Call). При желании введите дату и время в поле Срок: (Due By)

  9. Щелкните на кнопке ОК.

  10. Щелчком на кнопке Сохранить и закрыть сохраните изменения и вернитесь в папку контактов.

Примечание

Те поля контакта, которые отображаются в таблице режима просмотра по категориям, можно изменять непосредственным редактированием текста поля прямо в этой таблице, не открывая окна бланка контакта.

Рис. 20.6. Установка флага

  11. Выберите команду Вид > Текущее представление > Адресные карточки (View > Current View > Address Card), чтобы вернуться к прежнему режиму просмотра., Обратите внимание, что в карточке Василия Сидорова появилось напоминание о необходимости телефонного звонка, которое было установлено с помощью флага.


Упражнение 3. Список рассылки

Кроме одиночных контактов в папке можно размещать списки рассылки, которые являются группами контактов. Предположим, у вас есть четыре заместителя и большинство директив приходится рассылать всем четырем. Чтобы облегчить свою работу, подготовьте список рассылки и включите в него контакты заместителей. После этого при отправке очередной директивы не нужно будет последовательно указывать адреса всех четырех человек, достаточно выбрать соответствующий список рассылки. Для добавления списка выполните следующие шаги.

  1. В раскрывающемся списке кнопки Создать выберите команду Создать список рассылки (Distribution List).

Примечание

В Outlook XP имеется возможность объединять несколько контактов в списке рассылки, который, в свою очередь, может использоваться в операциях как одновременный контакт с несколькими людьми.

Рис. 20.7. Добавление адресов в список рассылки

  2. В поле Имя (Name) введите название Четыре электронных адреса.

  3. Щелкните на кнопке Выберите членов (Select Members).

  4. В списке Источник адресов окна добавления адресов, показанного на рис. 20.7, выберите пункт Контакты.

Примечание

Адреса для списка рассылки можно выбирать не только из папки контактов, но также из адресной книги Windows и из других адресных справочников, зарегистрированных в Outlook.

  5. В левом списке окна выделите строку Александр Петров (Эл. почта).

  6. Щелкните на кнопке Члены.

  7. Повторяя шаги 5 и 6, добавьте в список рассылки электронные адреса двух других людей.

  8. Щёлкните на кнопке ОК.

  9. Чтобы добавить в список рассылки электронный адрес, отсутствующий в спра вочнике, щелкните на кнопке Добавить (Add New).

  10. В открывшемся окне диалога Добавление новой записи (Add New) в поле Краткое имя (Display Name) введите Сергей Николаев. В поле Адрес электронной почты (E-mail address) напечатайте электронный адрес mcolaOphantom. ru. Установите флажок Добавить контакт (Add To Contacts), чтобы новый адрес автоматически был добавлен в папку контактов Outlook. Затем щелкните на кнопке ОК. Теперь окно списка рассылки будет выглядеть так, как показано на рис. 20.8.

Рис. 20.8. Список рассылки

Примечание

Чтобы удалить адрес из списка рассылки, выделите строку с этим ад-¦ ресом и щелкните на кнопке Удалить (Remove).

  11. Щелкните на кнопке Сохранить и закрыть панели инструментов. В папке контакт появится адресная карточка Сергея Николаева и заголовок списка рассылки.


Работа с контактами

Записанный контакт с данными о человеке или организации позволяет существенно экономить время. С помощью инструментов Outlook можно отправить по адресу контакта электронное сообщение, послать приглашения на совещание согласно адресам, указанным в списке контактов, и даже позвонить по телефонному номеру, зафиксированному в контакте. Вам не придется повторно вводить адреса и телефоны. Outlook автоматически считает необходимую информацию из папки контактов.


Упражнение 4. Планирование совещания

Контакты, хранящиеся в Outlook, могут использоваться для рассылки приглашении на совещание. Для планирования совещаний Outlook предлагает специальный инструмент. Попробуйте воспользоваться им.

  1. В панели ярлыков Outlook щелкните на значке Календарь.

  2. Щелкните на кнопке Создать.

  3. Раскройте вкладку Планирование (Scheduling).

  4. Щелкните на кнопке Другие (Invite Others).

  5. В списке Источник адресов открывшегося окна диалога (см. рис. 20.7) выберите пункт Контакты.

  6. В списке доступных имен и ресурсов щелкните на строке Александр Петров (Эл.почта).

  7. Щелкните на кнопке Обязательный, чтобы указать на настоятельную необходимость присутствия этого человека на совещании.

  8. Выделите строку Сергей Николаев (Эл. почта) и щелкните на кнопке Необязательный (Optional).

  9. Затем щелкните на кнопке ОК.

На вкладке Планирование, показанной на рис. 20.9, наряду с вашим именем появятся имена приглашенных. Бланк занятости по времени показывает, что в промежутке от 14:00 до 14:30 вы отсутствуете в офисе, интервал 11:00-11:30 занят, а с 15:00 до 15:30 вы тоже, видимо, не сможете присутствовать на совещании (все указанные встречи и время обеденного перерыва были настроены на предыдущем занятии). Вертикальная белая полоса с зеленым и красным краями предлагает интервал времени, который, по мнению Outlook, подходит для назначения совещания.

Примечание

Если Outlook имеет доступ (например, через локальную сеть) к расписаниям людей, приглашаемых на совещание, в окне планирования совещания появятся отметки занятых интервалов времени для этих людей. В такой ситуации вам было бы достаточно щелкнуть на кнопке Автовыбор (AutoPick), чтобы программа Outlook нашла для совещания время, устраивающее вас и всех приглашенных.

  10. Чтобы назначить начало совещания на 13:00, щелкните мышью в бланке занятости вблизи этого числа.

  11. С помощью раскрывающегося списка Конец собрания (Meeting End Time) выберите время окончания совещания 15:00.

Рис. 20.9. Планирование совещания

  12. Разверните вкладку Встреча (Appointment). В поле Тема введите текст Совещание, который будет добавлен в одноименное поле электронных сообщении. В поле, расположенное в нижней части этой вкладки, введите необходимые пояснения.

  13. Щелкните на кнопке Отправить. Outlook автоматически прочтет адреса приглашенных из папки Контакты, сгенерирует сообщения и при первой возможности отправит их по электронной почте.

  14. Закройте окно встречи без сохранения введенных данных.


Упражнение 5. Отправка письма

Не всегда можно лично встретиться с человеком. Многие документы приходится пересылать по электронной почте. Это упражнение научит вас отправлять текст, набранный в Word, по адресу, записанному в папке контактов. В подобных ситуациях удобнее всего воспользоваться мастером писем.

  1. В панели ярлыков Outlook выберите значок Контакты.

  2. Щелкните на записи Сидоров Василий, чтобы выделить ее.

  3. Выберите команду Действия > Новое письмо (Actions > New Letter To Contact). Запустится Microsoft Word, в котором откроется окно мастера писем.

  4. Установите флажок Строка даты (Date Line), чтобы добавить в письмо дату отправки, отформатированную стандартным образом.

  5. В раскрывающемся списке Шаблон (Choose A Page Design) выберите пункт Современное письмо (Professional Letter). Ниже указанного списка появится образец выбранного шаблона.

  6. Щелкните на кнопке Далее (Next), которая перенесет вас на вкладку Получатель (Recipient Info). Здесь в поле Имя получателя (Recipient's Name) уже указаны имя и фамилия человека, выбранного в списке контактов Outlook, а в поле Адрес доставки (Delivery Address) — его адрес.

Рис. 20.10. Добавление дополнительных адресов

  7. Щелкните на кнопке Далее. Третья вкладка мастера писем, показанная на рис. 20.10, позволяет добавлять некоторые вспомогательные поля и дополнительные адреса назначения.

  8. Щелкните на значке адресной книги.

  9. В списке Источник адресов открывшегося окна диалога (рис. 20.11) выберите пункт Контакты.

  10. Выделите строку Сидоров Василий.

  11. Щелкните на кнопке Копия (Сс).

Рис. 20.11. Выбор адреса

Примечание

Положения Почта (Mailing), Личные (Ноте) и Другие (Other) переключателя, расположенного в правом верхнем углу окна добавления адреса, позволяют выбрать один из трех адресов, записанных в контакте данного человека.

  12. Щелчком на кнопке ОК закройте окно диалога. В списке Копия третьего окна мастера появится дополнительный адресат.

  13. Затем щелкните на кнопке Далее. Введите или выберите из адресной книги свое имя и обратный адрес.

  14. Наконец щелкните на кнопке Готово (Finish).

Теперь в письмо добавлены все необходимые реквизиты. Помощник по Office спросит, не нужно ли вернуться в мастер писем, создать почтовые наклейки или распечатать адрес на конверте. При необходимости выполните одно из указанных действий, выбрав соответствующее положение переключателя в окне Помощника.

После этого вам останется только вставить текст сообщения, распечатать его, заклеить в конверт и отнести на почту.


Упражнение 6. Запись в дневнике

Дневник может хранить не только записи о работе с теми или иными приложениями Office. Вы можете самостоятельно заносить сообщения в дневник, сохраняя хронологию определенных событий. Давайте, используя технологию «перетащить и оставить», занесем в дневник запись о взаимодействии с человеком, указанным в контакте. Предположим, вы только что обсудили важный вопрос со своим коллегой и хотите зафиксировать этот факт.

  1. Откройте папку Контакты.

  2. Поместите указатель на карточку контакта с Александром Петровым, нажмите кнопку мыши и перетащите контакт в панель ярлыков Outlook на значок Дневник (Journal). Откроется окно диалога.

  3. В списке Тип (Entry Type) выберите пункт Телефонный звонок (Phone Call).

  4. В поле заметок рядом со значком карточки контакта введите описание воп роса, который вы обсуждали.

  5. При необходимости измените время и продолжительность события. По умолчанию Outlook установит время равным текущему, а продолжительность равной 0.

  6. Щелкните на кнопке Сохранить и закрыть.

  7. Чтобы просмотреть внесенную запись дневника, выберите в раскрывающемся списке папок пункт Дневник. Записи дневника появятся в текущем представлении По типу (By Type).

  8. Щелкните на значке «плюс» в строке заголовка Тип записи: Телефонный звонок (Entry Type: Call). Вы увидите значок разговора с Петровым, занесенный в дневник.

Рис.20.12. Дневник

  9. Щелкните на значке правой кнопкой мыши. Ниже перечислены команды появившегося контекстного меню (рис. 20.12).

  • Открыть (Open) — открывает документ, представленный значком (в данном случае запись дневника).

  • Печать (Print) — печатает запись дневника на стандартном принтере.

  • Переслать (Forward) — формирует сообщение и отправляет запись дневника по электронной почте.

  • Категории (Categories) — позволяет изменить категорию записи.

  • Пометить как прочтенные (Mark as Read).

  • Пометить как непрочтенные (Mark as Unread).

  • Удалить (Delete) — удаляет запись дневника.

  • Переместить в папку (Remove to Folder) — помещает запись в соответствующую папку.


Упражнение 7. Телефон

Вы помните, что в начале занятия при создании контактов вы заносили в них номера телефонов людей. Если в компьютере установлен модем, подключенный к телефонной линии, наличие этой информации позволяет автоматически набирать номер телефона человека, с которым вы хотите связаться. Конечно, на первый взгляд, проще снять трубку телефона и позвонить в ручном режиме, но представьте, что вы часто звоните в другие города и вам хочется знать, сколько времени длился тот или иной междугородный разговор. Outlook позволяет автоматически хронометрировать телефонные звонки, сохраняя записи о них в дневнике. Чтобы позвонить с использованием возможностей Outlook, выполните следующие шаги.

  1. Вернитесь в папку контактов щелчком на соответствующем ярлыке панели Outlook.

  2. Выделите контакт Петров Александр.

  3. Поставьте указатель мыши на кнопку Телефон (Dial) панели инструментов и щелкните на треугольнике рядом с ней. В раскрывающемся списке указаны все телефоны данного контакта. Выберите нужный вариант. (Кроме того, с помощью этого списка можно осуществить повторный набор номера, быстрый набор или сделать новый звонок.)

Откроется окно диалога нового звонка.

  4. Щелкните на кнопке Свойства соединения (Dialing Properties).

  5. Проверьте, все ли параметры соединения соответствуют реальному состоянию дел. Затем щелкните на кнопке ОК.

  6. Чтобы телефонный звонок фиксировался в дневнике, установите флажок При каждом звонке создавать запись в дневнике (Create New Journal Entry When Starting New Call).

  7. Щелкните на кнопке Параметры соединения (Dialing Options).

Открывшееся окно диалога (рис. 20.13) позволяет добавить настройки для быстрого набора номера и настроить свойства телефонной линии (а при наличии нескольких модемов выбрать тот, через который подключен телефонный аппарат).

Примечание

Чтобы иметь возможность набора телефонного номера с помощью компьютера, к телефонной розетке нужно подключить разъем Line модема, а телефонный аппарат следует включить в разъем Phone того же модема.

  8. Введя необходимые параметры, щелкните на кнопке ОК; чтобы вернуться в окно Новый звонок (New Call).

Рис. 20.13. Параметры соединения

  9. Щелкните на кнопке Позвонить (Start Call). Outlook наберет телефонный номер.

  10. После соединения с абонентом снимите телефонную трубку и щелкните в окне соединения на кнопке Разговор.

  11. Окончив разговор, щелкните на кнопке Конец связи (End Call). Откроется новая запись дневника, в которой будет указан контакт и продолжительность разговора. При необходимости скорректируйте параметры контакта и добавьте комментарии.

  12. Щелкните на кнопке Сохранить и закрыть. Запись параметров телефонного разговора будет добавлена в дневник.


Контрольное упражнение

Чтобы попрактиковаться в работе с контактами и закрепить навыки, полученные на этом занятии, выполните самостоятельно следующие шаги.

  1. Добавьте в список контактов имена, адреса и телефоны своих родных, друзей и знакомых.

  2. Назначьте всем этим контактам категорию Личные данные ( Ре r s о n a l).

  3. Добавьте несколько списков рассылки, сгруппировав людей по их интересам.

  4. Сформируйте приглашение на совещание и отправьте его по электронной поч-те, добавив в качестве адресатов некоторые из новых контактов.

  5. Добавьте задачу, которую нужно выполнить совместно с коллегой, уведомив его об этом.

    • Как добавить задачу, связанную с определенным контактом?

  6. Позвоните своему другу с помощью инструмента автонабора. Зафиксируйте продолжительность разговора в дневнике.

  7. С помощью контекстного меню контакта отправьте электронное письмо всем членам списка рассылки, созданного на шаге 2.

    • Какие действия нужно предпринять для отправки электронного сообщения?

  8. Просмотрите дневник и найдите в нем запись о только что выполненном телефонном разговоре.

    • Какими двумя способами можно открыть дневник?


Подведение итогов

На этом занятии вы познакомились со структурой контактов — записей с информацией о людях и организациях. Вы научились приглашать людей на совещания, звонить с помощью компьютера и выполнять с контактами некоторые другие действия, попутно протоколируя их в дневнике.

На следующем занятии вы изучите те папки Outlook, которые относятся к системе поддержки электронной почты, узнаете, как настраивать почтовые службы и учетные записи, научитесь отправлять, получать и сортировать сообщения.


Занятие №21

Электронная почта

ТЕМА ЗАНЯТИЯ

Outlook предлагает пользователю систему электронной почты, полностью интегрированную с другими приложениями Office. На этом занятии вы научитесь настраивать ее, отправлять сообщения и просматривать входящую почту. В упражнениях рассматриваются следующие темы:

  • настройка учетной записи;

  • связь с провайдером;

  • отправка сообщения;

  • управление рассылкой;

  • присоединение файлов;

  • чтение входящей почты;

  • ответ на письмо;

  • добавление дополнительных папок Outlook.


Настроика

Для выполнения упражнений этого занятия необходимо иметь зарегистрированный почтовый ящик у одного из провайдеров электронной почты, связь с которым осуществляется через локальную сеть или модем. Для правильной настройки почтовой системы Outlook вам необходимо знать имя почтового сервера, имя и пароль регистрации. При модемном соединении нужно также знать телефонный номер для связи с компьютером провайдера. Соответствующую информацию можно получить в службе технической поддержки провайдера или у администратора локальной сети.


Упражнение 1. Добавление службы

Чтобы иметь возможность получать и отправлять электронные сообщения с помощью Outlook, необходимо настроить параметры связи с провайдером. Для добавления службы электронной почты выполните следующие действия.

  1. Запустите Outlook.

  2. Выберите команду Сервис >Учетные записи электронной почты (Tools > E-mail Accounts). Тем самым вы запустите мастера создания учетных записей.

  3. В первом окне мастера Учетные записи электронной почты (E-mail Accounts) (рис. 21.1), можно добавлять и удалять почтовые службы Outlook, а также просматривать свойства установленных служб.

  4. Установите переключатель Электронная почта (E-mail) в положение Добавить новую учетную запись (Add a new e-mail account). Щелкните на кнопке Далее. Откроется окно добавления службы в активный профиль конфигурации.

  5. Установите переключатель в положение РОРЗ и щелкните на кнопке Далее. Откроется окно свойств учетной записи почты, показанное на рис. 21.2.

  6. В разделе Сведения о пользователе (User Information) введите свое имя и адрес электронной почты.

Рис. 21.1. Добавление службы

  7. В разделе Сведения о сервере (Server Information) того же окна диалога введите названия серверов исходящей (SMTP) и входящей (РОРЗ) почты. В поля Сведения о входе (Logon Name) и Пароль (Password) нужно ввести имя и пароль, открывающие доступ к серверу провайдера.

  8. Щелкните на кнопке Другие настройки (More Settings). На вкладке Общие в поле Учетная запись почты (Mail Account) введите легко запоминающееся имя учетной записи. На этой вкладке можно также указать название организации и адрес электронной почты.

  9. Если ваш компьютер связывается с почтовым сервером посредством модема, раскройте вкладку Подключение (Connection), показанную на рис. 21.3.

  10. Выберите положение через телефонную линию (Connect Using my phone line) переключателя Подключение (Connection).

  11. Если нужное удаленное соединение не настроено, щелкните на кнопке Добавить. В противном случае выберите имя корректного соединения в раскрывающемся списке Использовать следующее подключение (Dial Using The Following Connection) и перейдите к шагу 15.

  12. В открывшемся окне мастера нового соединения введите имя соединения.

  13. В раскрывающемся списке выберите модем, через который будет выполняться связь. Затем щелкните на кнопке Далее.

  14. Во втором окне мастера укажите телефон провайдера Интернета. Щелкните на кнопке Далее, а затем на кнопке Готово. Новое соединение появится в поле Использовать следующее удаленное соединение (Dial Using The Following Connection) окна диалога свойств службы.

  15. Щелкните на кнопке Свойства (Properties).

Рис. 21.2. Свойства учетной записи

Рис.21.3. Настройка соединения

  16. Проверьте, чтобы в раскрывающемся списке вкладки Тип сервера (Server) бы выбран протокол РРР .

  17. Два раза щелкните на кнопках ОК.

Примечание

Чтобы проверить правильность выбранных настроек, щелкните на кнопке Проверка настройки учетной записи (Test Account Settings). Outlook автоматически свяжется с провайдером, воспользовавшись параметрами добавленной службы.

  18. Убедившись, что установка связи прошла корректно, щелкните на кнопке Закрыть (Close) окна диалога Проверка настройки учетной записи (Test Account Settings).

  19. Щелкните на кнопке Далее окна мастера Учетные записи электронной почты, а затем на кнопке Готово.

Примечание

Окно диалога параметров соединения содержит множество параметров. Их настройка зависит от алгоритма работы почтового сервера. Выбор неверных значений может привести к невозможности связи с провайдером. Чтобы избежать лишних ошибок, заранее проконсультируйтесь с администратором или службой технической поддержки и выясните, как правильно настроить параметры связи.


Упражнение 2. Настройка параметров доставки почты

Чтобы получить входящую почту и отправить свои электронные сообщения, нужно связаться с сервером провайдера, указанным службой, настроенной в предыдущем упражнении. Для этого выполните следующие шаги:

  1. Чтобы определить, какие письма следует отправить, выберите команду Сервис > Параметры отправки и получения > Определить группы отправки и получения.

Рис. 21.4. Группы отправки и получения почты

  2. В открывшемся окне диалога (рис. 21.4) выделите название группы и щелкните на кнопке Изменить.

Рис. 21.5. Выбор режима доступа

  3. В открывшемся окне диалога (рис. 21.5) в левом поле показаны имеющиеся учетные записи, а справа — параметры отправки и доставки почты. Чтобы не отправлять письма, созданные в предыдущих упражнениях в учебных целях, для всех учетных записей снимите флажки Получение почты и установите переключатели в положение Загрузить только описание сообщения.

  4. Щелкните на кнопке ОК, а затем на кнопке Закрыть.


Отправка почты

Outlook предлагает удобный интерфейс для отправки исходящих сообщений. Для задания адресов можно пользоваться адресной книгой или списком контактов. Список рассылки позволяет настроить расписание отправки писем. К любому электронному сообщению можно присоединить один или несколько файлов данных, которые дойдут до адресата вместе с самим письмом.

Примечание

В последнее время для форматирования электронных сообщений все чаще используется стандарт НТМ1_Outlook XP полностью поддерживает этот формат при чтении и отправке электронной почты.


Упражнение 3. Новое сообщение

Чтобы создать новое электронное письмо и отправить его по назначению, достаточно заполнить несколько полей специальной формы Outlook и напечатать текст.

  1. Выберите команду Файл > Создать > Сообщение (File > New > Mail Message). Откроется окно, показанное на рис. 21.6.

  2. Чтобы указать адрес получателя, щелкните на кнопке Кому.

  3. В раскрывающемся списке Источник адресов открывшегося окна диалога (рис. 21.7) выберите источник, в котором хранится адрес получателя. Электронный адрес можно выбрать из Адресной книги Windows, Адресной книги Outlook или из списка контактов.

Рис. 21.6. Новое сообщение

  4. В левом списке выделите имя адресата или настроенный ранее список рассылки, с помощью которого можно адресовать письмо сразу нескольким получателям.

Рис. 21.7. Выбор адреса

  5. Щелкните на кнопке Кому.

  6. Чтобы копия письма была отправлена по второму адресу, выберите его в левом списке окна (при необходимости сменив источник адресов) и щелкните на кнопке Копия.

  7. Добавив адреса всех получателей, щелкните на кнопке ОК.

Адресная часть любого сообщения имеет три поля — Кому, Копия и СК (Вес), — в каждое из которых можно ввести несколько адресов, разделенных точкой с запятой. Письмо будет отправлено всем людям, адреса которых перечислены в трех этих полях. При этом получатели будут видеть в заголовке письма все адреса, введенные в поля Кому, Копия, а адреса, введенные в поле СК, будут скрыты от них.

Примечание

Чтобы отправить сообщение получателю, отсутствующему в адресных книгах, достаточно ввести его адрес в поле Кому окна сообщения. Нет необходимости сначала добавлять запись в адресную книгу, а затем выбирать ее оттуда с помощью кнопки Кому.

  8. Щелкните на поле Тема и введите тему сообщения, которая появится в окне почтовой программы получателя в списке пришедших сообщений. Это поле заполнять не обязательно, но наличие темы помогает получателю разбираться в многочисленных письмах, пришедших на его адрес.

  9. В основное окно сообщения введите текст письма.

  10. Если вы считаете, что отправляемое сообщение достаточно важно, щелкните на кнопке Важность: высокая панели инструментов. Такие письма помечаются в почтовой программе получателя специальным значком, требующим немедленной реакции.

  11. Щелкните на кнопке Отметить к исполнению.

  12. В списке Отметка открывшегося окна диалога (рис. 21.8) выберите пункт Ответить.

Рис. 21.8. Настройка отметки

  13. В календаре поля Срок: выберите тот день, до которого получатель должен среагировать на ваше сообщение.

  14. Щелкните на кнопке ОК. В списке писем почтовой программы получателя в строке такого помеченного сообщения пользователь увидит флажок, указывающий на необходимость определенной реакции на сообщение. В самом сообщении будет указан тип и срок ожидаемой реакции.

  15. Чтобы отправить письмо, щелкните на кнопке Отправить панели инструментов. Сообщение будет помещено в папку Исходящие (Outbox). При очередном соединении с почтовым сервером провайдера все сообщения этой папки будут отправлены адресатам.


Упражнение 4. Управление рассылкой

Кроме адресов, содержания и флагов каждое сообщение имеет набор дополнительных параметров, управляющих шифрованием, алгоритмом рассылки и правилами подтверждения сообщений. Чтобы получить доступ к параметрам электронного письма, созданного в предыдущем упражнений, выполните следующие шаги.

  1. В панели ярлыков Outlook раскройте группу папок Почта (Mail).

  2. Щелкните на значке Исходящие (Outbox).

  3. В списке сообщений дважды щелкните на строке письма с темой Приглашение на семинар.

  4. В панели инструментов окна сообщения щелкните на кнопке Параметры (Options). Откроется окно диалога, показанное на рис. 21.9.

Рис. 21.9. Параметры сообщения

Здесь есть набор флажков и полей, задающих следующие режимы рассылки:

  • списки Важность (Importance) и Пометка (Sensitivity) позволяют указать уровень важности письма и степень официальности сообщения;

  • флажки раздела Безопасность (Security) включают режимы шифрования сообщения и добавления к нему электронной подписи, однозначно идентифицирующей отправителя;

  • флажок и список Кнопки голосования (Use Voting Buttons) помещают в тело письма набор стандартных кнопок, с помощью которых получатель может быстро возвратить отправителю сообщения свое мнение относительна содержания письма;

  • флажки Уведомить о доставке этого сообщения (Request A Delivery Receipt For This Message) и Уведомить о прочтении этого сообщения (RequestA Read Receipt For This Message) обеспечивают автоматическую генерацию компьютером адресата ответного сообщения, уведомляющего отправителя соответственно о получении письма почтовой системой и о прочтении этого письма пользователем;

  • флажок Отправлять ответы (Have Replies Sent To), одноименное поле и кнопка Выбор имен (Select Names) позволяют указать адрес, на который должны приходить ответы на данное сообщение;

  • поле После отправки сохранить в (Save Sent Message To) и кнопка Обзор (Browse) дают возможность указать папку Outlook, в которую должна быть помещена копия сообщения после его отправки на почтовый сервер, а одноименный флажок позволяет включить или отменить режим сохранения копии;

  • флажок Не доставлять до (Do Not Deliver Before) и одноименное поле с календарем позволяют отложить отправку сообщения до указанного времени;

  • флажок Не действительно после (Expires After) и поле с календарем устанавливают дату, после которой данное сообщение станет недоступным (то есть будет удалено из Outlook);

  • поля Формат (Attachment Format) и Кодировка (Encoding) с раскрывающимися списками позволяют изменить формат и кодировку сообщения;

  • кнопки Контакты и Категории позволяют связать с сообщением некоторый контакт и отнести письмо к определенной категории.

  5. Настроив нужные режимы, щелкните на кнопке Закрыть.

  6. Закройте окно сообщения.

  7. Щелчком на кнопке Да подтвердите необходимость сохранения выполненных изменений.

Примечание

Модификацию сообщения и его параметров необходимо выполнять до момента передачи письма на сервер провайдера. После того как письмо уйдет, изменить его уже нельзя.


Упражнение 5. Формат сообщения

Примечание

Outlook предлагает для отправки и чтения сообщений два формата — обычный и HTML. В обычном формате письмо представляет собой простой текст, подобный тому, который набирается в программе Блокнот (Notepad). Такой текст не может содержать элементов оформления. То есть этот режим не дает возможности выбирать шрифт или назначать определенным фрагментам особенное начертание (курсив, полужирный текст).

Вариант HTML предлагает пользователю достаточно большие оформительские возможности. Этот режим позволяет настраивать шрифт и начертание, формировать маркированные списки, изменять цвет и отступы фрагментов. Однако формат HTML воспринимается не всеми почтовыми системами. Кроме того, сообщения в этом формате оказываются существенно длиннее, чем обычные письма. По этой причине формат HTML следует выбирать только в том случае, если точно известно, что получатель сможет его воспроизвести.

  1. Чтобы изменить формат сообщения, раскройте меню Формат (Format) и выберите пункт Обычный текст или Формат HTML.

В современной почтовой системе для представления символов национальных алфавитов используется множество различных кодировок. Для русского текста в Интернете обычно применяется кодировка KOI8-R, но иногда приходится выбирать другую кодировку. Если большинство получателей не может прочесть ваши сообщения, посоветуйтесь с провайдером, какую кодировку следует выбирать при отправке электронных писем.

  2. Изменить кодировку можно в одноименном поле окна диалога Параметры сообщения (Message Options).

Примечание

Выбирать нестандартную кодировку обычно приходится при чтении тех писем, которые из-за сбоев в почтовой системе или из-за ошибок в настройках почтовой программы отправителя в стандартном режиме не читаются.


Упражнение 6. Присоединение файлов

Несмотря на возможность форматирования текста сообщения с помощью формата HTML, все же достаточно трудно (а точнее говоря, невозможно) передать таким способом многостраничный документ, содержащий сложное форматирование. Тем более нельзя превратить в текст двоичный файл или изображение. К счастью, Outlook предлагает простой механизм присоединения к письму любого файла. Такой файл передается через Интернет вместе с сообщением. Получатель может извлечь его из письма и поместить на жесткий диск своего компьютера.

Чтобы создать письмо с присоединенным файлом, выполните следующие шаги.

  1. Создайте новое сообщение, выполнив последовательность действий, описанную в упражнении 3. Введите адрес назначения и тему письма.

  2. В основном поле сообщения введите пояснительный текст.

  3. Щелкните на кнопке Добавить файл.

  4. В открывшемся окне диалога найдите нужный файл на локальном или сетевом диске и щелкните на кнопке Вставка. Значок файла появится в поле Вложить (Attach), как показано на рис. 21.10.

  5. Чтобы отправить сообщение, щелкните на кнопке Отправить панели инструментов.

Рис. 21.10. Сообщение с присоединенным файлом

При необходимости в одно сообщение можно вставить несколько разных файлов. Но не забывайте, что отправка длинных файлов с помощью модема может занять много времени. Поэтому перед присоединением большого файла, например изображения, выполненного с высоким разрешением, полезно уменьшить его размер с помощью программы архивации, согласовав с получателем формат данных.


Чтение почты

Упражнение7. Входящие сообщения

При первом запуске Outlook открывается папка Входящие (Inbox), которая содержит сообщения, пришедшие по электронной почте. Чтобы вернуться к этой папке в процессе работы с Outlook и просмотреть новые письма, пришедшие на ваш адрес, выполните следующие шаги.

  1. В панели папок Outlook раскройте группу Ярлыки Outlook.

  2. Щелкните на значке папки Входящие.

  3. Чтобы связаться с сервером и обменяться с ним почтовыми сообщениями, щелкните на кнопке Отправить/получить (Send/Receive) панели инструментов. После этого вам, вероятно, придется подождать несколько минут, пока ваш компьютер и сервер провайдера обмениваются информацией. По окончании сеанса связи заголовки новых писем появятся в списке папки Входящие. При этом непрочитанные письма отмечаются значком запечатанного конверта, а прочитанные — значком открытого. Дата получения письма выводится справа от названия темы.

Рис. 21.11. Папка входящих сообщений

Письма с присоединенными файлами помечаются значком канцелярской скрепки (рис. 21.11).

  4. Чтобы прочитать письмо, щелкните в списке папки Входящие на его заголовке. Содержимое сообщения появится в нижней половине окна Outlook.

  5. Если вы хотите вывести содержимое письма в отдельное окно, щелкните на том же заголовке дважды.

  6. Чтобы извлечь из сообщения присоединенный к нему файл, щелкните на значке этого файла правой кнопкой мыши и выберите в контекстном меню команду Сохранить как (Save As)

  7. В появившемся окне диалога откройте ту папку жесткого диска, в которой нужно сохранить присоединенный файл, введите имя, под которым нужно записать этот файл, и щелкните на кнопке Сохранить (Save). Outlook автоматически раскодирует информацию и сохранит ее в виде указанного файла.

Примечание

Контекстное меню значков присоединенных файлов содержит несколько команд. С их помощью можно скопировать файл, открыть его в окне инструмента быстрого просмотра, открыть файл в породившем его приложении, распечатать информацию или просмотреть свойства присоединенного файла.

  8. Outlook автоматически отслеживает те письма, которые были прочитаны, и помечает их соответствующим значком. Если вы хотите в будущем ознакомиться с текстом более внимательно, имеет смысл оставить письму пометку непрочитанного. Для этого следует щелкнуть на заголовке письма правой кнопкой мыши и выбрать в контекстном меню команду Пометить как непрочтенные (Mark As Unread).


Упражнение 8. Ответ на письмо

С помощью действий, рассмотренных в упражнении 3 этого занятия, можно отправить письмо любому адресату. Однако для формирования ответов на пришедшие сообщения следует пользоваться специальными инструментами, значительно ускоряющими процедуру формирования письма.

  1. Чтобы ответить на пришедшее сообщение, выделите его в окне папки Входящие или откройте в отдельном окне.

  2. Щелкните на кнопке Ответить (Reply). Откроется окно нового исходящего сообщения. В его адресное поле автоматически будет введен электронный адрес отправителя исходного письма. В поле Тема появится копия темы письма, на которое вы отвечаете, но перед ней будут добавлены символы Re (от английского слова reply — ответить). В основное поле сообщения будет вставлена копия пришедшего письма. Отвечая на электронные письма, всегда оставляйте такую копию входящего сообщения (возможно, немного урезав ее). Она помогает адресату понять, на какое из его писем пришел ответ. Это особенно актуально для тех, кто любит писать лаконичные ответы типа «Да, я согласен».

  3. Щелкните на кнопке Отправить панели инструментов. Ответ будет записан в папку Исходящие и отправлен по назначению при очередном сеансе связи с сервером.

В панели инструментов окна входящего сообщения и папки Входящие есть еще две важные кнопки. Первая из них — Ответить всем (Reply То All) генерирует сообщение, аналогичное описанному выше, однако в поле Кому добавляется не только адрес отправителя исходного письма, но и адреса всех его получателей (исключая ваш). Это позволяет быстро ознакомить с ответом всех лиц, заинтересованных в получении информации по данному вопросу.

Кнопка Переслать (Forward) генерирует копию пришедшего сообщения, оставляя строку Кому пустой. Вы сами должны ввести в нее нужный адрес. Эта кнопка используется в тех случаях, когда полученное письмо нужно просто переслать другому человеку.


Упражнение 9. Папки писем

В предыдущих упражнениях были рассмотрены папки Исходящие и Входящие почтовой системы Outlook. Но этим список папок группы Почта не ограничивается. По умолчанию, Outlook создает в ней еще две специальные папки:

  • Удаленные (Deleted Items) — хранит все сообщения, стертые пользователем. Она подобна Корзине Windows и позволяет восстанавливать сообщения, удаленные по невнимательности. Чтобы эта папка автоматически очищалась при каждом завершении работы Outlook, выберите команду Сервис > Параметры (Tools > Options), раскройте вкладку Дополнительно (Other) и установите флажок Очищать папку Удаленные при выходе (Empty The Deleted Items Folder Upon Exiting);

  • Отправленные (Sent Items) — содержит копии сообщений, отправленных из папки Исходящие на почтовый сервер провайдера. Обратите внимание, что сама папка Исходящие хранит только неотправленные письма.

Кроме стандартных папок в группе Почта можно разместить любое число дополнительных папок, предназначенных для хранения прочитанных писем или черновиков. Наличие нескольких папок позволяет делить входящие сообщения по темам. Чтобы добавить новую почтовую папку, выполните следующие шаги.

  1. Выберите команду Файл > Создать > Папка (File > New > Folder).

  2. В поле Имя папки открывшегося окна диалога (рис. 21.14) введите название новой папки.

  3. В раскрывающемся списке Содержимое папки выберите пункт Элементы типа Почта (Май Items).

  4. В списке Поместить папку в (Select Where To Place The Folder) выделите пункт Входящие.

  5. Щелкните на кнопке ОК.

  6. В окне диалога, запрашивающем о необходимости размещения значка новой папки в панели ярлыков, щелкните на кнопке Да. Чтобы в процессе работы с Outlook переместить письмо из одной папки в другую, выполните следующие действия.

  7. Откройте папку, содержащую сообщение, которое нужно переместить.

  8. В списке писем щелкните на перемещаемом сообщении правой кнопкой мыши и выберите в контекстном меню команду Переместить в папку.

  9. В окне диалога Перемещение элементов дважды щелкните на той папке, в которую нужно поместить сообщение.

Примечание

С помощью описанной последовательности шагов можно перемещать не только почтовые сообщения, но и элементы любых других папок Outlook.


Контрольное упражнение

Воспользовавшись подсказками этого контрольного упражнения, самостоятельно создайте и отправьте несколько писем с помощью Outlook.

  1. Создайте новое сообщение и адресуйте его сразу нескольким своим друзьям или коллегам.

  2. Добавьте еще одного адресата в поле СК.

  3. Присоедините к сообщению файл Microsoft Excel.

  4. Назначьте письму низкую степень важности.

    • Какими двумя способами можно понизить важность письма?

  5. Добавьте в Outlook дополнительную папку для исходящих сообщений, назвав ее Черновики.

  6. Переместите только что созданное сообщение в эту папку.

  7. Просмотрите содержимое папки Входящие.

  8. Если в этой папке слишком мало писем, отправьте несколько сообщений самому себе.

  9. Рассортируйте входящие сообщения по степени важности.

    • Как упорядочить сообщения по некоторому признаку?

  10. Удалите несколько писем.

  11. Откройте папку Удаленные, найдите в ней стертые сообщения и восстановите их, переместив обратно в папку Входящие.


Подведение итогов

На этом занятии вы познакомились с почтовым клиентом программы Outlook, научились настраивать параметры учетной записи, отправлять и получать сообщения, форматировать их и присоединять к ним файлы.

На следующем занятии вы познакомитесь с шестым компонентом Microsoft Office — редактором web-узлов Frontpage. Вы узнаете, как с помощью этого мощного редактора можно построить достаточно сложный узел, не прибегая к программированию на языке HTML.


Занятие №22

ЧАСТЬ VII

Frontpage

Microsoft Frontpage XP — современная интегрированная оболочка для построения отдельных web-страниц и целых web-узлов. Даже неопытный пользователь, незнакомый с языками программирования, сможет с помощью Frontpage самостоятельно создать свой собственный web-узел и опубликовать его в Интернете. Web-редактор Frontpage станет прекрасным дополнением и для арсенала опытного Web-дизайнера.

Построение web-узла

ТЕМА ЗАНЯТИЯ

На этом занятии вы познакомитесь с новым приложением Microsoft Office — редактором web-узлов программой Frontpage. Вы научитесь создавать и модифицировать структуру узла. Ниже перечислены некоторые компоненты и операции, рассматриваемые в упражнениях занятия:

  • мастер web-узла;

  • список задач;

  • просмотр папок узла;

  • навигация;

  • проверка гиперссылок;

  • отчеты;

  • цветовая схема узла;

  • общие поля страницы.

Web-узел — это набор файлов в формате HTML, расположенных в определенной папке и связанных друг с другом гиперссылками. Один из файлов web-узла назначается главным, он представляет собой домашнюю страницу и открывается в браузере пользователя при подключении к web-узлу. Остальные web-страницы выводятся в окно браузера по мере перехода к ним по гиперссылкам. Кроме файлов HTML в состав узла входит набор графических объектов формата GIF или JPG, предназначенных для оформления страниц. С развитием браузеров, предлагающих самые разнообразные расширения стандарта HTML, в web-узлах все чаще стали появляться файлы других форматов.

Создание web-узла

Frontpage ХР — это интегрированная среда, содержащая редактор web-страниц, модули управления структурой узла и инструменты публикации узла на сервере. С помощью Frontpage даже совершенно не знакомый с языком HTML новичок может сконструировать вполне работоспособный web-узел. В руках опытного пользователя Frontpage становится мощным инструментом, позволяющим строить web-узлы любой сложности.

Примечание

Во Frontpage ХР три отдельных модуля — редактор страниц, компоновщик узла и средств поддержки web-сервера объединены в одну интегрированную оболочку, обеспечивающую удобный доступ ко всем инструментам.

Упражнение 1. Мастер web-узла

Чтобы создать законченный web-узел, недостаточно просто разместить в одной папке несколько HTML-файлов. Грамотно построенный узел имеет хорошо продуманную структуру. Это облегчает пользователю поиск необходимой информации. Если у вас нет большого опыта работы с web-страницами, мастер web-узла поможет правильно скомпоновать узел, а вам останется только наполнить страницы содержанием. Чтобы прибегнуть к услугам мастера, выполните следующие шаги.

  1. Запустите Frontpage.

  2. Выберите команду Файл > Создать ^ Страница или web-узел (File > New > Web). В области задач приложения откроется окно Создание web-страниц (New Page or Web) со списком шаблонов и мастеров, которыми можно воспользоваться для построения web-узла (рис. 22.1).

  3. В разделе Создание с помощью шаблона (New from Template) щелкните на значке Шаблоны веб-узлов (Web Site Template) и в появившемся окне диалога Шаблоны веб-узлов (Web Site Templates) щелкните на значке Мастер корпоративного веб-узла (Corporate Presence Wizard).

  4. В поле раздела Options (Параметры) введите название папки, в которой будут храниться файлы узла (я буду пользоваться для этих целей папкой С: \Мои документы\Му Webs\Corporate).

Рис. 22.1. Мастера и шаблоны web-узлов

  5. Щелкните на кнопке ОК.

  6. В первом окне мастера щелкните на кнопке Далее (Next).

    Второе окно предлагает список основных web-страниц, которые можно включить в новый web-узел:

    • Домашняя страница (Home Page);
    • Что нового (What's New);
    • Товары и услуги (Products/Services);
    • Оглавление (Table of Contents);
    • Обратная связь (FeedBack form);
    • Форма поиска (Search form).

  7. Оставьте установленными все флажки и щелкните на кнопке Далее. Следующее окно мастера, показанное на рис. 22.2, предлагает определить вид домашней страницы. Устанавливая и сбрасывая флажки этого окна, вы добавляете или убираете соответствующие разделы домашней страницы.

  8. Установите все четыре флажка.

  9. Щелкните на кнопке Далее.

Шесть следующих окон диалога мастера настраивают вид страницы определенного типа (из тех, которые были выбраны во втором окне мастера). Последовательно изучите каждое окно и установите флажки для тех компонентов, которые необходимо включить в web-узел. В последующих упражнениях этого занятия предполагается, что в этих шести окнах были оставлены те варианты настройки, которые предлагаются мастером по умолчанию.

Рис. 22.2. Мастер корпоративного узла

  10. Десятое окно мастера задает общее оформление всех страниц. Установите флажки этого окна в соответствии с рис. 22.3, затем щелкните два раза на кнопке Далее.

Рис. 22.3. Настройка оформления страниц

  11. Введите полное название компании, то же самое название, сокращенное до одного слова, и адрес компании. Щелкните на кнопке Далее.

  12. В следующем окне введите телефон компании, номер факса, электронный адрес web-мастера и адрес информационной поддержки. Щелкните два раза на кнопке Далее, а затем на кнопке Готово (Finish). Мастер сгенерирует новый web-узел и откроет его в режиме просмотра задач со списком действий, которые необходимо выполнить для получения законченного узла. Пункты этого списка, показанные на рис. 22.4, были добавлены мастером. В них перечислены операции, с помощью которых вы должны наполнить смысловым содержанием сформированные web-страницы. В процессе разработки узла можно вручную добавлять новые задачи, связанные с той или иной web-страницей. Вы научитесь этому в следующем упражнении. Список задач всегда под рукой, он хранится вместе с файлами web-узла и не даст позабыть о незавершенных операциях. Чтобы открыть его, достаточно щелкнуть на кнопке Задачи (Tasks) панели режимов.

Рис. 22.4. Просмотр задач

Примечание

Чтобы добавить задачу, выберите команду файл > Создать > Задача (File > New > Task). Для изменения параметров конкретной задачи дважды щелкните на ее строке.

Упражнение 2. Режимы просмотра

Frontpage предлагает шесть режимов просмотра web-узла, кнопки которых имеются на панели режимов:

  • Страница (Page) — редактор отдельной web-страницы. В этом режиме можно изменять содержание любой страницы узла, настраивать ее оформление и просматривать HTML-код, на основе которого генерируется страница;

  • Папки (Folders) — список папок и файлов web-узла с их подробными характеристиками, подобный списку окна Проводника Windows;

  • Отчеты (Reports) — статистическая информация об узле и отдельных его компонентах;

  • Переходы (Navigation) — редактор структуры web-узла, позволяющий в графическом режиме изменять связи и перестраивать гиперссылки;

  • Гиперссылки (Hyperlinks) — список web-страниц узла и схема гиперссылок выделенной страницы;

  • Задачи (Tasks) — список задач, связанных с определенными файлами, которые нужно не забыть выполнить для завершения разработки узла.

Переключать режимы просмотра можно как с помощью команд меню Вид (View), так и посредством кнопок панели режимов, расположенной в левой части окна Frontpage.

Рис. 22.5. Режим просмотра папок

  1. Чтобы просмотреть список файлов, сгенерированных мастером web-узла, щелкните на кнопке Папки (Folders) панели режимов. Окно Frontpage разделится на две области (рис. 22.5). В левую будет выведен список папок, вложенных в папку С:\Мот документы\Согрога1е (в которой хранятся все файлы текущего web-узла), а в правую — значки файлов корневой папки узла.

Примечание

Режим просмотра Папки (Folders)-Ha самом деле отображает не все файлы web-узла, а только те, которые несут определенную смысловую нагрузку. Вспомогательные папки, содержащие графические файлы стандартных элементов оформления и файлы поддержки расширений Frontpage, остаются скрытыми.

  2. Чтобы просмотреть список изображении, используемых в web-узле, щелк-к ните на значке папки images.

  3. Дважды щелкните на файле smallnsw.gif. Frontpage запустит программу, предназначенную для просмотра файлов формата GIF, и откроет в ней выбранный файл.

  4. Полюбуйтесь на значок, выбранный мастером, и закройте графическую программу.

  5. Для возврата в предыдущую папку щелкните в панели списка файлов правой кнопкой мыши и выберите в контекстном меню команду Вверх на один уровень (Up One Level).

  6. Выберите команду Файл > Создать > Папка (File > New > Folder). В списке папок появится значок новой папки с именем Новая папка. Щелкните на нем правой кнопкой мыши и в контекстном меню выберите команду Переименовать (Rename).

  7. Введите текст Дополнения. Это будет имя новой папки.

  8. В списке папок щелкните на значке Дополнения, чтобы открыть новую папку.

  9. Щелкните в пустом списке файлов правой кнопкой мыши и выберите команду Создать страницу (New Page).

  10. В качестве имени новой web-страницы введите Справочник. htm. Мы не будем сейчас наполнять новую страницу содержанием, но, чтобы не забыть о необходимости сделать это в дальнейшем, запишем соответствующий пункт в список задач.

  11. Щелкните на значке Справочник.htm. Выполните команду Файл > Создать > Задача.

  12. В поле Имя задачи (Task Name) открывшегося окна создания задачи (рис. 22.6) введите текст Создать страницу и ссылки.

Рис. 22.6. Добавление задачи

  13. Нажмите клавишу Tab и введите имя исполнителя задачи.

  14. В поле описания введите текст Создать страницу справочника по продуктам компании с таблицей, добавить ссылки с домашней страницы и на страницы описания продуктов.

  15. Щелкните на кнопке ОК.

  16. Выберите команду Вид > Задачи (View > Tasks). В списке операций вы увидите только что добавленную задачу со статусом Не запущена (Not Started).

Упражнение 3. Переходы

Мастер web-узла конструирует ссылки между страницами по определенному алгоритму. Вам может не понравиться созданная им структура связей. С помощью режима просмотра Переходы можно увидеть общую схему узла, добавить или разорвать определенные ссылки, скорректировать правила размещения ссылок в панелях навигации web-страниц.

  1. Щелкните на кнопке Переходы (Navigation) панели режимов.

  2. Чтобы вместить в область экрана всю схему узла, выберите в раскрывающемся списке Масштаб (Zoom) панели инструментов Переходы (Navigation) пункт По размеру данных (Size To Fit).

Рис. 22.7. Режим навигации

Теперь структура навигации будет выглядеть так, как показано на рис. 22.7. Каждая страница узла обозначается прямоугольником. Линии, соединяющие эти прямоугольники, символизируют взаимную подчиненность страниц. Например, страница Услуги (Services), с одной стороны, подчинена домашней странице Домой (Ноmе). Это означает, что Frontpage автоматически разместит в нижней части страницы Услуги ссылку на домашнюю страницу. С другой стороны, страница Услуги обеспечивает доступ к трем подчиненным страницам Услуги 1, Услуги 2 и Услуги 3. Frontpage поместит ссылки на них в самом начале страницы Услуги. Давайте изучим такие ссылки.

  3. Чтобы перейти из навигатора к просмотру страницы Услуги, дважды щелкните на ее прямоугольнике. При этом автоматически включается режим Страница.

  4. С помощью вертикальной полосы прокрутите содержимое страницы Услуги вниз, чтобы увидеть ссылки, расположенные в ее нижней части, как показано на рис. 22.8. Обратите внимание, что Frontpage дополнительно поместил ссылки на подчиненные страницы в левом поле, а ссылка на родительскую страницу Домой присутствует только внизу.

Рис. 22.8. Режим просмотра страницы

Примечание

Опробуйте действие имеющихся гиперссылок. Чтобы активизировать ссылку в режиме Страница, щелкните на ней, удерживая нажатой клавишу Ctrl. Перемещаясь по страницам с помощью ссылок, сравните структуру страниц со схемой навигатора узла.

  5. С помощью команды Вид > Способ перехода (View > Navigation) вернитесь в режим переходов.

  6. В левой части экрана расположена панель папок web-узла. Разверните в ней папку Дополнения, щелкнув на соответствующем значке «плюс». В этой папке расположена web-страница, созданная в предыдущем упражнении. Пока что она не включена в состав узла. Если предположить, что эта страница будет содержать сводную таблицу характеристик товаров фирмы, то ее следует подчинить странице Продукты (Products).

  7. Поместите указатель на значок Справочник.htm панели папок.

  8. Нажмите кнопку мыши и перетащите указатель в область схемы узла, чтобы появился прямоугольник новой страницы.

  9. Разместите прямоугольник выше прямоугольника Продукт1, чтобы линия связи соединяла новую страницу со страницей Продукты. Затем отпустите кнопку мыши. Frontpage добавит в структуру узла страницу Дополнения/ Cnpaвочник.htm и поместит ссылку на нее в левое поле ссылок страницы Продукты. В режиме навигатора можно не только добавлять новые, но и удалять ненужные страницы.

  10. Щелкните на странице Услуги 3 правой кнопкой мыши и выберите в контекстном меню команду Удалить (Delete).

  11. В открывшемся окне диалога выберите положение переключателя Удалить страницу с Web-узла (Delete This Page From The Web), азатем щелкните на кнопке ОК. Файл страницы будет удален с диска, а его значок — из схемы узла и всех папок.

Рис. 22.9. Переименованные страницы

Ориентацию схемы можно изменить, щелкнув на кнопке Портретная/альбомная (Portrait/Landscape) панели инструментов Переход.

Примечание

Выбор положения переключателя Удалить страницу из структуры переходов (Remove Page From The Navigation Structure) удаляет ссылки на данную страницу из панелей других страниц, но сохраняет файл страницы на жестком диске.

  12. Заголовок Дополнения/Справочник.htm не слишком хорош для web-страницы. Чтобы изменить его, щелкните на прямоугольнике этой страницы правой кнопкой мыши и выберите команду Переименовать, затем введите текст Справочник товаров. Этот же текст теперь будет использоваться в качестве заголовка на самой web-странице.

  13. Нажмите клавишу Tab. Frontpage автоматически перейдет в режим редактирования названия следующей страницы. Введите слово Трубы.

  14. Переименуйте другие страницы в соответствии с рис. 22.9, перемещаясь по ним с помощью клавиш Tab и Shift+Tab. Как видно из схемы узла, страницы Отзывы и Содержание не связаны с другими страницами. Чтобы предоставить пользователю доступ к этим двум страницам, выполните следующие действия.

  15. Перетащите прямоугольник страницы Содержание вправо вверх, подчинив его домашней странице Геркулес и разместив выше страницы Новости.

Примечание

Порядок расположения прямоугольников в схеме узла небезразличен, он определяет порядок размещения ссылок в панелях навигации web-страниц.

  16. Перетащите страницу Отзывы вправо, переместив ее в подчинение группе Услуги, как показано на рис. 22.10.

Рис. 22.10. Новая структура узла

Упражнение 4. Гиперссылки

Режим просмотра гиперссылок позволяет просматривать дерево гиперссылок и проверять работоспособность внутренних и внешних ссылок узла.

  1. Чтобы вывести дерево гиперссылок, щелкните в панели режимов на значке Гиперссылки (Hyperlinks). На экран будет выведен список папок и дерево гиперссылок. Обратите внимание в списке папок на миниатюру файла index.htm в виде домика. Это файл домашней страницы.

  2. В панели списка папок щелкните на файле products, htm.

Frontpage поместит значок выбранной страницы в середину окна и линиями покажет все ссылки, имеющиеся на этой странице (рис. 22.11). Давайте смоделируем некорректную гиперссылку, переименовав один из файлов web-узла.

Рис. 22.11. Просмотр гиперссылок

  3. Щелкните на значке prod03.htm и выберите команду Переименовать.

  4. Введите текст pi-od04. htm и нажмите клавишу Enter.

  5. Откроется окно диалога, предлагающее обновить Гиперссылки, указывающие на переименованную страницу. Щелкните в нем на кнопке Нет (No).

  6. Щелчком на значке products.htm вернитесь к прежней схеме. Выберите команду Сервис > Пересчитать гиперссылки (Tools > Recalculate Hyperlinks).

  7. В открывшемся окне диалога щелкните на кнопке Да. Frontpage просмотрит ссылки web-узла и проверит их состояние (при работе с большими узлами этот процесс может занять продолжительное время). Программа обнаружит на странице products, htm ссылку на несуществующий файл prod03.htm. Это отразится на схеме (рис. 22.12).

Рис. 22.12. Разорванная гиперссылка

Примечание

Обычно следует выбирать ответ Да (Yes). Этот вариант дает указание Frontpage скорректировать ссылки так, чтобы смена имени файла не внесла путаницы в структуру узла и не нарушила его работоспособность. По указанной причине никогда не переименовывайте файлы узла в Проводнике или с помощью других инструментов Windows. Пользуйтесь для этих целей списком файлов в окне Frontpage. Операционная система в отличие от Frontpage не способна модифицировать другие web-страницы, приводя их ссылки в соответствие новому имени файла.

Рис. 22.13. Раскрытие ветвей ссылок

Обратите внимание, что миниатюры файлов, связанных со страницей products, htm снабжены символами «плюс». Они разворачивают соответствующую ветвь паутины ссылок.

  8. Щелкните на значке «плюс» миниатюры prod0l.htm.

  9. Затем щелкните на значке «плюс» появившейся миниатюры index.htm. В окне появится новый фрагмент web-узла, показанный на рис. 22.13.

Такое раскрытие ветвей в схеме гиперссылок позволяет наглядно моделировать логику работы узла, не открывая сами web-страницы, загрузка которых часто занимает много времени и оперативной памяти.

Упражнение 5. Отчеты

Поиск разорванных ссылок в схеме гиперссылок, описанной в предыдущем упражнении, — не слишком большое удовольствие. Вы потратите много времени на перебор всех страниц и все же, вполне вероятно, не заметите каких-то деталей. К счастью, Frontpage предлагает разработчику целый набор отчетов, несущих в себе различную статистическую информацию о web-узле.

  1. Чтобы увидеть итоговую информацию Frontpage о данном узле, выберите команду Вид > Отчеты > Сводка веб-узла (View > Reports > Site Summary).

Рис. 22.14. Обзор web-узла

Откроется таблица с обзором основных параметров узла (рис. 22.14). Некоторые пункты представляют сводную информацию из более подробного отчета на данную тему, который можно открыть двойным щелчком на соответствующей строке, а также выбором пункта в меню Вид > Отчеты (View » Reports) или в раскрывающемся списке панели инструментов Отчеты (Reports). Назначение отчетов Frontpage описано в табл. 22.1. Пункты обзора узла, не открывающие доступ к отдельным отчетам (и не попавшие по этой причине в табл. 22.1), а лишь дающие итоговое значение определенного параметра, перечислены в табл. 22.2.

ТАБЛИЦА 22.1. Отчеты Frontpage
Отчет | Назначение
Все файлы (All Files) | Список всех файлов web-узла с указанием их размера, местоположения и даты обновления
Недавно добавленные файлы (Recently Added Files) | Файлы, созданные в течение нескольких последних недель
Недавно измененные файлы (Recently Changed Files) | Список файлов, обновлявшихся за несколько последних недель
Старые файлы | Файлы, которые нс обновлялись длительное (Older Files) время
Потерянные файлы (Unlinked Files) | Список файлов, которые нельзя открыть с домашней страницы путем последовательной активизации гиперссылок
Медленные страницы (Slow pages) | Web-страницы, на загрузку которых с удаленного компьютера уйдет слишком много времени
Неработающие гиперссылки (Broken Hyperlinks) | Список ссылок, содержащих ошибки, то есть таких, точка назначения которых неизвестна
Ошибки компонентов (Component Errors) | Логические ошибки, найденные программой Frontpage при просмотре страниц
Состояние проверки (Review Status) | Демонстрирует способ обновления файлов (например обновление с помощью кода Active Server Page), если таковой назначен
Назначено (Assigned To) | Любому файлу web-узла в целях предотвращения путаницы в процессе разработки можно назначить принадлежность определенной рабочей группе или конкретному разработчику. Этот отчет показывает принадлежность файлов
Категории (Categories) | Демонстрирует категории, назначенные файлам при разработке узла, а также их типы и местоположение в структуре папок
Состояние публикации (Publish Status) | Указывает, какие файлы опубликованы на web-узле, сообщает даты их последнего изменения и статус обновления
Использование | Статистика использования, ежемесячные, еженедельные, ежедневные итоги, статистика обращений к страницам, информация о посетителях, и т. д.

ТАБЛИЦА 22.2. Итоговые характеристики обзора узла
Параметр | Назначение
Рисунки (Pictures) | Количество и общий размер графических файлов узла
Связанные файлы (Linked Files) | Количество файлов, связанных с домашней страницей той или иной последовательностью гиперссылок
Гиперссылки (Hyperlinks) | Общее число гиперссылок на всех страницах узла
Непроверенные гиперссылки (UnverifiedHyperlinks ) | Число гиперссылок, статус которых на данный момент неизвестен
Внешние гиперссылки (External Hyperlinks) | Количество ссылок на ресурсы, расположенные вне файлов данного web-узла
Внутренние гинерссылки (Internal Hyperlinks) | Количество ссылок, указывающих па объекты файлов данного web-узла
Незавершенные задачи (Uncompleted Tasks) | Число задач, помеченных как невыполненные. Двойной щелчок на этой строке открывает режим просмотра задач
Неиспользуемые схемы (Unused Themes) | Количество цветовых схем, хранящихся в структуре узла, по не использующихся в реальных web-страницах. Двойной щелчок на этом пункте позволяет удалить лишние цветовые схемы

  2. Чтобы просмотреть список неработающих гиперссылок, дважды щелкните в обзоре узла на строке Неработающие гиперссылки.

Рис. 22.15. Список разорванных гиперссылок

В отчете показаны две такие ссылки (рис. 22.15). Первая появилась в результате переименования файла в предыдущем упражнении, вторая — после удаления файла УслугиЗ в упражнении 3. Давайте исправим эти недостатки.

  3. Дважды щелкните на строке разорванной гиперссылки prod03.htm.

  4. В поле Заменить гиперссылкой (Replace Hyperlink With) открывшегося окна диалога введите новое название файла prod04. htm.

Рис. 22.16. Правка web-страницы

  5. Щелкните на кнопке Заменить (Replace). Первый пункт списка разорванных ссылок исчезнет, что говорит о корректности исправленной ссылки.

  6. Щелкните на строке ссылки serv03.htm правой кнопкой мыши и выберите в контекстном меню команду Изменить страницу (Edit Page). Файл serv03.htm откроется в режиме страницы, и в нем будет выделена неверная ссылка, как показано на рис. 22.16.

  7. Нажатием клавиши Delete удалите ссылку.

  8. Выберите команду Файл > Закрыть (File > Close).

  9. Щелчком на кнопке Да подтвердите необходимость сохранения измененной web-страницы.

  10. Чтобы вернуться к списку неработающих гиперссылок, щелкните на значке Reports (Отчеты) панели режимов. Теперь этот список будет пуст, значит, все ссылки работают корректно.

Оформление web-узла

Объединение группы web-страниц в единую структуру узла позволяет программе Frontpage не только отслеживать схему построения ссылок между страницами, но и обеспечивать однотипное оформление всех страниц узла.

Упражнение 6. Выбор оформления

Каждый web-узел строится на основе определенной схемы, задающей однотипное оформление всем стандартным элементам страниц. При разработке узла в любой момент можно сменить схему. Для этого следует выполнить следующие шаги.

  1. Выберите команду Формат > Тема (Format > Theme). Откроется окно диалога, показанное на рис. 22.18. В нем вы увидите выбранную схему, с помощью которой оформлена страница, представленная ранее на рис. 22.16.

  2. В списке схем подыщите ту расцветку, которая больше всех подходит для разрабатываемого узла, например, выберите вариант Industrial (Индустриальный). В левой нижней части окна диалога есть четыре флажка, установка которых позволяет выполнять следующие действия:

  • Яркие цвета (Vivid Color) — раскрашивает выбранную схему более яркими цветами;

  • Активные рисунки (Active Graphics) — усложняет рисунок ссылок, кнопок и маркеров, добавляя тени и мелкие детали;

  • Фоновый рисунок (Background Picture) — размещает на заднем плане страницы фоновый рисунок;

Рис. 22.17. Выбор стандартной схемы

  • Применить с помощью CSS (Apply Using CSS) — назначает новое оформление с помощью каскадных таблиц стилей, добавляемых в HTML-код. Каскадные таблицы со стилями можно подключать к любому HTML-файлу, формируя на основе этих стилей оформление элементов страницы. При таком подходе для изменения вида целого web-узла достаточно лишь модифицировать таблицы стилей, которые, как правило, хранятся в отдельных файлах. Это помогает администраторам больших узлов сохранять единообразие всех документов, размещенных на web-сервере.

  3. Установите флажки Активные рисунки и Применить с помощью CSS. Если вас не устраивают стандартные схемы, модифицируйте параметры одной из них.

  4. Щелкните на кнопке Изменить (Modify). В окне появятся дополнительные кнопки, дающие доступ к следующим инструментам:

  • кнопка Цвета (Colors) открывает окно диалога с тремя вкладками. Первая из них — Цветовые схемы (Color Schemes) — позволяет выбрать одну из стандартных расцветок, доступных для данного варианта оформления страниц. Вкладка Цветовой круг (Color Wheel) дает возможность задать цветовой тон щелчком в пространстве цветов и установить яркость раскраски с помощью движка Яркость (Brightness). Третья вкладка Другой (Custom) имеет два раскрывающихся списка. В первом можно выбрать любой стандартный элемент страницы, а затем с помощью второго назначить этому элементу произвольный цвет;

  • щелчок на кнопке Графика (Graphics) открывает окно, показанное на рис. 22.18. В раскрывающемся списке Элемент (Item) выберите любой из стандартных элементов web-страницы. С помощью кнопок Обзор (Browse) вкладки Рисунок (Picture) назначьте в качестве его оформления любой графический файл, а на вкладке Шрифт (Font) подберите тексту этого элемента подходящее начертание. Повторяя эти операции, настройте все элементы страницы;

Рис. 22.18. Изменение схемы

  • кнопка Текст (Text) позволяет настроить начертание шрифта обычного текста web-страницы и шести заголовочных стилей. Выбирайте в списке Элемент стиль, который нужно изменить, а затем с помощью списка Шрифт (Font) назначайте ему нужный шрифт.

  5. Закончив модификацию схемы и вернувшись в окно диалога Темы (Themes), щелкните на кнопке Сохранить как (Save As).

  6. Введите в открывшемся окне название Схема пользователя и щелкните на кнопке ОК, чтобы сохранить новую схему в библиотеке.

  7. Чтобы присвоить выбранную схему всем страницам узла, выберите положение переключателя Ко всем страницам (All Pages).

  8. Щелкните на кнопке ОК.

Примечание

Для подбора схемы определенной страницы откройте HTML-файл в ре- жиме Страница или выделите его в окне переходов. Затем выполните команду формат > Тема, найдите нужный вариант оформления, выберите положение переключателя Выделенная страница (Selected Page), а затем щелкните на кнопке ОК.

После добавления в библиотеку новая схема становится доступной для всех web-узлов, разрабатываемых во Frontpage. Применяя такие схемы, вы легко сможете задать одинаковое оформление нескольким тематически связанным узлам.

Упражнение 7. Общие поля элементов

Одновременная разработка всех web-страниц узла в пределах одного проекта Frontpage имеет неоспоримые преимущества. Одно из них — быстрая смена оформления всех страниц — было освещено в предыдущем упражнении. С помощью Frontpage можно также добавлять на страницы узла общие поля, содержащие однотипные элементы заголовков и навигации. Содержимое таких общих полей обновляется автоматически при изменении структуры web-узла в окне навигатора. Чтобы настроить общие поля одной из страниц, выполните следующие шаги.

  1. Щелкните на значке Переходы панели режимов.

  2. Дважды щелкните на странице Товары, чтобы открыть ее в режиме просмотра Страница. Общие поля страницы отделяются от основного содержания пунктирными линиями (рис. 22.19).

Рис. 22.19. Общие поля

  3. Выберите команду Формат > Общие границы (Format > Shared Borders). Откроется окно диалога, показанное на рис. 22.20. В нем есть четыре флажка, инициирующих размещение общего поля с каждой из четырех сторон страницы:

  • Сверху (Top) — верхнее поле, в котором обычно размещается баннер (красочный заголовок, иногда с набором гиперссылок);

  • Слева (Left) — поле вдоль левого края страницы с кнопками ссылок на подчиненные страницы;

  • Справа (Right) — общее поле вдоль правого края, которое, как правило, не используется;

  • Внизу (Bottom) — поле по нижнему краю страницы. В нем обычно размещаются ссылки на дочерние, родительскую и домашнюю страницы, выполненные в текстовой форме на тот случай, если браузер пользователя не может отображать графические объекты либо в нем отключен соответствующий режим.

  4. Сбросьте все флажки и щелкните на кнопке О К. Вы увидите, что со страницы исчезли кнопки навигации и заголовок, автоматически размещаемые в полях общих элементов. Если вы предпочитаете самостоятельно размещать ссылки и заголовки, вам нужен именно этот вариант.

  5. Снова выберите команду Формат > Общие границы.

  6. Установите флажок Восстановить границы, используемые по умолчанию на веб-узле (Reset Borders For Current Page To Web Default).

  7. Щелкните на кнопке ОК. Frontpage вернет на страницу элементы навигации, размещаемые по умолчанию.

  8. Командой Файл > Закрыть Веб-узел (File > Close Web) закройте web-узел и все открытые web-страницы, подтверждая сохранение выполненных изменений.

Рис. 22.20. Настройка общих полей

Контрольное упражнение

Чтобы закрепить навыки работы со структурой web-узла, попробуйте самостоятельно выполнить следующие действия.

  1. Откройте web-узел, созданный на этом занятии.

  2. Включите режим переходов.

  3. Оставьте видимой на экране только страницу Товары и все подчиненные ей страницы.

    • Как в окне переходов оставить видимой только одну ветвь web-узла?

  4. Увеличьте масштаб просмотра до 100 %.

  5. Перетащите страницу Справочник вниз, чтобы ссылки на нее появлялись ниже ссылок остальных страниц группы Товары.

  6. Добавьте для страницы Товары задачу, информирующую о необходимости изменения оформления этой страницы.

  7. Запустите эту задачу, чтобы открыть страницу Товары в режиме Страница.

    • Какими приемами можно открыть web-страницу врежиме про смотра Страница?

  8. Выберите для активной страницы схему оформления Expedition.

  9. Измените цвета схемы, выбрав стандартный вариант Barcode.

  10. Назначьте заголовкам первого уровня новой схемы шрифт Anal.

  11. Сохраните полученную схему под именем Новая схема.

  12. Закройте web-страницу Товары, не сохраняя выполненные изменения.

  13. Пометьте задачу, добавленную на шаге 7, как выполненную.

    • Как изменить статус задачи?

  14. Закройте web-узел.

Подведение итогов

Упражнения этого занятия научили вас ориентироваться в режимах просмотра web-узла. Теперь вы знаете, как создать узел с помощью мастера, где настраивается схема связей между страницами, как сохранить список действий, описывающих задачи разработчика. Вы можете получить статистическую информацию об узле и отыскать некорректные ссылки. Наконец, вы можете изменить оформление узла и настроить общие поля страниц.

Следующее упражнение посвящено вопросам разработки и модификации отдельных web-страниц с помощью встроенного HTML-редактора приложения Frontpage.


Занятие №22

ЧАСТЬ VII

Frontpage

Microsoft Frontpage XP — современная интегрированная оболочка для построения отдельных web-страниц и целых web-узлов. Даже неопытный пользователь, незнакомый с языками программирования, сможет с помощью Frontpage самостоятельно создать свой собственный web-узел и опубликовать его в Интернете. Web-редактор Frontpage станет прекрасным дополнением и для арсенала опытного Web-дизайнера.

Построение web-узла

ТЕМА ЗАНЯТИЯ

На этом занятии вы познакомитесь с новым приложением Microsoft Office — редактором web-узлов программой Frontpage. Вы научитесь создавать и модифицировать структуру узла. Ниже перечислены некоторые компоненты и операции, рассматриваемые в упражнениях занятия:

  • мастер web-узла;

  • список задач;

  • просмотр папок узла;

  • навигация;

  • проверка гиперссылок;

  • отчеты;

  • цветовая схема узла;

  • общие поля страницы.

Web-узел — это набор файлов в формате HTML, расположенных в определенной папке и связанных друг с другом гиперссылками. Один из файлов web-узла назначается главным, он представляет собой домашнюю страницу и открывается в браузере пользователя при подключении к web-узлу. Остальные web-страницы выводятся в окно браузера по мере перехода к ним по гиперссылкам. Кроме файлов HTML в состав узла входит набор графических объектов формата GIF или JPG, предназначенных для оформления страниц. С развитием браузеров, предлагающих самые разнообразные расширения стандарта HTML, в web-узлах все чаще стали появляться файлы других форматов.


Создание web-узла

Frontpage ХР — это интегрированная среда, содержащая редактор web-страниц, модули управления структурой узла и инструменты публикации узла на сервере. С помощью Frontpage даже совершенно не знакомый с языком HTML новичок может сконструировать вполне работоспособный web-узел. В руках опытного пользователя Frontpage становится мощным инструментом, позволяющим строить web-узлы любой сложности.

Примечание

Во Frontpage ХР три отдельных модуля — редактор страниц, компоновщик узла и средств поддержки web-сервера объединены в одну интегрированную оболочку, обеспечивающую удобный доступ ко всем инструментам.


Упражнение 1. Мастер web-узла

Чтобы создать законченный web-узел, недостаточно просто разместить в одной папке несколько HTML-файлов. Грамотно построенный узел имеет хорошо продуманную структуру. Это облегчает пользователю поиск необходимой информации. Если у вас нет большого опыта работы с web-страницами, мастер web-узла поможет правильно скомпоновать узел, а вам останется только наполнить страницы содержанием. Чтобы прибегнуть к услугам мастера, выполните следующие шаги.

  1. Запустите Frontpage.

  2. Выберите команду Файл > Создать ^ Страница или web-узел (File > New > Web). В области задач приложения откроется окно Создание web-страниц (New Page or Web) со списком шаблонов и мастеров, которыми можно воспользоваться для построения web-узла (рис. 22.1).

  3. В разделе Создание с помощью шаблона (New from Template) щелкните на значке Шаблоны веб-узлов (Web Site Template) и в появившемся окне диалога Шаблоны веб-узлов (Web Site Templates) щелкните на значке Мастер корпоративного веб-узла (Corporate Presence Wizard).

  4. В поле раздела Options (Параметры) введите название папки, в которой будут храниться файлы узла (я буду пользоваться для этих целей папкой С: \Мои документы\Му Webs\Corporate).

Рис. 22.1. Мастера и шаблоны web-узлов

  5. Щелкните на кнопке ОК.

  6. В первом окне мастера щелкните на кнопке Далее (Next).

    Второе окно предлагает список основных web-страниц, которые можно включить в новый web-узел:

    • Домашняя страница (Home Page);
    • Что нового (What's New);
    • Товары и услуги (Products/Services);
    • Оглавление (Table of Contents);
    • Обратная связь (FeedBack form);
    • Форма поиска (Search form).

  7. Оставьте установленными все флажки и щелкните на кнопке Далее. Следующее окно мастера, показанное на рис. 22.2, предлагает определить вид домашней страницы. Устанавливая и сбрасывая флажки этого окна, вы добавляете или убираете соответствующие разделы домашней страницы.

  8. Установите все четыре флажка.

  9. Щелкните на кнопке Далее.

Шесть следующих окон диалога мастера настраивают вид страницы определенного типа (из тех, которые были выбраны во втором окне мастера). Последовательно изучите каждое окно и установите флажки для тех компонентов, которые необходимо включить в web-узел. В последующих упражнениях этого занятия предполагается, что в этих шести окнах были оставлены те варианты настройки, которые предлагаются мастером по умолчанию.

Рис. 22.2. Мастер корпоративного узла

  10. Десятое окно мастера задает общее оформление всех страниц. Установите флажки этого окна в соответствии с рис. 22.3, затем щелкните два раза на кнопке Далее.

Рис. 22.3. Настройка оформления страниц

  11. Введите полное название компании, то же самое название, сокращенное до одного слова, и адрес компании. Щелкните на кнопке Далее.

  12. В следующем окне введите телефон компании, номер факса, электронный адрес web-мастера и адрес информационной поддержки. Щелкните два раза на кнопке Далее, а затем на кнопке Готово (Finish). Мастер сгенерирует новый web-узел и откроет его в режиме просмотра задач со списком действий, которые необходимо выполнить для получения законченного узла. Пункты этого списка, показанные на рис. 22.4, были добавлены мастером. В них перечислены операции, с помощью которых вы должны наполнить смысловым содержанием сформированные web-страницы. В процессе разработки узла можно вручную добавлять новые задачи, связанные с той или иной web-страницей. Вы научитесь этому в следующем упражнении. Список задач всегда под рукой, он хранится вместе с файлами web-узла и не даст позабыть о незавершенных операциях. Чтобы открыть его, достаточно щелкнуть на кнопке Задачи (Tasks) панели режимов.

Рис. 22.4. Просмотр задач

Примечание

Чтобы добавить задачу, выберите команду файл > Создать > Задача (File > New > Task). Для изменения параметров конкретной задачи дважды щелкните на ее строке.


Упражнение 2. Режимы просмотра

Frontpage предлагает шесть режимов просмотра web-узла, кнопки которых имеются на панели режимов:

  • Страница (Page) — редактор отдельной web-страницы. В этом режиме можно изменять содержание любой страницы узла, настраивать ее оформление и просматривать HTML-код, на основе которого генерируется страница;

  • Папки (Folders) — список папок и файлов web-узла с их подробными характеристиками, подобный списку окна Проводника Windows;

  • Отчеты (Reports) — статистическая информация об узле и отдельных его компонентах;

  • Переходы (Navigation) — редактор структуры web-узла, позволяющий в графическом режиме изменять связи и перестраивать гиперссылки;

  • Гиперссылки (Hyperlinks) — список web-страниц узла и схема гиперссылок выделенной страницы;

  • Задачи (Tasks) — список задач, связанных с определенными файлами, которые нужно не забыть выполнить для завершения разработки узла.

Переключать режимы просмотра можно как с помощью команд меню Вид (View), так и посредством кнопок панели режимов, расположенной в левой части окна Frontpage.

Рис. 22.5. Режим просмотра папок

  1. Чтобы просмотреть список файлов, сгенерированных мастером web-узла, щелкните на кнопке Папки (Folders) панели режимов. Окно Frontpage разделится на две области (рис. 22.5). В левую будет выведен список папок, вложенных в папку С:\Мот документы\Согрога1е (в которой хранятся все файлы текущего web-узла), а в правую — значки файлов корневой папки узла.

Примечание

Режим просмотра Папки (Folders)-Ha самом деле отображает не все файлы web-узла, а только те, которые несут определенную смысловую нагрузку. Вспомогательные папки, содержащие графические файлы стандартных элементов оформления и файлы поддержки расширений Frontpage, остаются скрытыми.

  2. Чтобы просмотреть список изображении, используемых в web-узле, щелк-к ните на значке папки images.

  3. Дважды щелкните на файле smallnsw.gif. Frontpage запустит программу, предназначенную для просмотра файлов формата GIF, и откроет в ней выбранный файл.

  4. Полюбуйтесь на значок, выбранный мастером, и закройте графическую программу.

  5. Для возврата в предыдущую папку щелкните в панели списка файлов правой кнопкой мыши и выберите в контекстном меню команду Вверх на один уровень (Up One Level).

  6. Выберите команду Файл > Создать > Папка (File > New > Folder). В списке папок появится значок новой папки с именем Новая папка. Щелкните на нем правой кнопкой мыши и в контекстном меню выберите команду Переименовать (Rename).

  7. Введите текст Дополнения. Это будет имя новой папки.

  8. В списке папок щелкните на значке Дополнения, чтобы открыть новую папку.

  9. Щелкните в пустом списке файлов правой кнопкой мыши и выберите команду Создать страницу (New Page).

  10. В качестве имени новой web-страницы введите Справочник. htm. Мы не будем сейчас наполнять новую страницу содержанием, но, чтобы не забыть о необходимости сделать это в дальнейшем, запишем соответствующий пункт в список задач.

  11. Щелкните на значке Справочник.htm. Выполните команду Файл > Создать > Задача.

  12. В поле Имя задачи (Task Name) открывшегося окна создания задачи (рис. 22.6) введите текст Создать страницу и ссылки.

Рис. 22.6. Добавление задачи

  13. Нажмите клавишу Tab и введите имя исполнителя задачи.

  14. В поле описания введите текст Создать страницу справочника по продуктам компании с таблицей, добавить ссылки с домашней страницы и на страницы описания продуктов.

  15. Щелкните на кнопке ОК.

  16. Выберите команду Вид > Задачи (View > Tasks). В списке операций вы увидите только что добавленную задачу со статусом Не запущена (Not Started).


Упражнение 3. Переходы

Мастер web-узла конструирует ссылки между страницами по определенному алгоритму. Вам может не понравиться созданная им структура связей. С помощью режима просмотра Переходы можно увидеть общую схему узла, добавить или разорвать определенные ссылки, скорректировать правила размещения ссылок в панелях навигации web-страниц.

  1. Щелкните на кнопке Переходы (Navigation) панели режимов.

  2. Чтобы вместить в область экрана всю схему узла, выберите в раскрывающемся списке Масштаб (Zoom) панели инструментов Переходы (Navigation) пункт По размеру данных (Size To Fit).

Рис. 22.7. Режим навигации

Теперь структура навигации будет выглядеть так, как показано на рис. 22.7. Каждая страница узла обозначается прямоугольником. Линии, соединяющие эти прямоугольники, символизируют взаимную подчиненность страниц. Например, страница Услуги (Services), с одной стороны, подчинена домашней странице Домой (Ноmе). Это означает, что Frontpage автоматически разместит в нижней части страницы Услуги ссылку на домашнюю страницу. С другой стороны, страница Услуги обеспечивает доступ к трем подчиненным страницам Услуги 1, Услуги 2 и Услуги 3. Frontpage поместит ссылки на них в самом начале страницы Услуги. Давайте изучим такие ссылки.

  3. Чтобы перейти из навигатора к просмотру страницы Услуги, дважды щелкните на ее прямоугольнике. При этом автоматически включается режим Страница.

  4. С помощью вертикальной полосы прокрутите содержимое страницы Услуги вниз, чтобы увидеть ссылки, расположенные в ее нижней части, как показано на рис. 22.8. Обратите внимание, что Frontpage дополнительно поместил ссылки на подчиненные страницы в левом поле, а ссылка на родительскую страницу Домой присутствует только внизу.

Рис. 22.8. Режим просмотра страницы

Примечание

Опробуйте действие имеющихся гиперссылок. Чтобы активизировать ссылку в режиме Страница, щелкните на ней, удерживая нажатой клавишу Ctrl. Перемещаясь по страницам с помощью ссылок, сравните структуру страниц со схемой навигатора узла.

  5. С помощью команды Вид > Способ перехода (View > Navigation) вернитесь в режим переходов.

  6. В левой части экрана расположена панель папок web-узла. Разверните в ней папку Дополнения, щелкнув на соответствующем значке «плюс». В этой папке расположена web-страница, созданная в предыдущем упражнении. Пока что она не включена в состав узла. Если предположить, что эта страница будет содержать сводную таблицу характеристик товаров фирмы, то ее следует подчинить странице Продукты (Products).

  7. Поместите указатель на значок Справочник.htm панели папок.

  8. Нажмите кнопку мыши и перетащите указатель в область схемы узла, чтобы появился прямоугольник новой страницы.

  9. Разместите прямоугольник выше прямоугольника Продукт1, чтобы линия связи соединяла новую страницу со страницей Продукты. Затем отпустите кнопку мыши. Frontpage добавит в структуру узла страницу Дополнения/ Cnpaвочник.htm и поместит ссылку на нее в левое поле ссылок страницы Продукты. В режиме навигатора можно не только добавлять новые, но и удалять ненужные страницы.

  10. Щелкните на странице Услуги 3 правой кнопкой мыши и выберите в контекстном меню команду Удалить (Delete).

  11. В открывшемся окне диалога выберите положение переключателя Удалить страницу с Web-узла (Delete This Page From The Web), азатем щелкните на кнопке ОК. Файл страницы будет удален с диска, а его значок — из схемы узла и всех папок.

Рис. 22.9. Переименованные страницы

Ориентацию схемы можно изменить, щелкнув на кнопке Портретная/альбомная (Portrait/Landscape) панели инструментов Переход.

Примечание

Выбор положения переключателя Удалить страницу из структуры переходов (Remove Page From The Navigation Structure) удаляет ссылки на данную страницу из панелей других страниц, но сохраняет файл страницы на жестком диске.

  12. Заголовок Дополнения/Справочник.htm не слишком хорош для web-страницы. Чтобы изменить его, щелкните на прямоугольнике этой страницы правой кнопкой мыши и выберите команду Переименовать, затем введите текст Справочник товаров. Этот же текст теперь будет использоваться в качестве заголовка на самой web-странице.

  13. Нажмите клавишу Tab. Frontpage автоматически перейдет в режим редактирования названия следующей страницы. Введите слово Трубы.

  14. Переименуйте другие страницы в соответствии с рис. 22.9, перемещаясь по ним с помощью клавиш Tab и Shift+Tab. Как видно из схемы узла, страницы Отзывы и Содержание не связаны с другими страницами. Чтобы предоставить пользователю доступ к этим двум страницам, выполните следующие действия.

  15. Перетащите прямоугольник страницы Содержание вправо вверх, подчинив его домашней странице Геркулес и разместив выше страницы Новости.

Примечание

Порядок расположения прямоугольников в схеме узла небезразличен, он определяет порядок размещения ссылок в панелях навигации web-страниц.

  16. Перетащите страницу Отзывы вправо, переместив ее в подчинение группе Услуги, как показано на рис. 22.10.

Рис. 22.10. Новая структура узла


Упражнение 4. Гиперссылки

Режим просмотра гиперссылок позволяет просматривать дерево гиперссылок и проверять работоспособность внутренних и внешних ссылок узла.

  1. Чтобы вывести дерево гиперссылок, щелкните в панели режимов на значке Гиперссылки (Hyperlinks). На экран будет выведен список папок и дерево гиперссылок. Обратите внимание в списке папок на миниатюру файла index.htm в виде домика. Это файл домашней страницы.

  2. В панели списка папок щелкните на файле products, htm.

Frontpage поместит значок выбранной страницы в середину окна и линиями покажет все ссылки, имеющиеся на этой странице (рис. 22.11). Давайте смоделируем некорректную гиперссылку, переименовав один из файлов web-узла.

Рис. 22.11. Просмотр гиперссылок

  3. Щелкните на значке prod03.htm и выберите команду Переименовать.

  4. Введите текст pi-od04. htm и нажмите клавишу Enter.

  5. Откроется окно диалога, предлагающее обновить Гиперссылки, указывающие на переименованную страницу. Щелкните в нем на кнопке Нет (No).

  6. Щелчком на значке products.htm вернитесь к прежней схеме. Выберите команду Сервис > Пересчитать гиперссылки (Tools > Recalculate Hyperlinks).

  7. В открывшемся окне диалога щелкните на кнопке Да. Frontpage просмотрит ссылки web-узла и проверит их состояние (при работе с большими узлами этот процесс может занять продолжительное время). Программа обнаружит на странице products, htm ссылку на несуществующий файл prod03.htm. Это отразится на схеме (рис. 22.12).

Рис. 22.12. Разорванная гиперссылка

Примечание

Обычно следует выбирать ответ Да (Yes). Этот вариант дает указание Frontpage скорректировать ссылки так, чтобы смена имени файла не внесла путаницы в структуру узла и не нарушила его работоспособность. По указанной причине никогда не переименовывайте файлы узла в Проводнике или с помощью других инструментов Windows. Пользуйтесь для этих целей списком файлов в окне Frontpage. Операционная система в отличие от Frontpage не способна модифицировать другие web-страницы, приводя их ссылки в соответствие новому имени файла.

Рис. 22.13. Раскрытие ветвей ссылок

Обратите внимание, что миниатюры файлов, связанных со страницей products, htm снабжены символами «плюс». Они разворачивают соответствующую ветвь паутины ссылок.

  8. Щелкните на значке «плюс» миниатюры prod0l.htm.

  9. Затем щелкните на значке «плюс» появившейся миниатюры index.htm. В окне появится новый фрагмент web-узла, показанный на рис. 22.13.

Такое раскрытие ветвей в схеме гиперссылок позволяет наглядно моделировать логику работы узла, не открывая сами web-страницы, загрузка которых часто занимает много времени и оперативной памяти.


Упражнение 5. Отчеты

Поиск разорванных ссылок в схеме гиперссылок, описанной в предыдущем упражнении, — не слишком большое удовольствие. Вы потратите много времени на перебор всех страниц и все же, вполне вероятно, не заметите каких-то деталей. К счастью, Frontpage предлагает разработчику целый набор отчетов, несущих в себе различную статистическую информацию о web-узле.

  1. Чтобы увидеть итоговую информацию Frontpage о данном узле, выберите команду Вид > Отчеты > Сводка веб-узла (View > Reports > Site Summary).

Рис. 22.14. Обзор web-узла

Откроется таблица с обзором основных параметров узла (рис. 22.14). Некоторые пункты представляют сводную информацию из более подробного отчета на данную тему, который можно открыть двойным щелчком на соответствующей строке, а также выбором пункта в меню Вид > Отчеты (View » Reports) или в раскрывающемся списке панели инструментов Отчеты (Reports). Назначение отчетов Frontpage описано в табл. 22.1. Пункты обзора узла, не открывающие доступ к отдельным отчетам (и не попавшие по этой причине в табл. 22.1), а лишь дающие итоговое значение определенного параметра, перечислены в табл. 22.2.

ТАБЛИЦА 22.1. Отчеты Frontpage
Отчет | Назначение
Все файлы (All Files) | Список всех файлов web-узла с указанием их размера, местоположения и даты обновления
Недавно добавленные файлы (Recently Added Files) | Файлы, созданные в течение нескольких последних недель
Недавно измененные файлы (Recently Changed Files) | Список файлов, обновлявшихся за несколько последних недель
Старые файлы | Файлы, которые нс обновлялись длительное (Older Files) время
Потерянные файлы (Unlinked Files) | Список файлов, которые нельзя открыть с домашней страницы путем последовательной активизации гиперссылок
Медленные страницы (Slow pages) | Web-страницы, на загрузку которых с удаленного компьютера уйдет слишком много времени
Неработающие гиперссылки (Broken Hyperlinks) | Список ссылок, содержащих ошибки, то есть таких, точка назначения которых неизвестна
Ошибки компонентов (Component Errors) | Логические ошибки, найденные программой Frontpage при просмотре страниц
Состояние проверки (Review Status) | Демонстрирует способ обновления файлов (например обновление с помощью кода Active Server Page), если таковой назначен
Назначено (Assigned To) | Любому файлу web-узла в целях предотвращения путаницы в процессе разработки можно назначить принадлежность определенной рабочей группе или конкретному разработчику. Этот отчет показывает принадлежность файлов
Категории (Categories) | Демонстрирует категории, назначенные файлам при разработке узла, а также их типы и местоположение в структуре папок
Состояние публикации (Publish Status) | Указывает, какие файлы опубликованы на web-узле, сообщает даты их последнего изменения и статус обновления
Использование | Статистика использования, ежемесячные, еженедельные, ежедневные итоги, статистика обращений к страницам, информация о посетителях, и т. д.

ТАБЛИЦА 22.2. Итоговые характеристики обзора узла
Параметр | Назначение
Рисунки (Pictures) | Количество и общий размер графических файлов узла
Связанные файлы (Linked Files) | Количество файлов, связанных с домашней страницей той или иной последовательностью гиперссылок
Гиперссылки (Hyperlinks) | Общее число гиперссылок на всех страницах узла
Непроверенные гиперссылки (UnverifiedHyperlinks ) | Число гиперссылок, статус которых на данный момент неизвестен
Внешние гиперссылки (External Hyperlinks) | Количество ссылок на ресурсы, расположенные вне файлов данного web-узла
Внутренние гинерссылки (Internal Hyperlinks) | Количество ссылок, указывающих па объекты файлов данного web-узла
Незавершенные задачи (Uncompleted Tasks) | Число задач, помеченных как невыполненные. Двойной щелчок на этой строке открывает режим просмотра задач
Неиспользуемые схемы (Unused Themes) | Количество цветовых схем, хранящихся в структуре узла, по не использующихся в реальных web-страницах. Двойной щелчок на этом пункте позволяет удалить лишние цветовые схемы

  2. Чтобы просмотреть список неработающих гиперссылок, дважды щелкните в обзоре узла на строке Неработающие гиперссылки.

Рис. 22.15. Список разорванных гиперссылок

В отчете показаны две такие ссылки (рис. 22.15). Первая появилась в результате переименования файла в предыдущем упражнении, вторая — после удаления файла УслугиЗ в упражнении 3. Давайте исправим эти недостатки.

  3. Дважды щелкните на строке разорванной гиперссылки prod03.htm.

  4. В поле Заменить гиперссылкой (Replace Hyperlink With) открывшегося окна диалога введите новое название файла prod04. htm.

Рис. 22.16. Правка web-страницы

  5. Щелкните на кнопке Заменить (Replace). Первый пункт списка разорванных ссылок исчезнет, что говорит о корректности исправленной ссылки.

  6. Щелкните на строке ссылки serv03.htm правой кнопкой мыши и выберите в контекстном меню команду Изменить страницу (Edit Page). Файл serv03.htm откроется в режиме страницы, и в нем будет выделена неверная ссылка, как показано на рис. 22.16.

  7. Нажатием клавиши Delete удалите ссылку.

  8. Выберите команду Файл > Закрыть (File > Close).

  9. Щелчком на кнопке Да подтвердите необходимость сохранения измененной web-страницы.

  10. Чтобы вернуться к списку неработающих гиперссылок, щелкните на значке Reports (Отчеты) панели режимов. Теперь этот список будет пуст, значит, все ссылки работают корректно.


Оформление web-узла

Объединение группы web-страниц в единую структуру узла позволяет программе Frontpage не только отслеживать схему построения ссылок между страницами, но и обеспечивать однотипное оформление всех страниц узла.


Упражнение 6. Выбор оформления

Каждый web-узел строится на основе определенной схемы, задающей однотипное оформление всем стандартным элементам страниц. При разработке узла в любой момент можно сменить схему. Для этого следует выполнить следующие шаги.

  1. Выберите команду Формат > Тема (Format > Theme). Откроется окно диалога, показанное на рис. 22.18. В нем вы увидите выбранную схему, с помощью которой оформлена страница, представленная ранее на рис. 22.16.

  2. В списке схем подыщите ту расцветку, которая больше всех подходит для разрабатываемого узла, например, выберите вариант Industrial (Индустриальный). В левой нижней части окна диалога есть четыре флажка, установка которых позволяет выполнять следующие действия:

  • Яркие цвета (Vivid Color) — раскрашивает выбранную схему более яркими цветами;

  • Активные рисунки (Active Graphics) — усложняет рисунок ссылок, кнопок и маркеров, добавляя тени и мелкие детали;

  • Фоновый рисунок (Background Picture) — размещает на заднем плане страницы фоновый рисунок;

Рис. 22.17. Выбор стандартной схемы

  • Применить с помощью CSS (Apply Using CSS) — назначает новое оформление с помощью каскадных таблиц стилей, добавляемых в HTML-код. Каскадные таблицы со стилями можно подключать к любому HTML-файлу, формируя на основе этих стилей оформление элементов страницы. При таком подходе для изменения вида целого web-узла достаточно лишь модифицировать таблицы стилей, которые, как правило, хранятся в отдельных файлах. Это помогает администраторам больших узлов сохранять единообразие всех документов, размещенных на web-сервере.

  3. Установите флажки Активные рисунки и Применить с помощью CSS. Если вас не устраивают стандартные схемы, модифицируйте параметры одной из них.

  4. Щелкните на кнопке Изменить (Modify). В окне появятся дополнительные кнопки, дающие доступ к следующим инструментам:

  • кнопка Цвета (Colors) открывает окно диалога с тремя вкладками. Первая из них — Цветовые схемы (Color Schemes) — позволяет выбрать одну из стандартных расцветок, доступных для данного варианта оформления страниц. Вкладка Цветовой круг (Color Wheel) дает возможность задать цветовой тон щелчком в пространстве цветов и установить яркость раскраски с помощью движка Яркость (Brightness). Третья вкладка Другой (Custom) имеет два раскрывающихся списка. В первом можно выбрать любой стандартный элемент страницы, а затем с помощью второго назначить этому элементу произвольный цвет;

  • щелчок на кнопке Графика (Graphics) открывает окно, показанное на рис. 22.18. В раскрывающемся списке Элемент (Item) выберите любой из стандартных элементов web-страницы. С помощью кнопок Обзор (Browse) вкладки Рисунок (Picture) назначьте в качестве его оформления любой графический файл, а на вкладке Шрифт (Font) подберите тексту этого элемента подходящее начертание. Повторяя эти операции, настройте все элементы страницы;

Рис. 22.18. Изменение схемы

  • кнопка Текст (Text) позволяет настроить начертание шрифта обычного текста web-страницы и шести заголовочных стилей. Выбирайте в списке Элемент стиль, который нужно изменить, а затем с помощью списка Шрифт (Font) назначайте ему нужный шрифт.

  5. Закончив модификацию схемы и вернувшись в окно диалога Темы (Themes), щелкните на кнопке Сохранить как (Save As).

  6. Введите в открывшемся окне название Схема пользователя и щелкните на кнопке ОК, чтобы сохранить новую схему в библиотеке.

  7. Чтобы присвоить выбранную схему всем страницам узла, выберите положение переключателя Ко всем страницам (All Pages).

  8. Щелкните на кнопке ОК.

Примечание

Для подбора схемы определенной страницы откройте HTML-файл в ре- жиме Страница или выделите его в окне переходов. Затем выполните команду формат > Тема, найдите нужный вариант оформления, выберите положение переключателя Выделенная страница (Selected Page), а затем щелкните на кнопке ОК.

После добавления в библиотеку новая схема становится доступной для всех web-узлов, разрабатываемых во Frontpage. Применяя такие схемы, вы легко сможете задать одинаковое оформление нескольким тематически связанным узлам.


Упражнение 7. Общие поля элементов

Одновременная разработка всех web-страниц узла в пределах одного проекта Frontpage имеет неоспоримые преимущества. Одно из них — быстрая смена оформления всех страниц — было освещено в предыдущем упражнении. С помощью Frontpage можно также добавлять на страницы узла общие поля, содержащие однотипные элементы заголовков и навигации. Содержимое таких общих полей обновляется автоматически при изменении структуры web-узла в окне навигатора. Чтобы настроить общие поля одной из страниц, выполните следующие шаги.

  1. Щелкните на значке Переходы панели режимов.

  2. Дважды щелкните на странице Товары, чтобы открыть ее в режиме просмотра Страница. Общие поля страницы отделяются от основного содержания пунктирными линиями (рис. 22.19).

Рис. 22.19. Общие поля

  3. Выберите команду Формат > Общие границы (Format > Shared Borders). Откроется окно диалога, показанное на рис. 22.20. В нем есть четыре флажка, инициирующих размещение общего поля с каждой из четырех сторон страницы:

  • Сверху (Top) — верхнее поле, в котором обычно размещается баннер (красочный заголовок, иногда с набором гиперссылок);

  • Слева (Left) — поле вдоль левого края страницы с кнопками ссылок на подчиненные страницы;

  • Справа (Right) — общее поле вдоль правого края, которое, как правило, не используется;

  • Внизу (Bottom) — поле по нижнему краю страницы. В нем обычно размещаются ссылки на дочерние, родительскую и домашнюю страницы, выполненные в текстовой форме на тот случай, если браузер пользователя не может отображать графические объекты либо в нем отключен соответствующий режим.

  4. Сбросьте все флажки и щелкните на кнопке О К. Вы увидите, что со страницы исчезли кнопки навигации и заголовок, автоматически размещаемые в полях общих элементов. Если вы предпочитаете самостоятельно размещать ссылки и заголовки, вам нужен именно этот вариант.

  5. Снова выберите команду Формат > Общие границы.

  6. Установите флажок Восстановить границы, используемые по умолчанию на веб-узле (Reset Borders For Current Page To Web Default).

  7. Щелкните на кнопке ОК. Frontpage вернет на страницу элементы навигации, размещаемые по умолчанию.

  8. Командой Файл > Закрыть Веб-узел (File > Close Web) закройте web-узел и все открытые web-страницы, подтверждая сохранение выполненных изменений.

Рис. 22.20. Настройка общих полей


Контрольное упражнение

Чтобы закрепить навыки работы со структурой web-узла, попробуйте самостоятельно выполнить следующие действия.

  1. Откройте web-узел, созданный на этом занятии.

  2. Включите режим переходов.

  3. Оставьте видимой на экране только страницу Товары и все подчиненные ей страницы.

    • Как в окне переходов оставить видимой только одну ветвь web-узла?

  4. Увеличьте масштаб просмотра до 100 %.

  5. Перетащите страницу Справочник вниз, чтобы ссылки на нее появлялись ниже ссылок остальных страниц группы Товары.

  6. Добавьте для страницы Товары задачу, информирующую о необходимости изменения оформления этой страницы.

  7. Запустите эту задачу, чтобы открыть страницу Товары в режиме Страница.

    • Какими приемами можно открыть web-страницу врежиме про смотра Страница?

  8. Выберите для активной страницы схему оформления Expedition.

  9. Измените цвета схемы, выбрав стандартный вариант Barcode.

  10. Назначьте заголовкам первого уровня новой схемы шрифт Anal.

  11. Сохраните полученную схему под именем Новая схема.

  12. Закройте web-страницу Товары, не сохраняя выполненные изменения.

  13. Пометьте задачу, добавленную на шаге 7, как выполненную.

    • Как изменить статус задачи?

  14. Закройте web-узел.


Подведение итогов

Упражнения этого занятия научили вас ориентироваться в режимах просмотра web-узла. Теперь вы знаете, как создать узел с помощью мастера, где настраивается схема связей между страницами, как сохранить список действий, описывающих задачи разработчика. Вы можете получить статистическую информацию об узле и отыскать некорректные ссылки. Наконец, вы можете изменить оформление узла и настроить общие поля страниц.

Следующее упражнение посвящено вопросам разработки и модификации отдельных web-страниц с помощью встроенного HTML-редактора приложения Frontpage.


Занятие №23

Редактор web-страниц

ТЕМА ЗАНЯТИЯ

На этом занятии рассматриваются некоторые возможности редактора web-страниц, встроенного в приложение Frontpage. Вы научитесь выполнять следующие операции:

  • форматировать текст;

  • строить таблицы и списки;

  • настраивать гиперссылки и закладки;

  • добавлять рисунки;

  • изменять фон web-страницы;

  • просматривать HTML-код;

  • проверять страницу в браузере.

В упражнениях предыдущего занятия вы познакомились со структурой web-узла, его оформлением и ссылками страниц. Frontpage поддерживает множество инструментов, помогающих рассматривать узел не как набор страниц, а как единую структуру со множеством взаимосвязанных компонентов. Но кроме структуры необходимо разработать сами web-страницы, являющиеся основой любого узла.

В состав Frontpage входит мощный редактор web-страниц. Вы уже встречались с ним, знакомясь с режимом просмотра Страница. Чтобы модифицировать web-страницу, достаточно открыть ее в указанном режиме с помощью команды Файл > Открыть (File > Open) или просто дважды щелкнуть на значке страницы в любом из других режимов Frontpage.

Редактор страниц Frontpage во многом похож на Word. Но формат HTML имеет свои правила построения файлов, вносящие определенную специфику в процесс создания документов. На этом занятии вы познакомитесь с основными приемами разработки содержания страниц.

Текст

В основе практически любой web-страницы лежит текст. Его можно делить на абзацы, оформлять в виде пунктов маркированных списков или помещать в ячейки таблиц. Правильное форматирование текста во многом определяет удобство восприятия информации.

Упражнение 1. Форматирование текста

На страницах, созданных мастером web-узла, расположены комментарии и текстовые местозаполнители, которые нужно заменить реальным содержанием. Давайте приведем к надлежащему виду некоторые страницы узла. Остальные файлы вы можете модифицировать самостоятельно.

  1. Чтобы открыть web-узел, созданный на предыдущем занятии, выберите команду Файл > Открыть веб-узел (File > Open Web), выделите в окне диалога открытия узла папку Corporate, название которой совпадает с именем, данным узлу, и щелкните на кнопке Открыть (Open).

  2. Щелчком на кнопке Переходы панели режимов перейдите в режим переходов.

  3. Дважды щелкните на прямоугольнике страницы Товары. Выбранная web-страница откроется в режиме Страница, который позволяет изменять содержание документов Web (рис. 23.1).

  4. Щелчком выделите комментарий, расположенный в верхней части страницы, и введите текст То в ары компании Геркулес отличаются высоким качеством!

  5. Выделите слово Геркулес и щелкните на кнопке Полужирный (Bold) панели инструментов Форматирование (Formatting).

  6. Раскройте палитру кнопки Цвет текста (Font Color) и выберите в ней красный квадрат.

Рис. 23.1. Исходный вид страницы Товары

  7. В раскрывающемся списке Размер шрифта (Font Size) выберите пункт 4 (14pt). Теперь слово Геркулес выделено жирным крупным шрифтом'красного цвета.

  8. Щелкните правее восклицательного знака.

  9. Выберите команду Вставка > Горизонтальная линия (Insert > Horizontal Line). Текст первого абзаца окажется отделенным от остального содержания линией. Горизонтальная линия — это единственный графический элемент, который можно «нарисовать» на web-странице. Любые другие фигуры (наклонные линии, окружности, прямоугольники) размещаются только в виде файлов формата GIF или JPG, подготовленных в графическом редакторе или с помощью инструментов Frontpage.

  10. Поместите текстовый курсор правее буквы Н слова Название.

  11. Введите текст Трубы металлические.

  12. Сотрите остатки слов Название продукта!.

  13. Поместите курсор в начало строки Описание продукта 1. Введите текст Трубы толстые и тонкие любой длины.

Примечание

Текст Название продукта 1 — это гиперссылка на другую web-страницу. Чтобы заменить ее текст, нужно вставлять новые символы внутрь имеющихся слов (например, правее буквы Н), иначе добавляемые буквы могут оказаться обычным текстом страницы, расположенным за пределами ссылки.

Рис. 23.2. Обновленное содержание

  14. Нажатием клавиши Delete сотрите ненужные символы. При редактировании текста будьте внимательны. Удалив целый абзац, вы часто не сможете вернуть прежнее расположение строк нажатием клавиши Enter. Отступы нового абзаца могут оказаться другими. Если по ошибке был стерт нужный блок текста, восстановите его с помощью команды Правка > Отменить (Edit > Undo). Нажимая клавишу Enter для добавления абзаца, имейте в виду, что отступы новых абзацев часто зависят от того, в каком месте находился текстовый курсор в момент нажатия этой клавиши.

  15. Повторяя шаги 10-14, замените текст остальных абзацев страницы, приведя его в соответствие с рис. 23.2.

Упражнение 2. Таблицы

Страница Товары смотрится достаточно хорошо. Теперь стоит подумать о содержании ее дочерних страниц, предлагающих описание и цены конкретной продукции. Давайте приведем в надлежащий вид страницу с описанием ассортимента труб. Чтобы перейти к дочерней странице (или к любой другой странице, ссылка на которую присутствует в текущем документе), не нужно возвращаться в режим переходов. Достаточно активизировать соответствующую ссылку.

  1. Удерживая нажатой клавишу Ctrl, щелкните на строке текста Трубы металлические. Откроется страница Трубы, показанная на рис. 23.3. На ней уже есть маркированный список, в котором по замыслу разработчиков шаблонов Front-Page должны быть перечислены разновидности товара. Предположим, что недавно компания Геркулес расширила ассортимент труб, и вы хотите поместить список новых товаров правее имеющегося списка. Документы формата HTML не поддерживают размещение текста в несколько столбцов, поэтому web-дизайнеры часто пользуются для этих целей таблицами.

Рис. 23.3. Описание ассортимента труб

  2. Переместите курсор в начало строки Основные выгоды.

  3. Выберите команду Таблица > Вставить > Таблица (Table > Insert > Table).

  4. Вам понадобятся всего две ячейки, расположенные рядом. Поэтому введите в счетчик Число строк (Rows) открывшегося окна диалога (рис. 23.4) цифру 2.

  5. Чтобы по ширине таблица занимала не всю страницу, введите в поле Задать ширину (Specify Width) число 80, убедившись, что одноименный флажок установлен, а в расположенном рядом переключателе выбрано положение В процентах (In Percent).

Рис. 23.4. Параметры таблицы

  6. Щелкните на кнопке ОК.

  7. Выделите заголовок Основные выгоды и три строки расположенного под ним списка. Для этого протащите мышь слева от указанных абзацев.

Примечание

Разрабатывая web-страницы, не забывайте, что их будут просматривать люди, имеющие компьютеры с самыми разными дисплеями. Поэтому старайтесь задавать размеры элементов в процентах от ширины окнабраузера. Если, привыкнув к дисплею с высоким разрешением, вы добавите на страницу рисунок или таблицу шириной 1000 пикселов, то такой объект просто не поместится на экране монитора шириной 800 пикселов. Указывая размеры в процентах, можно избежать подобных неприятностей. Браузер удаленного пользователя сам масштабирует объект надлежащим образом.

  8. Нажатием клавиш Ctrl+X вырежьте выделенный текст.

  9. Щелкните в левой ячейке новой таблицы правой кнопкой мыши и выберите в контекстном меню команду Вставить (Paste).

  10. Нажатием клавиши Tab переместите курсор в правую ячейку таблицы.

  11. Введите заголовок Новые поступления.

  12. Выбором пункта Заголовок 3 (Heading 3) в списке Стиль (Style) панели инструментов Форматирование измените шрифт нового заголовка.

  13. Нажмите клавишу Enter и введите текст Трубы квадратные.

  14. Затем введите еще два пункта, отделяя их нажатиями клавиши Enter.

  15. Отредактируйте текст левой ячейки таблицы в соответствии с рис. 23.5.

Рис. 23.5. Добавление таблицы

  16. Выше новой таблицы введите абзац с кратким описанием продукции.

Упражнение 3. Списки

Пункты левой ячейки таблицы, добавленной в предыдущем упражнении, оформлены в виде маркированного списка, а правая ячейка содержит простой текст, который смотрится непривлекательно. Давайте назначим пунктам правого списка красочные маркеры.

  1. Щелкните в начале строки Трубы квадратные.

  2. Нажав клавишу Shift, щелкните в конце строки Трубы гнутые, чтобы выделить все три пункта списка.

  3. Щелчком на кнопке Маркеры (Bullets) добавьте выделенным абзацам стандартные маркеры.

  4. Чтобы поместить в качестве маркеров другой рисунок, выберите команду Формат > Список (Format > Bullets And Numbering).

  5. В открывшемся окне диалога (рис. 23.6) выберите положение переключателя Задать рисунок (Specify Picture).

Рис. 23.6. Выбор маркера

  6. Щелчком на кнопке Обзор откройте окно выбора файла. Затем дважды щелкните на значке файла smallnew.gif в папке images текущего web-узла.

  7. Щелчком на кнопке О К закройте окно настройки маркеров. Frontpage, так же как и Word, позволяет формировать не только маркированные, но и нумерованные списки. Чтобы пронумеровать пункты ассортимента стальных труб, выполните следующие действия.

  8. Выделите три абзаца левой ячейки таблицы, протащив указатель мыши слева от них.

  9. Щелкните на кнопке Нумерация (Numbering) панели инструментов Форматирование. Графические маркеры заменятся на последовательные числа/после чего списки станут такими, как показано на рис. 23.7.

Рис.23.7. Списки

Упражнение 4. Гиперссылки

При создании web-узла с помощью мастера приложение Frontpage автоматически размещает на страницах панели навигации с гиперссылками на различные web-страницы узла. Ссылки добавляются и в сам текст страниц. Но для обеспечения правильного функционирования web-узла разработчику часто приходится вставлять дополнительные ссылки или изменять параметры существующих.

Предположим, вы не хотите указывать цены прямо на странице Трубы, а планируете представить их на дополнительной странице, организовав соответствующую ссылку. Кроме того, требуется добавить адрес электронной почты менеджера, ответственного за продажу труб, и гиперссылку на полный справочник товаров фирмы. Чтобы соответствующим образом модифицировать web-страницу, выполните следующие шаги.

  1. Выделите абзац Цены, щелкнув слева от него.

  2. Введите текст Низкие цены, постоянным клиентам скидки.

  3. Выберите в списке Стиль панели инструментов Форматирование вариант Обычный (Normal), чтобы отменить шрифт, свойственный заголовкам.

  4. Нажмите клавишу Entern напечатайте Дополнительную информацию о трубах можно найти в справочнике товаров или получить у менеджера по адресу info@hercules .corn. Затем снова нажмите Enter.

  5. Уберите весь текст и объекты, оказавшиеся ниже этого предложения. Они вам не понадобятся. Для этого выделяйте ненужные объекты и удаляйте их нажатиями клавиши Delete.

Frontpage умеет распознавать текст, похожий на адреса электронной почты, и автоматически настраивать ссылки таких адресов. Поэтому символы info@percules.com сразу интерпретируются как электронный адрес. Они будут подчеркнуты и выделены цветом, свойственным гиперссылкам.

  6. Выполните команду Вид > Область задач (View > Task Pane). В появившемся окне в разделе Создать (New) щелкните на значке Пустая страница (Blank Page). Новая страница откроется в окне Frontpage.

  7. Щелкните на кнопке Сохранить (Save) панели инструментов Стандартная (Standard). В открывшемся окне диалога Сохранить как (Save As) введите имя рп -се01 .htm и щелкните на кнопке Сохранить. Сюда вы можете вносить необходимую информацию, касающуюся цен.

Рис. 23.8. Настройка гиперссылки

  8. Вернитесь на страницу prod0l. htm, щелкнув на соответствующей закладке, и выделите слово цены. Щелкните на нем правой кнопкой мыши и выберите в контекстном меню пункт Гиперссылка (Hyperlink).

Примечание

Обратите внимание на закладки с именами открытых файлов в верхней части окна в режиме страницы. Эта особенность, появившаяся впервые в Office XP, обеспечивает самый быстрый доступ к странице в процессе редактирования.

В появившемся окне диалога Добавление гиперссылки (Insert Hyperlink), показанном на рис. 23.8, в поле Текст (Text to display:) раздела Связать с (Link to) уже окажется введенным слово цены.

  9. Найдите в списке файлов папки Corporate файл с именем pri се01. htm и щелчком выделите его из списка, при этом имя данного файла будет введено в поле Адрес: (Adress:).

  10. Щелкните на кнопке ОК. Ссылка готова.

  11. Выделите два слова: справочнике товаров.

  12. Щелкните на кнопке Гиперссылка (Hyperlink) панели инструментов Стандартная.

  13. В списке вновь открывшегося окна диалога настройки гиперссылок дважды щелкните на папке Дополнения, чтобы раскрыть ее.

Рис. 23.9. Добавление гиперссылок

  14. Выделите значок Справочник.htm. Имя этого файла появится в поле Адрес:.

  15. Щелкните на кнопке ОК. Теперь на странице появились три дополнительные гиперссылки, как показано на рис. 23.9. Они будут опробованы в конце занятия.

С помощью окна диалога Добавление гиперссылки можно создавать ссылки самых разных типов. Для этого достаточно ввести полный указатель ресурса в поле Адрес: этого окна или воспользоваться одной из кнопок, расположенных правее списка файлов. Чтобы ссылка переносила пользователя в определенную точку web-страницы, выберите в раскрывающемся списке Закладка (Bookmark) одну из закладок, имеющихся на целевой web-странице.

Рисунки

Одним из основных преимуществ гипертекстовых документов перед более ранними форматами данных, распространявшихся через Интернет, является возможность размещения в HTML-файлах рисунков. Графические объекты web-страниц хранятся в отдельных файлах форматов GIF, JPEG или PNG. Примерами таких объектов могут служить маркеры списка, созданного в упражнении 3. Но графические возможности HTML-файлов и редактора Frontpage не ограничиваются этим примером.

Упражнение 5. Добавление рисунка

Чтобы добавить на web-страницу, сформированную в предыдущих упражнениях, логотип компании, выполните следующие шаги.

  1. Поместите текстовый курсор в начало первой строки web-страницы.

Примечание

В web-страницах все рисунки привязываются к определенной точке текста, то есть они являются как бы очередным символом. Поэтому для размещения рисунка в произвольных точках страницы web-дизайнерам приходится прибегать к различного рода хитростям, например размещать графические объекты в ячейках таблиц с невидимыми рамками.

  2. В строке меню приложения раскройте подменю Рисунок (Picture) меню Вставка (Insert) Откроются все возможности вставки рисунка, предоставляемые приложением:

  • Картинки (Clip Art) — возможность выбрать рисунок из одноименной библиотеки;

Рис. 23.10. Добавление рисунка

  • Из файла (From File) — при запуске этой команды открывается окно диалога, показанное на рис. 23.10. Кнопки левого ряда ускоряют доступ к нужным файлам. Например, чтобы вставить рисунок, имеющийся в наборе файлов разрабатываемого web-узла, нужно щелкнуть на кнопке Мои документы и выбрать нужный файл из списка; щелчок на кнопке Рабочий стол (Desktop) облегчает доступ к графическому файлу, расположенному налокальном или сетевом диске; кнопка вебпапки (Web Folders) позволяет просматривать папки и файлы на web-серверах и сетевых устройствах и выбирать нужные графические файлы. В поля Имя файла (File Name) и Тип файла (FileType) можно ввести полный указатель ресурса, добавив таким образом объект с заранее известным адресом;

  • Со сканера или камеры (From Scanner or Camera) — возможность получать изображение непосредственно со сканера или другого устройства, поддерживающего технологию TWAIN;

  • Создать фотоколлекцию (New Photo Gallery) — выбор этой команды позволяет вставлять фотографии из коллекции фотографий.

  3. Давайте воспользуемся первым вариантом. Щелкните на кнопке Clip Art.

  4. В области задач в окне Вставка картинки (Clip Art Gallery) введите в текстовое поле слово Am ma Ls (Животные) и щелкните на кнопке Найти (Search).

  5. Найдите рисунок тигра, щелкните на нем и с помощью указателя мыши перетащите его на web-страницу.

  6. Щелчком выделите рисунок.

  7. Перетащите угловой маркер габаритной рамки рисунка, уменьшив изображение до нужного размера.

  8. Щелкните на рисунке правой кнопкой мыши и выберите в контекстном меню команду Свойства рисунка (Picture Properties).

Примечание

Не размещайте на web-страницах слишком большие рисунки, на их загрузку с удаленного сервера требуется много времени. Это раздражает пользователей.

Рис. 23.11. Параметры рисунка

  9. На вкладке Общие (General), показанной на рис. 23.11, выберите положение переключателя GIF, чтобы указать формат, в котором должен храниться рисунок.

  10. Щелкните на кнопке Обзор, расположенной справа от поля Расположение (Location).

  11. В открывшемся окне дважды щелкните на файле news.htm, который по замыслу должен содержать общую информацию о компании и основные новости. Теперь щелчок на логотипе будет открывать указанную страницу.

  12. Раскройте вкладку Вид (Appearance). Чтобы текст, расположенный справа от рисунка, выровнялся по середине рисунка, выберите в раскрывающемся списке Выравнивание (Alignment) пункт По центру (Center).

  13. Щелкните на кнопке ОК.

  14. Чтобы сохранить выполненные изменения, выберите команду Файл > Сохранить (File> Save).

  15. В окне диалога Сохранение внедренных файлов (Save Embedded Files), показанном на рис. 23.12, щелкните на кнопке Сменить папку (Change Folder).

Рис. 23.12. Сохранение внедренного объекта

  16. Дважды щелкните в открывшемся окне на папке images, а затем на кнопке ОК, указав этим папку, в которой должен храниться файл добавленного рисунка.

  17. Щелкните на кнопке Переименовать (Rename) и введите имя logo.gif.

  18. Затем щелкните на кнопке ОК.

Эта операция приведет к преобразованию изображения формата WMF, полученного из библиотеки Clip Art, в формат GIF, который в отличие от WMF может демонстрироваться любым браузером. В итоге логотип будет записан в файл logo.gif.

Упражнение 6. Фон страницы

Хорошо подобранный фон помогает пользователю воспринимать информацию. С помощью фона можно выделить определенные области страницы и просто при

влечь внимание. Даже если вы не хотите размещать на заднем плане страницы красочный рисунок, всегда задавайте какой-либо однотонный фон, хорошо контрастирующий с текстом. В противном случае браузер удаленного пользователя окрасит фон .в свой цвет, который может существенно испортить страницу, сделав некоторые объекты плохо различимыми.

В качестве фона можно выбрать любой графический файл. При сохранении страницы он будет преобразован в формат GIF или JPEG. Если изображение не покрывает страницу целиком, то оно будет размножено и уложено в виде одинаковых прямоугольных плиток, плотно соприкасающихся друг с другом. Этот факт часто используется для создания фона с вертикальными или горизонтальными полосами путем многократного повторения широкого и низкого или высокого и узкого изображения. Такой подход позволяет, с одной стороны, сформировать привлекательный фон, а с другой — сэкономить время загрузки фона страницы.

Чтобы изменить фон, выполните следующие действия.

  1. Выберите команду Формат > Тема.
  2. В открывшемся окне диалога Темы, показанном на рис. 22.18, установите флажок Фоновый рисунок и щелкните на кнопке Изменить, а затем на кнопке Графика.
  3. В открывшемся окне диалога Изменение темы (Modify Theme) в раскрывающемся списке Элемент выберите Фоновый рисунок (Background Picture) и щелкните на кнопке Обзор, как показано на рис. 23.13.
  4. В появившемся окне диалога Открытие файла (Open) раскройте папку Offi-ceXP\OfficelO\Bitmaps\Styles и дважды щелкните на значке файла acblends.gif.
  5. Щелкнув на кнопке ОК, перейдите к окну диалога Темы. В окне Образец темы (Sample of Theme) посмотрите на результат сделанных изменений.
  6. Убедитесь, что переключатель Применить тему (Apply Theme to) установлен в положение К выбранным страницам и щелкните на кнопке ОК.

Рис. 23.13. Изменение фона страницы

Теперь web-страница будет выглядеть так, как показано на рис. 23.14.

Рис. 23.14. Web-страница с рисунком и измененным фоном

  7. Щелкните на странице правой кнопкой мыши и выберите из контекстного меню пункт Свойства страницы (Page Properties) В открывшемся одноименном окне диалога раскройте вкладку Общие.

  8. В поле Название (Title) введите текст Трубы от компании Геркулес. При загрузке страницы этот текст будет появляться в заголовке окна браузера. Щелкните на кнопке ОК.

Если для страницы тема не установлена, то изменение фона можно произвести с помощью команды Формат > Фон (Format > Background), в появившемся окне диалога установить флажок Фоновый рисунок, щелкнуть на кнопке Обзор и в окне диалога Выбор рисунка фона (Select Background Pictures) выбрать файл с расширением GIF, например тот, что использован в этом упражнении.

Специальные объекты

Упражнение7. Панель навигации

Панели навигации — это особые объекты Frontpage, которые позволяют автоматически добавлять и обновлять ссылки на страницы, иерархически связанные с текущей. Из упражнения 7 предыдущего занятия вы уже узнали, как добавлять и убирать панели навигации с помощью команды Общие границы (Shared Borders). Теперь пришло время научиться настраивать панели навигации конкретных страниц.

В левой части web-страницы Трубы есть местозаполнитель [Измените свойства этой панели для отображения на ней гиперссылок (Editthe properties forthis Link Bar to display hyperlinks here)], представляющий собой ненастроенную панель навигации. Давайте изучим ее свойства.

Рис. 23.15. Вкладка Общие окна диалога Свойства панели ссылок

  1. Щелкните на указанном местозаполнителе правой кнопкой мыши и выберите команду Свойства панели ссылок (Link Bar Properties). Откроется окно диалога с двумя вкладками, показанное на рис. 23.15. Вкладка Общие дает возможность указать, какие гиперссылки должны появляться в панели ссылок.

Положения переключателя раздела Добавляемые гиперссылки (Hyperlinks To Add То Page) позволяют добавлять следующие группы гиперссылок:

  • Родительский уровень (Parent Level) — на страницы, расположенные в навигаторе на уровень выше текущей;

  • Тот же уровень (Same Level) — на страницы того же уровня подчиненности, связанные в навигаторе с одной и той же родительской страницей;

  • Назад и далее (Back And Next) — на предыдущую и последующую страницы той же группы подчиненности, что и текущая;

  • Дочерний уровень (Child Level) — ссылки на дочерние страницы относительно текущей;

  • Глобальный уровень (Top Level) — ссылки на страницы самого верхнего уровня иерархии навигатора;

  • Дочерние страницы домашней (Child Page Under Home) — ссылки на страницы второго уровня иерархии навигатора.

Кроме того, флажки Домашняя страница (Home Page) и Родительская страница (Parent Page) позволяют независимо от положения переключателя помещать в панель навигации ссылки соответственно на домашнюю и родительскую web-страницы узла.

  2. Выберите положение переключателя Назад и далее.

Рис. 23.16. Панели навигации

  3. Установите флажки Домашняя страница и Родительская страница.

На вкладке Стиль (Style) приводятся образцы стандартных стилей оформления гиперссылок и предоставляется возможность установить их ориентацию.

  4. С помощью полосы прокрутки в разделе Выберите стиль выберите подходящий стиль оформления гиперссылок и щелкните на нем.

  5. Щелкните на кнопке ОК.

  6. Прокрутите web-страницу вниз. Вы увидите в ее нижней части еще одну панель навигации с текстовыми ссылками.

  7. Выделите эту панель и, чтобы открыть окно параметров панели, нажмите клавиши Alt+Enter.

  8. Выберите положение переключателя Same Level.

  9. Установите флажки Home Page и Parent Page.

  10. Щелкните на кнопке ОК. Теперь ссылки панелей будут выглядеть так, как показано на рис. 23.16.

Примечание

Всегда помещайте в нижнюю часть страницы гиперссылки навигации в текстовом формате. Они позволят работать тем пользователям, браузеры которых не способны загружать изображения.

Упражнение 8. Закладки

Закладки позволяют формировать гиперссылки на определенную точку конкретной web-страницы. С помощью таких ссылок пользователь может одним щелчком прокрутить страницу к нужному месту. Чтобы добавить закладку, выполните следующие шаги.

  1. Выберите команду Вид > Список папок (View > Folder List), чтобы вывести в окно Frontpage панель списка файлов и папок web-узла.

  2. Дважды щелкните на значке файла prod04.htm, чтобы открыть его в окне редактора.

  3. Прокрутите web-страницу в самый низ и щелкните в начале слов Phone.

  4. Выберите команду Вставка > Закладка (Insert > Bookmark).

  5. В поле Имя закладки (Bookmark Name) открывшегося окна диалога (рис. 23.17) введите слова end_of_page.

Рис. 23.17. Добавление закладки

  6. Щелкните на кнопке ОК.

  7. Закройте файл prod04.htm.

  8. При появлении соответствующего запроса подтвердите необходимость со хранения выполненных изменений.

Теперь давайте добавим на страницу Трубы ссылку, указывающую на только что созданную закладку.

  9. Введите в конце страницы Трубы фразу Обратите внимание на наши дешевые гвозди.

  10. Выделите слово г возди, затем щелкните на нем правой кнопкой мыши и выберите команду Гиперссылка.

  11. В списке открывшегося окна диалога создания гиперссылки щелкните на значке файла prod04.htm.

  12. В том же окне щелкните на кнопке Закладка (Bookmark), а затем на имени закладки в появившемся окне диалога Выделить место в документе (Select Place in Document) и щелкните на кнопке ОК. В поле Адрес: окна диалога Добавление гиперссылки будет введено имя prod04.htm#end_of_page, как показано на рис. 23.18.

Рис. 23.18. Ссылка на закладку

  13. Щелкните на кнопке ОК.

Действие полученной гиперссылки вы сможете оценить, выполняя последнее упражнение занятия.

Просмотр страницы

Окно режима просмотра Страница имеет три вкладки, открывающие доступ к трем различным вариантам демонстрации web-страницы. Первый из них — Обычный (Normal) предназначен для разработки страниц с помощью средств редактирования приложения Frontpage. Второй режим — HTML — позволяет просматривать и корректировать код web-страницы, сгенерированный редактором. Наконец, третья вкладка дает возможность, не выходя из Frontpage, предварительно просмотреть построенную web-страницу.

Упражнение 9. HTML-код

Frontpage предлагает разработчику множество разнообразных инструментов, позволяющих конструировать практически любые web-страницы. Однако полное управление форматом отображения информации можно получить, только редактируя исходный код HTML-файла, формирующий изображение страницы. Frontpage предлагает два способа просмотра этого кода.

  1. Не выходя из окна web-страницы Трубы, выберите команду Вид > Показать теги (View > Reveal Tags).

Рис. 23.19. Теги документа

В этом режиме (рис. 23.19) на экране отображается не только содержимое web-страницы, но и управляющие конструкции — теги, — которые и формируют имеющееся форматирование документа. В HTML-документе все теги заключены в угловые скобки. Они делятся на открывающие и закрывающие, которые отличаются от первых наличием символа «/». Между одноименными открывающим и закрывающим тегами размещается текст, форматирование которого задается этими тегами. Например, между тегами <table> и </table> заключено содержимое таблицы. Некоторые теги, такие как <hr>, который добавляет на страницу горизонтальную линию, не имеют парного закрывающего тега. Многоуровневое вложение подобных конструкций позволяет задавать любые самые сложные варианты форматирования документа. Указанный режим демонстрации страницы помогает понять ее структуру и облегчает поиск ошибок.

  2. Переместите указатель мыши на значок тега </а>, расположенный справа от изображения тигра. Появится всплывающая подсказка, демонстрирующая полный текст этого тега. Однако указанный вариант просмотра страницы дает возможность видеть теги,но не позволяет их редактировать.

  3. Чтобы получить полный доступ к коду страницы, щелкните на корешке HTML. Вы увидите текстовый документ, на основе которого генерируется web-страница. Давайте попробуем скорректировать его.

  4. Прокрутите содержимое окна до текста Тонкие медные трубы.

  5. Введите перед словом медные теги <bxfont color=»c90000">.

  6. После этого слова добавьте теги </font></b>.

Примечание

Добавление тегов в режиме редактирования кода HTML иногда приводит к нарушению ранее назначенных режимов форматирования и искажению некоторых объектов. Перед изменением кода полезно сохранить на диске копию редактируемой web-страницы, чтобы в случае неудачи иметь возможность возвратиться к исходному варианту.

  7. Щелкните на корешке Обычный, чтобы вернуться в обычный режим просмотра страницы.

  8. Нажатием клавиш Ctrl+/ отключите демонстрацию тегов. Обратите внимание, что теги, добавленные в режиме редактирования исходного кода, окрасили слово медные в красный цвет и задали ему жирное начертание.

Досконально изучив язык HTML, вы сможете корректировать страницы, созданные во Frontpage, добавляя в них самые сложные эффекты, недоступные существующим web-редакторам.

Упражнение 10. Предварительный просмотр

Режим предварительного просмотра показывает web-страницу такой, какой она будет в окне браузера.

  1. Чтобы включить такой просмотр, щелкните на корешке Просмотр (Preview). Теперь на странице отсутствуют пунктирные линии, показывающие границы разделов страницы. Изменилась рамка таблицы, стали другими шрифт и интервалы между строками. Для активизации гиперссылок теперь не нужно нажимать клавишу Ctrl. Достаточно просто щелкнуть на ссылке. В целом обычный режим просмотра очень похож на результирующую страницу, он позволяет достаточно точно оценивать расположение объектов и оформление текста. Но, редактируя документ, не забывайте периодически обращаться к вкладке Просмотр, которая точнее показывает общий вид элементов страницы. Перед публикацией web-узла обязательно просмотрите его страницы в окне браузера. Если на вашем компьютере установлено несколько браузеров, откройте узел в каждом из них, внимательно изучите все детали и убедитесь, что все браузеры корректно отображают введенную информацию и графические объекты. Имейте в виду, что Frontpage позволяет оперативно загружать web-страницы в любой браузер.

  2. Щелчком на кнопке Сохранить панели инструментов Стандартная сохраните измененный вариант страницы Трубы.

  3. Выберите команду Файл > Просмотр в обозревателе (File > Preview In Browser).

  4. В открывшемся окне диалога выберите пункт Internet Explorer, а затем щелкните на кнопке Просмотр (Preview). Страница Трубы, сформированная в упражнениях этого занятия, появится в окне Internet Explorer . Давайте проверим работу ссылок, добавленных на эту страницу.

  5. Переместите указатель на слова справочник товаров, чтобы значок указателя принял форму ладони, и щелкните мышью. Страница Трубы сменится страницей Справочник товаров.

  6. Чтобы вернуться обратно, щелкните на кнопке Назад на Трубы от компании Геркулес панели инструментов Internet Explorer.

  7. Повторяя шаги 5 и 6, проверьте действие ссылки цены.

  8. Щелкните на гиперссылке гвозди. Обратите внимание, что это действие не только открывает страницу Гвозди, но и прокручивает ее до закладки end_of_ page, вставленной в конец этой страницы.

  9. В текстовой панели навигации, расположенной в нижней части страницы Гвозди, щелкните на ссылке Up, чтобы переместиться к странице Товары — родительской по отношению к трем web-страницам, рассмотренным выше.

  10. Чтобы вернуться на страницу Трубы, щелкните на ссылке Трубы металлические.

  11. Щелкните на ссылке info@hercules. corn. Эта операция запустит Outllook и откроет окно нового сообщения, в поле Кому (То) которого уже будет добавлен электронный адрес получателя. Чтобы отослать письмо по адресу, указанному в гиперссылке, останется только ввести текст и щелкнуть на кнопке Отправить (Send).

  12. Закройте окно Internet Explorer.

  13. В приложении Frontpage выберите команду Файл > Закрыть веб-узел (File > Close Web). При появлении запросов о необходимости сохранения изменений щелкайте на кнопке Да.

Контрольное упражнение

Чтобы закрепить навыки, полученные на этом занятии, выполните следующие действия.

  1. Откройте web-узел, созданный в предыдущем упражнении.

    • Как быстро открыть web-узел, с которым вы недавно работали?

  2. Выведите в режиме Страница содержимое файла Справочник.htm, сохраненного в папке Дополнения.

  3. Добавьте на страницу Справочник товаров таблицу с тремя столбцами.

  4. Введите в эту таблицу названия, цены и минимальные партии поставок товаров, освещаемых web-узлом Corporate.

  5. Назначьте ячейкам таблицы желтый фон.

    • Как изменить фон ячеек таблицы?

  6. Добавьте на web-страницу тот же логотип, который был вставлен на страницу Трубы.

  7. Назначьте фон страницы, идентичный выбранному в упражнении 6.

  8. Название каждого товара, расположенное в левой ячейке таблицы, свяжите со ссылкой на web-страницу, содержащую подробное описание этого товара.

  9. Измените расположенную слева панель навигации так, чтобы в нее выводились кнопки страниц того же уровня, а также ссылки на домашнюю и родительскую страницы.

  10. В качестве текста, выводимого в заголовке браузера при открытии данной страницы, назначьте предложение Справочник товаров компании Геркулес.

    • Как настроить текст заголовка окна?

  11. Просмотрите HTML-код полученной страницы.

  12. Откройте страницу Справочник товаров в окне браузера Internet Explorer и проверьте работу гиперссылок.

  13. Сохраните изменения и закройте web-узел.

Подведение итогов

На этом занятии был рассмотрен интегрированный в приложение Frontpage модуль редактирования web-страниц. Вы научились строить таблицы, создавать маркированные и нумерованные списки, добавлять рисунки, задавать рисунок для фона, настраивать гиперссылки на другие web-страницы и ресурсы Интернета.

Следующее занятие рассказывает о методах создания web-страниц с кадрами и способах анимации объектов страниц. На нем также будет рассмотрено назначение некоторых дополнительных элементов и расширений, предлагаемых компанией Microsoft.


Занятие №23

Редактор web-страниц

ТЕМА ЗАНЯТИЯ

На этом занятии рассматриваются некоторые возможности редактора web-страниц, встроенного в приложение Frontpage. Вы научитесь выполнять следующие операции:

  • форматировать текст;

  • строить таблицы и списки;

  • настраивать гиперссылки и закладки;

  • добавлять рисунки;

  • изменять фон web-страницы;

  • просматривать HTML-код;

  • проверять страницу в браузере.

В упражнениях предыдущего занятия вы познакомились со структурой web-узла, его оформлением и ссылками страниц. Frontpage поддерживает множество инструментов, помогающих рассматривать узел не как набор страниц, а как единую структуру со множеством взаимосвязанных компонентов. Но кроме структуры необходимо разработать сами web-страницы, являющиеся основой любого узла.

В состав Frontpage входит мощный редактор web-страниц. Вы уже встречались с ним, знакомясь с режимом просмотра Страница. Чтобы модифицировать web-страницу, достаточно открыть ее в указанном режиме с помощью команды Файл > Открыть (File > Open) или просто дважды щелкнуть на значке страницы в любом из других режимов Frontpage.

Редактор страниц Frontpage во многом похож на Word. Но формат HTML имеет свои правила построения файлов, вносящие определенную специфику в процесс создания документов. На этом занятии вы познакомитесь с основными приемами разработки содержания страниц.


Текст

В основе практически любой web-страницы лежит текст. Его можно делить на абзацы, оформлять в виде пунктов маркированных списков или помещать в ячейки таблиц. Правильное форматирование текста во многом определяет удобство восприятия информации.


Упражнение 1. Форматирование текста

На страницах, созданных мастером web-узла, расположены комментарии и текстовые местозаполнители, которые нужно заменить реальным содержанием. Давайте приведем к надлежащему виду некоторые страницы узла. Остальные файлы вы можете модифицировать самостоятельно.

  1. Чтобы открыть web-узел, созданный на предыдущем занятии, выберите команду Файл > Открыть веб-узел (File > Open Web), выделите в окне диалога открытия узла папку Corporate, название которой совпадает с именем, данным узлу, и щелкните на кнопке Открыть (Open).

  2. Щелчком на кнопке Переходы панели режимов перейдите в режим переходов.

  3. Дважды щелкните на прямоугольнике страницы Товары. Выбранная web-страница откроется в режиме Страница, который позволяет изменять содержание документов Web (рис. 23.1).

  4. Щелчком выделите комментарий, расположенный в верхней части страницы, и введите текст То в ары компании Геркулес отличаются высоким качеством!

  5. Выделите слово Геркулес и щелкните на кнопке Полужирный (Bold) панели инструментов Форматирование (Formatting).

  6. Раскройте палитру кнопки Цвет текста (Font Color) и выберите в ней красный квадрат.

Рис. 23.1. Исходный вид страницы Товары

  7. В раскрывающемся списке Размер шрифта (Font Size) выберите пункт 4 (14pt). Теперь слово Геркулес выделено жирным крупным шрифтом'красного цвета.

  8. Щелкните правее восклицательного знака.

  9. Выберите команду Вставка > Горизонтальная линия (Insert > Horizontal Line). Текст первого абзаца окажется отделенным от остального содержания линией. Горизонтальная линия — это единственный графический элемент, который можно «нарисовать» на web-странице. Любые другие фигуры (наклонные линии, окружности, прямоугольники) размещаются только в виде файлов формата GIF или JPG, подготовленных в графическом редакторе или с помощью инструментов Frontpage.

  10. Поместите текстовый курсор правее буквы Н слова Название.

  11. Введите текст Трубы металлические.

  12. Сотрите остатки слов Название продукта!.

  13. Поместите курсор в начало строки Описание продукта 1. Введите текст Трубы толстые и тонкие любой длины.

Примечание

Текст Название продукта 1 — это гиперссылка на другую web-страницу. Чтобы заменить ее текст, нужно вставлять новые символы внутрь имеющихся слов (например, правее буквы Н), иначе добавляемые буквы могут оказаться обычным текстом страницы, расположенным за пределами ссылки.

Рис. 23.2. Обновленное содержание

  14. Нажатием клавиши Delete сотрите ненужные символы. При редактировании текста будьте внимательны. Удалив целый абзац, вы часто не сможете вернуть прежнее расположение строк нажатием клавиши Enter. Отступы нового абзаца могут оказаться другими. Если по ошибке был стерт нужный блок текста, восстановите его с помощью команды Правка > Отменить (Edit > Undo). Нажимая клавишу Enter для добавления абзаца, имейте в виду, что отступы новых абзацев часто зависят от того, в каком месте находился текстовый курсор в момент нажатия этой клавиши.

  15. Повторяя шаги 10-14, замените текст остальных абзацев страницы, приведя его в соответствие с рис. 23.2.


Упражнение 2. Таблицы

Страница Товары смотрится достаточно хорошо. Теперь стоит подумать о содержании ее дочерних страниц, предлагающих описание и цены конкретной продукции. Давайте приведем в надлежащий вид страницу с описанием ассортимента труб. Чтобы перейти к дочерней странице (или к любой другой странице, ссылка на которую присутствует в текущем документе), не нужно возвращаться в режим переходов. Достаточно активизировать соответствующую ссылку.

  1. Удерживая нажатой клавишу Ctrl, щелкните на строке текста Трубы металлические. Откроется страница Трубы, показанная на рис. 23.3. На ней уже есть маркированный список, в котором по замыслу разработчиков шаблонов Front-Page должны быть перечислены разновидности товара. Предположим, что недавно компания Геркулес расширила ассортимент труб, и вы хотите поместить список новых товаров правее имеющегося списка. Документы формата HTML не поддерживают размещение текста в несколько столбцов, поэтому web-дизайнеры часто пользуются для этих целей таблицами.

Рис. 23.3. Описание ассортимента труб

  2. Переместите курсор в начало строки Основные выгоды.

  3. Выберите команду Таблица > Вставить > Таблица (Table > Insert > Table).

  4. Вам понадобятся всего две ячейки, расположенные рядом. Поэтому введите в счетчик Число строк (Rows) открывшегося окна диалога (рис. 23.4) цифру 2.

  5. Чтобы по ширине таблица занимала не всю страницу, введите в поле Задать ширину (Specify Width) число 80, убедившись, что одноименный флажок установлен, а в расположенном рядом переключателе выбрано положение В процентах (In Percent).

Рис. 23.4. Параметры таблицы

  6. Щелкните на кнопке ОК.

  7. Выделите заголовок Основные выгоды и три строки расположенного под ним списка. Для этого протащите мышь слева от указанных абзацев.

Примечание

Разрабатывая web-страницы, не забывайте, что их будут просматривать люди, имеющие компьютеры с самыми разными дисплеями. Поэтому старайтесь задавать размеры элементов в процентах от ширины окнабраузера. Если, привыкнув к дисплею с высоким разрешением, вы добавите на страницу рисунок или таблицу шириной 1000 пикселов, то такой объект просто не поместится на экране монитора шириной 800 пикселов. Указывая размеры в процентах, можно избежать подобных неприятностей. Браузер удаленного пользователя сам масштабирует объект надлежащим образом.

  8. Нажатием клавиш Ctrl+X вырежьте выделенный текст.

  9. Щелкните в левой ячейке новой таблицы правой кнопкой мыши и выберите в контекстном меню команду Вставить (Paste).

  10. Нажатием клавиши Tab переместите курсор в правую ячейку таблицы.

  11. Введите заголовок Новые поступления.

  12. Выбором пункта Заголовок 3 (Heading 3) в списке Стиль (Style) панели инструментов Форматирование измените шрифт нового заголовка.

  13. Нажмите клавишу Enter и введите текст Трубы квадратные.

  14. Затем введите еще два пункта, отделяя их нажатиями клавиши Enter.

  15. Отредактируйте текст левой ячейки таблицы в соответствии с рис. 23.5.

Рис. 23.5. Добавление таблицы

  16. Выше новой таблицы введите абзац с кратким описанием продукции.


Упражнение 3. Списки

Пункты левой ячейки таблицы, добавленной в предыдущем упражнении, оформлены в виде маркированного списка, а правая ячейка содержит простой текст, который смотрится непривлекательно. Давайте назначим пунктам правого списка красочные маркеры.

  1. Щелкните в начале строки Трубы квадратные.

  2. Нажав клавишу Shift, щелкните в конце строки Трубы гнутые, чтобы выделить все три пункта списка.

  3. Щелчком на кнопке Маркеры (Bullets) добавьте выделенным абзацам стандартные маркеры.

  4. Чтобы поместить в качестве маркеров другой рисунок, выберите команду Формат > Список (Format > Bullets And Numbering).

  5. В открывшемся окне диалога (рис. 23.6) выберите положение переключателя Задать рисунок (Specify Picture).

Рис. 23.6. Выбор маркера

  6. Щелчком на кнопке Обзор откройте окно выбора файла. Затем дважды щелкните на значке файла smallnew.gif в папке images текущего web-узла.

  7. Щелчком на кнопке О К закройте окно настройки маркеров. Frontpage, так же как и Word, позволяет формировать не только маркированные, но и нумерованные списки. Чтобы пронумеровать пункты ассортимента стальных труб, выполните следующие действия.

  8. Выделите три абзаца левой ячейки таблицы, протащив указатель мыши слева от них.

  9. Щелкните на кнопке Нумерация (Numbering) панели инструментов Форматирование. Графические маркеры заменятся на последовательные числа/после чего списки станут такими, как показано на рис. 23.7.

Рис.23.7. Списки


Упражнение 4. Гиперссылки

При создании web-узла с помощью мастера приложение Frontpage автоматически размещает на страницах панели навигации с гиперссылками на различные web-страницы узла. Ссылки добавляются и в сам текст страниц. Но для обеспечения правильного функционирования web-узла разработчику часто приходится вставлять дополнительные ссылки или изменять параметры существующих.

Предположим, вы не хотите указывать цены прямо на странице Трубы, а планируете представить их на дополнительной странице, организовав соответствующую ссылку. Кроме того, требуется добавить адрес электронной почты менеджера, ответственного за продажу труб, и гиперссылку на полный справочник товаров фирмы. Чтобы соответствующим образом модифицировать web-страницу, выполните следующие шаги.

  1. Выделите абзац Цены, щелкнув слева от него.

  2. Введите текст Низкие цены, постоянным клиентам скидки.

  3. Выберите в списке Стиль панели инструментов Форматирование вариант Обычный (Normal), чтобы отменить шрифт, свойственный заголовкам.

  4. Нажмите клавишу Entern напечатайте Дополнительную информацию о трубах можно найти в справочнике товаров или получить у менеджера по адресу info@hercules .corn. Затем снова нажмите Enter.

  5. Уберите весь текст и объекты, оказавшиеся ниже этого предложения. Они вам не понадобятся. Для этого выделяйте ненужные объекты и удаляйте их нажатиями клавиши Delete.

Frontpage умеет распознавать текст, похожий на адреса электронной почты, и автоматически настраивать ссылки таких адресов. Поэтому символы info@percules.com сразу интерпретируются как электронный адрес. Они будут подчеркнуты и выделены цветом, свойственным гиперссылкам.

  6. Выполните команду Вид > Область задач (View > Task Pane). В появившемся окне в разделе Создать (New) щелкните на значке Пустая страница (Blank Page). Новая страница откроется в окне Frontpage.

  7. Щелкните на кнопке Сохранить (Save) панели инструментов Стандартная (Standard). В открывшемся окне диалога Сохранить как (Save As) введите имя рп -се01 .htm и щелкните на кнопке Сохранить. Сюда вы можете вносить необходимую информацию, касающуюся цен.

Рис. 23.8. Настройка гиперссылки

  8. Вернитесь на страницу prod0l. htm, щелкнув на соответствующей закладке, и выделите слово цены. Щелкните на нем правой кнопкой мыши и выберите в контекстном меню пункт Гиперссылка (Hyperlink).

Примечание

Обратите внимание на закладки с именами открытых файлов в верхней части окна в режиме страницы. Эта особенность, появившаяся впервые в Office XP, обеспечивает самый быстрый доступ к странице в процессе редактирования.

В появившемся окне диалога Добавление гиперссылки (Insert Hyperlink), показанном на рис. 23.8, в поле Текст (Text to display:) раздела Связать с (Link to) уже окажется введенным слово цены.

  9. Найдите в списке файлов папки Corporate файл с именем pri се01. htm и щелчком выделите его из списка, при этом имя данного файла будет введено в поле Адрес: (Adress:).

  10. Щелкните на кнопке ОК. Ссылка готова.

  11. Выделите два слова: справочнике товаров.

  12. Щелкните на кнопке Гиперссылка (Hyperlink) панели инструментов Стандартная.

  13. В списке вновь открывшегося окна диалога настройки гиперссылок дважды щелкните на папке Дополнения, чтобы раскрыть ее.

Рис. 23.9. Добавление гиперссылок

  14. Выделите значок Справочник.htm. Имя этого файла появится в поле Адрес:.

  15. Щелкните на кнопке ОК. Теперь на странице появились три дополнительные гиперссылки, как показано на рис. 23.9. Они будут опробованы в конце занятия.

С помощью окна диалога Добавление гиперссылки можно создавать ссылки самых разных типов. Для этого достаточно ввести полный указатель ресурса в поле Адрес: этого окна или воспользоваться одной из кнопок, расположенных правее списка файлов. Чтобы ссылка переносила пользователя в определенную точку web-страницы, выберите в раскрывающемся списке Закладка (Bookmark) одну из закладок, имеющихся на целевой web-странице.


Рисунки

Одним из основных преимуществ гипертекстовых документов перед более ранними форматами данных, распространявшихся через Интернет, является возможность размещения в HTML-файлах рисунков. Графические объекты web-страниц хранятся в отдельных файлах форматов GIF, JPEG или PNG. Примерами таких объектов могут служить маркеры списка, созданного в упражнении 3. Но графические возможности HTML-файлов и редактора Frontpage не ограничиваются этим примером.


Упражнение 5. Добавление рисунка

Чтобы добавить на web-страницу, сформированную в предыдущих упражнениях, логотип компании, выполните следующие шаги.

  1. Поместите текстовый курсор в начало первой строки web-страницы.

Примечание

В web-страницах все рисунки привязываются к определенной точке текста, то есть они являются как бы очередным символом. Поэтому для размещения рисунка в произвольных точках страницы web-дизайнерам приходится прибегать к различного рода хитростям, например размещать графические объекты в ячейках таблиц с невидимыми рамками.

  2. В строке меню приложения раскройте подменю Рисунок (Picture) меню Вставка (Insert) Откроются все возможности вставки рисунка, предоставляемые приложением:

  • Картинки (Clip Art) — возможность выбрать рисунок из одноименной библиотеки;

Рис. 23.10. Добавление рисунка

  • Из файла (From File) — при запуске этой команды открывается окно диалога, показанное на рис. 23.10. Кнопки левого ряда ускоряют доступ к нужным файлам. Например, чтобы вставить рисунок, имеющийся в наборе файлов разрабатываемого web-узла, нужно щелкнуть на кнопке Мои документы и выбрать нужный файл из списка; щелчок на кнопке Рабочий стол (Desktop) облегчает доступ к графическому файлу, расположенному налокальном или сетевом диске; кнопка вебпапки (Web Folders) позволяет просматривать папки и файлы на web-серверах и сетевых устройствах и выбирать нужные графические файлы. В поля Имя файла (File Name) и Тип файла (FileType) можно ввести полный указатель ресурса, добавив таким образом объект с заранее известным адресом;

  • Со сканера или камеры (From Scanner or Camera) — возможность получать изображение непосредственно со сканера или другого устройства, поддерживающего технологию TWAIN;

  • Создать фотоколлекцию (New Photo Gallery) — выбор этой команды позволяет вставлять фотографии из коллекции фотографий.

  3. Давайте воспользуемся первым вариантом. Щелкните на кнопке Clip Art.

  4. В области задач в окне Вставка картинки (Clip Art Gallery) введите в текстовое поле слово Am ma Ls (Животные) и щелкните на кнопке Найти (Search).

  5. Найдите рисунок тигра, щелкните на нем и с помощью указателя мыши перетащите его на web-страницу.

  6. Щелчком выделите рисунок.

  7. Перетащите угловой маркер габаритной рамки рисунка, уменьшив изображение до нужного размера.

  8. Щелкните на рисунке правой кнопкой мыши и выберите в контекстном меню команду Свойства рисунка (Picture Properties).

Примечание

Не размещайте на web-страницах слишком большие рисунки, на их загрузку с удаленного сервера требуется много времени. Это раздражает пользователей.

Рис. 23.11. Параметры рисунка

  9. На вкладке Общие (General), показанной на рис. 23.11, выберите положение переключателя GIF, чтобы указать формат, в котором должен храниться рисунок.

  10. Щелкните на кнопке Обзор, расположенной справа от поля Расположение (Location).

  11. В открывшемся окне дважды щелкните на файле news.htm, который по замыслу должен содержать общую информацию о компании и основные новости. Теперь щелчок на логотипе будет открывать указанную страницу.

  12. Раскройте вкладку Вид (Appearance). Чтобы текст, расположенный справа от рисунка, выровнялся по середине рисунка, выберите в раскрывающемся списке Выравнивание (Alignment) пункт По центру (Center).

  13. Щелкните на кнопке ОК.

  14. Чтобы сохранить выполненные изменения, выберите команду Файл > Сохранить (File> Save).

  15. В окне диалога Сохранение внедренных файлов (Save Embedded Files), показанном на рис. 23.12, щелкните на кнопке Сменить папку (Change Folder).

Рис. 23.12. Сохранение внедренного объекта

  16. Дважды щелкните в открывшемся окне на папке images, а затем на кнопке ОК, указав этим папку, в которой должен храниться файл добавленного рисунка.

  17. Щелкните на кнопке Переименовать (Rename) и введите имя logo.gif.

  18. Затем щелкните на кнопке ОК.

Эта операция приведет к преобразованию изображения формата WMF, полученного из библиотеки Clip Art, в формат GIF, который в отличие от WMF может демонстрироваться любым браузером. В итоге логотип будет записан в файл logo.gif.


Упражнение 6. Фон страницы

Хорошо подобранный фон помогает пользователю воспринимать информацию. С помощью фона можно выделить определенные области страницы и просто при

влечь внимание. Даже если вы не хотите размещать на заднем плане страницы красочный рисунок, всегда задавайте какой-либо однотонный фон, хорошо контрастирующий с текстом. В противном случае браузер удаленного пользователя окрасит фон .в свой цвет, который может существенно испортить страницу, сделав некоторые объекты плохо различимыми.

В качестве фона можно выбрать любой графический файл. При сохранении страницы он будет преобразован в формат GIF или JPEG. Если изображение не покрывает страницу целиком, то оно будет размножено и уложено в виде одинаковых прямоугольных плиток, плотно соприкасающихся друг с другом. Этот факт часто используется для создания фона с вертикальными или горизонтальными полосами путем многократного повторения широкого и низкого или высокого и узкого изображения. Такой подход позволяет, с одной стороны, сформировать привлекательный фон, а с другой — сэкономить время загрузки фона страницы.

Чтобы изменить фон, выполните следующие действия.

  1. Выберите команду Формат > Тема.
  2. В открывшемся окне диалога Темы, показанном на рис. 22.18, установите флажок Фоновый рисунок и щелкните на кнопке Изменить, а затем на кнопке Графика.
  3. В открывшемся окне диалога Изменение темы (Modify Theme) в раскрывающемся списке Элемент выберите Фоновый рисунок (Background Picture) и щелкните на кнопке Обзор, как показано на рис. 23.13.
  4. В появившемся окне диалога Открытие файла (Open) раскройте папку Offi-ceXP\OfficelO\Bitmaps\Styles и дважды щелкните на значке файла acblends.gif.
  5. Щелкнув на кнопке ОК, перейдите к окну диалога Темы. В окне Образец темы (Sample of Theme) посмотрите на результат сделанных изменений.
  6. Убедитесь, что переключатель Применить тему (Apply Theme to) установлен в положение К выбранным страницам и щелкните на кнопке ОК.

Рис. 23.13. Изменение фона страницы

Теперь web-страница будет выглядеть так, как показано на рис. 23.14.

Рис. 23.14. Web-страница с рисунком и измененным фоном

  7. Щелкните на странице правой кнопкой мыши и выберите из контекстного меню пункт Свойства страницы (Page Properties) В открывшемся одноименном окне диалога раскройте вкладку Общие.

  8. В поле Название (Title) введите текст Трубы от компании Геркулес. При загрузке страницы этот текст будет появляться в заголовке окна браузера. Щелкните на кнопке ОК.

Если для страницы тема не установлена, то изменение фона можно произвести с помощью команды Формат > Фон (Format > Background), в появившемся окне диалога установить флажок Фоновый рисунок, щелкнуть на кнопке Обзор и в окне диалога Выбор рисунка фона (Select Background Pictures) выбрать файл с расширением GIF, например тот, что использован в этом упражнении.


Специальные объекты

Упражнение7. Панель навигации

Панели навигации — это особые объекты Frontpage, которые позволяют автоматически добавлять и обновлять ссылки на страницы, иерархически связанные с текущей. Из упражнения 7 предыдущего занятия вы уже узнали, как добавлять и убирать панели навигации с помощью команды Общие границы (Shared Borders). Теперь пришло время научиться настраивать панели навигации конкретных страниц.

В левой части web-страницы Трубы есть местозаполнитель [Измените свойства этой панели для отображения на ней гиперссылок (Editthe properties forthis Link Bar to display hyperlinks here)], представляющий собой ненастроенную панель навигации. Давайте изучим ее свойства.

Рис. 23.15. Вкладка Общие окна диалога Свойства панели ссылок

  1. Щелкните на указанном местозаполнителе правой кнопкой мыши и выберите команду Свойства панели ссылок (Link Bar Properties). Откроется окно диалога с двумя вкладками, показанное на рис. 23.15. Вкладка Общие дает возможность указать, какие гиперссылки должны появляться в панели ссылок.

Положения переключателя раздела Добавляемые гиперссылки (Hyperlinks To Add То Page) позволяют добавлять следующие группы гиперссылок:

  • Родительский уровень (Parent Level) — на страницы, расположенные в навигаторе на уровень выше текущей;

  • Тот же уровень (Same Level) — на страницы того же уровня подчиненности, связанные в навигаторе с одной и той же родительской страницей;

  • Назад и далее (Back And Next) — на предыдущую и последующую страницы той же группы подчиненности, что и текущая;

  • Дочерний уровень (Child Level) — ссылки на дочерние страницы относительно текущей;

  • Глобальный уровень (Top Level) — ссылки на страницы самого верхнего уровня иерархии навигатора;

  • Дочерние страницы домашней (Child Page Under Home) — ссылки на страницы второго уровня иерархии навигатора.

Кроме того, флажки Домашняя страница (Home Page) и Родительская страница (Parent Page) позволяют независимо от положения переключателя помещать в панель навигации ссылки соответственно на домашнюю и родительскую web-страницы узла.

  2. Выберите положение переключателя Назад и далее.

Рис. 23.16. Панели навигации

  3. Установите флажки Домашняя страница и Родительская страница.

На вкладке Стиль (Style) приводятся образцы стандартных стилей оформления гиперссылок и предоставляется возможность установить их ориентацию.

  4. С помощью полосы прокрутки в разделе Выберите стиль выберите подходящий стиль оформления гиперссылок и щелкните на нем.

  5. Щелкните на кнопке ОК.

  6. Прокрутите web-страницу вниз. Вы увидите в ее нижней части еще одну панель навигации с текстовыми ссылками.

  7. Выделите эту панель и, чтобы открыть окно параметров панели, нажмите клавиши Alt+Enter.

  8. Выберите положение переключателя Same Level.

  9. Установите флажки Home Page и Parent Page.

  10. Щелкните на кнопке ОК. Теперь ссылки панелей будут выглядеть так, как показано на рис. 23.16.

Примечание

Всегда помещайте в нижнюю часть страницы гиперссылки навигации в текстовом формате. Они позволят работать тем пользователям, браузеры которых не способны загружать изображения.


Упражнение 8. Закладки

Закладки позволяют формировать гиперссылки на определенную точку конкретной web-страницы. С помощью таких ссылок пользователь может одним щелчком прокрутить страницу к нужному месту. Чтобы добавить закладку, выполните следующие шаги.

  1. Выберите команду Вид > Список папок (View > Folder List), чтобы вывести в окно Frontpage панель списка файлов и папок web-узла.

  2. Дважды щелкните на значке файла prod04.htm, чтобы открыть его в окне редактора.

  3. Прокрутите web-страницу в самый низ и щелкните в начале слов Phone.

  4. Выберите команду Вставка > Закладка (Insert > Bookmark).

  5. В поле Имя закладки (Bookmark Name) открывшегося окна диалога (рис. 23.17) введите слова end_of_page.

Рис. 23.17. Добавление закладки

  6. Щелкните на кнопке ОК.

  7. Закройте файл prod04.htm.

  8. При появлении соответствующего запроса подтвердите необходимость со хранения выполненных изменений.

Теперь давайте добавим на страницу Трубы ссылку, указывающую на только что созданную закладку.

  9. Введите в конце страницы Трубы фразу Обратите внимание на наши дешевые гвозди.

  10. Выделите слово г возди, затем щелкните на нем правой кнопкой мыши и выберите команду Гиперссылка.

  11. В списке открывшегося окна диалога создания гиперссылки щелкните на значке файла prod04.htm.

  12. В том же окне щелкните на кнопке Закладка (Bookmark), а затем на имени закладки в появившемся окне диалога Выделить место в документе (Select Place in Document) и щелкните на кнопке ОК. В поле Адрес: окна диалога Добавление гиперссылки будет введено имя prod04.htm#end_of_page, как показано на рис. 23.18.

Рис. 23.18. Ссылка на закладку

  13. Щелкните на кнопке ОК.

Действие полученной гиперссылки вы сможете оценить, выполняя последнее упражнение занятия.


Просмотр страницы

Окно режима просмотра Страница имеет три вкладки, открывающие доступ к трем различным вариантам демонстрации web-страницы. Первый из них — Обычный (Normal) предназначен для разработки страниц с помощью средств редактирования приложения Frontpage. Второй режим — HTML — позволяет просматривать и корректировать код web-страницы, сгенерированный редактором. Наконец, третья вкладка дает возможность, не выходя из Frontpage, предварительно просмотреть построенную web-страницу.


Упражнение 9. HTML-код

Frontpage предлагает разработчику множество разнообразных инструментов, позволяющих конструировать практически любые web-страницы. Однако полное управление форматом отображения информации можно получить, только редактируя исходный код HTML-файла, формирующий изображение страницы. Frontpage предлагает два способа просмотра этого кода.

  1. Не выходя из окна web-страницы Трубы, выберите команду Вид > Показать теги (View > Reveal Tags).

Рис. 23.19. Теги документа

В этом режиме (рис. 23.19) на экране отображается не только содержимое web-страницы, но и управляющие конструкции — теги, — которые и формируют имеющееся форматирование документа. В HTML-документе все теги заключены в угловые скобки. Они делятся на открывающие и закрывающие, которые отличаются от первых наличием символа «/». Между одноименными открывающим и закрывающим тегами размещается текст, форматирование которого задается этими тегами. Например, между тегами <table> и </table> заключено содержимое таблицы. Некоторые теги, такие как <hr>, который добавляет на страницу горизонтальную линию, не имеют парного закрывающего тега. Многоуровневое вложение подобных конструкций позволяет задавать любые самые сложные варианты форматирования документа. Указанный режим демонстрации страницы помогает понять ее структуру и облегчает поиск ошибок.

  2. Переместите указатель мыши на значок тега </а>, расположенный справа от изображения тигра. Появится всплывающая подсказка, демонстрирующая полный текст этого тега. Однако указанный вариант просмотра страницы дает возможность видеть теги,но не позволяет их редактировать.

  3. Чтобы получить полный доступ к коду страницы, щелкните на корешке HTML. Вы увидите текстовый документ, на основе которого генерируется web-страница. Давайте попробуем скорректировать его.

  4. Прокрутите содержимое окна до текста Тонкие медные трубы.

  5. Введите перед словом медные теги <bxfont color=»c90000">.

  6. После этого слова добавьте теги </font></b>.

Примечание

Добавление тегов в режиме редактирования кода HTML иногда приводит к нарушению ранее назначенных режимов форматирования и искажению некоторых объектов. Перед изменением кода полезно сохранить на диске копию редактируемой web-страницы, чтобы в случае неудачи иметь возможность возвратиться к исходному варианту.

  7. Щелкните на корешке Обычный, чтобы вернуться в обычный режим просмотра страницы.

  8. Нажатием клавиш Ctrl+/ отключите демонстрацию тегов. Обратите внимание, что теги, добавленные в режиме редактирования исходного кода, окрасили слово медные в красный цвет и задали ему жирное начертание.

Досконально изучив язык HTML, вы сможете корректировать страницы, созданные во Frontpage, добавляя в них самые сложные эффекты, недоступные существующим web-редакторам.


Упражнение 10. Предварительный просмотр

Режим предварительного просмотра показывает web-страницу такой, какой она будет в окне браузера.

  1. Чтобы включить такой просмотр, щелкните на корешке Просмотр (Preview). Теперь на странице отсутствуют пунктирные линии, показывающие границы разделов страницы. Изменилась рамка таблицы, стали другими шрифт и интервалы между строками. Для активизации гиперссылок теперь не нужно нажимать клавишу Ctrl. Достаточно просто щелкнуть на ссылке. В целом обычный режим просмотра очень похож на результирующую страницу, он позволяет достаточно точно оценивать расположение объектов и оформление текста. Но, редактируя документ, не забывайте периодически обращаться к вкладке Просмотр, которая точнее показывает общий вид элементов страницы. Перед публикацией web-узла обязательно просмотрите его страницы в окне браузера. Если на вашем компьютере установлено несколько браузеров, откройте узел в каждом из них, внимательно изучите все детали и убедитесь, что все браузеры корректно отображают введенную информацию и графические объекты. Имейте в виду, что Frontpage позволяет оперативно загружать web-страницы в любой браузер.

  2. Щелчком на кнопке Сохранить панели инструментов Стандартная сохраните измененный вариант страницы Трубы.

  3. Выберите команду Файл > Просмотр в обозревателе (File > Preview In Browser).

  4. В открывшемся окне диалога выберите пункт Internet Explorer, а затем щелкните на кнопке Просмотр (Preview). Страница Трубы, сформированная в упражнениях этого занятия, появится в окне Internet Explorer . Давайте проверим работу ссылок, добавленных на эту страницу.

  5. Переместите указатель на слова справочник товаров, чтобы значок указателя принял форму ладони, и щелкните мышью. Страница Трубы сменится страницей Справочник товаров.

  6. Чтобы вернуться обратно, щелкните на кнопке Назад на Трубы от компании Геркулес панели инструментов Internet Explorer.

  7. Повторяя шаги 5 и 6, проверьте действие ссылки цены.

  8. Щелкните на гиперссылке гвозди. Обратите внимание, что это действие не только открывает страницу Гвозди, но и прокручивает ее до закладки end_of_ page, вставленной в конец этой страницы.

  9. В текстовой панели навигации, расположенной в нижней части страницы Гвозди, щелкните на ссылке Up, чтобы переместиться к странице Товары — родительской по отношению к трем web-страницам, рассмотренным выше.

  10. Чтобы вернуться на страницу Трубы, щелкните на ссылке Трубы металлические.

  11. Щелкните на ссылке info@hercules. corn. Эта операция запустит Outllook и откроет окно нового сообщения, в поле Кому (То) которого уже будет добавлен электронный адрес получателя. Чтобы отослать письмо по адресу, указанному в гиперссылке, останется только ввести текст и щелкнуть на кнопке Отправить (Send).

  12. Закройте окно Internet Explorer.

  13. В приложении Frontpage выберите команду Файл > Закрыть веб-узел (File > Close Web). При появлении запросов о необходимости сохранения изменений щелкайте на кнопке Да.


Контрольное упражнение

Чтобы закрепить навыки, полученные на этом занятии, выполните следующие действия.

  1. Откройте web-узел, созданный в предыдущем упражнении.

    • Как быстро открыть web-узел, с которым вы недавно работали?

  2. Выведите в режиме Страница содержимое файла Справочник.htm, сохраненного в папке Дополнения.

  3. Добавьте на страницу Справочник товаров таблицу с тремя столбцами.

  4. Введите в эту таблицу названия, цены и минимальные партии поставок товаров, освещаемых web-узлом Corporate.

  5. Назначьте ячейкам таблицы желтый фон.

    • Как изменить фон ячеек таблицы?

  6. Добавьте на web-страницу тот же логотип, который был вставлен на страницу Трубы.

  7. Назначьте фон страницы, идентичный выбранному в упражнении 6.

  8. Название каждого товара, расположенное в левой ячейке таблицы, свяжите со ссылкой на web-страницу, содержащую подробное описание этого товара.

  9. Измените расположенную слева панель навигации так, чтобы в нее выводились кнопки страниц того же уровня, а также ссылки на домашнюю и родительскую страницы.

  10. В качестве текста, выводимого в заголовке браузера при открытии данной страницы, назначьте предложение Справочник товаров компании Геркулес.

    • Как настроить текст заголовка окна?

  11. Просмотрите HTML-код полученной страницы.

  12. Откройте страницу Справочник товаров в окне браузера Internet Explorer и проверьте работу гиперссылок.

  13. Сохраните изменения и закройте web-узел.


Подведение итогов

На этом занятии был рассмотрен интегрированный в приложение Frontpage модуль редактирования web-страниц. Вы научились строить таблицы, создавать маркированные и нумерованные списки, добавлять рисунки, задавать рисунок для фона, настраивать гиперссылки на другие web-страницы и ресурсы Интернета.

Следующее занятие рассказывает о методах создания web-страниц с кадрами и способах анимации объектов страниц. На нем также будет рассмотрено назначение некоторых дополнительных элементов и расширений, предлагаемых компанией Microsoft.


Занятие №24

Усовершенствование web-страниц

ТЕМА ЗАНЯТИЯ

На двух предыдущих занятиях были рассмотрены вопросы построения схемы web-узла и разработки содержания его страниц. Теперь вы познакомитесь с некоторыми специальными объектами и способами оформления страниц, повышающими их привлекательность. В упражнениях этого занятия изучаются следующие темы:

  • компоненты Frontpage;

  • изображение по расписанию;

  • дата и время:

  • бегущая строка;

  • кадры;

  • звук;

  • видеоклип;

  • динамические эффекты.

Компоненты FrontPage

Кроме стандартных приемов форматирования web-страниц, основанных на возможностях языка HTML, Frontpage предлагает набор средств, которые называют компонентами Frontpage. С их помощью можно улучшить оформление узла и расширить его функциональные возможности. Имейте в виду, что дополнительные функции могут не поддерживаться некоторыми браузерами, поэтому, применяя расширения компании Microsoft, обратите особое внимание на проверку работоспособности web-страниц в различных браузерах. Желательно протестировать web-узел на разных компьютерных платформах. Компоненты Frontpage добавляются в web-страницу с помощью команд подменю Вставка > Веб-компонент (Insert > Web Component). Описание некоторых компонентов Frontpage приведено в табл. 24.1.

ТАБЛИЦА 24.1. Компоненты Frontpage
Название | Описание
Примечание(Comment) | Позволяет вводить в web-страницу комментарии. Они будут видны в процессе разработки, но удаленный пользователь их не увидит. Этот компонент удобен для документирования web-узлов
Поле подтверждения(Confirmation Field) | Используется для подтверждения введенных данных, например в форме web-страницы
Страница(Included Page) | Позволяет заменить содержимое текущей web- страницы другой web-страницей
Страница по расписанию (Included Page Based on Schedule) | Дает возможность включить в web-страницу некоторый файл на строго определенное время. По прошествии заданного интервала времени файл не будет отображаться на странице. Этот компонент полезен, например, для вывода сообщений о скидках, действительных только на определенный период
Рисунок с расписанием(Included Picture Based on Schedule) | Позволяет выводить изображение на web- странице в течение заданного интервала времени. По прошествии этого периода изображение появляться не будет :
Поиск в Интернете | Добавляет в web-узел форму процедуры поиска (Search Form) заданного текста
Подстановка (Substitution) | В процессе выполнения этот компонент заменяется значением определенного параметра или системной переменной окружения
Оглавление(Table Of Contents) | Формирует на web-странице оглавление узла, созданного во Frontpage. Это оглавление будет автоматически обновляться при изменении содержимого web-узла

Название | Описание
Дата и время (Date And Time) | В процессе работы на месте этого компонента будут выводиться дата и время
Счетчик посещений (Hit Counter) | Форма, производящая подсчет количества посетителей web-узла
Объявление на странице... (Page Banner) | Добавляет на каждую страницу web-узла один и тот же баннер
Быстрая строка (Marquee) | Выводит текст в виде бегущей строки, параметры которой можно менять в широких пределах

Примечание

Большинство перечисленных компонентов становится доступным из окна диалога Вставка компонента веб-узла (Insert Web Component), возникающем на экране при команде Вставка > Веб-компонент.

Упражнение 1. Изображение по расписанию

На предыдущем занятии вы добавили на web-страницу Трубы изображение тигра. Давайте воспользуемся компонентом Frontpage, чтобы обеспечить автоматическую замену этого рисунка другим на определенный интервал времени. Для этого выполните следующие шаги.

  1. Откройте в приложении Frontpage узел Corporate.

  2. Выведите содержимое страницы Трубы (файл prodOl.htm) в режиме просмотра Страница.

  3. Поместите курсор правее изображения тигра.

  4. Выберите команду Вставить > Рисунок ^ Картинки (Insert > Picture > Clip Art).

  5. В текстовое поле в области задач приложения введите слово Animаls (Животные), затем щелкните на кнопке Найти. Поставьте указатель мыши на рисунок коровы и выберите в контекстном меню команду Вставить (Insert). На web-странице появится второе изображение, как показано на рис. 24.1.

  6. Щелчком на кнопке Сохранить панели инструментов Стандартная сохраните новый вариант страницы.

  7. В открывшемся окне диалога Сохранение внедренных файлов щелкните на кнопке Переименовать, введите имя logo2 . gi f и щелкните на кнопке ОК.

  8. Выделите изображение коровы и нажатием клавиши Delete удалите его. Выполненные шаги 3-8 никак не изменили web-страницу. Они необходимы, чтобы преобразовать векторный рисунок библиотеки Clip Art в растровое изображение формата GIF. Если у вас есть два заранее подготовленных файла формата GIF с соответствующими рисунками, эти шаги можно опустить.

  9. Щелчком выделите изображение тигра.

  10. Выберите команду Вставка > Веб-компонент. В появившемся окне диалога Вставка компонента Веб-узла выделите в списке Тип компонента: (Component Type.) пункт Включенное содержимое (Included Content:) и в списке Выбеоите тип содержимого: (Choose a type of Content) дважды щелкните ТнктеРигу иок с расписанием (Picture Based on Schedule), как показано на ST

Рис. 24.1 . Добавление изображения по расписанию

  11. В окне диалога Свойства рисунка с расписанием (Scheduled Picture Prooertie> показанном на рис. 24.2, щелкните на верхней кнопке Обзор propert1es)

Рис. 24.2. Расписание вывода изображений

  12. Выберите в появившемся списке файл logo2.gif и щелкните на кнопке ОК.

  13. Щелкните на нижней кнопке Обзор.

  14. Выберите файл logo.gif и щелкните на кнопке ОК.

  15. С помощью раскрывающихся списков группы Окончание (Ending) установи те дату, отстоящую вперед от текущей примерно на два месяца.

  16. Щелкните на кнопке ОК.

Настроенный режим вывода изображений инициирует демонстрацию на web-странице файла logo2.gif (корова) в течение двух месяцев. До и после этого интервала времени на странице будет появляться файл logo.gif (тигр). Давайте проверим работу этого изменчивого изображения в окне браузера.

Рис. 24.3. Смена системного времени

  17. Выберите команду Файл > Просмотр в обозревателе. В качестве логотипа в окне Internet Explorer появится изображение коровы.

  18. Дважды щелкните на часах Панели задач Windows.

  19. В окне диалога настройки времени, показанном на рис. 24.3, увеличьте на 1 номер года.

  20. Щелкните на кнопке ОК.

  21. В окне Frontpage щелкните на кнопке Сохранить, чтобы обновить дату страницы.

  22. Переключитесь в окно Internet Explorer и нажмите клавишу F5, чтобы обновить документ. Теперь на страницу вернулось изображение тигра, так как новая дата не попадает во временной интервал компонента Рисунок с расписанием.

  23. Закройте окно браузера.

Примечание

Окончив эксперименты, не забудьте восстановить правильную системную дату.

Упражнение 2. Время и комментарии

Чтобы познакомиться с компонентом Frontpage, называющимся Дата и время (Date And Time), выполните следующие шаги.

  1. С помощью полосы прокрутки перейдите в самый низ страницы Трубы.

Рис. 24.4. Компонент даты и времени

  2. Последняя строка страницы содержит надпись Дата изменения (Last modified) и дату, соответствующую моменту последнего сохранения данной web-страницы (рис. 24.4). Этот компонент Дата и время был автоматически добавлен мастером при создании узла Corporate на занятии 22. Давайте скорректируем свойства компонента.

Примечание

Чтобы самостоятельно добавить компонент Дата и время, воспользуйтесь соответствующей командой Вставка > Дата и время (Insert > Date And Time).

  3. Щелкните на дате правой кнопкой мыши и выберите команду Свойства даты и времени (Date And Time Properties).

  4. В открывшемся окне диалога, показанном на рис. 24.5, выберите положение Дату последнего автоматического обновления страницы (Date This Page Was Last Automatically Update) переключателя Отображать (Display). Этот вариант задания даты чрезвычайно удобен, но он работает только при использовании расширений модуля Personal Web Server компании Microsoft.

  5. В раскрывающемся списке Формат даты (Date Format) выберите подходящий вариант вывода даты.

  6. Чтобы добавить индикатор времени, выберите один из пунктов раскрывающегося списка Time Format (Формат времени).

  7. Щелкните на кнопке ОК. Поскольку для нормальной работы модифицированного компонента требуется Personal Web Server, следует вставить соответствующий комментарий, который не виден удаленному пользователю, но появляется перед разработчиком узла в окне Frontpage.

  8. Щелкните в начале строки Дата изменения и выберите команду Вставка > Примечание (Insert > Comment).

  9. В открывшемся окне диалога введите текст Внимание ! Данный компонент даты и времени работает только под управлением Personal Web Server.

  10. Щелкните на кнопке ОК.

  11. Нажмите клавишу Enter.

Рис. 24.5. Параметры даты и времени

Рис. 24.6. Страница с комментарием :

  12. Замените текст Дата изменения на вариант Дата последнего обновления. Теперь страница будет выглядеть так, как показано на рис. 24.6.

  13. Щелкните на корешке Просмотр. Обратите внимание, что в этом режиме (так же, как и в окне браузера) комментарий не виден.

Упражнение 3. Бегущая строка

С помощью бегущей строки можно выделить определенный текст и привлечь к нему внимание удаленного пользователя. Этот компонент поддерживается не всеми браузерами, а только теми, которые совместимы с расширениями компании Microsoft. В других программах символы бегущей строки будут отображаться в виде статического текста. Чтобы сделать имеющийся текстовый фрагмент бегущей строкой, выполните следующие шаги:

  1. Выделите строку Низкие цены, постоянным клиентам скидки, щелкнув мышью слева от нее.

  2. Щелкните в панели инструментов Стандартная на кнопке Веб-компонент (Web Component) и выделите в появившемся окне диалога Вставка компонента веб-узла пункт Динамические эффекты (Dynamic Effects). В правой части окна диалога дважды щелкните на пункте Быстрая строка (Marquee).

  3. В открывшемся окне диалога (рис. 24.7) выберите положение Влево (Left) переключателя Направление (Direction), чтобы выбрать направление движения строки.

Рис. 24.7. Свойства бегущей строки

  4. Сбросьте флажок Постоянно (Continuously).

  5. Введите в счетчик раздела Повторы (Repeat) число 3.

  6. При необходимости измените другие параметры, после чего щелкните на кнопке ОК.

  7. Щелкните на вкладке Просмотр. Текст бегущей строки будет двигаться в окне справа налево. После того как вся строка три раза пересечет web-страницу, ее текст исчезнет и больше не появится. Для повторения эффекта придется перезагрузить страницу в режиме предварительного просмотра или в окне браузера.

  8. Закройте web-узел командой Файл > Закрыть веб-узел.

Кадры

Кадры позволяют разбивать окно браузера на несколько прямоугольных областей, в каждой из которых будет демонстрироваться отдельная web-страница. Наличие кадров позволяет упростить перемещение по страницам узла. Обычно слева в отдельном кадре помещают оглавление web-узла, которое доступно всегда, вне зависимости от того, какая страница находится в этот момент в основном кадре справа. В результате простым щелчком в левом кадре пользователь может быстро загрузить в основную область браузера необходимую информацию.

Упражнение 4. Страница с кадрами

Для создания страниц с кадрами во Frontpage имеется специальный мастер, избавляющий вас от необходимости изучать специальные теги. Кроме того, этот мастер позаботится об организации альтернативного варианта просмотра страниц для-тех пользователей, браузеры которых не поддерживают кадры.

На двух предыдущих занятиях вы уже научились создавать web-страницы, поэтому сейчас не будут рассматриваться детали разработки конкретных страниц.

В качестве содержания нового узла можно воспользоваться страницами, созданными ранее для узла Corporate. Но навигация по этим страницам будет организована с помощью кадров.

  1. Выберите команду Файл > Создать > Страницу или веб-узел (File > New > Web or Page).

  2. В области задач в разделе Создание с помощью шаблона щелкните на значке Шаблоны веб-узлов (Web Site Templates).

  3. В поле Укажите расположение нового веб-узла (Specify The Location Of The New Web) открывшегося окна диалога введите путь папки узла и имя Frames.

  4. Дважды щелкните на значке Одностраничный веб-узел (One Page Web).

  5. Выберите в подменю Файл > Последние веб-узлы (File > Recent Webs) пункт Corporate, чтобы открыть узел, созданный на предыдущих занятиях.

  6. Щелкните на кнопке Папки (Folders) панели режимов.

  7. Нажмите клавишу Ctrl и, не отпуская ее, щелкайте на именах файлов, чтобы выделить группу страниц в соответствии с рис. 24.8.

  8. Щелкните на одном из выделенных файлов правой кнопкой мыши и выберите в контекстном меню команду Копировать (Copy).

  9. Закройте узел Corporate.

  10. В окне узла Frames выберите команду Вид > Папки (View > Folders), щелкните в области списка файлов правой кнопкой мыши и выберите команду Вставить. В результате этих операции часть страниц узла Corporate будет перенесена в узел Frames.

Рис. 24.8. Копирование web-страниц

  11. Щелкните на значке режима Страница.

  12. В области задач в разделе Создание с помощью шаблона щелкните на значке Шаблоны страниц... (Page Templates...).

  13. В окне диалога Шаблоны страниц (Page Templates) щелкните на вкладке Стра ница рамок (Frames Pages).

  14. Щелкните на значке Колонтитулы и оглавление (Header, Footer And Contents).

  15. Щелкните на кнопке ОК. В окне Frontpage появится страница с четырьмя пустыми кадрами и несколькими кнопками, позволяющими связывать кадры с определенными HTML-файлами.

  16. Чтобы создать файл кадра заголовка, щелкните на верхней кнопке Создать страницу (New Page).

  17. Щелкните на кнопке Сохранить панели инструментов Стандартная, введите в открывшемся окне диалога имя topframe. htm и щелкните на кнопке Сохранить. Теперь в верхний кадр будет выводиться содержимое страницы topframe. htm.

  18. Вслед за этим Frontpage попросит назначить имя главного файла, управляющего кадрами. Введите в окно диалога имя index, htm и щелкните на кнопке Сохранить.

Примечание

Файл index.htm обычно играет роль страницы, которая загружается в браузер по умолчанию после открытия web-узла. В новом узле эта роль отводится странице, управляющей кадрами.

  19. Щелкните на левой кнопке Создать страницу.

  20. Повторите шаг 17, введя для левого кадра имя leftframe. htm.

  21. Щелкните на нижней кнопке Создать стра н и цу и сохраните содержимое ниж него кадра в файле bottomframe.htm.

  22. Щелкните на единственной из оставшихся кнопок Задать начальную страницу (Set Initial Page).

  23. Выберите в списке файл products.htm и щелкните на кнопке ОК. В основном кадре сразу же появится содержимое этой страницы, которая была скопирована из узла Corporate.

Упражнение 5. Кадры заголовка и примечания

Пришло время наполнить содержанием верхний и нижний кадры. Для этого выполните следующие шаги.

  1. Щелкните в верхнем кадре.

  2. Выберите команду Вставка > Рисунок > Картинки....

Рис. 24.9. Параметры изображения

  3. В области задач в окне Вставка картинок (Clip Art) введите в текстовое роле слово Animals (Животные), затем щелкните на кнопке Найти; из появившегося набора изображений остановитесь на картинке с тигром и выберите в контекстном меню команду Вставить. В результате в верхнем кадре появится логотип компании.

  4. Чтобы настроить размеры логотипа, щелчком выделите его и нажмите клавиши Alt+Enter. Откроется окно диалога параметров изображения, показанное на рис. 24.9.

  5. Щелкните на вкладке Вид.

  6. Установите флажок Задать размер (Specify size).

  7. В счетчик Высота (Height) введите число 70.

  8. В раскрывающемся списке Выравнивание выберите пункт По центру.

  9. Щелкните на кнопке ОК.

  10. Чтобы рисунок был виден целиком, перетащите границу верхнего кадра немного вниз.

  11. Щелкните правее добавленного изображения и введите слово Геркулес.

  12. Выделите название компании и щелкните па кнопке Полужирный панели инструментов Форматирование.

  13. Чтобы увеличить шрифт, выберите в раскрывающемся списке Размер шрифта пункт 7 (36 pt).

Рис. 24.10. Содержание верхнего и нижнего кадров

  14. Щелкните в нижнем кадре и введите текст Подробную информацию о деятельности компании можно получить по адресу info@hercules.corn . В конце ввода этой строки нажмите клавишу Пробел, чтобы Frontpage автоматически связал с адресом электронной почты соответствующую гиперссылку.

  15. Перетащите границу нижнего кадра вниз, чтобы по возможности уменьшить его размеры. Теперь страница с кадрами будет выглядеть так, как показано на рис. 24.10.

Упражнение 6. Оглавление web-узла

Вам осталось сконструировать оглавление узла в левом кадре страницы и настроить соответствующие гиперссылки на страницы, которые должны демонстрироваться в основном (правом) кадре.

  1. Щелкните в левом кадре страницы.

  2. Введите слово Продукция и нажмите клавишу Enter.

  3. Затем введите слова Трубы, Панели и Гвозди, отделяя их друг от друга нажатиями клавиши Enter.

  4. Выделите четыре пункта левого кадра, протащив мышь слева от них.

  5. Щелкните на кнопке Маркеры панели инструментов Форматирование. Оглавление узла готово. Теперь нужно настроить гиперссылки.

  6. Выделите слово Продукция, щелкните на нем правой кнопкой мыши и выберите в контекстном меню команду Гиперссылка.

  7. В открывшемся окне диалога (рис. 24.11) из списка файлов выделите файл products.htm и щелкните на нем. При этом имя файла появится в текстовом поле Адрес:.

Рис. 24.11. Выбор рамки

Рис. 24.12. Параметры страницы рамок

  8. Щелкните на кнопке Выбор рамки (Target Frame).

  9. В разделе Текущая страница рамок (Current Frames Page) окна диалога Конечная рамка (Target Frame) щелкните на правом кадре/чтобы в поле Настройка объекта (Target Setting) появилось слово main. Это заставит браузер выводить файл, на который указывает гиперссылка, в правый кадр.

  10. Щелкните два раза на кнопке ОК.

  11. Повторяя шаги 6-10, назначьте словам Трубы, Панели и Гвозди соответственно ссылки на файлы prodOl.htm, prod02.htm и prod04.htm. He забывайте в качестве целевого выбирать правый кадр.

Обычно кадры используются для структурирования окна браузера, которое при этом должно выглядеть как одна страница с несколькими полями. По этой причине рамки, разделяющие кадры, как правило делают невидимыми.

Рис. 24.13. Страница с кадрами

Чтобы скрыть рамки, выполните следующие шаги.

  12. Щелкните в области страницы с кадрами правой кнопкой мыши и выберите в контекстном меню команду Свойства рамки (Frame Properties).

  13. В открывшемся окне диалога щелкните на кнопке Страница рамок (Frames Page). Эта операция откроет другое окно диалога, показанное на рис. 24.12.

  14. Раскройте вкладку Рамки (Frames).

  15. Сбросьте флажок Показать границы (Show Borders).

  16. Два раза щелкните на кнопках ОК. Теперь страница станет такой, как показано на рис. 24.15. Эта операция завершает создание структуры web-узла с кадрами. Вам остается наполнить содержанием страницы prod0l.htm, prod02.htm и prod04.htm. Сделайте это самостоятельно, открывая файлы в режиме просмотра Страница. При желании измените фон страниц и форматирование текста. Можете добавить несколько картинок или еще как-нибудь приукрасить web-узел.

  17. Чтобы познакомиться с поведением узла с кадрами и проверить действие гиперссылок, щелкните на корешке Просмотр. *

  18. Щелкните на слове Трубы. В основном окне появится содержимое страницы Трубы, а остальные три кадра останутся без изменения, дв;

Примечание

Рисунок и графические маркеры страницы Трубы будут отображаться в виде пустых прямоугольников, так как соответствующие файлы формата GIF не были скопированы в узел Frames. Чтобы изображения появлялись на своих местах, в Проводнике скопируйте папку images из узла Corporate в узел Frames.

  19. Щелкните на ссылке Гвозди. Соответствующая страница длинная и не влезает в основной кадр целиком, поэтому в ее правой части появится полоса прокрутки. Попробуйте с помощью этой полосы просмотреть всю страницу. Вы увидите, что прокручивается только область правого кадра, в то время как остальные кадры остаются на прежних местах. Таким образом, страница с кадрами позволяет, с одной стороны, обеспечить постоянный доступ к важным элементам узла, таким как гиперссылки оглавления, заголовок узла или адрес компании, а с другой — просматривать в одном из кадров достаточно большие документы.

Мультимедийные эффекты

Все web-страницы, рассматривавшиеся в предыдущих упражнениях книги, были статическими. В них можно просматривать имеющееся содержание и с помощью щелчков на гиперссылках загружать другие страницы узла. В настоящее время наблюдается бурное развитие мультимедийных технологий, они не обошли и Интернет. Frontpage в полной мере поддерживает возможности размещения на web-страницах мультимедийных объектов и настройки динамических эффектов, являющихся реакцией на определенные действия пользователя.

Упражнение 7. Фоновый звук

В упражнении 4 предыдущего занятия рассказывалось, как добавлять гиперссылки на другие web-страницы. Можно с помощью аналогичных ссылок адресовать и звуковые файлы. При щелчке на такой ссылке браузер загрузит с удаленного сервера звуковой файл и проиграет его. Кроме того, любой странице можно назначить фоновый звук, который будет воспроизводиться при открытии НТМL-файла.

Примечание

Воспроизводить звуковые файлы можно только на мультимедийном компьютере, в котором установлена звуковая карта с подключенными громкоговорителями или наушниками.

Чтобы добавить на web-страницу Трубы звуковой файл, выполните следующие шаги.

  1. Откройте файл prodOl.htm узла Corporate в режиме Страница.

  2. Введите в конец страницы предложение Наши медные трубы могут издавать музыкальные звуки, вы слышали их при открытии этой страницы.

  3. Выберите команду Файл > Свойства (File > Properties).

Рис. 24.14. Выбор звукового файла

  4. На вкладке Общие (рис. 24.14) щелкните на кнопке Обзор, расположенной в разделе Фоновый звук (Background Sound).

  5. В открывшемся окне диалога найдите папку, в которую был установлен пакет Office XP, откройте вложенную в нее папку Office10 и выберите файл reminder.wav. Щелкните на кнопке Открыть.

  6. Затем закройте окно свойств, щелкнув на кнопке ОК.

  7. Выберите команду Файл > Сохранить. В появившемся окне диалога Сохранение внедренных файлов щелкните на кнопке ОК.

  8. Чтобы прослушать звуковое сопровождение, щелкните на вкладке Просмотр. Сразу же после загрузки страницы вы услышите периодически повторяющийся звук файла reminder.wav.

Упражнение 8. Видеоклип

Frontpage позволяет размещать на web-страницах не только звуки, но и видеоклипы. В этом упражнении в кадр содержания узла Frames будет добавлена гиперссылка на страницу с видеоклипом.

  1. Чтобы открыть узел Frames, выберите команду Файл > Открыть веб-узел. С помощью раскрывающегося списка Папка и списка файлов окна диалога Открытие веб-узла (Open Web) найдите папку Frames. Раскройте ее двойным щелчком на соответствующем значке. Затем щелкните на кнопке Открыть.

  2. В панели режимов щелкните на значке Папки.

  3. В списке файлов узла дважды щелкните на значке index, htm, чтобы открыть в режиме Страница (Page) основную страницу с кадрами.

  4. Щелкните в левом кадре справа от ссылки Гвозди и нажмите клавишу Enter.

  5. Введите слово Видеоклип и, чтобы выделить его, нажмите клавиши Shift+Ctrl+<-.

  6. Щелкните на выделенном слове правой кнопкой мыши и выберите команду Hyperlink.

  7. В открывшемся окне диалога (рис. 24.15) в поле Адрес: введите имя video. htm.

  8. Щелкните на кнопке Выбор рамки..

  9. В открывшемся окне диалога в списке Общие объекты выделите пункт Страница целиком (Whole Page). Такая настройка целевого кадра заставит страницу с видеоклипом заменить страницу с кадрами, освободив видеоклипу по возможности большее пространство окна браузера.

  10. Два раза щелкните на кнопке ОК.

  11. Чтобы сохранить новый вариант домашней страницы, щелкните на кнопке Сохранить панели инструментов Стандартная. Гиперссылка на видеоклип готова. Теперь для его демонстрации нужно создать саму web-страницу.

  12. Щелкните на кнопке Создать панели инструментов Стандартная.

Рис. 24.15. Добавление ссылки на новую страницу

  13. На появившейся пустой странице введите слова Домашняя страница, выделите их и щелкните на кнопке Гиперссылка панели инструментов Стандартная.

  14. В окне диалога настройки гиперссылки щелкните на значке файла index, htm, а затем на кнопке ОК. Полученная ссылка позволит пользователю после просмотра видеоклипа вернуться на домашнюю страницу.

  15. Нажмите клавишу Enter.

  16. Выберите команду Вставка > Рисунок > Видеоклип (Insert > Picture > Video).

  17. В окне диалога Video (Видеоклип) выберите любой файл с расширением AVI. Если на жестком диске не оказалось ни одного видеоклипа, получите такой файл через Интернет с какого-либо web-узла.

  18. Щелкните на кнопке Открыть.

  19. Выберите команду Файл > Сохранить. В открывшемся окне диалога введите имя video, htm и щелкните на кнопке Сохранить. В окне диалога Сохранение внедренных файлов щелкните на кнопке ОК.

  20. Закройте web-страницу с видеоклипом. На экране должна появиться страница с кадрами, ранее скрытая web-страницей с видеоклипом.

  21. Выберите в меню Файл (File) команду Просмотр в обозревателе.

Рис. 24.16. Web-страница с видеоклипом

  22. В открывшемся окне диалога щелкните на пункте Internet Explorer, а затем на кнопке Просмотр. Домашняя страница с кадрами откроется в окне браузера.

  23. Щелкните на ссылке Видеоклип. Вместо страницы с кадрами в том же окне появится web-страница с видеоклипом, который автоматически запустится на воспроизведение, как показано на рис. 24.16.

  24. Чтобы после просмотра видеоролика (или даже в процессе просмотра) вернуться на страницу с кадрами, щелкните на гиперссылке Домашняя страница.

Упражнение 9. Динамические эффекты

Во всех предыдущих упражнениях, за исключением последнего, вы строили статические web-страницы. Их содержимое не менялось в процессе просмотра. Frontpage позволяет создавать и динамические страницы, которые не просто отображают данные, но и реагируют на определенные действия пользователя, например на перемещение указателя мыши.

Рис. 24.17. Панель динамических эффектов

Чтобы наделить домашнюю страницу узла Frames новыми возможностями, выполните следующие шаги.

  1. Откройте web-узел Frames, перейдите в режим просмотра Страница и откройте в нем файл index, htm.

  2. Щелкните правой кнопкой мыши на любой панели инструментов и выберите в контекстном меню пункт Эффекты DHTML (DHTML Effects). Появится панель инструментов динамических эффектов, показанная на рис. 24.17.

  3. Щелчком выделите изображение тигра в верхнем кадре страницы.

  4. В раскрывающемся списке Выбор события (Choose An Event) выберите пункт Наведение мыши (Mouse Over).

  5. В списке Выбор эффекта (Choose An Effect) выберите пункт Замена рисунка (Swap Picture).

  6. В списке Настройка (Effect Settings) щелкните на пункте Выбор рисунка (Choose Picture). Откроется окно диалога Рисунок.

  7. В списке файлов найдите графический файл в формате GIF, например, созданный в упражнении 1 файл logo2.gif, содержащий Изображение коровы, (С:/Мои документы /MyWebs/Corporate/images/logo2.gif) и щелкните на кнопке Open (Открыть). Назначенный эффект будет инициировать смену изображения тигра на рисунок коровы в момент перемещения указателя на изображение. Когда пользователь уберет указатель в сторону, на странице вновь появится тигр.

Рис. 24.18. Настройка динамических эффектов

Теперь давайте добавим эффект, который будет воспроизводиться автоматически после загрузки web-страницы.

  8. Выделите в правом кадре фразу Товары компании Геркулес отличаются высоким качеством (рис. 24.18).

  9. В раскрывающемся списке Выбор события выберите пункт Загрузка страницы (Page Load).

  10. В раскрывающемся списке Выбор эффекта выберите пункт Падение по одному слову (Drop In By Word).

  11. Щелчком на кнопке Сохранить панели инструментов сохраните выполненные изменения.

  12. Чтобы протестировать добавленные эффекты, щелкните на корешке Просмотр. Сразу после загрузки страницы с кадрами строка, выделенная на шаге 8, отсутствует. Ее слова появляются позже, вылетая по очереди сверху.

  13. Переместите указатель мыши на изображение тигра. Оно сменится на рисунок коровы. Уберите указатель в сторону — тигр вернется на прежнее место. Такой прием смены изображения часто используется для подсвечивания рисунков с гиперссылками. Это помогает пользователю отличать рисунки, добавленные в качестве оформления, от тех, которые позволяют получить доступ к другим ресурсам Интернета.

Контрольное упражнение

Чтобы закрепить полученные знания, попробуйте самостоятельно построить еще один web-узел с кадрами.

  1. Создайте новый узел.

  2. Скопируйте в него файлы semces.htm, servOl.htm и serv02.htm из узла Corporate.

  3. Создайте новую страницу с двумя кадрами — основным и заголовком.

  4. Свяжите верхний кадр с новой web-страницей topframe.htm, а нижний — с имеющимся файлом services, htm.

    • Под каким именем следует сохранять основной HTML-файл, управляющий кадрами?

  5. Добавьте в верхний кадр текстовые ссылки на файлы, перечисленные на шаге 2 контрольного упражнения, организовав таким образом оглавление этого небольшого узла.

    • Как следует настраивать ссылки, чтобы страницы узла загружались в нижний кадр?

  6. Правее ссылок добавьте какое-нибудь изображение из библиотеки Clip Art.

  7. Добавьте к этому изображению такой динамический эффект, чтобы рисунок улетал вверх с кадра при щелчке на нем.

    • Какие параметры эффекта следует выбрать?

  8. Назначьте фоновый звук странице serv0l.htm.

  9. Сохраните новый web-узел и закройте Frontpage.

Подведение итогов

Это занятие является завершающим. Если вы внимательно изучили все предложенные упражнения, значит, вы получили достаточные навыки работы со всеми шестью приложениями пакета Microsoft Office XP. К сожалению, не слишком большой объем книги не позволил в полной мере раскрыть все приемы работы и подробно описать многочисленные инструменты Office. Попробуйте самостоятельно изучить компоненты, не вошедшие в книгу. Не бойтесь экспериментов. Приложения Office XP имеют дружественный интерфейс и прекрасную справочную систему, которые в трудной ситуации придут вам на помощь.

Для более детального изучения описанных приложений обратитесь к книгам серии «Самоучитель» издательства «Питер», посвященным конкретным приложениям из пакета Microsoft Office XP.


Занятие №24

Усовершенствование web-страниц

ТЕМА ЗАНЯТИЯ

На двух предыдущих занятиях были рассмотрены вопросы построения схемы web-узла и разработки содержания его страниц. Теперь вы познакомитесь с некоторыми специальными объектами и способами оформления страниц, повышающими их привлекательность. В упражнениях этого занятия изучаются следующие темы:

  • компоненты Frontpage;

  • изображение по расписанию;

  • дата и время:

  • бегущая строка;

  • кадры;

  • звук;

  • видеоклип;

  • динамические эффекты.


Компоненты FrontPage

Кроме стандартных приемов форматирования web-страниц, основанных на возможностях языка HTML, Frontpage предлагает набор средств, которые называют компонентами Frontpage. С их помощью можно улучшить оформление узла и расширить его функциональные возможности. Имейте в виду, что дополнительные функции могут не поддерживаться некоторыми браузерами, поэтому, применяя расширения компании Microsoft, обратите особое внимание на проверку работоспособности web-страниц в различных браузерах. Желательно протестировать web-узел на разных компьютерных платформах. Компоненты Frontpage добавляются в web-страницу с помощью команд подменю Вставка > Веб-компонент (Insert > Web Component). Описание некоторых компонентов Frontpage приведено в табл. 24.1.

ТАБЛИЦА 24.1. Компоненты Frontpage
Название | Описание
Примечание(Comment) | Позволяет вводить в web-страницу комментарии. Они будут видны в процессе разработки, но удаленный пользователь их не увидит. Этот компонент удобен для документирования web-узлов
Поле подтверждения(Confirmation Field) | Используется для подтверждения введенных данных, например в форме web-страницы
Страница(Included Page) | Позволяет заменить содержимое текущей web- страницы другой web-страницей
Страница по расписанию (Included Page Based on Schedule) | Дает возможность включить в web-страницу некоторый файл на строго определенное время. По прошествии заданного интервала времени файл не будет отображаться на странице. Этот компонент полезен, например, для вывода сообщений о скидках, действительных только на определенный период
Рисунок с расписанием(Included Picture Based on Schedule) | Позволяет выводить изображение на web- странице в течение заданного интервала времени. По прошествии этого периода изображение появляться не будет :
Поиск в Интернете | Добавляет в web-узел форму процедуры поиска (Search Form) заданного текста
Подстановка (Substitution) | В процессе выполнения этот компонент заменяется значением определенного параметра или системной переменной окружения
Оглавление(Table Of Contents) | Формирует на web-странице оглавление узла, созданного во Frontpage. Это оглавление будет автоматически обновляться при изменении содержимого web-узла

Название | Описание
Дата и время (Date And Time) | В процессе работы на месте этого компонента будут выводиться дата и время
Счетчик посещений (Hit Counter) | Форма, производящая подсчет количества посетителей web-узла
Объявление на странице... (Page Banner) | Добавляет на каждую страницу web-узла один и тот же баннер
Быстрая строка (Marquee) | Выводит текст в виде бегущей строки, параметры которой можно менять в широких пределах

Примечание

Большинство перечисленных компонентов становится доступным из окна диалога Вставка компонента веб-узла (Insert Web Component), возникающем на экране при команде Вставка > Веб-компонент.


Упражнение 1. Изображение по расписанию

На предыдущем занятии вы добавили на web-страницу Трубы изображение тигра. Давайте воспользуемся компонентом Frontpage, чтобы обеспечить автоматическую замену этого рисунка другим на определенный интервал времени. Для этого выполните следующие шаги.

  1. Откройте в приложении Frontpage узел Corporate.

  2. Выведите содержимое страницы Трубы (файл prodOl.htm) в режиме просмотра Страница.

  3. Поместите курсор правее изображения тигра.

  4. Выберите команду Вставить > Рисунок ^ Картинки (Insert > Picture > Clip Art).

  5. В текстовое поле в области задач приложения введите слово Animаls (Животные), затем щелкните на кнопке Найти. Поставьте указатель мыши на рисунок коровы и выберите в контекстном меню команду Вставить (Insert). На web-странице появится второе изображение, как показано на рис. 24.1.

  6. Щелчком на кнопке Сохранить панели инструментов Стандартная сохраните новый вариант страницы.

  7. В открывшемся окне диалога Сохранение внедренных файлов щелкните на кнопке Переименовать, введите имя logo2 . gi f и щелкните на кнопке ОК.

  8. Выделите изображение коровы и нажатием клавиши Delete удалите его. Выполненные шаги 3-8 никак не изменили web-страницу. Они необходимы, чтобы преобразовать векторный рисунок библиотеки Clip Art в растровое изображение формата GIF. Если у вас есть два заранее подготовленных файла формата GIF с соответствующими рисунками, эти шаги можно опустить.

  9. Щелчком выделите изображение тигра.

  10. Выберите команду Вставка > Веб-компонент. В появившемся окне диалога Вставка компонента Веб-узла выделите в списке Тип компонента: (Component Type.) пункт Включенное содержимое (Included Content:) и в списке Выбеоите тип содержимого: (Choose a type of Content) дважды щелкните ТнктеРигу иок с расписанием (Picture Based on Schedule), как показано на ST

Рис. 24.1 . Добавление изображения по расписанию

  11. В окне диалога Свойства рисунка с расписанием (Scheduled Picture Prooertie> показанном на рис. 24.2, щелкните на верхней кнопке Обзор propert1es)

Рис. 24.2. Расписание вывода изображений

  12. Выберите в появившемся списке файл logo2.gif и щелкните на кнопке ОК.

  13. Щелкните на нижней кнопке Обзор.

  14. Выберите файл logo.gif и щелкните на кнопке ОК.

  15. С помощью раскрывающихся списков группы Окончание (Ending) установи те дату, отстоящую вперед от текущей примерно на два месяца.

  16. Щелкните на кнопке ОК.

Настроенный режим вывода изображений инициирует демонстрацию на web-странице файла logo2.gif (корова) в течение двух месяцев. До и после этого интервала времени на странице будет появляться файл logo.gif (тигр). Давайте проверим работу этого изменчивого изображения в окне браузера.

Рис. 24.3. Смена системного времени

  17. Выберите команду Файл > Просмотр в обозревателе. В качестве логотипа в окне Internet Explorer появится изображение коровы.

  18. Дважды щелкните на часах Панели задач Windows.

  19. В окне диалога настройки времени, показанном на рис. 24.3, увеличьте на 1 номер года.

  20. Щелкните на кнопке ОК.

  21. В окне Frontpage щелкните на кнопке Сохранить, чтобы обновить дату страницы.

  22. Переключитесь в окно Internet Explorer и нажмите клавишу F5, чтобы обновить документ. Теперь на страницу вернулось изображение тигра, так как новая дата не попадает во временной интервал компонента Рисунок с расписанием.

  23. Закройте окно браузера.

Примечание

Окончив эксперименты, не забудьте восстановить правильную системную дату.


Упражнение 2. Время и комментарии

Чтобы познакомиться с компонентом Frontpage, называющимся Дата и время (Date And Time), выполните следующие шаги.

  1. С помощью полосы прокрутки перейдите в самый низ страницы Трубы.

Рис. 24.4. Компонент даты и времени

  2. Последняя строка страницы содержит надпись Дата изменения (Last modified) и дату, соответствующую моменту последнего сохранения данной web-страницы (рис. 24.4). Этот компонент Дата и время был автоматически добавлен мастером при создании узла Corporate на занятии 22. Давайте скорректируем свойства компонента.

Примечание

Чтобы самостоятельно добавить компонент Дата и время, воспользуйтесь соответствующей командой Вставка > Дата и время (Insert > Date And Time).

  3. Щелкните на дате правой кнопкой мыши и выберите команду Свойства даты и времени (Date And Time Properties).

  4. В открывшемся окне диалога, показанном на рис. 24.5, выберите положение Дату последнего автоматического обновления страницы (Date This Page Was Last Automatically Update) переключателя Отображать (Display). Этот вариант задания даты чрезвычайно удобен, но он работает только при использовании расширений модуля Personal Web Server компании Microsoft.

  5. В раскрывающемся списке Формат даты (Date Format) выберите подходящий вариант вывода даты.

  6. Чтобы добавить индикатор времени, выберите один из пунктов раскрывающегося списка Time Format (Формат времени).

  7. Щелкните на кнопке ОК. Поскольку для нормальной работы модифицированного компонента требуется Personal Web Server, следует вставить соответствующий комментарий, который не виден удаленному пользователю, но появляется перед разработчиком узла в окне Frontpage.

  8. Щелкните в начале строки Дата изменения и выберите команду Вставка > Примечание (Insert > Comment).

  9. В открывшемся окне диалога введите текст Внимание ! Данный компонент даты и времени работает только под управлением Personal Web Server.

  10. Щелкните на кнопке ОК.

  11. Нажмите клавишу Enter.

Рис. 24.5. Параметры даты и времени

Рис. 24.6. Страница с комментарием :

  12. Замените текст Дата изменения на вариант Дата последнего обновления. Теперь страница будет выглядеть так, как показано на рис. 24.6.

  13. Щелкните на корешке Просмотр. Обратите внимание, что в этом режиме (так же, как и в окне браузера) комментарий не виден.


Упражнение 3. Бегущая строка

С помощью бегущей строки можно выделить определенный текст и привлечь к нему внимание удаленного пользователя. Этот компонент поддерживается не всеми браузерами, а только теми, которые совместимы с расширениями компании Microsoft. В других программах символы бегущей строки будут отображаться в виде статического текста. Чтобы сделать имеющийся текстовый фрагмент бегущей строкой, выполните следующие шаги:

  1. Выделите строку Низкие цены, постоянным клиентам скидки, щелкнув мышью слева от нее.

  2. Щелкните в панели инструментов Стандартная на кнопке Веб-компонент (Web Component) и выделите в появившемся окне диалога Вставка компонента веб-узла пункт Динамические эффекты (Dynamic Effects). В правой части окна диалога дважды щелкните на пункте Быстрая строка (Marquee).

  3. В открывшемся окне диалога (рис. 24.7) выберите положение Влево (Left) переключателя Направление (Direction), чтобы выбрать направление движения строки.

Рис. 24.7. Свойства бегущей строки

  4. Сбросьте флажок Постоянно (Continuously).

  5. Введите в счетчик раздела Повторы (Repeat) число 3.

  6. При необходимости измените другие параметры, после чего щелкните на кнопке ОК.

  7. Щелкните на вкладке Просмотр. Текст бегущей строки будет двигаться в окне справа налево. После того как вся строка три раза пересечет web-страницу, ее текст исчезнет и больше не появится. Для повторения эффекта придется перезагрузить страницу в режиме предварительного просмотра или в окне браузера.

  8. Закройте web-узел командой Файл > Закрыть веб-узел.


Кадры

Кадры позволяют разбивать окно браузера на несколько прямоугольных областей, в каждой из которых будет демонстрироваться отдельная web-страница. Наличие кадров позволяет упростить перемещение по страницам узла. Обычно слева в отдельном кадре помещают оглавление web-узла, которое доступно всегда, вне зависимости от того, какая страница находится в этот момент в основном кадре справа. В результате простым щелчком в левом кадре пользователь может быстро загрузить в основную область браузера необходимую информацию.


Упражнение 4. Страница с кадрами

Для создания страниц с кадрами во Frontpage имеется специальный мастер, избавляющий вас от необходимости изучать специальные теги. Кроме того, этот мастер позаботится об организации альтернативного варианта просмотра страниц для-тех пользователей, браузеры которых не поддерживают кадры.

На двух предыдущих занятиях вы уже научились создавать web-страницы, поэтому сейчас не будут рассматриваться детали разработки конкретных страниц.

В качестве содержания нового узла можно воспользоваться страницами, созданными ранее для узла Corporate. Но навигация по этим страницам будет организована с помощью кадров.

  1. Выберите команду Файл > Создать > Страницу или веб-узел (File > New > Web or Page).

  2. В области задач в разделе Создание с помощью шаблона щелкните на значке Шаблоны веб-узлов (Web Site Templates).

  3. В поле Укажите расположение нового веб-узла (Specify The Location Of The New Web) открывшегося окна диалога введите путь папки узла и имя Frames.

  4. Дважды щелкните на значке Одностраничный веб-узел (One Page Web).

  5. Выберите в подменю Файл > Последние веб-узлы (File > Recent Webs) пункт Corporate, чтобы открыть узел, созданный на предыдущих занятиях.

  6. Щелкните на кнопке Папки (Folders) панели режимов.

  7. Нажмите клавишу Ctrl и, не отпуская ее, щелкайте на именах файлов, чтобы выделить группу страниц в соответствии с рис. 24.8.

  8. Щелкните на одном из выделенных файлов правой кнопкой мыши и выберите в контекстном меню команду Копировать (Copy).

  9. Закройте узел Corporate.

  10. В окне узла Frames выберите команду Вид > Папки (View > Folders), щелкните в области списка файлов правой кнопкой мыши и выберите команду Вставить. В результате этих операции часть страниц узла Corporate будет перенесена в узел Frames.

Рис. 24.8. Копирование web-страниц

  11. Щелкните на значке режима Страница.

  12. В области задач в разделе Создание с помощью шаблона щелкните на значке Шаблоны страниц... (Page Templates...).

  13. В окне диалога Шаблоны страниц (Page Templates) щелкните на вкладке Стра ница рамок (Frames Pages).

  14. Щелкните на значке Колонтитулы и оглавление (Header, Footer And Contents).

  15. Щелкните на кнопке ОК. В окне Frontpage появится страница с четырьмя пустыми кадрами и несколькими кнопками, позволяющими связывать кадры с определенными HTML-файлами.

  16. Чтобы создать файл кадра заголовка, щелкните на верхней кнопке Создать страницу (New Page).

  17. Щелкните на кнопке Сохранить панели инструментов Стандартная, введите в открывшемся окне диалога имя topframe. htm и щелкните на кнопке Сохранить. Теперь в верхний кадр будет выводиться содержимое страницы topframe. htm.

  18. Вслед за этим Frontpage попросит назначить имя главного файла, управляющего кадрами. Введите в окно диалога имя index, htm и щелкните на кнопке Сохранить.

Примечание

Файл index.htm обычно играет роль страницы, которая загружается в браузер по умолчанию после открытия web-узла. В новом узле эта роль отводится странице, управляющей кадрами.

  19. Щелкните на левой кнопке Создать страницу.

  20. Повторите шаг 17, введя для левого кадра имя leftframe. htm.

  21. Щелкните на нижней кнопке Создать стра н и цу и сохраните содержимое ниж него кадра в файле bottomframe.htm.

  22. Щелкните на единственной из оставшихся кнопок Задать начальную страницу (Set Initial Page).

  23. Выберите в списке файл products.htm и щелкните на кнопке ОК. В основном кадре сразу же появится содержимое этой страницы, которая была скопирована из узла Corporate.


Упражнение 5. Кадры заголовка и примечания

Пришло время наполнить содержанием верхний и нижний кадры. Для этого выполните следующие шаги.

  1. Щелкните в верхнем кадре.

  2. Выберите команду Вставка > Рисунок > Картинки....

Рис. 24.9. Параметры изображения

  3. В области задач в окне Вставка картинок (Clip Art) введите в текстовое роле слово Animals (Животные), затем щелкните на кнопке Найти; из появившегося набора изображений остановитесь на картинке с тигром и выберите в контекстном меню команду Вставить. В результате в верхнем кадре появится логотип компании.

  4. Чтобы настроить размеры логотипа, щелчком выделите его и нажмите клавиши Alt+Enter. Откроется окно диалога параметров изображения, показанное на рис. 24.9.

  5. Щелкните на вкладке Вид.

  6. Установите флажок Задать размер (Specify size).

  7. В счетчик Высота (Height) введите число 70.

  8. В раскрывающемся списке Выравнивание выберите пункт По центру.

  9. Щелкните на кнопке ОК.

  10. Чтобы рисунок был виден целиком, перетащите границу верхнего кадра немного вниз.

  11. Щелкните правее добавленного изображения и введите слово Геркулес.

  12. Выделите название компании и щелкните па кнопке Полужирный панели инструментов Форматирование.

  13. Чтобы увеличить шрифт, выберите в раскрывающемся списке Размер шрифта пункт 7 (36 pt).

Рис. 24.10. Содержание верхнего и нижнего кадров

  14. Щелкните в нижнем кадре и введите текст Подробную информацию о деятельности компании можно получить по адресу info@hercules.corn . В конце ввода этой строки нажмите клавишу Пробел, чтобы Frontpage автоматически связал с адресом электронной почты соответствующую гиперссылку.

  15. Перетащите границу нижнего кадра вниз, чтобы по возможности уменьшить его размеры. Теперь страница с кадрами будет выглядеть так, как показано на рис. 24.10.


Упражнение 6. Оглавление web-узла

Вам осталось сконструировать оглавление узла в левом кадре страницы и настроить соответствующие гиперссылки на страницы, которые должны демонстрироваться в основном (правом) кадре.

  1. Щелкните в левом кадре страницы.

  2. Введите слово Продукция и нажмите клавишу Enter.

  3. Затем введите слова Трубы, Панели и Гвозди, отделяя их друг от друга нажатиями клавиши Enter.

  4. Выделите четыре пункта левого кадра, протащив мышь слева от них.

  5. Щелкните на кнопке Маркеры панели инструментов Форматирование. Оглавление узла готово. Теперь нужно настроить гиперссылки.

  6. Выделите слово Продукция, щелкните на нем правой кнопкой мыши и выберите в контекстном меню команду Гиперссылка.

  7. В открывшемся окне диалога (рис. 24.11) из списка файлов выделите файл products.htm и щелкните на нем. При этом имя файла появится в текстовом поле Адрес:.

Рис. 24.11. Выбор рамки

Рис. 24.12. Параметры страницы рамок

  8. Щелкните на кнопке Выбор рамки (Target Frame).

  9. В разделе Текущая страница рамок (Current Frames Page) окна диалога Конечная рамка (Target Frame) щелкните на правом кадре/чтобы в поле Настройка объекта (Target Setting) появилось слово main. Это заставит браузер выводить файл, на который указывает гиперссылка, в правый кадр.

  10. Щелкните два раза на кнопке ОК.

  11. Повторяя шаги 6-10, назначьте словам Трубы, Панели и Гвозди соответственно ссылки на файлы prodOl.htm, prod02.htm и prod04.htm. He забывайте в качестве целевого выбирать правый кадр.

Обычно кадры используются для структурирования окна браузера, которое при этом должно выглядеть как одна страница с несколькими полями. По этой причине рамки, разделяющие кадры, как правило делают невидимыми.

Рис. 24.13. Страница с кадрами

Чтобы скрыть рамки, выполните следующие шаги.

  12. Щелкните в области страницы с кадрами правой кнопкой мыши и выберите в контекстном меню команду Свойства рамки (Frame Properties).

  13. В открывшемся окне диалога щелкните на кнопке Страница рамок (Frames Page). Эта операция откроет другое окно диалога, показанное на рис. 24.12.

  14. Раскройте вкладку Рамки (Frames).

  15. Сбросьте флажок Показать границы (Show Borders).

  16. Два раза щелкните на кнопках ОК. Теперь страница станет такой, как показано на рис. 24.15. Эта операция завершает создание структуры web-узла с кадрами. Вам остается наполнить содержанием страницы prod0l.htm, prod02.htm и prod04.htm. Сделайте это самостоятельно, открывая файлы в режиме просмотра Страница. При желании измените фон страниц и форматирование текста. Можете добавить несколько картинок или еще как-нибудь приукрасить web-узел.

  17. Чтобы познакомиться с поведением узла с кадрами и проверить действие гиперссылок, щелкните на корешке Просмотр. *

  18. Щелкните на слове Трубы. В основном окне появится содержимое страницы Трубы, а остальные три кадра останутся без изменения, дв;

Примечание

Рисунок и графические маркеры страницы Трубы будут отображаться в виде пустых прямоугольников, так как соответствующие файлы формата GIF не были скопированы в узел Frames. Чтобы изображения появлялись на своих местах, в Проводнике скопируйте папку images из узла Corporate в узел Frames.

  19. Щелкните на ссылке Гвозди. Соответствующая страница длинная и не влезает в основной кадр целиком, поэтому в ее правой части появится полоса прокрутки. Попробуйте с помощью этой полосы просмотреть всю страницу. Вы увидите, что прокручивается только область правого кадра, в то время как остальные кадры остаются на прежних местах. Таким образом, страница с кадрами позволяет, с одной стороны, обеспечить постоянный доступ к важным элементам узла, таким как гиперссылки оглавления, заголовок узла или адрес компании, а с другой — просматривать в одном из кадров достаточно большие документы.


Мультимедийные эффекты

Все web-страницы, рассматривавшиеся в предыдущих упражнениях книги, были статическими. В них можно просматривать имеющееся содержание и с помощью щелчков на гиперссылках загружать другие страницы узла. В настоящее время наблюдается бурное развитие мультимедийных технологий, они не обошли и Интернет. Frontpage в полной мере поддерживает возможности размещения на web-страницах мультимедийных объектов и настройки динамических эффектов, являющихся реакцией на определенные действия пользователя.


Упражнение 7. Фоновый звук

В упражнении 4 предыдущего занятия рассказывалось, как добавлять гиперссылки на другие web-страницы. Можно с помощью аналогичных ссылок адресовать и звуковые файлы. При щелчке на такой ссылке браузер загрузит с удаленного сервера звуковой файл и проиграет его. Кроме того, любой странице можно назначить фоновый звук, который будет воспроизводиться при открытии НТМL-файла.

Примечание

Воспроизводить звуковые файлы можно только на мультимедийном компьютере, в котором установлена звуковая карта с подключенными громкоговорителями или наушниками.

Чтобы добавить на web-страницу Трубы звуковой файл, выполните следующие шаги.

  1. Откройте файл prodOl.htm узла Corporate в режиме Страница.

  2. Введите в конец страницы предложение Наши медные трубы могут издавать музыкальные звуки, вы слышали их при открытии этой страницы.

  3. Выберите команду Файл > Свойства (File > Properties).

Рис. 24.14. Выбор звукового файла

  4. На вкладке Общие (рис. 24.14) щелкните на кнопке Обзор, расположенной в разделе Фоновый звук (Background Sound).

  5. В открывшемся окне диалога найдите папку, в которую был установлен пакет Office XP, откройте вложенную в нее папку Office10 и выберите файл reminder.wav. Щелкните на кнопке Открыть.

  6. Затем закройте окно свойств, щелкнув на кнопке ОК.

  7. Выберите команду Файл > Сохранить. В появившемся окне диалога Сохранение внедренных файлов щелкните на кнопке ОК.

  8. Чтобы прослушать звуковое сопровождение, щелкните на вкладке Просмотр. Сразу же после загрузки страницы вы услышите периодически повторяющийся звук файла reminder.wav.


Упражнение 8. Видеоклип

Frontpage позволяет размещать на web-страницах не только звуки, но и видеоклипы. В этом упражнении в кадр содержания узла Frames будет добавлена гиперссылка на страницу с видеоклипом.

  1. Чтобы открыть узел Frames, выберите команду Файл > Открыть веб-узел. С помощью раскрывающегося списка Папка и списка файлов окна диалога Открытие веб-узла (Open Web) найдите папку Frames. Раскройте ее двойным щелчком на соответствующем значке. Затем щелкните на кнопке Открыть.

  2. В панели режимов щелкните на значке Папки.

  3. В списке файлов узла дважды щелкните на значке index, htm, чтобы открыть в режиме Страница (Page) основную страницу с кадрами.

  4. Щелкните в левом кадре справа от ссылки Гвозди и нажмите клавишу Enter.

  5. Введите слово Видеоклип и, чтобы выделить его, нажмите клавиши Shift+Ctrl+<-.

  6. Щелкните на выделенном слове правой кнопкой мыши и выберите команду Hyperlink.

  7. В открывшемся окне диалога (рис. 24.15) в поле Адрес: введите имя video. htm.

  8. Щелкните на кнопке Выбор рамки..

  9. В открывшемся окне диалога в списке Общие объекты выделите пункт Страница целиком (Whole Page). Такая настройка целевого кадра заставит страницу с видеоклипом заменить страницу с кадрами, освободив видеоклипу по возможности большее пространство окна браузера.

  10. Два раза щелкните на кнопке ОК.

  11. Чтобы сохранить новый вариант домашней страницы, щелкните на кнопке Сохранить панели инструментов Стандартная. Гиперссылка на видеоклип готова. Теперь для его демонстрации нужно создать саму web-страницу.

  12. Щелкните на кнопке Создать панели инструментов Стандартная.

Рис. 24.15. Добавление ссылки на новую страницу

  13. На появившейся пустой странице введите слова Домашняя страница, выделите их и щелкните на кнопке Гиперссылка панели инструментов Стандартная.

  14. В окне диалога настройки гиперссылки щелкните на значке файла index, htm, а затем на кнопке ОК. Полученная ссылка позволит пользователю после просмотра видеоклипа вернуться на домашнюю страницу.

  15. Нажмите клавишу Enter.

  16. Выберите команду Вставка > Рисунок > Видеоклип (Insert > Picture > Video).

  17. В окне диалога Video (Видеоклип) выберите любой файл с расширением AVI. Если на жестком диске не оказалось ни одного видеоклипа, получите такой файл через Интернет с какого-либо web-узла.

  18. Щелкните на кнопке Открыть.

  19. Выберите команду Файл > Сохранить. В открывшемся окне диалога введите имя video, htm и щелкните на кнопке Сохранить. В окне диалога Сохранение внедренных файлов щелкните на кнопке ОК.

  20. Закройте web-страницу с видеоклипом. На экране должна появиться страница с кадрами, ранее скрытая web-страницей с видеоклипом.

  21. Выберите в меню Файл (File) команду Просмотр в обозревателе.

Рис. 24.16. Web-страница с видеоклипом

  22. В открывшемся окне диалога щелкните на пункте Internet Explorer, а затем на кнопке Просмотр. Домашняя страница с кадрами откроется в окне браузера.

  23. Щелкните на ссылке Видеоклип. Вместо страницы с кадрами в том же окне появится web-страница с видеоклипом, который автоматически запустится на воспроизведение, как показано на рис. 24.16.

  24. Чтобы после просмотра видеоролика (или даже в процессе просмотра) вернуться на страницу с кадрами, щелкните на гиперссылке Домашняя страница.


Упражнение 9. Динамические эффекты

Во всех предыдущих упражнениях, за исключением последнего, вы строили статические web-страницы. Их содержимое не менялось в процессе просмотра. Frontpage позволяет создавать и динамические страницы, которые не просто отображают данные, но и реагируют на определенные действия пользователя, например на перемещение указателя мыши.

Рис. 24.17. Панель динамических эффектов

Чтобы наделить домашнюю страницу узла Frames новыми возможностями, выполните следующие шаги.

  1. Откройте web-узел Frames, перейдите в режим просмотра Страница и откройте в нем файл index, htm.

  2. Щелкните правой кнопкой мыши на любой панели инструментов и выберите в контекстном меню пункт Эффекты DHTML (DHTML Effects). Появится панель инструментов динамических эффектов, показанная на рис. 24.17.

  3. Щелчком выделите изображение тигра в верхнем кадре страницы.

  4. В раскрывающемся списке Выбор события (Choose An Event) выберите пункт Наведение мыши (Mouse Over).

  5. В списке Выбор эффекта (Choose An Effect) выберите пункт Замена рисунка (Swap Picture).

  6. В списке Настройка (Effect Settings) щелкните на пункте Выбор рисунка (Choose Picture). Откроется окно диалога Рисунок.

  7. В списке файлов найдите графический файл в формате GIF, например, созданный в упражнении 1 файл logo2.gif, содержащий Изображение коровы, (С:/Мои документы /MyWebs/Corporate/images/logo2.gif) и щелкните на кнопке Open (Открыть). Назначенный эффект будет инициировать смену изображения тигра на рисунок коровы в момент перемещения указателя на изображение. Когда пользователь уберет указатель в сторону, на странице вновь появится тигр.

Рис. 24.18. Настройка динамических эффектов

Теперь давайте добавим эффект, который будет воспроизводиться автоматически после загрузки web-страницы.

  8. Выделите в правом кадре фразу Товары компании Геркулес отличаются высоким качеством (рис. 24.18).

  9. В раскрывающемся списке Выбор события выберите пункт Загрузка страницы (Page Load).

  10. В раскрывающемся списке Выбор эффекта выберите пункт Падение по одному слову (Drop In By Word).

  11. Щелчком на кнопке Сохранить панели инструментов сохраните выполненные изменения.

  12. Чтобы протестировать добавленные эффекты, щелкните на корешке Просмотр. Сразу после загрузки страницы с кадрами строка, выделенная на шаге 8, отсутствует. Ее слова появляются позже, вылетая по очереди сверху.

  13. Переместите указатель мыши на изображение тигра. Оно сменится на рисунок коровы. Уберите указатель в сторону — тигр вернется на прежнее место. Такой прием смены изображения часто используется для подсвечивания рисунков с гиперссылками. Это помогает пользователю отличать рисунки, добавленные в качестве оформления, от тех, которые позволяют получить доступ к другим ресурсам Интернета.


Контрольное упражнение

Чтобы закрепить полученные знания, попробуйте самостоятельно построить еще один web-узел с кадрами.

  1. Создайте новый узел.

  2. Скопируйте в него файлы semces.htm, servOl.htm и serv02.htm из узла Corporate.

  3. Создайте новую страницу с двумя кадрами — основным и заголовком.

  4. Свяжите верхний кадр с новой web-страницей topframe.htm, а нижний — с имеющимся файлом services, htm.

    • Под каким именем следует сохранять основной HTML-файл, управляющий кадрами?

  5. Добавьте в верхний кадр текстовые ссылки на файлы, перечисленные на шаге 2 контрольного упражнения, организовав таким образом оглавление этого небольшого узла.

    • Как следует настраивать ссылки, чтобы страницы узла загружались в нижний кадр?

  6. Правее ссылок добавьте какое-нибудь изображение из библиотеки Clip Art.

  7. Добавьте к этому изображению такой динамический эффект, чтобы рисунок улетал вверх с кадра при щелчке на нем.

    • Какие параметры эффекта следует выбрать?

  8. Назначьте фоновый звук странице serv0l.htm.

  9. Сохраните новый web-узел и закройте Frontpage.


Подведение итогов

Это занятие является завершающим. Если вы внимательно изучили все предложенные упражнения, значит, вы получили достаточные навыки работы со всеми шестью приложениями пакета Microsoft Office XP. К сожалению, не слишком большой объем книги не позволил в полной мере раскрыть все приемы работы и подробно описать многочисленные инструменты Office. Попробуйте самостоятельно изучить компоненты, не вошедшие в книгу. Не бойтесь экспериментов. Приложения Office XP имеют дружественный интерфейс и прекрасную справочную систему, которые в трудной ситуации придут вам на помощь.

Для более детального изучения описанных приложений обратитесь к книгам серии «Самоучитель» издательства «Питер», посвященным конкретным приложениям из пакета Microsoft Office XP.


Занятие №3

Взаимодействие с операционной системой

ТЕМА ЗАНЯТИЯ

Операционная система — важная часть программного обеспечения компьютера. Она обеспечивает грамотное взаимодействие программ между собой и с имеющимся оборудованием. Именно операционная система Windows предоставляет программам стандартный оконный интерфейс и общие правила работы с документами, значками, шрифтами и принтерами. На этом занятии обсуждаются некоторые полезные приемы работы с основными компонентами операционной системы Windows, к которым относятся:

  • рабочий стол;

  • папки с документами;

  • Панель задач;

  • главное меню;

  • диспетчер печати.

Все приложения пакета Microsoft Office XP работают только в Windows 95, Windows 98 или Windows NT. Поскольку часть функций программ (к которым относятся вопросы взаимодействия приложений, доступа к дискам и принтерам, а также многие другие) неразрывно связана с операционной системой, для полноценного использования всех возможностей Office XP необходимо хорошо знать основные системные компоненты Windows. К сожалению, в эту книгу невозможно вместить полное описание Windows. Чтобы изучить всю мощь современной операционной оболочки компании Microsoft, обратитесь к книге К. Стинсона, К. Зихерта «Эффективная работа в Windows 2000 Professional» издательства «Питер», выпущенной в 2001 году.

Рабочий стол Windows

После запуска компьютера на экране появляется рабочий стол с набором значков. Это ярлыки документов и программ либо сами документы. Каждая программа запускается в отдельном окне, которое размещается на рабочем столе Windows — основной сцене всех действий.

Упражнение 1. Значки рабочего стола

Объекты рабочего стола оказываются под рукой сразу после загрузки Windows. Вам не приходится искать их по всему дереву файлов жесткого диска. Поэтому на рабочем столе обычно размещаются те ярлыки, файлы и папки, которыми пользуются чаще всего. Ярлыки — это маленькие файлы, содержащие ссылку на документ или программу. Они обеспечивают быстрый доступ к объекту. Любой файл может иметь сколь угодно много ярлыков, которые размещаются в папках компьютера, на рабочем столе или в Главном меню. Таким образом, доступ к конкретному документу возможен сразу из нескольких мест графического интерфейса.

  1. Программа установки Office XP добавляет на рабочий стол ярлык Microsoft Outlook, предполагая, что вы будете пользоваться этим прекрасным приложением для организации своих дел и чтения электронных писем. Дважды щелкните на указанном значке. Откроется Outlook.

  2. Вам понравился такой способ запуска приложений? Переместите указатель мыши в левый нижний угол рабочего стола и щелкните на кнопке Пуск (Start).

  3. Укажите на пункт Программы (Programs), а затем в раскрывшемся подменю на пункт Microsoft Word.

  4. Нажмите правую кнопку мыши и перетащите ярлык Microsoft Word на пустое пространство рабочего стола.

Примечание

Если рабочий стол оказался скрыт окнами приложений, щелкните на значке Свернуть все окна (Minimize All) Панели задач. Все открытые окна свернутся на Панель задач. Чтобы восстановить окна в их прежней конфигурации, достаточно повторно щелкнуть на этом значке.

Рис. 3.1. Рабочий стол Windows

  5. При отпускании кнопки мыши раскроется контекстное меню, показанное на рис. 3.1. Выберите в нем пункт Копировать (Copy Here). На рабочем столе появится копия ярлыка.

  6. Щелкните на новом значке Microsoft Word правой кнопкой мыши. Раскроется контекстное меню ярлыка, показанное на рис. 3.2.

Рис. 3.2. Контекстное меню ярлыка

Команды контекстного меню позволяют выполнять с ярлыком все операции, обычные для любого объекта Windows. Вы можете вырезать, скопировать, удалить или переименовать ярлык, открыть объект, на который ссылается ярлык, или открыть окно свойств ярлыка.

Примечание

Удаляя ярлык, вы никак не влияете на сам объект. Это абсолютно безболезненная операция, не затрагивающая файл, на который ссылается ярлык.

  7. Дважды щелкните на новом ярлыке. Запустится Microsoft Word.

  8. Введите в новом документе какой-либо текст и выберите команду Файл > Сохранить (File > Save).

  9. В левой панели окна диалога Сохранение документа (Save As) щелкните на кнопке Рабочий стол (Desktop). Затем введите имя файла Текст . doc и щелкните на кнопке Сохранить (Save).

  10. Закройте Word и все остальные окна приложений. Новый документ Word разместится прямо на рабочем столе компьютера.

Примечание

Значок Teкст.doc — это не ярлык, а сам документ, поэтому его перемещение в другую папку приведет к переносу самого документа, а удаление повлечет потерю данных. Чтобы отличить ярлык от документа или исполняемого файла, обратите внимание на значок ярлыка. В его левом нижнем углу всегда имеется небольшая стрелка (см. рис. 3.2).

Упражнение 2. Документы на рабочем столе

Рабочий стол Windows предлагает множество разных способов работы с документами.

  1. Укажите на значок Teкст.doc. Нажмите левую кнопку мыши и перетащите выбранный документ на значок Microsoft Word, как показано на рис. 3.3. Запустится программа Word, и файл Текет.doc будет автоматически открыт.

  2. Выделите в открывшемся документе Word любой фрагмент текста и нажмите клавиши Ctrl+C. Выделенный текст скопируется в буфер обмена Windows. Закройте Word.

  3. Щелкните на рабочем столе правой кнопкой мыши и выберите в контекстном меню команду Вставить (Paste). На рабочем столе появится значок фрагмента документа, являющийся самостоятельным файлом.

  4. Запустите Word и введите в нем произвольный текст.

  5. Если окно Word развернуто до максимального размера, щелкните в его заголовке на кнопке восстановления размеров.

Примечание

Описанный прием позволяет открывать документы нестандартных для данного приложения типов. Например, двойной щелчок на файле с расширением txt приводит к его открытию в программе Блокнот (Notepad). Но если перетащить значок этого файла на значок Microsoft Word, документ будет открыт в приложении Word.

Рис. 3.3. Открытие документа

  6. Переместите окно так, чтобы оно не закрывало значок фрагмента. При необходимости измените размер окна.

  7. Перетащите фрагмент с рабочего стола в документ Word, как показано на рис. 3.4. Содержимое фрагмента добавится в текст Word в точке отпускания кнопки мыши.

P ис. 3.4. Добавление фрагмента в документ Word

Фрагмент — это обычный файл на жестком диске. Таких файлов может быть сколь угодно много. С их помощью можно организовать подобие буфера обмена Windows с любым количеством фрагментов, хранящихся на .рабочем столе или в другой папке компьютера. По мере необходимости их можно вставлять в документы приложений. Фрагмент может содержать не только текст Word, а объект любой программы, поддерживающей технологию переноса объектов между приложениями.

Примечание

В Office XP имеется встроенный буфер обмена, позволяющий хранить одновременно несколько фрагментов и пользоваться ими во всех приложениях Office. Этот инструмент подробно рассматривается на следующем занятии.

На рабочем столе всегда присутствует значок Корзина (Recycle Bin). После удаления документа с помощью инструментов Windows или в любом 32-разрядном приложении (к которым относятся все модули Office XP) он не исчезает бесследно, а попадает в Корзину. Это позволяет избежать неприятных последствий в случае ошибок.

Примечание

В Корзину не попадают файлы, удаленные 16-разрядными приложениями Windows или программами DOS. Старайтесь пользоваться только 32-разрядными приложениями, которые поддерживают все нововведения Windows, включая Корзину и длинные имена файлов.

  8. Щелкните на значке Текст.с1ос правой кнопкой мыши и выберите в контекстном меню команду Удалить (Delete). Документ исчезнет с рабочего стола.

  9. Чтобы восстановить стертый файл, щелкните на значке Корзина (Recycle Bin). Откроется окно диалога, показанное на рис. 3.5.

  10. Найдите значок документа Текст.с1ос и щелкните на нем правой кнопкой мыши.

Рис. 3.5. Окно Корзины

Выберите в контекстном меню команду Восстановить (Recover). Удаленный документ вновь появится на прежнем месте.

Примечание

Объем Корзины не безграничен. Если вы случайно удалили важный файл, восстановите его как можно скорее. Когда Корзина переполняется, первыми из нее исчезают файлы, удаленные раньше других.

Папки Windows

Открывая документы из окон приложений или с помощью значков рабочего стола, важно понимать, что на самом деле все документы представляют собой файлы — поименованные информационные блоки, расположенные в иерархической структуре папок или каталогов жестких дисков компьютера или на сетевых дисках.

Упражнение 3. Мой компьютер

Чтобы разобраться, где находятся ваши документы, выполните следующие операции.

  1. Дважды щелкните на значке Мой компьютер (My Computer) рабочего стола. Откроется окно, в котором расположены значки всех локальных дисков, подключенных сетевых дисков и системных папок Windows (рис. 3.6). Мой компьютер (My Computer) — это главная папка компьютера, в которой размещены все остальные папки с документами, ярлыками, приложениями и служебными файлами.

  2. Дважды щелкните на значке диска С:. Откроется окно этого диска.

Рис. 3.6. Окно Мой компьютер

Примечание

Если на компьютере установлена одна из последних версий Windows, возможно, что для выделения значка будет достаточно просто переместить на него указатель мыши, а активизация значка будет выполняться одинарным, а не двойным щелчком. Стиль поведения системы можно настроить в окне диалога, которое открывается выбором команды Вид > Свойства папки (View > Folder Options). Мне больше нравится стандартный стиль работы с мышью, поэтому в книге предполагается, что объекты выделяются щелчком и активизируются двойным щелчком.

  3. Найдите папку Windows и дважды щелкните на ней. Откроется окно этой папки, содержащей служебные папки и файлы операционной системы.

  4. В окне Windows дважды щелкните на папке Рабочий стол (Desktop). Появится окно, показанное в правом нижнем углу рис. 3.7. Сравните его содержимое с рабочим столом, и вы поймете, что значки и документы рабочего стола на самом деле хранятся в одной из папок диска С:. Здесь можно найти и документ Teкст.doc. Двойным щелчком на его значке в окне папки можно запустить Word и открыть этот документ. Папки операционной системы образуют иерархическую структуру вложенных друг в друга объектов, в корне которой находится папка Мой компьютер (My Computer).

Рис. 3.7. Папки операционной системы Windows

Перемещаясь по папкам, можно найти любой файл. Последовательное перечисление имен папок, в которые вложен файл, называется полным путем к файлу. Файлы и папки можно перемещать и копировать между окнами папок с помощью технологии перетаскивания или посредством контекстных меню, раскрывающихся правой кнопкой мыши. Некоторые папки операционной системы имеют особое назначение. Часть из них доступна в Главном меню.

  5. Щелкните на кнопке Пуск (Start) Панели задач.

  6. Переместите указатель мыши на папку Документы (Documents). Раскроется подменю, показанное на рис. 3.8. Здесь находятся ярлыки тех документов, с которыми вы недавно работали.

Примечание

Чтобы получить доступ к файлам папки Мои документы (My Documents), переместите указатель на одноименный пункт подменю Документы (Documents). Разработчики Windows предполагают, что в этой папке должны храниться ваши рабочие файлы.

  7. Для продолжения работы с недавно открывавшимся документом (например, с файлом Текст.аос) найдите его название в подменю Документы (Documents) и щелкните на нем.

  8. Снова щелкните на кнопке Пуск (Start) и переместите указатель на пункт Избранное (Favorites). Вы увидите содержимое личной папки, в которой хранятся часто открываемые документы. Эта же папка обеспечивает доступ к каналам и ссылкам Internet Explorer. Личная папка удобна потому, что во многих окнах диалога она открывается щелчком на специальной кнопке и ее не нужно долго искать в иерархической структуре папок,

Рис. 3.8. Меню Документы

Упражнение 4. Управление папками из Office

Описание операций управления файлами с помощью инструментов Windows выходит за рамки этой книги. Чтобы освоить все тонкости этой операционной системы, обратитесь к книге Б. Богумирского «Энциклопедия Windows 98» («Питер», 1999). Наиболее полезной книгой по Windows Millenium Edition является бестселлер А. Денисова, А. Белова, И. Вихарева «Самоучитель Windows Millennium Edition» («Питер», 2001). Это упражнение научит вас создавать и удалять папки с помощью окон диалога приложений Office ХР.

  1. Запустите Excel и заполните несколько ячеек открывшегося листа.

  2. Выберите команду Файл > Сохранить (File > Save). Появится окно диалога Сохранение документа (Save As), показанное на рис. 3.9.

Рис. 3.9. Окно диалога сохранения документа

  3. В левой панели окна щелкните на кнопке Мои Документы (My Documents). В основном списке окна появится содержимое этой папки. Предположим, что вы только что начали работать над новым проектом и хотите, чтобы все относящиеся к нему файлы хранились в отдельной папке. Но вы забыли создать такую папку заранее. Что же делать?

  4. Щелкните в панели инструментов окна на кнопке Создать папку (Create New Folder).

Примечание

Описанные здесь приемы управления папками и файлами в равной степени относятся к окнам диалога открытия документа, вставки объекта и другим окнам диалога, открываемым в приложениях пакета Office ХР и предназначенным для выбора файла.

  5. В открывшемся окне диалога введите имя папки Новый проект и щелкните на кнопке ОК. Новая папка будет добавлена в текущую папку Мои Документы (My Documents) и сразу откроется в окне диалога Сохранение документа (Save As).

  6. Чтобы вернуться в папку Мои Документы (My Documents), щелкните в панели инструментов окна на кнопке со стрелкой влево. Эта кнопка позволяет возвращаться назад в те папки, которые недавно открывались в окне выбора файла. В папке Мои Документы (My Documents), показанной па рис. 3.9, есть файл с непонятным названием Книга1.xls. Если файл был создан недавно, вы, вероятно, еще помните, что в нем хранится: Полезно отразить это в названии документа.

  7. Щелчком выделите значок Книга1.xls.

  8. Щелкните на кнопке Сервис (Tools).

  9. Выберите в раскрывшемся подменю (рис. 3.10) команду Переименовать (Rename). Название значка станет выделенным, и вы сможете дать файлу новое имя или изменить существующее.

Рис. 3.10. Меню сервисных инструментов

Другие команды этого подменю выполняют следующие операции:

  • Удалить (Delete) — удаляет выделенный файл;

  • Печать (Print) — печатает выделенный документ на стандартном принтере;

  • Добавить в папку «Избранное» (Add To Favorites) — добавляет в папку избранных документов ярлык выделенного файла;

  • Подключить сетевой диск (Map Network Drive) — подключает диск другого локального компьютера к файловой системе Windows;

  • Свойства (Properties) — открывает окно диалога свойств выделенного объекта (файла или папки);

  • Параметры web-документа (Web Options) — открывает окно диалога параметров документов web;

  • Общие параметры (General Options) — позволяет настроить параметры окна диалога сохранения документа.

  10. Если оказалось, что какой-либо файл больше не нужен, выделите его в списке окна диалога и нажмите клавишу Delete. Файл будет перемещен в Корзину.

Примечание

Чтобы стереть файл в обход Корзины, при выполнении операции удаления в любом окне интерфейса Windows или приложения Office держите нажатой клавишу Shift. Имейте в виду, что документ, удаленный в обход Корзины, восстановить невозможно!

  11. Чтобы получить доступ к файлам Интернета, щелкните в левой панели окна сохранения файла на кнопке web-папки (Web Folders).

  12. Для добавления папки удаленного ресурса щелкните на кнопке Создать папку (Create New Folder). Откроется окно мастера Добавление папки web (Add Web Folder). Далее следуйте указаниям мастера.

Примечание

Если в Office 97 только появились первые инструменты поддержки формата HTML, то в пакете Office XP система доступа в Интернет полностью интегрирована. Теперь вы можете работать с документами интрасети и Интернета точно так же, как с локальными файлами компьютера.

Главное меню Windows

Главное меню Windows раскрывается щелчком на кнопке Пуск (Start) и обеспечивает доступ ко всем основным инструментам и приложениям компьютера. При установке Office XP в Главном меню появляются два пункта: Создать документ Office (New Office Document) и Открыть документ Office (Open Office Document), а в подменю Программы (Programs) Главного меню добавляются ярлыки шести приложений Office XP.

Упражнение 5. Создание документа Office

В этом упражнении вы изучите еще два способа создания документов Office.

  1. Раскройте Главное меню и выберите пункт Создать документ Office (New Office Document). Откроется окно диалога Создание документа Office (New Office Document), показанное на рис. 3.11. Вкладки этого окна содержат полный набор шаблонов и мастеров создания различных документов Office. Значки вкладки Общие (General) позволяют запустить любое из шести приложений Office и открыть в нем пустой документ. Остальные вкладки содержат значки следующих объектов:

  • Базы данных (Databases) — мастера построения стандартных баз данных Access;

  • Шаблоны оформления (Design Templates) — шаблоны, на основе которых создаются презентации PowerPoint с заранее заданным оформлением;

  • Письма и факсы (Letters & Faxes) — стандартные шаблоны писем и факсимильных сообщений для Word;

  • Ходатайство (Legal Pleadings) — мастер построения шаблона официального ходатайства и наполнения его содержанием, а также шаблоны, созданные этим мастером;

  • Слияние (Mail Merge) — стандартные шаблоны составных отправлений, предназначенных для рассылки нескольким адресатам;

  • Записки (Memos) — докладные записки и небольшие письма;

  • Презентации (Presentations) — презентации PowerPoint;

  • Публикации (Publications) — шаблоны текстов, предназначенных для публикации;

  • Отчеты (Reports) — отчеты для Word;

  • Электронные таблицы (Spreadsheet Solutions) — шаблоны электронных таблиц Excel;

  • Веб-страницы (Web Pages) — мастер построения web-страниц и шаблоны файлов формата HTML;

  • Другие документы (Other Documents) — дополнительные мастера и шаблоны документов.

Рис. 3.11. Окно создания документа Office

  2. Откройте нужную вкладку, найдите подходящий шаблон или мастер и щелкните на его значке. В поле просмотра в правой части окна диалога появится общий вид выбранного шаблона. Если вместо этого появится сообщение о недоступности выбранного компонента, не огорчайтесь, — благодаря автоматической системе установки компонентов Office шаблон все же можно будет открыть, но для этого потребуется выполнить несколько дополнительных шагов.

Примечание

В Office XP найден компромисс между проблемой экономии дискового пространства и необходимостью доступа к дополнительным компонентам приложений. Во время установки Office подавляюща^ часть этих компонентов не копируется на жесткий диск, но ссылки на них появляются в окнах диалога приложений. Если комплект устанавливался с сервера, то при обращении к такому отсутствующему компоненту модуль установки Office автоматически загрузит с сетевого диска недостающие файлы, и вы сможете продолжить работу, не прерываясь на процедуру переустановки Office. Если установка производилась с компакт-диска, держите его под рукой, он может понадобиться в любой момент для добавления недостающих компонентов.

  3. Щелкните на кнопке ОК. При необходимости ответьте на вопросы мастера. Если на экране появится окно диалога, показанное на рис. 3.12, это означает, что в пакет Office устанавливаются дополнительные компоненты. Иногда программа установки может потребовать перезагрузки компьютера. В этом случае сохраните измененные документы, закройте все открытые приложения и щелкните на кнопке Да (Yes). После перезагрузки продолжайте прерванную работу.

Рис. 3.12. Программа установки добавляет недостающие компоненты

Активизация значка в окне Создание документа Office (New Office Document) автоматически запустит соответствующее приложение Office, в котором откроется документ, построенный на основе выбранного шаблона. Это окно диалога позволяет оперативно просмотреть имеющиеся шаблоны и подобрать подходящее решение для вашего проекта.

Есть и другой способ создания документов Office. Можно вообще не открывать программу Office, а создать необходимые файлы с помощью Windows. Это удобно, если вам нужно определить состав будущего проекта, распределить документы по папкам, дать им легко запоминающиеся названия, а затем поставить перед подчиненными задачи по заполнению созданных файлов необходимым содержанием.

  4. Щелкните на пустом месте рабочего стола правой кнопкой мыши.

  5. В контекстном меню выберите пункт Создать (New). Раскроется подменю, показанное на рис. 3.13.

Рис. 3.13. Создание документа Office

  6. Чтобы добавить в папку или на рабочий стол презентацию PowerPoint, выберите команду Презентация Microsoft PowerPoint (Microsoft PowerPoint Presentation). Появится значок нового файла, название которого будет подсвечено.

  7. В качестве имени введите текст Презентация.ppt. Для создания документа Word, электронной таблицы Excel или базы данных Access выбирайте соответствующие пункты того же подменю.

Упражнение 6. Рабочие документы в Главном меню

Если вы постоянно работаете с одними и теми же документами или папками, бывает удобно разместить их ярлыки прямо в Главном меню. Тогда файлы будут под рукой в любой момент, даже когда рабочий стол закрыт многочисленными окнами приложений. Наиболее важные ярлыки можно поместить в основной список Главного меню. Для этого достаточно открыть папку, содержащую нужный документ, и перетащить его значок на кнопку Пуск (Start) Панели задач.

  1. Чтобы разместить в Главном меню ярлык документа Текст.doc, перетащите его значок с рабочего стола на кнопку Пуск (Start). В Главное меню можно добавлять папки с документами и вложенными папками.

  2. Щелкните на кнопке Пуск (Start) правой кнопкой мыши и выберите в контекстном меню команду Проводник (Windows Explorer). Откроется окно Проводника, в правой панели которого появится содержимое папки Главного меню.

  3. Щелкните на свободном пространстве правой панели проводника правой кнопкой мыши и выберите в контекстном меню команду Создать > Папка (New > Folder).

  4. В качестве названия введите текст Важные документы, как показано на рис. 3.14. В этой новой папке Главного меню будут храниться ярлыки ваших документов.

  5. Щелкните на свободном пространстве рабочего стола правой кнопкой мыши и выберите в контекстном меню команду Создать > Папка (New > Folder).

Рис. 3.14. Значки Главного меню в окне Проводника

  6. Введите текст Текущий проект. Так будет называться новая папка.

  7. Двойным щелчком на значке новой папки откройте ее окно.

  8. Щелкните в этом окне правой кнопкой мыши и выберите команду Создать > Документ Microsoft Word (New > Microsoft Word Document). Дайте новому документу имя Отчет.

  9. С помощью аналогичных действий создайте в той же папке еще два документа, чтобы она выглядела так, как показано на рис. 3.15.

Рис. 3.15. Папка с документами Office

  10. Закройте окно папки Текущий проект. Теперь для облегчения доступа к документам Office нужно поместить их ярлыки в только что созданную папку Важные документы Главного меню.

  11. Правой кнопкой мыши перетащите значок папки Текущий проект в окно проводника на значок папки Важные документы.

  12. В раскрывшемся контекстном меню выберите команду Создать ярлык (Create Shortcut).

  13. Повторяя шаги 8 и 9, создайте ярлык для файла Презентация.ppt, имеющегося на рабочем столе.

  14. Закройте окно Проводника.

В Главном меню появилась новая папка. Если переместить на нее указатель мыши, раскроется список помещенных в нее ярлыков (рис. 3.16). В новую папку можно добавлять ярлыки любых других папок и файлов. Щелчок на ярлыке папки Текущий проект откроет окно этой папки с документами, щелчок на ярлыке файла Презентация откроет указанный документ в программе PowerPoint. Обратите внимание, что в Главном меню, показанном на рис. 3.16, присутствует ярлык Текст, помещенный туда на первом шаге упражнения.

Рис. 3.16. Главное меню с ярлыками документов

Вывод результатов работы

После создания необходимых документов и наполнения их содержанием возникает вопрос: «Что дальше?» С развитием локальных сетей и Интернета документы все чаще пересылаются заказчику или предоставляются на суд общественности и начальства в электронном виде. Тем не менее до сих пор огромное количество информации выводится на печать. Если же у вас (или у заказчика) нет локальной сети или электронной почты, сформированные документы часто приходится переносить на другой компьютер с помощью гибких дисков.

Упражнение 7. Запись файлов на гибкий диск

Чтобы записать документ Teкст.doc на гибкий диск, выполните следующие шаги.

  1. Щелкните на значке документа правой кнопкой мыши.

  2. Выберите в контекстном меню команду Отправить (Send To). Раскроется подменю, показанное на рис. 3.17. Содержимое этого подменю определяется исходной конфигурацией операционной системы и может модифицироваться пользователем. Обычно подменю Отправить (Send To) содержит список дисков, папок, принтеров и других мест назначения, по которым часто рассылаются документы. Такое подменю доступно для любого файла, папки или группы выделенных значков. Оно ускоряет пересылку объектов.

  3. Чтобы скопировать документ Текст-doc на гибкий диск, просто вставьте диск в дисковод и выберите в меню Отправить (Send To) пункт Диск 3,5 (А) (3.5 Floppy А), название которого может варьироваться в зависимости от конкретной конфигурации дисководов компьютера.

  4. Если нужно записать на гибкий диск сразу несколько документов, щелкните на кнопке Пуск (Start) и выберите команду Программы > Проводник (Programs > Windows Explorer).

  5. В левой панели проводника найдите папку с вашими документами и щелкните на ее значке. Файлы этой папки появятся в правой панели проводника.

Рис. 3.17. Подменю Отправить

Примечание

Проводник — основной инструмент операционной системы Windows, предназначенный для управления файлами локальных и сетевых дисков. В левой панели Проводника отображается дерево папок. Для раскрытия очередной ветви щелкните на знаке «плюс» рядом с соответствующей папкой. Чтобы скрыть ветвь, щелкните на знаке «минус». Щелчок на значке любой папки левой панели Проводника выводит содержимое этой папки в правую панель.

  6. Нажмите клавишу Ctrl и, не отпуская ее, щелкайте по очереди на значках всех тех файлов, которые нужно записать на гибкий диск. Значки файлов по мере их выделения будут подсвечиваться.

Примечание

Чтобы выделить несколько последовательно расположенных значков, щелкните на первом из них и, нажав клавишу Shift, щелкните на последнем значке. Эти два значка будут выделены вместе со всеми объектами, расположенными между ними.

  7. Щелкните правой кнопкой мыши на любом из выделенных файлов.

  8. Выберите в контекстном меню команду Копировать (Copy), как показано на рис. 3.18.

Рис. 3.18. Копирование группы файлов

  9. Правой кнопкой мыши щелкните в левой панели проводника на значке диска А: и выберите в контекстном меню команду Вставить (Paste). Перед копированием файлов на гибкий диск нелишне будет проверить, достаточно ли на диске свободного места для новых файлов. Чтобы узнать объем свободного пространства гибкого диска, понадобится сделать еще два шага (не забыв перед этим вставить гибкий диск в дисковод).

  10. На рабочем столе дважды щелкните на значке Мой компьютер (My Computer).

  11. В открывшемся окне папки Мой компьютер (My Computer) щелкните на значке диска А: правой кнопкой мыши и выберите в контекстном меню команду Свойства (Properties). Откроется окно диалога, показанное на рис. 3.19. В нем отображаются общий объем диска, размер свободного пространства и некоторые другие характеристики.

Рис. 3.19. Окно свойств диска

Примечание

Чтобы освободить гибкий диск от ненужных файлов, щелкните на значке диска А: в окне Мой компьютер (My Computer), описанным выше способом выделите файлы, которые следует удалить, и нажмите клавишу Delete. Имейте в виду, что удаляемые файлы гибких дисков не попадают в Корзину и восстановить их невозможно.

Упражнение 8. Печать документа

На первом занятии вы уже изучили процедуру печати документа из окна приложения. Сейчас давайте попробуем вывести информацию на принтер, не открывая создавшую документ программу, а пользуясь исключительно возможностями операционной системы Windows. Для начала давайте добавим на рабочий стол ярлык принтера.

  1. Щелкните на кнопке Пуск (Start) и выберите пункт Настройка > Принтеры (Settings > Printers).

  2. В открывшемся окне папки Принтеры (Printers) щелкните правой кнопкой мыши на том принтере, который предполагается использовать чаще других (рис. 3.20).

Рис. 3.20. Папка принтеров

  3. В контекстном меню выберите команду Создать ярлык (Create Shortcut). Появится окно диалога, информирующее о невозможности создания ярлыка в папке Принтеры (Printers) и запрашивающее о необходимости добавления ярлыка на рабочий стол.

  4. Щелкните на кнопке Да (Yes). Ярлык выбранного принтера появится на рабочем столе.

  5. Закройте окно папки Принтеры (Printers).

  6. Чтобы распечатать документ Текст.doc, просто перетащите его значок на вновь созданный ярлык принтера.

Подобные ярлыки можно создать сразу для нескольких локальных или сетевых принтеров, чтобы оперативно печатать документы на любом из них. (Можно иметь несколько значков одного принтера в разных папках.) С помощью аналогичных действий на рабочий стол можно добавлять значки дисков компьютера. Это позволит копировать файлы на гибкие, жесткие и сетевые диски с помощью простого перетаскивания.

Контрольное упражнение

На этом занятии вы познакомились с некоторыми функциями операционной системы и инструментами Office, частично подменяющими системные инструменты Windows. Выполняя контрольное упражнение, проверьте, насколько хорошо вы усвоили материал занятия.

Выше была рассмотрена методика печати документов с помощью перетаскивания значков файлов. Можно еще больше упростить процедуру печати. Давайте поместим ярлык принтера в подменю Отправить (Send To).

  1. Щелкните на кнопке Пуск (Start) и выберите команду Программы > Проводник (Programs > Windows Explorer).

  2. Выведите в правую панель Проводника содержимое папки SendTo, вложенной в папку Windows.

    • Как отобразить в окне Проводника файлы указанной папки?

  3. Скопируйте ярлык принтера в папку SendTo.

    • Как добавить значок принтера в папку SendTo?

  4. Распечатайте документ Teкст.doc с помощью команд контекстного меню.

    • Как распечатать файл с помощью контекстного меню?

  5. Добавьте в подменю Отправить (Send To) ярлыки других принтеров или папок и потренируйтесь в работе с этим подменю.

    • Как упростить добавление новых пунктов в подменю Отправить (Send To)?

Подведение итогов

На этом занятии вы познакомились с приемами управления файлами из окон приложений Office XP, научились пользоваться значками Windows и ярлыками принтеров. Теперь вы можете открыть, распечатать и переписать на гибкий диск нужный документ. Эта книга посвящена пакету Microsoft Office XP, поэтому в ней затронуты только самые основные инструменты Windows.

На следующем занятии вы изучите элементы интерфейса окон приложений Office XP, узнаете о новом режиме работы панелей инструментов, о способах поиска, выделения и редактирования объектов, познакомитесь со справочной системой, помогающей решать возникающие вопросы.


Занятие №3

Взаимодействие с операционной системой

ТЕМА ЗАНЯТИЯ

Операционная система — важная часть программного обеспечения компьютера. Она обеспечивает грамотное взаимодействие программ между собой и с имеющимся оборудованием. Именно операционная система Windows предоставляет программам стандартный оконный интерфейс и общие правила работы с документами, значками, шрифтами и принтерами. На этом занятии обсуждаются некоторые полезные приемы работы с основными компонентами операционной системы Windows, к которым относятся:

  • рабочий стол;

  • папки с документами;

  • Панель задач;

  • главное меню;

  • диспетчер печати.

Все приложения пакета Microsoft Office XP работают только в Windows 95, Windows 98 или Windows NT. Поскольку часть функций программ (к которым относятся вопросы взаимодействия приложений, доступа к дискам и принтерам, а также многие другие) неразрывно связана с операционной системой, для полноценного использования всех возможностей Office XP необходимо хорошо знать основные системные компоненты Windows. К сожалению, в эту книгу невозможно вместить полное описание Windows. Чтобы изучить всю мощь современной операционной оболочки компании Microsoft, обратитесь к книге К. Стинсона, К. Зихерта «Эффективная работа в Windows 2000 Professional» издательства «Питер», выпущенной в 2001 году.


Рабочий стол Windows

После запуска компьютера на экране появляется рабочий стол с набором значков. Это ярлыки документов и программ либо сами документы. Каждая программа запускается в отдельном окне, которое размещается на рабочем столе Windows — основной сцене всех действий.


Упражнение 1. Значки рабочего стола

Объекты рабочего стола оказываются под рукой сразу после загрузки Windows. Вам не приходится искать их по всему дереву файлов жесткого диска. Поэтому на рабочем столе обычно размещаются те ярлыки, файлы и папки, которыми пользуются чаще всего. Ярлыки — это маленькие файлы, содержащие ссылку на документ или программу. Они обеспечивают быстрый доступ к объекту. Любой файл может иметь сколь угодно много ярлыков, которые размещаются в папках компьютера, на рабочем столе или в Главном меню. Таким образом, доступ к конкретному документу возможен сразу из нескольких мест графического интерфейса.

  1. Программа установки Office XP добавляет на рабочий стол ярлык Microsoft Outlook, предполагая, что вы будете пользоваться этим прекрасным приложением для организации своих дел и чтения электронных писем. Дважды щелкните на указанном значке. Откроется Outlook.

  2. Вам понравился такой способ запуска приложений? Переместите указатель мыши в левый нижний угол рабочего стола и щелкните на кнопке Пуск (Start).

  3. Укажите на пункт Программы (Programs), а затем в раскрывшемся подменю на пункт Microsoft Word.

  4. Нажмите правую кнопку мыши и перетащите ярлык Microsoft Word на пустое пространство рабочего стола.

Примечание

Если рабочий стол оказался скрыт окнами приложений, щелкните на значке Свернуть все окна (Minimize All) Панели задач. Все открытые окна свернутся на Панель задач. Чтобы восстановить окна в их прежней конфигурации, достаточно повторно щелкнуть на этом значке.

Рис. 3.1. Рабочий стол Windows

  5. При отпускании кнопки мыши раскроется контекстное меню, показанное на рис. 3.1. Выберите в нем пункт Копировать (Copy Here). На рабочем столе появится копия ярлыка.

  6. Щелкните на новом значке Microsoft Word правой кнопкой мыши. Раскроется контекстное меню ярлыка, показанное на рис. 3.2.

Рис. 3.2. Контекстное меню ярлыка

Команды контекстного меню позволяют выполнять с ярлыком все операции, обычные для любого объекта Windows. Вы можете вырезать, скопировать, удалить или переименовать ярлык, открыть объект, на который ссылается ярлык, или открыть окно свойств ярлыка.

Примечание

Удаляя ярлык, вы никак не влияете на сам объект. Это абсолютно безболезненная операция, не затрагивающая файл, на который ссылается ярлык.

  7. Дважды щелкните на новом ярлыке. Запустится Microsoft Word.

  8. Введите в новом документе какой-либо текст и выберите команду Файл > Сохранить (File > Save).

  9. В левой панели окна диалога Сохранение документа (Save As) щелкните на кнопке Рабочий стол (Desktop). Затем введите имя файла Текст . doc и щелкните на кнопке Сохранить (Save).

  10. Закройте Word и все остальные окна приложений. Новый документ Word разместится прямо на рабочем столе компьютера.

Примечание

Значок Teкст.doc — это не ярлык, а сам документ, поэтому его перемещение в другую папку приведет к переносу самого документа, а удаление повлечет потерю данных. Чтобы отличить ярлык от документа или исполняемого файла, обратите внимание на значок ярлыка. В его левом нижнем углу всегда имеется небольшая стрелка (см. рис. 3.2).


Упражнение 2. Документы на рабочем столе

Рабочий стол Windows предлагает множество разных способов работы с документами.

  1. Укажите на значок Teкст.doc. Нажмите левую кнопку мыши и перетащите выбранный документ на значок Microsoft Word, как показано на рис. 3.3. Запустится программа Word, и файл Текет.doc будет автоматически открыт.

  2. Выделите в открывшемся документе Word любой фрагмент текста и нажмите клавиши Ctrl+C. Выделенный текст скопируется в буфер обмена Windows. Закройте Word.

  3. Щелкните на рабочем столе правой кнопкой мыши и выберите в контекстном меню команду Вставить (Paste). На рабочем столе появится значок фрагмента документа, являющийся самостоятельным файлом.

  4. Запустите Word и введите в нем произвольный текст.

  5. Если окно Word развернуто до максимального размера, щелкните в его заголовке на кнопке восстановления размеров.

Примечание

Описанный прием позволяет открывать документы нестандартных для данного приложения типов. Например, двойной щелчок на файле с расширением txt приводит к его открытию в программе Блокнот (Notepad). Но если перетащить значок этого файла на значок Microsoft Word, документ будет открыт в приложении Word.

Рис. 3.3. Открытие документа

  6. Переместите окно так, чтобы оно не закрывало значок фрагмента. При необходимости измените размер окна.

  7. Перетащите фрагмент с рабочего стола в документ Word, как показано на рис. 3.4. Содержимое фрагмента добавится в текст Word в точке отпускания кнопки мыши.

P ис. 3.4. Добавление фрагмента в документ Word

Фрагмент — это обычный файл на жестком диске. Таких файлов может быть сколь угодно много. С их помощью можно организовать подобие буфера обмена Windows с любым количеством фрагментов, хранящихся на .рабочем столе или в другой папке компьютера. По мере необходимости их можно вставлять в документы приложений. Фрагмент может содержать не только текст Word, а объект любой программы, поддерживающей технологию переноса объектов между приложениями.

Примечание

В Office XP имеется встроенный буфер обмена, позволяющий хранить одновременно несколько фрагментов и пользоваться ими во всех приложениях Office. Этот инструмент подробно рассматривается на следующем занятии.

На рабочем столе всегда присутствует значок Корзина (Recycle Bin). После удаления документа с помощью инструментов Windows или в любом 32-разрядном приложении (к которым относятся все модули Office XP) он не исчезает бесследно, а попадает в Корзину. Это позволяет избежать неприятных последствий в случае ошибок.

Примечание

В Корзину не попадают файлы, удаленные 16-разрядными приложениями Windows или программами DOS. Старайтесь пользоваться только 32-разрядными приложениями, которые поддерживают все нововведения Windows, включая Корзину и длинные имена файлов.

  8. Щелкните на значке Текст.с1ос правой кнопкой мыши и выберите в контекстном меню команду Удалить (Delete). Документ исчезнет с рабочего стола.

  9. Чтобы восстановить стертый файл, щелкните на значке Корзина (Recycle Bin). Откроется окно диалога, показанное на рис. 3.5.

  10. Найдите значок документа Текст.с1ос и щелкните на нем правой кнопкой мыши.

Рис. 3.5. Окно Корзины

Выберите в контекстном меню команду Восстановить (Recover). Удаленный документ вновь появится на прежнем месте.

Примечание

Объем Корзины не безграничен. Если вы случайно удалили важный файл, восстановите его как можно скорее. Когда Корзина переполняется, первыми из нее исчезают файлы, удаленные раньше других.


Папки Windows

Открывая документы из окон приложений или с помощью значков рабочего стола, важно понимать, что на самом деле все документы представляют собой файлы — поименованные информационные блоки, расположенные в иерархической структуре папок или каталогов жестких дисков компьютера или на сетевых дисках.


Упражнение 3. Мой компьютер

Чтобы разобраться, где находятся ваши документы, выполните следующие операции.

  1. Дважды щелкните на значке Мой компьютер (My Computer) рабочего стола. Откроется окно, в котором расположены значки всех локальных дисков, подключенных сетевых дисков и системных папок Windows (рис. 3.6). Мой компьютер (My Computer) — это главная папка компьютера, в которой размещены все остальные папки с документами, ярлыками, приложениями и служебными файлами.

  2. Дважды щелкните на значке диска С:. Откроется окно этого диска.

Рис. 3.6. Окно Мой компьютер

Примечание

Если на компьютере установлена одна из последних версий Windows, возможно, что для выделения значка будет достаточно просто переместить на него указатель мыши, а активизация значка будет выполняться одинарным, а не двойным щелчком. Стиль поведения системы можно настроить в окне диалога, которое открывается выбором команды Вид > Свойства папки (View > Folder Options). Мне больше нравится стандартный стиль работы с мышью, поэтому в книге предполагается, что объекты выделяются щелчком и активизируются двойным щелчком.

  3. Найдите папку Windows и дважды щелкните на ней. Откроется окно этой папки, содержащей служебные папки и файлы операционной системы.

  4. В окне Windows дважды щелкните на папке Рабочий стол (Desktop). Появится окно, показанное в правом нижнем углу рис. 3.7. Сравните его содержимое с рабочим столом, и вы поймете, что значки и документы рабочего стола на самом деле хранятся в одной из папок диска С:. Здесь можно найти и документ Teкст.doc. Двойным щелчком на его значке в окне папки можно запустить Word и открыть этот документ. Папки операционной системы образуют иерархическую структуру вложенных друг в друга объектов, в корне которой находится папка Мой компьютер (My Computer).

Рис. 3.7. Папки операционной системы Windows

Перемещаясь по папкам, можно найти любой файл. Последовательное перечисление имен папок, в которые вложен файл, называется полным путем к файлу. Файлы и папки можно перемещать и копировать между окнами папок с помощью технологии перетаскивания или посредством контекстных меню, раскрывающихся правой кнопкой мыши. Некоторые папки операционной системы имеют особое назначение. Часть из них доступна в Главном меню.

  5. Щелкните на кнопке Пуск (Start) Панели задач.

  6. Переместите указатель мыши на папку Документы (Documents). Раскроется подменю, показанное на рис. 3.8. Здесь находятся ярлыки тех документов, с которыми вы недавно работали.

Примечание

Чтобы получить доступ к файлам папки Мои документы (My Documents), переместите указатель на одноименный пункт подменю Документы (Documents). Разработчики Windows предполагают, что в этой папке должны храниться ваши рабочие файлы.

  7. Для продолжения работы с недавно открывавшимся документом (например, с файлом Текст.аос) найдите его название в подменю Документы (Documents) и щелкните на нем.

  8. Снова щелкните на кнопке Пуск (Start) и переместите указатель на пункт Избранное (Favorites). Вы увидите содержимое личной папки, в которой хранятся часто открываемые документы. Эта же папка обеспечивает доступ к каналам и ссылкам Internet Explorer. Личная папка удобна потому, что во многих окнах диалога она открывается щелчком на специальной кнопке и ее не нужно долго искать в иерархической структуре папок,

Рис. 3.8. Меню Документы


Упражнение 4. Управление папками из Office

Описание операций управления файлами с помощью инструментов Windows выходит за рамки этой книги. Чтобы освоить все тонкости этой операционной системы, обратитесь к книге Б. Богумирского «Энциклопедия Windows 98» («Питер», 1999). Наиболее полезной книгой по Windows Millenium Edition является бестселлер А. Денисова, А. Белова, И. Вихарева «Самоучитель Windows Millennium Edition» («Питер», 2001). Это упражнение научит вас создавать и удалять папки с помощью окон диалога приложений Office ХР.

  1. Запустите Excel и заполните несколько ячеек открывшегося листа.

  2. Выберите команду Файл > Сохранить (File > Save). Появится окно диалога Сохранение документа (Save As), показанное на рис. 3.9.

Рис. 3.9. Окно диалога сохранения документа

  3. В левой панели окна щелкните на кнопке Мои Документы (My Documents). В основном списке окна появится содержимое этой папки. Предположим, что вы только что начали работать над новым проектом и хотите, чтобы все относящиеся к нему файлы хранились в отдельной папке. Но вы забыли создать такую папку заранее. Что же делать?

  4. Щелкните в панели инструментов окна на кнопке Создать папку (Create New Folder).

Примечание

Описанные здесь приемы управления папками и файлами в равной степени относятся к окнам диалога открытия документа, вставки объекта и другим окнам диалога, открываемым в приложениях пакета Office ХР и предназначенным для выбора файла.

  5. В открывшемся окне диалога введите имя папки Новый проект и щелкните на кнопке ОК. Новая папка будет добавлена в текущую папку Мои Документы (My Documents) и сразу откроется в окне диалога Сохранение документа (Save As).

  6. Чтобы вернуться в папку Мои Документы (My Documents), щелкните в панели инструментов окна на кнопке со стрелкой влево. Эта кнопка позволяет возвращаться назад в те папки, которые недавно открывались в окне выбора файла. В папке Мои Документы (My Documents), показанной па рис. 3.9, есть файл с непонятным названием Книга1.xls. Если файл был создан недавно, вы, вероятно, еще помните, что в нем хранится: Полезно отразить это в названии документа.

  7. Щелчком выделите значок Книга1.xls.

  8. Щелкните на кнопке Сервис (Tools).

  9. Выберите в раскрывшемся подменю (рис. 3.10) команду Переименовать (Rename). Название значка станет выделенным, и вы сможете дать файлу новое имя или изменить существующее.

Рис. 3.10. Меню сервисных инструментов

Другие команды этого подменю выполняют следующие операции:

  • Удалить (Delete) — удаляет выделенный файл;

  • Печать (Print) — печатает выделенный документ на стандартном принтере;

  • Добавить в папку «Избранное» (Add To Favorites) — добавляет в папку избранных документов ярлык выделенного файла;

  • Подключить сетевой диск (Map Network Drive) — подключает диск другого локального компьютера к файловой системе Windows;

  • Свойства (Properties) — открывает окно диалога свойств выделенного объекта (файла или папки);

  • Параметры web-документа (Web Options) — открывает окно диалога параметров документов web;

  • Общие параметры (General Options) — позволяет настроить параметры окна диалога сохранения документа.

  10. Если оказалось, что какой-либо файл больше не нужен, выделите его в списке окна диалога и нажмите клавишу Delete. Файл будет перемещен в Корзину.

Примечание

Чтобы стереть файл в обход Корзины, при выполнении операции удаления в любом окне интерфейса Windows или приложения Office держите нажатой клавишу Shift. Имейте в виду, что документ, удаленный в обход Корзины, восстановить невозможно!

  11. Чтобы получить доступ к файлам Интернета, щелкните в левой панели окна сохранения файла на кнопке web-папки (Web Folders).

  12. Для добавления папки удаленного ресурса щелкните на кнопке Создать папку (Create New Folder). Откроется окно мастера Добавление папки web (Add Web Folder). Далее следуйте указаниям мастера.

Примечание

Если в Office 97 только появились первые инструменты поддержки формата HTML, то в пакете Office XP система доступа в Интернет полностью интегрирована. Теперь вы можете работать с документами интрасети и Интернета точно так же, как с локальными файлами компьютера.


Главное меню Windows

Главное меню Windows раскрывается щелчком на кнопке Пуск (Start) и обеспечивает доступ ко всем основным инструментам и приложениям компьютера. При установке Office XP в Главном меню появляются два пункта: Создать документ Office (New Office Document) и Открыть документ Office (Open Office Document), а в подменю Программы (Programs) Главного меню добавляются ярлыки шести приложений Office XP.


Упражнение 5. Создание документа Office

В этом упражнении вы изучите еще два способа создания документов Office.

  1. Раскройте Главное меню и выберите пункт Создать документ Office (New Office Document). Откроется окно диалога Создание документа Office (New Office Document), показанное на рис. 3.11. Вкладки этого окна содержат полный набор шаблонов и мастеров создания различных документов Office. Значки вкладки Общие (General) позволяют запустить любое из шести приложений Office и открыть в нем пустой документ. Остальные вкладки содержат значки следующих объектов:

  • Базы данных (Databases) — мастера построения стандартных баз данных Access;

  • Шаблоны оформления (Design Templates) — шаблоны, на основе которых создаются презентации PowerPoint с заранее заданным оформлением;

  • Письма и факсы (Letters & Faxes) — стандартные шаблоны писем и факсимильных сообщений для Word;

  • Ходатайство (Legal Pleadings) — мастер построения шаблона официального ходатайства и наполнения его содержанием, а также шаблоны, созданные этим мастером;

  • Слияние (Mail Merge) — стандартные шаблоны составных отправлений, предназначенных для рассылки нескольким адресатам;

  • Записки (Memos) — докладные записки и небольшие письма;

  • Презентации (Presentations) — презентации PowerPoint;

  • Публикации (Publications) — шаблоны текстов, предназначенных для публикации;

  • Отчеты (Reports) — отчеты для Word;

  • Электронные таблицы (Spreadsheet Solutions) — шаблоны электронных таблиц Excel;

  • Веб-страницы (Web Pages) — мастер построения web-страниц и шаблоны файлов формата HTML;

  • Другие документы (Other Documents) — дополнительные мастера и шаблоны документов.

Рис. 3.11. Окно создания документа Office

  2. Откройте нужную вкладку, найдите подходящий шаблон или мастер и щелкните на его значке. В поле просмотра в правой части окна диалога появится общий вид выбранного шаблона. Если вместо этого появится сообщение о недоступности выбранного компонента, не огорчайтесь, — благодаря автоматической системе установки компонентов Office шаблон все же можно будет открыть, но для этого потребуется выполнить несколько дополнительных шагов.

Примечание

В Office XP найден компромисс между проблемой экономии дискового пространства и необходимостью доступа к дополнительным компонентам приложений. Во время установки Office подавляюща^ часть этих компонентов не копируется на жесткий диск, но ссылки на них появляются в окнах диалога приложений. Если комплект устанавливался с сервера, то при обращении к такому отсутствующему компоненту модуль установки Office автоматически загрузит с сетевого диска недостающие файлы, и вы сможете продолжить работу, не прерываясь на процедуру переустановки Office. Если установка производилась с компакт-диска, держите его под рукой, он может понадобиться в любой момент для добавления недостающих компонентов.

  3. Щелкните на кнопке ОК. При необходимости ответьте на вопросы мастера. Если на экране появится окно диалога, показанное на рис. 3.12, это означает, что в пакет Office устанавливаются дополнительные компоненты. Иногда программа установки может потребовать перезагрузки компьютера. В этом случае сохраните измененные документы, закройте все открытые приложения и щелкните на кнопке Да (Yes). После перезагрузки продолжайте прерванную работу.

Рис. 3.12. Программа установки добавляет недостающие компоненты

Активизация значка в окне Создание документа Office (New Office Document) автоматически запустит соответствующее приложение Office, в котором откроется документ, построенный на основе выбранного шаблона. Это окно диалога позволяет оперативно просмотреть имеющиеся шаблоны и подобрать подходящее решение для вашего проекта.

Есть и другой способ создания документов Office. Можно вообще не открывать программу Office, а создать необходимые файлы с помощью Windows. Это удобно, если вам нужно определить состав будущего проекта, распределить документы по папкам, дать им легко запоминающиеся названия, а затем поставить перед подчиненными задачи по заполнению созданных файлов необходимым содержанием.

  4. Щелкните на пустом месте рабочего стола правой кнопкой мыши.

  5. В контекстном меню выберите пункт Создать (New). Раскроется подменю, показанное на рис. 3.13.

Рис. 3.13. Создание документа Office

  6. Чтобы добавить в папку или на рабочий стол презентацию PowerPoint, выберите команду Презентация Microsoft PowerPoint (Microsoft PowerPoint Presentation). Появится значок нового файла, название которого будет подсвечено.

  7. В качестве имени введите текст Презентация.ppt. Для создания документа Word, электронной таблицы Excel или базы данных Access выбирайте соответствующие пункты того же подменю.


Упражнение 6. Рабочие документы в Главном меню

Если вы постоянно работаете с одними и теми же документами или папками, бывает удобно разместить их ярлыки прямо в Главном меню. Тогда файлы будут под рукой в любой момент, даже когда рабочий стол закрыт многочисленными окнами приложений. Наиболее важные ярлыки можно поместить в основной список Главного меню. Для этого достаточно открыть папку, содержащую нужный документ, и перетащить его значок на кнопку Пуск (Start) Панели задач.

  1. Чтобы разместить в Главном меню ярлык документа Текст.doc, перетащите его значок с рабочего стола на кнопку Пуск (Start). В Главное меню можно добавлять папки с документами и вложенными папками.

  2. Щелкните на кнопке Пуск (Start) правой кнопкой мыши и выберите в контекстном меню команду Проводник (Windows Explorer). Откроется окно Проводника, в правой панели которого появится содержимое папки Главного меню.

  3. Щелкните на свободном пространстве правой панели проводника правой кнопкой мыши и выберите в контекстном меню команду Создать > Папка (New > Folder).

  4. В качестве названия введите текст Важные документы, как показано на рис. 3.14. В этой новой папке Главного меню будут храниться ярлыки ваших документов.

  5. Щелкните на свободном пространстве рабочего стола правой кнопкой мыши и выберите в контекстном меню команду Создать > Папка (New > Folder).

Рис. 3.14. Значки Главного меню в окне Проводника

  6. Введите текст Текущий проект. Так будет называться новая папка.

  7. Двойным щелчком на значке новой папки откройте ее окно.

  8. Щелкните в этом окне правой кнопкой мыши и выберите команду Создать > Документ Microsoft Word (New > Microsoft Word Document). Дайте новому документу имя Отчет.

  9. С помощью аналогичных действий создайте в той же папке еще два документа, чтобы она выглядела так, как показано на рис. 3.15.

Рис. 3.15. Папка с документами Office

  10. Закройте окно папки Текущий проект. Теперь для облегчения доступа к документам Office нужно поместить их ярлыки в только что созданную папку Важные документы Главного меню.

  11. Правой кнопкой мыши перетащите значок папки Текущий проект в окно проводника на значок папки Важные документы.

  12. В раскрывшемся контекстном меню выберите команду Создать ярлык (Create Shortcut).

  13. Повторяя шаги 8 и 9, создайте ярлык для файла Презентация.ppt, имеющегося на рабочем столе.

  14. Закройте окно Проводника.

В Главном меню появилась новая папка. Если переместить на нее указатель мыши, раскроется список помещенных в нее ярлыков (рис. 3.16). В новую папку можно добавлять ярлыки любых других папок и файлов. Щелчок на ярлыке папки Текущий проект откроет окно этой папки с документами, щелчок на ярлыке файла Презентация откроет указанный документ в программе PowerPoint. Обратите внимание, что в Главном меню, показанном на рис. 3.16, присутствует ярлык Текст, помещенный туда на первом шаге упражнения.

Рис. 3.16. Главное меню с ярлыками документов


Вывод результатов работы

После создания необходимых документов и наполнения их содержанием возникает вопрос: «Что дальше?» С развитием локальных сетей и Интернета документы все чаще пересылаются заказчику или предоставляются на суд общественности и начальства в электронном виде. Тем не менее до сих пор огромное количество информации выводится на печать. Если же у вас (или у заказчика) нет локальной сети или электронной почты, сформированные документы часто приходится переносить на другой компьютер с помощью гибких дисков.


Упражнение 7. Запись файлов на гибкий диск

Чтобы записать документ Teкст.doc на гибкий диск, выполните следующие шаги.

  1. Щелкните на значке документа правой кнопкой мыши.

  2. Выберите в контекстном меню команду Отправить (Send To). Раскроется подменю, показанное на рис. 3.17. Содержимое этого подменю определяется исходной конфигурацией операционной системы и может модифицироваться пользователем. Обычно подменю Отправить (Send To) содержит список дисков, папок, принтеров и других мест назначения, по которым часто рассылаются документы. Такое подменю доступно для любого файла, папки или группы выделенных значков. Оно ускоряет пересылку объектов.

  3. Чтобы скопировать документ Текст-doc на гибкий диск, просто вставьте диск в дисковод и выберите в меню Отправить (Send To) пункт Диск 3,5 (А) (3.5 Floppy А), название которого может варьироваться в зависимости от конкретной конфигурации дисководов компьютера.

  4. Если нужно записать на гибкий диск сразу несколько документов, щелкните на кнопке Пуск (Start) и выберите команду Программы > Проводник (Programs > Windows Explorer).

  5. В левой панели проводника найдите папку с вашими документами и щелкните на ее значке. Файлы этой папки появятся в правой панели проводника.

Рис. 3.17. Подменю Отправить

Примечание

Проводник — основной инструмент операционной системы Windows, предназначенный для управления файлами локальных и сетевых дисков. В левой панели Проводника отображается дерево папок. Для раскрытия очередной ветви щелкните на знаке «плюс» рядом с соответствующей папкой. Чтобы скрыть ветвь, щелкните на знаке «минус». Щелчок на значке любой папки левой панели Проводника выводит содержимое этой папки в правую панель.

  6. Нажмите клавишу Ctrl и, не отпуская ее, щелкайте по очереди на значках всех тех файлов, которые нужно записать на гибкий диск. Значки файлов по мере их выделения будут подсвечиваться.

Примечание

Чтобы выделить несколько последовательно расположенных значков, щелкните на первом из них и, нажав клавишу Shift, щелкните на последнем значке. Эти два значка будут выделены вместе со всеми объектами, расположенными между ними.

  7. Щелкните правой кнопкой мыши на любом из выделенных файлов.

  8. Выберите в контекстном меню команду Копировать (Copy), как показано на рис. 3.18.

Рис. 3.18. Копирование группы файлов

  9. Правой кнопкой мыши щелкните в левой панели проводника на значке диска А: и выберите в контекстном меню команду Вставить (Paste). Перед копированием файлов на гибкий диск нелишне будет проверить, достаточно ли на диске свободного места для новых файлов. Чтобы узнать объем свободного пространства гибкого диска, понадобится сделать еще два шага (не забыв перед этим вставить гибкий диск в дисковод).

  10. На рабочем столе дважды щелкните на значке Мой компьютер (My Computer).

  11. В открывшемся окне папки Мой компьютер (My Computer) щелкните на значке диска А: правой кнопкой мыши и выберите в контекстном меню команду Свойства (Properties). Откроется окно диалога, показанное на рис. 3.19. В нем отображаются общий объем диска, размер свободного пространства и некоторые другие характеристики.

Рис. 3.19. Окно свойств диска

Примечание

Чтобы освободить гибкий диск от ненужных файлов, щелкните на значке диска А: в окне Мой компьютер (My Computer), описанным выше способом выделите файлы, которые следует удалить, и нажмите клавишу Delete. Имейте в виду, что удаляемые файлы гибких дисков не попадают в Корзину и восстановить их невозможно.


Упражнение 8. Печать документа

На первом занятии вы уже изучили процедуру печати документа из окна приложения. Сейчас давайте попробуем вывести информацию на принтер, не открывая создавшую документ программу, а пользуясь исключительно возможностями операционной системы Windows. Для начала давайте добавим на рабочий стол ярлык принтера.

  1. Щелкните на кнопке Пуск (Start) и выберите пункт Настройка > Принтеры (Settings > Printers).

  2. В открывшемся окне папки Принтеры (Printers) щелкните правой кнопкой мыши на том принтере, который предполагается использовать чаще других (рис. 3.20).

Рис. 3.20. Папка принтеров

  3. В контекстном меню выберите команду Создать ярлык (Create Shortcut). Появится окно диалога, информирующее о невозможности создания ярлыка в папке Принтеры (Printers) и запрашивающее о необходимости добавления ярлыка на рабочий стол.

  4. Щелкните на кнопке Да (Yes). Ярлык выбранного принтера появится на рабочем столе.

  5. Закройте окно папки Принтеры (Printers).

  6. Чтобы распечатать документ Текст.doc, просто перетащите его значок на вновь созданный ярлык принтера.

Подобные ярлыки можно создать сразу для нескольких локальных или сетевых принтеров, чтобы оперативно печатать документы на любом из них. (Можно иметь несколько значков одного принтера в разных папках.) С помощью аналогичных действий на рабочий стол можно добавлять значки дисков компьютера. Это позволит копировать файлы на гибкие, жесткие и сетевые диски с помощью простого перетаскивания.


Контрольное упражнение

На этом занятии вы познакомились с некоторыми функциями операционной системы и инструментами Office, частично подменяющими системные инструменты Windows. Выполняя контрольное упражнение, проверьте, насколько хорошо вы усвоили материал занятия.

Выше была рассмотрена методика печати документов с помощью перетаскивания значков файлов. Можно еще больше упростить процедуру печати. Давайте поместим ярлык принтера в подменю Отправить (Send To).

  1. Щелкните на кнопке Пуск (Start) и выберите команду Программы > Проводник (Programs > Windows Explorer).

  2. Выведите в правую панель Проводника содержимое папки SendTo, вложенной в папку Windows.

    • Как отобразить в окне Проводника файлы указанной папки?

  3. Скопируйте ярлык принтера в папку SendTo.

    • Как добавить значок принтера в папку SendTo?

  4. Распечатайте документ Teкст.doc с помощью команд контекстного меню.

    • Как распечатать файл с помощью контекстного меню?

  5. Добавьте в подменю Отправить (Send To) ярлыки других принтеров или папок и потренируйтесь в работе с этим подменю.

    • Как упростить добавление новых пунктов в подменю Отправить (Send To)?


Подведение итогов

На этом занятии вы познакомились с приемами управления файлами из окон приложений Office XP, научились пользоваться значками Windows и ярлыками принтеров. Теперь вы можете открыть, распечатать и переписать на гибкий диск нужный документ. Эта книга посвящена пакету Microsoft Office XP, поэтому в ней затронуты только самые основные инструменты Windows.

На следующем занятии вы изучите элементы интерфейса окон приложений Office XP, узнаете о новом режиме работы панелей инструментов, о способах поиска, выделения и редактирования объектов, познакомитесь со справочной системой, помогающей решать возникающие вопросы.


Занятие №4

Общие черты приложений Office

ТЕМА ЗАНЯТИЯ

Приложения Office XP объединены в пакет не только потому, что вместе они обеспечивают выполнение всех основных задач, встающих перед персоналом офиса современной компании. Эти программы выполняют разные функции, но имеют много общего, и пользователю, научившемуся хорошо работать с одной из них, не составляет никакого труда быстро освоить остальные приложения пакета. На этом занятии рассматриваются следующие операции и компоненты:

  • меню и панели инструментов;

  • навигация в пределах документа;

  • редактирование содержания;

  • буфер обмена Office XP;

  • справочная система;

  • Помощник по Office.

Запустив любое приложение Office XP, вы сразу же сталкиваетесь со стандартными элементами оконного интерфейса Windows. В любой программе есть меню, панели инструментов, полосы прокрутки документов и команды вызова справки. В Office XP все эти компоненты унифицированы, поэтому имеет смысл изучить их перед рассмотрением специфики отдельных программ пакета.


Меню и панели инструментов

Строка меню обеспечивает доступ ко всем командам программы. Панели инструментов содержат кнопки и раскрывающиеся списки, с помощью которых можно выполнять часто используемые операции и настраивать наиболее важные параметры. В Office XP меню и панели инструментов получили дальнейшее развитие. Работать с кнопками панелей стало удобнее и быстрее, а названия пунктов меню точнее соответствуют выполняемым командам.


Упражнение 1. Команды меню

Строка главного меню, обычно размещаемая в верхней части окна приложения (рис. 4.1), подобна панели инструментов, все кнопки которой являются раскрывающимися списками команд. Более того, в некоторых панелях инструментов (например, в панели Рисование (Drawing)) появились кнопки, чрезвычайно похожие на списки команд Главного меню.

Рис. 4.1. Строка меню и раскрывающиеся списки команд

Однако по традиции строка Главного меню выделяется разработчиками и пользователями. Давайте рассмотрим структуру меню приложений Office.

  1. Запустите Microsoft Excel и щелкните на пункте Вид (View) строки меню программы.

  2. Передвиньте указатель мыши на строку Панели инструментов (Toolbars). Раскроются два вложенных друг в друга списка пунктов, показанных на рис. 4.1. Оформление строк меню различается в зависимости от того, какая операция выполняется выбором конкретного пункта. Ниже перечислены возможные варианты.

  • Если в правой части пункта меню есть маленький треугольник (строка Панели инструментов (Toolbars) на рис. 4.1), значит, этот пункт раскрывает дополнительное подменю.

  • Выбор команды, имя которой заканчивается многоточием, например Масштаб... (Zoom...), открывает окно диалога, подобное показанному на рис. 4.2. Окна диалога широко распространены как в Office XP, так и во многих других приложениях Windows. Они позволяют практически безгранично расширять возможности любой программы, предоставляя пользователю возможность ввода самых разнообразных параметров.

Рис. 4.2. Окно диалога выбора коэффициента масштабирования

  • Выбор команды без многоточия (пункт Примечания (Comments)) приводит к немедленному исполнению определенной операции.

  • Некоторые пункты меню (например, Строка формул (Formula Bar)) играют роль флажков. При щелчках на них включается соответствующий режим (в данном случае на экране появляется строка формулы), а слева от названия пункта появляется метка. Повторный щелчок на таком пункте отключает режим и убирает метку.

  • Два верхних пункта меню Вид (View) — Обычный (Normal) и Разметка страницы (Page Break Preview) — являются примером переключателя с несколькими (в данном случае двумя) положениями. Щелкнув на таком пункте, можно выбрать одно из нескольких состояний. Значок в виде . нажатой кнопки показывает, какое состояние является активным.

  • В правой части названий некоторых команд в качестве подсказки приводится клавиатурная комбинация (например, Ctrl+V для команды Правка > Вставить (Edit > Paste)), с помощью которой можно быстро выполнить данную команду.

  • Если рядом с именем команды присутствует значок (см. команду Во весь экран (Full Screen)), значит, в одной из панелей инструментов имеется кнопка быстрого выбора этой команды.

  3. Потренируйтесь в раскрытии подменю, выборе тех или иных команд, включении и выключении режимов.

  4. Строку меню, как и панель инструментов, можно перетащить в любое место экрана. Схватите ее мышью за расположенную слева вертикальную черту и перетащите в новое положение. Меню (и панели инструментов) можно переместить к любому краю окна либо разместить в середине окна приложения (рис. 4.3), где оно выглядит как небольшое окно с заголовком.

Рис. 4.3. Перестановка меню и панелей инструментов


Упражнение 2. Панели инструментов

Панели инструментов, как правило, располагаются вдоль верхнего края окна ниже строки меню и содержат значки, щелчки на которых приводят к выполнению тех или иных операций. Как и пункты меню, различные кнопки панелей инструментов ведут себя по-разному.

  1. В программе Excel щелкните на кнопке Создать (New) панели инструментов Стандартная (Standard), и сразу же появится новая электронная таблица.

  2. Щелкните на кнопке Открыть (Open) той же панели инструментов. На этот раз откроется окно диалога, позволяющее найти нужный файл. Поскольку панели инструментов Стандартная (Standard) и Форматирование (Formatting) расположены в одной строке, многочисленные кнопки обеих панелей просто не помещаются на экране.

Примечание

Чтобы получить доступ к кнопкам, отсутствующим в данный момент на панели инструментов, щелкните на маленьком треугольнике в правой части панели, и недостающие кнопки появятся в раскрывающейся палитре, как показано на рис. 4.4.

  3. Щелкните на черном треугольнике в правой части панели инструментов Стандартная; (Standard).

  4. Щелкните на кнопке Рисование (Drawing). В нижней части окна появится одноименная панель инструментов. Указанная кнопка играет роль флажка. Повторный щелчок на ней скроет панель Рисование (Drawing). Обратите внимание, что теперь кнопка Рисование (Drawing) переместилась в основную часть панели инструментов.

Рис. 4.4. Палитра дополнительных кнопок

Примечание

В Office XP кнопки панелей инструментов ведут себя разумно. Если на экран не помещаются все кнопки, то в панели остаются только те, которыми вы пользуетесь чаще всего. Остальные значки перемещаются в раскрывающуюся палитру дополнительных кнопок. Выбор значка дополнительной палитры возвращает его в основную панель.

  5. Чтобы открыть или скрыть определенную панель инструментов, раскройте меню Вид (View) и укажите на пункт Панели инструментов (Toolbars). В появившемся списке панелей щелкните на имени той, которую нужно отобразить или скрыть.

Рис. 4.5. Список кнопок панели инструментов

Примечание

Список, позволяющий отображать и скрывать панели инструментов, можно вывести на экран простым щелчком правой кнопкой мыши на любой видимой панели инструментов или на строке меню.

  6. Чтобы добавить или убрать кнопку из панели инструментов Форматирование (Formatting), щелкните на черном треугольнике в правой части панели.

  7. В раскрывшейся палитре щелкните на кнопке Добавить или удалить кнопки (Add Or Remove Buttons).

  8. В списке, показанном на рис. 4.5, щелкните на названии той кнопки, которую нужно добавить или убрать. Галочки в этом списке стоят напротив тех кнопок, которые в данный момент присутствуют в панели инструментов. Другие панели настраиваются аналогично.

  9. В панели инструментов Рисование (Drawing) щелкните на кнопке Автофигуры (Autoshapes).

  10. Укажите на пункт Линии (Lines). Как видно из рис. 4.6, часть кнопок панелей инструментов позволяет раскрывать вложенные меню, что лишний раз указывает на схожесть панелей инструментов и строки меню приложения.

  11. Некоторые кнопки устроены еще сложнее. Щелкните на кнопке Цвет заливки (Fill Color) панели инструментов Рисование (Drawing). Текущая ячейка немедленно закрасится другим цветом.

Рис. 4.6. Меню в панели инструментов

  12. Теперь щелкните на стрелке справа от этой кнопки. Раскроется палитра цветных кнопок, позволяющих не только залить ячейку другим цветом, но и изменить цвет, назначаемый щелчком на самой кнопке Цвет заливки (Fill Color). По мере знакомства с Office XP вы обнаружите множество таких сложных кнопок.

  13. Наконец, в панели инструментов могут размещаться раскрывающиеся списки. Щелкните на списке Размер (Font Size) панели инструментов Форматирование (Formatting) и выберите значение 20. Теперь вводимые символы будут иметь новый размер.


Поиск и выделение объектов

Редактируя содержание документа, пользователь имеет дело с текстом, числами, графическими и другими объектами. Очень часто содержимое документа не помещается па экране целиком, и пользователю приходится листать его в поисках нужного материала. Чтобы отыскать определенный фрагмент в многостраничном документе, часто необходимы специальные инструменты Office.


Упражнение 3. Прокрутка документа и поиск

Поучитесв перемещаться по документу и выполнять поиск определенных объектов с помощью следующих шагов.

Рис. 4.7. Инструменты навигации

  1. Выберите в главном меню пункт Создать документ Office (New Office Document).

  2. Щелкните на вкладке Отчеты (Reports), а затем дважды на значке Современный отчет (Professional Reports). Запустится Word, и в нем будет создан новый документ, показанный на рис. 4.7.

  3. Для перемещения вверх и вниз по документу щелкайте на стрелках полосы прокрутки основной панели либо нажимайте клавиши Page Up и Page Down.

  4. Для перехода на одну страницу вверх или вниз щелкайте на кнопках Предыдущая страница (Previous Page) или Следующая страница (Next Page).

  5. Чтобы сместиться сразу на несколько страниц, перетаскивайте ползунок полосы прокрутки. При этом рядом с ним будет появляться номер страницы, определяемый текущим положением ползунка.

  6. Для перехода к определенному разделу документа щелкните на заголовке этого раздела в панели схемы документа. Эта панель тоже имеет полосу прокрутки, с помощью которой можно пролистывать содержание документа.

  7. Если требуется найти в документе определенный текст, выберите команду Правка > Найти (Edit > Find). Откроется окно диалога, показанное на рис. 4.8.

  8. Введите в поле Найти (Find What) число 15.

Рис. 4.8. Окно поиска и найденный фрагмент

  9. Щелкните на кнопке Найти далее (Find Next). Word начнет просматривать документ, начиная от текущей позиции текстового курсора, найдет первое вхождение числа 15 и выделит его (см. рис. 4.8).

  10. Чтобы возобновить поиск и обнаружить все вхождения числа 15 в документ, продолжайте щелкать на кнопке Найти далее (Find Next).

  11. Отыскав нужные фрагменты, щелчком на кнопке Отмена (Cancel) закройте окно диалога поиска.

Мы рассмотрели приемы навигации и поиска на примере документа Word. Остальные приложения Office имеют сходные инструменты перемещения по документу. В PowerPoint и FronPage есть, соответственно, панели содержания и списка файлов, похожие на панель схемы документа Word. Окна диалога поиска варьируются в зависимости от специфики приложения, но приемы работы с ними сходны во всех программах Office.

Примечание

Окна диалога, подобные окну поиска, можно оставлять открытыми и одновременно выполнять другие операции (в отличие от большинства окон диалога, блокирующих все остальные действия). Это позволяет редактировать найденные фрагменты, а затем оперативно продолжать поиск.


Упражнение 4. Выделение, удаление и замена

На первом занятии были рассмотрены простейшие приемы ввода текста. В реальной работе часто приходится переставлять целые слова, абзацы, страницы и блоки данных. Для осуществления подобных операций необходимо указать программе тот фрагмент, который нужно копировать или переместить, то есть выделить его. Это делается так.

  1. Щелчком поместите курсор в начало выделяемого фрагмента (перед первой буквой выделяемого текста или перед выделяемым графическим объектом).

  2. Нажмите клавишу Shift и, не отпуская ее, нажимайте клавиши вправо, вниз. и Page Down до тех пор, пока не подсветится нужная часть документа.

  3. Чтобы удалить выделенный фрагмент, нажмите клавишу Delete. Чтобы заменить его другим текстом или рисунком, просто начните вводить новый текст или вставьте соответствующий рисунок. В момент ввода нового содержимого выделенный фрагмент автоматически удаляется. С помощью указанного алгоритма действительно можно выделить любой блок данных. Однако Office предлагает дополнительные приемы выделения, значительно убыстряющие работу. Для выделения фрагмента в непрерывном текстовом блоке (в документе Word, на слайде PowerPoint, в отчете Access, в электронном сообщении Outlook или на web-странице Frontpage) пользуйтесь следующими приемами:

  • чтобы выделить слово, дважды щелкните на нем;

  • для выделения абзаца трижды щелкните на нем;

  • чтобы выделить строку или пункт структуры, щелкните слева от нее, а для выделения нескольких строк нажмите кнопку мыши слева от первой из них и протащите мышь вниз;

  • протаскиванием указателя по тексту можно быстро выделить несколько слов;

  • чтобы выделить рисунок, диаграмму или другой внедренный объект, просто щелкните на нем.

Теперь потренируйтесь в выделении блоков ячеек таблиц Word, Excel, PowerPoint и Access.

  4. Запустите Access и откройте базу данных, созданную на втором занятии.

  5. В левой панели окна базы данных щелкните на кнопке Таблицы (Tables), а затем дважды щелкните на значке Таблица данных. Откроется окно таблицы, показанное на рис. 4.9.

  6. Щелчками на кнопках столбца, строки и таблицы попробуйте выделить соответствующие фрагменты и целую таблицу.

  7. Щелкните в любой ячейке второй строки.

  8. Нажмите клавишу Shift и щелкните на кнопке четвертой строки. Будут выделены три строки, с первой по четвертую. Аналогичным образом можно выделить несколько смежных столбцов.

Примечание

Таблицы Word и PowerPoint не имеют кнопок для строк и столбцов. Для выделения фрагментов в этих таблицах следует щелкать на воображаемых кнопках, расположенных сверху и слева от ячеек таблицы.

Рис. 4.9. Выделение ячеек таблицы

  9. Чтобы выделить блок смежных ячеек, подсвеченный на рис. 4.9, щелкните в левой верхней ячейке блока.

  10. Нажмите клавишу Shift и щелкните в правой нижней ячейке блока. В предыдущем упражнении вы познакомились с окном диалога поиска. Приложения Office позволяют не только искать, но и автоматически заменять одни фрагменты текста другими. Предположим, оказалось необходимым заменить в тексте большого документа часто встречающуюся величину 15% на 17%. Для этого достаточно выполнить следующие шаги.

  11. Перейдите к документу Word, показанному на рис. 4.7, и выберите команду Правка > Заменить (Edit > Replace). Откроется окно диалога, показанное на рис. 4.10.

  12. В ноле Найти (Find What) введите 15%.

  13. В поле Заменить на (Replace with) введите 17%.

  14. Щелкните на кнопке Найти далее (Find Next), в документе будет найдено и выделено первое вхождение текста 15%.

  15. Чтобы заменить его на 17%, щелкните на кнопке Заменить (Replace). Word выполнит замену и автоматически отыщет следующий фрагмент 15%.

  16. Если какой-то из найденных фрагментов нужно оставить без изменения, просто щелкните на кнопке Найти далее (Find Next).

Рис. 4.10. Окно диалога замены текста

  17. Если вы уверены, что нужно заменить абсолютно все вхождения текста 15% на 17%, щелкните на кнопке Заменить все (Replace All). Будьте внимательны, после этого в тексте не останется ни одного фрагмента 15%.

Вид окна диалога замены, так же как и элементы окна поиска, варьируется от приложения к приложению, но основные его инструменты работают одинаково во всех программах.


Редактирование содержания

В предыдущих упражнениях вы научились отыскивать и выделять фрагменты документов. Операции вырезания, копирования и вставки, доступные в любом приложении Office, равно как и практически в любой другой программе Windows, позволяют переносить и дублировать блоки документов с помощью буферов обмена Office XP if Windows.


Упражнение 5. Вырезание, копирование и вставка

Операции вырезания, копирования и вставки используются настолько часто, что разработчики программ Office предоставили сразу несколько способов выполнения этих команд.

Рис. 4.11. Вырезание фрагмента с помощью меню Правка

  1. Запустите Word и откройте документ, созданный на первом занятии (см.рис. 1.12).

  2. Выделр1те второе и третье предложение, как показано на рис. 4.11.

  3. Выберите в меню Правка (Edit) команду Вырезать (Cut). Выделенный текст исчезнет. Но не беспокойтесь, он не пропал навсегда, а переместился в буфер обмена, откуда его можно вставить в любое место документа и даже в окно другого приложения.

  4. Щелчком переместите курсор правее таблицы и нажмите клавишу Enter.

  5. В панели инструментов Стандартная (Standard) щелкните на кнопке Вставить (Paste). Вырезанный фрагмент появится ниже таблицы (рис. 4.12).

Рис. 4.12. Кнопки редактирования содержания

  6. Выделите весь текст, протащив указатель мыши слева от него (см. рис. 4.12).

  7. Щелкните на выделенном фрагменте правой кнопкой мыши и выберите в контекстном меню команду Копировать (Copy). Вид документа не изменится, однако выделенный блок попадет в буфер обмена.

  8. Запустите Outlook и щелкните на кнопке Создать (New) панели инструментов. Откроется окно нового сообщения.

  9. Щелкните в текстовой области сообщения.

  10. Щелкните на кнопке Вставка (Insert) панели инструментов Стандартная (Standard).пpилoжeния. Текст, скопированный из документа Word, будет вставлен в сообщение Outlook, как показано на рис. 4.13. Теперь документ, подготовленный в Word, можно отправить адресату по электронной почте.

Таким образом, приложения Office поддерживают четыре способа вырезания, вставки и копирования фрагментов. Соответствующие команды имеются в меню Правка (Edit) и в контекстном меню. Кнопки команд редактирования содержания всегда можно найти на панели инструментов Стандартная (Standard). Кроме того, те же команды можно выполнить нажатием следующих клавиатурных комбинаций:

  • вырезать — Ctrl+X или Shift+Delete;

  • копировать — Ctrl+C или Ctrl+Insert;

  • вставить — CtrL+V или Shift+Insert.

Рис. 4.13. Вставка текста в другое приложение


Упражнение 6. Буфер обмена Office и отмена операций

Многочисленные пользователи Windows давно отметили тот недостаток, что в буфере обмена может храниться только один фрагмент. До недавнего времени единственной возможностью одновременного хранения нескольких блоков данных было перетаскивание фрагментов на рабочий стол. Этот прием вы изучили на третьем занятии. Но работа с такими фрагментами неудобна, поскольку рабочий стол обычно скрыт за окнами приложений. Только в Office 2000 наконец появился буфер обмена с несколькими ячейками.

Примечание

Office XP предлагает пользователю расширенный буфер обмена, способный одновременно вместить до 24 фрагментов.

В Office XP буфер обмена оформлен в виде окна, встроенного в область задач. Чтобы использовать его возможности, выполните следующие шаги.

  1. Переключитесь в документ Word, открытый в предыдущем упражнении, выделите первую строку и нажмите клавиши Ctrl+Insert. Выделенный текст скопируется в буфер обмена.

  2. В окне документа справа в области задач появится окно буфера обмена, показанное на рис. 4.14, в котором вы увидите скопированный фрагмент.

Рис. 4.14. Панель буфера обмена

  3. Выделите вторую строку текста и щелкните на кнопке Копировать (Copy) панели инструментов приложения. Выделенный фрагмент будет помещен в окне буфера обмена над первым фрагментом.

  4. Запустите Microsoft Excel и введите в первые несколько ячеек числа в соответствии с рис. 4.15. Выполните команду Правка > Буфер обмена (Edit > Clipboard). В открывшемся в области задач окне буфера будут присутствовать фрагменты, скопированные из документа Word.

  5. Щелкните на кнопке Start (Пуск) и выберите команду Программы > Стандартные > Блокнот (Programs > Accessories > Notepad).

  6. В окне Блокнота введите текст Заголовок электронной таблицы.

  7. Выделите слово таблицы и выберите команду Правка > Копировать (Edit > Copy).

  8. Выберите команду Правка > Выделить все (Edit > Select All), а затем нажмите клавиши Ctrl+X.

Эти операции должны были поместить в стандартный буфер обмена Windows сначала слово таблицы, а затем вырезать в него всю строку Заголовок электронной таблицы, заменив при этом предыдущее содержимое буфера. Что же произошло с буфером Office XP?

Рис. 4.15. Буфер обмена Office 2000 в окне Excel

  9. Нажатием клавиш Alt+Tab переключитесь в окно Excel. Обратите внимание, в буфер обмена Office XP попали фрагменты приложения Windows, не входящего в пакет Office XP. Таким образом, буфер обмена Office XP можно использовать для хранения нескольких фрагментов любого приложения Windows.

Примечание

Не спешите радоваться. К сожалению, вставлять фрагменты из буфера Office XP можно только в приложения Office XP, но не в другие программы Windows. Поэтому возможность хранения в буфере Office нескольких фрагментов из других программ Windows полезна только в тех случаях, когда планируется размещать эти фрагменты в документах Office.

  10. В окне Excel щелкните в ячейке ВЗ и нажмите клавиши Ctrl+Insert. Панель буфера обмена расширится, содержимое ячейки ВЗ появится в верхней строке буфера обмена.

  11. Щелкните в ячейке В4.

  12. Нажмите клавишу Shift и щелкните в ячейке Е6.

  13. Щелкните на кнопке Копировать (Copy) панели инструментов Стандартная (Standard). Теперь буфер обмена выглядит так, как показано па рис. 4.15. Мы научились копировать и вырезать фрагменты в буфер обмена Office. Но это только полдела. Как же перенести данные обратно из буфера обмена в документ Office?

  14. Щелкните в электронной таблице в ячейке А1.

  15. В панели буфера обмена щелкните на четвертом значке. Надпись, вырезанная из блокнота, появится в Excel. Таким образом, чтобы вставить фрагмент из буфера обмена в точку курсора документа Office, достаточно просто щелкнуть на значке нужного фрагмента. Обратите внимание на значок вставки, появившийся рядом со вставленным 4фагментом. Если вы задержите указатель мыши на этом значке, то в раскрывающемся списке можете выбрать один из предлагаемых параметров вставки: Сохранить форматы оригинала (Keep Source Formatting) или Использовать форматы конечных ячеек (Match Destination Formatting).

  16. Если вы ошиблись и вставили не тот фрагмент, просто нажмите клавиши Ctrl+Z. Все вернется к прежнему состоянию, и операцию вставки можно будет повторить. Нажатие клавиш Ctrl+Z, выполнение команды Правка > Отменить (Edit > Undo) или щелчок на кнопке Отменить (Undo) панели инструментов Стандартная (Standard) приводят к отмене последней операции. Приложения Office поддерживают многоуровневую отмену, поэтому, нажимая Ctrl+Z, можно вернуться назад на несколько шагов.

  17. Переключитесь в Word.

  18. Выделите в документе надпись Геркулес и нажмите клавиши Ctrl+C.

  19. Скопируйте в буфер обмена еще семнадцать (фрагментов из Word и Excel. Теперь заняты все ячейки буфера обмена. Что же произойдет, если скопировать еще один фрагмент? Попробуйте сделать это. Данная операция приведет к удалению из буфера обмена первого, самого старого фрагмента.

  20. Переключитесь в окно Word и щелкните на кнопке Создать (New) панели инструментов Стандартная (Standard). Откроется новый документ.

  21. В окне буфера обмена щелкните на пункте Вставить все (Paste All). Содержимое всех ячеек будет вставлено в документ Word последовательно друг за другом.

  22. Если данные буфера обмена устарели, щелкните на пункте Очистить все (Clear All) в верхней части окна буфера обмена. Все фрагменты будут удалены из буфера. Отдельный фрагмент может быть удален из буфера выбором команды Удалить (Delete) в раскрывающемся списке, который появляется, если щелкнуть на маленьком треугольнике справа от соответствующего фрагмента. Указанная операция очищает и буфер обмена Windows.

Осталось разобраться с тем, как буфер обмена Office взаимодействует с буфером обмена Windows. Запомните два следующих правила. Если последней выполнялась команда вырезания или копирования, в буфер Windows запишется объект, вырезанный или скопированный этой операцией. Если последней выполнялась операция вставки не последнего фрагмента буфера обмена Office XP, то этот фрагмент оказывается в буфере обмена Windows.


Справочная система

В Microsoft Office реализовано несколько способов получения справочной инфор-мации:0ни одинаковы для всех приложений Office. Справочная система позволяет быстро разрешить возникшие проблемы. Ею можно пользоваться и как учебником или справочником. Ниже представлен список основных ее компонентов.

  • Помощник по Office — интерактивный инструмент, позволяющий вводить вопросы и выбирать ответ из списка тем, близких к сути заданного вопроса. Часто Помощник по Office пытается сам понять источник возникших трудностей и'периодически предлагает пользователю полезные подсказки.

  • Окно справочной системы — база данных с возможностями поиска информации по названию темы или по ключевому слову.

  • Что это такое? — инструмент, позволяющий указать элемент окна диалога и получить краткое описание назначения выбранного объекта.

  • Microsoft на Web — система поиска справочной информации на web-страницах компании Microsoft.


Упражнение 7. Получение справки

В этом упражнении мы не будем рассматривать вопросы поиска справки в Интернете. Навигация но web-страницам — это отдельная большая тема. Если вы хотите научиться ориентироваться в Интернете, прочтите книгу А. Денисова, А. Белова, И. Вихарева «Интернет. Самоучитель» («Питер», 2001). Сейчас вам предлагается изучить три локальных компонента справочной системы. Давайте посмотрим, что скажет эта справочная система Office о новом буфере обмена.

Рис. 4.16. Помощник по Office

  1. Запустите Microsoft Access и откройте ту базу данных, которая уже использовалась на этом занятии. Если пакет Office XP был установлен стандартным образом, то вы наверняка уже встречались с Помощником по Office, который обычно появляется в правом нижнем углу окна.

  2. Если Помощника нет, щелкните в панели инструментов на кнопке Справка по Microsoft Access (Microsoft Access Help) или на аналогичной кнопке в любой другой программе Office. В правом нижнем углу появится забавная фигурка Помощника по Office, которая сразу предложит вам список советов и откроет доступ к полю ввода вопросов, как показано на рис. 4.16. Если Помощник уже присутствует на экране, то для открытия-того же самого списка советов достаточно щелкнуть на фигурке Помощника, на указанной выше кнопке панели инструментов или нажать клавишу F1.

  3. Иногда Помощник бывает достаточно назойлив. Если вы не нуждаетесь в частых советах, щелкните на фигурке Помощника правой кнопкой мыши и выберите в контекстном меню команду Параметры (Options). Откроется окно диалога, позволяющее настроить поведение Помощника (рис. 4.17).

Рис. 4.17. Параметры Помощника

Примечание

Чтобы совсем убрать Помощника, выберите в контекстном меню Помощника команду Скрыть (Hide).

  4. В окне параметров Помощника так же, как и в любом другом окне диалога, можно воспользоваться контекстной справкой, объясняющей назначение элементов окна. Для этого щелкните на кнопке с вопросительным знаком, расположенной в правой части заголовка окна. Рядом со стрелкой указателя-мыши появится большой вопросительный знак.

  5. Щелкните на любом переключателе, поле или другом элементе окна диалога, например на флажке 0 сочетаниях клавиш (Keyboard Shortcuts). Появится всплывающая подсказка с кратким описанием выбранного элемента интерфейса.

  6. Щелчком на кнопке О К закройте окно параметров.

  7. Щелкните на фигурке Помощника, введите в поле вопроса слова Буфер обмена (Clipboard)" и нажмите клавишу Найти (Find). Помощник покажет список тем, связанных с введенным ключевым словом. [Работая с английской версией Office, нужно вводить вопросы и ключевые слова на английском языке. В русской версии, естественно, нужно будет пользоваться русским языком.]

  8. Найдите тему, наиболее точно соответствующую вашему вопросу, и щелкните на ней. Обратите внимание на стрелку См. далее (See more). Она позволяет вывести продолжение списка тем. Я выбрал пункт Копирование и вставка нескольких объектов. Откроется окно справочной системы. Навигация по страницам этой базы данных подобна поиску информации в Интернете. Чтобы найти нужную справку, следует щелкать на гиперссылках (подчеркнутых фрагментах текста) и внимательно читать текст очередной страницы. Рано или поздно вы отыщете ответ на свой вопрос.

  9. Если вас постигла неудача и найти нужную информацию не удалось, не отчаивайтесь. Щелкните в панели инструментов окна справочной системы на кнопке Показать (Show). Окно увеличится, в нем появится дополнительная область.

Ниже дано описание трех вкладок окна справочной системы.

  • Содержание (Contents)— содержит оглавление справочной системы Office в виде иерархического дерева папок, перемещаясь по которому можно добраться до любой страницы справочной системы.

  • Мастер ответов (Answer Wizard) — позволяет ввести вопрос и отыскать страницы справочной системы, в той или иной мере раскрывающие тему вопроса.

  • Указатель (Index) — предлагает ввести или выбрать в списке ключевое слово, нбсле чего щелчок на кнопке Найти (Search) инициирует вывод списка страниц справочной системы, содержащих выбранное слово. Щелчок на названии страницы выводит соответствующую информацию в правую панель окна справочной системы.

Примечание

В приложениях Microsoft Office XP нет необходимости вызывать справочную систему, чтобы воспользоваться мастером ответов. В правой части строки меню окна приложения имеется Окно вопроса. Введите туда интересующий вас вопрос и нажмите клавишу Enter. Вы увидите перечень пунктов Справки, имеющих отношение к данной теме.


Контрольное упражнение

Давайте проверим, насколько хорошо вы освоили общие приемы работы с приложениями Office.

  1. Запустите Access, откройте базу данных, созданную на втором занятии, затем откроите таблицу данных.

  2. Щелчком на кнопке в левом верхнем углу таблицы выделите все данные.

    • Как с помощью меню выделить весь документ ?

  3. Скопируйте выделенные данные.

  4. Создайте новый документ Excel и откройте второй лист книги Excel.

  5. Вставьте в него скопированную таблицу данных.

  6. С помощью Помощника по Office найдите в справочной системе страницы, описывающие тему Вставка.

    • Какая команда меню позволяет задать вопрос справочной системе Office?

  7. Откройте наиболее интересную из них и выведите ее на принтер.

    • Как распечатать текущую страницу справки ?

  8. Сохраните новый документ Excel.

  9. Переключитесь в Access и удалите выделенные данные.

    • Как восстановить данные, удаленные из таблицы Access?

  10. Закройте все приложения.


Подведение итогов

Это занятие завершает первую часть, к которой рассматривались общие черты приложений Office XP и взаимодействие этих программ с операционной системой Windows. Далее вы научитесь выполнять более сложные операции в конкретных программах. Не забывайте, что все шесть компонентов пакета Office тесно взаимосвязаны, поэтому многие приемы, описываемые при изучении одного приложения, можно реализовать и в других программах даже в тех случаях, когда нет явного указания такой возможности. Действительно, иногда кажется, что проще описать различия программ Office, чем перечислить все их общие черты.

Следующая часть книги посвящена описанию Microsoft Word — одного из самых мощных текстовых процессоров.


ЧАСТЬ II

Word

Microsoft Word XP — один из лучших текстовых редакторов. Он позволяет создавать и редактировать документы, добавлять в них таблицы и рисунки, изменять оформление абзацев и начертание шрифта, готовить документ к печати. Дополнительные модули Word позволяют выполнять такие операции, как проверка орфографии и грамматики, формирование оглавлений и указателей, слияние с базой данных.

Создание и разметка документа

ТЕМА ЗАНЯТИЯ

Вторая часть книги посвящена описанию приложения Word — мощного текстового процессора. На этом занятии вы познакомитесь с шаблонами документов, научитесь экспортировать файлы Word в формат HTML и познакомитесь с четырьмя режимами просмотра документов, которые перечислены ниже:

  • обычный режим;

  • разметка страницы;

  • структура документа;

  • электронный документ.

Современную жизнь нельзя представить без обилия текстовых документов в бумажном и электронном виде. Word XP — это современная версия популярного текстового процессора, позволяющая писать письма, форматировать тексты любой сложности, добавлять в них рисунки, формулы и графики и даже верстать целые книги. Сегодня формат документов Word стал общепризнанным. Вы можете отправить такой документ по электронной почте в любую точку земного тара, и практически везде его смогут прочесть.

Создание документа

В первой части книги вы уже научились создавать и открывать простейшие документы Word. Сейчас пришло время познакомиться с шаблонами и мастерами, генерирующими стандартное содержание и общее оформление документов. Наличие такого предварительно настроенного документа облегчает процесс ввода конкретного текста.

Упражнение 1. Шаблоны

Шаблоны можно рассматривать как обычные документы Word, в которых кроме текста и списка стилен хранится информация о конфигурации панелей инструментов, макросы и параметры, определяющие вид документа и поведение программы. Шаблоны очень удобны, когда ряд документов требуется оформить в одинаковом стиле. Однажды настроив шаблон, вы создаете на его основе несколько файлов, которые наследуют имеющиеся в шаблоне текст и объекты, стили и оформление, макросы и параметры интерфейса Word. Вспомните, что на предыдущих занятиях мы уже пользовались стандартными шаблонами Office, теперь давайте создадим свой собственный шаблон.

  1. Откройте документ, созданный на первом занятии. Удалите из него весь текст, таблицу Excel и рисунок кактуса. На странице останется только надпись Геркулес и горизонтальная линия.

  2. Выберите команду Файл > Сохранить как (File > Save As). Откроется окно диалога Сохранение документа (Save As), показанное на рис. 5.1.

  3. В раскрывающемся списке Тип файла (Save As Type) выберите пункт Шаблон документа (Document Template).

  4. В левой панели окна сохранения файла щелкните на кнопке Мои документы (My Documents).

  5. В панели инструментов щелкните на кнопке Создать папку (Create New Folder).

  6. В открывшемся окне диалога введите текст Шаблоны.

  7. Щелкните на кнопке ОК.

  8. В поле Имя файла (File Name) введите Here.

  9. Щелкните на кнопке Сохранить (Save).

Рис. 5.1. Сохранение шаблона

  10. Выберите команду Файл > Закрыть (File > Close), чтобы закрыть окно шаблона. Теперь у вас есть шаблон с заголовком Геркулес, сохраненный в специальной папке.

  11. Чтобы указать программе Word, где следует искать шаблоны пользователя, выберите команду Сервис > Параметры (Tools > Options).

Рис. 5.2. Пути к служебным файлам

  12. Щелкните в открывшемся окне диалога на вкладке Расположение (File Locations). На этой вкладке, показанной на рис. 5.2, хранится информация об именах, некоторых специальных папок, в том числе и имя папки шаблонов польаователя.

  13. Щелкните на строчке Шаблоны пользователя (User Templates).

  14. Затем щелкните на кнопке Изменить (Modify). Откроется окно диалога, которое очень похоже на окно сохранения файлов, но предназначено для выбора папки.

  15. Щелкните в левой панели этого окна на кнопке Мои документы (My Documents), затем в основной области окна диалога дважды щелкните на недавно созданной папке Шаблоны.

  16. Щелкните на кнопке ОК. Вы вернетесь на вкладку Расположение (File Locations), но теперь в строке Шаблоны пользователя (User Templates) указана правильная папка.

  17. Снова щелкните на кнопке ОК, чтобы закрыть окно параметров.

  18. Теперь попробуйте создать на базе построенного шаблона новый документ. Выберите команду Файл > Создать (File > New). В правой стороне экрана появляется окно Создание документа (New Document) области задач. В разделе Создание с помощью шаблона (New from Template) перечислены недавно используемые шаблоны и ряд стандартных шаблонов. Щелкните на значке Общие шаблоны (General Templates). Значок шаблона Here появился в окне диалога Шаблоны (Templates), как показано на рис. 5.3. Сюда кроме стандартных шаблонов выводятся значки всех файлов с расширением .dot, записанных в папку с шаблонами пользователя.

Рис. 5.3. Выбор шаблона документа

  19. С помощью переключателя Создать (Create New) выберите тип создаваемого 4:>айла. Положение Документ (Document) соответствует созданию обычного текстового документа, а Шаблон (Template) позволяет создать новый шаблон.

  20. Дважды щелкните на значке Here. Откроется новый документ, в котором сразу появится большая надпись Геркулес, как показано на рис. 5.4. Теперь, пользуясь новым шаблоном, вы можете быстро добавлять такие надписи в начало каждого документа гипотетической компании Геркулес, и все они будут точными копиями заголовка, хранящегося в шаблоне.

Рис. 5.4. Документ, построенный на базе шаблона пользователя

Следует заметить, что так называемый «Обычный документ», который создается щелчком на кнопке Создать (New) панели инструментов или выбором значка Новый документ (Blanck Document) в разделе Создание документа (New) окна области задач, на самом деле тоже построен на основе шаблона. Этот шаблон записан в файле Normal.dot, который хранится в папке C:\Microsoft Office\Templates [ Предполагается, что пакет Office 2002 был установлен в папку Microsoft Office диска С:.]. Шаблон NormaLdot играет важную роль. Он определяет исходную конфигурацию Word, т. е. вид и поведение программы при ее запуске.

Примечание

Если вы обнаружили, что Word выглядит как-то странно или работает неверно, попробуйте закрыть программу и удалить файл Normal.dot. При следующем запуске Word этот шаблон будет сгенерирован заново в соответствии со стандартной конфигурацией, заложенной в Word разработчиками программы.

Упражнение 2. Мастер создания документа

Создавая документ с помощью мастера, вы имеете дело как бы с интеллектуальным шаблоном, который может менять свою конфигурацию в соответствии с конкретными запросами пользователя. Мастера часто вставляют в документ специальные макросы — небольшие программы, автоматизирующие ввод текста. На предыдущих занятиях вы уже не раз пользовались мастерами. Давайте детально познакомимся с возможностями этих помощников на примере одного из них — мастера профессионально оформленного резюме.

  1. Выберите команду Файл > Создать (File > New). В окне диалога Создание документа (New Document) области задач в разделе Создание с помощью шаблона (New From Template) щелкните на значке Общие шаблоны (General Templates). В появившемся окне диалога Шаблоны (Templates) раскройте вкладку Другие документы (Other Documents) и дважды щелкните на значке Мастер резюме (Resume Wizard). Откроется первое окно мастера, описывающее назначение запущенного модуля.

Примечание

Обратите внимание, что значки мастеров отличаются от значков обычных шаблонов наличием изображения волшебной палочки.

  2. Щелкните на кнопке Далее (Next).

  3. Во втором окне мастера, показанном на рис. 5.5, установив переключатель в правое положение, выберите для своего резюме изысканный стиль. Затем щелкните на кнопке Далее (Next).

Рис. 5.5. Второе окно мастера резюме

  4. В следующем окне выберите положение переключателя Профессиональное (Professional CV) и снова щелкните на кнопке Далее (Next).

Примечание

В нижней части окна любого мастера Office XP есть пять кнопок. Две из них — Далее (Next) и Назад (Back) позволяют перемещаться по окнам мастера. Если вы ошиблись или решили поменять данные, введенные ранее, щелкая на кнопке Назад (Back), вернитесь к одному из предыдущих окон и скорректируйте параметры мастера. При этом нет нужды заново повторять всю процедуру. Кнопка Отмена (Cancel) позволяет в любой момент прервать работу мастера. Кнопка Готово (Finish) инициирует генерацию результата на базе уже введенных данных. Наконец, кнопка с вопросительным знаком позволяет получить справку.

  5. В двух следующих окнах введите свое имя, адрес, телефоны и укажите, какую информацию о вас следует включать в резюме.

  6. В шестом окне мастера, показанном на рис. 5.6, установите флажки, соответствующие тем разделам, которые должны быть включены в резюме.

Рис. 5.6. Шестое окно мастера резюме

  7. Щелкните на кнопке Далее (Next).

  8. В следующем окне укажите, какие дополнительные разделы следует включать в документ, а с помощью последнего из информативных окон добавьте при необходимости разделы, не предусмотренные разработчиками мастера. Щелкните на кнопке Далее (Next).

  9. В последнем окне мастера, информирующем о том, что все готово для создания документа, щелкните на кнопке Готово (Finish). Мастер сгенерирует документ, показанный на рис. 5.7. В нем появятся введенные вами данные и дополнительные поля, которые можно заполнить позже.
  10. Сохраните это резюме в папке Мои документы (My Documents) под именем Резюме. Теперь вы умеете строить документы на базе шаблонов и наполнять их информацией с помощью мастеров. Однако иногда случается так, что текстовое содержание уже имеется в обычном текстовом файле ASCII, например, полученном по электронной почте. Такой текст легко импортируется в Word, где его можно оформить с помощью мощных возможностей этого текстового редактора. Чтобы открыть ASCII-текст формата DOS, выполните следующие шаги.
  11. Выберите команду Файл > Открыть (File > Open).
  12. В раскрывающемся списке Тип файлов (Files Of Types) окна диалога Открытие документа (Open) выберите пункт Текстовые файлы (Text Files) или Все файлы (All Files).

Рис. 5.7. Документ, сгенерированный мастером

  13. Найдите текстовый файл и дважды щелкните на его значке. Откроется окно диалога Преобразование файла (Convert File), показанное на рис. 5.8.

Рис. 5.8. Выбор варианта преобразования

  14. Выберите пункт Текст MS-DOS (MS-DOS Text).

Примечание

Если окно преобразования не появится, вы не сможете правильно настроить отображение русских букв. В этом случае выберите команду Сервис > Параметры (Tools > Options) и на вкладке Общие (General) установите флажок Подтверждать преобразование при открытии (Confirm Conversion At Open). Затем повторите импорт текстового файла.

  15. Щелкните на кнопке ОК. Текст DOS будет преобразован в формат Windows. При импорте файлов другого формата выбирайте в окне диалога Преобразование файла (Convert File) нужный вариант преобразования.

Режимы просмотра

В Microsoft Word один и тот же документ можно отображать в четырех перечисленных ниже режимах просмотра.

  • Обычный (Normal View) — предназначен для ввода и форматирования текста, отображаемого в виде непрерывной вертикальной полосы.

  • Разметка страницы (Print Layout View) — позволяет оценить расположение текста и объектов относительно физических страниц документа.

  • Структура (Outline View) — служит для задания и редактирования иерархической структуры разделов основного текста, что позволяет полностью отвлечься от графических объектов и реальных размеров страниц и сконцентрировать внимание на содержании.

  • Веб-документ (Web Layout View) — предназначен для формирования web-страниц, для которых характерна неограниченная длина.

Режимы просмотра проще всего переключать с помощью кнопок, расположенных в левом нижнем углу окна документа (рис. 5.9). Не забывайте про наличие разных режимов, всегда работайте в том из них, который лучше соответствует решаемой задаче.

Рис. 5.9. Кнопки режимов просмотра

Упражнение 3. Обычный режим

Создавая или модифицируя текстовый документ, вы чаще всего работаете в обычном режиме просмотра. На рис. 5.10 показан пример документа в этом режиме и основные элементы окна Word. При обычном просмотре документ имеет неограниченную длину, хотя его ширина определяется размером страницы. Разбиение на страницы показано горизонтальными пунктирными линиями. В этом режиме на экране не видны фигуры, рисунки и другие графические объекты.

Рис. 5.10. Документ Word в обычном режиме

Строка состояния Word в любом режиме просмотра выводит одну и ту же информацию, которая помогает ориентироваться в больших документах. В первом слева поле строки состояния видны номер текущей страницы, номер текущего раздела, а далее через дробь — номер текущей страницы и число страниц в документе. Во второе поле выводится расстояние от левого края документа до текущего положения текстового курсора, затем номера текущих строки и столбца.

  1. Откройте любой не очень короткий документ и с помощью команды Вид > Обычный (View > Normal) включите обычный режим просмотра (если текущим является другой режим).

  2. Щелкните на кнопке Схема документа (Document Map). В левой части окна появится панель, демонстрирующая иерархическую структуру разделов документа, как показано на рис. 5.11. Указанная кнопка играет роль флажка. Повторный щелчок на ней скроет панель схемы. Такую панель можно открыть и в любом другом режиме просмотра.

  3. Щелкните в панели схемы документа на одном из пунктов. Текст в основном окне переместится к соответствующему разделу.

Примечание

Раздел характеризуется наличием заголовка, отмеченного специальным стилем. Вы познакомитесь с этими стилями в упражнении 5 этого занятия.

Рис. 5.11. Схема документа

  4. Чтобы прокрутить текст вручную, пользуйтесь кнопками и ползунком вертикальной полосы прокрутки, расположенной в правой части окна. Полоса прокрутки есть и в панели схемы документа.

  5. Щелкните на кнопке Следующая страница (Next Page). Текст в окне переместится к началу следующей страницы. Кнопка Предыдущая страница (Previous Page) выполняет обратную процедуру, прокручивая текст на одну страницу вверх.

  6. Щелкните на кнопке Выбор объекта перехода (Select Browse Object). Откроется показанное на рис. 5.12 окно со значками. Эти значки позволяют изменять функции кнопок Следующая страница (Next Page) и Предыдущая страница (Previous Page).

Рис. 5.12. Выбор объекта перехода

  7. Попробуйте щелкнуть на значке Разделы (Browse By Section). Теперь указанные кнопки будут прокручивать документ соответственно к предыдущему и следующему разделу (а не к странице).

  8. В обычном режиме в верхней части окна может располагаться горизонтальная линейка, позволяющая контролировать горизонтальные отступы. Чтобы показать или скрыть линейку, выберите команду Вид > Линейка (View > Ruler).

  9. Вероятно, вы захотите настроить масштаб отображения текста по своему вкусу. Для этого щелкните на раскрывающемся списке Масштаб (Zoom) панели инструментов Стандартная (Standard) и выберите подходящий масштаб. Чтобы ширина текста в точности равнялась ширине окна, выберите последний пункт По ширине страницы (Page Width).

  10. Выполните команду Вид > Во весь экран (View > Full Screen). Окно Word развернется на весь экран компьютера. При этом исчезнут меню, заголовок окна, панели инструментов, строка состояния и полоса прокрутки. Будет виден только сам документ и кнопка Вернуть обычный режим (Close Full Screen). Такой полноэкранный режим просмотра позволяет целиком сосредоточиться на содержании документа.

  11. Чтобы вернуть исчезнувшие элементы интерфейса, щелкните на кнопке Вернуть обычный режим (Close Full Screen).

Примечание

В полноэкранном режиме можно пользоваться всеми командами меню. Переместите указатель мыши вплотную к верхнему краю экрана, и перед вами появится всплывающая строка меню Word.

  12. Дважды щелкните в любом из двух левых полей строки состояния. Откроется окно перехода к объекту, показанное на рис. 5.13.
  13. В списке Объект перехода (Go To What) выберите тип объекта, который нужно найти, например пункт Страница (Page).

Рис. 5.13. Вкладка перехода окна диалога поиска и замены

  14. В поле Введите номер страницы (Enter Page Number), название которого варьируется в зависимости от выбранного типа объекта, введите номер страницы, к которой нужно перейти. Для перехода вперед или назад на N страниц относительно текущей введите соответственно +N или -N, где N — целое число.
  15. Щелкните на кнопке Перейти (Go To). Документ прокрутится до искомого объекта.

Упражнение 4. Разметка страницы

Режим разметки страниц позволяет видеть документ таким, каким он будет на бумажных страницах, распечатанных на принтере. Здесь в виде белых прямоугольников отображаются страницы документа, на которых наряду с текстом видны абсолютно все объекты, как показано на рис. 5.14. Если документ содержит многочисленные рисунки или графики, с ним удобнее работать именно в режиме разметки страницы.

Рис. 5.14. Режим разметки страницы

Окно режима разметки практически не отличается от окна обычного режима. Но включив отображение линейки, вы кроме горизонтальной линейки увидите еще и вертикальную, которая позволяет оценивать положение объектов на странице по второй координате. Приемы перемещения по документу тоже совпадают в обоих режимах, однако в раскрывающемся списке Масштаб (Zoom) в режиме разметки появляются три дополнительных пункта —По ширине текста (Text Width), Страница целиком (Whole Page) и Две страницы (Two Pages), названия которых не требуют дополнительных пояснений.

Работая в режиме разметки, не спешите расставлять объекты и форматировать текст. Для начала следует настроить размеры страницы и ее полей.

  1. Выберите команду Файл > Параметры страницы (File > Page Setup).

  2. В открывшемся окне диалога щелкните на вкладке Размер бумаги (Paper Size), которая показана на рис. 5.15.

  3. В списке Размер бумаги (Paper Size) выберите тот размер листа, на котором должен печататься документ.

  4. Чтобы задать нестандартный размер, выберите пункт Другой (Custom Size) и введите ширину и высоту страницы в счетчики Ширина (Width) и Высота (Height).

Рис. 5.15. Параметры страницы

  5. После настройки размеров страницы следует указать размеры отступов и выбрать вариант вывода текста на принтер. Для этого раскройте вкладку Поля (Margins), которая показана на рис. 5.16.

  6. В счетчики Верхнее (Тор), Нижнее (Bottom), Левое (Left) и Правое (Right) введите ширину полей страницы.

  7. С помощью переключателя Ориентация (Orientation) окна диалога параметров страницы выберите книжное или альбомное расположение страницы относительно текста.

Рис. 5.16. Настройка полей

  8. Если вы собираетесь печатать документ на обеих сторонах листов, а левый и правый отступы не равны между собой, то в раскрывающемся списке Несколько страниц: (Multiple Pages) выберите Зеркальные поля (Mirror Margins). Это обеспечит правильную расстановку полей. При выборе 2 страницы на листе (2 Pages Per Sheet) на одном листе бумаги будут размещены две страницы. Поле Образец (Preview) отображает текущую раскладку страниц и позволяет визуально проконтролировать введенные параметры.

Примечание

В верхнем и нижнем поле страницы расположены верхний и нижний колонтитулы, в которых размещаются, например, номера страниц или названия текущих разделов документа. Если вы пользуетесь колонтитулами, не делайте верхнее и нижнее поля слишком узкими.

  9. Раскройте вкладку Источник бумаги. В разделе Различать колонтитулы: с помощью соответствующих счетчиков настройте расстояния от края страницы до верхнего и нижнего колонтитулов.
  10. Щелчком на кнопке О К закройте окно диалога параметров страницы.
  11. Поля можно настроить и с помощью линеек. Чтобы увеличить ширину левого поля, поместите указатель мыши на границу серой и белой областей горизонтальной линейки (см. рис. 5.14), нажмите кнопку мыши и перетаскивайте границу поля. Аналогично настраиваются и остальные три поля страницы.
  12. В многостраничном документе, как правило, требуется расстановка номеров страниц. Нет смысла делать это вручную. Word умеет нумеровать страницы автоматически. Выберите команду Вставка > Номера страниц (Insert > Page Numbers). Откроется окно диалога, показанное на рис. 5.17.

Рис. 5.17. Добавление нумерации страниц

  13. С помощью раскрывающегося списка Положение (Position) укажите, должны ли номера страниц располагаться вверху или внизу страницы. В списке Выравнивание (Alignment) выберите нужный режим выравнивания номера в колонтитуле.

  14. Чтобы номер отсутствовал на первой странице документа, сбросьте флажок Номер на первой странице (Show Number On First Page).

  15. Если требуется дополнительное форматирование номеров, щелкните на кнопке Формат (Format) и настройте параметры окна диалога Формат номера (Page Number Format).

  16. Щелчками на кнопках OK закройте все окна диалога. Word автоматически пронумерует страницы документа. При редактировании текста вы сможете выбрасывать и вставлять фрагменты, а также перемещать целые блоки страниц. Word автоматически скорректирует нумерацию и обеспечит правильную последовательность чисел.

  17. Чтобы изменить шрифт номеров страниц и добавить в колонтитулы другую информацию, выберите команду Вид > Колонтитулы (View > Header And Footer). Текст документа станет блеклым, а колонтитулы будут выделены пунктирными прямоугольниками, как показано на рис. 5.18. Кроме того, появится панель инструментов Колонтитулы (Header And Footer).

  18. С помощью полосы прокрутки найдите любой прямоугольник с надписью Верхний колонтитул (Header).

  19. Введите в нем текст Это верхний колонтитул. Теперь в верхнем поле каждой страницы будет выведена такая надпись. Вы скажете, что-подобные заголовки страниц никому не нужны. Да, конечно, это лишь простейший пример. Давайте посмотрим, какие возможности предлагает панель инструментов Колонтитулы (Header And Footer).

Рис. 5.18. Редактирование колонтитулов

  20. Щелкните в прямоугольнике Нижний колонтитул (Footer).

  21. В панели Колонтитулы (Header And Footer) щелкните на кнопке Вставить авто текст (Insert AutoText).

  22. Выберите в раскрывающемся меню пункт Полное имя файла (Filename And Path). Теперь вы не забудете, как называется файл, в котором хранится источник распечатанного текста. Имя этого файла появится в нижнем колонтитуле каждой страницы. Если вы переименуете файл документа или переместите его в другую папку, то при следующем открытии документа в нижнем колонтитуле появится уже новое имя файла. Панель инструментов Колонтитулы (Header And Footer) позволяет-таюке вставлять в колонтитулы дату и время последнего обновления документа, дату печати документа, имя автора и другую информацию.

  23. Чтобы закрыть режим просмотра колонтитулов, щелкните на кнопке Закрыть (Close) панели инструментов Колонтитулы (Header And Footer). Иногда, просмотрев документ в режиме разметки страницы, вы можете остаться недовольны тем, как Word разбил текст на страницы. В этом случае вручную вставьте в текст дополнительные разрывы страниц.

  24. Поместите курсор в ту точку, где должна начинаться новая страница, и выберите команду Вставка > Разрыв (Insert > Break). Откроется окно диалога, показанное на рис. 5.19. В нем верхний переключатель позволяет из трех положений выбрать тип разрыва. Нижний переключатель позволяет вставить метку начала следующего раздела и выбрать, как должен располагаться раздел: с начала следующей страницы, с четной, с нечетной или без разрыва страницы.

Рис. 5.19. Вставка разрыва

  25. Выберите положение переключателя Новую страницу (Page Break).

  26. Затем щелкните на кнопке ОК. Текст правее и ниже курсора будет перенесен в начало следующей страницы, а конец текущей страницы останется пустым.

Режим электронного документа, который включается командой Вид > Веб-документ (View > Web Layout), является как бы комбинацией обычного режима и режима разметки страницы. Электронный документ позволяет видеть все объекты, включая рисунки и графики, перемещать их по документу и изменять их размер. Но в режиме электронного документа нет разбивки на страницы и весь текст отображается в виде бесконечной вертикальной ленты. Здесь нет и вертикальной линейки. Поскольку предполагается, что электронный документ будет публиковаться на web-узле, разработчики Word учли, что web-страницы могут иметь любую длину, а для их просмотра в окне браузера используется вертикальная полоса прокрутки.

Если вы пользуетесь текстовым процессором Word для подготовки web-страниц, вместо режима разметки страниц всегда пользуйтесь режимом электронного документа. В этом случае после преобразования в формат HTML не произойдет потери назначенного форматирования. Например, на web-странице невозможно разместить текст в несколько столбцов (если не пользоваться таблицами), поэтому режим просмотра электронного документа игнорирует такое форматирование, четко следуя стандартам HTML.

Примечание

Запись формата HTML в Office XP выполняется без ошибок, а полученная web-страница точно повторяет вид исходного электронного документа.

Чтобы сформировать web-страницу, достаточно выбрать команду Файл >Сохранить как веб-страницу (File > Save As Web Page) и в окне диалога Сохранение документа (Save As) ввести имя HTML-файла. Полученную web-страницу можно продолжать модифицировать как в Word, так и в любом web-редакторе.

Примечание

Обратите внимание, что после преобразования в web-страницу или после открытия файла формата HTML в меню Вид (View) появляется новая команда Источник HTML (HTML Source), выбор которой открывает окно с исходным HTML-кодом, формирующим редактируемый документ.

Упражнение 5. Структура документа

Любой достаточно объемный документ обычно состоит из разделов и подразделов разного уровня. Самые внешние разделы, например части той книги, которую вы сейчас читаете, выделяются крупными заголовками. Для занятий выбраны заголовки поменьше. Названия упражнений набраны еще более мелким шрифтом. Такое разбиение документа на отдельные блоки не чуждо и для Word. Этот текстовый процессор позволяет присваивать названиям тех или иных разделов специальные заголовочные стили, которые, во-первых, обеспечивают одинаковое оформление всех заголовков определенного уровня, а во-вторых, дают знать программе Word, где начинается и заканчивается очередной раздел. Эта информация позволяет Word правильно форматировать документ. Например, заголовок раздела никогда не окажется па другой странице, отдельно от текста этого раздела.

Если вы редактируете большой документ, имеющий иерархическую совокупность вложенных друг в друга разделов, с ним удобно работать в режиме структуры. В этом режиме просмотра, показанном на рис. 5.20, удобно переставлять, удалять и добавлять разделы, изменять их уровень.

  1. Щелчком на кнопке Создать (New) откройте новый документ.

  2. С помощью команды Вид > Структура (View > Outline) переключитесь в режим структуры.

  3. Введите текст Параметры оборудования. Нажмите клавишу Enter. Затем введите строку Специальные вопросы, снова нажмите Enter и введите Разрешение проблем. Это будут названия трех разделов верхнего уровня. Им соответствует стиль Заголовок! (Headingi).

  4. Переместите курсор в конец первой строки и нажмите клавишу Enter. Появится еще один заголовок раздела. Чтобы понизить его уровень, нажмите клавишу Tab. Новая строка станет подразделом темы Параметры оборудования (см.рис. 5.20). Введите текст Быстродействие.

  5. Нажмите клавишу Enter и введите заголовок еще одного раздела второго уровня. Обратите внимание, что теперь не нужно нажимать клавишу Tab. В режиме структуры стиль нового абзаца всегда повторяет заголовочный стиль предыдущего абзаца.

  6. Введите еще несколько заголовков разделов второго и третьего уровней, чтобы получить текст, показанный на рис. 5.20. Для понижения уровня от второго к третьему нажимайте клавишу Tab. Имейте в виду, что заголовкам без отступа соответствует стиль Заголовок! (Heading!), заголовкам с одинарным отступом — стиль Заголовок2 (Heading2), а заголовкам с двойным отступом — стиль Заголовок З (Heading3). Следите за полем Стиль (Style) панели инструментов Форматирование (Formatting).

Рис. 5.20. Документ в режиме структуры

В нем всегда указано название стиля того абзаца, в котором находится текстовый курсор. Если вы ошиблись и заголовок получил неверный стиль, не огорчайтесь. Чтобы понизить уровень заголовка, щелкните на нем мышью и нажмите Tab. Для повышения уровня заголовка следует нажать клавиши Shift+Tab. Слева от каждого заголовка имеется знак «плюс» или «минус». «Плюс» говорит о том, что данный раздел не пуст и наполнен определенным содержанием (в данном случае заголовками вложенных подразделов). Пустым разделам соответствует знак «минус».

Примечание

Чтобы узнать стиль абзаца, щелкните в нем и взгляните на список Стиль (Style) панели инструментов Форматирование (Formatting). Абзацные стили используются в Word не только для выделения заголовков. Любому абзацу можно назначить стандартный или специально разработанный для него стиль. Способы форматирования документа с помощью стилей будут рассмотрены на следующем занятии.

Рис. 5.21. Тот же документ в обычном режиме просмотра

  7. Щелчком на кнопке Обычный режим (Normal) переключитесь в обычный режим просмотра. Вы увидите введенные заголовки разделов расположенными друг под другом без отступов. Они будут отличаться шрифтом. Каждому заголовочному стилю соответствует свой шрифт, как показано на рис. 5.21.

  8. Теперь наполните созданные разделы каким-либо содержанием. Для этого щелкайте в конце названия каждого раздела, нажимайте клавишу Enter и вводите текст. Пусть каждый раздел состоит всего из нескольких слов. Сейчас важна не общая длина документа, а его иерархическая структура. Обратите внимание, что в обычном режиме при нажатии клавиши Enter формируется абзац не заголовочного стиля, а стиля Обычный (Normal), который соответствует простому тексту.

  9. Переключитесь обратно в режим Структура (Outline). Вы увидите весь текст документа.

  10. В панели инструментов Структура (Оutlining), которая появляется при переключении в режим структуры, выберите в раскрывающемся списке пункт Показать уровень 2 (Show Level 2). Содержимое документа свернется, и на экране останутся только заголовки первого и второго уровней. Кнопки панели Структура (Outlining), показанной на рис. 5.22, позволяют развернуть документ до разделов любого уровня вложения. Выбор в раскрывающемся списке пункта Показать все уровни (Show All Levels) выводит на экран весь документ. Кнопки со знаками «плюс» и «минус» той же панели разворачивают и сворачивают тот раздел, в котором находится текстовый курсор.

  11. Щелкните в строке заголовка Установка.

  12. Затем щелкните на кнопке Вниз (Move Down) панели инструментов Структура (Outlining). Заголовок Установка сместится вниз под заголовок Обновление.

Рис. 5.22. Панель инструментов режима структуры

  13. Теперь в раскрывающемся списке выберите пункт Показать все уровни (Show All Levels), чтобы снова вывести на экран все содержимое документа. Выполненное перемещение строки заголовка повлекло сдвиг всего раздела.

  14. Щелкните назнаке «плюс» слева от заголовка раздела Быстродействие. Окажутся выделенными этот раздел и все его подразделы, как показано на рис. 5.23.

Рис. 5.23. Выделение раздела документа

  15. Нажатием клавиш Ctrl+Х вырежьте выделенный фрагмент. Переместите текстовый курсор в начало заголовка Обновление и щелкните на кнопке Вставить (Paste) панели инструментов Стандартная (Standard). Выделенный ранее подраздел будет целиком перенесен внутрь раздела Специальные вопросы.

Контрольное упражнение

Пришло время проверить, насколько хорошо вы усвоили материал этого занятия.

  1. Создайте новый шаблон на основе шаблона Here.dot.

    • Как в окне диалога создания документа вывести список шаблонов в виде таблицы с дополнительной информацией о файлах?

  2. Переключитесь в режим структуры и введите несколько заголовков первого уровня, которые соответствуют стандартным разделам шаблона, предназначенного, например, для оформления ежемесячных отчетов отделов компании.

    • Подумайте, как с помощью панели инструментов Структура (Outlining) убрать оформление заголовков разделов и вместить в окно больше текста?

  3. Переключитесь в обычный режим и введите в разделы шаблона пояснительный текст, указывающий на то, какая информация должна размещаться в каждом разделе.

  4. В режиме разметки страниц добавьте нумерацию страниц. Установите ширину левого поля страницы 4 см, а правого — 3 см.

    • Для переплета отчетов необходимо добавить в верхней части страницы дополнительное поле в 2 см. Как это сделать?

  5. Распечатайте новый шаблон и сохраните его в папке Мои документы (My Documents).

Подведение итогов

Теперь вы умеете создавать сложные текстовые документы с помощью шаблонов и мастеров Word, а также разрабатывать собственные шаблоны. Вы можете редактировать документ в одном из четырех режимов просмотра, разрабатывать общую структуру документа, настраивать параметры страницы и перемещаться по тексту с помощью панели схемы документа.

После создания структуры документа и ввода текста следует побеспокоиться о внешнем виде текста. Конечно, главным является смысловое наполнение документа, но грамотное форматирование и выделение ключевых фраз облегчает чтение и способствует пониманию смысла написанного. Следующее занятие посвящено вопросам форматирования текста.


ЧАСТЬ II

Word

Microsoft Word XP — один из лучших текстовых редакторов. Он позволяет создавать и редактировать документы, добавлять в них таблицы и рисунки, изменять оформление абзацев и начертание шрифта, готовить документ к печати. Дополнительные модули Word позволяют выполнять такие операции, как проверка орфографии и грамматики, формирование оглавлений и указателей, слияние с базой данных.

Создание и разметка документа

ТЕМА ЗАНЯТИЯ

Вторая часть книги посвящена описанию приложения Word — мощного текстового процессора. На этом занятии вы познакомитесь с шаблонами документов, научитесь экспортировать файлы Word в формат HTML и познакомитесь с четырьмя режимами просмотра документов, которые перечислены ниже:

  • обычный режим;

  • разметка страницы;

  • структура документа;

  • электронный документ.

Современную жизнь нельзя представить без обилия текстовых документов в бумажном и электронном виде. Word XP — это современная версия популярного текстового процессора, позволяющая писать письма, форматировать тексты любой сложности, добавлять в них рисунки, формулы и графики и даже верстать целые книги. Сегодня формат документов Word стал общепризнанным. Вы можете отправить такой документ по электронной почте в любую точку земного тара, и практически везде его смогут прочесть.


Создание документа

В первой части книги вы уже научились создавать и открывать простейшие документы Word. Сейчас пришло время познакомиться с шаблонами и мастерами, генерирующими стандартное содержание и общее оформление документов. Наличие такого предварительно настроенного документа облегчает процесс ввода конкретного текста.


Упражнение 1. Шаблоны

Шаблоны можно рассматривать как обычные документы Word, в которых кроме текста и списка стилен хранится информация о конфигурации панелей инструментов, макросы и параметры, определяющие вид документа и поведение программы. Шаблоны очень удобны, когда ряд документов требуется оформить в одинаковом стиле. Однажды настроив шаблон, вы создаете на его основе несколько файлов, которые наследуют имеющиеся в шаблоне текст и объекты, стили и оформление, макросы и параметры интерфейса Word. Вспомните, что на предыдущих занятиях мы уже пользовались стандартными шаблонами Office, теперь давайте создадим свой собственный шаблон.

  1. Откройте документ, созданный на первом занятии. Удалите из него весь текст, таблицу Excel и рисунок кактуса. На странице останется только надпись Геркулес и горизонтальная линия.

  2. Выберите команду Файл > Сохранить как (File > Save As). Откроется окно диалога Сохранение документа (Save As), показанное на рис. 5.1.

  3. В раскрывающемся списке Тип файла (Save As Type) выберите пункт Шаблон документа (Document Template).

  4. В левой панели окна сохранения файла щелкните на кнопке Мои документы (My Documents).

  5. В панели инструментов щелкните на кнопке Создать папку (Create New Folder).

  6. В открывшемся окне диалога введите текст Шаблоны.

  7. Щелкните на кнопке ОК.

  8. В поле Имя файла (File Name) введите Here.

  9. Щелкните на кнопке Сохранить (Save).

Рис. 5.1. Сохранение шаблона

  10. Выберите команду Файл > Закрыть (File > Close), чтобы закрыть окно шаблона. Теперь у вас есть шаблон с заголовком Геркулес, сохраненный в специальной папке.

  11. Чтобы указать программе Word, где следует искать шаблоны пользователя, выберите команду Сервис > Параметры (Tools > Options).

Рис. 5.2. Пути к служебным файлам

  12. Щелкните в открывшемся окне диалога на вкладке Расположение (File Locations). На этой вкладке, показанной на рис. 5.2, хранится информация об именах, некоторых специальных папок, в том числе и имя папки шаблонов польаователя.

  13. Щелкните на строчке Шаблоны пользователя (User Templates).

  14. Затем щелкните на кнопке Изменить (Modify). Откроется окно диалога, которое очень похоже на окно сохранения файлов, но предназначено для выбора папки.

  15. Щелкните в левой панели этого окна на кнопке Мои документы (My Documents), затем в основной области окна диалога дважды щелкните на недавно созданной папке Шаблоны.

  16. Щелкните на кнопке ОК. Вы вернетесь на вкладку Расположение (File Locations), но теперь в строке Шаблоны пользователя (User Templates) указана правильная папка.

  17. Снова щелкните на кнопке ОК, чтобы закрыть окно параметров.

  18. Теперь попробуйте создать на базе построенного шаблона новый документ. Выберите команду Файл > Создать (File > New). В правой стороне экрана появляется окно Создание документа (New Document) области задач. В разделе Создание с помощью шаблона (New from Template) перечислены недавно используемые шаблоны и ряд стандартных шаблонов. Щелкните на значке Общие шаблоны (General Templates). Значок шаблона Here появился в окне диалога Шаблоны (Templates), как показано на рис. 5.3. Сюда кроме стандартных шаблонов выводятся значки всех файлов с расширением .dot, записанных в папку с шаблонами пользователя.

Рис. 5.3. Выбор шаблона документа

  19. С помощью переключателя Создать (Create New) выберите тип создаваемого 4:>айла. Положение Документ (Document) соответствует созданию обычного текстового документа, а Шаблон (Template) позволяет создать новый шаблон.

  20. Дважды щелкните на значке Here. Откроется новый документ, в котором сразу появится большая надпись Геркулес, как показано на рис. 5.4. Теперь, пользуясь новым шаблоном, вы можете быстро добавлять такие надписи в начало каждого документа гипотетической компании Геркулес, и все они будут точными копиями заголовка, хранящегося в шаблоне.

Рис. 5.4. Документ, построенный на базе шаблона пользователя

Следует заметить, что так называемый «Обычный документ», который создается щелчком на кнопке Создать (New) панели инструментов или выбором значка Новый документ (Blanck Document) в разделе Создание документа (New) окна области задач, на самом деле тоже построен на основе шаблона. Этот шаблон записан в файле Normal.dot, который хранится в папке C:\Microsoft Office\Templates [ Предполагается, что пакет Office 2002 был установлен в папку Microsoft Office диска С:.]. Шаблон NormaLdot играет важную роль. Он определяет исходную конфигурацию Word, т. е. вид и поведение программы при ее запуске.

Примечание

Если вы обнаружили, что Word выглядит как-то странно или работает неверно, попробуйте закрыть программу и удалить файл Normal.dot. При следующем запуске Word этот шаблон будет сгенерирован заново в соответствии со стандартной конфигурацией, заложенной в Word разработчиками программы.


Упражнение 2. Мастер создания документа

Создавая документ с помощью мастера, вы имеете дело как бы с интеллектуальным шаблоном, который может менять свою конфигурацию в соответствии с конкретными запросами пользователя. Мастера часто вставляют в документ специальные макросы — небольшие программы, автоматизирующие ввод текста. На предыдущих занятиях вы уже не раз пользовались мастерами. Давайте детально познакомимся с возможностями этих помощников на примере одного из них — мастера профессионально оформленного резюме.

  1. Выберите команду Файл > Создать (File > New). В окне диалога Создание документа (New Document) области задач в разделе Создание с помощью шаблона (New From Template) щелкните на значке Общие шаблоны (General Templates). В появившемся окне диалога Шаблоны (Templates) раскройте вкладку Другие документы (Other Documents) и дважды щелкните на значке Мастер резюме (Resume Wizard). Откроется первое окно мастера, описывающее назначение запущенного модуля.

Примечание

Обратите внимание, что значки мастеров отличаются от значков обычных шаблонов наличием изображения волшебной палочки.

  2. Щелкните на кнопке Далее (Next).

  3. Во втором окне мастера, показанном на рис. 5.5, установив переключатель в правое положение, выберите для своего резюме изысканный стиль. Затем щелкните на кнопке Далее (Next).

Рис. 5.5. Второе окно мастера резюме

  4. В следующем окне выберите положение переключателя Профессиональное (Professional CV) и снова щелкните на кнопке Далее (Next).

Примечание

В нижней части окна любого мастера Office XP есть пять кнопок. Две из них — Далее (Next) и Назад (Back) позволяют перемещаться по окнам мастера. Если вы ошиблись или решили поменять данные, введенные ранее, щелкая на кнопке Назад (Back), вернитесь к одному из предыдущих окон и скорректируйте параметры мастера. При этом нет нужды заново повторять всю процедуру. Кнопка Отмена (Cancel) позволяет в любой момент прервать работу мастера. Кнопка Готово (Finish) инициирует генерацию результата на базе уже введенных данных. Наконец, кнопка с вопросительным знаком позволяет получить справку.

  5. В двух следующих окнах введите свое имя, адрес, телефоны и укажите, какую информацию о вас следует включать в резюме.

  6. В шестом окне мастера, показанном на рис. 5.6, установите флажки, соответствующие тем разделам, которые должны быть включены в резюме.

Рис. 5.6. Шестое окно мастера резюме

  7. Щелкните на кнопке Далее (Next).

  8. В следующем окне укажите, какие дополнительные разделы следует включать в документ, а с помощью последнего из информативных окон добавьте при необходимости разделы, не предусмотренные разработчиками мастера. Щелкните на кнопке Далее (Next).

  9. В последнем окне мастера, информирующем о том, что все готово для создания документа, щелкните на кнопке Готово (Finish). Мастер сгенерирует документ, показанный на рис. 5.7. В нем появятся введенные вами данные и дополнительные поля, которые можно заполнить позже.
  10. Сохраните это резюме в папке Мои документы (My Documents) под именем Резюме. Теперь вы умеете строить документы на базе шаблонов и наполнять их информацией с помощью мастеров. Однако иногда случается так, что текстовое содержание уже имеется в обычном текстовом файле ASCII, например, полученном по электронной почте. Такой текст легко импортируется в Word, где его можно оформить с помощью мощных возможностей этого текстового редактора. Чтобы открыть ASCII-текст формата DOS, выполните следующие шаги.
  11. Выберите команду Файл > Открыть (File > Open).
  12. В раскрывающемся списке Тип файлов (Files Of Types) окна диалога Открытие документа (Open) выберите пункт Текстовые файлы (Text Files) или Все файлы (All Files).

Рис. 5.7. Документ, сгенерированный мастером

  13. Найдите текстовый файл и дважды щелкните на его значке. Откроется окно диалога Преобразование файла (Convert File), показанное на рис. 5.8.

Рис. 5.8. Выбор варианта преобразования

  14. Выберите пункт Текст MS-DOS (MS-DOS Text).

Примечание

Если окно преобразования не появится, вы не сможете правильно настроить отображение русских букв. В этом случае выберите команду Сервис > Параметры (Tools > Options) и на вкладке Общие (General) установите флажок Подтверждать преобразование при открытии (Confirm Conversion At Open). Затем повторите импорт текстового файла.

  15. Щелкните на кнопке ОК. Текст DOS будет преобразован в формат Windows. При импорте файлов другого формата выбирайте в окне диалога Преобразование файла (Convert File) нужный вариант преобразования.


Режимы просмотра

В Microsoft Word один и тот же документ можно отображать в четырех перечисленных ниже режимах просмотра.

  • Обычный (Normal View) — предназначен для ввода и форматирования текста, отображаемого в виде непрерывной вертикальной полосы.

  • Разметка страницы (Print Layout View) — позволяет оценить расположение текста и объектов относительно физических страниц документа.

  • Структура (Outline View) — служит для задания и редактирования иерархической структуры разделов основного текста, что позволяет полностью отвлечься от графических объектов и реальных размеров страниц и сконцентрировать внимание на содержании.

  • Веб-документ (Web Layout View) — предназначен для формирования web-страниц, для которых характерна неограниченная длина.

Режимы просмотра проще всего переключать с помощью кнопок, расположенных в левом нижнем углу окна документа (рис. 5.9). Не забывайте про наличие разных режимов, всегда работайте в том из них, который лучше соответствует решаемой задаче.

Рис. 5.9. Кнопки режимов просмотра


Упражнение 3. Обычный режим

Создавая или модифицируя текстовый документ, вы чаще всего работаете в обычном режиме просмотра. На рис. 5.10 показан пример документа в этом режиме и основные элементы окна Word. При обычном просмотре документ имеет неограниченную длину, хотя его ширина определяется размером страницы. Разбиение на страницы показано горизонтальными пунктирными линиями. В этом режиме на экране не видны фигуры, рисунки и другие графические объекты.

Рис. 5.10. Документ Word в обычном режиме

Строка состояния Word в любом режиме просмотра выводит одну и ту же информацию, которая помогает ориентироваться в больших документах. В первом слева поле строки состояния видны номер текущей страницы, номер текущего раздела, а далее через дробь — номер текущей страницы и число страниц в документе. Во второе поле выводится расстояние от левого края документа до текущего положения текстового курсора, затем номера текущих строки и столбца.

  1. Откройте любой не очень короткий документ и с помощью команды Вид > Обычный (View > Normal) включите обычный режим просмотра (если текущим является другой режим).

  2. Щелкните на кнопке Схема документа (Document Map). В левой части окна появится панель, демонстрирующая иерархическую структуру разделов документа, как показано на рис. 5.11. Указанная кнопка играет роль флажка. Повторный щелчок на ней скроет панель схемы. Такую панель можно открыть и в любом другом режиме просмотра.

  3. Щелкните в панели схемы документа на одном из пунктов. Текст в основном окне переместится к соответствующему разделу.

Примечание

Раздел характеризуется наличием заголовка, отмеченного специальным стилем. Вы познакомитесь с этими стилями в упражнении 5 этого занятия.

Рис. 5.11. Схема документа

  4. Чтобы прокрутить текст вручную, пользуйтесь кнопками и ползунком вертикальной полосы прокрутки, расположенной в правой части окна. Полоса прокрутки есть и в панели схемы документа.

  5. Щелкните на кнопке Следующая страница (Next Page). Текст в окне переместится к началу следующей страницы. Кнопка Предыдущая страница (Previous Page) выполняет обратную процедуру, прокручивая текст на одну страницу вверх.

  6. Щелкните на кнопке Выбор объекта перехода (Select Browse Object). Откроется показанное на рис. 5.12 окно со значками. Эти значки позволяют изменять функции кнопок Следующая страница (Next Page) и Предыдущая страница (Previous Page).

Рис. 5.12. Выбор объекта перехода

  7. Попробуйте щелкнуть на значке Разделы (Browse By Section). Теперь указанные кнопки будут прокручивать документ соответственно к предыдущему и следующему разделу (а не к странице).

  8. В обычном режиме в верхней части окна может располагаться горизонтальная линейка, позволяющая контролировать горизонтальные отступы. Чтобы показать или скрыть линейку, выберите команду Вид > Линейка (View > Ruler).

  9. Вероятно, вы захотите настроить масштаб отображения текста по своему вкусу. Для этого щелкните на раскрывающемся списке Масштаб (Zoom) панели инструментов Стандартная (Standard) и выберите подходящий масштаб. Чтобы ширина текста в точности равнялась ширине окна, выберите последний пункт По ширине страницы (Page Width).

  10. Выполните команду Вид > Во весь экран (View > Full Screen). Окно Word развернется на весь экран компьютера. При этом исчезнут меню, заголовок окна, панели инструментов, строка состояния и полоса прокрутки. Будет виден только сам документ и кнопка Вернуть обычный режим (Close Full Screen). Такой полноэкранный режим просмотра позволяет целиком сосредоточиться на содержании документа.

  11. Чтобы вернуть исчезнувшие элементы интерфейса, щелкните на кнопке Вернуть обычный режим (Close Full Screen).

Примечание

В полноэкранном режиме можно пользоваться всеми командами меню. Переместите указатель мыши вплотную к верхнему краю экрана, и перед вами появится всплывающая строка меню Word.

  12. Дважды щелкните в любом из двух левых полей строки состояния. Откроется окно перехода к объекту, показанное на рис. 5.13.
  13. В списке Объект перехода (Go To What) выберите тип объекта, который нужно найти, например пункт Страница (Page).

Рис. 5.13. Вкладка перехода окна диалога поиска и замены

  14. В поле Введите номер страницы (Enter Page Number), название которого варьируется в зависимости от выбранного типа объекта, введите номер страницы, к которой нужно перейти. Для перехода вперед или назад на N страниц относительно текущей введите соответственно +N или -N, где N — целое число.
  15. Щелкните на кнопке Перейти (Go To). Документ прокрутится до искомого объекта.


Упражнение 4. Разметка страницы

Режим разметки страниц позволяет видеть документ таким, каким он будет на бумажных страницах, распечатанных на принтере. Здесь в виде белых прямоугольников отображаются страницы документа, на которых наряду с текстом видны абсолютно все объекты, как показано на рис. 5.14. Если документ содержит многочисленные рисунки или графики, с ним удобнее работать именно в режиме разметки страницы.

Рис. 5.14. Режим разметки страницы

Окно режима разметки практически не отличается от окна обычного режима. Но включив отображение линейки, вы кроме горизонтальной линейки увидите еще и вертикальную, которая позволяет оценивать положение объектов на странице по второй координате. Приемы перемещения по документу тоже совпадают в обоих режимах, однако в раскрывающемся списке Масштаб (Zoom) в режиме разметки появляются три дополнительных пункта —По ширине текста (Text Width), Страница целиком (Whole Page) и Две страницы (Two Pages), названия которых не требуют дополнительных пояснений.

Работая в режиме разметки, не спешите расставлять объекты и форматировать текст. Для начала следует настроить размеры страницы и ее полей.

  1. Выберите команду Файл > Параметры страницы (File > Page Setup).

  2. В открывшемся окне диалога щелкните на вкладке Размер бумаги (Paper Size), которая показана на рис. 5.15.

  3. В списке Размер бумаги (Paper Size) выберите тот размер листа, на котором должен печататься документ.

  4. Чтобы задать нестандартный размер, выберите пункт Другой (Custom Size) и введите ширину и высоту страницы в счетчики Ширина (Width) и Высота (Height).

Рис. 5.15. Параметры страницы

  5. После настройки размеров страницы следует указать размеры отступов и выбрать вариант вывода текста на принтер. Для этого раскройте вкладку Поля (Margins), которая показана на рис. 5.16.

  6. В счетчики Верхнее (Тор), Нижнее (Bottom), Левое (Left) и Правое (Right) введите ширину полей страницы.

  7. С помощью переключателя Ориентация (Orientation) окна диалога параметров страницы выберите книжное или альбомное расположение страницы относительно текста.

Рис. 5.16. Настройка полей

  8. Если вы собираетесь печатать документ на обеих сторонах листов, а левый и правый отступы не равны между собой, то в раскрывающемся списке Несколько страниц: (Multiple Pages) выберите Зеркальные поля (Mirror Margins). Это обеспечит правильную расстановку полей. При выборе 2 страницы на листе (2 Pages Per Sheet) на одном листе бумаги будут размещены две страницы. Поле Образец (Preview) отображает текущую раскладку страниц и позволяет визуально проконтролировать введенные параметры.

Примечание

В верхнем и нижнем поле страницы расположены верхний и нижний колонтитулы, в которых размещаются, например, номера страниц или названия текущих разделов документа. Если вы пользуетесь колонтитулами, не делайте верхнее и нижнее поля слишком узкими.

  9. Раскройте вкладку Источник бумаги. В разделе Различать колонтитулы: с помощью соответствующих счетчиков настройте расстояния от края страницы до верхнего и нижнего колонтитулов.
  10. Щелчком на кнопке О К закройте окно диалога параметров страницы.
  11. Поля можно настроить и с помощью линеек. Чтобы увеличить ширину левого поля, поместите указатель мыши на границу серой и белой областей горизонтальной линейки (см. рис. 5.14), нажмите кнопку мыши и перетаскивайте границу поля. Аналогично настраиваются и остальные три поля страницы.
  12. В многостраничном документе, как правило, требуется расстановка номеров страниц. Нет смысла делать это вручную. Word умеет нумеровать страницы автоматически. Выберите команду Вставка > Номера страниц (Insert > Page Numbers). Откроется окно диалога, показанное на рис. 5.17.

Рис. 5.17. Добавление нумерации страниц

  13. С помощью раскрывающегося списка Положение (Position) укажите, должны ли номера страниц располагаться вверху или внизу страницы. В списке Выравнивание (Alignment) выберите нужный режим выравнивания номера в колонтитуле.

  14. Чтобы номер отсутствовал на первой странице документа, сбросьте флажок Номер на первой странице (Show Number On First Page).

  15. Если требуется дополнительное форматирование номеров, щелкните на кнопке Формат (Format) и настройте параметры окна диалога Формат номера (Page Number Format).

  16. Щелчками на кнопках OK закройте все окна диалога. Word автоматически пронумерует страницы документа. При редактировании текста вы сможете выбрасывать и вставлять фрагменты, а также перемещать целые блоки страниц. Word автоматически скорректирует нумерацию и обеспечит правильную последовательность чисел.

  17. Чтобы изменить шрифт номеров страниц и добавить в колонтитулы другую информацию, выберите команду Вид > Колонтитулы (View > Header And Footer). Текст документа станет блеклым, а колонтитулы будут выделены пунктирными прямоугольниками, как показано на рис. 5.18. Кроме того, появится панель инструментов Колонтитулы (Header And Footer).

  18. С помощью полосы прокрутки найдите любой прямоугольник с надписью Верхний колонтитул (Header).

  19. Введите в нем текст Это верхний колонтитул. Теперь в верхнем поле каждой страницы будет выведена такая надпись. Вы скажете, что-подобные заголовки страниц никому не нужны. Да, конечно, это лишь простейший пример. Давайте посмотрим, какие возможности предлагает панель инструментов Колонтитулы (Header And Footer).

Рис. 5.18. Редактирование колонтитулов

  20. Щелкните в прямоугольнике Нижний колонтитул (Footer).

  21. В панели Колонтитулы (Header And Footer) щелкните на кнопке Вставить авто текст (Insert AutoText).

  22. Выберите в раскрывающемся меню пункт Полное имя файла (Filename And Path). Теперь вы не забудете, как называется файл, в котором хранится источник распечатанного текста. Имя этого файла появится в нижнем колонтитуле каждой страницы. Если вы переименуете файл документа или переместите его в другую папку, то при следующем открытии документа в нижнем колонтитуле появится уже новое имя файла. Панель инструментов Колонтитулы (Header And Footer) позволяет-таюке вставлять в колонтитулы дату и время последнего обновления документа, дату печати документа, имя автора и другую информацию.

  23. Чтобы закрыть режим просмотра колонтитулов, щелкните на кнопке Закрыть (Close) панели инструментов Колонтитулы (Header And Footer). Иногда, просмотрев документ в режиме разметки страницы, вы можете остаться недовольны тем, как Word разбил текст на страницы. В этом случае вручную вставьте в текст дополнительные разрывы страниц.

  24. Поместите курсор в ту точку, где должна начинаться новая страница, и выберите команду Вставка > Разрыв (Insert > Break). Откроется окно диалога, показанное на рис. 5.19. В нем верхний переключатель позволяет из трех положений выбрать тип разрыва. Нижний переключатель позволяет вставить метку начала следующего раздела и выбрать, как должен располагаться раздел: с начала следующей страницы, с четной, с нечетной или без разрыва страницы.

Рис. 5.19. Вставка разрыва

  25. Выберите положение переключателя Новую страницу (Page Break).

  26. Затем щелкните на кнопке ОК. Текст правее и ниже курсора будет перенесен в начало следующей страницы, а конец текущей страницы останется пустым.

Режим электронного документа, который включается командой Вид > Веб-документ (View > Web Layout), является как бы комбинацией обычного режима и режима разметки страницы. Электронный документ позволяет видеть все объекты, включая рисунки и графики, перемещать их по документу и изменять их размер. Но в режиме электронного документа нет разбивки на страницы и весь текст отображается в виде бесконечной вертикальной ленты. Здесь нет и вертикальной линейки. Поскольку предполагается, что электронный документ будет публиковаться на web-узле, разработчики Word учли, что web-страницы могут иметь любую длину, а для их просмотра в окне браузера используется вертикальная полоса прокрутки.

Если вы пользуетесь текстовым процессором Word для подготовки web-страниц, вместо режима разметки страниц всегда пользуйтесь режимом электронного документа. В этом случае после преобразования в формат HTML не произойдет потери назначенного форматирования. Например, на web-странице невозможно разместить текст в несколько столбцов (если не пользоваться таблицами), поэтому режим просмотра электронного документа игнорирует такое форматирование, четко следуя стандартам HTML.

Примечание

Запись формата HTML в Office XP выполняется без ошибок, а полученная web-страница точно повторяет вид исходного электронного документа.

Чтобы сформировать web-страницу, достаточно выбрать команду Файл >Сохранить как веб-страницу (File > Save As Web Page) и в окне диалога Сохранение документа (Save As) ввести имя HTML-файла. Полученную web-страницу можно продолжать модифицировать как в Word, так и в любом web-редакторе.

Примечание

Обратите внимание, что после преобразования в web-страницу или после открытия файла формата HTML в меню Вид (View) появляется новая команда Источник HTML (HTML Source), выбор которой открывает окно с исходным HTML-кодом, формирующим редактируемый документ.


Упражнение 5. Структура документа

Любой достаточно объемный документ обычно состоит из разделов и подразделов разного уровня. Самые внешние разделы, например части той книги, которую вы сейчас читаете, выделяются крупными заголовками. Для занятий выбраны заголовки поменьше. Названия упражнений набраны еще более мелким шрифтом. Такое разбиение документа на отдельные блоки не чуждо и для Word. Этот текстовый процессор позволяет присваивать названиям тех или иных разделов специальные заголовочные стили, которые, во-первых, обеспечивают одинаковое оформление всех заголовков определенного уровня, а во-вторых, дают знать программе Word, где начинается и заканчивается очередной раздел. Эта информация позволяет Word правильно форматировать документ. Например, заголовок раздела никогда не окажется па другой странице, отдельно от текста этого раздела.

Если вы редактируете большой документ, имеющий иерархическую совокупность вложенных друг в друга разделов, с ним удобно работать в режиме структуры. В этом режиме просмотра, показанном на рис. 5.20, удобно переставлять, удалять и добавлять разделы, изменять их уровень.

  1. Щелчком на кнопке Создать (New) откройте новый документ.

  2. С помощью команды Вид > Структура (View > Outline) переключитесь в режим структуры.

  3. Введите текст Параметры оборудования. Нажмите клавишу Enter. Затем введите строку Специальные вопросы, снова нажмите Enter и введите Разрешение проблем. Это будут названия трех разделов верхнего уровня. Им соответствует стиль Заголовок! (Headingi).

  4. Переместите курсор в конец первой строки и нажмите клавишу Enter. Появится еще один заголовок раздела. Чтобы понизить его уровень, нажмите клавишу Tab. Новая строка станет подразделом темы Параметры оборудования (см.рис. 5.20). Введите текст Быстродействие.

  5. Нажмите клавишу Enter и введите заголовок еще одного раздела второго уровня. Обратите внимание, что теперь не нужно нажимать клавишу Tab. В режиме структуры стиль нового абзаца всегда повторяет заголовочный стиль предыдущего абзаца.

  6. Введите еще несколько заголовков разделов второго и третьего уровней, чтобы получить текст, показанный на рис. 5.20. Для понижения уровня от второго к третьему нажимайте клавишу Tab. Имейте в виду, что заголовкам без отступа соответствует стиль Заголовок! (Heading!), заголовкам с одинарным отступом — стиль Заголовок2 (Heading2), а заголовкам с двойным отступом — стиль Заголовок З (Heading3). Следите за полем Стиль (Style) панели инструментов Форматирование (Formatting).

Рис. 5.20. Документ в режиме структуры

В нем всегда указано название стиля того абзаца, в котором находится текстовый курсор. Если вы ошиблись и заголовок получил неверный стиль, не огорчайтесь. Чтобы понизить уровень заголовка, щелкните на нем мышью и нажмите Tab. Для повышения уровня заголовка следует нажать клавиши Shift+Tab. Слева от каждого заголовка имеется знак «плюс» или «минус». «Плюс» говорит о том, что данный раздел не пуст и наполнен определенным содержанием (в данном случае заголовками вложенных подразделов). Пустым разделам соответствует знак «минус».

Примечание

Чтобы узнать стиль абзаца, щелкните в нем и взгляните на список Стиль (Style) панели инструментов Форматирование (Formatting). Абзацные стили используются в Word не только для выделения заголовков. Любому абзацу можно назначить стандартный или специально разработанный для него стиль. Способы форматирования документа с помощью стилей будут рассмотрены на следующем занятии.

Рис. 5.21. Тот же документ в обычном режиме просмотра

  7. Щелчком на кнопке Обычный режим (Normal) переключитесь в обычный режим просмотра. Вы увидите введенные заголовки разделов расположенными друг под другом без отступов. Они будут отличаться шрифтом. Каждому заголовочному стилю соответствует свой шрифт, как показано на рис. 5.21.

  8. Теперь наполните созданные разделы каким-либо содержанием. Для этого щелкайте в конце названия каждого раздела, нажимайте клавишу Enter и вводите текст. Пусть каждый раздел состоит всего из нескольких слов. Сейчас важна не общая длина документа, а его иерархическая структура. Обратите внимание, что в обычном режиме при нажатии клавиши Enter формируется абзац не заголовочного стиля, а стиля Обычный (Normal), который соответствует простому тексту.

  9. Переключитесь обратно в режим Структура (Outline). Вы увидите весь текст документа.

  10. В панели инструментов Структура (Оutlining), которая появляется при переключении в режим структуры, выберите в раскрывающемся списке пункт Показать уровень 2 (Show Level 2). Содержимое документа свернется, и на экране останутся только заголовки первого и второго уровней. Кнопки панели Структура (Outlining), показанной на рис. 5.22, позволяют развернуть документ до разделов любого уровня вложения. Выбор в раскрывающемся списке пункта Показать все уровни (Show All Levels) выводит на экран весь документ. Кнопки со знаками «плюс» и «минус» той же панели разворачивают и сворачивают тот раздел, в котором находится текстовый курсор.

  11. Щелкните в строке заголовка Установка.

  12. Затем щелкните на кнопке Вниз (Move Down) панели инструментов Структура (Outlining). Заголовок Установка сместится вниз под заголовок Обновление.

Рис. 5.22. Панель инструментов режима структуры

  13. Теперь в раскрывающемся списке выберите пункт Показать все уровни (Show All Levels), чтобы снова вывести на экран все содержимое документа. Выполненное перемещение строки заголовка повлекло сдвиг всего раздела.

  14. Щелкните назнаке «плюс» слева от заголовка раздела Быстродействие. Окажутся выделенными этот раздел и все его подразделы, как показано на рис. 5.23.

Рис. 5.23. Выделение раздела документа

  15. Нажатием клавиш Ctrl+Х вырежьте выделенный фрагмент. Переместите текстовый курсор в начало заголовка Обновление и щелкните на кнопке Вставить (Paste) панели инструментов Стандартная (Standard). Выделенный ранее подраздел будет целиком перенесен внутрь раздела Специальные вопросы.


Контрольное упражнение

Пришло время проверить, насколько хорошо вы усвоили материал этого занятия.

  1. Создайте новый шаблон на основе шаблона Here.dot.

    • Как в окне диалога создания документа вывести список шаблонов в виде таблицы с дополнительной информацией о файлах?

  2. Переключитесь в режим структуры и введите несколько заголовков первого уровня, которые соответствуют стандартным разделам шаблона, предназначенного, например, для оформления ежемесячных отчетов отделов компании.

    • Подумайте, как с помощью панели инструментов Структура (Outlining) убрать оформление заголовков разделов и вместить в окно больше текста?

  3. Переключитесь в обычный режим и введите в разделы шаблона пояснительный текст, указывающий на то, какая информация должна размещаться в каждом разделе.

  4. В режиме разметки страниц добавьте нумерацию страниц. Установите ширину левого поля страницы 4 см, а правого — 3 см.

    • Для переплета отчетов необходимо добавить в верхней части страницы дополнительное поле в 2 см. Как это сделать?

  5. Распечатайте новый шаблон и сохраните его в папке Мои документы (My Documents).


Подведение итогов

Теперь вы умеете создавать сложные текстовые документы с помощью шаблонов и мастеров Word, а также разрабатывать собственные шаблоны. Вы можете редактировать документ в одном из четырех режимов просмотра, разрабатывать общую структуру документа, настраивать параметры страницы и перемещаться по тексту с помощью панели схемы документа.

После создания структуры документа и ввода текста следует побеспокоиться о внешнем виде текста. Конечно, главным является смысловое наполнение документа, но грамотное форматирование и выделение ключевых фраз облегчает чтение и способствует пониманию смысла написанного. Следующее занятие посвящено вопросам форматирования текста.


Занятие №6

Оформление документа

ТЕМА ЗАНЯТИЯ

На занятии рассказывается об инструментах Word, позволяющих форматировать текст и придавать документу необходимое оформление. Вы познакомитесь с операциями и элементами форматирования, которые перечислены ниже:

  • настройка отступов и интервалов;

  • табуляция;

  • маркированные и нумерованные списки;

  • текст в несколько столбцов;

  • выбор начертания и размера шрифта;

  • стиль;

  • линии и фигуры;

  • библиотека ClipArt.

Параметры абзаца

Простейшие текстовые редакторы, подобные Блокнот (Notepad) или встроенному редактору командной оболочки Norton Commander, не отслеживают смысловую логику документа. В них основной структурной единицей является символ. В текстовых процессорах, к которым относится и Word, в качестве элементарного структурного блока рассматривается абзац. Word полагает, что содержимое абзаца является связным текстом, и сам расставляет буквы и слова внутри абзаца наилучшим образом в соответствии с назначенными пользователем правилами форматирования. В результате в процессе редактирования документа отпадает необходимость в корректировке длины строк, выделении заголовков специальным шрифтом, добавлении маркеров списков и отступов «красной строки». Word сам позаботится о правильном оформлении. Вам нужно лишь указать программе правила, в соответствии с которыми должен форматироваться документ.

Упражнение 1. Отступы, интервалы и табуляции

Конфигурация абзаца характеризуется отступами сверху и снизу, интервалами слева и справа, межстрочным интервалом, отступом первой строки, режимом выравнивания текста по ширине страницы и некоторыми другими параметрами. Давайте изучим приемы настройки этих величин.

  1. Запустите Word и в автоматически открывшемся новом документе напечатайте несколько десятков слов, например введите текст любого абзаца этой книги. Обратите внимание, что по достижении правого края страницы текст автоматически переносится на следующую строку.

  2. Окончив ввод абзаца, нажмите клавишу Enter. Текстовый курсор переместится на новую строку, обозначив этим конец текущего абзаца и подготовив текстовый процессор для ввода следующего.

  3. Введите еще несколько абзацев.

  4. Щелчком на кнопке Режим разметки (Print Layout View) переключитесь в режим разметки страниц, который позволяет видеть точное форматирование текста. (На протяжении всего занятия используйте именно этот режим просмотра документа.)

  5. Если на экране нет вертикальной и горизонтальной линеек, включите их командой Вид > Линейка (View > Ruler). Теперь окно Word будет выглядеть примерно так, как показано на рис. 6.1. Чтобы задать расстояния от границ левого и правого полей страницы до абзацев некоторого блока текста, нужно настроить отступы блока. При изменении ширины полей страницы размеры абзацев модифицируются таким образом, чтобы отступы от краев полей оставались неизменными. Для настройки отступов блока текста нужно сначала выделить этот текст. Если требуется модифицировать параметры только одного абзаца, достаточно просто поместить в него текстовый курсор.

  6. Выделите второй и третий абзацы.

Рис. 6.1. Пять абзацев и линейки в режиме разметки страниц

  7. В левой части горизонтальной линейки найдите треугольный маркер Отступ первой строки (First Line Indent), вершина которого направлена вниз, захватите его мышью и перетащите вправо на 3 см. Перемещением этого маркера можно изменять положение начала первых строк выделенных абзацев, не изменяя отступов остального текста. Заметьте, что первая строка может начинаться как правее (отступ), так и левее (выступ) основного текста.

  8. Перетащите вправо на 1 см маркер Выступ (Hanging Indent), имеющий форму треугольника, вершина которого направлена вверх. Изменится левый отступ тела абзацев, но отступ первых строк останется прежним.

  9. В левой части горизонтальной линейки есть еще один маркер, имеющий форму прямоугольника, — Отступ слева (Left Indent). Перетащите его вправо на 1 см. Вы увидите, что перемещение этого маркера равносильно синхронному сдвигу маркеров Отступ первой строки (Line Indent) и Выступ (Hanging Indent) на одинаковое расстояние, то есть приводит к смещению левого края абзаца относительно поля страницы.

  10. Щелкните на тексте второго абзаца, сняв выделение блока текста и поместив курсор в тело этого абзаца.

  11. Перетащите влево на 4 см маркер Отступ справа (Right Indent), расположенный в правой части горизонтальной линейки. Он задает правый край абзаца.

После всех проделанных операций текст выглядит так, как показано на рис. 6.2.

Рис. 6.2. Настройка отступов

  12. Щелкните на кнопке По центру (Center) панели инструментов Форматирование (Formatting).

Рис. 6.3. Режимы выравнивания

Рис. 6.4. Окно диалога параметров абзаца

  13. Выделите третий абзац и щелкните на кнопке По правому краю (Align Right) той же панели инструментов.

  14. Щелкните на четвертом абзаце, а затем на кнопке По ширине (Justify). Теперь первые четыре абзаца текста демонстрируют четыре режима выравнивания текста (рис. 6.3).

  15. Выделите второй, третий и четвертый абзацы и выберите команду Формат > Абзац (Format > Paragraph). Вкладка Отступы и интервалы (Indents And Spacing) открывшегося окна диалога (рис. 6.4) позволяет задавать отступы абзаца и режим выравнивания, которые мы настраивали с помощью горизонтальной линейки и кнопок панели инструментов Форматирование (Formatting). Раздел Интервал (Spacing) той же вкладки позволяет задать интервал между строками внутри абзаца и расстояние между абзацами.

Рис. 6.5. Настройка интервалов

  16. Введите в счетчик перед (Before) число 6.

  17. В списке междустрочный (Line Spacing) выберите пункт Полуторный (1,5 tines).

  18. Щелкните на кнопке ОК. Интервалы в трех выделенных абзацах изменятся и станут такими, как показано на рис. 6.5. Обратите внимание, что область Образец (Preview) окна диалога Абзац (Paragraph) позволяет наблюдать влияние введенных величин па вид текущего абзаца еще до окончательного применения выбранных значений параметров к тексту документа.

  19. Сохраните документ, он пригодится вам в следующих упражнениях.

Упражнение 2. Списки и столбцы

Word позволяет последовательно нумеровать абзацы или выделять их с помощью разнообразных маркеров, размещаемых слева от первых строк абзацев. Для изучения маркированных и нумерованных списков воспользуйтесь текстом документа, созданным в предыдущем упражнении.

  1. Нажатием клавиш Ctrl+A выделите весь текст.

  2. Чтобы вернуть всем абзацам оформление, свойственное стилю Обычный (Normal), выберите соответствующий пункт в раскрывающемся списке Стиль (Style) панели инструментов Форматирование (Formatting).

  3. Щелкните на кнопке Нумерация (Numbering) той же панели инструментов. Абзацы будут пронумерованы последовательными числами.

  4. Поместите курсор в конец второго абзаца и нажмите клавишу Enter. Новому абзацу автоматически будет присвоен номер 3, а номера последующих абзацев изменятся так, чтобы сохранилась непрерывная последовательность чисел.

Рис. 6.6. Списки

  5. Выделите второй абзац, затем щелкните на кнопке Маркеры (Bullets) панели инструментов Форматирование (Formatting). Номер выделенного абзаца заменится на маркер. Заметьте, что при этом остальные абзацы снова будут перенумерованы (рис. 6.6).

  6. Word предлагает пользователям разнообразные типы нумерации и значки маркеров. Чтобы оформить фрагмент текста по своему вкусу, выделите его и выполните команду Формат > Список (Format > Bullets And Numbering). Вкладка Маркированный (Bulleted) открывшегося окна диалога Список (Bullets And Numbering) позволяет выбрать для выделенных абзацев форму маркеров (рис. 6,7). Для этого достаточно щелкнуть на прямоугольнике с маркером нужного типа, а затем на кнопке ОК. Вкладка Нумерованный (Numbered) того же окна диалога дает возможность указать тип нумерации. Эта вкладка практически идентична предыдущей, что указывает на родственную природу маркированных и нумерованных списков.

Рис. 6.7. Выбор маркера

Примечание

Чтобы убрать маркеры и нумерацию, выберите в окне диалога Список (Bullets And Numbering) прямоугольник Нет (None).

В некоторых случаях текст документа необходимо разместить в несколько столбцов. Чтобы преобразовать в такую форму готовый текст, выполните следующие действия.

  7. Выделите первый и второй абзацы рабочего примера и щелкните на кнопке Колонки (Columns) панели инструментов Стандартная (Standard). В раскрывшейся палитре щелкните на третьем столбце. Теперь текст первых двух абзацев будет разбит на три столбца, как показано на рис. 6.8.

    Обратите внимание, что с помощью горизонтальной линейки можно по отдельности настраивать отступы каждого столбца (для этого нужно выделить соответствующий фрагмент текста) и интервалы между столбцами.

  8. Чтобы изменить параметры столбцов, переместите курсор в текст одного из них и выполните команду Формат > Колонки (Format > Columns). В открывшемся окне диалога можно выбрать одну из пяти стандартных конфигураций столбцов, задать число столбцов, их ширину и расстояние между ними.

Рис. 6.8. Текст в три столбца

Примечание

Столбцы видны в документе только в режиме разметки страницы. Во всех остальных режимах просмотра текст выводится в один столбец, хотя параметры столбцов при этом не сбрасываются и учитываются при печати такого документа в любом режиме просмотра.

Форматирование текста

Возможности оформления не ограничиваются параметрами абзацев. Word позволяет изменять размер, начертание, цвет и другие характеристики шрифта, которым набран текст документа. Для облегчения ввода текста и представления табличных данных можно воспользоваться табулированными отступами. Чтобы задать однотипное оформление нескольким абзацам одного или разных документов, можно настроить абзацные стили пользователя.

Упражнение 3. Выбор шрифта

Программа Word позволяет настраивать различные параметры символов. В этом упражнении мы коснемся лишь некоторых. Давайте рассмотрим кнопки панели инструментов, позволяющие быстро изменять начертание шрифта.

  1. Чтобы отформатировать символы фрагмента текста, выделите его, а затем щелкните на одной из кнопок панели инструментов Форматирование (Formatting), перечисленных в табл. 6.1.

ТАБЛИЦА 6.1. Раскрывающиеся списки и кнопки форматирования символов
Кнопка или список | Клавиатурная комбинация | Назначение
Bold (Полужирный) | Ctrl+B | Выделяет полужирным начертанием
Italic (Курсив) | Ctrl+I | Выделяет курсивом
Underline (Подчеркнутый) | Ctrl+U | Подчеркивает текст
Font Size (Размер шрифта) |  | Позволяет выбрать или ввести размер шрифта
Font (Шрифт) |  | Позволяет выбрать один из шрифтов, установленных в Windows
Font Color (Цвет шрифта) |  | Щелчок на кнопке выделяет текст ранее выбранным цветом. Щелчок на стрелке справа от кнопки раскрывает палитру цветов, с помощью которой задается цвет текста
Highlight (Выделение цветом) |  | Щелчок на кнопке окрашивает фон текста ранее выбранным цветом. Щелчок на стрелке справа от кнопки раскрывает палитру цветов, с по мощью которой задается цвет фона
Superscript (Верхний индекс) | Ctrl+Shift+= | Преобразует выделенный текст в верхний индекс
Subscript (Нижний индекс) | Ctrl+O | Преобразует выделенный текст в нижний индекс

На рис. 6.9 показан пример текста, разные фрагменты которого выделены тем или иным способом форматирования.

Рис. 6.9. Варианты форматирования текста

Примечание

Две последние кнопки из перечисленных в табл. 6.1 в стандартной конфигурации Word отсутствуют на панели инструментов. Чтобы они там появились, щелкните на треугольнике, расположенном в правой части панели инструментов, выберите команду Добавить или удалить кнопки (Add Or Remove Buttons) и щелкните в раскрывшемся списке кнопок на соответствующих названиях.

Рис. 6.10. Выбор формата шрифта

  2. Для получения доступа к дополнительным параметрам шрифта выберите команду Формат > Шрифт (Format > Font). Откроется окно диалога Шрифт (Font). Одноименная вкладка, показанная на рис. 6.10, позволяет выбрать шрифт, его размер, вариант начертания, режим и цвет подчеркивания. Здесь же есть несколько флажков, позволяющих включать и отключать режимы оформления.

Примечание

Если изменить форматирование текста, не выделив предварительно никакого фрагмента, то новый формат будет назначен тексту, вводимому в точке текстового курсора. Однако любое перемещение курсора до ввода первого символа отменит новую настройку формата.

  3. Две другие вкладки окна диалога Шрифт (Font) дают возможность настраивать интервалы между буквами, смещение символов и кернинг, а также назначать тексту анимационные эффекты.

Упражнение 4. Табуляция

В то время как поля и отступы определяют общий вид документа и абзацев, табуляции помогают размещать текст внутри абзаца. Позиции табуляции задают точки на горизонтальной линейке, по которым можно выравнивать текст. В этом упражнении с помощью табуляций строится небольшая таблица из двух строк.

  1. Создайте новый документ Word.

  2. Щелкните на горизонтальной линейке на отметке 2 см. На линейке появится значок табуляции.

  3. Щелкните на отметках 5,8 и 11 см, чтобы добавить еще три позиции табуляции.

  4. Нажмите клавишу Tab и введите цифру-1. Текстовый курсор перепрыгнет в текущей строке вправо на позицию 2 см, где и появится введенная цифра.

  5. Напечатайте цифры 2, 3 и 4, нажимая перед вводом каждой из них клавишу Tab.

  6. Нажмите клавишу Enter и введите еще четыре числа, предваряя каждое из них нажатием клавиши Tab. В документе появятся два столбца чисел, выравненных по размещенным ранее позициям табуляции, как показано на рис. 6.11.

  7. Выделите две строки с числами и перетащите значок табуляции с отметки 8 см на отметку 7 см. Третий столбец таблицы сместится влево вслед за значком табуляции.

Нажатие клавиши Tab всегда перемещает текстовый курсор к следующей из установленных позиций табуляции, а сдвиг значка табуляции влечет смещение текста, привязанного к этой позиции. Таким образом можно строить небольшие таблички и задавать стандартные отступы. Word предлагает несколько режимов выравнивания текста по позиции табуляции. Чтобы выбрать нужный вариант, щелкайте на прямоугольнике режима табуляции в левой части горизонтальной линейки до тех пор, пока не появится нужный значок. После этого щелчком разместите позицию табуляции на нужной отметке горизонтальной линейки. Значки разных типов табуляции и возможные режимы выравнивания перечислены в табл. 6.2.

Рис. 6.11. Табулированный текст

ТАБЛИЦА 6.2. Типы табуляции

Значок | Назначение режима
 | Левый край текста выравнивается по табуляции
 | Правый край текста выравнивается по табуляции
 | Центр выравнивается по табуляции
 | Десятичная точка числа выравнивается по табуляции
 | Вертикальный отрезок в данной опции
 | Непосредственное размещение отступа первой строки
 | Непосредственное размещение левого отступа тела абзаца

Примечание

Чтобы удалить позицию табуляции, перетащите ее значок на поле режима табуляции.

  8. Не отменяя выделения столбцов, выберите команду Формат > Табуляция (For mat > Tabs). Откроется окно диалога, показанное на рис. 6.12.

  9. В списке Позиции табуляции (Tab Stop Position) щелкните на последней строке.

  10. Щелкните на кнопке Удалить (Clear), чтобы убрать позицию табуляции, расположенную в районе 11 см.

Рис. 6.12. Окно диалога настройки табуляции

  11. В поле ввода Позиции табуляции (Tab Stop Position) введите число 12.

  12. Выберите положение По правому краю (Right) переключателя Выравнивание (Alignment).

  13. Выберите положение 2 переключателя Заполнитель (Leader).

  14. Щелкните на кнопке Установить (Set).

Рис. 6.13. Коррекция четвертой позиции табуляции

  15. Закройте окно щелчком на кнопке ОК. Теперь вместо табуляции в районе 11 см (которая была установлена на глаз) появится табуляция в позиции 12 см с выравниванием текста по правому краю и с заполнением пустого пространства перед табуляцией точками, как показано на рис. 6.13.

Примечание

Счетчик По умолчанию (Default Tab Stops) окна диалога Табуляция (Tabs) задает расстояние между позициями табуляций, присутствующими по умолчанию правее самой правой табуляции, установленной пользователем (см. рис. 6.12), а также по всей ширине документа при отсутствии принудительно настроенных табуляций.

Упражнение 5. Стиль

Стиль — это именованное описание формата абзаца или символов текста. Вместо того чтобы вручную форматировать каждый абзац, можно задать стиль и настроить для него необходимые параметры. Затем таким стилем можно оформить любой блок текста, в результате параметры стиля будут перенесены на конкретный фрагмент документа.

Стили бывают двух типов:

  • абзацный — задает оформление целого абзаца;

  • символьный — задает шрифт, начертание и оформление фрагмента текста абзаца.

Любому символу текста всегда присущи два стиля: абзацный и символьный. По умолчанию Word присваивает тексту абзацный стиль Обычный (Normal) и символьный стиль Основной шрифт абзаца (Default Paragraph Font). Все приемы форматирования текста, рассмотренные выше на этом занятии, не влияли на его стиль. Сейчас давайте сформируем два новых стиля.

  1. Создайте новый документ. Выберите команду Формат > Стили и Форматирование (Format >Styles and Formatting). В правой части экрана в области задач откроется соответствующее окно, показанное на рис. 6.14.

Рис. 6.14. Окно стилей

  2. В разделе Выберите форматирование для применения (Pick Formatting to Apply) перечислен набор доступных стилей. Поставьте указатель мыши на одном из них. Появляется всплывающая подсказка с кратким описанием указанного стиля. Щелкните на выбранном стиле. В разделе Форматирование выделенного текста (Formatting Selected Text) появится название этого стиля и раскрывающийся список, содержащий доступные операции.

Примечание

Благодаря наличию области задач в приложениях Microsoft Office XP работа по созданию, изменению и применению стилей значительно облегчилась.

  3. Щелкните на кнопке Создать стиль (New Style), откроется окно диалога Создание стиля (New Style), показанное на рис. 6.15.

  4. В раскрывающемся списке Стиль (Style Type) оставьте вариант Абзаца (Paragraph), так как сейчас нам нужен стиль для оформления абзаца.

Рис. 6.15. Создание нового стиля

  5. В поле Имя (Name) введите название Красивый абзац.

  6. В списке Основан на стиле (Style Based On) выберите пункт Обычный (Normal). В результате все параметры нового стиля будут соответствовать одноименным параметрам стиля Обычный (Normal), которые мы затем немного изменим.

  7. Щелкните па кнопке Формат (Format) и в раскрывшемся меню выберите пункт Абзац (Paragraph). Откроется стандартное окно форматирования абзаца (см. выше рис. 6.4), с помощью которого в данной ситуации задаются параметры шрифта настраиваемого стиля.

  8. Выберите режим выравнивания По ширине (Justified), введите для отступов абзаца слева и справа значение 1 см, для отступа первой строки — 2 см и для интервала перед абзацем — 6 пунктов. Затем щелкните два раза на кнопке ОК. Новый стиль появится в списке Выберите форматирование для применения (Pick Formatting to Apply) окна диалога Стили и Форматирование(Styles and Formatting).

  9. Снова щелкните на кнопке Создать стиль (New Style).

  10. В раскрывающемся списке Стиль (Style Type) появившегося окна диалога Создание стиля (New Style) выберите пункт Знака (Character), чтобы определить новый символьный стиль.

  11. В поле Имя (Name) введите название Крупный текст.

  12. В списке Основан на стиле (Based On) выберите пункт Основной шрифт абзаца (Default Paragraph Font).

  13. Щелкните на кнопке Формат (Format) и в раскрывшемся меню выберите пункт Шрифт (Font).

Примечание

Меню кнопки формат (Format) открывает доступ к любым параметрам абзаца или шрифта. Самостоятельно изучите остальные команды этого меню.

  14. В открывшемся окне диалога форматирования шрифта (см. рис. 6.11)выбери-те шрифт ArialCyr, размер 20 пунктов, начертание Полужирный курсив (Bold Italic).

  15. Два раза щелкните на кнопке ОК, а затем щелкните на кнопке Close (Закрыть). Теперь документ содержит описания двух новых стилей, с помощью которых можно форматировать абзацы и фрагменты текста.

  16. Введите несколько абзацев текста и выделите первые три.

  17. В раскрывающемся списке Стиль (Style) панели инструментов Форматирование (Formatting) выберите новый стиль Красивый абзац. Три выделенных абзаца окажутся оформленными в соответствии с только что созданным абзацным стилем.

  18. Выделите несколько слов в первом абзаце и выберите в том же списке Стиль (Style) пункт Крупный текст. Выделенные слова изменятся в соответствии с новым символьным стилем.

  19. Повторите эту операцию, выделяя слова второго, третьего и четвертого абзацев (рис. 6.16).

Казалось бы, те же самые операции можно выполнить и с помощью обычных команд форматирования, но оформление текста с помощью стилей дает несколько преимуществ.

  • Стиль способен хранить сложный вариант форматирования, который можно быстро назначить любому абзацу или фрагменту.

  • Стиль можно поместить в шаблон, и его унаследуют все документы, созданные на основе этого шаблона.

  • Изменив стиль, вы моментально измените вид всех фрагментов документа, оформленных в соответствии с этим стилем.

Рис. 6.16. Оформление с помощью стилей

  • Модифицировав стиль в шаблоне, вы сразу же измените вид всех фрагментов текста, отформатированных этим стилем во всех документах, основанных на скорректированном шаблоне. (Чтобы этого добиться, для каждого из выбранных документов в окне диалога Шаблоны и надстройки (Templates And Add-ins), которое открывается командой Сервис > Шаблоны и надстройки (Tools > Templates And Add-ins), должен быть установлен флажок Автоматически обновлять стили (Automatically Update Document Styles)).

  20. Чтобы почувствовать всю мощь шаблонов в действии, снова выберите команду Формат > Стили и Форматирование (Format > Styles and Formatting), в списке Выберите форматирование для применения (Pick Formatting to Apply) выделите пункт Красивый абзац и в раскрывающемся списке выберите команду Изменить (Modify).

  21. В окне диалога Изменение стиля (Modify Style) щелкните на кнопке Формат (Format), а затем выберите в раскрывшемся списке пункт Абзац (Paragraph).

  22. В окне диалога Абзац (Paragraph) увеличьте отступы слева и справа до 2 см. Два раза щелкните на кнопке ОК, а затем щелкните на кнопке Закрыть (Close).

Обратите внимание, что увеличились отступы у трех первых абзацев, которым был назначен стиль Красивый абзац. Аналогичным способом можно быстро скорректировать, например, размер шрифта фрагментов, выделенных стилем Крупный текст. Подумайте, сколько бы времени ушло на такое изменение оформления стандартными средствами, если бы потребовалось модифицировать несколько абзацев, разбросанных по многостраничному документу.

Подготовив специальные стили для определенных элементов текста (например, для подрисуночных подписей), вы сможете настраивать формат всех подписей с помощью простой корректировки соответствующего стиля. С помощью стилей можно выполнить любое форматирование текста. При отсутствии достаточного опыта такой подход потребует дополнительных затрат времени, но, научившись изменять оформление документов путем манипуляций со стилями, вы сможете экономить-многие часы.

Графические объекты

Word умеет внедрять в свои документы объекты других приложений Windows, например графического редактора Paint. Но на этом оформительские возможности Word не заканчиваются. В пакет Microsoft Office XP входит несколько специализированных модулей, доступных в любом из шести основных приложений, со своей стороны предлагающих пользователю команды и инструменты быстрого доступа к таким дополнительным компонентам. Эти модули формируют и добавляют в документы объекты определенных типов. С одним из них — инструментом WordArt — вы познакомились на занятии 1.

Упражнение 6. Фигуры и надписи

В Word, PowerPoint и Excel есть специальная панель инструментов Рисование (Drawing), которая позволяет украшать документы разнообразными фигурами. Чтобы такие фигуры были видны в документе Word, переключитесь в режим разметки страницы или в режим электронного документа. Если панель инструментов, показанная на рис. 6.17, отсутствует на экране, щелкните на кнопке Рисование (Drawing) панели инструментов Стандартная (Standard).

Рис. 6.17. Панель инструментов рисования

Теперь давайте нарисуем несколько фигур.

  1. Введите в документ текст Это прямоугольник.

  2. В панели инструментов Рисование (Drawing) щелкните на кнопке Прямоугольник (Rectangle).

  3. Переместите указатель выше и правее введенного текста, нажмите кнопку мыши и растяните диагональ прямоугольника так, чтобы он охватил текст. Предполагалось, что прямоугольник будет играть роль рамки, выделяя текст. Но сам текст пропал. Почему так получилось? Дело в том, что любая фигура имеет границу и внутреннюю область. По умолчанию граница рисуется тонкой черной линией, а внутренняя область закрашивается белым цветом. Эти параметры легки изменить.

  4. Щелкните в панели инструментов Рисование (Drawing) на стрелке справа от кнопки Цвет заливки (Fill Color) и в раскрывшейся палитре выберите пункт Нет заливки (No Fill). Прямоугольник станет прозрачным, и текст снова появится на экране.

  5. Щелчком на стрелке справа от кнопки 11вет линии (Line Color) раскройте палитру цвета границы фигуры и выберите в ней синий квадрат.

  6. Щелкните в той же панели инструментов на кнопке Объем (3D) и в раскрывшейся палитре вариантов объемного оформления выберите второй значок первого ряда. Теперь текст окружен синим объемным прямоугольником (рис. 6.18).

Рис. 6.18. Фигуры в документе Word

  7. Щелкните на кнопке Автофигуры (AutoShapes) панели инструментов Рисование (Drawing).

  8. Выберите в раскрывшемся меню пункт Фигурные стрелки > Стрелка влево (Block Arrows > Left Arrow).

  9. Растяните мышью стрелку ниже прямоугольника, как показано на рис. 6.19.

  10. С помощью палитры кнопки Цвет заливки (Fill Color) залейте стрелку зеленым цветом.

  11. Щелкните на кнопке Тип лини и (Line Style) и выберите линию толщиной 3 пункта. Любая фигура имеет восемь управляющих маркеров, которые отображаются в виде залитых квадратов в углах и по серединам границ габаритного контейнера фигуры и позволяют изменять ее размеры. Сверху от габаритного контейнера располагается еще одна точка, окрашенная в зеленый цвет. Поместив в нее указатель мыши, можно свободно поворачивать габаритный контейнер, а с ним и всю фигуру. Некоторые фигуры дополнительно имеют одну или несколько управляющих точек в виде желтых ромбов, позволяющих изменять форму фигуры. Стрелка обладает одной такой точкой.

  12. Захватите правый средний маркер нарисованной стрелки и перетащите его вправо. Стрелка станет шире.

  13. Перетащите управляющую точку вправо. Стрелка изменит свою форму и станет примерно такой, как показано на рис. 6.19.

Рис. 6.19. Изменение формы и расположения фигур

  14. В панели инструментов Рисование (Drawing) выберите команду Автофигуры > Выноски > Скругленная прямоугольная выноска (AutoShapes > Callouts> Rounded Rectangular Callout).

  15. Растяните выноску, показанную на рис. 6.20, чтобы она перекрывала стрелку и прямоугольник. При необходимости скорректируйте форму выноски с помощью управляющих маркеров.

  16. Щелкните внутри выноски и введите текст Это стрелка влево. Не забудьте, что при редактировании текста кнопка Выбор объектов (Select Objects) должна быть отжата. Подобные выноски позволяют располагать надписи в любом месте документа, на схемах, рисунках и графиках.

  17. На самом деле надпись можно добавить в любую автофигуру. Щелкните на кнопке Выбор объектов (Select Objects), а затем на стрелке, чтобы выделить ее.

  18. Щелкните на кнопке Надпись (Text Box), а затем введите текст Надпись на стрелке. Он появится прямо на зеленом поле стрелки, будет перемещаться вместе с ней и никогда не выйдет за границы этой стрелки.

  19. Снова щелкните на кнопке Выбор объектов (Select Objects), так как ввод надписи автоматически отключает этот режим, а затем щелчком выделите объемный прямоугольник.

  20. В панели инструментов Рисование (Drawing) выберите команду Действия > Порядок > На передний план (Draw > Order > Bring To Front). Порядок расположения объектов изменится. Если раньше выноска располагалась поверх объемного прямоугольника, то теперь прямоугольник оказывается сверху выноски.

Примечание

Фигура, которую вы хотите отформатировать, должна быть выделена, то есть окружена габаритным контейнером с маркерами. Если маркеров нет, щелкните на кнопке Выбор объектов (Select Objects) панели инструментов Рисование (Drawing), а затем на той фигуре, которую нужно модифицировать. Чтобы выключить режим выделения и продолжить редактирование текста документа, повторно щелкните на кнопке Выбор объектов (Select Objects).

Меню Действия (Draw) и Автофигуры (AutoShapes) позволяют рисовать самые разнообразные графические объекты и выполнять с ними многие операции, такие как группировка, равномерное распределение по странице или вращение. Попробуйте сами изучить возможности панели инструментов Рисование (Drawing). С ее помощью можно рисовать достаточно сложные схемы, не прибегая к услугам графических редакторов.

Упражнение 7. Библиотека картинок

Microsoft Office XP предлагает обширную библиотеку рисунков, в которой можно найти подходящую картинку для оформления практически любого документа. Поскольку Word — это текстовый редактор, оперирующий с символами, картинки, так же как и фигуры, не просто помещаются в то или иное место страницы, они оказываются привязанными к определенному символу документа. Это очень удобно.. При редактировании многостраничного файла текст может сместиться на несколько страниц, при этом произойдет аналогичное перемещение всех связанных с текстом рисунков и логика документа не нарушится. Чтобы добавить рисунок библиотеки ClipArt в документ Word, созданный в предыдущем упражнении, выполните следующие шаги.

  1. Щелкните в конце строки Это прямоугольник, нажмите несколько раз клавишу Enter, чтобы текстовый курсор оказался ниже зеленой стрелки, и введите текст Вставляем рисунок.

Примечание

В документе, показанном на рис. 6.19, только строка Это прямоугольник является настоящим абзацем документа Word. Все остальные надписи расположены на автофигурах и являются их неотъемлемой частью. Эти надписи исчезают с экрана при переключении в обычный режим просмотра.

  2. Выберите команду Вставка >Рисунок > Картинки (Insert > Picture > ClipArt). Откроется окно Вставка картинки (Insert ClipArt), показанное на рис. 6.20.

  3. Введите ключевое слово Животные (Animals) для поиска картинки в поле Искать текст (Search text) в разделе Поиск клипа (Search for) и щелкните на кнопке Найти (Search). В поле Результаты (Results) появятся имеющиеся в коллекции картинки с изображениями животных.

Рис. 6.20. Окно Вставка картинки области задач

  4. Наведите указатель мыши на понравившуюся картинку. Щелкните на стрелке, появившейся справа от картинки и в раскрывшемся меню выберите пункт Вставить (Insert). Рисунок будет вставлен в конец строки Вставляем рисунок.

  5. Захватите угловой маркер рамки рисунка и перетащите его по направлению к центру рисунка, чтобы немного уменьшить размеры объекта.

  6. Захватив рисунок мышью за середину, перетащите его влево, чтобы он оказался между словами Вставляем и рисунок, как показано на рис. 6.21. Когда рисунок выделен, в окне Word появляется панель инструментов Настройка изображения (Picture), показанная на рис. 6.22, которая позволяет изменять контрастность, яркость, режим обтекания текстом и другие параметры рисунка.

Рис. 6.21. Добавление рисунка

Примечание

Теперь рисунок привязан к слову Вставляем. Попробуйте добавить несколько абзацев перед строкой Вставляем рисунок или несколько слов в начало этой строки. Вы заметите, что рисунок перемещается вместе со словом Вставляем.

Рис. 6.22. Панель инструментов для настройки изображения

Примечание

В контекстном меню любого выделенного объекта доступна команда ГиnepccbiAKa(l-lyperlink), которая превращает текст, рисунок, фигуру и любой другой элемент документа в гиперссылку на другой документ или на web-страницу Интернета.

  7. Щелкните на добавленном рисунке правой кнопкой мыши и выберите в контекстном меню команду Гиперссылка (Hyperlink).

  8. Вокнедиалога Добавление гиперссылки (Insert Hyperlink), показанном на рис. 6.23, укажите имя файла или URL документа Интернета либо выберите нужный объект в списке.

  9. Щелкните на кнопке ОК.

Рис. 6.23. Окно диалога добавления гиперссылки

Четыре кнопки в левой части этого окна диалога позволяют связать объект с ги-перссылками следующих категорий:

  • Имеющимся файлом, веб-страницей (Existing File Or Web Page) — недавно открывавшиеся файлы, недавно просматривавшиеся web-страницы или любой другой ресурс, имя которого можно ввести в поле Адрес: (Address:);

  • Местом в этом документе (Place In This Document) — заголовки и закладки текущего документа;

  • Новым документом (Create New Document) — ссылка на несуществующий документ, который будет создан позже;

  • Электронной почтой (E-mail Address) — электронный адрес удаленного пользователя. При щелчке на такой ссылке запускается программа Outlook, которая позволяет отправить письмо по адресу гиперссылки.

Когда гиперссылка назначается текстовому фрагменту, Word окрашивает текст другим цветом и подчеркивает его, сигнализируя о наличии гиперссылки. Рисунки „ с гиперссылками никак не выделяются. Чтобы найти такие ссылки, перемещайте '' указатель по всем рисункам документа. Если рисунок связан с гиперссылкой, на экране появится всплывающая подсказка с именем ресурса, на который ссылается рисунок.

  10. Чтобы добавить в документ еще один рисунок, переместите текстовый курсор в ту точку, куда нужно вставить рисунок, и с помощью области задач переключитесь в окно Вставка картинки (ClipArt).

  11. Щелкните на кнопке Изменить (Modify) окна Вставка картинки (ClipArt), чтобы вернуться к разделу Поиск клипа (Search for), и повторите описанные выше действия.

Библиотека картинок обладает широкими возможностями сортировки и поиска картинок по ключевым словам. Из окна Вставка картинки (ClipArt) можно связаться с Интернетом и поискать картинки на специальном сервере компании Microsoft, Откуда их можно перенести в локальную библиотеку. Для этого выберите в разделе См.также (See Also) раздел Коллекция картинок в Интернете (Clips Online). Окно Вставка картинки (ClipArt) также позволяет импортировать в библиотеку рисунки из графических файлов различных форматов.

Контрольное упражнение

Word предлагает огромное количество приемов форматирования текста и объектов. Контрольное упражнение поможет освоить еще несколько полезных операций.

  1. Создайте нумерованный список из четырех пустых абзацев.

  2. Добавьте в каждый абзац по одному рисунку библиотеки картинок, выравняв их размеры.

  3. Разместите абзацы с рисунками в два столбца. Теперь на странице документа должны быть видны четыре пронумерованных рисунка.

  4. Добавьте ниже рисунков еще один абзац с текстом. Он автоматически получит номер 5 и разместится во втором столбце.

    • Как отменить нумерацию абзаца и расположить его ниже столбцов, чтобы он занял всю ширину страницы?

  5. Увеличьте левый отступ пятого абзаца.

    • Как с помощью панели инструментов изменить отступ абзаца ?

  6. Обведите все четыре рисунка овалами с прозрачным заполнением и красной границей толщиной в 6 пунктов.

  7. Выделите в пятом абзаце несколько слов и назначьте им шрифт Arial Cyr размером 18 пунктов и курсивное начертание.

  8. Добавьте в нижнюю часть документа еще один абзац с несколькими строками текста.

  9. Выделите первые три слова этого абзаца тем же шрифтом, которым выделялись слова на шаге 14 упражнения 5.

    • Как скопировать формат текста, используя кнопку Формат по о'бразцу (Fonnat Painter) панели инструментов?

  10. С помощью табуляций добавьте в конец документа табличку из четырех столбцов с выравниванием чисел по правому краю па отметках 2,6,10 и 14 см и вертикальными линиями в позициях 3, 7 и 11 см.

Подведение итогов

Вы получили представление о том, как форматировать текст, создавать и назначать стили, настраивать отступы и интервалы, пользоваться табуляциями, добавлять в документы Word фигуры и рисунки. Не останавливайтесь па достигнутом, старайтесь не только постоянно применять известные инструменты, но и расширять свой кругозор, пытаясь изменять еще незнакомые вам параметры окон диалога Word и пользуясь всевозможными командами контекстных меню объектов и кнопками панелей инструментов. Для получения подсказок и разъяснений обращайтесь к справочной системе Microsoft Office.

На следующем занятии вы научитесь строить таблицы и пояснять текстовое содержание диаграммами и графиками.


Занятие №6

Оформление документа

ТЕМА ЗАНЯТИЯ

На занятии рассказывается об инструментах Word, позволяющих форматировать текст и придавать документу необходимое оформление. Вы познакомитесь с операциями и элементами форматирования, которые перечислены ниже:

  • настройка отступов и интервалов;

  • табуляция;

  • маркированные и нумерованные списки;

  • текст в несколько столбцов;

  • выбор начертания и размера шрифта;

  • стиль;

  • линии и фигуры;

  • библиотека ClipArt.


Параметры абзаца

Простейшие текстовые редакторы, подобные Блокнот (Notepad) или встроенному редактору командной оболочки Norton Commander, не отслеживают смысловую логику документа. В них основной структурной единицей является символ. В текстовых процессорах, к которым относится и Word, в качестве элементарного структурного блока рассматривается абзац. Word полагает, что содержимое абзаца является связным текстом, и сам расставляет буквы и слова внутри абзаца наилучшим образом в соответствии с назначенными пользователем правилами форматирования. В результате в процессе редактирования документа отпадает необходимость в корректировке длины строк, выделении заголовков специальным шрифтом, добавлении маркеров списков и отступов «красной строки». Word сам позаботится о правильном оформлении. Вам нужно лишь указать программе правила, в соответствии с которыми должен форматироваться документ.


Упражнение 1. Отступы, интервалы и табуляции

Конфигурация абзаца характеризуется отступами сверху и снизу, интервалами слева и справа, межстрочным интервалом, отступом первой строки, режимом выравнивания текста по ширине страницы и некоторыми другими параметрами. Давайте изучим приемы настройки этих величин.

  1. Запустите Word и в автоматически открывшемся новом документе напечатайте несколько десятков слов, например введите текст любого абзаца этой книги. Обратите внимание, что по достижении правого края страницы текст автоматически переносится на следующую строку.

  2. Окончив ввод абзаца, нажмите клавишу Enter. Текстовый курсор переместится на новую строку, обозначив этим конец текущего абзаца и подготовив текстовый процессор для ввода следующего.

  3. Введите еще несколько абзацев.

  4. Щелчком на кнопке Режим разметки (Print Layout View) переключитесь в режим разметки страниц, который позволяет видеть точное форматирование текста. (На протяжении всего занятия используйте именно этот режим просмотра документа.)

  5. Если на экране нет вертикальной и горизонтальной линеек, включите их командой Вид > Линейка (View > Ruler). Теперь окно Word будет выглядеть примерно так, как показано на рис. 6.1. Чтобы задать расстояния от границ левого и правого полей страницы до абзацев некоторого блока текста, нужно настроить отступы блока. При изменении ширины полей страницы размеры абзацев модифицируются таким образом, чтобы отступы от краев полей оставались неизменными. Для настройки отступов блока текста нужно сначала выделить этот текст. Если требуется модифицировать параметры только одного абзаца, достаточно просто поместить в него текстовый курсор.

  6. Выделите второй и третий абзацы.

Рис. 6.1. Пять абзацев и линейки в режиме разметки страниц

  7. В левой части горизонтальной линейки найдите треугольный маркер Отступ первой строки (First Line Indent), вершина которого направлена вниз, захватите его мышью и перетащите вправо на 3 см. Перемещением этого маркера можно изменять положение начала первых строк выделенных абзацев, не изменяя отступов остального текста. Заметьте, что первая строка может начинаться как правее (отступ), так и левее (выступ) основного текста.

  8. Перетащите вправо на 1 см маркер Выступ (Hanging Indent), имеющий форму треугольника, вершина которого направлена вверх. Изменится левый отступ тела абзацев, но отступ первых строк останется прежним.

  9. В левой части горизонтальной линейки есть еще один маркер, имеющий форму прямоугольника, — Отступ слева (Left Indent). Перетащите его вправо на 1 см. Вы увидите, что перемещение этого маркера равносильно синхронному сдвигу маркеров Отступ первой строки (Line Indent) и Выступ (Hanging Indent) на одинаковое расстояние, то есть приводит к смещению левого края абзаца относительно поля страницы.

  10. Щелкните на тексте второго абзаца, сняв выделение блока текста и поместив курсор в тело этого абзаца.

  11. Перетащите влево на 4 см маркер Отступ справа (Right Indent), расположенный в правой части горизонтальной линейки. Он задает правый край абзаца.

После всех проделанных операций текст выглядит так, как показано на рис. 6.2.

Рис. 6.2. Настройка отступов

  12. Щелкните на кнопке По центру (Center) панели инструментов Форматирование (Formatting).

Рис. 6.3. Режимы выравнивания

Рис. 6.4. Окно диалога параметров абзаца

  13. Выделите третий абзац и щелкните на кнопке По правому краю (Align Right) той же панели инструментов.

  14. Щелкните на четвертом абзаце, а затем на кнопке По ширине (Justify). Теперь первые четыре абзаца текста демонстрируют четыре режима выравнивания текста (рис. 6.3).

  15. Выделите второй, третий и четвертый абзацы и выберите команду Формат > Абзац (Format > Paragraph). Вкладка Отступы и интервалы (Indents And Spacing) открывшегося окна диалога (рис. 6.4) позволяет задавать отступы абзаца и режим выравнивания, которые мы настраивали с помощью горизонтальной линейки и кнопок панели инструментов Форматирование (Formatting). Раздел Интервал (Spacing) той же вкладки позволяет задать интервал между строками внутри абзаца и расстояние между абзацами.

Рис. 6.5. Настройка интервалов

  16. Введите в счетчик перед (Before) число 6.

  17. В списке междустрочный (Line Spacing) выберите пункт Полуторный (1,5 tines).

  18. Щелкните на кнопке ОК. Интервалы в трех выделенных абзацах изменятся и станут такими, как показано на рис. 6.5. Обратите внимание, что область Образец (Preview) окна диалога Абзац (Paragraph) позволяет наблюдать влияние введенных величин па вид текущего абзаца еще до окончательного применения выбранных значений параметров к тексту документа.

  19. Сохраните документ, он пригодится вам в следующих упражнениях.


Упражнение 2. Списки и столбцы

Word позволяет последовательно нумеровать абзацы или выделять их с помощью разнообразных маркеров, размещаемых слева от первых строк абзацев. Для изучения маркированных и нумерованных списков воспользуйтесь текстом документа, созданным в предыдущем упражнении.

  1. Нажатием клавиш Ctrl+A выделите весь текст.

  2. Чтобы вернуть всем абзацам оформление, свойственное стилю Обычный (Normal), выберите соответствующий пункт в раскрывающемся списке Стиль (Style) панели инструментов Форматирование (Formatting).

  3. Щелкните на кнопке Нумерация (Numbering) той же панели инструментов. Абзацы будут пронумерованы последовательными числами.

  4. Поместите курсор в конец второго абзаца и нажмите клавишу Enter. Новому абзацу автоматически будет присвоен номер 3, а номера последующих абзацев изменятся так, чтобы сохранилась непрерывная последовательность чисел.

Рис. 6.6. Списки

  5. Выделите второй абзац, затем щелкните на кнопке Маркеры (Bullets) панели инструментов Форматирование (Formatting). Номер выделенного абзаца заменится на маркер. Заметьте, что при этом остальные абзацы снова будут перенумерованы (рис. 6.6).

  6. Word предлагает пользователям разнообразные типы нумерации и значки маркеров. Чтобы оформить фрагмент текста по своему вкусу, выделите его и выполните команду Формат > Список (Format > Bullets And Numbering). Вкладка Маркированный (Bulleted) открывшегося окна диалога Список (Bullets And Numbering) позволяет выбрать для выделенных абзацев форму маркеров (рис. 6,7). Для этого достаточно щелкнуть на прямоугольнике с маркером нужного типа, а затем на кнопке ОК. Вкладка Нумерованный (Numbered) того же окна диалога дает возможность указать тип нумерации. Эта вкладка практически идентична предыдущей, что указывает на родственную природу маркированных и нумерованных списков.

Рис. 6.7. Выбор маркера

Примечание

Чтобы убрать маркеры и нумерацию, выберите в окне диалога Список (Bullets And Numbering) прямоугольник Нет (None).

В некоторых случаях текст документа необходимо разместить в несколько столбцов. Чтобы преобразовать в такую форму готовый текст, выполните следующие действия.

  7. Выделите первый и второй абзацы рабочего примера и щелкните на кнопке Колонки (Columns) панели инструментов Стандартная (Standard). В раскрывшейся палитре щелкните на третьем столбце. Теперь текст первых двух абзацев будет разбит на три столбца, как показано на рис. 6.8.

    Обратите внимание, что с помощью горизонтальной линейки можно по отдельности настраивать отступы каждого столбца (для этого нужно выделить соответствующий фрагмент текста) и интервалы между столбцами.

  8. Чтобы изменить параметры столбцов, переместите курсор в текст одного из них и выполните команду Формат > Колонки (Format > Columns). В открывшемся окне диалога можно выбрать одну из пяти стандартных конфигураций столбцов, задать число столбцов, их ширину и расстояние между ними.

Рис. 6.8. Текст в три столбца

Примечание

Столбцы видны в документе только в режиме разметки страницы. Во всех остальных режимах просмотра текст выводится в один столбец, хотя параметры столбцов при этом не сбрасываются и учитываются при печати такого документа в любом режиме просмотра.


Форматирование текста

Возможности оформления не ограничиваются параметрами абзацев. Word позволяет изменять размер, начертание, цвет и другие характеристики шрифта, которым набран текст документа. Для облегчения ввода текста и представления табличных данных можно воспользоваться табулированными отступами. Чтобы задать однотипное оформление нескольким абзацам одного или разных документов, можно настроить абзацные стили пользователя.


Упражнение 3. Выбор шрифта

Программа Word позволяет настраивать различные параметры символов. В этом упражнении мы коснемся лишь некоторых. Давайте рассмотрим кнопки панели инструментов, позволяющие быстро изменять начертание шрифта.

  1. Чтобы отформатировать символы фрагмента текста, выделите его, а затем щелкните на одной из кнопок панели инструментов Форматирование (Formatting), перечисленных в табл. 6.1.

ТАБЛИЦА 6.1. Раскрывающиеся списки и кнопки форматирования символов
Кнопка или список | Клавиатурная комбинация | Назначение
Bold (Полужирный) | Ctrl+B | Выделяет полужирным начертанием
Italic (Курсив) | Ctrl+I | Выделяет курсивом
Underline (Подчеркнутый) | Ctrl+U | Подчеркивает текст
Font Size (Размер шрифта) |  | Позволяет выбрать или ввести размер шрифта
Font (Шрифт) |  | Позволяет выбрать один из шрифтов, установленных в Windows
Font Color (Цвет шрифта) |  | Щелчок на кнопке выделяет текст ранее выбранным цветом. Щелчок на стрелке справа от кнопки раскрывает палитру цветов, с помощью которой задается цвет текста
Highlight (Выделение цветом) |  | Щелчок на кнопке окрашивает фон текста ранее выбранным цветом. Щелчок на стрелке справа от кнопки раскрывает палитру цветов, с по мощью которой задается цвет фона
Superscript (Верхний индекс) | Ctrl+Shift+= | Преобразует выделенный текст в верхний индекс
Subscript (Нижний индекс) | Ctrl+O | Преобразует выделенный текст в нижний индекс

На рис. 6.9 показан пример текста, разные фрагменты которого выделены тем или иным способом форматирования.

Рис. 6.9. Варианты форматирования текста

Примечание

Две последние кнопки из перечисленных в табл. 6.1 в стандартной конфигурации Word отсутствуют на панели инструментов. Чтобы они там появились, щелкните на треугольнике, расположенном в правой части панели инструментов, выберите команду Добавить или удалить кнопки (Add Or Remove Buttons) и щелкните в раскрывшемся списке кнопок на соответствующих названиях.

Рис. 6.10. Выбор формата шрифта

  2. Для получения доступа к дополнительным параметрам шрифта выберите команду Формат > Шрифт (Format > Font). Откроется окно диалога Шрифт (Font). Одноименная вкладка, показанная на рис. 6.10, позволяет выбрать шрифт, его размер, вариант начертания, режим и цвет подчеркивания. Здесь же есть несколько флажков, позволяющих включать и отключать режимы оформления.

Примечание

Если изменить форматирование текста, не выделив предварительно никакого фрагмента, то новый формат будет назначен тексту, вводимому в точке текстового курсора. Однако любое перемещение курсора до ввода первого символа отменит новую настройку формата.

  3. Две другие вкладки окна диалога Шрифт (Font) дают возможность настраивать интервалы между буквами, смещение символов и кернинг, а также назначать тексту анимационные эффекты.


Упражнение 4. Табуляция

В то время как поля и отступы определяют общий вид документа и абзацев, табуляции помогают размещать текст внутри абзаца. Позиции табуляции задают точки на горизонтальной линейке, по которым можно выравнивать текст. В этом упражнении с помощью табуляций строится небольшая таблица из двух строк.

  1. Создайте новый документ Word.

  2. Щелкните на горизонтальной линейке на отметке 2 см. На линейке появится значок табуляции.

  3. Щелкните на отметках 5,8 и 11 см, чтобы добавить еще три позиции табуляции.

  4. Нажмите клавишу Tab и введите цифру-1. Текстовый курсор перепрыгнет в текущей строке вправо на позицию 2 см, где и появится введенная цифра.

  5. Напечатайте цифры 2, 3 и 4, нажимая перед вводом каждой из них клавишу Tab.

  6. Нажмите клавишу Enter и введите еще четыре числа, предваряя каждое из них нажатием клавиши Tab. В документе появятся два столбца чисел, выравненных по размещенным ранее позициям табуляции, как показано на рис. 6.11.

  7. Выделите две строки с числами и перетащите значок табуляции с отметки 8 см на отметку 7 см. Третий столбец таблицы сместится влево вслед за значком табуляции.

Нажатие клавиши Tab всегда перемещает текстовый курсор к следующей из установленных позиций табуляции, а сдвиг значка табуляции влечет смещение текста, привязанного к этой позиции. Таким образом можно строить небольшие таблички и задавать стандартные отступы. Word предлагает несколько режимов выравнивания текста по позиции табуляции. Чтобы выбрать нужный вариант, щелкайте на прямоугольнике режима табуляции в левой части горизонтальной линейки до тех пор, пока не появится нужный значок. После этого щелчком разместите позицию табуляции на нужной отметке горизонтальной линейки. Значки разных типов табуляции и возможные режимы выравнивания перечислены в табл. 6.2.

Рис. 6.11. Табулированный текст

ТАБЛИЦА 6.2. Типы табуляции

Значок | Назначение режима
 | Левый край текста выравнивается по табуляции
 | Правый край текста выравнивается по табуляции
 | Центр выравнивается по табуляции
 | Десятичная точка числа выравнивается по табуляции
 | Вертикальный отрезок в данной опции
 | Непосредственное размещение отступа первой строки
 | Непосредственное размещение левого отступа тела абзаца

Примечание

Чтобы удалить позицию табуляции, перетащите ее значок на поле режима табуляции.

  8. Не отменяя выделения столбцов, выберите команду Формат > Табуляция (For mat > Tabs). Откроется окно диалога, показанное на рис. 6.12.

  9. В списке Позиции табуляции (Tab Stop Position) щелкните на последней строке.

  10. Щелкните на кнопке Удалить (Clear), чтобы убрать позицию табуляции, расположенную в районе 11 см.

Рис. 6.12. Окно диалога настройки табуляции

  11. В поле ввода Позиции табуляции (Tab Stop Position) введите число 12.

  12. Выберите положение По правому краю (Right) переключателя Выравнивание (Alignment).

  13. Выберите положение 2 переключателя Заполнитель (Leader).

  14. Щелкните на кнопке Установить (Set).

Рис. 6.13. Коррекция четвертой позиции табуляции

  15. Закройте окно щелчком на кнопке ОК. Теперь вместо табуляции в районе 11 см (которая была установлена на глаз) появится табуляция в позиции 12 см с выравниванием текста по правому краю и с заполнением пустого пространства перед табуляцией точками, как показано на рис. 6.13.

Примечание

Счетчик По умолчанию (Default Tab Stops) окна диалога Табуляция (Tabs) задает расстояние между позициями табуляций, присутствующими по умолчанию правее самой правой табуляции, установленной пользователем (см. рис. 6.12), а также по всей ширине документа при отсутствии принудительно настроенных табуляций.


Упражнение 5. Стиль

Стиль — это именованное описание формата абзаца или символов текста. Вместо того чтобы вручную форматировать каждый абзац, можно задать стиль и настроить для него необходимые параметры. Затем таким стилем можно оформить любой блок текста, в результате параметры стиля будут перенесены на конкретный фрагмент документа.

Стили бывают двух типов:

  • абзацный — задает оформление целого абзаца;

  • символьный — задает шрифт, начертание и оформление фрагмента текста абзаца.

Любому символу текста всегда присущи два стиля: абзацный и символьный. По умолчанию Word присваивает тексту абзацный стиль Обычный (Normal) и символьный стиль Основной шрифт абзаца (Default Paragraph Font). Все приемы форматирования текста, рассмотренные выше на этом занятии, не влияли на его стиль. Сейчас давайте сформируем два новых стиля.

  1. Создайте новый документ. Выберите команду Формат > Стили и Форматирование (Format >Styles and Formatting). В правой части экрана в области задач откроется соответствующее окно, показанное на рис. 6.14.

Рис. 6.14. Окно стилей

  2. В разделе Выберите форматирование для применения (Pick Formatting to Apply) перечислен набор доступных стилей. Поставьте указатель мыши на одном из них. Появляется всплывающая подсказка с кратким описанием указанного стиля. Щелкните на выбранном стиле. В разделе Форматирование выделенного текста (Formatting Selected Text) появится название этого стиля и раскрывающийся список, содержащий доступные операции.

Примечание

Благодаря наличию области задач в приложениях Microsoft Office XP работа по созданию, изменению и применению стилей значительно облегчилась.

  3. Щелкните на кнопке Создать стиль (New Style), откроется окно диалога Создание стиля (New Style), показанное на рис. 6.15.

  4. В раскрывающемся списке Стиль (Style Type) оставьте вариант Абзаца (Paragraph), так как сейчас нам нужен стиль для оформления абзаца.

Рис. 6.15. Создание нового стиля

  5. В поле Имя (Name) введите название Красивый абзац.

  6. В списке Основан на стиле (Style Based On) выберите пункт Обычный (Normal). В результате все параметры нового стиля будут соответствовать одноименным параметрам стиля Обычный (Normal), которые мы затем немного изменим.

  7. Щелкните па кнопке Формат (Format) и в раскрывшемся меню выберите пункт Абзац (Paragraph). Откроется стандартное окно форматирования абзаца (см. выше рис. 6.4), с помощью которого в данной ситуации задаются параметры шрифта настраиваемого стиля.

  8. Выберите режим выравнивания По ширине (Justified), введите для отступов абзаца слева и справа значение 1 см, для отступа первой строки — 2 см и для интервала перед абзацем — 6 пунктов. Затем щелкните два раза на кнопке ОК. Новый стиль появится в списке Выберите форматирование для применения (Pick Formatting to Apply) окна диалога Стили и Форматирование(Styles and Formatting).

  9. Снова щелкните на кнопке Создать стиль (New Style).

  10. В раскрывающемся списке Стиль (Style Type) появившегося окна диалога Создание стиля (New Style) выберите пункт Знака (Character), чтобы определить новый символьный стиль.

  11. В поле Имя (Name) введите название Крупный текст.

  12. В списке Основан на стиле (Based On) выберите пункт Основной шрифт абзаца (Default Paragraph Font).

  13. Щелкните на кнопке Формат (Format) и в раскрывшемся меню выберите пункт Шрифт (Font).

Примечание

Меню кнопки формат (Format) открывает доступ к любым параметрам абзаца или шрифта. Самостоятельно изучите остальные команды этого меню.

  14. В открывшемся окне диалога форматирования шрифта (см. рис. 6.11)выбери-те шрифт ArialCyr, размер 20 пунктов, начертание Полужирный курсив (Bold Italic).

  15. Два раза щелкните на кнопке ОК, а затем щелкните на кнопке Close (Закрыть). Теперь документ содержит описания двух новых стилей, с помощью которых можно форматировать абзацы и фрагменты текста.

  16. Введите несколько абзацев текста и выделите первые три.

  17. В раскрывающемся списке Стиль (Style) панели инструментов Форматирование (Formatting) выберите новый стиль Красивый абзац. Три выделенных абзаца окажутся оформленными в соответствии с только что созданным абзацным стилем.

  18. Выделите несколько слов в первом абзаце и выберите в том же списке Стиль (Style) пункт Крупный текст. Выделенные слова изменятся в соответствии с новым символьным стилем.

  19. Повторите эту операцию, выделяя слова второго, третьего и четвертого абзацев (рис. 6.16).

Казалось бы, те же самые операции можно выполнить и с помощью обычных команд форматирования, но оформление текста с помощью стилей дает несколько преимуществ.

  • Стиль способен хранить сложный вариант форматирования, который можно быстро назначить любому абзацу или фрагменту.

  • Стиль можно поместить в шаблон, и его унаследуют все документы, созданные на основе этого шаблона.

  • Изменив стиль, вы моментально измените вид всех фрагментов документа, оформленных в соответствии с этим стилем.

Рис. 6.16. Оформление с помощью стилей

  • Модифицировав стиль в шаблоне, вы сразу же измените вид всех фрагментов текста, отформатированных этим стилем во всех документах, основанных на скорректированном шаблоне. (Чтобы этого добиться, для каждого из выбранных документов в окне диалога Шаблоны и надстройки (Templates And Add-ins), которое открывается командой Сервис > Шаблоны и надстройки (Tools > Templates And Add-ins), должен быть установлен флажок Автоматически обновлять стили (Automatically Update Document Styles)).

  20. Чтобы почувствовать всю мощь шаблонов в действии, снова выберите команду Формат > Стили и Форматирование (Format > Styles and Formatting), в списке Выберите форматирование для применения (Pick Formatting to Apply) выделите пункт Красивый абзац и в раскрывающемся списке выберите команду Изменить (Modify).

  21. В окне диалога Изменение стиля (Modify Style) щелкните на кнопке Формат (Format), а затем выберите в раскрывшемся списке пункт Абзац (Paragraph).

  22. В окне диалога Абзац (Paragraph) увеличьте отступы слева и справа до 2 см. Два раза щелкните на кнопке ОК, а затем щелкните на кнопке Закрыть (Close).

Обратите внимание, что увеличились отступы у трех первых абзацев, которым был назначен стиль Красивый абзац. Аналогичным способом можно быстро скорректировать, например, размер шрифта фрагментов, выделенных стилем Крупный текст. Подумайте, сколько бы времени ушло на такое изменение оформления стандартными средствами, если бы потребовалось модифицировать несколько абзацев, разбросанных по многостраничному документу.

Подготовив специальные стили для определенных элементов текста (например, для подрисуночных подписей), вы сможете настраивать формат всех подписей с помощью простой корректировки соответствующего стиля. С помощью стилей можно выполнить любое форматирование текста. При отсутствии достаточного опыта такой подход потребует дополнительных затрат времени, но, научившись изменять оформление документов путем манипуляций со стилями, вы сможете экономить-многие часы.


Графические объекты

Word умеет внедрять в свои документы объекты других приложений Windows, например графического редактора Paint. Но на этом оформительские возможности Word не заканчиваются. В пакет Microsoft Office XP входит несколько специализированных модулей, доступных в любом из шести основных приложений, со своей стороны предлагающих пользователю команды и инструменты быстрого доступа к таким дополнительным компонентам. Эти модули формируют и добавляют в документы объекты определенных типов. С одним из них — инструментом WordArt — вы познакомились на занятии 1.


Упражнение 6. Фигуры и надписи

В Word, PowerPoint и Excel есть специальная панель инструментов Рисование (Drawing), которая позволяет украшать документы разнообразными фигурами. Чтобы такие фигуры были видны в документе Word, переключитесь в режим разметки страницы или в режим электронного документа. Если панель инструментов, показанная на рис. 6.17, отсутствует на экране, щелкните на кнопке Рисование (Drawing) панели инструментов Стандартная (Standard).

Рис. 6.17. Панель инструментов рисования

Теперь давайте нарисуем несколько фигур.

  1. Введите в документ текст Это прямоугольник.

  2. В панели инструментов Рисование (Drawing) щелкните на кнопке Прямоугольник (Rectangle).

  3. Переместите указатель выше и правее введенного текста, нажмите кнопку мыши и растяните диагональ прямоугольника так, чтобы он охватил текст. Предполагалось, что прямоугольник будет играть роль рамки, выделяя текст. Но сам текст пропал. Почему так получилось? Дело в том, что любая фигура имеет границу и внутреннюю область. По умолчанию граница рисуется тонкой черной линией, а внутренняя область закрашивается белым цветом. Эти параметры легки изменить.

  4. Щелкните в панели инструментов Рисование (Drawing) на стрелке справа от кнопки Цвет заливки (Fill Color) и в раскрывшейся палитре выберите пункт Нет заливки (No Fill). Прямоугольник станет прозрачным, и текст снова появится на экране.

  5. Щелчком на стрелке справа от кнопки 11вет линии (Line Color) раскройте палитру цвета границы фигуры и выберите в ней синий квадрат.

  6. Щелкните в той же панели инструментов на кнопке Объем (3D) и в раскрывшейся палитре вариантов объемного оформления выберите второй значок первого ряда. Теперь текст окружен синим объемным прямоугольником (рис. 6.18).

Рис. 6.18. Фигуры в документе Word

  7. Щелкните на кнопке Автофигуры (AutoShapes) панели инструментов Рисование (Drawing).

  8. Выберите в раскрывшемся меню пункт Фигурные стрелки > Стрелка влево (Block Arrows > Left Arrow).

  9. Растяните мышью стрелку ниже прямоугольника, как показано на рис. 6.19.

  10. С помощью палитры кнопки Цвет заливки (Fill Color) залейте стрелку зеленым цветом.

  11. Щелкните на кнопке Тип лини и (Line Style) и выберите линию толщиной 3 пункта. Любая фигура имеет восемь управляющих маркеров, которые отображаются в виде залитых квадратов в углах и по серединам границ габаритного контейнера фигуры и позволяют изменять ее размеры. Сверху от габаритного контейнера располагается еще одна точка, окрашенная в зеленый цвет. Поместив в нее указатель мыши, можно свободно поворачивать габаритный контейнер, а с ним и всю фигуру. Некоторые фигуры дополнительно имеют одну или несколько управляющих точек в виде желтых ромбов, позволяющих изменять форму фигуры. Стрелка обладает одной такой точкой.

  12. Захватите правый средний маркер нарисованной стрелки и перетащите его вправо. Стрелка станет шире.

  13. Перетащите управляющую точку вправо. Стрелка изменит свою форму и станет примерно такой, как показано на рис. 6.19.

Рис. 6.19. Изменение формы и расположения фигур

  14. В панели инструментов Рисование (Drawing) выберите команду Автофигуры > Выноски > Скругленная прямоугольная выноска (AutoShapes > Callouts> Rounded Rectangular Callout).

  15. Растяните выноску, показанную на рис. 6.20, чтобы она перекрывала стрелку и прямоугольник. При необходимости скорректируйте форму выноски с помощью управляющих маркеров.

  16. Щелкните внутри выноски и введите текст Это стрелка влево. Не забудьте, что при редактировании текста кнопка Выбор объектов (Select Objects) должна быть отжата. Подобные выноски позволяют располагать надписи в любом месте документа, на схемах, рисунках и графиках.

  17. На самом деле надпись можно добавить в любую автофигуру. Щелкните на кнопке Выбор объектов (Select Objects), а затем на стрелке, чтобы выделить ее.

  18. Щелкните на кнопке Надпись (Text Box), а затем введите текст Надпись на стрелке. Он появится прямо на зеленом поле стрелки, будет перемещаться вместе с ней и никогда не выйдет за границы этой стрелки.

  19. Снова щелкните на кнопке Выбор объектов (Select Objects), так как ввод надписи автоматически отключает этот режим, а затем щелчком выделите объемный прямоугольник.

  20. В панели инструментов Рисование (Drawing) выберите команду Действия > Порядок > На передний план (Draw > Order > Bring To Front). Порядок расположения объектов изменится. Если раньше выноска располагалась поверх объемного прямоугольника, то теперь прямоугольник оказывается сверху выноски.

Примечание

Фигура, которую вы хотите отформатировать, должна быть выделена, то есть окружена габаритным контейнером с маркерами. Если маркеров нет, щелкните на кнопке Выбор объектов (Select Objects) панели инструментов Рисование (Drawing), а затем на той фигуре, которую нужно модифицировать. Чтобы выключить режим выделения и продолжить редактирование текста документа, повторно щелкните на кнопке Выбор объектов (Select Objects).

Меню Действия (Draw) и Автофигуры (AutoShapes) позволяют рисовать самые разнообразные графические объекты и выполнять с ними многие операции, такие как группировка, равномерное распределение по странице или вращение. Попробуйте сами изучить возможности панели инструментов Рисование (Drawing). С ее помощью можно рисовать достаточно сложные схемы, не прибегая к услугам графических редакторов.


Упражнение 7. Библиотека картинок

Microsoft Office XP предлагает обширную библиотеку рисунков, в которой можно найти подходящую картинку для оформления практически любого документа. Поскольку Word — это текстовый редактор, оперирующий с символами, картинки, так же как и фигуры, не просто помещаются в то или иное место страницы, они оказываются привязанными к определенному символу документа. Это очень удобно.. При редактировании многостраничного файла текст может сместиться на несколько страниц, при этом произойдет аналогичное перемещение всех связанных с текстом рисунков и логика документа не нарушится. Чтобы добавить рисунок библиотеки ClipArt в документ Word, созданный в предыдущем упражнении, выполните следующие шаги.

  1. Щелкните в конце строки Это прямоугольник, нажмите несколько раз клавишу Enter, чтобы текстовый курсор оказался ниже зеленой стрелки, и введите текст Вставляем рисунок.

Примечание

В документе, показанном на рис. 6.19, только строка Это прямоугольник является настоящим абзацем документа Word. Все остальные надписи расположены на автофигурах и являются их неотъемлемой частью. Эти надписи исчезают с экрана при переключении в обычный режим просмотра.

  2. Выберите команду Вставка >Рисунок > Картинки (Insert > Picture > ClipArt). Откроется окно Вставка картинки (Insert ClipArt), показанное на рис. 6.20.

  3. Введите ключевое слово Животные (Animals) для поиска картинки в поле Искать текст (Search text) в разделе Поиск клипа (Search for) и щелкните на кнопке Найти (Search). В поле Результаты (Results) появятся имеющиеся в коллекции картинки с изображениями животных.

Рис. 6.20. Окно Вставка картинки области задач

  4. Наведите указатель мыши на понравившуюся картинку. Щелкните на стрелке, появившейся справа от картинки и в раскрывшемся меню выберите пункт Вставить (Insert). Рисунок будет вставлен в конец строки Вставляем рисунок.

  5. Захватите угловой маркер рамки рисунка и перетащите его по направлению к центру рисунка, чтобы немного уменьшить размеры объекта.

  6. Захватив рисунок мышью за середину, перетащите его влево, чтобы он оказался между словами Вставляем и рисунок, как показано на рис. 6.21. Когда рисунок выделен, в окне Word появляется панель инструментов Настройка изображения (Picture), показанная на рис. 6.22, которая позволяет изменять контрастность, яркость, режим обтекания текстом и другие параметры рисунка.

Рис. 6.21. Добавление рисунка

Примечание

Теперь рисунок привязан к слову Вставляем. Попробуйте добавить несколько абзацев перед строкой Вставляем рисунок или несколько слов в начало этой строки. Вы заметите, что рисунок перемещается вместе со словом Вставляем.

Рис. 6.22. Панель инструментов для настройки изображения

Примечание

В контекстном меню любого выделенного объекта доступна команда ГиnepccbiAKa(l-lyperlink), которая превращает текст, рисунок, фигуру и любой другой элемент документа в гиперссылку на другой документ или на web-страницу Интернета.

  7. Щелкните на добавленном рисунке правой кнопкой мыши и выберите в контекстном меню команду Гиперссылка (Hyperlink).

  8. Вокнедиалога Добавление гиперссылки (Insert Hyperlink), показанном на рис. 6.23, укажите имя файла или URL документа Интернета либо выберите нужный объект в списке.

  9. Щелкните на кнопке ОК.

Рис. 6.23. Окно диалога добавления гиперссылки

Четыре кнопки в левой части этого окна диалога позволяют связать объект с ги-перссылками следующих категорий:

  • Имеющимся файлом, веб-страницей (Existing File Or Web Page) — недавно открывавшиеся файлы, недавно просматривавшиеся web-страницы или любой другой ресурс, имя которого можно ввести в поле Адрес: (Address:);

  • Местом в этом документе (Place In This Document) — заголовки и закладки текущего документа;

  • Новым документом (Create New Document) — ссылка на несуществующий документ, который будет создан позже;

  • Электронной почтой (E-mail Address) — электронный адрес удаленного пользователя. При щелчке на такой ссылке запускается программа Outlook, которая позволяет отправить письмо по адресу гиперссылки.

Когда гиперссылка назначается текстовому фрагменту, Word окрашивает текст другим цветом и подчеркивает его, сигнализируя о наличии гиперссылки. Рисунки „ с гиперссылками никак не выделяются. Чтобы найти такие ссылки, перемещайте '' указатель по всем рисункам документа. Если рисунок связан с гиперссылкой, на экране появится всплывающая подсказка с именем ресурса, на который ссылается рисунок.

  10. Чтобы добавить в документ еще один рисунок, переместите текстовый курсор в ту точку, куда нужно вставить рисунок, и с помощью области задач переключитесь в окно Вставка картинки (ClipArt).

  11. Щелкните на кнопке Изменить (Modify) окна Вставка картинки (ClipArt), чтобы вернуться к разделу Поиск клипа (Search for), и повторите описанные выше действия.

Библиотека картинок обладает широкими возможностями сортировки и поиска картинок по ключевым словам. Из окна Вставка картинки (ClipArt) можно связаться с Интернетом и поискать картинки на специальном сервере компании Microsoft, Откуда их можно перенести в локальную библиотеку. Для этого выберите в разделе См.также (See Also) раздел Коллекция картинок в Интернете (Clips Online). Окно Вставка картинки (ClipArt) также позволяет импортировать в библиотеку рисунки из графических файлов различных форматов.


Контрольное упражнение

Word предлагает огромное количество приемов форматирования текста и объектов. Контрольное упражнение поможет освоить еще несколько полезных операций.

  1. Создайте нумерованный список из четырех пустых абзацев.

  2. Добавьте в каждый абзац по одному рисунку библиотеки картинок, выравняв их размеры.

  3. Разместите абзацы с рисунками в два столбца. Теперь на странице документа должны быть видны четыре пронумерованных рисунка.

  4. Добавьте ниже рисунков еще один абзац с текстом. Он автоматически получит номер 5 и разместится во втором столбце.

    • Как отменить нумерацию абзаца и расположить его ниже столбцов, чтобы он занял всю ширину страницы?

  5. Увеличьте левый отступ пятого абзаца.

    • Как с помощью панели инструментов изменить отступ абзаца ?

  6. Обведите все четыре рисунка овалами с прозрачным заполнением и красной границей толщиной в 6 пунктов.

  7. Выделите в пятом абзаце несколько слов и назначьте им шрифт Arial Cyr размером 18 пунктов и курсивное начертание.

  8. Добавьте в нижнюю часть документа еще один абзац с несколькими строками текста.

  9. Выделите первые три слова этого абзаца тем же шрифтом, которым выделялись слова на шаге 14 упражнения 5.

    • Как скопировать формат текста, используя кнопку Формат по о'бразцу (Fonnat Painter) панели инструментов?

  10. С помощью табуляций добавьте в конец документа табличку из четырех столбцов с выравниванием чисел по правому краю па отметках 2,6,10 и 14 см и вертикальными линиями в позициях 3, 7 и 11 см.


Подведение итогов

Вы получили представление о том, как форматировать текст, создавать и назначать стили, настраивать отступы и интервалы, пользоваться табуляциями, добавлять в документы Word фигуры и рисунки. Не останавливайтесь па достигнутом, старайтесь не только постоянно применять известные инструменты, но и расширять свой кругозор, пытаясь изменять еще незнакомые вам параметры окон диалога Word и пользуясь всевозможными командами контекстных меню объектов и кнопками панелей инструментов. Для получения подсказок и разъяснений обращайтесь к справочной системе Microsoft Office.

На следующем занятии вы научитесь строить таблицы и пояснять текстовое содержание диаграммами и графиками.


Занятие №7

Таблицы и графики

ТЕМА ЗАНЯТИЯ

На этом занятии описываются инструменты создания и форматирования таблиц, а также модуль Microsoft Chart, позволяющий представлять табличные данные в виде диаграмм и графиков. На занятии обсуждаются следующие темы:

  • построение таблицы;

  • добавление и удаление строк и столбцов;

  • объединение и разбиение ячеек;

  • форматирование таблиц;

  • преобразование табулированных данных в таблицу;

  • построение диаграмм на базе таблицы;

  • форматирование диаграмм и графиков.

Таблицы

Таблицы используются для представления самой разнообразной числовой и текстовой информации, которую можно упорядочить по одному или нескольким критериям. Word обладает обширным набором инструментов для построения и форматирования таблиц, что позволяет строить очень сложные таблицы с любым мыслимым оформлением. Обратите внимание, что в Word для работы с таблицами отведен целый пункт Главного меню.

Упражнение 1. Добавление таблицы

  1. Откройте новый или существующий документ. Переключитесь в обычный режим просмотра и поместите текстовый курсор в конец того абзаца, после которого нужно добавить таблицу.

  2. Нажмите клавишу Enter и введите заголовок План выпуска продукции.

  3. С помощью раскрывающегося списка Стиль (Style) панели инструментов Форматирование (Formatting) назначьте ему стиль Заголовок 3 (Heading 3).

  4. Щелкните на кнопке Добавить таблицу (Insert Table).

  5. В раскрывшейся палитре с клетками щелкните на четвертой клетке третьей строки. Выбранная клетка задает размер таблицы в ячейках. В результате выполненных действий в документ будет вставлена таблица размером 3х4 ячейки, показанная на рис. 7.1.

Рис.7.1. Добавление таблицы

Примечание

Если палитра кнопки Добавить таблицу (Insert Table) не позволяет создать таблицу с нужным числом ячеек, выберите команду Таблица > Добавить > Таблица (Table > Insert > Table), в открывшемся окне диалога введите параметры создаваемой таблицы и щелкните на кнопке ОК.

  6. Теперь следует наполнить таблицу полезной информацией. Щелкните в первой ячейке первой строки и введите текст Название товара.

  7. Нажмите клавишу Tab. Курсор переместится во вторую ячейку первой строки. Введите текст Январь.

  8. При каждом последующем нажатии клавиши Tab курсор будет перемещаться последовательно по всем ячейкам таблицы, позволяя вводить нужные данные. Заполните таблицу в соответствии с рис. 7.2.

Рис. 7.2. Ввод данных в таблицу

Примечание

Для перехода к предыдущей ячейке нажимайте клавиши Shift+Tab. Для перемещения по ячейкам таблицы можно также пользоваться клавишами со стрелками либо просто щелкать мышью на нужной ячейке.

  9. После ввода числа в последнюю ячейку третьей строки снова нажмите клавишу Tab. Таблица автоматически увеличится на одну строку, и вы сможете заполнить еще четыре ячейки. Таким образом, нет особой нужды заранее рассчитывать точное число строк таблицы. По мере ввода данных Word добавит столько строк, сколько будет нужно. Текст ячеек таблицы можно форматировать точно так же, как и любой другой текст документа Word. Единственное отличие состоит в том, что выравнивание текста выполняется не относительно полей страницы, а относительно границ каждой ячейки. Настраивая вид ячеек, можно выделять конкретные ячейки, группы строк или столбцов и всю таблицу целиком. Назначаемые режимы форматирования и выравнивания текста будут влиять только на выделенные ячейки. Поскольку абзац, предшествующий таблице, был выделен стилем Заголовок 3 (Heading 3), все ячейки таблицы получили в наследство тот же стиль. Но этот стиль предназначен для заголовка. Давайте изменим стиль ячеек таблицы.

  10. Выбором команды Таблица > Выделить > Таблица (Table > Select > Table) выделите всю таблицу (при выполнении этой команды текстовый курсор должен находиться в одной из ячеек выделяемой таблицы) и выберите в раскрывающемся списке Стиль (Style) панели инструментов Форматирование (Formatting) пункт Обычный (Normal).

Рис. 7.3. Форматирование текста таблицы

  11. Щелкните мышью левее первой ячейки верхней строки. Будет выделена вся верхняя строка таблицы.

  12. Щелкните на кнопке По центру (Center) панели инструментов Форматирование (Formatting),.чтобы центрировать содержимое ячеек. Затем нажатием клавиш Ctrl+B назначьте тексту выделенной строки полужирное начертание.

  13. Поместите указатель мыши в первую ячейку второй строки чуть правее левой границы ячейки, чтобы значок указателя принял форму наклонной стрелки (рис. 7.3), и протащите мышь вниз, выделив этим приемом первые ячейки строк со второй по четвертую.

  14. Нажатием клавиш Ctrl+I назначьте выделенным ячейкам курсивное начертание.

  15. В любой момент можно изменить конфигурацию таблицы, добавляя в нее строки и столбцы. Щелкните во втором столбце таблицы и выберите команду Таблица > Добавить » Столбцы справа (Table > Insert > Columns To The Right).

Примечание

Чтобы удалить строку, столбец или группу ячеек, выделите удаляемые ячейки и выберите соответствующую команду подменю Таблица » Удалить (Table > Delete). Нажатие клавиши Delete не удаляет выделенные ячейки, а лишь стирает их содержимое.

  16. Щелкните в верхней ячейке нового столбца и введите слово Апрель. Нажмите клавишу -L и введите число во вторую ячейку нового столбца. Аналогичным образом заполните все пустые ячейки.

  17. Щелчком на верхней границе первой ячейки третьего столбца выделите весь столбец, как показано на рис. 7.4.

Рис. 7.4. Перетаскивание столбца

  18. Поместите указатель в ячейку со словом Апрель и нажмите левую кнопку мыши.

  19. Перетащите мышь правее первой ячейки пятого столбца и отпустите левую кнопку. Третий столбец переместится в конец таблицы. Word предлагает еще один интересный способ добавления и удаления ячеек. Их можно просто нарисовать. Это очень быстрая и удобная методика построения таблиц, однако она требует определенных навыков и умения точно манипулировать мышью.

  20. Попробуйте «дорисовать» одну широкую ячейку в верхней части таблицы. Для этого выберите команду Таблица > Нарисовать таблицу (Table > Draw Table). Word автоматически переключит документ в режим разметки страниц, так как только этот режим позволяет оценивать реальные размеры изображаемых элементов документа. Значок указателя мыши примет форму карандаша, и на экране появится панель инструментов Таблицы и границы (Tables And Borders), показанная на рис. 7.5. Она обеспечивает доступ к инструментам форматирования и редактирования таблиц.

Рис. 7.5. Панель инструментов Таблицы и границы

  21. Поместите указатель в верхний левый угол таблицы и нажмите левую кнопку мыши.

Рис. 7.6. Нарисованная ячейка

  22. Протащите мышь вправо до правой границы таблицы и чуть вверх, чтобы появилась еще одна широкая ячейка, показанная на рис. 7.6.

  23. Введите в новую ячейку текст План компании Геркулес на 2002 год.

Упражнение 2. Размер ячеек

Таблицу, построенную в предыдущем упражнении, хотелось бы сделать немного поуже. Кроме того, следует расширить первый столбец, чтобы слова Панели квадратные выводились одной строкой, и для лучшей читабельности текста немного увеличить высоту всех строк.

  1. Если режим отображения линеек отключен, выберите команду Вид > Линейка (View > Ruler). Обратите внимание: когда курсор находится в пределах таблицы, на вертикальной и горизонтальной линейках появляются специальные маркеры, позволяющие изменять высоту и ширину ячеек (рис. 7.7). Кроме того, на горизонтальной линейке присутствуют маркеры регулировки отступов текста текущей ячейки или выделенного столбца от границ ячеек. Самостоятельно подвигайте эти маркеры и изучите их воздействие на вид таблицы.

  2. Перетащите маркер границы между первой и второй строками таблицы вниз на 1 см.

  3. Щелкните на верхней ячейке таблицы.

Рис. 7.7. Маркеры линеек

Рис. 7.8. Окно диалога свойств таблицы

  4. В панели инструментов Таблицы и границы (Tables And Borders) щелкните на стрелке слева от кнопки режима выравнивания и выберите в открывшейся палитре кнопку Выровнять по центру (Align Center).

Рис. 7.9. Настройка размеров таблицы

  5. Чтобы увеличить шрифт заглавной ячейки, выберите в раскрывающемся списке Размер (Font Size) панели инструментов Форматирование (Formatting) число 18.

  6. Чтобы точно задать ширину таблицы, выберите команду Таблица > Свойства таблицы (Table > Table Properties). Откроется окно диалога, показанное на рис. 7.8. Оно имеет четыре вкладки, с помощью которых можно настраивать параметры выделенных строк, столбцов или ячеек, а также таблицы в целом.

  7. На вкладке Таблица (Table) установите флажок ширина (Preferred Width).

  8. Введите в одноименный счетчик число 30.

  9. Щелкните на кнопке ОК. Теперь ширина таблицы будет равна 30 делениям, как показано на рис. 7.9.

  10. Переместите указатель на вертикальную линию границы между первым и вторым столбцом, чтобы значок принял форму двунаправленной стрелки, и нажмите левую кнопку мыши.

  11. Перетащите границу вправо на такое расстояние, чтобы текст всех ячеек первого столбца помещался в одну строку. Мы настроили ширину первого столбца, но получилось так, что второй столбец оказался слишком узким. Давайте выровняем ширину четырех правых столбцов таблицы.

  12. Нажмите левую кнопку мыши в ячейке Январь и протащите указатель до правой нижней ячейки таблицы. Окажутся выделенными четыре правых столбца.

  13. Щелкните на кнопке Выровнять ширину столбцов (Distribute Columns Evenly). Ширина выделенных столбцов станет одинаковой.

  14. Выделите последние четыре строки таблицы, протащив мышь слева от них. Выберите команду Таблица > Свойства таблицы (Table > Table Properties). На вкладке Строка (Row) открывшегося окна диалога установите флажок Высота (Specify Height) и введите в одноименный счетчик число 1. Затем щелкните ил кнопке ОК. Таблица станет такой, как показано на рис. 7.10.

Рис. 7.10. Таблица с настроенными ячейками

Упражнение 3. Разбиение и объединение ячеек

Построенная таблица достаточно проста. В реальной жизни часто возникает надобность сформировать таблицу с подзаголовками, объединяющими серию строк или столбцов. Чтобы научиться объединять ячейки, выполните следующие шаги.

  1. Щелкните в ячейке с текстом Январь.

  2. Раскройте в панели инструментов Таблицы и границы (Tables And Borders) па литру кнопки вставки объекта.

  3. Выберите пункт Добавить строки выше (Insert Rows Above).

  4. В новой строке выделите четыре правые ячейки, как показано на рис. 7.11.

Рис. 7.11. Объединение ячеек

  5. Щелчком на кнопке Объединить ячейки (Merge Cells) преобразуйте четыре вы деленные ячейки в одну.

  6. Введите текст По месяцам.

  7. Выделите ячейку с текстом Название товара и ячейку над ней. Щелчком на кнопке Объединить ячейки (Merge Cells) объедините их.

  8. Щелчком на значке Выравнять по центру (Align Center) в палитре кнопки выравнивания объектов подравняйте надпись в образовавшейся большой ячейке. Теперь заголовки строк и столбцов выглядят привлекательнее.

Примечание

Иногда таблицы оказываются достаточно высокими и не помещаются на одной странице. Чтобы заголовки столбцов дублировались при переносе части таблицы на следующую страницу, выделите первые несколько строк таблицы, которые должны повторяться на каждой странице, и выберите команду Таблица > Заголовки (Table > Heading Rows Repeat). Для отключения этого режима повторно выберите ту же самую команду.

  9. Ячейки "можно не только объединять, но и разделять. Выделите три нижние ячейки столбца Февраль и щелкните на кнопке Разбить ячейки (Split Cells). Откроется окно диалога, показанное на рис. 7.12.

Рис. 7.12. Разбиение ячеек

  10. Сбросьте флажок Объединить перед разбиением (Merge Cells Before Split). Остальные параметры оставьте без изменения. Это заставит Word разделить каждую из трех ячеек пополам.

  11. Щелкните на кнопке О К и введите в новые ячейки произвольные числа. Теперь таблица будет выглядеть примерно так, как показано на рис. 7.12.

Упражнение 4. Форматирование таблицы

Давайте немного приукрасим таблицу, изменив линии ячеек.

  1. Щелкните в верхней ячейке таблицы, созданной в предыдущих упражнениях.

  2. Выберите в раскрывающемся списке Тип линии (Line Style) панели инструментов Таблицы и границы (Tables And Borders) двойную линию.

  3. Щелкните в той же панели инструментов на стрелке справа от кнопки настройки границ. Раскрывшаяся палитра показывает, что активная ячейка не имеет границ, выполненных двойной линией.

  4. Щелчком на кнопке Нижняя граница (Bottom Border) замените нижнюю одинарную границу ячейки на двойную (рис. 7.13).

  5. Выделите всю таблицу, в списке Тип линии (Line Style) выберите одинарную линию.

  6. В списке Толщина линии (Line Weight) выберите толщину 3 пункта.

  7. Щелчком на кнопке Внешние границы (Outside Border) палитры настройки грат ниц очертите таблицу жирной линией. Ручной настройкой границ ячеек можно создать сколь угодно сложное оформление таблицы. Но, как правило, пользователей устраивает один из стандартных стилей, предлагаемых инструментом автоформата таблиц.

  8. Щелкните в любой точке, не выходящей за пределы таблицы и выберите команду Таблица > Автоформат (Table > Table AutoFormat). Откроется окно диалога, показанное на рис. 7.14.

Рис. 7.13. Настройка границ

Примечание

Окно диалога Автоформат (AutoFormat), в приложении Word XP имеет более сложную структуру, чем в предыдущих версиях Office. Число имеющихся готовых вариантов формата таблица здесь значительно больше, чем раньше. Кроме того, появилась возможность самостоятельно создавать и изменять стили таблиц.

  9. Перебирайте пункты списка Форматы (Formats) и наблюдайте предлагаемое оформление в разделе Образец (Preview) окна диалога.

Рис. 7.14. Выбор автоформата таблицы

Рис. 7.15. Окончательный вид таблицы

  10. Отыскав подходящий вариант, попробуйте установить или сбросить некоторые флажки двух нижних разделов окна диалога. Это позволит модифицировать отдельные элементы выбранного автоформата. Затем щелкните на кнопке ОК.

Для таблицы этого упражнения я выбрал автоформат Столбцы 4 (Columns 4) и не стал менять состояние флажков. Результат такого форматирования таблицы показан на рис. 7.15. Он не совсем удачен, так как таблица имеет сложную структуру заголовков и ячеек. Для более простых таблиц автоформат дает прекрасные результаты.

Графики и диаграммы

Таблицы удобны для хранения точных числовых данных, но человеку часто нужны не точные цифры, а общее представление о величине какого-либо параметра. Поэтому табличные данные полезно дублировать диаграммами, которые отображают информацию с помощью графических элементов, таких как гистограммы, круговые диаграммы или графики.

Упражнение 5. Построение диаграммы на базе таблицы

Если раньше вы не пользовались таблицами Word, весьма вероятно, что какая-то часть ваших данных хранится в обычном текстовом файле. Теперь, почувствовав всю мощь программы Word, вы решили перенести их в красиво оформленную таблицу, а заодно построить диаграмму. Как быстрее решить эту задачу?

  1. В Главном меню Windows выберите команду Программы > Стандартные > Блокнот (Programs > Accessories > Notepad).

Рис. 7.16. Пример текстового файла

  2. Нажмите клавишу Tab и введите слово Январь.

  3. Сндва нажмите Tab и введите Февраль.

  4. Продолжайте ввод слов и чисел в соответствии с рис. 7.16, отделяя их друг от друга символом табуляции.

  5. Выберите команду Файл > Сохранить (File > Save) и запишите файл в папку Мои документы (My Documents) под именем Таблица.txt.

  6. Закройте окно Блокнота. Теперь у вас есть пример обычного текстового файла с небольшой таблицей. Давайте импортируем ее в Word и проиллюстрируем имеющиеся числовые данные диаграммой.

  7. В программе Word щелкните на кнопке Открыть (Open) панели инструментов Стандартная (Standard). В списке Тип файлов (Files Of Type) окна диалога открытия файла выберите пункт Все файлы (All Files), найдите только что созданный файл Таблица.1х1 и откройте его. В окне диалога Преобразование файла (Convert File) дважды щелкните на строке Только текст (Text Only). Таблица появится в окне Word. Она может оказаться немного кривоватой, но это не имеет значения. Главное, что столбцы таблицы разделены символами табуляции.

  8. Нажатием клавиш Ctrl+A выделите весь документ. Затем выберите команду Таблица > Преобразовать > Преобразовать в таблицу (Table > Convert > Text To Table).

  9. Проверьте, чтобы параметры окна диалога Преобразовать в таблицу (Convert Text To Table) были настроены в соответствии с рис. 7.17.

Рис. 7.17. Преобразование текста в таблицу

  10. Щелкните на кнопке Автоформат (AutoFormat).

Примечание

Если данные текстового файла разделены не табуляциями, а, скажем, запятыми, выберите в разделе Разделитель (Separate Text At) окна диалога преобразования положение переключателя Другой (Other) и введите в одноименное поле соответствующий символ (запятую).

  11. В окне диалога Автоформат таблицы (Table AutoFormat) выберите вариант Стандарт 1 (Classic 1). Затем два раза щелкните на кнопке ОК. Таблица готова! Microsoft Office позволяет создавать диаграммы двумя способами: с помощью мастера диаграмм Excel, который уже встречался вам на занятии 2, или с помощью модуля Microsoft Graph, который доступен в различных приложениях Office. Сейчас давайте воспользуемся вторым вариантом.

  12. Щелкните в любой ячейке полученной таблицы и выберите команду Таблица > Выделить > Таблица (Table > Select > Table).

  13. Выберите команду Вставка ^ Рисунок > Диаграмма (Insert > Picture > Chart). В документе Word появится диаграмма и откроется окно таблицы данных Microsoft Graph XP. Информация из таблицы Word будет перенесена в окно Graph XP, а меню и панели инструментов Word заменятся на соответствующие компоненты модуля Graph, как показано на рис. 7.18.

  14. Щелкните на пустой области документа Word. Окно данных, панели инструментов и меню модуля Graph XP исчезнут, а ниже таблицы Word разместится диаграмма, представляющая данные этой таблицы в графической форме.

Рис. 7.18. Построение диаграммы на базе таблицы Word

Упражнение 6. Форматирование диаграмм и графиков

Скорее всего, вас не устроит та диаграмма, которая генерируется по умолчанию. Модуль Microsoft Graph предоставляет широчайшие возможности форматирования. Вы можете выбирать тип диаграммы, изменять цвет рядов данных, добавлять заголовки, перемещать легенду, настраивать оси, их шкалы и метки делений, добавлять подписи данных и изменять множество дополнительных параметров, влияющих на способ представления данных. В этом упражнении на примере диаграммы, построенной на базе таблицы Word, будут рассмотрены лишь некоторые из доступных приемов форматирования.

  1. Чтобы модифицировать диаграмму, нужно снова открыть модуль Microsoft Graph. Для этого дважды щелкните на диаграмме.

  2. Щелчком на кнопке Режим таблицы (View Datasheet) скройте таблицу данных Graph. Сейчас мы не будем изменять данные. Таблица данных Graph похожа на лист Excel. Если вам придется вручную вводить данные для диаграмм Graph, пользуйтесь приемами, изложенными в упражнениях занятия 9.

  3. В панели инструментов Стандартная (Standard) раскройте палитру кнопки типа диаграммы и выберите подходящий тип, например График (Line Chart).

Примечание

Способы форматирования диаграмм Microsoft Graph похожи на приемы оформления диаграмм Excel, о которых рассказывается на занятии 11.

Примечание

Если вас не устраивают типы диаграмм, представленные в палитре кноп- ки панели инструментов, выберите команду Диаграмма > Тип диаграммы (Chart > Chart Type). Откроется окно диалога, первая вкладка которого предлагает на выбор больше сотни стандартных вариантов диаграмм, а вторая дает пользователю возможность сконструировать свой собственный тип диаграммы.

  4. Легенда диаграммы расположена неудобно, давайте переместим ее вниз. Для этого щелкните на легенде правой кнопкой мыши, выберите в контекстном меню команду Формат легенды (Format Legend) и на вкладке Размещение (Placement) открывшегося окна диалога выберите положение переключателя Внизу, посередине (Bottom). Затем щелкните на кнопке ОК.

  5. Захватите мышью правый нижний маркер габаритного прямоугольника диаграммы и перетащите его вправо вниз, чтобы сделать диаграмму немного крупнее, как показано на рис. 7.19.

Теперь давайте приукрасим подписи осей, изменим сетку, на фоне которой выводится график, и увеличим маркеры данных, чтобы они были лучше видны.

  6. Дважды щелкните на числах меток вертикальной оси графика. В открывшемся окне диалога разверните вкладку Шкала (Scale), показанную на рис. 7.20.

  7. Сбросьте флажки Максимальное значение (Maximum) и Цена основных делений (Major Unit), чтобы отключить автоматическую настройку этих параметров.

  8. В одноименные поля после флажков введите числа 80 и 20 соответственно.

  9. Щелкните на кнопке ОК. Четыре другие вкладки окна диалога форматирования осей позволяют настраивать вид осей, шрифт меток делений, числовой формат меток и режим их выравнивания.

  10. Чтобы убрать серый фон графика, выберите команду Диаграмма > Параметры диаграммы (Chart > Chart Options), которая открывает окно диалога параметров диаграммы. Шесть вкладок этого окна содержат следующие параметры:

Рис. 7.19. Форматирование диаграммы

  • Заголовки (Titles) — названия диаграммы, вертикальных и горизонтальных осей;

  • Оси (Axes) — режимы отображения осей категорий и значений;

  • Линии сетки (Gridlines) — флажки включения и отключения вертикальных и горизонтальных линий сетки фона диаграммы;

  • Легенда (Legend) — режим отображения и способ расположения легенды диаграммы;

  • Подписи данных (Data Labels) — переключатель, дающий возможность выводить различные подписи рядом с маркерами данных;

  • Таблица данных (Data Table) — флажки настройки режима вывода таблицы отображаемых данных под горизонтальной осью диаграммы.

  11. На вкладке Линии сетки (Gridlines), показанной на рис. 7.21, сбросьте флажок основные линии (Major Gridlines) в разделе Ось Y (значений) (Value (Y) Axis).

  12. Установите одноименный флажок в разделе Ось Х (категорий) (Category (X) Axis).

  13. Щелчком на кнопке ОК закройте окно диалога. Горизонтальные линии сетки будут заменены на вертикальные.

  14. Щелкните на области построения диаграммы. В меню Формат (Format) выберите первую команду. Ее название начинается со слова Выделенный (Selected), после которого следует название выделенного элемента. В данной ситуации это будет команда Выделенная область построения диаграммы (Selected Plot Area).

Рис. 7.20. Форматирование осей диаграммы

  15. В открывшемся окне диалога выберите положение Прозрачная (None) переключателя Заливка (Area), чтобы отменить заливку диаграммы. Затем щелкните на кнопке ОК.

Рис. 7.21. Параметры диаграммы

  16. Чтобы выйти из режима редактирования диаграммы и закрыть модуль Microsoft Graph, щелкните на свободном пространстве документа Word. Теперь таблица и график будут выглядеть так, как показано на рис. 7.22.

  17. Сохраните документ, он пригодится в контрольном упражнении.

Рис. 7.22. Окончательный вид диаграммы

Контрольное упражнение

С помощью этого упражнения попробуйте самостоятельно изучить некоторые приемы форматирования таблиц и диаграмм.

  1. Откройте файл, созданный в упражнении 6.

  2. Добавьте в конец таблицы еще один столбец и заполните его ячейки.

    • Как обновить диаграмму, чтобы в ней появились данные добавленного столбца?

  3. Залейте фон первой строки и первого столбца таблицы желтым цветом.

  4. Рассортируйте строки таблицы по возрастанию чисел в столбце Февраль.

    • Как автоматически рассортировать табличные данные?

  5. Двойным щелчком на диаграмме запустите Microsoft Graph.

  6. Дважды щелкните на подписях горизонтальной оси и в открывшемся окне диалога измените ориентировку подписей, чтобы их текст выводился вертикально.

  7. Добавьте заголовки диаграммы и осей.

    • Где назначаются заголовки элементов диаграммы?

  8. В области легенды выделите маркер ряда данных Трубы, дважды щелкните на нем и в открывшемся окне диалога измените цвет маркера на черный. Повторите эту операцию для всех рядов данных.

Подведение итогов

На этом занятии вы познакомились с приемами построения и форматирования таблиц, импорта табличных данных из текстовых файлов. Вы научились строить и оформлять диаграммы.

Следующее занятие завершает изучение приложения Word XP. Оно посвящено описанию модуля проверки орфографии и процедуры объединения документа Word с внешними табличными данными.


Занятие №7

Таблицы и графики

ТЕМА ЗАНЯТИЯ

На этом занятии описываются инструменты создания и форматирования таблиц, а также модуль Microsoft Chart, позволяющий представлять табличные данные в виде диаграмм и графиков. На занятии обсуждаются следующие темы:

  • построение таблицы;

  • добавление и удаление строк и столбцов;

  • объединение и разбиение ячеек;

  • форматирование таблиц;

  • преобразование табулированных данных в таблицу;

  • построение диаграмм на базе таблицы;

  • форматирование диаграмм и графиков.


Таблицы

Таблицы используются для представления самой разнообразной числовой и текстовой информации, которую можно упорядочить по одному или нескольким критериям. Word обладает обширным набором инструментов для построения и форматирования таблиц, что позволяет строить очень сложные таблицы с любым мыслимым оформлением. Обратите внимание, что в Word для работы с таблицами отведен целый пункт Главного меню.


Упражнение 1. Добавление таблицы

  1. Откройте новый или существующий документ. Переключитесь в обычный режим просмотра и поместите текстовый курсор в конец того абзаца, после которого нужно добавить таблицу.

  2. Нажмите клавишу Enter и введите заголовок План выпуска продукции.

  3. С помощью раскрывающегося списка Стиль (Style) панели инструментов Форматирование (Formatting) назначьте ему стиль Заголовок 3 (Heading 3).

  4. Щелкните на кнопке Добавить таблицу (Insert Table).

  5. В раскрывшейся палитре с клетками щелкните на четвертой клетке третьей строки. Выбранная клетка задает размер таблицы в ячейках. В результате выполненных действий в документ будет вставлена таблица размером 3х4 ячейки, показанная на рис. 7.1.

Рис.7.1. Добавление таблицы

Примечание

Если палитра кнопки Добавить таблицу (Insert Table) не позволяет создать таблицу с нужным числом ячеек, выберите команду Таблица > Добавить > Таблица (Table > Insert > Table), в открывшемся окне диалога введите параметры создаваемой таблицы и щелкните на кнопке ОК.

  6. Теперь следует наполнить таблицу полезной информацией. Щелкните в первой ячейке первой строки и введите текст Название товара.

  7. Нажмите клавишу Tab. Курсор переместится во вторую ячейку первой строки. Введите текст Январь.

  8. При каждом последующем нажатии клавиши Tab курсор будет перемещаться последовательно по всем ячейкам таблицы, позволяя вводить нужные данные. Заполните таблицу в соответствии с рис. 7.2.

Рис. 7.2. Ввод данных в таблицу

Примечание

Для перехода к предыдущей ячейке нажимайте клавиши Shift+Tab. Для перемещения по ячейкам таблицы можно также пользоваться клавишами со стрелками либо просто щелкать мышью на нужной ячейке.

  9. После ввода числа в последнюю ячейку третьей строки снова нажмите клавишу Tab. Таблица автоматически увеличится на одну строку, и вы сможете заполнить еще четыре ячейки. Таким образом, нет особой нужды заранее рассчитывать точное число строк таблицы. По мере ввода данных Word добавит столько строк, сколько будет нужно. Текст ячеек таблицы можно форматировать точно так же, как и любой другой текст документа Word. Единственное отличие состоит в том, что выравнивание текста выполняется не относительно полей страницы, а относительно границ каждой ячейки. Настраивая вид ячеек, можно выделять конкретные ячейки, группы строк или столбцов и всю таблицу целиком. Назначаемые режимы форматирования и выравнивания текста будут влиять только на выделенные ячейки. Поскольку абзац, предшествующий таблице, был выделен стилем Заголовок 3 (Heading 3), все ячейки таблицы получили в наследство тот же стиль. Но этот стиль предназначен для заголовка. Давайте изменим стиль ячеек таблицы.

  10. Выбором команды Таблица > Выделить > Таблица (Table > Select > Table) выделите всю таблицу (при выполнении этой команды текстовый курсор должен находиться в одной из ячеек выделяемой таблицы) и выберите в раскрывающемся списке Стиль (Style) панели инструментов Форматирование (Formatting) пункт Обычный (Normal).

Рис. 7.3. Форматирование текста таблицы

  11. Щелкните мышью левее первой ячейки верхней строки. Будет выделена вся верхняя строка таблицы.

  12. Щелкните на кнопке По центру (Center) панели инструментов Форматирование (Formatting),.чтобы центрировать содержимое ячеек. Затем нажатием клавиш Ctrl+B назначьте тексту выделенной строки полужирное начертание.

  13. Поместите указатель мыши в первую ячейку второй строки чуть правее левой границы ячейки, чтобы значок указателя принял форму наклонной стрелки (рис. 7.3), и протащите мышь вниз, выделив этим приемом первые ячейки строк со второй по четвертую.

  14. Нажатием клавиш Ctrl+I назначьте выделенным ячейкам курсивное начертание.

  15. В любой момент можно изменить конфигурацию таблицы, добавляя в нее строки и столбцы. Щелкните во втором столбце таблицы и выберите команду Таблица > Добавить » Столбцы справа (Table > Insert > Columns To The Right).

Примечание

Чтобы удалить строку, столбец или группу ячеек, выделите удаляемые ячейки и выберите соответствующую команду подменю Таблица » Удалить (Table > Delete). Нажатие клавиши Delete не удаляет выделенные ячейки, а лишь стирает их содержимое.

  16. Щелкните в верхней ячейке нового столбца и введите слово Апрель. Нажмите клавишу -L и введите число во вторую ячейку нового столбца. Аналогичным образом заполните все пустые ячейки.

  17. Щелчком на верхней границе первой ячейки третьего столбца выделите весь столбец, как показано на рис. 7.4.

Рис. 7.4. Перетаскивание столбца

  18. Поместите указатель в ячейку со словом Апрель и нажмите левую кнопку мыши.

  19. Перетащите мышь правее первой ячейки пятого столбца и отпустите левую кнопку. Третий столбец переместится в конец таблицы. Word предлагает еще один интересный способ добавления и удаления ячеек. Их можно просто нарисовать. Это очень быстрая и удобная методика построения таблиц, однако она требует определенных навыков и умения точно манипулировать мышью.

  20. Попробуйте «дорисовать» одну широкую ячейку в верхней части таблицы. Для этого выберите команду Таблица > Нарисовать таблицу (Table > Draw Table). Word автоматически переключит документ в режим разметки страниц, так как только этот режим позволяет оценивать реальные размеры изображаемых элементов документа. Значок указателя мыши примет форму карандаша, и на экране появится панель инструментов Таблицы и границы (Tables And Borders), показанная на рис. 7.5. Она обеспечивает доступ к инструментам форматирования и редактирования таблиц.

Рис. 7.5. Панель инструментов Таблицы и границы

  21. Поместите указатель в верхний левый угол таблицы и нажмите левую кнопку мыши.

Рис. 7.6. Нарисованная ячейка

  22. Протащите мышь вправо до правой границы таблицы и чуть вверх, чтобы появилась еще одна широкая ячейка, показанная на рис. 7.6.

  23. Введите в новую ячейку текст План компании Геркулес на 2002 год.


Упражнение 2. Размер ячеек

Таблицу, построенную в предыдущем упражнении, хотелось бы сделать немного поуже. Кроме того, следует расширить первый столбец, чтобы слова Панели квадратные выводились одной строкой, и для лучшей читабельности текста немного увеличить высоту всех строк.

  1. Если режим отображения линеек отключен, выберите команду Вид > Линейка (View > Ruler). Обратите внимание: когда курсор находится в пределах таблицы, на вертикальной и горизонтальной линейках появляются специальные маркеры, позволяющие изменять высоту и ширину ячеек (рис. 7.7). Кроме того, на горизонтальной линейке присутствуют маркеры регулировки отступов текста текущей ячейки или выделенного столбца от границ ячеек. Самостоятельно подвигайте эти маркеры и изучите их воздействие на вид таблицы.

  2. Перетащите маркер границы между первой и второй строками таблицы вниз на 1 см.

  3. Щелкните на верхней ячейке таблицы.

Рис. 7.7. Маркеры линеек

Рис. 7.8. Окно диалога свойств таблицы

  4. В панели инструментов Таблицы и границы (Tables And Borders) щелкните на стрелке слева от кнопки режима выравнивания и выберите в открывшейся палитре кнопку Выровнять по центру (Align Center).

Рис. 7.9. Настройка размеров таблицы

  5. Чтобы увеличить шрифт заглавной ячейки, выберите в раскрывающемся списке Размер (Font Size) панели инструментов Форматирование (Formatting) число 18.

  6. Чтобы точно задать ширину таблицы, выберите команду Таблица > Свойства таблицы (Table > Table Properties). Откроется окно диалога, показанное на рис. 7.8. Оно имеет четыре вкладки, с помощью которых можно настраивать параметры выделенных строк, столбцов или ячеек, а также таблицы в целом.

  7. На вкладке Таблица (Table) установите флажок ширина (Preferred Width).

  8. Введите в одноименный счетчик число 30.

  9. Щелкните на кнопке ОК. Теперь ширина таблицы будет равна 30 делениям, как показано на рис. 7.9.

  10. Переместите указатель на вертикальную линию границы между первым и вторым столбцом, чтобы значок принял форму двунаправленной стрелки, и нажмите левую кнопку мыши.

  11. Перетащите границу вправо на такое расстояние, чтобы текст всех ячеек первого столбца помещался в одну строку. Мы настроили ширину первого столбца, но получилось так, что второй столбец оказался слишком узким. Давайте выровняем ширину четырех правых столбцов таблицы.

  12. Нажмите левую кнопку мыши в ячейке Январь и протащите указатель до правой нижней ячейки таблицы. Окажутся выделенными четыре правых столбца.

  13. Щелкните на кнопке Выровнять ширину столбцов (Distribute Columns Evenly). Ширина выделенных столбцов станет одинаковой.

  14. Выделите последние четыре строки таблицы, протащив мышь слева от них. Выберите команду Таблица > Свойства таблицы (Table > Table Properties). На вкладке Строка (Row) открывшегося окна диалога установите флажок Высота (Specify Height) и введите в одноименный счетчик число 1. Затем щелкните ил кнопке ОК. Таблица станет такой, как показано на рис. 7.10.

Рис. 7.10. Таблица с настроенными ячейками


Упражнение 3. Разбиение и объединение ячеек

Построенная таблица достаточно проста. В реальной жизни часто возникает надобность сформировать таблицу с подзаголовками, объединяющими серию строк или столбцов. Чтобы научиться объединять ячейки, выполните следующие шаги.

  1. Щелкните в ячейке с текстом Январь.

  2. Раскройте в панели инструментов Таблицы и границы (Tables And Borders) па литру кнопки вставки объекта.

  3. Выберите пункт Добавить строки выше (Insert Rows Above).

  4. В новой строке выделите четыре правые ячейки, как показано на рис. 7.11.

Рис. 7.11. Объединение ячеек

  5. Щелчком на кнопке Объединить ячейки (Merge Cells) преобразуйте четыре вы деленные ячейки в одну.

  6. Введите текст По месяцам.

  7. Выделите ячейку с текстом Название товара и ячейку над ней. Щелчком на кнопке Объединить ячейки (Merge Cells) объедините их.

  8. Щелчком на значке Выравнять по центру (Align Center) в палитре кнопки выравнивания объектов подравняйте надпись в образовавшейся большой ячейке. Теперь заголовки строк и столбцов выглядят привлекательнее.

Примечание

Иногда таблицы оказываются достаточно высокими и не помещаются на одной странице. Чтобы заголовки столбцов дублировались при переносе части таблицы на следующую страницу, выделите первые несколько строк таблицы, которые должны повторяться на каждой странице, и выберите команду Таблица > Заголовки (Table > Heading Rows Repeat). Для отключения этого режима повторно выберите ту же самую команду.

  9. Ячейки "можно не только объединять, но и разделять. Выделите три нижние ячейки столбца Февраль и щелкните на кнопке Разбить ячейки (Split Cells). Откроется окно диалога, показанное на рис. 7.12.

Рис. 7.12. Разбиение ячеек

  10. Сбросьте флажок Объединить перед разбиением (Merge Cells Before Split). Остальные параметры оставьте без изменения. Это заставит Word разделить каждую из трех ячеек пополам.

  11. Щелкните на кнопке О К и введите в новые ячейки произвольные числа. Теперь таблица будет выглядеть примерно так, как показано на рис. 7.12.


Упражнение 4. Форматирование таблицы

Давайте немного приукрасим таблицу, изменив линии ячеек.

  1. Щелкните в верхней ячейке таблицы, созданной в предыдущих упражнениях.

  2. Выберите в раскрывающемся списке Тип линии (Line Style) панели инструментов Таблицы и границы (Tables And Borders) двойную линию.

  3. Щелкните в той же панели инструментов на стрелке справа от кнопки настройки границ. Раскрывшаяся палитра показывает, что активная ячейка не имеет границ, выполненных двойной линией.

  4. Щелчком на кнопке Нижняя граница (Bottom Border) замените нижнюю одинарную границу ячейки на двойную (рис. 7.13).

  5. Выделите всю таблицу, в списке Тип линии (Line Style) выберите одинарную линию.

  6. В списке Толщина линии (Line Weight) выберите толщину 3 пункта.

  7. Щелчком на кнопке Внешние границы (Outside Border) палитры настройки грат ниц очертите таблицу жирной линией. Ручной настройкой границ ячеек можно создать сколь угодно сложное оформление таблицы. Но, как правило, пользователей устраивает один из стандартных стилей, предлагаемых инструментом автоформата таблиц.

  8. Щелкните в любой точке, не выходящей за пределы таблицы и выберите команду Таблица > Автоформат (Table > Table AutoFormat). Откроется окно диалога, показанное на рис. 7.14.

Рис. 7.13. Настройка границ

Примечание

Окно диалога Автоформат (AutoFormat), в приложении Word XP имеет более сложную структуру, чем в предыдущих версиях Office. Число имеющихся готовых вариантов формата таблица здесь значительно больше, чем раньше. Кроме того, появилась возможность самостоятельно создавать и изменять стили таблиц.

  9. Перебирайте пункты списка Форматы (Formats) и наблюдайте предлагаемое оформление в разделе Образец (Preview) окна диалога.

Рис. 7.14. Выбор автоформата таблицы

Рис. 7.15. Окончательный вид таблицы

  10. Отыскав подходящий вариант, попробуйте установить или сбросить некоторые флажки двух нижних разделов окна диалога. Это позволит модифицировать отдельные элементы выбранного автоформата. Затем щелкните на кнопке ОК.

Для таблицы этого упражнения я выбрал автоформат Столбцы 4 (Columns 4) и не стал менять состояние флажков. Результат такого форматирования таблицы показан на рис. 7.15. Он не совсем удачен, так как таблица имеет сложную структуру заголовков и ячеек. Для более простых таблиц автоформат дает прекрасные результаты.


Графики и диаграммы

Таблицы удобны для хранения точных числовых данных, но человеку часто нужны не точные цифры, а общее представление о величине какого-либо параметра. Поэтому табличные данные полезно дублировать диаграммами, которые отображают информацию с помощью графических элементов, таких как гистограммы, круговые диаграммы или графики.


Упражнение 5. Построение диаграммы на базе таблицы

Если раньше вы не пользовались таблицами Word, весьма вероятно, что какая-то часть ваших данных хранится в обычном текстовом файле. Теперь, почувствовав всю мощь программы Word, вы решили перенести их в красиво оформленную таблицу, а заодно построить диаграмму. Как быстрее решить эту задачу?

  1. В Главном меню Windows выберите команду Программы > Стандартные > Блокнот (Programs > Accessories > Notepad).

Рис. 7.16. Пример текстового файла

  2. Нажмите клавишу Tab и введите слово Январь.

  3. Сндва нажмите Tab и введите Февраль.

  4. Продолжайте ввод слов и чисел в соответствии с рис. 7.16, отделяя их друг от друга символом табуляции.

  5. Выберите команду Файл > Сохранить (File > Save) и запишите файл в папку Мои документы (My Documents) под именем Таблица.txt.

  6. Закройте окно Блокнота. Теперь у вас есть пример обычного текстового файла с небольшой таблицей. Давайте импортируем ее в Word и проиллюстрируем имеющиеся числовые данные диаграммой.

  7. В программе Word щелкните на кнопке Открыть (Open) панели инструментов Стандартная (Standard). В списке Тип файлов (Files Of Type) окна диалога открытия файла выберите пункт Все файлы (All Files), найдите только что созданный файл Таблица.1х1 и откройте его. В окне диалога Преобразование файла (Convert File) дважды щелкните на строке Только текст (Text Only). Таблица появится в окне Word. Она может оказаться немного кривоватой, но это не имеет значения. Главное, что столбцы таблицы разделены символами табуляции.

  8. Нажатием клавиш Ctrl+A выделите весь документ. Затем выберите команду Таблица > Преобразовать > Преобразовать в таблицу (Table > Convert > Text To Table).

  9. Проверьте, чтобы параметры окна диалога Преобразовать в таблицу (Convert Text To Table) были настроены в соответствии с рис. 7.17.

Рис. 7.17. Преобразование текста в таблицу

  10. Щелкните на кнопке Автоформат (AutoFormat).

Примечание

Если данные текстового файла разделены не табуляциями, а, скажем, запятыми, выберите в разделе Разделитель (Separate Text At) окна диалога преобразования положение переключателя Другой (Other) и введите в одноименное поле соответствующий символ (запятую).

  11. В окне диалога Автоформат таблицы (Table AutoFormat) выберите вариант Стандарт 1 (Classic 1). Затем два раза щелкните на кнопке ОК. Таблица готова! Microsoft Office позволяет создавать диаграммы двумя способами: с помощью мастера диаграмм Excel, который уже встречался вам на занятии 2, или с помощью модуля Microsoft Graph, который доступен в различных приложениях Office. Сейчас давайте воспользуемся вторым вариантом.

  12. Щелкните в любой ячейке полученной таблицы и выберите команду Таблица > Выделить > Таблица (Table > Select > Table).

  13. Выберите команду Вставка ^ Рисунок > Диаграмма (Insert > Picture > Chart). В документе Word появится диаграмма и откроется окно таблицы данных Microsoft Graph XP. Информация из таблицы Word будет перенесена в окно Graph XP, а меню и панели инструментов Word заменятся на соответствующие компоненты модуля Graph, как показано на рис. 7.18.

  14. Щелкните на пустой области документа Word. Окно данных, панели инструментов и меню модуля Graph XP исчезнут, а ниже таблицы Word разместится диаграмма, представляющая данные этой таблицы в графической форме.

Рис. 7.18. Построение диаграммы на базе таблицы Word


Упражнение 6. Форматирование диаграмм и графиков

Скорее всего, вас не устроит та диаграмма, которая генерируется по умолчанию. Модуль Microsoft Graph предоставляет широчайшие возможности форматирования. Вы можете выбирать тип диаграммы, изменять цвет рядов данных, добавлять заголовки, перемещать легенду, настраивать оси, их шкалы и метки делений, добавлять подписи данных и изменять множество дополнительных параметров, влияющих на способ представления данных. В этом упражнении на примере диаграммы, построенной на базе таблицы Word, будут рассмотрены лишь некоторые из доступных приемов форматирования.

  1. Чтобы модифицировать диаграмму, нужно снова открыть модуль Microsoft Graph. Для этого дважды щелкните на диаграмме.

  2. Щелчком на кнопке Режим таблицы (View Datasheet) скройте таблицу данных Graph. Сейчас мы не будем изменять данные. Таблица данных Graph похожа на лист Excel. Если вам придется вручную вводить данные для диаграмм Graph, пользуйтесь приемами, изложенными в упражнениях занятия 9.

  3. В панели инструментов Стандартная (Standard) раскройте палитру кнопки типа диаграммы и выберите подходящий тип, например График (Line Chart).

Примечание

Способы форматирования диаграмм Microsoft Graph похожи на приемы оформления диаграмм Excel, о которых рассказывается на занятии 11.

Примечание

Если вас не устраивают типы диаграмм, представленные в палитре кноп- ки панели инструментов, выберите команду Диаграмма > Тип диаграммы (Chart > Chart Type). Откроется окно диалога, первая вкладка которого предлагает на выбор больше сотни стандартных вариантов диаграмм, а вторая дает пользователю возможность сконструировать свой собственный тип диаграммы.

  4. Легенда диаграммы расположена неудобно, давайте переместим ее вниз. Для этого щелкните на легенде правой кнопкой мыши, выберите в контекстном меню команду Формат легенды (Format Legend) и на вкладке Размещение (Placement) открывшегося окна диалога выберите положение переключателя Внизу, посередине (Bottom). Затем щелкните на кнопке ОК.

  5. Захватите мышью правый нижний маркер габаритного прямоугольника диаграммы и перетащите его вправо вниз, чтобы сделать диаграмму немного крупнее, как показано на рис. 7.19.

Теперь давайте приукрасим подписи осей, изменим сетку, на фоне которой выводится график, и увеличим маркеры данных, чтобы они были лучше видны.

  6. Дважды щелкните на числах меток вертикальной оси графика. В открывшемся окне диалога разверните вкладку Шкала (Scale), показанную на рис. 7.20.

  7. Сбросьте флажки Максимальное значение (Maximum) и Цена основных делений (Major Unit), чтобы отключить автоматическую настройку этих параметров.

  8. В одноименные поля после флажков введите числа 80 и 20 соответственно.

  9. Щелкните на кнопке ОК. Четыре другие вкладки окна диалога форматирования осей позволяют настраивать вид осей, шрифт меток делений, числовой формат меток и режим их выравнивания.

  10. Чтобы убрать серый фон графика, выберите команду Диаграмма > Параметры диаграммы (Chart > Chart Options), которая открывает окно диалога параметров диаграммы. Шесть вкладок этого окна содержат следующие параметры:

Рис. 7.19. Форматирование диаграммы

  • Заголовки (Titles) — названия диаграммы, вертикальных и горизонтальных осей;

  • Оси (Axes) — режимы отображения осей категорий и значений;

  • Линии сетки (Gridlines) — флажки включения и отключения вертикальных и горизонтальных линий сетки фона диаграммы;

  • Легенда (Legend) — режим отображения и способ расположения легенды диаграммы;

  • Подписи данных (Data Labels) — переключатель, дающий возможность выводить различные подписи рядом с маркерами данных;

  • Таблица данных (Data Table) — флажки настройки режима вывода таблицы отображаемых данных под горизонтальной осью диаграммы.

  11. На вкладке Линии сетки (Gridlines), показанной на рис. 7.21, сбросьте флажок основные линии (Major Gridlines) в разделе Ось Y (значений) (Value (Y) Axis).

  12. Установите одноименный флажок в разделе Ось Х (категорий) (Category (X) Axis).

  13. Щелчком на кнопке ОК закройте окно диалога. Горизонтальные линии сетки будут заменены на вертикальные.

  14. Щелкните на области построения диаграммы. В меню Формат (Format) выберите первую команду. Ее название начинается со слова Выделенный (Selected), после которого следует название выделенного элемента. В данной ситуации это будет команда Выделенная область построения диаграммы (Selected Plot Area).

Рис. 7.20. Форматирование осей диаграммы

  15. В открывшемся окне диалога выберите положение Прозрачная (None) переключателя Заливка (Area), чтобы отменить заливку диаграммы. Затем щелкните на кнопке ОК.

Рис. 7.21. Параметры диаграммы

  16. Чтобы выйти из режима редактирования диаграммы и закрыть модуль Microsoft Graph, щелкните на свободном пространстве документа Word. Теперь таблица и график будут выглядеть так, как показано на рис. 7.22.

  17. Сохраните документ, он пригодится в контрольном упражнении.

Рис. 7.22. Окончательный вид диаграммы


Контрольное упражнение

С помощью этого упражнения попробуйте самостоятельно изучить некоторые приемы форматирования таблиц и диаграмм.

  1. Откройте файл, созданный в упражнении 6.

  2. Добавьте в конец таблицы еще один столбец и заполните его ячейки.

    • Как обновить диаграмму, чтобы в ней появились данные добавленного столбца?

  3. Залейте фон первой строки и первого столбца таблицы желтым цветом.

  4. Рассортируйте строки таблицы по возрастанию чисел в столбце Февраль.

    • Как автоматически рассортировать табличные данные?

  5. Двойным щелчком на диаграмме запустите Microsoft Graph.

  6. Дважды щелкните на подписях горизонтальной оси и в открывшемся окне диалога измените ориентировку подписей, чтобы их текст выводился вертикально.

  7. Добавьте заголовки диаграммы и осей.

    • Где назначаются заголовки элементов диаграммы?

  8. В области легенды выделите маркер ряда данных Трубы, дважды щелкните на нем и в открывшемся окне диалога измените цвет маркера на черный. Повторите эту операцию для всех рядов данных.


Подведение итогов

На этом занятии вы познакомились с приемами построения и форматирования таблиц, импорта табличных данных из текстовых файлов. Вы научились строить и оформлять диаграммы.

Следующее занятие завершает изучение приложения Word XP. Оно посвящено описанию модуля проверки орфографии и процедуры объединения документа Word с внешними табличными данными.


Занятие №8

Дополнительные возможности Word

ТЕМА ЗАНЯТИЯ

На заключительном занятии гю теме Word XP вы освоите некоторые дополнительные инструменты этого приложения:

  • язык документа;

  • проверка орфографии и грамматики;

  • слияние с внешними данными.

Microsoft Word умеет выполнять множество вспомогательных операций, значительно облегчающих работу с документом, его форматирование и проверку. Описание всех дополнительных операции Word можно найти в книге Б. Карпова Microsoft Word 2002: справочник» («Питер», 2001). На этом занятии рассматриваются два важных инструмента — модуль проверки орфографии и грамматики, позволяющий быстро выявлять и исправлять ошибки, и процедура слияния, с помощью которой красиво оформленный документ Word с пустыми полями можно связать с внешней таблицей или базой данных, получив в результате отформатированный отчет, данные которого можно оперативно обновлять.

Орфография и грамматика

В пакете Microsoft Office есть модуль автоматической проверки орфографии и грамматики. Он доступен во всех приложениях Office и позволяет с помощью одних и тех же приемов быстро проверять и корректировать как документы Word, так, например, и текст записей баз данных Access. В зависимости от конфигурации Windows и версии Office словари этого модуля могут поддерживать работу с несколькими языками.

Упражнение 1. Язык документа

По мере ввода текста каждому слову назначается атрибут, определяющий, каким языком написано слово. Эта информация используется при проверке документа для выбора словаря, которым следует руководствоваться при идентификации каждого конкретного слова. Word, как правило, сам корректно распознает язык, выбирая один из тех языков, поддержка которых установлена на компьютере. Смена языка происходит при переключении раскладки клавиатуры с английской на русскую и обратно.

Примечание

Если Word не подчеркивает слова и фразы с ошибками, значит, отключен режим автоматической проверки правописания. Чтобы включить его, выберите команду Сервис > Параметры (Tools > Options). В открывшемся окне диалога щелкните на вкладке Правописание (Spelling & Grammar) и установите флажки Автоматически проверять орфографию (Check Spelling As You Type) и Автоматически проверять грамматику (Check Grammar As You Type).

Примечание

При установке русскоязычной версии Office инсталлируются словари для русского и английского языков. Если англоязычная версия Office ХР устанавливается поверх предыдущей русской версии Office, то поддержка русского языка сохраняется.

Если Word замечает в тексте слово, написанное с ошибкой, такое слово подчеркивается красной зигзагообразной линией, как показано на рис. 8.1. Чтобы исправить слово, отредактируйте его, заменив неверные символы, или воспользуйтесь словар&м Office.

Рис. 8.1. Автоматическая проверка правописания

  1. Щелкните на подчеркнутом слове правой кнопкой мыши и выберите в контекстном меню правильный вариант написания или одну из следующих команд:

    • Пропустить все (Ignore All) — не воспринимать выделенное слово в качестве ошибочного в текущем документе;
    • Добавить (Add) — добавить слово в словарь Word и в дальнейшем считать данное написание правильным;
    • Автозамена (AutoCorrect) — настроить автоматическую коррекцию написания данного слова с помощью словаря Word. Выбрав в списке Auto-Correct (Автозамена) правильный вариант написания, вы добавляете пункт в список автозамены. При следующей ошибке в том же слове Word сам исправит неверное написание;

Примечание

Чтобы просмотреть и отредактировать список автоматической коррекции, выберите команду Сервис > Автозамена (Tools > AutoCorrect).

  • Язык (Language) — изменить язык слова;
  • Орфография (Spelling) — запустить модуль проверки орфографии.

  2. Если по каким-то причинам Word назначил фрагменту текста неверный язык, выделите этот текст и выберите команду Сервис > Язык > Выбрать язык (Tools > Language > Set Language). Откроется окно диалога, показанное на рис. 8.2.

  3. В списке окна диалога выберите язык для выделенного текста. Языки, словари которых установлены на компьютере, отмечены специальными значками (рис. 8.2).

Рис. 8.2. Выбор языка

  4. Если нет нужды проверять правописание выделенного фрагмента или невозможно указать верный язык (так бывает, например, в случае работы с математическими формулами), установите флажок Не проверять правописание (Do Not Check Spelling Or Grammar).

  5. Щелкните на кнопке ОК.

При вводе текста Word кроме орфографии автоматически проверяет грамматику (если в окне параметров установлен флажок Автоматически проверять грамматику (Check Grammar As You Type)). Неверные грамматические конструкции подчеркиваются зеленой зигзагообразной линией.

  6. Чтобы исправить грамматическую ошибку, щелкните правой кнопкой мыши на фразе, подчеркнутой зеленой линией, и выберите в контекстном меню скорректированный вариант фразы или одну из следующих команд:

    • Пропустить (Ignore) — не считать данную фразу ошибочной;
    • Грамматика (Grammar) — запустить модуль проверки грамматики.

Упражнение 2. Проверка орфографии и грамматики

Автоматическая проверка орфографии и грамматики не всегда удобна. Иногда нужно целиком сосредоточиться на основной теме документа и не хочется отвлекаться на мелкие .ошибки. При импорте текстового содержания, при неверной настройке языка документа или при обработке документа большого объема ошибок может оказаться слишком много, тогда автоматическая проверка существенно замедлит работу Word. В таких ситуациях отключите автоматическую проверку (сбросив флажки, указанные в совете предыдущего упражнения), а на последней стадии разработки документа вручную проверьте правописание с помощью следующих действий.

  1. Для перехода к началу документа нажмите клавиши Ctrl+Home.

  2. Выберите команду Сервис > Правописание (Tools > Spelling And Grammar). Откроется окно диалога, показанное на рис. 8.3, и Word начнет сканировать документ на предмет ошибок. В верхнем прокручивающемся поле этого окна появится первая наиденная фраза с ошибкой. В нижнее прокручивающееся поле выводится верное (по мнению Word) написание фразы либо список слов, которыми Word предлагает заменить ошибочное.

Рис. 8.3. Окно диалога проверки правописания

  3. Орфографические ошибки выделяются красным цветом. Для их коррекции выполняйте одно из следующих действий:

    • если исправления не требуются, щелкните на кнопке Пропустить (Ignore);
    • чтобы пропустить в текущем документе все подобные «ошибки», щелкните на кнопке Пропустить все (Ignore All);
    • для исправления слова выберите в нижнем поле один из предлагаемых вариантов и щелкните на кнопке Заменить (Change);
    • чтобы автоматически исправить в текущем документе все подобные ошибки, щелкните на кнопке Заменить все (Change All);
    • если в нижнем поле отсутствует правильный вариант написания, отредактируйте фразу в верхнем поле и щелкните на кнопке Заменить (Change), затем при необходимости подтвердите выполненную коррекцию щелчком на кнопке Да (Yes);
    • если выделенное слово должно считаться верным во всех документах, его нужно добавить в словарь Word, для этого щелкните на кнопке Добавить(Add).

  4. Грамматические ошибки выделяются зеленым цветом. При этом кнопки окна диалога проверки правописания несколько видоизменяются. Грамматические ошибки исправляются с помощью следующих операций:

    • чтобы исправить предложение, выберите один из пунктов нижнего прокручивающегося поля или вручную отредактируйте текст в верхнем поле, затем щелкните на кнопке Изменить (Change);
    • если исправления не требуются, щелкните на кнопке Пропустить (Ignore);
    • если исправления не требуются, щелкните на кнопке Пропустить(Ignore);

      щелчок на кнопке Отменить правило (Ignore Rule) отменяет проверку данного грамматического правила в текущем документе;

    • если исправления не требуются, щелкните на кнопке Пропустить (Ignore);

      кнопка Следующее (Next Sentence) инициирует пропуск текущего предложения и переход к проверке следующего.

  5. После выполнения одной из вышеуказанных операций Word продолжит поиск и выведет в окно модуля проверки очередную ошибку. Исправляйте ошибки до тех пор, пока не появится сообщение о том, что проверка документа завершена. Если необходимость в грамматической проверке отсутствует, сбросьте флажок Грамматика (Check Grammar). Если язык проверяемой фра зы был установлен неверно, что привело к обнаружению ложной ошибки, измените язык с помощью раскрывающегося списка Язык словаря (Dictionary Language).

Слияние

Суть слияния состоит в том, что вы берете документ, например образец письма, и таблицу с фамилиями и адресами людей, которым нужно разослать это письмо, а затем, автоматически объединяя образец с таблицей, генерируете набор писем. Все копии исходного письма наследуют общий текст, но содержат разную информацию в области адреса и фамилии получателя, которая заполняется на основе таблицы данных.

Упражнение 3. Создание главного документа

Для создания слияния прежде всего нужно разработать главный документ, играющий роль образца. Этот документ может иметь любое содержание. Основная идея заключается в том, что некоторые части текста заменяются полями, которые заполняются в результате слияния главного документа с таблицей данных.

  1. Откройте Word и создайте новый документ.

  2. Введите основной текст письма, но не указывайте адрес и фамилию получателя, например так, как показано па рис. 8.4. Затем сохраните документ под именем Письмо.doc.

  3. Выберите команду Сервис > Письма и рассылки > Мастер слияния (Tools > Letters and Mailings > Mail Merge Wizard). В области задач откроется окно Слияние (Mail Merge), показанное на рис. 8.5.

  4. В разделе Выбор типа документа (Select document type) выберите пункт Письма (Letters) и перейдите к следующему шагу мастера, щелкнув на команде Далее: Открытие документа (Next: Starting document).

Рис. 8.4. Текст главного документа слияния

Примечание

Пункты раздела Выбор типа документа (Select document type) определяют тип главного документа слияния. При необходимости вы всегда сможете позже изменить тип главного документа или связать с выбранным источником данных еще один главный документ.

Рис. 8.5. Окно Слияние (Mail Merge) области задач

  5. На этом этапе необходимо выбрать в качестве главного документа один из предлагаемых вариантов: использовать уже открытый документ, создать новый документ на основе шаблона или открыть существующий документ. Чтобы выбрать в качестве главного документа слияния только что созданный текст, щелкните на пункте Текущий документ (Use the current document).

  6. При необходимости отредактируйте содержание главного документа.

  7. Перейдите к следующему этану, щелкнув на команде Далее: Выбор получателей (Next: Select recipients).

Упражнение 4. Построение источника данных

Теперь нужно создать источник данных слияния (адресов и фамилий получателей письма).

  1. В разделе Выбор получателей (Select Recipients) окна Слияние (Merge Mailing) области задач выберите пункт Создание списка (Type a new list) (рис. 8.6).

Рис. 8.6. Окно Выбор получателей (Select Recipients) мастера Слияние (Mail Merge)

  2. Щелкните на команде Создать (Create) в разделе Создание списка (Type a new list). Откроется окно диалога, показанное на рис. 8.7.

Источник данных слияния представляет собой базу данных, состоящую из записей, на основе каждой из которых с помощью главного документа будет сгенерирован конкретный экземпляр письма. Все записи имеют одинаковые поля данных.

Некоторые наиболее распространенные поля заранее внесены в список окна создания источника данных. Вы можете удалить из базы данных ненужные поля и добавить свои собственные.

Рис. 8.7. Создание источника данных

Другие пункты раздела Выбор получателей (Select Recipients) позволяют выбрать в качестве источника данных имеющуюся базу данных, ранее созданную в Word или в приложении типа Access, либо адресную книгу.

Примечание

Наличие в источнике данных лишних полей никак не влияет на результат слияния, но замедляет работу программы.

  3. Щелкните на кнопке Настройка (Customize). Откроется окно диалога, пока занное на рис. 8.8.

  4. Выделите пункт Обращение (Title).

  5. Щелчком на кнопке Удалить (Delete) сотрите выделенное поле.

Рис. 8.8. Настройка полей источника данных

Рис. 8.9. Окно диалога Получатели слияния (Mail Merge Recipients)

  6. Повторяя шаги 4 и 5, удалите все поля, кроме Имя (FirstName), Фамилия (Last Name), Организация (Company Name), Адрес1 (Addressi) и Индекс (PostalCode).

  7. Щелкните на кнопке ОК.

  8. Щелкните на кнопке Закрыть (Close) окна диалога Создание источника данных (New Address List).

  9. В открывшемся окне диалога сохранения документа введите имя Гости и щелкните на кнопке Сохранить (Save). Появится показанное на рис. 8.9 окно диалога Получатели слияния (Mail Merge Recipients), в котором в настоящее время нет ни одной записи.

  10. Вам обязательно придется когда-нибудь ввести информацию в источник данных. Щелкните на кнопке Изменить... (Edit...), чтобы сделать это сейчас. Откроется форма для ввода данных. Давайте добавим несколько записей. Позже слияние сгенерирует ровно столько копий главного документа, сколько записей имеется в источнике данных.

  11. Заполните поля формы.

  12. Чтобы добавить еще одну запись, щелкните на кнопке Создать запись (New Entry).

  13. Введите еще несколько записей, перенеся в них информацию, представленную в табл. 8.1.

ТАБЛИЦА 8.1. Источник данных слияния
Номер записи | Имя | Фамилия | Организация | Адрес1 | Индекс
1 | Василий | Решетников | Премьер | Первая ул., 33 | 113114
2 | Петр | Петров | Фантом | Прямой пр., 18 | 114113
3 | Виктор | Горелов | Фантом | Четвертый проезд, 143 | 113278
4 | Игорь | Черный | Фантом | а/я 318 | 115333
5 | Илья | Николаев | Фантом | Косая ул. | 114232
6 | Леонид | Леонидов | Фантом | Зимний пр. | 211434

  14. Щелкните на кнопке Закрыть (Close), чтобы сохранить базу данных, а затем — на кнопке ОК окна Mail Merge Recipients.

Примечание

Для изменения информации источника данных щелкните в панели инструментов Слияние (Mail Merge) на кнопке Получатели (Mail Merge RecipientsEdit Data Source), а затем в открывшемся окне диалога — на кнопке Изменить (Edit). Откроется форма источника данных. Для перемещения по записям источника пользуйтесь кнопками Первая (First), Назад (Previous), Вперед (Next), Последняя (Last) в нижней части формы.

Рис. 8.10 . Панель инструментов Слияние

Упражнение 5. Размещение полей данных

Пришло время разместить поля источника данных в тексте главного документа.

  1. Перейдите к следующему этапу создания рассылки, щелкнув на команде Далее: Создание письма (Next: Write your letter) в области задач. Поместите курсор в первую строку документа и щелкните на команде Другие элементы (More Items). Откроется окно диалога Добавление поля слияния (Insert Merge Field), в котором содержится список полей источника данных, созданного в предыдущем упражнении.

  2. Выделите пункт Имя (FirstName) и щелкните на кнопке Вставить (Insert). Поле слияния появится в первой строке главного документа. Оно содержит специальный код, сообщающий программе Word, где следует размещать информацию из соответствующего ноля источника данных. Затем выберите пункт Фамилия (LastName) и снова щелкните на кнопке Вставить (Insert). Щелкните на кнопке Закрыть (Close), чтобы закрыть окно диалога Добавить поле слияния (Insert Merge Field).

  3. Введите пробел, чтобы отделить имя от фамилии.

  4. Нажмите клавишу Enter, откройте окно диалога Добавление поля слияния (Insert Merge Field) и выделите в списке пункт Адрес1 (Addressi).

  5. Снова нажмите Enter и выделите в том же списке пункт Индекс (PostalCode).

  6. Переместите курсор в конец слова Уважаемый и нажмите клавишу Пробел.

  7. Выберите в списке Добавление поля слияния (Insert Merge Field) ноле Имя (First Name), нажмите клавишу Пробел и там же выберите поле Фамилия (LastName). Теперь главный документ должен выглядеть так, как показано на рис. 8.11.

Рис. 8.11. Главный документ с полями слияния

При слиянии Word позволяет не только перебрать все записи источника данных, но и отобрать некоторые из них. Для этого можно воспользоваться полями Word или запросом. Список Добавить поле Word (Insert Word Field) панели инструментов Слияние (Merge Mail) позволяет добавлять в документ следующие поля, выполняющие отбор записей источника данных на основе определенных правил:

  • ASK (Запрос) и FILLIN (Заполнение) генерируют паузу в процессе печати слияния и дают возможность вводить дополнительный текст в каждый экземпляр документа, например индивидуальный номер клиента или пароль;

  • IF... THEN... ELSE позволяет ввести условие и действие, которое выполняется в случае истинности или ложности условия;

  • MERGE REC (Номер записи) и MERGE SEQ (Номер по порядку ) добавляют в документ соответственно номер записи источника данных и порядковый номер экземпляра слияния. Если в слиянии участвуют не все записи источника данных, эти номера будут отличаться друг от друга;

  • NEXT (Следующая запись) и NEXTIF (Следующая запись, если) дают возможность напечатать в одном экземпляре документа информацию из нескольких последовательных записей источника данных;

  • SET BOOKMARK (Закладка) позволяет связать некоторый текст документа с закладкой, которую можно вставлять в документ любое число раз. Если изменится исходный текст, обозначенный закладкой, то он моментально обновится во всех точках вставки этой закладки;

  • SKIPIF (Пропустить запись, если) дает возможность ввести условие, в случае истинности которого текущая запись будет пропущена и не попадет в слияние.

Давайте добавим в слияние пару полей Word.

  8. Нажатием клавиш Ctrl+Home переместитесь в начало документа и выберите в панели инструментов Слияние (Merge Mail) команду Добавить поле Word > SKIPIF (Insert Word Field > Skip Record If).

Рис. 8.12. Добавление поля Word

  9. В раскрывающемся списке Поле (Field Name) выберите пункт Индекс (Postal- Code), как показано на рис. 8.12.

  10. В списке Оператор (Comparison) выберите пункт Равно (Equal To).

  11. Введите в поле Значение (Compare To) величину 114113.

  12. Щелкните на кнопке ОК. Теперь при слиянии в источнике данных будут пропущены те записи, в поле Индекс (PostalCode) которых записано значение 114113.

  13. Нажмите клавиши Ctrl+End, а затем два раза клавишу Enter. Выберите команду Добавить поле Word > MERGEREC (Insert Word Field > Merge Record #). С помощью этого поля вы сможете отследить, какие записи источника данных попадут в слияние. Теперь главный документ станет таким, как показано на рис. 8.13.

  14. Перейдите к следующему этапу создания рассылки, щелкнув на команде Далее: Просмотр писем (Next: Preview your letters) области задач.

  15. Щелкните на команде Изменить список (Edit Recipient List) в области задач, чтобы создать запрос, с помощью которого записи будут рассортированы по алфавиту имен получателей писем.

Рис. 8.13. Главный документ с полями Word

Давайте добавим правило отбора, оставляющее только адресатов из компании «Фантом». Щелкните на стрелке рядом с заголовком столбца Организация (Company Name) и в раскрывшемся списке выберите пункт Дополнительно (Advanced). В появившемся окне диалога есть две вкладки. Первая из них — Отбор записей (Filter Records), — представленная на рис. 8.14, позволяет фильтровать записи источника данных.

  16. В списке Поле (Field) выберите пункт Организация (Company).

  17. В списке Оператор (Comparison) оставьте вариант Равно (Equal To).

  18. В поле Значение (Compare To) введите текст Фантом.

  19. Раскройте вкладку Сортировка записей (Sort Records) и настройте ее параметры.

  20. Щелкните на кнопке ОК. Это обеспечит сортировку результата слияния по алфавиту фамилий адресатов, а затем по алфавиту их имен.

Примечание

Назначение одинаковых правил сортировки для писем и наклеек на конверты позволяет при отправке писем не тратить время на поиск нужного конверта. Конверты с наклейками будут лежать на вашем столе в том же порядке, что и письма.

  21. Щелчком на кнопке ОК закройте окно диалога Получатели и сохраните новую версию главного документа.

Упражнение 6. Печать результата слияния

У вас уже есть главный документ и связанный с ним источник данных, который отфильтрован и рассортирован с помощью запроса. Казалось бы, можно выполнить слияние и распечатать результат. Однако перед этим полезно проверить правильность слияния.

  1. Продолжая работать с документом предыдущего упражнения, щелкните на кнопке Поиск ошибок (Check For Errors) панели инструментов Слияние (Merge Mail). Откроется окно диалога с переключателем, имеющим три положения. Первое положение переключателя позволяет получить сообщения обо всех обнаруженных ошибках без выполнения слияния. Выбрав второе положение переключателя, вы получите как само слияние, так и сообщения обо всех ошибках в последовательно появляющихся окнах диалога. Третье положение переключателя инициирует генерацию слияния и в отдельном документе сохраняет отчет об ошибках.

  2. Выберите положение переключателя Создать только отчет об ошибках (Simulate The Merge And Report Errors In A New Document).

  3. Щелкните на кнопке ОК.

Рис. 8.14. Проверка корректности параметров слияния

Примечание

При правильном выполнении всех операций в слиянии не обнаружится никаких ошибок, но если, к примеру, в главном документе оказалось неверное поле данных, появится сообщение.

  4. Щелкните на кнопке Поля/Данные (View Merged Data). Вы увидите, что поля главного документа заменятся на данные одной из записей источника данных.

  5. С помощью кнопок Следующая запись (Next Record) и Предыдущая запись (Previous Record) панели инструментов слияния или соответствующих кнопок области задач просмотрите все экземпляры документа, соответствующие конкретным записям источника данных. Обратите внимание, что запись адресата Василий Решетников отсутствует, так как она отфильтрована запросом из-за несоответствия названия компании значению Фантом (см. табл. 8.1). Тем не менее в этом режиме предварительного просмотра вы сможете наблюдать запись адресата Петр Петров, которая при окончательном слиянии будет пропущена из-за наличия в главном документе поля SKIPIF (Пропустить запись, если) с соответствующим условием.

  6. Снова щелкните на кнопке Поля/Данные (View Merged Data), чтобы вернуть отображение полей.

  7. Наконец пришло время выполнить слияние. Щелкните на команде Далее: Завершение слияния (Next: Complete the Merge) чтобы перейти к последнему окну мастера.

  8. Вы можете выбрать один из четырех режимов слияния, воспользовавшись соответствующими кнопками панели инструментов Слияние (Mail Merge):

    • Слияние в новый документ (Merge to New Document) — создает документ Word, в котором последовательно на отдельных страницах размещаются все экземпляры, построенные на основе слияния;
    • Слияние при печати (Merge to Printer) —печатает результат слияния на принтер;
    • Объединить для отправки (Merge to E-Mail) — отправляет каждый экземпляр слияния нужному адресату но электронной почте. Чтобы указать, какое поле источника данных содержит адреса электронной почты, щелкните на этой кнопке и выберите нужное поле в списке Кому (То) открывшегося окна диалога Составные электронные письма (Merge to E-Mail), затем щелкните на кнопке ОК. (В этом же окне диалога можно ввести содержимое поля Тема (Subject) электронных сообщений, а также выбрать, какие именно записи вы хотите отправить.);
    • Объединить для отправки по факсу (Merge to Fax) — отправляет каждый экземпляр слияния нужному адресату по факсу.

  9. Щелкните на кнопке ОК. Результат слияния будет отправлен в новый документ, на принтер или по электронной почте. В первом случае вновь созданный документ появится на экране и его можно будет сохранить в отдельном файле на жестком диске.

Контрольное упражнение

В качестве контрольного упражнения попробуйте распечатать наклейки на конверты для писем, созданных на этом занятии с помощью слияния.

  1. Откройте документ Письмо.doc, а затем откройте окно Слияние (Mail Merge) области задач.

  2. В разделе Выбор типа документа (Select document type) выберите пункт Наклейки (Mailing Labels) и перейдите к следующему этапу.

  3. Щелкните на команде Параметры наклейки (Label Options).

  4. В окне диалога Параметры наклейки (Label Options) настроите формат наклеек на конверты. Перейдите к следующему этапу.

  5. Воспользуйтесь в качестве источника данных существующим файлом Гости.

    • Как указать в качестве источника данных существующий файл ?

  6. Добавьте в текст наклеек поля Имя (FirstName), Фамилия (LastName), Индекс (Postal Code) и Адрес1 (Addressi), снабдив их соответствующими подписями.

  7. Щелкните на кнопке Обновление всех наклеек (Update All Labels), чтобы копировать макет первой созданной наклейки на всех остальные.

  8. Перейдите к следующему этапу и просмотрите созданные наклейки.

    • Как перейти к нужной записи ?
  9. Проверьте слияние на отсутствие ошибок.
  10. Выполните слияние в новый документ.
    • Как быстро выполнить слияние в новый документ?

  11. Проверьте правописание и грамматику полученного документа. При этом не забывайте пропускать все собственные имена (но не вносите их в словарь Word).

12. Распечатайте слияние.

Подведение итогов

Вы научились пользоваться двумя дополнительными модулями Word — проверкой правописания и слиянием. Word имеет множество других не менее интересных вспомогательных инструментов, которые можно найти в меню Сервис (Tools). Попробуйте изучить их самостоятельно.

Это занятие было заключительным разделом части книги, посвященной приложению Word. На следующем занятии вы перейдете к изучению электронных таблиц Excel.

Для повседневной работы с программой Word XP рекомендуем пользоваться уже упоминавшейся книгой Б. Карпова «Microsoft Word 2002: справочник» («Питер», 2001).


Занятие №8

Дополнительные возможности Word

ТЕМА ЗАНЯТИЯ

На заключительном занятии гю теме Word XP вы освоите некоторые дополнительные инструменты этого приложения:

  • язык документа;

  • проверка орфографии и грамматики;

  • слияние с внешними данными.

Microsoft Word умеет выполнять множество вспомогательных операций, значительно облегчающих работу с документом, его форматирование и проверку. Описание всех дополнительных операции Word можно найти в книге Б. Карпова Microsoft Word 2002: справочник» («Питер», 2001). На этом занятии рассматриваются два важных инструмента — модуль проверки орфографии и грамматики, позволяющий быстро выявлять и исправлять ошибки, и процедура слияния, с помощью которой красиво оформленный документ Word с пустыми полями можно связать с внешней таблицей или базой данных, получив в результате отформатированный отчет, данные которого можно оперативно обновлять.


Орфография и грамматика

В пакете Microsoft Office есть модуль автоматической проверки орфографии и грамматики. Он доступен во всех приложениях Office и позволяет с помощью одних и тех же приемов быстро проверять и корректировать как документы Word, так, например, и текст записей баз данных Access. В зависимости от конфигурации Windows и версии Office словари этого модуля могут поддерживать работу с несколькими языками.


Упражнение 1. Язык документа

По мере ввода текста каждому слову назначается атрибут, определяющий, каким языком написано слово. Эта информация используется при проверке документа для выбора словаря, которым следует руководствоваться при идентификации каждого конкретного слова. Word, как правило, сам корректно распознает язык, выбирая один из тех языков, поддержка которых установлена на компьютере. Смена языка происходит при переключении раскладки клавиатуры с английской на русскую и обратно.

Примечание

Если Word не подчеркивает слова и фразы с ошибками, значит, отключен режим автоматической проверки правописания. Чтобы включить его, выберите команду Сервис > Параметры (Tools > Options). В открывшемся окне диалога щелкните на вкладке Правописание (Spelling & Grammar) и установите флажки Автоматически проверять орфографию (Check Spelling As You Type) и Автоматически проверять грамматику (Check Grammar As You Type).

Примечание

При установке русскоязычной версии Office инсталлируются словари для русского и английского языков. Если англоязычная версия Office ХР устанавливается поверх предыдущей русской версии Office, то поддержка русского языка сохраняется.

Если Word замечает в тексте слово, написанное с ошибкой, такое слово подчеркивается красной зигзагообразной линией, как показано на рис. 8.1. Чтобы исправить слово, отредактируйте его, заменив неверные символы, или воспользуйтесь словар&м Office.

Рис. 8.1. Автоматическая проверка правописания

  1. Щелкните на подчеркнутом слове правой кнопкой мыши и выберите в контекстном меню правильный вариант написания или одну из следующих команд:

    • Пропустить все (Ignore All) — не воспринимать выделенное слово в качестве ошибочного в текущем документе;
    • Добавить (Add) — добавить слово в словарь Word и в дальнейшем считать данное написание правильным;
    • Автозамена (AutoCorrect) — настроить автоматическую коррекцию написания данного слова с помощью словаря Word. Выбрав в списке Auto-Correct (Автозамена) правильный вариант написания, вы добавляете пункт в список автозамены. При следующей ошибке в том же слове Word сам исправит неверное написание;

Примечание

Чтобы просмотреть и отредактировать список автоматической коррекции, выберите команду Сервис > Автозамена (Tools > AutoCorrect).

  • Язык (Language) — изменить язык слова;
  • Орфография (Spelling) — запустить модуль проверки орфографии.

  2. Если по каким-то причинам Word назначил фрагменту текста неверный язык, выделите этот текст и выберите команду Сервис > Язык > Выбрать язык (Tools > Language > Set Language). Откроется окно диалога, показанное на рис. 8.2.

  3. В списке окна диалога выберите язык для выделенного текста. Языки, словари которых установлены на компьютере, отмечены специальными значками (рис. 8.2).

Рис. 8.2. Выбор языка

  4. Если нет нужды проверять правописание выделенного фрагмента или невозможно указать верный язык (так бывает, например, в случае работы с математическими формулами), установите флажок Не проверять правописание (Do Not Check Spelling Or Grammar).

  5. Щелкните на кнопке ОК.

При вводе текста Word кроме орфографии автоматически проверяет грамматику (если в окне параметров установлен флажок Автоматически проверять грамматику (Check Grammar As You Type)). Неверные грамматические конструкции подчеркиваются зеленой зигзагообразной линией.

  6. Чтобы исправить грамматическую ошибку, щелкните правой кнопкой мыши на фразе, подчеркнутой зеленой линией, и выберите в контекстном меню скорректированный вариант фразы или одну из следующих команд:

    • Пропустить (Ignore) — не считать данную фразу ошибочной;
    • Грамматика (Grammar) — запустить модуль проверки грамматики.


Упражнение 2. Проверка орфографии и грамматики

Автоматическая проверка орфографии и грамматики не всегда удобна. Иногда нужно целиком сосредоточиться на основной теме документа и не хочется отвлекаться на мелкие .ошибки. При импорте текстового содержания, при неверной настройке языка документа или при обработке документа большого объема ошибок может оказаться слишком много, тогда автоматическая проверка существенно замедлит работу Word. В таких ситуациях отключите автоматическую проверку (сбросив флажки, указанные в совете предыдущего упражнения), а на последней стадии разработки документа вручную проверьте правописание с помощью следующих действий.

  1. Для перехода к началу документа нажмите клавиши Ctrl+Home.

  2. Выберите команду Сервис > Правописание (Tools > Spelling And Grammar). Откроется окно диалога, показанное на рис. 8.3, и Word начнет сканировать документ на предмет ошибок. В верхнем прокручивающемся поле этого окна появится первая наиденная фраза с ошибкой. В нижнее прокручивающееся поле выводится верное (по мнению Word) написание фразы либо список слов, которыми Word предлагает заменить ошибочное.

Рис. 8.3. Окно диалога проверки правописания

  3. Орфографические ошибки выделяются красным цветом. Для их коррекции выполняйте одно из следующих действий:

    • если исправления не требуются, щелкните на кнопке Пропустить (Ignore);
    • чтобы пропустить в текущем документе все подобные «ошибки», щелкните на кнопке Пропустить все (Ignore All);
    • для исправления слова выберите в нижнем поле один из предлагаемых вариантов и щелкните на кнопке Заменить (Change);
    • чтобы автоматически исправить в текущем документе все подобные ошибки, щелкните на кнопке Заменить все (Change All);
    • если в нижнем поле отсутствует правильный вариант написания, отредактируйте фразу в верхнем поле и щелкните на кнопке Заменить (Change), затем при необходимости подтвердите выполненную коррекцию щелчком на кнопке Да (Yes);
    • если выделенное слово должно считаться верным во всех документах, его нужно добавить в словарь Word, для этого щелкните на кнопке Добавить(Add).

  4. Грамматические ошибки выделяются зеленым цветом. При этом кнопки окна диалога проверки правописания несколько видоизменяются. Грамматические ошибки исправляются с помощью следующих операций:

    • чтобы исправить предложение, выберите один из пунктов нижнего прокручивающегося поля или вручную отредактируйте текст в верхнем поле, затем щелкните на кнопке Изменить (Change);
    • если исправления не требуются, щелкните на кнопке Пропустить (Ignore);
    • если исправления не требуются, щелкните на кнопке Пропустить(Ignore);

      щелчок на кнопке Отменить правило (Ignore Rule) отменяет проверку данного грамматического правила в текущем документе;

    • если исправления не требуются, щелкните на кнопке Пропустить (Ignore);

      кнопка Следующее (Next Sentence) инициирует пропуск текущего предложения и переход к проверке следующего.

  5. После выполнения одной из вышеуказанных операций Word продолжит поиск и выведет в окно модуля проверки очередную ошибку. Исправляйте ошибки до тех пор, пока не появится сообщение о том, что проверка документа завершена. Если необходимость в грамматической проверке отсутствует, сбросьте флажок Грамматика (Check Grammar). Если язык проверяемой фра зы был установлен неверно, что привело к обнаружению ложной ошибки, измените язык с помощью раскрывающегося списка Язык словаря (Dictionary Language).


Слияние

Суть слияния состоит в том, что вы берете документ, например образец письма, и таблицу с фамилиями и адресами людей, которым нужно разослать это письмо, а затем, автоматически объединяя образец с таблицей, генерируете набор писем. Все копии исходного письма наследуют общий текст, но содержат разную информацию в области адреса и фамилии получателя, которая заполняется на основе таблицы данных.


Упражнение 3. Создание главного документа

Для создания слияния прежде всего нужно разработать главный документ, играющий роль образца. Этот документ может иметь любое содержание. Основная идея заключается в том, что некоторые части текста заменяются полями, которые заполняются в результате слияния главного документа с таблицей данных.

  1. Откройте Word и создайте новый документ.

  2. Введите основной текст письма, но не указывайте адрес и фамилию получателя, например так, как показано па рис. 8.4. Затем сохраните документ под именем Письмо.doc.

  3. Выберите команду Сервис > Письма и рассылки > Мастер слияния (Tools > Letters and Mailings > Mail Merge Wizard). В области задач откроется окно Слияние (Mail Merge), показанное на рис. 8.5.

  4. В разделе Выбор типа документа (Select document type) выберите пункт Письма (Letters) и перейдите к следующему шагу мастера, щелкнув на команде Далее: Открытие документа (Next: Starting document).

Рис. 8.4. Текст главного документа слияния

Примечание

Пункты раздела Выбор типа документа (Select document type) определяют тип главного документа слияния. При необходимости вы всегда сможете позже изменить тип главного документа или связать с выбранным источником данных еще один главный документ.

Рис. 8.5. Окно Слияние (Mail Merge) области задач

  5. На этом этапе необходимо выбрать в качестве главного документа один из предлагаемых вариантов: использовать уже открытый документ, создать новый документ на основе шаблона или открыть существующий документ. Чтобы выбрать в качестве главного документа слияния только что созданный текст, щелкните на пункте Текущий документ (Use the current document).

  6. При необходимости отредактируйте содержание главного документа.

  7. Перейдите к следующему этану, щелкнув на команде Далее: Выбор получателей (Next: Select recipients).


Упражнение 4. Построение источника данных

Теперь нужно создать источник данных слияния (адресов и фамилий получателей письма).

  1. В разделе Выбор получателей (Select Recipients) окна Слияние (Merge Mailing) области задач выберите пункт Создание списка (Type a new list) (рис. 8.6).

Рис. 8.6. Окно Выбор получателей (Select Recipients) мастера Слияние (Mail Merge)

  2. Щелкните на команде Создать (Create) в разделе Создание списка (Type a new list). Откроется окно диалога, показанное на рис. 8.7.

Источник данных слияния представляет собой базу данных, состоящую из записей, на основе каждой из которых с помощью главного документа будет сгенерирован конкретный экземпляр письма. Все записи имеют одинаковые поля данных.

Некоторые наиболее распространенные поля заранее внесены в список окна создания источника данных. Вы можете удалить из базы данных ненужные поля и добавить свои собственные.

Рис. 8.7. Создание источника данных

Другие пункты раздела Выбор получателей (Select Recipients) позволяют выбрать в качестве источника данных имеющуюся базу данных, ранее созданную в Word или в приложении типа Access, либо адресную книгу.

Примечание

Наличие в источнике данных лишних полей никак не влияет на результат слияния, но замедляет работу программы.

  3. Щелкните на кнопке Настройка (Customize). Откроется окно диалога, пока занное на рис. 8.8.

  4. Выделите пункт Обращение (Title).

  5. Щелчком на кнопке Удалить (Delete) сотрите выделенное поле.

Рис. 8.8. Настройка полей источника данных

Рис. 8.9. Окно диалога Получатели слияния (Mail Merge Recipients)

  6. Повторяя шаги 4 и 5, удалите все поля, кроме Имя (FirstName), Фамилия (Last Name), Организация (Company Name), Адрес1 (Addressi) и Индекс (PostalCode).

  7. Щелкните на кнопке ОК.

  8. Щелкните на кнопке Закрыть (Close) окна диалога Создание источника данных (New Address List).

  9. В открывшемся окне диалога сохранения документа введите имя Гости и щелкните на кнопке Сохранить (Save). Появится показанное на рис. 8.9 окно диалога Получатели слияния (Mail Merge Recipients), в котором в настоящее время нет ни одной записи.

  10. Вам обязательно придется когда-нибудь ввести информацию в источник данных. Щелкните на кнопке Изменить... (Edit...), чтобы сделать это сейчас. Откроется форма для ввода данных. Давайте добавим несколько записей. Позже слияние сгенерирует ровно столько копий главного документа, сколько записей имеется в источнике данных.

  11. Заполните поля формы.

  12. Чтобы добавить еще одну запись, щелкните на кнопке Создать запись (New Entry).

  13. Введите еще несколько записей, перенеся в них информацию, представленную в табл. 8.1.

ТАБЛИЦА 8.1. Источник данных слияния
Номер записи | Имя | Фамилия | Организация | Адрес1 | Индекс
1 | Василий | Решетников | Премьер | Первая ул., 33 | 113114
2 | Петр | Петров | Фантом | Прямой пр., 18 | 114113
3 | Виктор | Горелов | Фантом | Четвертый проезд, 143 | 113278
4 | Игорь | Черный | Фантом | а/я 318 | 115333
5 | Илья | Николаев | Фантом | Косая ул. | 114232
6 | Леонид | Леонидов | Фантом | Зимний пр. | 211434

  14. Щелкните на кнопке Закрыть (Close), чтобы сохранить базу данных, а затем — на кнопке ОК окна Mail Merge Recipients.

Примечание

Для изменения информации источника данных щелкните в панели инструментов Слияние (Mail Merge) на кнопке Получатели (Mail Merge RecipientsEdit Data Source), а затем в открывшемся окне диалога — на кнопке Изменить (Edit). Откроется форма источника данных. Для перемещения по записям источника пользуйтесь кнопками Первая (First), Назад (Previous), Вперед (Next), Последняя (Last) в нижней части формы.

Рис. 8.10 . Панель инструментов Слияние


Упражнение 5. Размещение полей данных

Пришло время разместить поля источника данных в тексте главного документа.

  1. Перейдите к следующему этапу создания рассылки, щелкнув на команде Далее: Создание письма (Next: Write your letter) в области задач. Поместите курсор в первую строку документа и щелкните на команде Другие элементы (More Items). Откроется окно диалога Добавление поля слияния (Insert Merge Field), в котором содержится список полей источника данных, созданного в предыдущем упражнении.

  2. Выделите пункт Имя (FirstName) и щелкните на кнопке Вставить (Insert). Поле слияния появится в первой строке главного документа. Оно содержит специальный код, сообщающий программе Word, где следует размещать информацию из соответствующего ноля источника данных. Затем выберите пункт Фамилия (LastName) и снова щелкните на кнопке Вставить (Insert). Щелкните на кнопке Закрыть (Close), чтобы закрыть окно диалога Добавить поле слияния (Insert Merge Field).

  3. Введите пробел, чтобы отделить имя от фамилии.

  4. Нажмите клавишу Enter, откройте окно диалога Добавление поля слияния (Insert Merge Field) и выделите в списке пункт Адрес1 (Addressi).

  5. Снова нажмите Enter и выделите в том же списке пункт Индекс (PostalCode).

  6. Переместите курсор в конец слова Уважаемый и нажмите клавишу Пробел.

  7. Выберите в списке Добавление поля слияния (Insert Merge Field) ноле Имя (First Name), нажмите клавишу Пробел и там же выберите поле Фамилия (LastName). Теперь главный документ должен выглядеть так, как показано на рис. 8.11.

Рис. 8.11. Главный документ с полями слияния

При слиянии Word позволяет не только перебрать все записи источника данных, но и отобрать некоторые из них. Для этого можно воспользоваться полями Word или запросом. Список Добавить поле Word (Insert Word Field) панели инструментов Слияние (Merge Mail) позволяет добавлять в документ следующие поля, выполняющие отбор записей источника данных на основе определенных правил:

  • ASK (Запрос) и FILLIN (Заполнение) генерируют паузу в процессе печати слияния и дают возможность вводить дополнительный текст в каждый экземпляр документа, например индивидуальный номер клиента или пароль;

  • IF... THEN... ELSE позволяет ввести условие и действие, которое выполняется в случае истинности или ложности условия;

  • MERGE REC (Номер записи) и MERGE SEQ (Номер по порядку ) добавляют в документ соответственно номер записи источника данных и порядковый номер экземпляра слияния. Если в слиянии участвуют не все записи источника данных, эти номера будут отличаться друг от друга;

  • NEXT (Следующая запись) и NEXTIF (Следующая запись, если) дают возможность напечатать в одном экземпляре документа информацию из нескольких последовательных записей источника данных;

  • SET BOOKMARK (Закладка) позволяет связать некоторый текст документа с закладкой, которую можно вставлять в документ любое число раз. Если изменится исходный текст, обозначенный закладкой, то он моментально обновится во всех точках вставки этой закладки;

  • SKIPIF (Пропустить запись, если) дает возможность ввести условие, в случае истинности которого текущая запись будет пропущена и не попадет в слияние.

Давайте добавим в слияние пару полей Word.

  8. Нажатием клавиш Ctrl+Home переместитесь в начало документа и выберите в панели инструментов Слияние (Merge Mail) команду Добавить поле Word > SKIPIF (Insert Word Field > Skip Record If).

Рис. 8.12. Добавление поля Word

  9. В раскрывающемся списке Поле (Field Name) выберите пункт Индекс (Postal- Code), как показано на рис. 8.12.

  10. В списке Оператор (Comparison) выберите пункт Равно (Equal To).

  11. Введите в поле Значение (Compare To) величину 114113.

  12. Щелкните на кнопке ОК. Теперь при слиянии в источнике данных будут пропущены те записи, в поле Индекс (PostalCode) которых записано значение 114113.

  13. Нажмите клавиши Ctrl+End, а затем два раза клавишу Enter. Выберите команду Добавить поле Word > MERGEREC (Insert Word Field > Merge Record #). С помощью этого поля вы сможете отследить, какие записи источника данных попадут в слияние. Теперь главный документ станет таким, как показано на рис. 8.13.

  14. Перейдите к следующему этапу создания рассылки, щелкнув на команде Далее: Просмотр писем (Next: Preview your letters) области задач.

  15. Щелкните на команде Изменить список (Edit Recipient List) в области задач, чтобы создать запрос, с помощью которого записи будут рассортированы по алфавиту имен получателей писем.

Рис. 8.13. Главный документ с полями Word

Давайте добавим правило отбора, оставляющее только адресатов из компании «Фантом». Щелкните на стрелке рядом с заголовком столбца Организация (Company Name) и в раскрывшемся списке выберите пункт Дополнительно (Advanced). В появившемся окне диалога есть две вкладки. Первая из них — Отбор записей (Filter Records), — представленная на рис. 8.14, позволяет фильтровать записи источника данных.

  16. В списке Поле (Field) выберите пункт Организация (Company).

  17. В списке Оператор (Comparison) оставьте вариант Равно (Equal To).

  18. В поле Значение (Compare To) введите текст Фантом.

  19. Раскройте вкладку Сортировка записей (Sort Records) и настройте ее параметры.

  20. Щелкните на кнопке ОК. Это обеспечит сортировку результата слияния по алфавиту фамилий адресатов, а затем по алфавиту их имен.

Примечание

Назначение одинаковых правил сортировки для писем и наклеек на конверты позволяет при отправке писем не тратить время на поиск нужного конверта. Конверты с наклейками будут лежать на вашем столе в том же порядке, что и письма.

  21. Щелчком на кнопке ОК закройте окно диалога Получатели и сохраните новую версию главного документа.


Упражнение 6. Печать результата слияния

У вас уже есть главный документ и связанный с ним источник данных, который отфильтрован и рассортирован с помощью запроса. Казалось бы, можно выполнить слияние и распечатать результат. Однако перед этим полезно проверить правильность слияния.

  1. Продолжая работать с документом предыдущего упражнения, щелкните на кнопке Поиск ошибок (Check For Errors) панели инструментов Слияние (Merge Mail). Откроется окно диалога с переключателем, имеющим три положения. Первое положение переключателя позволяет получить сообщения обо всех обнаруженных ошибках без выполнения слияния. Выбрав второе положение переключателя, вы получите как само слияние, так и сообщения обо всех ошибках в последовательно появляющихся окнах диалога. Третье положение переключателя инициирует генерацию слияния и в отдельном документе сохраняет отчет об ошибках.

  2. Выберите положение переключателя Создать только отчет об ошибках (Simulate The Merge And Report Errors In A New Document).

  3. Щелкните на кнопке ОК.

Рис. 8.14. Проверка корректности параметров слияния

Примечание

При правильном выполнении всех операций в слиянии не обнаружится никаких ошибок, но если, к примеру, в главном документе оказалось неверное поле данных, появится сообщение.

  4. Щелкните на кнопке Поля/Данные (View Merged Data). Вы увидите, что поля главного документа заменятся на данные одной из записей источника данных.

  5. С помощью кнопок Следующая запись (Next Record) и Предыдущая запись (Previous Record) панели инструментов слияния или соответствующих кнопок области задач просмотрите все экземпляры документа, соответствующие конкретным записям источника данных. Обратите внимание, что запись адресата Василий Решетников отсутствует, так как она отфильтрована запросом из-за несоответствия названия компании значению Фантом (см. табл. 8.1). Тем не менее в этом режиме предварительного просмотра вы сможете наблюдать запись адресата Петр Петров, которая при окончательном слиянии будет пропущена из-за наличия в главном документе поля SKIPIF (Пропустить запись, если) с соответствующим условием.

  6. Снова щелкните на кнопке Поля/Данные (View Merged Data), чтобы вернуть отображение полей.

  7. Наконец пришло время выполнить слияние. Щелкните на команде Далее: Завершение слияния (Next: Complete the Merge) чтобы перейти к последнему окну мастера.

  8. Вы можете выбрать один из четырех режимов слияния, воспользовавшись соответствующими кнопками панели инструментов Слияние (Mail Merge):

    • Слияние в новый документ (Merge to New Document) — создает документ Word, в котором последовательно на отдельных страницах размещаются все экземпляры, построенные на основе слияния;
    • Слияние при печати (Merge to Printer) —печатает результат слияния на принтер;
    • Объединить для отправки (Merge to E-Mail) — отправляет каждый экземпляр слияния нужному адресату но электронной почте. Чтобы указать, какое поле источника данных содержит адреса электронной почты, щелкните на этой кнопке и выберите нужное поле в списке Кому (То) открывшегося окна диалога Составные электронные письма (Merge to E-Mail), затем щелкните на кнопке ОК. (В этом же окне диалога можно ввести содержимое поля Тема (Subject) электронных сообщений, а также выбрать, какие именно записи вы хотите отправить.);
    • Объединить для отправки по факсу (Merge to Fax) — отправляет каждый экземпляр слияния нужному адресату по факсу.

  9. Щелкните на кнопке ОК. Результат слияния будет отправлен в новый документ, на принтер или по электронной почте. В первом случае вновь созданный документ появится на экране и его можно будет сохранить в отдельном файле на жестком диске.


Контрольное упражнение

В качестве контрольного упражнения попробуйте распечатать наклейки на конверты для писем, созданных на этом занятии с помощью слияния.

  1. Откройте документ Письмо.doc, а затем откройте окно Слияние (Mail Merge) области задач.

  2. В разделе Выбор типа документа (Select document type) выберите пункт Наклейки (Mailing Labels) и перейдите к следующему этапу.

  3. Щелкните на команде Параметры наклейки (Label Options).

  4. В окне диалога Параметры наклейки (Label Options) настроите формат наклеек на конверты. Перейдите к следующему этапу.

  5. Воспользуйтесь в качестве источника данных существующим файлом Гости.

    • Как указать в качестве источника данных существующий файл ?

  6. Добавьте в текст наклеек поля Имя (FirstName), Фамилия (LastName), Индекс (Postal Code) и Адрес1 (Addressi), снабдив их соответствующими подписями.

  7. Щелкните на кнопке Обновление всех наклеек (Update All Labels), чтобы копировать макет первой созданной наклейки на всех остальные.

  8. Перейдите к следующему этапу и просмотрите созданные наклейки.

    • Как перейти к нужной записи ?
  9. Проверьте слияние на отсутствие ошибок.
  10. Выполните слияние в новый документ.
    • Как быстро выполнить слияние в новый документ?

  11. Проверьте правописание и грамматику полученного документа. При этом не забывайте пропускать все собственные имена (но не вносите их в словарь Word).

12. Распечатайте слияние.


Подведение итогов

Вы научились пользоваться двумя дополнительными модулями Word — проверкой правописания и слиянием. Word имеет множество других не менее интересных вспомогательных инструментов, которые можно найти в меню Сервис (Tools). Попробуйте изучить их самостоятельно.

Это занятие было заключительным разделом части книги, посвященной приложению Word. На следующем занятии вы перейдете к изучению электронных таблиц Excel.

Для повседневной работы с программой Word XP рекомендуем пользоваться уже упоминавшейся книгой Б. Карпова «Microsoft Word 2002: справочник» («Питер», 2001).


ЧАСТЬ III

Excel

Microsoft Excel XP — программа, обладающая эффективными средствами обработки числовой информации, представленной в виде электронных таблиц. Она позволяет выполнять математические, финансовые и статистические вычисления, оформлять отчеты, построенные на базе таблиц, выводить числовую информацию в виде графиков и диаграмм.

Электронная таблица

ТЕМА ЗАНЯТИЯ

На этом занятии вы познакомитесь со структурой электронных таблиц Excel и научитесь выполнять следующие операции:

  • вводить данные;

  • копировать и перемещать листы Excel;

  • выделять ячейки таблицы;

  • форматировать текст;

  • настраивать ячейки;

  • форматировать числа;

  • добавлять строки и столбцы.

Электронные таблицы предназначены для ввода и обработки табличных данных. С помощью Excel можно выполнять сложные вычисления с большими массивами чисел, строить диаграммы и печатать финансовые отчеты.

Понятие электронной таблицы

Документ приложения Excel называется рабочей книгой (workbook) или просто книгой Excel. Такая книга состоит из листов (worksheet), которые представляют собой большие таблицы ячеек с числами и текстовой информацией. Таблицы Excel похожи на базы данных, но предназначены не столько для хранения информации, сколько для проведения математических и статистических расчетов.

Упражнение 1. Книга Excel

Давайте создадим пустую книгу Excel, введем в нее числа и формулы и поучимся манипулировать с ее листами.

  1. Запустите Excel с помощью команды Пуск > Программы > Microsoft Excel (Start > Programs > Microsoft Excel). В окне Excel сразу откроется новая рабочая книга с тремя листами.

Рис. 9.1. Лист Excel

  2. Щелкните в ячейке А1 первого листа и введите текст Клиенты.

  3. Нажмите клавишу Enter и введите текст Январь.

  4. Перемещаясь по ячейкам с помощью клавиш со стрелками, клавиш Enter и Tab или с помощью мыши, сформируйте таблицу, показанную на рис. 9.1.

  5. Щелкните на ячейке А9 и введите слово Итого.

  6. Нажмите клавишу Tab и введите =СУММ(ВЗ : В7) (=SUM(B3 : В7)). Эта форму ла автоматически подсчитывает сумму ячеек столбца Январь.

  7. Снова нажмите клавишу Tab и введите 4юрмулу=СУММ(СЗ:С7) (=SUM(C3 :С7)).

  8. Добавьте подобные формулы во все ячейки строки 9, указывая в скобках букву текущего столбца. Теперь Excel автоматически суммирует числа в столбцах и выводит результат в строку 9, как показано на рис. 9.2.

Рис. 9.2. Таблица с формулами

  9. Щелкните на ячейке D9. Обратите внимание, что в выделенной ячейке с формулой выводится результат расчета, а сама формула видна в строке формулы в верхней части окна Excel. Попробуйте щелкнуть на любой ячейке верхних пяти строк таблицы и изменить находящееся в ней число. Excel автоматически скорректирует сумму столбца в строке Итого. Таким образом, вам теперь не нужно по несколько раз пересчитывать суммы столбцов на калькуляторе. Excel мгновенно реагирует на любые изменения таблицы, и вы всегда знаете точные итоговые значения. Конечно, Excel умеет выполнять над содержимым ячеек таблицы и более сложные математические операции. По умолчанию книга Excel имеет три листа со стандартными именами. Трех листов может не хватить для всех данных, а стандартные названия листов никак не раскрывают их назначение. Давайте научимся добавлять листы и назначать им более понятные имена.

Примечание

Если значение в ячейке с формулой не обновляется автоматически, выберите команду Сервис > Параметры (Tools > Options), раскройте вкладку Вычисления (Calculation) и выберите положение переключателя Автоматически (Automatic). Затем щелкните на кнопке ОК.

Примечание

Чтобы по умолчанию в книге появлялось другое количество листов, выберите команду Сервис > Параметры, раскройте вкладку Общие (General) и измените величину в счетчике Листов в новой книге (Sheets In New Workbook).

  10. Щелкните правой кнопкой мыши на корешке Лист1.

  11. Выберите в контекстном меню команду Переименовать (Rename).

  12. Введите новое имя Клиенты.

  13. Дважды щелкните на корешке Лист2 и введите имя Расходы.

  14. Щелкните на корешке Расходы правой кнопкой мыши и выберите в контек стном меню команду Переместить/скопировать (Move Or Copy).

  15. В открывшемся окне диалога (рис. 9.3) установите флажок Создавать копию (Create A Copy), чтобы выбранный лист копировался, а не перемещался.

Рис.9.3. Копирование листа

  16. В списке Перед листом (Before Sheet) щелкните на пункте переместить в конец (Move To End), чтобы скопировать первый лист в конец книги.

  17. Затем щелкните на кнопке ОК.

Примечание

Чтобы скопировать выбранный лист в новую рабочую книгу с одним листом, выберите в раскрывающемся списке В книгу (То Book) пункт Новая книга (New Book).

  18. Чтобы добавить еще один пустой лист, щелкните правой кнопкой мыши на корешке Расходы и выберите команду Добавить (Insert).

  19. На вкладке Общие (General) открывшегося окна диалога Вставка (Insert) щелкните на значке Лист (Worksheet). Затем щелкните на кнопке ОК. В рабочей книге появится пятый лист.

  20. Выберите команду Файл > Сохранить (File > Save).

  21. В появившемся окне диалога сохранения документа щелкните на кнопке Мои документы (My Documents).

  22. В поле Имя файла (File Name) введите название Электронная таблица. Затем щелкните на кнопке ОК, чтобы сохранить созданную книгу Excel. Обратите внимание, что документы Excel имеют расширение xls.

Упражнение 2. Ввод данных

Электронные таблицы обрабатывают числовые данные, которые размещаются в ячейках листа Excel. Столбцы и строки таблицы могут иметь текстовые названия. На листе Excel могут также располагаться заголовки, подписи и дополнительные ячейки данных с пояснительным текстом. Ввод информации — это один из первых шагов построения электронной таблицы. В этом упражнении вы изучите некоторые приемы ввода данных.

  1. Откройте файл, созданный в предыдущем упражнении, и щелкните на корешке листа Расходы.

  2. Щелкните на ячейке ВЗ и введите в нее текст Январь.

  3. Excel позволяет автоматически заполнять ячейки листа последовательными логически связанными значениями. Поместите указатель на квадратный маркер в правом нижнем углу активной ячейки.

  4. Нажмите кнопку мыши и протащите указатель вправо, чтобы рамка охватила ячейки с ВЗ по НЗ (рис. 9.4), и отпустите кнопку мыши. Семь ячеек строки заполнятся последовательными названиями месяцев года.

Рис. 9.4. Заполнение ячеек последовательными значениями

  5. Введите в ячейку А4 число 2002, а в ячейку А5 число 2005.

  6. Щелкните на клетке А4.

  7. Нажмите клавишу Shift и щелкните на ячейке А5, чтобы выделить сразу две ячейки. Для выделения ячеек листа Excel можно пользоваться следующими приемами:

    • щелчок на ячейке выделяет ее;
    • чтобы выделить прямоугольную область, щелкните на ее угловой клетке, нажмите клавишу Shift и щелкните на клетке противоположного угла области либо протащите мышь по диагонали от первого угла области до второго;
    • строка или столбец выделяются щелчком на кнопке заголовка строки или столбца;
    • чтобы выделить несколько строк или столбцов, протащите мышь по их заголовкам или щелкните па первом заголовке, нажмите клавишу Shift и щелкните на последнем заголовке группы;
    • нажав клавишу Ctrl и щелкая в клетках листа, можно выделить несколько разрозненных ячеек;
    • чтобы выделить весь лист, щелкните на кнопке листа, расположенной на пересечении линеек заголовков строк и столбцов.

Примечание

Если шаг 4 привел к заполнению всех семи ячеек словом Январь, значит, в Excel не задан список последовательных названий месяцев на русском языке. Чтобы добавить список значений для автоматического ввода, выберите команду Сервис ^ Параметры, раскройте вкладку Списки (Custom Lists). В поле Элементы списка (List Entries) введите последовательные элементы списка (Январь, Февраль, Март и т. д.) по одному на каждую строку и щелкните на кнопке Добавить (Add).

  8. Протащите угловой маркер рамки выделения вниз, чтобы рамка охватила ячейки с А4 но А12. Указанная серия ячеек будет заполнена последовательными числами с шагом 3, который определяется разницей чисел, введенных в две первые ячейки серии.

  9. Введите 1 в ячейку В4 и 3 в ячейку С4. Выделите эти две ячейки и протащите маркер рамки вправо, чтобы охватить все клетки строки вплоть до Н4.

  10. Протащите маркер полученной рамки шириной в 7 клеток вниз, чтобы охватить все строки вплоть до 12. Теперь таблица будет выглядеть так, как показано на рис. 9.5. С помощью подобных приемов таблица быстро заполняется исходными значениями, которые позже можно корректировать по мере надобности. Чтобы таблица стала более попятной, ее нужно снабдить заголовком. Ниже таблицы полезно добавить несколько итоговых значений, рассчитанных на основе данных таблицы,

  11. Введите в ячейку В 1 текст Расходы компании по месяцам. Текст заголовка не влезает в одну ячейку, поэтому следует объединить несколько ячеек.

Примечание

В последней версии Office XP появился новый способ, облегчающий ввод данных. Обратите внимание на значок параметров автозаполнения, который появляется после завершения операции заполнения рядом с угловым маркером последней заполненной ячейки. Раскрывающийся список содержит возможные параметры заполнения.

Рис. 9.5. Автозаполнение ячеек

  12. Выделите клетки с В1 по Gl.

  13. Щелкните на кнопке Объединить и поместить в центре (Merge And Center) пане ли инструментов Форматирование (Formatting).

  14. Выделите ячейки с В14 по Е14 и щелкните на кнопке Объединить и поместить в центре.

  15. Введите текст Среднее значение таблицы. По окончании ввода текста или числа ячейка находится в режиме редактирования содержимого. Многие команды для работы с ячейками в этом режиме недоступны.

  16. Чтобы выйти из режима редактирования, но остаться в текущей ячейке, щелкните на кнопке Ввод (Enter), расположенной слева от строки формулы.

Примечание

Чтобы переключиться в режим редактирования и изменить содержимое ячейки, дважды щелкните на ней. Щелчок на кнопке Отмена (Cancel), расположенной левее кнопки Ввод, выключает режим редактирования с отменой всех изменений, выполненных с момента последнего входа в этот режим.

  17. Щелчком на кнопке По левому краю (Align Left) панели инструментов Форма тирование выравняйте содержимое объединенной ячейки по левому краю.

  18. Щелкните на ячейке F14. \

  19. В строке формул щелкните на кнопке Изменить формулу (Edit Formula). Откроется окно диалога, помогающее строить корректные формулы.

Рис. 9.6. Вычисление среднего значения

  20. В раскрывающемся списке Формула (Formula) выберите пункт СРЗНАЧ (AVERAGE).

  21. Щелкните на строке формул и измените величину в скобках на В4: Н12, как показано на рис. 9.6.

  22. Щелкните на кнопке ОК. Теперь в ячейке F14 будет автоматически подсчитываться среднее значение всех чисел прямоугольной области от клетки В4 до клетки Н12. В данной ситуации эта величина равна 7.

  23. Щелкните на ячейке В4 и введите число 500. Нажмите клавишу Enter. Среднее значение таблицы сразу же изменится.

Форматирование листа Excel

Упражнение 3. Оформление ячеек

Вы уже умеете вводить числа, заголовки и подписи, вычислять сумму и среднее значение группы ячеек. Однако работать с таблицей намного приятнее, когда ее строки и столбцы окрашены в разные цвета и выделены рамками. Грамотное оформление ячеек помогает быстрее отыскивать числа, которые требуют изменения, и ячейки с результатами вычислений.

Рис. 9.7. Окно диалога автоформата

  1. Чтобы раскрасить таблицу листа Расходы, выделите прямоугольную область АЗ:Н14 и выберите команду Формат > Автоформат (Format > AutoFormat).

  2. В открывшемся окне диалога (рис. 9.7) щелкните на образце Классический 3 (Classic 3).

  3. Щелкните на кнопке Параметры (Options), открыв этой командой область флажков для установки дополнительных параметров.

  4. Сбросьте флажок ширину и высоту (Width/Height), чтобы инструмент автоформата не изменял размеры ячеек.

Примечание

В формулах Excel прямоугольная область ячеек задается идентификаторами левой верхней и правой нижней ячеек, соединенными двоеточием, например АЗ:Н14. В упражнениях третьей части книги для обозначения группы ячеек (или диапазона) используется аналогичный синтаксис.

Рис. 9.8. Форматирование ячеек

  5. Затем щелкните на кнопке ОК. Программа Excel сама оформит таблицу выбранным стилем.

  6. Чтобы привести вид заголовков строк в соответствие заголовкам столбцов, выделите ячейки А4:А12 и выберите команду Формат > Ячейки (Format > Cells).

  7. Раскройте вкладку Вид (Patterns), показанную на рис. 9.8.

  8. Щелкните на квадрате темно-синего цвета, сходного с цветом фона заголовков столбцов.

  9. Раскройте вкладку Граница (Border), показанную на рис. 9.9.

Рис. 9.9. Настройка границ ячеек

  10. В списке Тип линии (Style) выберите линию подходящей толщины.

  11. Щелкните на кнопке Внешние (Outline), чтобы обвести выделенные ячейки рамкой.

Примечание

Чтобы залить выделенные ячейки узором, пользуйтесь раскрывающимся списком Узор (Pattern) вкладки Вид.

  12. Щелчком на кнопке верхней границы уберите линию между ячейками A3 иА4.

  13. Затем щелкните на кнопке ОК.

  14. Цвет ячеек заголовков строк стал темно-синим, и черный текст в них плохо виден. Не отменяя выделения ячеек, щелкните в панели инструментов Фор матирование на стрелке справа от кнопки Цвет шрифта (Font Color).

  15. Выберите в раскрывшейся палитре белый цвет.

  16. Выделите ячейки А12:Н12 и снова выполните команду Формат > Ячейки.

  17. На вкладке Граница выберите тот же тин линии, что и на шаге 10, затем щелк ните на кнопке нижней границы.

Рис. 9.10. Оформленная таблица

  18. Щелчком на кнопке ОК закройте окно диалога. На листе ниже строки 12 появится разделительная линия. Теперь таблица будет выглядеть так, как показано на рис. 9.10.

Упражнение 4. Стиль

Конечно, Excel позволяет форматировать не только цвет и рамку ячеек, но также шрифт и расположение их содержимого.

  1. Снова выделите ячейки А4:А12, затем щелкните на них правой кнопкой мыши и выберите в контекстном меню команду Формат ячеек (Format Cells).

  2. В открывшемся окне диалога раскройте вкладку Выравнивание (Alignment), показанную на рис. 9.11.

  3. В раскрывающемся списке по горизонтали (Horizontal) выберите пункт по левому краю (отступ) (Left (Indent)),

  4. С помощью стрелок введите в счетчик отступ (Indent) величину 1, чтобы задать небольшой отступ чисел от левого края ячеек.

  5. Щелкните на кнопке ОК.

  6. В панели инструментов Форматирование щелкните на кнопках Полужирный (Bold) и Курсив (Italic). На занятии 6 обсуждались стили документов Word. Электронные таблицы Excel тоже можно форматировать с помощью стилей.

Рис. 9.11. Настройка выравнивания текста

Применение стилей позволяет быстро назначать ячейкам определенное заранее заданное оформление. Изменение стиля приводит к моментальному обновлению форматирования всех ячеек, которым назначен этот стиль. Давайте настроим стиль для заголовков и подписей и назначим его двум группам объединенных ячеек листа Расходы.

  7. За основу вновь создаваемого стиля всегда выбирается формат активной ячейки. Щелкните на объединенной ячейке B1:G1, чтобы выбрать формат ее стиля в качестве исходного.

  8. Выполните команду Формат > Стиль (Format > Style).

  9. Введите слово Надпись в поле раскрывающегося списка открывшегося окна диалога. Это будет имя нового стиля. В окне диалога появятся его исходные параметры (то есть режим форматирования диапазона B1:G1).

  10. Щелкните на кнопке Изменить (Modify).

  11. В открывшемся окне диалога Формат ячеек (Format Cells) на вкладке шрифт (Font) выберите полужирный шрифт размером 12 пунктов и щелкните на кнопке ОК.

Рис. 9.12. Окно настройки стиля

Рис. 9.13. Форматирование текста

  12. В окне диалога Стиль (Style) сбросьте все флажки, кроме шрифт, как показано на рис. 9.12, чтобы новый стиль влиял только на шрифт ячейки и не изменял другие параметры оформления.

  13. Щелкните на кнопке ОК. Заголовок Расходы компании по месяцам увеличится в соответствии с новым размером шрифта.

  14. Чтобы изменить шрифт подписи Среднее значение таблицы, выделите ячейки B14:F14.

  15. Выполните команду Формат > Стиль, в раскрывающемся списке Имя стиля (Style Name) выберите пункт надпись и щелкните на кнопке ОК.

Примечание

Чтобы создать новый документ на основе шаблона с дополнительными стилями и оформлением, выберите команду Файл > Создать (File > New), раскройте в окне диалога Создание документа (New) вкладку с нужным шаблоном и дважды щелкните на его значке. Любую книгу Excel можно использовать в качестве шаблона, предварительно сохранив ее в файле формата XLT.

Текущий документ был создан без использования шаблона, тем не менее в нем есть несколько стандартных стилей Excel:

  • Обычный (Normal) — стандартный стиль ячеек;

  • Процентный (Percent) — стиль ячеек, содержащих процентные величины;

  • Финансовый (Comma) — денежные значения (рубли и копейки);

  • Финансовый [0] (Comma [0]) — денежные значения (только рубли);

  • Денежный (Currency) — денежные значения (рубли, копейки и знак денежной единицы);

  • Денежный [0] (Currency [0]) — денежные значения (только рубли и знак денежной единицы).

  16. Чтобы задать ячейкам таблицы денежный стиль представления чисел, выделите ячейки В4:Н12.

  17. Нажмите клавишу Ctrl и, не отпуская ее, щелкните на ячейке F14. Эта ячейка будет присоединена к выделению.

  18. Выберите команду Формат > Стиль, в списке Имя стиля выберите пункт Денежный и щелкните на кнопке ОК. Таблица станет такой, как показано на рис. 9.13.

Упражнение 5. Формат чисел

Так как программа Excel предназначена для обработки чисел, важную роль играет правильная настройка их формата. Для человека число 10 — это просто единица и ноль. С точки зрения Excel эти две цифры могут нести совершенно разную информацию в зависимости от того, обозначают ли они количество работников компании, денежную величину, процентную часть целого или фрагмент заголовка «10 ведущих фирм». Во всех четырех ситуациях это число должно отображаться и обрабатываться по-разному. Excel поддерживает следующие форматы данных:

  • Общий (General) — текст и числовые значения произвольного типа;

  • Числовой (Number) — наиболее общий способ представления чисел;

  • Денежный (Currency) — денежные величины;

  • Финансовый (Accounting) — денежные величины с выравниванием по разделителю целой и дробной частей;

  • Дата (Date) — дата или дата и время;

  • Время (Time) — время или дата и время;

  • Процентный (Percentage) — значение ячейки, умноженное на 100 с символом «%» в конце;

  • Дробный (Fraction) — рациональные дроби с числителем и знаменателем;

  • Экспоненциальный (Scientific) —десятичные дробные числа;

  • Текстовый (Text) — текстовые данные отображаются точно так же, как вводятся и обрабатываются строки, вне зависимости от их содержимого;

  • Дополнительный (Special) —форматы для работы с базами данных и списками адресов;

  • Заказной (Custom) — формат, настраиваемый пользователем.

Наиболее распространенные варианты формата данных можно назначать с помощью панели инструментов Форматирование.

  1. Щелкните на ячейке С4, а затем на кнопке Процентный формат (Percent Style). Величина клетки С4 будет умножена на 100, и к ней добавится знак «%».

Рис. 9.14. Вкладка выбора формата данных

  2. Нажмите клавишу вниз и щелкните на кнопке Денежный формат (Currency).

  3. Щелкните на ячейке Сб, а затем на кнопке Формат с разделителями (Comma Style). Эта кнопка заставляет числа выравниваться в столбце по разделителю целой и дробной частей.

  4. Выделите ячейку С7 и щелкните на кнопке Увеличить разрядность (Increase Decimal). Эта кнопка не изменяет основной формат, но добавляет один знак в дробной части числа.

  5. Нажмите клавишу Enter и щелкните на кнопке Уменьшить разрядность (Decrease Decimal). Эта операция убирает один знак дробной части и округляет число. Теперь ячейки с С4 по С9 выглядят совершенно по-разному, хотя исходно в них были введены совершенно одинаковые числа. Другие форматы назначаются с помощью следующих действий.

  6. Щелкните на ячейке С10 и выберите команду Формат > Ячейки.

  7. В открывшемся окне диалога раскройте вкладку Число (Number) (рис. 9.14).

  8. В списке Числовые форматы (Category) щелкните на пункте Дата (Date).

  9. В появившемся списке Тип (Type) щелкните на строке 14 мар 01 (14-Mar-Ol). Затем щелкните на кнопке ОК.

  10. Аналогичным образом назначьте ячейке С11 формат Экспоненциальный, а ячейке С12 — формат Числовой. Теперь таблица будет выглядеть так (рис. 9.15). Обратите внимание, что среднее значение таблицы не изменилось, то есть при смене формата изменяется только способ отображения, а сами числовые значения остаются неизменными. Для проверки этого факта выполните следующие шаги.

  11. Дважды щелкните на ячейке СЮ и измените величину 03.01.1900 на 03.02.1900.

  12. Нажмите клавишу Enter. Среднее значение таблицы (которое выводится в денежном формате) моментально изменится на 15.41р. Как войдите, можно суммировать даты с процентами и в результате получать рубли. Это типичный пример неверного назначения форматов данных.

Рис. 9.15. Различные форматы чисел

Упражнение 6. Добавление строк и столбцов

Редко удается сразу построить таблицу с нужной структурой. В процессе разработки листа часто приходится добавлять и переставлять столбцы и строки. Давайте поучимся этим операциям.

  1. Выделите ячейки ЕЗ и F3 и выберите команду Вставка >Столбцы (Insert > Columns). Слева от столбца с заголовком Апрель появятся два пустых столбца (рис. 9.16). Их количество соответствует числу ячеек выделенного блока по горизонтали.

  2. Выделите диапазон ВЗ:С12 и нажмите клавиши Ctrl+C, чтобы скопировать содержимое выделенных ячеек.

  3. Щелкните на клетке ЕЗ правой кнопкой мыши и выберите в контекстном меню команду Вставить (Paste). Эта операция вставит данные не только в ячейку ЕЗ, но и в другие ячейки новых столбцов. В правом нижнем углу вставленного фрагмента появился значок вставки. Поместив на него указатель мыши, вы увидите раскрывающийся список, позволяющий выбрать один из параметров вставки: Сохранить форматы оригинала (Keep Source Formatting), Использовать форматы конечных ячеек (Match Destination Formatting), Значения и форматы чисел (Values and Number Formatting), Сохранить ширину столбцов оригинала (Keep Source Column Width), Только форматы (Formatting Only) или Ссылки на ячейки (Link Cells).

Примечание

При вставке блока данных в одну ячейку программа Ехсе1.всегда занимает вставляемой информацией столько ячеек, сколько было вырезано или скопировано. Если перед выполнением вставки было выделено несколько ячеек, то данные будут вставлены только в том случае, если форма диапазона-приемника идентична форме диапазона-источника.

Рис. 9.16. Добавление столбцов

  4. Щелкните на ячейке Н14, в которую переместилась ячейка с формулой среднего значения таблицы. В строке формул вы увидите текст =CP3HA4(B4:J12) (=AVERAGE(B4:312)). To есть область вычисления среднего значения автоматически расширилась на два вставленных столбца. Таким образом, формулы, работающие с массивами данных, автоматически адаптируются при увеличении размера массива.

Дополнительные строки добавляются точно так же, как столбцы. Вставляя строки или столбцы в таблицу с данными, будьте внимательны. Удалить лишние ячейки гораздо труднее, чем вставить. Выделение ячеек с последующим нажатием клавиши Delete, конечно, очищает ячейки, но размеры таблицы при этом не изменяются.

Упражнение 7. Размеры ячеек и их замораживание

Чтобы таблица лучше вписывалась в экран компьютера или на страницу принтера, можно подрегулировать ширину и высоту ячеек.

  1. Поместите указатель на границу между заголовками столбцов А и В, чтобы его значок принял форму двунаправленной стрелки.

  2. Нажмите кнопку мыши и перетащите границу столбцов влево, уменьшив этим ширину первого столбца.

  3. Выделите строки 13 и 14.

  4. Выберите команду Формат > Строка > Высота (Format > Row > Height).

  5. В открывшемся окне диалога введите число 15 и щелкните на кнопке ОК. Выделенные строки станут выше.

  6. Чтобы максимально сузить таблицу, протащите мышь по кнопкам строк с 1 по 14, выделив этим все ячейки данных.

  7. Выберите команду Формат > Столбец > Автоподбор ширины (Format > Column > AutoFit Selection). Эта операция максимально сузит столбцы, но лишь до такого размера, чтобы все данные свободно помещались в ячейках таблицы.

Рис. 9.17. Закрепление ячеек

Иногда при редактировании таблицы приходится копировать или переносить данные между ячейками, далеко отстоящими друг от друга. В этом случае можно закрепить часть строк и столбцов на экране. Работая с большими таблицами, бывает удобно закрепить строку и столбец заголовков, чтобы не запутаться в ячейках. Для закрепления заголовков выполните следующие шаги.

  8. Щелкните на ячейке В4. Затем выберите команду Окно > Закрепить области (Window > Freeze Panes). Ячейки, расположенные выше или левее выделенной, окажутся закрепленными и отгороженными от остальной таблицы тонкими черными линиями.

  9. Щелкните три раза на кнопке прокрутки вниз.

  10. Теперь два раза щелкните на кнопке прокрутки вправо. Лист Excel прокручивается как обычно, но закрепленные ячейки остаются на экране, как показано на рис. 9.17. Создается впечатление, что столбцы В и С, а также строки 4, 5 и 6 временно исчезли с экрана.

  11. Чтобы отменить закрепление, выполните команду Окно > Снять закрепление областей (Window > Unfreeze Panes). Лист будет выглядеть, как прежде.

Контрольное упражнение

Попробуйте самостоятельно заполнить данными один лист электронной таблицы.

  1. Переключитесь на лист Лист4.

  2. Измените название этого листа на Календарь.

  3. Введите в ячейку A3 символы Пн.

  4. Перетащите маркер выделения вниз, чтобы ячейки с A3 по А9 заполнились сокращенными названиями дней недели.

  5. В прямоугольную область B3:F9 введите числа календаря на текущий месяц.

  6. В строке 1 введите заголовок Календарь на текущий меся ц, объедините для него несколько ячеек и выровняйте заголовок по правому краю диапазона.

  7. Добавьте обрамление жирной линией вокруг блока ячеек A3:F9.

  8. Отделите линией столбец А от столбца В.

    • Как быстро добавить вертикальную линию?

  9. Залейте фон ячеек строк 8 и 9 красным цветом, а шрифт текста этих строк выделите жирным начертанием.

    • Как изменить фон ячеек?

  10. Объедините ячейки А11:С11 и введите в них текст Всего дней в месяце.

  11. В ячейку D11 вставьте формулу, подсчитывающую число дней месяца.

    • Как подсчитать число дней месяца?

  12. Скопируйте текущий лист в новую книгу Excel с одним листом и сохраните новую книгу в файле Календарь.xls.

  13. В книге Электронная таблица.xls раскройте лист Клиенты(2).

  14. Выделите строку 9 и удалите ее.

  15. Переименуйте этот лист, дав ему название Формулы. Затем сохраните документ.

Подведение итогов

На этом занятии вы узнали, как добавлять, копировать и переименовывать листы Excel, строить таблицы, оформлять и форматировать их. Вы познакомились с разными форматами чисел и научились настраивать собственные стили.

В упражнениях занятия вы строили формулы для расчета среднего значения, суммы и количества чисел. Вычисление статистических величин — одно из основных назначений электронных таблиц. Расчеты в Excel выполняются с помощью формул. На следующем занятии вы узнаете основные правила построения формул и познакомитесь с некоторыми функциями Excel.


ЧАСТЬ III

Excel

Microsoft Excel XP — программа, обладающая эффективными средствами обработки числовой информации, представленной в виде электронных таблиц. Она позволяет выполнять математические, финансовые и статистические вычисления, оформлять отчеты, построенные на базе таблиц, выводить числовую информацию в виде графиков и диаграмм.

Электронная таблица

ТЕМА ЗАНЯТИЯ

На этом занятии вы познакомитесь со структурой электронных таблиц Excel и научитесь выполнять следующие операции:

  • вводить данные;

  • копировать и перемещать листы Excel;

  • выделять ячейки таблицы;

  • форматировать текст;

  • настраивать ячейки;

  • форматировать числа;

  • добавлять строки и столбцы.

Электронные таблицы предназначены для ввода и обработки табличных данных. С помощью Excel можно выполнять сложные вычисления с большими массивами чисел, строить диаграммы и печатать финансовые отчеты.


Понятие электронной таблицы

Документ приложения Excel называется рабочей книгой (workbook) или просто книгой Excel. Такая книга состоит из листов (worksheet), которые представляют собой большие таблицы ячеек с числами и текстовой информацией. Таблицы Excel похожи на базы данных, но предназначены не столько для хранения информации, сколько для проведения математических и статистических расчетов.


Упражнение 1. Книга Excel

Давайте создадим пустую книгу Excel, введем в нее числа и формулы и поучимся манипулировать с ее листами.

  1. Запустите Excel с помощью команды Пуск > Программы > Microsoft Excel (Start > Programs > Microsoft Excel). В окне Excel сразу откроется новая рабочая книга с тремя листами.

Рис. 9.1. Лист Excel

  2. Щелкните в ячейке А1 первого листа и введите текст Клиенты.

  3. Нажмите клавишу Enter и введите текст Январь.

  4. Перемещаясь по ячейкам с помощью клавиш со стрелками, клавиш Enter и Tab или с помощью мыши, сформируйте таблицу, показанную на рис. 9.1.

  5. Щелкните на ячейке А9 и введите слово Итого.

  6. Нажмите клавишу Tab и введите =СУММ(ВЗ : В7) (=SUM(B3 : В7)). Эта форму ла автоматически подсчитывает сумму ячеек столбца Январь.

  7. Снова нажмите клавишу Tab и введите 4юрмулу=СУММ(СЗ:С7) (=SUM(C3 :С7)).

  8. Добавьте подобные формулы во все ячейки строки 9, указывая в скобках букву текущего столбца. Теперь Excel автоматически суммирует числа в столбцах и выводит результат в строку 9, как показано на рис. 9.2.

Рис. 9.2. Таблица с формулами

  9. Щелкните на ячейке D9. Обратите внимание, что в выделенной ячейке с формулой выводится результат расчета, а сама формула видна в строке формулы в верхней части окна Excel. Попробуйте щелкнуть на любой ячейке верхних пяти строк таблицы и изменить находящееся в ней число. Excel автоматически скорректирует сумму столбца в строке Итого. Таким образом, вам теперь не нужно по несколько раз пересчитывать суммы столбцов на калькуляторе. Excel мгновенно реагирует на любые изменения таблицы, и вы всегда знаете точные итоговые значения. Конечно, Excel умеет выполнять над содержимым ячеек таблицы и более сложные математические операции. По умолчанию книга Excel имеет три листа со стандартными именами. Трех листов может не хватить для всех данных, а стандартные названия листов никак не раскрывают их назначение. Давайте научимся добавлять листы и назначать им более понятные имена.

Примечание

Если значение в ячейке с формулой не обновляется автоматически, выберите команду Сервис > Параметры (Tools > Options), раскройте вкладку Вычисления (Calculation) и выберите положение переключателя Автоматически (Automatic). Затем щелкните на кнопке ОК.

Примечание

Чтобы по умолчанию в книге появлялось другое количество листов, выберите команду Сервис > Параметры, раскройте вкладку Общие (General) и измените величину в счетчике Листов в новой книге (Sheets In New Workbook).

  10. Щелкните правой кнопкой мыши на корешке Лист1.

  11. Выберите в контекстном меню команду Переименовать (Rename).

  12. Введите новое имя Клиенты.

  13. Дважды щелкните на корешке Лист2 и введите имя Расходы.

  14. Щелкните на корешке Расходы правой кнопкой мыши и выберите в контек стном меню команду Переместить/скопировать (Move Or Copy).

  15. В открывшемся окне диалога (рис. 9.3) установите флажок Создавать копию (Create A Copy), чтобы выбранный лист копировался, а не перемещался.

Рис.9.3. Копирование листа

  16. В списке Перед листом (Before Sheet) щелкните на пункте переместить в конец (Move To End), чтобы скопировать первый лист в конец книги.

  17. Затем щелкните на кнопке ОК.

Примечание

Чтобы скопировать выбранный лист в новую рабочую книгу с одним листом, выберите в раскрывающемся списке В книгу (То Book) пункт Новая книга (New Book).

  18. Чтобы добавить еще один пустой лист, щелкните правой кнопкой мыши на корешке Расходы и выберите команду Добавить (Insert).

  19. На вкладке Общие (General) открывшегося окна диалога Вставка (Insert) щелкните на значке Лист (Worksheet). Затем щелкните на кнопке ОК. В рабочей книге появится пятый лист.

  20. Выберите команду Файл > Сохранить (File > Save).

  21. В появившемся окне диалога сохранения документа щелкните на кнопке Мои документы (My Documents).

  22. В поле Имя файла (File Name) введите название Электронная таблица. Затем щелкните на кнопке ОК, чтобы сохранить созданную книгу Excel. Обратите внимание, что документы Excel имеют расширение xls.


Упражнение 2. Ввод данных

Электронные таблицы обрабатывают числовые данные, которые размещаются в ячейках листа Excel. Столбцы и строки таблицы могут иметь текстовые названия. На листе Excel могут также располагаться заголовки, подписи и дополнительные ячейки данных с пояснительным текстом. Ввод информации — это один из первых шагов построения электронной таблицы. В этом упражнении вы изучите некоторые приемы ввода данных.

  1. Откройте файл, созданный в предыдущем упражнении, и щелкните на корешке листа Расходы.

  2. Щелкните на ячейке ВЗ и введите в нее текст Январь.

  3. Excel позволяет автоматически заполнять ячейки листа последовательными логически связанными значениями. Поместите указатель на квадратный маркер в правом нижнем углу активной ячейки.

  4. Нажмите кнопку мыши и протащите указатель вправо, чтобы рамка охватила ячейки с ВЗ по НЗ (рис. 9.4), и отпустите кнопку мыши. Семь ячеек строки заполнятся последовательными названиями месяцев года.

Рис. 9.4. Заполнение ячеек последовательными значениями

  5. Введите в ячейку А4 число 2002, а в ячейку А5 число 2005.

  6. Щелкните на клетке А4.

  7. Нажмите клавишу Shift и щелкните на ячейке А5, чтобы выделить сразу две ячейки. Для выделения ячеек листа Excel можно пользоваться следующими приемами:

    • щелчок на ячейке выделяет ее;
    • чтобы выделить прямоугольную область, щелкните на ее угловой клетке, нажмите клавишу Shift и щелкните на клетке противоположного угла области либо протащите мышь по диагонали от первого угла области до второго;
    • строка или столбец выделяются щелчком на кнопке заголовка строки или столбца;
    • чтобы выделить несколько строк или столбцов, протащите мышь по их заголовкам или щелкните па первом заголовке, нажмите клавишу Shift и щелкните на последнем заголовке группы;
    • нажав клавишу Ctrl и щелкая в клетках листа, можно выделить несколько разрозненных ячеек;
    • чтобы выделить весь лист, щелкните на кнопке листа, расположенной на пересечении линеек заголовков строк и столбцов.

Примечание

Если шаг 4 привел к заполнению всех семи ячеек словом Январь, значит, в Excel не задан список последовательных названий месяцев на русском языке. Чтобы добавить список значений для автоматического ввода, выберите команду Сервис ^ Параметры, раскройте вкладку Списки (Custom Lists). В поле Элементы списка (List Entries) введите последовательные элементы списка (Январь, Февраль, Март и т. д.) по одному на каждую строку и щелкните на кнопке Добавить (Add).

  8. Протащите угловой маркер рамки выделения вниз, чтобы рамка охватила ячейки с А4 но А12. Указанная серия ячеек будет заполнена последовательными числами с шагом 3, который определяется разницей чисел, введенных в две первые ячейки серии.

  9. Введите 1 в ячейку В4 и 3 в ячейку С4. Выделите эти две ячейки и протащите маркер рамки вправо, чтобы охватить все клетки строки вплоть до Н4.

  10. Протащите маркер полученной рамки шириной в 7 клеток вниз, чтобы охватить все строки вплоть до 12. Теперь таблица будет выглядеть так, как показано на рис. 9.5. С помощью подобных приемов таблица быстро заполняется исходными значениями, которые позже можно корректировать по мере надобности. Чтобы таблица стала более попятной, ее нужно снабдить заголовком. Ниже таблицы полезно добавить несколько итоговых значений, рассчитанных на основе данных таблицы,

  11. Введите в ячейку В 1 текст Расходы компании по месяцам. Текст заголовка не влезает в одну ячейку, поэтому следует объединить несколько ячеек.

Примечание

В последней версии Office XP появился новый способ, облегчающий ввод данных. Обратите внимание на значок параметров автозаполнения, который появляется после завершения операции заполнения рядом с угловым маркером последней заполненной ячейки. Раскрывающийся список содержит возможные параметры заполнения.

Рис. 9.5. Автозаполнение ячеек

  12. Выделите клетки с В1 по Gl.

  13. Щелкните на кнопке Объединить и поместить в центре (Merge And Center) пане ли инструментов Форматирование (Formatting).

  14. Выделите ячейки с В14 по Е14 и щелкните на кнопке Объединить и поместить в центре.

  15. Введите текст Среднее значение таблицы. По окончании ввода текста или числа ячейка находится в режиме редактирования содержимого. Многие команды для работы с ячейками в этом режиме недоступны.

  16. Чтобы выйти из режима редактирования, но остаться в текущей ячейке, щелкните на кнопке Ввод (Enter), расположенной слева от строки формулы.

Примечание

Чтобы переключиться в режим редактирования и изменить содержимое ячейки, дважды щелкните на ней. Щелчок на кнопке Отмена (Cancel), расположенной левее кнопки Ввод, выключает режим редактирования с отменой всех изменений, выполненных с момента последнего входа в этот режим.

  17. Щелчком на кнопке По левому краю (Align Left) панели инструментов Форма тирование выравняйте содержимое объединенной ячейки по левому краю.

  18. Щелкните на ячейке F14. \

  19. В строке формул щелкните на кнопке Изменить формулу (Edit Formula). Откроется окно диалога, помогающее строить корректные формулы.

Рис. 9.6. Вычисление среднего значения

  20. В раскрывающемся списке Формула (Formula) выберите пункт СРЗНАЧ (AVERAGE).

  21. Щелкните на строке формул и измените величину в скобках на В4: Н12, как показано на рис. 9.6.

  22. Щелкните на кнопке ОК. Теперь в ячейке F14 будет автоматически подсчитываться среднее значение всех чисел прямоугольной области от клетки В4 до клетки Н12. В данной ситуации эта величина равна 7.

  23. Щелкните на ячейке В4 и введите число 500. Нажмите клавишу Enter. Среднее значение таблицы сразу же изменится.


Форматирование листа Excel

Упражнение 3. Оформление ячеек

Вы уже умеете вводить числа, заголовки и подписи, вычислять сумму и среднее значение группы ячеек. Однако работать с таблицей намного приятнее, когда ее строки и столбцы окрашены в разные цвета и выделены рамками. Грамотное оформление ячеек помогает быстрее отыскивать числа, которые требуют изменения, и ячейки с результатами вычислений.

Рис. 9.7. Окно диалога автоформата

  1. Чтобы раскрасить таблицу листа Расходы, выделите прямоугольную область АЗ:Н14 и выберите команду Формат > Автоформат (Format > AutoFormat).

  2. В открывшемся окне диалога (рис. 9.7) щелкните на образце Классический 3 (Classic 3).

  3. Щелкните на кнопке Параметры (Options), открыв этой командой область флажков для установки дополнительных параметров.

  4. Сбросьте флажок ширину и высоту (Width/Height), чтобы инструмент автоформата не изменял размеры ячеек.

Примечание

В формулах Excel прямоугольная область ячеек задается идентификаторами левой верхней и правой нижней ячеек, соединенными двоеточием, например АЗ:Н14. В упражнениях третьей части книги для обозначения группы ячеек (или диапазона) используется аналогичный синтаксис.

Рис. 9.8. Форматирование ячеек

  5. Затем щелкните на кнопке ОК. Программа Excel сама оформит таблицу выбранным стилем.

  6. Чтобы привести вид заголовков строк в соответствие заголовкам столбцов, выделите ячейки А4:А12 и выберите команду Формат > Ячейки (Format > Cells).

  7. Раскройте вкладку Вид (Patterns), показанную на рис. 9.8.

  8. Щелкните на квадрате темно-синего цвета, сходного с цветом фона заголовков столбцов.

  9. Раскройте вкладку Граница (Border), показанную на рис. 9.9.

Рис. 9.9. Настройка границ ячеек

  10. В списке Тип линии (Style) выберите линию подходящей толщины.

  11. Щелкните на кнопке Внешние (Outline), чтобы обвести выделенные ячейки рамкой.

Примечание

Чтобы залить выделенные ячейки узором, пользуйтесь раскрывающимся списком Узор (Pattern) вкладки Вид.

  12. Щелчком на кнопке верхней границы уберите линию между ячейками A3 иА4.

  13. Затем щелкните на кнопке ОК.

  14. Цвет ячеек заголовков строк стал темно-синим, и черный текст в них плохо виден. Не отменяя выделения ячеек, щелкните в панели инструментов Фор матирование на стрелке справа от кнопки Цвет шрифта (Font Color).

  15. Выберите в раскрывшейся палитре белый цвет.

  16. Выделите ячейки А12:Н12 и снова выполните команду Формат > Ячейки.

  17. На вкладке Граница выберите тот же тин линии, что и на шаге 10, затем щелк ните на кнопке нижней границы.

Рис. 9.10. Оформленная таблица

  18. Щелчком на кнопке ОК закройте окно диалога. На листе ниже строки 12 появится разделительная линия. Теперь таблица будет выглядеть так, как показано на рис. 9.10.


Упражнение 4. Стиль

Конечно, Excel позволяет форматировать не только цвет и рамку ячеек, но также шрифт и расположение их содержимого.

  1. Снова выделите ячейки А4:А12, затем щелкните на них правой кнопкой мыши и выберите в контекстном меню команду Формат ячеек (Format Cells).

  2. В открывшемся окне диалога раскройте вкладку Выравнивание (Alignment), показанную на рис. 9.11.

  3. В раскрывающемся списке по горизонтали (Horizontal) выберите пункт по левому краю (отступ) (Left (Indent)),

  4. С помощью стрелок введите в счетчик отступ (Indent) величину 1, чтобы задать небольшой отступ чисел от левого края ячеек.

  5. Щелкните на кнопке ОК.

  6. В панели инструментов Форматирование щелкните на кнопках Полужирный (Bold) и Курсив (Italic). На занятии 6 обсуждались стили документов Word. Электронные таблицы Excel тоже можно форматировать с помощью стилей.

Рис. 9.11. Настройка выравнивания текста

Применение стилей позволяет быстро назначать ячейкам определенное заранее заданное оформление. Изменение стиля приводит к моментальному обновлению форматирования всех ячеек, которым назначен этот стиль. Давайте настроим стиль для заголовков и подписей и назначим его двум группам объединенных ячеек листа Расходы.

  7. За основу вновь создаваемого стиля всегда выбирается формат активной ячейки. Щелкните на объединенной ячейке B1:G1, чтобы выбрать формат ее стиля в качестве исходного.

  8. Выполните команду Формат > Стиль (Format > Style).

  9. Введите слово Надпись в поле раскрывающегося списка открывшегося окна диалога. Это будет имя нового стиля. В окне диалога появятся его исходные параметры (то есть режим форматирования диапазона B1:G1).

  10. Щелкните на кнопке Изменить (Modify).

  11. В открывшемся окне диалога Формат ячеек (Format Cells) на вкладке шрифт (Font) выберите полужирный шрифт размером 12 пунктов и щелкните на кнопке ОК.

Рис. 9.12. Окно настройки стиля

Рис. 9.13. Форматирование текста

  12. В окне диалога Стиль (Style) сбросьте все флажки, кроме шрифт, как показано на рис. 9.12, чтобы новый стиль влиял только на шрифт ячейки и не изменял другие параметры оформления.

  13. Щелкните на кнопке ОК. Заголовок Расходы компании по месяцам увеличится в соответствии с новым размером шрифта.

  14. Чтобы изменить шрифт подписи Среднее значение таблицы, выделите ячейки B14:F14.

  15. Выполните команду Формат > Стиль, в раскрывающемся списке Имя стиля (Style Name) выберите пункт надпись и щелкните на кнопке ОК.

Примечание

Чтобы создать новый документ на основе шаблона с дополнительными стилями и оформлением, выберите команду Файл > Создать (File > New), раскройте в окне диалога Создание документа (New) вкладку с нужным шаблоном и дважды щелкните на его значке. Любую книгу Excel можно использовать в качестве шаблона, предварительно сохранив ее в файле формата XLT.

Текущий документ был создан без использования шаблона, тем не менее в нем есть несколько стандартных стилей Excel:

  • Обычный (Normal) — стандартный стиль ячеек;

  • Процентный (Percent) — стиль ячеек, содержащих процентные величины;

  • Финансовый (Comma) — денежные значения (рубли и копейки);

  • Финансовый [0] (Comma [0]) — денежные значения (только рубли);

  • Денежный (Currency) — денежные значения (рубли, копейки и знак денежной единицы);

  • Денежный [0] (Currency [0]) — денежные значения (только рубли и знак денежной единицы).

  16. Чтобы задать ячейкам таблицы денежный стиль представления чисел, выделите ячейки В4:Н12.

  17. Нажмите клавишу Ctrl и, не отпуская ее, щелкните на ячейке F14. Эта ячейка будет присоединена к выделению.

  18. Выберите команду Формат > Стиль, в списке Имя стиля выберите пункт Денежный и щелкните на кнопке ОК. Таблица станет такой, как показано на рис. 9.13.


Упражнение 5. Формат чисел

Так как программа Excel предназначена для обработки чисел, важную роль играет правильная настройка их формата. Для человека число 10 — это просто единица и ноль. С точки зрения Excel эти две цифры могут нести совершенно разную информацию в зависимости от того, обозначают ли они количество работников компании, денежную величину, процентную часть целого или фрагмент заголовка «10 ведущих фирм». Во всех четырех ситуациях это число должно отображаться и обрабатываться по-разному. Excel поддерживает следующие форматы данных:

  • Общий (General) — текст и числовые значения произвольного типа;

  • Числовой (Number) — наиболее общий способ представления чисел;

  • Денежный (Currency) — денежные величины;

  • Финансовый (Accounting) — денежные величины с выравниванием по разделителю целой и дробной частей;

  • Дата (Date) — дата или дата и время;

  • Время (Time) — время или дата и время;

  • Процентный (Percentage) — значение ячейки, умноженное на 100 с символом «%» в конце;

  • Дробный (Fraction) — рациональные дроби с числителем и знаменателем;

  • Экспоненциальный (Scientific) —десятичные дробные числа;

  • Текстовый (Text) — текстовые данные отображаются точно так же, как вводятся и обрабатываются строки, вне зависимости от их содержимого;

  • Дополнительный (Special) —форматы для работы с базами данных и списками адресов;

  • Заказной (Custom) — формат, настраиваемый пользователем.

Наиболее распространенные варианты формата данных можно назначать с помощью панели инструментов Форматирование.

  1. Щелкните на ячейке С4, а затем на кнопке Процентный формат (Percent Style). Величина клетки С4 будет умножена на 100, и к ней добавится знак «%».

Рис. 9.14. Вкладка выбора формата данных

  2. Нажмите клавишу вниз и щелкните на кнопке Денежный формат (Currency).

  3. Щелкните на ячейке Сб, а затем на кнопке Формат с разделителями (Comma Style). Эта кнопка заставляет числа выравниваться в столбце по разделителю целой и дробной частей.

  4. Выделите ячейку С7 и щелкните на кнопке Увеличить разрядность (Increase Decimal). Эта кнопка не изменяет основной формат, но добавляет один знак в дробной части числа.

  5. Нажмите клавишу Enter и щелкните на кнопке Уменьшить разрядность (Decrease Decimal). Эта операция убирает один знак дробной части и округляет число. Теперь ячейки с С4 по С9 выглядят совершенно по-разному, хотя исходно в них были введены совершенно одинаковые числа. Другие форматы назначаются с помощью следующих действий.

  6. Щелкните на ячейке С10 и выберите команду Формат > Ячейки.

  7. В открывшемся окне диалога раскройте вкладку Число (Number) (рис. 9.14).

  8. В списке Числовые форматы (Category) щелкните на пункте Дата (Date).

  9. В появившемся списке Тип (Type) щелкните на строке 14 мар 01 (14-Mar-Ol). Затем щелкните на кнопке ОК.

  10. Аналогичным образом назначьте ячейке С11 формат Экспоненциальный, а ячейке С12 — формат Числовой. Теперь таблица будет выглядеть так (рис. 9.15). Обратите внимание, что среднее значение таблицы не изменилось, то есть при смене формата изменяется только способ отображения, а сами числовые значения остаются неизменными. Для проверки этого факта выполните следующие шаги.

  11. Дважды щелкните на ячейке СЮ и измените величину 03.01.1900 на 03.02.1900.

  12. Нажмите клавишу Enter. Среднее значение таблицы (которое выводится в денежном формате) моментально изменится на 15.41р. Как войдите, можно суммировать даты с процентами и в результате получать рубли. Это типичный пример неверного назначения форматов данных.

Рис. 9.15. Различные форматы чисел


Упражнение 6. Добавление строк и столбцов

Редко удается сразу построить таблицу с нужной структурой. В процессе разработки листа часто приходится добавлять и переставлять столбцы и строки. Давайте поучимся этим операциям.

  1. Выделите ячейки ЕЗ и F3 и выберите команду Вставка >Столбцы (Insert > Columns). Слева от столбца с заголовком Апрель появятся два пустых столбца (рис. 9.16). Их количество соответствует числу ячеек выделенного блока по горизонтали.

  2. Выделите диапазон ВЗ:С12 и нажмите клавиши Ctrl+C, чтобы скопировать содержимое выделенных ячеек.

  3. Щелкните на клетке ЕЗ правой кнопкой мыши и выберите в контекстном меню команду Вставить (Paste). Эта операция вставит данные не только в ячейку ЕЗ, но и в другие ячейки новых столбцов. В правом нижнем углу вставленного фрагмента появился значок вставки. Поместив на него указатель мыши, вы увидите раскрывающийся список, позволяющий выбрать один из параметров вставки: Сохранить форматы оригинала (Keep Source Formatting), Использовать форматы конечных ячеек (Match Destination Formatting), Значения и форматы чисел (Values and Number Formatting), Сохранить ширину столбцов оригинала (Keep Source Column Width), Только форматы (Formatting Only) или Ссылки на ячейки (Link Cells).

Примечание

При вставке блока данных в одну ячейку программа Ехсе1.всегда занимает вставляемой информацией столько ячеек, сколько было вырезано или скопировано. Если перед выполнением вставки было выделено несколько ячеек, то данные будут вставлены только в том случае, если форма диапазона-приемника идентична форме диапазона-источника.

Рис. 9.16. Добавление столбцов

  4. Щелкните на ячейке Н14, в которую переместилась ячейка с формулой среднего значения таблицы. В строке формул вы увидите текст =CP3HA4(B4:J12) (=AVERAGE(B4:312)). To есть область вычисления среднего значения автоматически расширилась на два вставленных столбца. Таким образом, формулы, работающие с массивами данных, автоматически адаптируются при увеличении размера массива.

Дополнительные строки добавляются точно так же, как столбцы. Вставляя строки или столбцы в таблицу с данными, будьте внимательны. Удалить лишние ячейки гораздо труднее, чем вставить. Выделение ячеек с последующим нажатием клавиши Delete, конечно, очищает ячейки, но размеры таблицы при этом не изменяются.


Упражнение 7. Размеры ячеек и их замораживание

Чтобы таблица лучше вписывалась в экран компьютера или на страницу принтера, можно подрегулировать ширину и высоту ячеек.

  1. Поместите указатель на границу между заголовками столбцов А и В, чтобы его значок принял форму двунаправленной стрелки.

  2. Нажмите кнопку мыши и перетащите границу столбцов влево, уменьшив этим ширину первого столбца.

  3. Выделите строки 13 и 14.

  4. Выберите команду Формат > Строка > Высота (Format > Row > Height).

  5. В открывшемся окне диалога введите число 15 и щелкните на кнопке ОК. Выделенные строки станут выше.

  6. Чтобы максимально сузить таблицу, протащите мышь по кнопкам строк с 1 по 14, выделив этим все ячейки данных.

  7. Выберите команду Формат > Столбец > Автоподбор ширины (Format > Column > AutoFit Selection). Эта операция максимально сузит столбцы, но лишь до такого размера, чтобы все данные свободно помещались в ячейках таблицы.

Рис. 9.17. Закрепление ячеек

Иногда при редактировании таблицы приходится копировать или переносить данные между ячейками, далеко отстоящими друг от друга. В этом случае можно закрепить часть строк и столбцов на экране. Работая с большими таблицами, бывает удобно закрепить строку и столбец заголовков, чтобы не запутаться в ячейках. Для закрепления заголовков выполните следующие шаги.

  8. Щелкните на ячейке В4. Затем выберите команду Окно > Закрепить области (Window > Freeze Panes). Ячейки, расположенные выше или левее выделенной, окажутся закрепленными и отгороженными от остальной таблицы тонкими черными линиями.

  9. Щелкните три раза на кнопке прокрутки вниз.

  10. Теперь два раза щелкните на кнопке прокрутки вправо. Лист Excel прокручивается как обычно, но закрепленные ячейки остаются на экране, как показано на рис. 9.17. Создается впечатление, что столбцы В и С, а также строки 4, 5 и 6 временно исчезли с экрана.

  11. Чтобы отменить закрепление, выполните команду Окно > Снять закрепление областей (Window > Unfreeze Panes). Лист будет выглядеть, как прежде.


Контрольное упражнение

Попробуйте самостоятельно заполнить данными один лист электронной таблицы.

  1. Переключитесь на лист Лист4.

  2. Измените название этого листа на Календарь.

  3. Введите в ячейку A3 символы Пн.

  4. Перетащите маркер выделения вниз, чтобы ячейки с A3 по А9 заполнились сокращенными названиями дней недели.

  5. В прямоугольную область B3:F9 введите числа календаря на текущий месяц.

  6. В строке 1 введите заголовок Календарь на текущий меся ц, объедините для него несколько ячеек и выровняйте заголовок по правому краю диапазона.

  7. Добавьте обрамление жирной линией вокруг блока ячеек A3:F9.

  8. Отделите линией столбец А от столбца В.

    • Как быстро добавить вертикальную линию?

  9. Залейте фон ячеек строк 8 и 9 красным цветом, а шрифт текста этих строк выделите жирным начертанием.

    • Как изменить фон ячеек?

  10. Объедините ячейки А11:С11 и введите в них текст Всего дней в месяце.

  11. В ячейку D11 вставьте формулу, подсчитывающую число дней месяца.

    • Как подсчитать число дней месяца?

  12. Скопируйте текущий лист в новую книгу Excel с одним листом и сохраните новую книгу в файле Календарь.xls.

  13. В книге Электронная таблица.xls раскройте лист Клиенты(2).

  14. Выделите строку 9 и удалите ее.

  15. Переименуйте этот лист, дав ему название Формулы. Затем сохраните документ.


Подведение итогов

На этом занятии вы узнали, как добавлять, копировать и переименовывать листы Excel, строить таблицы, оформлять и форматировать их. Вы познакомились с разными форматами чисел и научились настраивать собственные стили.

В упражнениях занятия вы строили формулы для расчета среднего значения, суммы и количества чисел. Вычисление статистических величин — одно из основных назначений электронных таблиц. Расчеты в Excel выполняются с помощью формул. На следующем занятии вы узнаете основные правила построения формул и познакомитесь с некоторыми функциями Excel.


Ответы на вопросы контрольных упражнений

Контрольный вопрос 1.1

Как создать новый Веб-узел в программе Frontpage?

Щелкните на кнопке Пуск и выберите команду Программы > Microsoft Frontpage. В окне Frontpage раскройте меню Файл (File) и выберите команду Создать > Страница или веб-узел.

Контрольный вопрос 1.2

Что нужно сделать, чтобы превратить сплошную линию, нарисованную в документе Word, в пунктирную?

Если в нижней части окна Word нет панели инструментов Рисование, щелкните на одноименной кнопке панели инструментов Стандартная. Щелчком выделите линию. Щелкните на кнопке Тип штриха панели инструментов Рисование и в раскрывшейся палитре выберите пунктирную линию.

Контрольный вопрос 1.3

Как в Word распечатать на стандартном принтере текущую страницу?

Нажмите клавиши Ctrl+P. В разделе Страницы окна диалога Печать выберите положение переключателя Текущая. Затем щелкните на кнопке ОК.

Контрольный вопрос 1.4

Как экспортировать документ Word в файл формата HTML?

Выберите команду файл > Сохранить как. В раскрывающемся списке Тип файла выберите пункт Веб-страница. Введите имя HTML-файла в поле Имя файла и щелкните на кнопке Сохранить.

Контрольный вопрос 2.1

Как в Access открыть имеющуюся базу данных?

В области задач приложения, появляющейся при запуске программы, щелкните на имени файла базы данных в списке раздела Открытие базы. Если в списке его не находите, то щелкните на пункте Другие файлы и в появившемся окне диалога Открытие файла найдите нужный файл.

Контрольный вопрос 2.2

Какими двумя способами можно удалить запись базы данных?

В окне базы данных щелкните на кнопке Таблицы, затем дважды щелкните на пункте Таблица данных. В открывшемся окне таблицы щелкните на кнопке слева от третьей строки и нажмите клавишу Delete. Либо щелкните в окне базы данных на кнопке Формы, затем дважды щелкните на пункте Таблица данных. В открывшейся форме, щелкая на кнопке со стрелкой вправо, переместитесь к третьей записи и щелкните на кнопке Удалить запись панели инструментов.

Контрольный вопрос 2.3

Как в Excelудалить содержимое группы ячеек?

Щелкните на ячейке D6, нажмите клавишу Shift и, не отпуская ее, щелкните на ячейке Е7. Будет выделена вся группа ячеек. Нажмите клавишу Delete.

Контрольный вопрос 2.4

Как скопировать данные из ячейки электронной таблицы в поле базы данных?

Щелкните в электронной таблице на ячейке А1 и нажмите клавиши Ctrl+C. Переключитесь в окно таблицы базы данных Access. Щелкните в первой ячейке последней (пустой) строки таблицы и нажмите клавиши Ctrl+V. При необходимости введите данные в другие поля новой записи.

Контрольный вопрос 3.1

Как отобразить в окне Проводника файлы указанной папки?

С помощью вертикальной полосы прокрутки отыщите в левой панели Проводника папку Windows и щелкните на знаке «плюс» слева от нее. В раскрывшейся ветви вложенных папок найдите значок папки SendTo и щелкните на нем.

Контрольный вопрос 3.2

Как добавить значок принтера в папку SendTo?

Правой кнопкой мыши перетащите созданный вами ярлык принтера с рабочего стола в окно проводника и выберите в раскрывшемся после отпускания кнопки мыши контекстном меню команду Копировать.

Контрольный вопрос 3.3

Как распечатать файл с помощью контекстного меню?

Щелкните на значке Teкст.doc правой кнопкой мыши и выберите в контекстном меню пункт Отправить. В раскрывшемся подменю вы увидите только что созданный ярлык принтера. Щелкните на нем.

Контрольный вопрос 3.4

Как упростить добавление новых пунктов в подменю Send To?

Добавьте в папку SendTo ярлык этой папки. Тогда для добавления ярлыка объекта в подменю Отправить достаточно будет щелкнуть на значке объекта правой кнопкой мыши и выбрать в контекстном меню пункт Отправить > SendTo.

Контрольный вопрос 4.1

Как с помощью меню выделить весь документ? Выберите команду Правка > Выделить все записи (Edit > Select All Records).

Контрольный вопрос 4.2

Какая команда меню позволяет задать вопрос справочной системе Office?

Команда Справка > Справка по Microsoft Excel или аналогичная команда другого приложения.

Контрольный вопрос 4.3

Как распечатать текущую страницу справки? Щелкните на кнопке Печать панели инструментов справочной системы.

Контрольный вопрос 4.4

Как восстановить данные, удаленные из таблицы Access?

Удаленные записи таблицы Access восстановить невозможно! Будьте внимательны, изменение информации в базе данных сразу находит отражение в файле на жестком диске. Не все команды Access и других приложений Office можно отменить командой Отмена.

Контрольный вопрос 5.1

Как в окне диалога создания документа вывести список шаблонов в виде таблицы с дополнительной информацией о файлах?

Щелкните на кнопке Таблица в правой части окна диалога Создать.

Контрольный вопрос 5.2

Подумайте, как с помощью панели инструментов Структура убрать оформление заголовков разделов и разместить на экране больше текста?

Щелкните на кнопке Отобразить форматирование панели инструментов Структура.

Контрольный вопрос 5.3

Для переплета отчетов необходимо добавить в верхней части страницы дополнительное поле в 2 см. Как это сделать?

Выберите команду Файл > Параметры страницы, раскройте вкладку Поля. В счетчик Переплет введите число 2 и в переключателе Положение переплета (Gutter Position) выберите положение Сверху (Тор).

Контрольный вопрос 6.1

Как отменить нумерацию абзаца и расположить его ниже столбцов, чтобы он занял всю ширину страницы?

Щелкните в тексте абзаца, затем для отмены нумерации щелкните на кнопке Нумерация (Numbering) панели инструментов Форматирование (Formatting). После этого выделите пятый абзац, щелкните на кнопке Столбцы панели инструментов Стандартная и выберите в раскрывшейся палитре первый столбец.

Контрольный вопрос 6.2

Как с помощью панели инструментов изменить отступ абзаца?

Воспользуйтесь кнопками Увеличить отступ (Increase Indent) и Уменьшить отступ (Decrease Indent) панели инструментов Форматирование (Formatting).

Контрольный вопрос 6.3

Как скопировать формат текста, используя кнопку Формат по образцу панели инструментов ?

Щелкните на том символе, формат которого нужно скопировать, а затем на кнопке Формат по образцу (Format Painter) панели инструментов Стандартная (Standard). Затем протаскиванием мыши выделите фрагмент, которому нужно назначить новый формат.

Контрольный вопрос 7.1

Как обновить диаграмму, чтобы в ней появились данные добавленного столбца?

Выделите всю таблицу и нажмите клавиши Ctrl+C. Двойным щелчком на диаграмме откройте Microsoft Graph. Щелкните в первой ячейке таблицы данных Graph и нажмите клавиши Ctrl+V.

Контрольный вопрос 7.2

Как автоматически рассортировать табличные данные?

Поместите курсор в таблицу и выполните команду Таблица > Сортировка (Table > Sort). В открывшемся окне диалога выберите столбец, по которому нужно сортировать таблицу, и укажите режим сортировки (по убыванию или по возрастанию).

Контрольный вопрос 7.3

Где назначаются заголовки элементов диаграммы?

Выберите команду Диаграмма > Параметры диаграммы (Chart > Chart Options). Раскройте вкладку Заголовки (Titles) и введите заголовки в соответствующие поля окна .диалога.

Контрольный вопрос 8.1

Как указать в качестве источника данных существующий файл?

Выберите в разделе Существующий список области задач команду Обзор и выберите в окне диалога Выбор источника данных файл Гостиное.

Контрольный вопрос 8.2

Как перейти к нужной записи?

Введите "номер записи в поле Перейти к записи панели инструментов Слияние и нажмите клавишу Enter.

Контрольный вопрос 8.3

Как быстро выполнить слияние в новый документ? Щелкните на кнопке Слияние в новый документ панели инструментов Слияние.

Контрольный вопрос 9.1

Как быстро добавить вертикальную линию?

Выделите ячейки АЗ—А9. Щелкните в панели инструментов Форматирование на стрелке справа от кнопки Границы и в раскрывшейся палитре щелкните на кнопке правой границы.

Контрольный вопрос 9.2

Как изменить фон ячеек?

Выделите ячейки, фон которых нужно изменить, и выберите в панели инструментов Форматирование в палитре кнопки Цвет заливки красный квадрат.

Контрольный вопрос 9.3

Как посчитать число дней месяца?

Щелкните на ячейке D11. Щелкните на кнопке Изменить формулу. В раскрывающемся списке Формула выберите пункт СЧЕТ. Щелкните в строке формулы и измените текст в скобках на ВЗ : F9. Нажмите клавишу Enter.

Контрольный вопрос 10.1

С помощью какой функции выделяется целая часть числа?

Чтобы получить целую часть числа, введите в ячейку НЗ формулу =ЦЕЛОЕ(СЗ) (=INT(G3)).

Контрольный вопрос 10.2

Как продублировать формулы двух ячеек в нескольких строках?

Щелкните на ячейке G3, нажмите клавишу Shift и щелкните на ячейке НЗ. Протащите маркер правого нижнего угла рамки выделения вниз на 6 ячеек, чтобы рамка охватила диапазон G3:H9.

Контрольный вопрос 10.3

Как задать в качестве аргумента функции две строки листа? Введите формулу =СУММ( 3:4) (=SUM(3:4)).

Контрольный вопрос 10.4

Сумму каких ячеек подсчитывает вставленная формула?

Механизм относительной адресации приведет к изменению ссылок в формуле ячейки F13 в сторону увеличения на 2 строки. В результате в этой ячейке появится формула =СУММ(5:6) (=SUM(5:6)), подсчитывающая сумму чисел пятой и шестой строк листа.

Контрольный вопрос 11.1

Как задать заголовки рядов данных?

Раскройте вкладку Ряд, щелкайте в списке Ряд на каждом ряде данных и вводите в поле Имя текстовое название или ссылку на клетку листа.

Контрольный вопрос 11.2

Как изменить размеры диаграммы?

Чтобы увеличить или уменьшить объект диаграммы, выделите его и перетащите один из угловых или боковых маркеров габаритного контейнера. Для изменения размеров рисунка диаграммы внутри области построения щелкните в пределах рядов данных, выделив элемент Область построения диаграммы, и перетащите угловой маркер появившейся рамки.

Контрольный вопрос 11.3

Как внести диаграмму в список пользовательских типов?

Выберите команду Диаграмма > Тип диаграммы. Раскройте вкладку Нестандартные. Выберите положение переключателя Дополнительные, а затем щелкните на кнопке Добавить. В открывшемся окне диалога введите имя нового типа и его описание. Два раза щелкните на кнопке ОК.

Контрольный вопрос 12.1

Как установить высоту верхнего колонтитула 2 см, а нижнего — 3 см?

Выберите команду Параметры страницы, раскройте вкладку Поля. Введите в счетчик Верхний колонтитул число 2, а в счетчик Нижний колонтитул — число 3. Щелкните на кнопке ОК.

Контрольный вопрос 12.2

Где устанавливается номер первой страницы?

Выберите команду Параметры страницы, раскройте вкладку Страница открывшегося окна диалога. Введите в поле Номер первой страницы число 20 и щелкните на кнопке ОК.

Контрольный вопрос 12.3

Как распечатать лист без столбцов Е и F, не скрывая их?

Выделите столбцы A—D, нажмите клавишу Ctrl и протащите мышь по кнопкам столбцов G—J, добавив их к выделению. Выберите команду Файл > Область печати > Задать.

Контрольный вопрос 13.1

Как удалить слайд в режиме слайдов? Выберите в меню Правка команду Удалить слайд.

Контрольный вопрос 13.2

Как превратить маркированный список в отдельный слайд?

Поместите текстовый курсор в начало первого пункта второго маркированного списка слайда в режиме структуры. Нажмите клавишу Enter. Нажмите клавишу Т. Нажмите клавиши Shift+Tab, чтобы повысить уровень нового пункта до статуса слайда. Введите заголовок нового слайда.

Контрольный вопрос 13.3

Как создать итоговый слайд в режиме сортировщика?

Щелкните на втором слайде. Нажмите клавишу Shift и, не отпуская ее, щелкните на шестом слайде. Щелкните на кнопке Итоговый слайд панели инструментов Сортировщик слайдов. Итоговый слайд займет место непосредственно вслед за первым слайдом.

Контрольный вопрос 14.1

Какая гиперссылка обеспечивает переход на первый слайд?

В окне диалога настройки гиперссылок щелкните на кнопке Место в этом документе и выберите в списке пункт Первый слайд.

Контрольный вопрос 14.2

Как настраивается формат даты?

Выберите команду Вид > Колонтитулы, установите флажок Дата и время/выберите положение переключателя Автообновление и выберите формат отображения даты и времени в одноименном раскрывающемся списке.

Контрольный вопрос 14.3

Как изменить способ размещения блоков?

Выделите блок начальника, щелкнув на нем. На панели инструментов Организационная диаграмма выберите в меню Макет вариант размещения блоков друг над другом: Левосторонний или Правосторонний.

Контрольный вопрос 15.1

Как присоединить презентацию к электронному сообщению?

Выберите команду Файл > Отправить > Вложение в сообщение. В поле Кому открывшегося окна сообщения введите адрес назначения и щелкните на кнопке Отправить панели инструментов.

Контрольный вопрос 15.2

Как изменить качество записи?

Выберите команду Показ слайдов > Звукозапись. Щелкните на кнопке Изменить качество. В раскрывающемся списке Название выберите пункт Радиотрансляция и щелкните на кнопке ОК. Чтобы начать запись, щелкните на кнопке ОК еще раз.

Контрольный вопрос 15.3

Какие режимы следует выбрать в окне параметров слайд-фильма?

Выберите команду Показ слайдов > Настройка презентации. Выберите положение переключателя Управляемый пользователем, установите флажки Непрерывный цикл до нажатия 'Esc' (Loop Continuously Until 'Esc') и Без анимации (Show Without Animation). Сбросьте флажок С полосой прокрутки (Show Scrollbar) и щелкните на кнопке ОК.

Контрольный вопрос 16.1

Какой параметр определяет длину поля?

Чтобы укоротить поле Имя, выделите его в списке конструктора и на вкладке Общие измените значение поля Размер поля.

Контрольный вопрос 16.2

Как запретить добавление пустого поля?

Выберите в списке конструктора поле Фамилия. На вкладке Общие в раскрывающемся списке Обязательное поле выберите пункт Да.

Контрольный вопрос 16.3

Как сделать, чтобы в список подстановки кроме названия метода выводился его кодовый номер?

В четвертом окне мастера подстановки сбросьте флажок Скрыть ключевой столбец (Hide Key Column).

Контрольный вопрос 16.4

Какие операции закрывают базу данных?

Чтобы закрыть базу данных, достаточно закрыть окно базы данных или приложение Access.

Контрольный вопрос 17.1

Как с помощью мастера создать итоговый запрос?

В третьем окне мастера, которое появляется только в том случае, когда первым полем запроса является поле главной из двух связанных таблиц, выберите положение переключателя Итоговый. Затем щелкните на кнопке-Итоги и установите в открывшемся окне диалога флажок Подсчет записей.

Контрольный вопрос 17.2

Какое условие отбора необходимо добавить? В ячейку Или (Or) первого столбца бланка фильтра введите текст «Петров».

Контрольный вопрос 17.3

Как включить режим просмотра SQL?

Режим просмотра SQL позволяет вывести в текстовое окно эквивалент запроса, написанный с помощью языка структурированных запросов SQL. Чтобы включить этот режим, выберите команду Вид > Режим SQL (View > SQL View).

Контрольный вопрос 18.1

Как с помощью мастера отчетов сгруппировать записи по дате?

В списке третьего окна мастера отчетов выберите поле Дата и щелкните на кнопке >.

Контрольный вопрос 18.2

Как назначить обратную алфавитному порядку сортировку по двум полям?

В верхнем раскрывающемся списке четвертого окна мастера выберите пункт Фамилия. Щелкните на кнопке справа от этого списка, чтобы включить сортировку по убыванию. Во втором раскрывающемся списке выберите пункт FirstName, затем щелкните на кнопке, расположенной справа от второго списка.

Контрольный вопрос 18.3

Как быстро убрать рамку всех элементов управления?

Нажатием клавиш Ctrl+A выделите все элементы управления, затем в панели инструментов Форматирование выберите в палитре кнопки Цвет линии/границы (Line/ Border Color) пункт Прозрачный.

Контрольный вопрос 19.1

Как включить указанный режим просмотра?

В области календаря по месяцам поместите указатель на один из дней, нажмите кнопку мыши и протащите указатель по трем соседним числам.

Контрольный вопрос 19.2

Как изменить режим списка задач в календаре?

Щелкните в области списка задач правой кнопкой мыши и выберите один из пунктов подменю Представление панели задач (TaskPad View) контекстного меню.

Контрольный вопрос 19.3

Как быстро перейти к бланку текущего дня? Щелкните на кнопке Сегодня панели инструментов календаря.

Контрольный вопрос 20.1

Как добавить задачу, связанную с определенным контактом ?

Выделите контакт и перетащите его в панель ярлыков на значок Задачи. В открывшемся окне введите параметры задачи и щелкните на кнопке Отправить, чтобы отослать описание задачи своему коллеге.

Контрольный вопрос 20.2

Какие действия нужно предпринять для отправки электронного сообщения?

Щелкните на списке рассылки правой кнопкой мыши, выберите команду Создать сообщение контакту. Введите тему и текст сообщения и щелкните на кнопке Отправить.

Контрольный вопрос 20.3

Какими двумя способами можно открыть дневник?

Для открытия дневника достаточно щелкнуть на его значке в панели ярлыков или выбрать дневник в раскрывающемся списке папок, расположенном ниже панели инструментов.

Контрольный вопрос 21.1

Какими двумя способами можно понизить важность письма?

В окне сообщения щелкните на кнопке Важность: низкая (Importance: Low) .или щелкните в папке Исходящие на строке данного сообщения правой кнопкой мыши, выберите команду Параметры и затем выберите в списке Важность открывшегося окна диалога пункт Низкая (Low).

Контрольный вопрос 21.2

Как упорядочить сообщения по некоторому признаку?

Чтобы упорядочить сообщение по степени важности, щелкните в списке писем на заголовке столбца флага важности, отображаемого в виде восклицательного знака. Щелчком на заголовке другого столбца можно упорядочить сообщения по любому из доступных признаков.

Контрольный вопрос 22.1

Как в окне переходов оставить видимой только одну ветвь web-узла?

Выделите прямоугольник Товары и щелкните на кнопке Просмотреть только поддерево (View Subtree Only).

Контрольный вопрос 22.2

Какими приемами можно открыть web-страницу в режиме просмотра Страница?

Для открытия web-страницы достаточно выполнить одно из следующих действий:

выбрать команду File > Open; дважды щелкнуть на прямоугольнике страницы в окне навигатора; дважды щелкнуть на значке файла с расширением НТМ в режиме просмотра папок или в панели папок другого режима; с помощью команды Запустить задачу контекстного меню активизировать задачу, связанную со страницей; дважды щелкнуть на значке страницы в режиме просмотра гиперссылок.

Контрольный вопрос 22.3

Как изменить статус задачи?

Щелкните на строке задачи правой кнопкой мыши и выберите в контекстном меню команду Пометить как завершенную.

Контрольный вопрос 23.1

Как быстро открыть web-узел, с которым вы недавно работали?

Раскройте меню Файл (File) и выберите название узла (пункт Corporate) в подменю Последние веб-узлы.

Контрольный вопрос 23.2

Как изменить фон ячеек таблицы?

Щелкните в одной из ячеек таблицы, выберите команду Таблица > Свойства > Таблица, в списке 11вет раздела Фон выберите желтый квадрат и щелкните на кнопке ОК.

Контрольный вопрос 23.3

Как настроить текст заголовка окна?

В режиме просмотра Страница выберите команду Файл > Свойства и введите нужный текст в поле Заголовок вкладки Общие.

Контрольный вопрос 24.1

Под каким именем следует сохранять основной HTML-файл, управляющий кадрами?

Основную страницу любого web-узла следует сохранять под именем index.htm и размещать в корневой папке узла.

Контрольный вопрос 24.2

Как следует настраивать ссылки, чтобы страницы узла загружались в нижний кадр?

В окне диалога Create Hyperlink (создание гиперссылки) в поле Адрес: введите имя файла загружаемой страницы, затем щелкните на кнопке Выбор рамки, щелкните в открывшемся окне диалога на нижнем кадре миниатюры страницы. Затем два раза щелкните на кнопках ОК.

Контрольный вопрос 24.3

Какие параметры эффекта следует выбрать?

В списке Выбор события выберите пункт Щелчок (Click), в списке Выбор эффекта — пункт Вылет (Fly Out), а в списке Настройка — пункт Вверх (То Тор).


Введение

Самоучитель по Microsoft Office XP предназначен для тех читателей, которые уже имеют определенный опыт работы с компьютером и хотят познакомиться с возможностями приложений широко распространенного пакета программ компании Microsoft. Эти офисные программы появились много лет назад. Их первые версии были написаны для операционных систем MS-DOS и Windows 3.1. Office XP — это последняя версия популярного пакета, который теперь включает в себя шесть приложений, работающих под управлением операционной системы Windows 95, Windows 98 или Windows NT.

Диск состоит из 24 занятий с несложными упражнениями, описывающими методику исполнения определенных операций. Материал диска не содержит сложных технических подробностей, а ориентирован на начинающего пользователя, стремящегося быстрее научиться решать конкретные задачи с помощью программ Microsoft Office. Каждое упражнение имеет четкую цель и предлагает последовательность шагов, позволяющих решить поставленную задачу. Многочисленные рисунки помогают читателю ориентироваться в графическом интерфейсе Windows и в окнах диалога приложений Office XP.

Этот диск написан на основе русифицированной версии Microsoft Office XP. Однако при описании интерфейса в скобках даются английские названия соответствующих элементов, что поможет пользователям, работающим с английской версией программы.

В первой части диска рассматриваются наиболее распространенные приемы работы в Windows. Здесь же описывается технология взаимодействия приложений Office друг с другом и с операционной системой компьютера, способы запуска приложений, копирование файлов, печать документов и другие распространенные действия.

Часть 2 посвящена широко известному текстовому процессору Word, новая версия которого стала еще более мощной и удобной. Вы научитесь вводить и форматировать текст, оформлять документы с помощью рисунков, добавлять таблицы, распечатывать многостраничные документы, проверять орфографию и грамматику, формировать слияние текста Word с данными таблиц.

Часть 3 описывает методику работы с электронными таблицами Excel. Здесь рассказывается о структуре и назначении листов Excel, о приемах работы с формулами и функциями, обеспечивающими выполнение самых сложных математических операций. Вы научитесь представлять результаты расчетов в виде графиков и диаграмм, распечатывать листы Excel.

На трех занятиях четвертой части изучается приложение PowerPoint, предназначенное для построения презентаций — последовательностей слайдов с материалами доклада. Вы познакомитесь с широкими графическими возможностями этой программы, научитесь пользоваться стандартными шаблонами и создавать свои собственные схемы оформления. На диске рассматриваются приемы построения электронных презентаций, демонстрируемых с помощью компьютерного проектора или в интрасети. Вы также научитесь строить интерактивные слайд-фильмы, управляемые зрителем.

Часть 5 знакомит с профессиональной системой управления базами данных — приложением- Access. Удобный интерфейс, понятные инструменты и приходящие на помощь мастера таблиц, форм и отчетов позволяют строить базы данных в Access даже неискушенным пользователям. Изучив Access немного лучше, вы сможете создавать достаточно сложные структуры данных с несколькими таблицами, расширенными возможностями поиска и сортировки информации.

Программа Outlook, рассматриваемая в упражнениях шестой части диска, представляет собой универсальный организатор ваших документов. Календарь Outlook помогает структурировать рабочее время; дневник и список задач позволяют хранить списки выполненных дел и незавершенных мероприятий. Библиотека контактов Outlook — это прекрасный справочник, в котором могут храниться адреса, телефоны и другая информация о людях и организациях. В Outlook также включен почтовый клиент, обеспечивающий быструю и удобную связь со всем миром посредством Интернета.

Часть 7 посвящена новому компоненту комплекта — web-редактору Frontpage ХР. На занятиях этой части рассматриваются примеры построения web-узлов и редактирования web-страниц. Вы познакомитесь с мастером web-узла и с методикой построения узлов с кадрами. В упражнениях рассматриваются способы организации гиперссылок на различные объекты локального диска компьютера и Интернета. Вы научитесь конструировать на web-страницах таблицы и списки, добавлять динамически изменяющиеся объекты и компоненты Frontpage.

На протяжении всего диска особое внимание отводится вопросам взаимодействия приложений пакета Office ХР друг с другом. В упражнениях рассматриваются многочисленные дополнительные модули пакета, доступные в любой из шести основных программ. Это компоненты построения графиков и диаграмм, библиотека Clip Art, графический модуль WordArt, инструмент создания организационных диаграмм, модуль проверки орфографии и грамматики, а также другие составные элементы пакета.


Соглашения, принятые на диске

Для облегчения восприятия материала-основной текст упражнений организован в виде нумерованного списка шагов. В конце каждого занятия имеется контрольное упражнение. Автор рекомендует читателю самостоятельно выполнить все описанные в нем шаги и ответить на поставленные вопросы. Если вам не удастся сразу решить предложенные задачи, перечитайте материал соответствующего занятия или обратитесь к приложению, расположенному в конце диска и содержащему ответы на все контрольные вопросы.

Наряду с нумерованными списками в тексте упражнений встречаются специальные врезки, концентрирующие внимание читателя на том или ином вопросе.

Врезки Совет содержат описания приемов, логически связанных с основными шагами упражнения, но не вошедших в основной текст.

Примечания содержат техническую информацию по теме упражнения. Эти технические вопросы не связаны напрямую с выполняемой операцией, но они расширяют кругозор читателя и разъясняют смысл происходящего.

Врезки Новое в Office XP содержат описание отличий последней версии пакета Microsoft Office от пакета Microsoft Office 2000.

Для облегчения восприятия материала названия всех элементов интерфейса программ выделены специальным шрифтом. Моноширинным шрифтом отмечен текст, который по сценарию упражнений должен вводиться читателем в поля окон диалога или в текст документов.

Многие операции, описываемые на диске, выполняются с помощью команд меню. Для краткости названия таких команд приводятся в виде, например, File > Open (Файл > Открыть). Стрелка, соединяющая названия пунктов меню, указывает на то, что вы должны сначала щелкнуть на пункте File (Файл) строки меню, а затем выбрать в раскрывшемся подменю команду Open (Открыть).

Многие команды можно выбрать с помощью специальных клавиатурных комбинаций. Использование таких комбинаций значительно ускоряет работу с документами. Если для выполнения определенной операции требуется нажатие нескольких клавиш, то их названия соединяются знаком «+». Так, обозначение Alt+Tab указывает на то, что для выполнения определенной операции нужно нажать клавишу Alt и, не отпуская ее, нажать клавишу Tab. Затем следует отпустить обе клавиши.